TRS管理员使用说明

TRS全文数据库是由北京拓尔思(TRS)信息技术股份有限公司开发的一个体系结构先进、功能强大的面向文本数据的数据库管理系统，广泛地用于各种企业信息数据库、以及企业信息门户的建设。TRS全文数据库的核心技术为全文检索，它为各种格式文档的存储、管理和检索提供动力。 第一次使用TRS全文数据库的用户，请首先了解如下基础知识：

  • 基本概念　： 有关TRS系统中各种对象的概念及其属性的说明
  • 字段与索引： 介绍TRS的各种字段类型、索引类型和索引策略等
  • 权限机制　： TRS的各级权限机制，权限管理和权限检查的规则等
  • 数据加载　： 数据加载的方法以及数据文件和控制文件的格式说明
  • 数据检索　： TRS表达式的语法规则以及运算符、函数、键值等的说明

TRS管理员是TRS全文数据库的一个主要的客户端管理工具，用于对各种TRS对象进行管理、设计和维护等，并具备完整的检索、浏览和维护功能。在上一版本的基础上，又作出了以下几个方面的重大改进：

  • 界面风格焕然一新，提供标签页式多文档管理，新增可浮动的导航和属性面板
  • 新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示
  • 树形管理用户组、用户和数据格式，可筛选所属对象
  • 属性表式管理各种对象属性，可直接修改更新，结构和权限独立出来
  • 采用新的文本方式导入/导出对象，方便修改和将来扩展
  • 支持生成多级导航树，概览增加字段排序和记录标志，细览实现图文混合显示和命中点定位
  • 可自定义表单编辑记录界面，下拉列表提供日期/字符型字段可能值选择
  • 改进了装库控制文件生成和结果报告查看对话框

启动TRS管理员后，将进入TRS管理员的主窗口。TRS管理员主要由以下几个部分组成：

  • 对象管理： 完成各种TRS对象的创建、管理与维护工作
  • 记录维护： 实现对数据库/视图的浏览、检索和维护功能
  • 文件编辑： 生成和编辑各种TRS文件或其他文本文件

TRS管理员工具里还提供了一个独立于TRS管理员以外的仿命令行工具——TRS命令语言，用于输入和执行TRS命令语句。它的操作方法和MS-DOS的命令行工具基本一致，同时增加了一些辅助的界面功能（如检索历史、操作日志、表达式生成器等）以方便用户的使用。 在上一版本的基础上，作了以下几个方面的重大改进：

  • 采用全新的标签页式多文档管理及浮动窗口的主界面
  • 新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示
  • 语句中不同类型词法符号的彩色显示
  • 语句输入过程提供多种提示功能
  • 修改装入记录等语句的进度显示方式，可实现进度百分数等信息不断刷新显示
  • DROP、UPDATE、DELETE等语句增加了提示确认的功能，防止误操作
  • 支持打开多个脚本文件进行编辑，同时还提供了若干新功能

启动TRS命令语言后，将进入TRS命令语言的主窗口。TRS命令语言主要由以下几个部分组成：

  • 输出窗口： 用来显示TRSL语句执行的结果，检索结果的概览和细览
  • 脚本编辑窗口： 用于创建编辑文本文件或者脚本文件

有关命令语言的详细语法请参阅语法参考部分。


系统概览

TRS全文数据库是由北京拓尔思(TRS)信息技术股份有限公司开发的一个体系结构先进、功能强大的面向文本数据的数据库管理系统，广泛地用于各种企业信息数据库、以及企业信息门户的建设。TRS全文数据库服务器的核心技术为全文检索，它为各种格式文档的存储、管理和检索提供动力。它的主要功能和性能如下：

  • “零”空间膨胀率（-0.1至0.2）。
  • 基于成本优化的查询算法(索引分区技术, 多线程并行运算技术，面向全文检索的Cache技术), 使得G级数据库查询速度达到亚秒级，并支持大量并发用户的同时访问。
  • 多线程设计，支持SMP体系结构。
  • 支持跨平台计算：支持NT, Linux, Sun Solaris, IBM AIX, HP-UX。
  • 除了提供规范的C/C++ API外，还提供COM和JavaBeans组件, 可以使用符合工业标准的开发工具进行快速开发(ASP和JSP)。
  • 采用开放的数据存贮管理机制，通过TRS for RDBMS Gateway，可以透明地连接oracle、db2、sql server、sybase和informix五个主流的数据库管理系统。它是电子商务应用中全文检索引擎的最佳解决方案。
  • 领先的中文信息处理技术：内嵌汉语自动分词系统，支持按词索引、按字索引、按关键词索引、二元组索引，大大提高检索的准确性和响应时间。
  • 检索信息快、准而且全：允许使用文中的任意字、词、句和片段进行检索，提供了基于文献内容而不仅仅是文献外部特征的全文检索手段。TRS所提供的按词和按用户自定义关键词进行索引和检索，以及基于知识词典的扩展检索功能，满足了特殊应用领域的高查准率和高查全率的要求。
  • 检索功能强大：全方位检索手段，提供了多达48种检索运算符。包括外部特征与正文内容的各种逻辑组合检索、位置检索、二次检索、渐进检索、历史检索、词根检索、大小写敏感检索、概念检索、对检索结果按与检索表达式的相关性和重要性程度排序等。
  • 安全性好: 具有系统级、数据库级、记录级和字段级四级安全控制机制。


TRS对象

TRS系统中的对象包括：

  • 用户组(GROUP)
  • 用户(USER)
  • 数据库(DATABASE)
  • 数据库字段(BASECOL)
  • 视图(VIEW)
  • 视图字段(VIEWCOL)
  • 词典(DICTIONARY)
  • 数据格式(FORMAT)

所有这些对象都具有一致的命名规则：

  • 只能包括A-Z，a-z，0-9，_，或多字节编码字符(数据格式除外)。
  • 对象名最长为31个字符，且其中英文字母不区分大小写。
  • 除数据格式外，对象名不能是TRS保留字(关键词)。
  • 同一属域内的对象不能重名。
  • 注意：建议不要使用数字开头，尽管这是允许的。


用户组

用户组(GROUP)

TRS具有独立于操作系统的用户组管理机制。用户组的设立，使得系统对数据的安全控制更加完善，也更加简单方便。每个TRS系统可支持多达65535个用户组。

用户组对象具有下列属性：

·名称
名称是TRS用户组对象名，即用户组名。用户组名与用户组名之间，以及用户组名与用户名之间不能重复。

·说明信息
说明信息是对TRS用户组对象进行说明的信息。

系统安装时，将自动创建两个用户组：ADMINISTRATOR和GUEST。系统还有一个匿名用户组。


用户

用户(USER)

TRS具有独立于操作系统的用户管理机制。要访问TRS系统，必须首先申请一个用户帐号。用户帐号是实现系统及数据安全的主要手段，也是系统计费的主要依据。每个TRS系统可支持多达65535个用户。

用户对象具有下列属性：

·用户账号
用户账号是TRS用户对象名，即用户帐号名，也就是用户名。用户名与用户名之间，以及用户名与用户组名之间不能重复。

·用户密码
用户密码是该用户登录到TRS系统时必须输入的口令。设置登录口令的目的主要是为了保证用户帐号的私用性。可以不设置登录口令，否则登录口令中只允许出现字母或数字的ASCII字符。

·密级
密级定义了该用户在TRS系统的接触机密数据的级别。数值越小，级别越高。对于数据库中使用密级加密的数据记录，只有当用户的密级值不大于记录的密级值时，才能看到该记录的内容。0密级是一个特殊密级，表示该用户不能查看任何用密级加密的记录。

·用户类型
用户类型实际上是用户在TRS系统中的权限级别。TRS系统有四种用户类型：
☆ 系统数据库管理员(DBA)
☆ 用户组数据库管理员(GDA)
☆ 系统资源用户(RESOURCE)
☆ 系统登录用户(CONNECT)

·所属用户组
即该用户所在的用户组。用户也可属于匿名用户组。但一个用户只能属于一个组。

·最大检索历史步数
最大检索历史步数是指用户在进行数据库查询时，需要保存的最大检索历史步数。保存的检索历史可以在以后检索中直接引用，而不需要重新检索。

·最大下载记录数
最大下载记录数是指用户在进行数据库查询时，允许一次下载的最大检索结果记录数。但该限制的实现需由具体的应用自己完成。

·缺省附加分词词典
该用户在创建数据库时，如果数据库的附加分词词典指定为缺省值，则系统自动为数据库指定这里所给出的附加分词词典。

·缺省附加停用词典
该用户在创建数据库时，如果数据库的附加停用词典指定为缺省值，则系统自动为数据库指定这里所给出的附加停用词典。

·缺省稀疏词典
该用户在创建数据库时，如果数据库的稀疏词典指定为缺省值，则系统自动为数据库指定这里所给出的稀疏词典。

·说明信息
说明信息是对TRS用户对象进行说明的信息。
·登录互斥开关
登录互斥开关决定该用户是否允许同时从多个不同的IP地址进行登录，但来自本机IP地址的用户登录不计算在内。

系统安装时，将自动创建两个用户：SYSTEM和PUB。

SYSTEM是TRS系统的超级用户，其主要特征有：

  • 是DBA用户。
  • 属于ADMINISTRATOR用户组。
  • 不能被注销。
  • 不能修改名称。
  • 可由自己修改口令。
  • 可创建和注销其它任何用户。
  • 可清除任何用户的口令。
  • 可修改任何用户的除口令以外的任何属性。
  • 可授予或收回任何用户的任何权限。

PUB是TRS系统的一个公共用户，其主要特征有：

  • 是CONNECT用户。
  • 属于GUEST用户组。
  • 不能修改名称。
  • 没有口令，也不允许设置口令。
  • 可被SYSTEM用户注销。
  • 对TRS系统数据对象的操作，必须通过相关的权限检查。

TRS用户还有其它一些特点：

  • 每一个用户组中允许有多个DBA用户。
  • 每一个用户组中允许有多个GDA用户。

任何用户可修改“自己”的如下属性，其它项只能由SYSTEM用户管理：

  • 登录口令
  • 最大检索历史步数
  • 缺省附加分词词典
  • 缺省附加停用词典
  • 缺省稀疏词典
  • 说明信息
  • 登录互斥开关

当一个用户被删除时，该用户所拥有的所有数据库、用户组，以及词典对象的拥有者将改为SYSTEM用户，即这些对象自动归为SYSTEM用户所拥有。


系统数据库管理员用户

系统数据库管理员用户(DBA)

系统数据库管理员所拥有的权限包括：

  • 不经授权就可对系统中的所有数据库、视图，以及词典对象进行所有操作。
  • 蕴涵用户组数据库管理员(GDA)的所有权限。

系统数据库管理员中的SYSTEM用户为超级用户，所拥有的权限包括：

  • 维护系统配置。
  • 创建和注销用户组，维护所有用户组的属性。
  • 创建和注销用户，维护所有用户的属性。
  • 创建数据格式，维护数据格式的属性。
  • 蕴涵系统数据库管理员的所有权限。


用户组数据库管理员用户

用户组数据库管理员用户(GDA)

用户组数据库管理员所拥有的权限包括：

  • 不经授权就可对系统中与该用户处在同一用户组的用户所拥有的所有数据库、视图，以及词典对象进行所有操作。
  • 蕴涵系统资源用户(Resource)的所有权限。


系统资源用户

系统资源用户(RESOURCE)

系统资源用户所拥有的权限包括：

  • 有权在系统中创建数据库、视图，以及词典对象。
  • 蕴涵系统登录用户的所有权限。


系统登录用户

系统登录用户(CONNECT)

系统登录用户所拥有的权限包括：

  • 有权登录到系统中。
  • 不经授权就可对系统中自己所拥有的数据库、视图，以及词典对象进行所有操作。
  • 经过授权，可对系统中其他用户所拥有的数据库、视图，以及词典对象进行相应的操作。


数据库

数据库(DATABASE)

数据库是TRS系统中的主要数据对象，它物理地存储了用户加载到系统中的所有数据资料。每个TRS系统可管理多达数十亿个数据库。

数据库的规模主要指以下两个方面：能够容纳的最大记录数和数据库文件的最大容量。一个数据库的最大记录数取决于操作系统的位数和TRS所采用的文件系统的位数：在32位文件系统中，最多可容纳4亿多条记录，而在64位文件系统中，如果是32位操作系统，则最多可容纳20多亿条记录，如果是64位操作系统，则最多可容纳40多亿条记录。制约数据库文件最大容量的唯一因素是文件系统的位数，如果TRS采用了32位文件系统，则单个文件的大小不能超过2G字节（在Windows平台上不能超过4G字节），但如果采用64位文件系统，则单个文件的容量实际上没有限制。操作系统与文件系统的位数没有必然的联系，许多 32位操作系统都支持64位文件系统，如WIN32、Linux、Solaris等，所以在32位操作系统上，TRS也尽可能地采用64位文件系统。

每个记录的最大长度为256兆字节，每个字段值的最大长度为16兆字节（但以独立，即ALONE方式存储的字段值的长度不受此限制。如果需要并允许压缩，则计算压缩后的字段值长度）。但在实际中，如果一个记录（或字段值）太长，会引起操作系统忙于虚拟内存的交换，使机器性能急剧下降，所以系统人为地限制一个记录的最大长度为物理内存兆字节数的64的倍数（最小为1）兆字节，如物理内存为128兆字节，则允许的最大记录长度为2兆字节。这里的“记录长度”是指集中存储在数据库主文件中的数据块的长度（包含各字段的存储控制信息，以及以集中方式存储的字段值。对于字段值，如果需要并允许压缩，则计算压缩后的字段值长度），或者是各个全文型和二进制型字段中的文本数据的总长度（如果需要并允许压缩，则计算压缩后的数据长度）；“物理内存”是指 TRS系统配置中的值，而不是实际机器所拥有的硬件内存，调节TRS系统配置就可以改变当前系统中一个记录所允许的最大长度，但最大不能超过256兆字节。字段值的最大长度不能调节。

数据库对象具有下列属性：
·名称
名称是TRS数据库的对象名，即数据库名，是访问、维护和管理该数据库的入口。数据库名不能与属于同一用户的其它数据库、视图以及各种词典同名。

·别名列表
别名是该数据库名的别称，一般是为了方便使用而给出的数据库名的缩写，或其英文名称。数据库别名与数据库名具有同等的地位。一个数据库可以定义多个别名。

·拥有者
拥有者表明哪个用户拥有该数据库。拥有者与名称（别名）唯一确定一个数据库对象。拥有者对该数据库能够进行任何操作，而不受其它数据安全控制的制约。

·缺省检索字段
缺省检索字段是指在对该数据库进行查询时，检索表达式中没有明确指定检索目标字段的子表达式所默认的目标字段。在缺省情况下，缺省检索字段也是系统在进行相关性排序的目标字段，如果没有在该字段上进行检索，则就不能进行相关性排序。这个缺省检索字段是系统的默认值，虽然在检索时可以指定一个或多个其它的“缺省检索字段”，但这些“缺省检索字段”与相关性排序没有关系，相关性排序仍然取决于这个缺省检索字段。

·分词词典
分词词典是该数据库按词索引时所引用的词典。如果不为数据库指定分词词典，则该数据库将按字索引。

·附加分词词典
附加分词词典是该数据库按词索引时所引用的扩充词典。

·停用词典
停用词典是该数据库按词索引时所引用的不允许索引的词典。

·附加停用词典
附加停用词典是该数据库按词索引时所引用的不允许索引的扩充词典。

·稀疏词典
稀疏词典是该数据库按词索引时所引用的允许索引的词典。如果不为数据库指定稀疏词典，则该数据库索引所有不属于停用词典和附加停用词典中的词汇。

·公共访问权限
公共访问权限是指TRS系统中所有用户对该数据库所拥有的权限。对数据库可设置的公共访问权限共有五种：
☆ 记录检索权(SELECT)
☆ 数据更新权(UPDATE)
☆ 数据索引权(INDEX)
☆ 数据库结构修改权(ALTER)
☆ 数据库删除权(DROP)

·词根索引开关
词根索引开关决定数据库的短语型和全文型字段数据中的字母单词是否按词根进行索引。如果设置该开关，则索引不区分大小写。

·大小写敏感开关
大小写敏感开关决定数据库的字符型、短语型和全文型字段数据中的字母串是否区分大小写进行索引。

·数字索引开关
数字索引开关决定数据库的短语型和全文型字段数据中的数字是否进行索引。

·二元索引开关
二元索引开关决定数据库的短语型和全文型字段是否建立二元组索引。

·禁止压缩开关
禁止压缩开关决定数据库是否对数据和索引进行压缩。

·使用语言
使用语言是指存储在数据库中的数据所使用的字符集编码。TRS系统支持的字符集有：
☆ 简体中文(GB2312、GBK、GB18030)
☆ 繁体中文(BIG5)
☆ 纯英文(ENGLISH)
☆ 统一码(UTF8)
特别注意：当没有指定系统字符集时，字符集不支持统一码。

·数据宿主系统
有一类应用：TRS系统只管理和维护索引，而数据存储在其它系统中。数据宿主系统就是用来描述存储数据的系统的信息。描述信息对TRS没有实际的意义，如果数据库没有数据宿主系统，则TRS系统负责管理数据库的数据。不存储数据不针对日期型、数值型和字符型字段，因一些特殊应用和性能要求，这三种字段值始终存储。

·存放路径
存放路径指明数据库数据文件的存储目录。

·说明信息
说明信息是对TRS数据库对象进行说明的信息。

在定义数据库时，对每一个属性都必须给出其正确取值。数据库类型始终不允许修改。在数据库加载之前，对数据库的属性可以进行任意修改。在加载了数据后，下列属性不再允许修改：

  • 数据字符集
  • 数据宿主系统
  • 数据存放路径

当创建了索引后，下列属性不再允许修改：

  • 分词词典
  • 附加分词词典
  • 停用词典
  • 附加停用词典
  • 稀疏词典
  • 缺省检索字段
  • 词根索引开关
  • 大小写敏感开关
  • 数字索引开关
  • 二元组索引开关
  • 禁止压缩开关

TRS还支持一种自动分裂数据库，其属性、结构和权限由所属的自动模式视图决定，用户不能修改，但对记录和索引的维护与普通数据库一样。


数据库字段

数据库字段(BASECOL)

数据库字段是TRS系统对不同数据类型进行存储和管理的主要依据，也是对数据库进行查询的唯一入口，所有的查询操作都是在一定的字段上进行的。每个数据库可定义1到1023个字段。

数据库字段对象具有下列属性：
·字段名
字段名是TRS数据库字段的对象名，是访问、维护和管理该数据库字段的入口。字段名不能与同一数据库中的其它字段同名。

·别名列表
别名是该字段名的别称，一般是为了方便使用而给出的字段名的缩写，或其英文名称。字段别名与字段名具有同等的地位。一个字段可以定义多个别名。

·字段类型
字段类型决定了该字段所能存储的数据类型。TRS能够存储和索引六种类型的数据：
☆ 日期型(DATE)
☆ 数值型(NUMBER)
☆ 字符串型(CHAR)
☆ 短语型(PHRASE)
☆ 全文型(DOCUMENT)
☆ 二进制型(BIT)

·缺省取值
缺省取值是指在数据库加载时，对于未给出字段值的DATE、NUMBER或CHAR型字段所对应的缺省取值。DATE型字段的缺省值只支持绝对年份，而不支持缺省世纪数的短格式年份，即总是认为缺省世纪数为0。缺省字段值中只允许指定一个字段值。DATE字段如果取$DATE（不区分大小写）作为缺省值，则表示字段值是记录入库日期的“年月日”部分，如果取$TIME（不区分大小写）作为缺省值，则表示字段值是记录入库日期的“年月日时分秒”；NUMBER字段如果取$CODE（不区分大小写）作为缺省值，则表示字段值是该记录入库时的唯一自然数顺序码，记录之间以加载时间先后为序，自然数顺序码的最大位数与该字段的子类型所能支持的最大十进制整数位数相同；CHAR字段如果取$CODE（不区分大小写）作为缺省值，则表示字段值是该记录入库时的非数字唯一顺序码，记录之间以加载的时间先后为序，如果取$USER（不区分大小写）作为缺省值，则表示字段值是当前进行操作的用户名，当该CHAR字段定义了字段值格式时，其缺省字段值还必须符合这一格式限定。

·格式限定
该属性对于不同的字段类型有不同的意义，限定格式本身不区分大小写：
☆ 对于CHAR型字段，字段值格式是指数据库加载时，给出的字段值所必须遵循的格式。限定格式串首尾不允许出现空格。限定格式的组成规则为，见《TRSDatabase6.doc》1.4节。如果该字段设置了“最大长度”限制，则“限定格式”的长度必须与“最大长度”相一致。一个字段设置了“限定格式”，就意味着每个记录的字段值必须与“限定格式”具有相同的字节长度。
☆ 对于DATE型字段，字段值格式是指输出字段值时使用的格式。目前30多种输出格式，具体输出格式见《TRSDatabase6.doc》1.4节。特别说明：除第一种格式（缺省格式）外，对于其它的所有格式，如果格式包含了“时分秒”，但实际数据缺少其中的一个或两个，则按缺省格式输出；如果格式包含了“年月日”，但实际数据缺少其中的一个或两个，则按缺省格式输出。
☆ 对于NUMBER型字段，字段值格式是指输出字段值时使用的格式。目前支持10种输出格式，具体输出格式见《TRSDatabase6.doc》1.4节。
☆ 对于其他类型的字段，不支持字段值格式。

·取值范围
取值范围是指在加载数据时，DATE、NUMBER或CHAR型字段的合法取值的集合。取值范围的定义格式包括：
☆ 枚举定义：格式为V1,V2,V3,Vn，即枚举该字段上所有可能取值；
☆ 区间定义：格式为V1,…,V2，表示该字段上所有可能取值必须在最小值V1和最大值V2之间；
☆ 混合定义：格式为V1,V2,…,V3,Vn，是以上两种方式的混合。
以上各格式中的逗号和点号都必须是半角符号。CHAR型字段的取值范围所给出的每个值串首尾不允许空格。DATE型字段的取值范围所给出的每个日期中只支持绝对（完全）年份，而不支持缺省世纪数的短格式年份，即总是认为缺省世纪数为0。只有DATE型字段的取值范围支持模糊格式，即允许日期格式中缺省一些成份，但对于区间定义定义的范围，其中的V1和V2“前模糊”的成份必须是相同的，即在“年月日时分秒”的顺序下，V1和V2的第一个确定的日期成份的位置必须是相同的 。对于DATE型字段还必须注意：其日期的书写格式中不要使用逗号‘,’和点号‘.’分隔各成分，以免与“取值范围”本身的表示格式中的逗号和点号发生冲突。如果第一个字符为‘@’，则表示其中存储的是取值范围所在文件的文件名。缺省值为空，表示字段的值没有范围限制。

·显示标签
显示标签是该字段在用户界面上显示的对应名字。

·显示区宽度
显示区宽度是字段值在用户界面上显示区域的缺省宽度单位数。

·显示区高度
显示区高度是字段值在用户界面上显示区域的缺省高度单位数。

·公共查询开关
公共查询开关决定是否允许TRS系统中的所有用户在该字段上进行查询。

·禁止索引开关
禁止索引开关决定该字段是否建立索引。BIT字段始终不建索引。

·允许多值开关
允许多值开关决定在一个记录中该字段是否允许存在多个值。PHRASE和DOCUMENT字段始终不允许多个字段值。

·值唯一性开关
值唯一性开关决定在数据库的所有记录中，该字段（DATE、NUMBER或CHAR型字段）是否允许出现重复的字段值。该开关将自动关闭“禁止索引开关”。

·禁止空值开关
禁止空值开关决定在一个记录中该字段（DATE、NUMBER或CHAR型字段）是否允许没有字段值。

·最大长度或最大精度
该属性对于不同的字段类型有不同的意义：
☆ 对于CHAR型字段，该属性表示单个字段值的最大取值长度，超过规定长度的字符将被忽略，并以不超过最大长度的最后一个完整的数据库字符集编码为截断点。字符串型单个字段值的最大长度是255个字节，0表示没有限制。
☆ 对于NUMBER型字段，该属性表示字段值的小数位精度，同时决定整数位的位数。具体如下：

限定值

说明

0 ~ 6

数据为小数位精度为0到6位的实数。限定值即为小数位的最大精度，超出精度的小数部分被忽略并遵循四舍五入的规则。0表示只取整数部分，直接忽略小数部分。
表示范围是32位二进制单精度浮点数。表示整数时可确保7位十进制有符号整数，即：±9999999，在这个范围之外的整数部分，不能保证精确地表示。

100 ~ 114

数据为小数位精度为0到14位的实数。限定值减100，即为小数位的最大精度，超出精度的小数部分被忽略并遵循四舍五入的规则。100表示只取整数部分，直接忽略小数部分。
表示范围是64位二进制双精度浮点数。表示整数时可确保15位十进制有符号整数，即：±999999999999999，在这个范围之外的整数部分，不能保证精确地表示。

9

表示范围是32位二进制有符号整数。可确保9位十进制有符号整数。即：±999999999。

18 (极个别平台不支持)

表示范围是64位二进制有符号整数。可确保18位十进制有符号整数。即：±999999999999999999。

32

表示范围是32位十进制有符号整数。
表示范围是：±99999999999999999999999999999999。

☆ 对于其他类型的字段，该属性没有意义。

·索引属性
索引属性是指在DOCUMENT字段进行全文检索时，可以用来限定检索的目标词或短语的位置和格式的属性，包括位置索引属性和格式索引属性。位置索引属性是传统的索引属性，包括：
☆ 段落(SEG)
☆ 句子(SEN)
☆ 位置(POS)
对DOCUMENT字段来说，位置索引属性是必须的，在指定索引属性时，可以使用其中之一，或者多个的组合。但格式索引属性则不是必须的。详细说明见《TRSDatabase6.doc》3.4节。

·词根语言
如果数据库指明进行词根索引，则所有的字母文字的单词都要进行词根处理。词根索引语种就是用来指定数据库中字母文字的语种，目前支持12种语言：英语、俄语、法语、西班牙语、葡萄牙语、意大利语、德语、荷兰语、瑞典语、挪威语、丹麦语、芬兰语。显然当一个字段中有多种字母文字时，就无法进行正确的词根处理。如果不指明词根索引语种，则系统将根据字母的种类默认一个语种：拉丁字母默认为英语；西里尔字母默认为俄语。

·混合索引模式
混合索引模式只对具有“按词”索引属性的数据库的PHRASE和DOCUMENT字段有效。字词混合索引可以细分成三部分：只属于“按词”的索引；只属于“按字”的索引；属于“按词”和“按字”的公共索引。混合索引模式是指明其中字词公共索引部分的存储方式，共有四种：
☆ 全冗余模式 将公共部分分别在“按词”和“按字”索引中各存一份。优点是检索时直接取各自的索引即可；缺点是索引空间膨胀大。
☆ 半冗余模式 将公共部分只存储在“按词”的索引中。优点是“按词”检索时可直接取“按词”的索引即可，且索引空间膨小；缺点是“按字”检索时要取“按字”的索引和“按词”的索引进行合并，多一次“或”运算。
☆ 零冗余模式 将公共部分单独存储。优点是索引空间膨小；缺点是“按字”检索时要取“按字”的索引和“按词”的索引进行合并，多一次“或”运算，逻辑上，“按词”检索也多一次“或”运算。
☆ 禁止词模式 这种模式实际不是“混合索引”，而是为了实现在其它未指明混合索引模式的字段“按词”索引的情况下，该字段“按字”索引。
一般地，如果一个字片是“按词”和“按字”的公共部分，则它不可能存在只属于“按词”的索引。因此零冗余模式与半冗余模式的实际效果可能是一样的，没有明显的差别。如果一个PHRASE或DOCUMENT字段未指明任何混合索引模式，则该字段是“按词”，还是“按字”索引，取决于数据库的属性。

·全字索引开关
全字索引开关只有在混合索引模式有效或者数据库按字索引的前提下才有效。如果是全字索引，则“按字”检索能够进行单个字的查询。

·数据缓冲开关
数据缓冲开关决定该字段的“数据”是否【修订015】集中存储，并在“检索缓冲”启动的情况下时，允许进入内存缓冲。虽然所有类型的字段都允许进行缓冲，但DOCUMENT和BIT类型的字段只存储一个标志，表示字段是否有值，而不是存储实际的字段值。

·相关性开关
相关性开关决定检索命中该字段时，该字段是否允许参与相关性排序。除BIT类型的字段外，其它类型的字段都允许参与相关性排序。

·索引存放路径
索引存放路径指明该字段的索引文件的存储目录。

·说明信息
说明信息是对TRS数据库字段对象进行说明的信息。

在定义数据库字段时，对每一个属性都必须给出其正确取值。在数据库加载之前，对数据库字段的属性可以进行任意修改，在加载了数据后，下列属性不再允许修改：

  • 字段类型

  • 多值允许开关

  • 值唯一性开关

  • 空值禁止开关

  • 最大长度或精度

  • 数据缓冲开关

  • 相关性开关

仅针对PHRASE和DOCUMENT类型字段而言，DATE、NUMBER和CHAR类型字段在任何时候都允许修改 。

当创建了索引后，下列属性不再允许修改：

  • 索引存放路径

  • 索引属性，但是如果原来已有格式索引属性，则对格式索引属性的修改有些例外：允许添加新的格式索引属性；允许为格式索引属性添加新的特征；允许添加/修改格式索引属性的别名；允许添加/修改格式索引属性的特征别名。

  • 混合索引模式

  • 全字索引开关

  • 词根索引语种。

除了可定义的字段外，每个数据库都有一个固定的名为DOCID的逻辑字段。该字段的内容是数据库记录的物理记录号，可用来查询数据库记录。一个记录加载到数据库以后就有了一个唯一的物理记录号，除非对该记录的PHRASE或DOCUMENT字段值进行修改，其值将始终保持不变。


视图

视图(VIEW)

视图是TRS系统中的一种辅助数据对象。TRS系统支持对数据库记录和字段进行直接的授权机制来实现数据的安全保密性控制，但有时显得有些烦琐。通过视图来限制某些用户对数据库字段和记录的查询，就可以用一种简便的方式间接地完成对数据库记录和字段查询权的控制。

视图实际上是一个逻辑数据表，它是逻辑地从一个或多个数据库中抽取一个或多个字段并满足指定条件的记录。视图并不物理地存储数据，只是描述了组成该视图的数据所遵循的逻辑。每个TRS系统可管理多达数十亿个视图，每个视图中可包含1到128个数据库。

视图对象具有下列属性：

·名称
名称是TRS视图的对象名，即视图名，是访问、维护和管理该视图的入口。视图名不能与属于同一用户的其它视图、数据库以及各种词典同名。

·别名列表
别名是该视图名的别称，一般是为了方便使用而给出的视图名的缩写，或其英文名称。视图别名与视图名具有同等的地位。一个视图可以定义多个别名。

·拥有者
拥有者表明哪个用户拥有该视图。拥有者与名称（别名）唯一确定一个视图对象。拥有者对该视图能够进行任何操作，而不受其它数据安全控制的制约。

·缺省检索字段
缺省检索字段是指在对该视图进行查询时，检索表达式没有明确指定检索目标字段的子表达式所默认的目标字段。

·公共访问权限
公共访问权限是指TRS系统中所有用户对该视图所拥有的权限。对视图可设置的公共访问权限共有三种：
☆ 记录检索权(SELECT)
☆ 视图结构修改权(ALTER)
☆ 视图删除权(DROP)

·所含数据库
所含数据库是指该视图中所包含的数据库。视图中不能包含视图。

·记录选取条件
记录选取条件实际上是一个对该视图所包含的每个数据库进行检索的检索表达式。记录抽取条件中的检索目标字段（包括缺省的目标字段）动态地对应于该视图所包含的每个数据库中的字段，而不是该视图的字段。如果从多个数据库中选取数据的条件不一致，则可在各个数据库中建立“空字段”（不存储任何数据的字段）进行相互映射，以保证选取条件中的字段在各个数据库中都存在。

·说明信息
说明信息是对TRS视图对象进行说明的信息。

一般情况下，视图只能用于对数据的查询，而不支持对数据的“增、删、改”等操作，但TRS系统支持一种特殊的视图：数据库自动分裂模式视图，简称为自动模式视图。这种视图不但支持对数据记录的维护，而且随着数据记录的增加，能够自动分裂数据库，以维持单个数据库的规模。自动模式视图除了普通视图的三种访问权限外，还具有数据索引权限和数据更新权限的管理。


视图字段

视图字段(VIEWCOL)

视图字段是对视图进行查询的唯一入口，所有的查询操作都是在一定的字段上进行的。每个视图可定义1到1023个字段，每个字段可映射1到64个数据库中的某个字段。

视图字段对象具有下列属性：

·字段名
字段名是TRS视图字段的对象名，即字段名，是访问、维护和管理该视图字段的入口。字段名不能与同一视图中的其它字段同名。

·别名列表
别名是该字段名的别称，一般是为了方便使用而给出的字段名的缩写，或其英文名称。字段别名与字段名具有同等的地位。一个字段可以定义多个别名。

·字段类型
字段类型表明了该字段所映射的数据库字段所存储的数据类型。对应于数据库字段，视图字段也有六种类型：
☆ 日期型(DATE)
☆ 数值型(NUMBER)
☆ 字符串型(CHAR)
☆ 短语型(PHRASE)
☆ 全文型(DOCUMENT)
☆ 二进制型(BIT)

·显示标签
显示标签是上用户界面上该字段的对应名字。

·显示区宽度
显示区宽度是字段值在用户界面上显示区域的缺省宽度单位数。

·显示区高度
显示区高度是字段值在用户界面上显示区域的缺省高度单位数。

·公共查询开关
公共查询开关决定是否允许TRS系统中的所有用户在该字段上进行查询。

·数据库字段映射
数据库字段映射决定了该字段对应于哪些数据库中的哪个字段。

·说明信息
说明信息是对TRS视图字段对象进行说明的信息。


词典

词典(DICTIONARY)

TRS的全文检索不单是一种快速的字串匹配系统，要获得良好的检索效果，必须使用和参照词典。词典对象是TRS系统中非常重要的基础资源，是按词索引和检索技术的根本依据。

词典对象具有下列属性：

·名称
名称是TRS词典的对象名，即词典名，是访问、维护和管理该词典的入口。词典名不能与属于同一用户的其它视图、数据库以及各种词典同名。

·别名列表
别名是该词典名的别称，一般是为了方便使用而给出的词典名的缩写，或其英文名称。词典别名与词典名具有同等的地位。一个词典可以定义多个别名。

·拥有者
拥有者表明哪个用户拥有该词典。拥有者与名称（别名）唯一确定一个词典对象。拥有者对该词典能够进行任何操作，而不受其它数据安全控制的制约。

·类型
按用途划分，TRS系统有八种类型的词典：
☆ 分词词典(SEGMENT)
☆ 附加分词词典(SEGMENTEX)
☆ 停用词典(STOP)
☆ 附加停用词典(STOPEX)
☆ 稀疏词典(SPARSE)
☆ 主题词典(THESAURUS)
☆ 同义词典(SYNONYM)
☆ 反义词典(ANTONYM)
其中，分词词典、附加分词词典、停用词典、附加停用词典和稀疏词典统称为索引词典，主题词典、同义词典和反义词典统称为辅助知识词典。

·公共访问权限
公共访问权限是指TRS系统中所有用户对该词典所拥有的权限。对词典可设置的公共访问权限共有三种（其中引用权总是开放的）：
☆ 检索引用权(SELECT)
☆ 更新维护权(UPDATE)
☆ 删除权(DROP)

·使用语言
使用语言是指该词典语言版本。TRS系统支持的字符集有：
☆ 简体中文(GB2312、GBK、GB18030)
☆ 繁体中文(BIG5)
☆ 纯英文(ENGLISH)
☆ 统一码(UTF8)

·数据存放路径
数据存放路径指明词典数据文件的存储目录。词典创建后，其存储目录任何时候都不允许修改。

·说明信息
说明信息是对TRS词典对象进行说明的信息。

系统安装时，将自动创建系统缺省的分词词典、停用词典、主题词典、同义词典和反义词典。


分词词典

分词词典(SEGMENT)

按词索引和检索是TRS的主要特点之一，内嵌的分词系统采用以词典为基础的分词算法。分词词典用于对表意文字（中文、日文、韩文）自动分词，由若干个词汇组成，词典中由字母和数字组成的词汇不起作用。每部分词词典可容纳多达50万条词汇，每个词汇的最大长度为48个字节。

分词词典由词汇组成，TRS系统提供的缺省分词词典的每个词汇还具有语法属性，以提高分词的准确性。用户定义的分词词典或增加的词汇则没有属性。该词典是经过加密处理的，用户可以浏览词典的词汇，但不能浏览其属性。每部分词词典可容纳多达10万条词汇，每个词汇的最大长度为48个字节。

分词词典的使用要点：

  • 在创建数据库时引用分词词典。分词词典被引用后，一般不允许再对该词典进行维护，除非重新创建数据库的索引。
  • 在一般情况下均使用系统提供的缺省分词词典。
  • 对英文数据库不使用分词词典。
  • 一般不对系统缺省分词词典进行维护，当需要加入用户专业词汇时，可通过创建附加分词词典来实现。
  • 分词词典中的英文词汇不起作用，因此不要在分词词典中加入英文词汇。
  • 生僻词并不一定要加入到分词词典，这些词即使不在词典中，也能检索。

TRS系统提供一个特殊空分词词典，其特殊性在于：系统安装或升级时，该词典将被自动创建，不能进行维护，也不能以其它任何手工方式创建（否则不具有自动创建时的功能）；词典中没有任何词项，当数据库引用该词典时，将按字建立索引，并用来指定“所有的单字都建索引”，以便能够进行单个字的查询。因此也把该词典叫做“全字词典”。


附加分词词典

附加分词词典(SEGMENTEX)

附加分词词典是分词词典的补充。TRS提供的缺省分词词典是一部通用的分词词典，在多数情况下没有包括用户应用的特殊词汇。在这种情况下，一般不是对系统缺省分词词典进行维护，而是通过建立新的附加分词词典来定义新的词汇，系统在自动分词时将同时参考分词词典和附加分词词典中的词汇。

附加分词词典由一系列词汇组成，词典中的英文词汇不起作用。每部附加分词词典可容纳多达5万条词汇，每个词汇的最大长度为48个字节。

附加分词词典的使用要点：

  • 在创建数据库时引用附加分词词典。附加分词词典被引用后，一般不允许再对该词典进行维护，除非重新创建数据库的索引。
  • 在一般情况下均使用系统提供的缺省分词词典。即使在数据库不引用任何附加分词词典，用户应用的特殊词汇也能进行检索。
  • 对英文数据库不使用分词词典。
  • 附加分词词典中由字母和数字组成的词汇不起作用，因此不要在加入这些词汇。
  • 附加分词词典一般包含了某个领域的专业词汇。


停用词典

停用词典(STOP)

停用词典又称为禁用词典，它是由一系列没有检索意义的高频词组成的，如英文文献中的“the”、“of”、“and”、“to”等，中文文献中的“的”、“关于”、“但是”、“而且”等。从相关性方面讲，文献中的这些词没有检索意义，因为这些词会出现在每篇文献中。在检索系统中，通常使用停用词典来过滤掉文献中没有检索意义的词，以最大限度地减少数据库的空间膨胀率、加快查询速度。

停用词典中的词汇可以是中英文标点符号、中英文高频词等。每部停用词典可容纳多达5千条词汇，每个词汇的最大长度为48个字节。

停用词典的使用要点：

  • 在创建数据库时引用停用词典。
  • 一般不对系统缺省停用词典进行维护，当需要过滤更多的无意义词时，可通过创建附加停用词典来实现。
  • 无论是何种语言的数据库，均可引用停用词典。
  • 并不是语言中所有的高频词都需要作为停用词，例如“家”、“世界”是高频词，但对大多数社会科学资料数据库来说，它们可能是重要的词汇。一个词是不是需要作为停用词，与数据库的领域特点有关，如在计算机科学文献中，“计算机”可作为停用词，因为它几乎出现在每一篇文献中，没有检索意义。


附加停用词典

附加停用词典(STOPEX)

附加停用词典是停用词典的补充。TRS提供的缺省停用词典是一部通用的停用词典，不包括特殊领域的无检索意义的词汇。在这种情况下，一般不是对系统缺省停用词典进行维护，而是通过建立新的附加停用词典，并在创建数据库时引用该附加停用词典。

附加停用词典中的词汇可以是标点符号、高频词等。每部附加停用词典可容纳多达5千条词汇，每个词汇的最大长度为48个字节。

附加停用词典的使用要点：

  • 在创建数据库时引用附加停用词典。
  • 无论是何种语言的数据库，均可引用附加停用词典。
  • 附加停用词典一般包含了某个领域的高频词。


稀疏词典

稀疏词典(SPARSE)

在某些应用领域中，用户并不需要进行全文检索，而希望从文献中自动抽取一些词汇作为检索的关键词，也就是说并不需要索引文献中的所有词汇，而只需索引其中一些关键词。稀疏词典就是存储这些关键词汇的词典。

关键词可以是任何词汇，包括由字母和数字组成的词汇。每部稀疏词典可容纳多达5万条词汇，每个词汇的最大长度为48个字节。

稀疏词典的使用要点：

  • 在创建数据库时引用稀疏词典。稀疏词典被引用后，一般不允许再对该词典进行维护，除非重新创建数据库的索引。
  • 稀疏词典一般单独使用。
  • 稀疏词典中的词汇既可以是任何词汇，包括由字母和数字组成的词汇。


主题词典

主题词典(THESAURUS)

主题词典又称为叙词表，它是一种语义词典，由词及其各种关系组成，能反映某学科领域的语义相关概念。TRS系统支持ANSI Thesaurus标准(Z39.19-1980)所规定的所有13种词间关系。这13种关系完全包括了中国《汉语主题词表》的“用、代、属、分、参”结构。

主题词典主要用于检索时的后控制和标引时的自动或辅助选择索引词，是提高查全率和查准率、实现多语种检索和智能化概念检索的的重要途径。在TRS系统中，主题词典是一种特殊的数据库，所以其规模能够达到一般数据库的所能达到的规模。

下表描述了ANSI主题词表的结构：

关系 说明 举例
族首词
(Lead Term) 		概念上外延最广的主题词 “木刻”的族首词是“美术”
上位词
(Broader Term) 		概念上外延较广的主题词 “木刻”的上位词是“版画”
下位词
(Narrower Term) 		概念上内涵更窄的主题词 “木刻”的下位词有“水印木刻”和“套色木刻”
等同词
(Equivalence,Preferred Term) 		也称正式主题词或规范主题词 “电子计算机”是“电脑”的等同词
替代词(用代词)
(Used For,Non-Preferred Term) 		也称非正式主题词或非规范主题词 “电脑”、“计算机”是“电子计算机”的替代词
相关词
(Related Term) 		概念相近但不是等关系的主题词 “计算机应用”和“自动控制”是相关关系
缩略词
(Abbreviation) 		主题词的缩略词 “Database Management System”的缩略词为“DBMS”
被所略词
(Abbreviation For) 		缩略词的正式名称 “DBMS”的正式名称为“Database Management System”
组合概念
(Combined Concepts) 		为将来TRS版本预留
历史注释
(History Note) 		对主题词的历史进行说明
范围注释
(Scope Note) 		对主题词的适用范围进行说明
外文等同词
(Language Equivalent) 		其它语种的等同词 “计算机”的英文等同词是“Computer”
后组配概念
(Post-coordinated Concept) 		为将来TRS版本预留

对应于主题词表的结构，TRS系统定义了相应的函数以引用结构中的各种关系：

函数名 | 含义和作用
BT(主题词[,词典]) | 获得某个主题词的上位词
NT(主题词[,词典]) | 获得某个主题词的下位词
PT(主题词[,词典]) | 获得某个主题词的等同词
UF(主题词[,词典]) | 获得某个主题词的替代词
AB(主题词[,词典]) | 获得某个主题词的缩略词
ABF(主题词[,词典]) | 获得某个缩略词的被缩略词
RT(主题词[,词典]) | 获得某个主题词的相关词
LE(主题词[,词典]) | 获得某个主题词的外文等同词
ALLBT(主题词[,词典]) | 获得某个检索词的所有层次的上位词
ALLNT(主题词[,词典]) | 获得某个检索词的所有层次的下位词

主题词典的使用要点：

  • 通过浏览主题词典进行词汇的交互式选择完成检索。
  • 利用主题词典函数，或自动扩展功能进行多语种和智能化概念检索。此时必须保持词典的字符集必须与所检索的数据库的字符集保持一致，否则无效。

在TRS系统中，主题词典是一种特殊的数据库，其最大规模与一般的数据库相同。主题词典主要用于检索时的后控制和标引时的自动或辅助选择索引词，是提高查全率和查准率、实现多语种检索和智能化概念检索的重要途径。为此TRS系统定义了与主题词关系相对应的函数以使能在检索表达式中引用词典中的各种关系 。


同义词典

同义词典(SYNONYM)

同义词典是对主题词典中替代关系的扩充，以实现范围更大和意义更广的同义词扩展检索，以提高查全率，是TRS系统完成智能化检索的又一种手段。比如：假设在同义词典中“计算机”的同义词为“电脑”，那么在使用该同义词典对“计算机”进行扩展检索时，所有包含“计算机”或“电脑”的文献将被检索出来。

在主题词典中，有一些关系（如替代、缩略等）也具有“同义词”的含义，这些关系与同义词典的区别在于：

  • 主题词典中的主题词及其关系是经过严格控制的，一般不能随意地加以变动。而同义词典则没有这么严格，可以比较随意地进行增加、删除和修改等维护。
  • 主题词典中一般只收录概念词，不收录或很少收录专用名词，如人名、机构名等，这些词应在同义词典中定义。

在TRS系统中，同义词典是一种特殊的数据库，所以其规模能够达到一般数据库的所能达到的规模。同义词典的内部结构非常简单，一般不需要了解。为了便于引用同义词典，TRS系统定义了一个同义词典函数：ST(词汇[,词典])。通过该函数可在指定的同义词典中获取给定词汇的同义词集。

同义词典的使用要点：

  • 通过浏览同义词典进行词汇的交互式选择完成检索。
  • 利用同义词典函数，或自动扩展功能进行智能化概念检索。此时必须保持词典的字符集必须与所检索的数据库的字符集保持一致，否则无效。

下表是与同义词典有关的检索函数：

函数名 | 含义和作用
ST(词汇[,词典]) | 获得某个词的同义词


反义词典

反义词典(ANTONYM)

反义词典主要用来进行反义词的联想检索，也是TRS系统实现智能化检索的手段之一。比如：假设在反义词典中“拥护”的反义词为“反对”，那么在使用该同义词典对“拥护”进行扩展检索时，所有包含“拥护”或“反对”的文献将被检索出来。

在TRS系统中，反义词典是一种特殊的数据库，所以其规模能够达到一般数据库的所能达到的规模。反义词典的内部结构非常简单，一般不需要了解。为了便于引用反义词典，TRS系统定义了一个反义词典函数：AT(词汇[,词典])。通过该函数可在指定的同义词典中获取给定词汇的反义词集。

反义词典的使用要点：

  • 通过浏览反义词典进行词汇的交互式选择完成检索。
  • 利用反义词典函数，或自动扩展功能进行智能化概念检索。此时必须保持词典的字符集必须与所检索的数据库的字符集保持一致，否则无效。

下表是与反义词典有关的检索函数：

函数名 | 含义和作用
AT(词汇[,词典]) | 获得某个词的反义词


其它词典

前面已经分别说明了分词词典、附加分词词典、停用词典、附加停用词典以及稀疏词典等五种索引词典。实际上，在TRS 系统中还有另外三种索引词典，即歧义词典、二元组词典（高频词词典）和单字词典，统称为辅助索引词典。它们是系统的固定资源，具有唯一性，用户不可维护，只能进行系统级的维护

歧义词典是用在按词索引时决定分词歧义串的正确分词方法的词典。歧义词典一旦改变，所有使用按词索引策略的数据库必须重新建立索引。

二元组词典是用来决定哪些字、词（或字串）需要与其前后相邻的字、词（或字串）进行二元组合的词典。对于按词和按字索引，TRS使用不同的二元组词典。当按词二元组词典被改变时，所有使用按词的二元组索引策略的数据库必须重新建立索引。当按字二元组词典被改变时，所有使用按字的二元组索引策略的数据库必须重新建立索引。

单字词典是用来决定按字索引时，哪些字需要单独建立索引的词典。TRS的按字索引，基本上不能把单字作为其索引的入口（键值），但某些字具有单独查询的意义，这些字就存储在单字词典中。单字词典一旦改变，所有使用按字索引策略的数据库必须重新建立索引。如果一个数据库引用了系统中“全字词典”，则单字词典将不起作用。


数据格式

数据格式(FORMAT)

数据格式用来说明多媒体数据的格式类型。在数据库加载时，TRS系统将根据数据格式确定相应的数据存储方式，使用相应的分词方法；在数据输出时，TRS系统将根据数据格式对数据进行相应的处理，便于浏览。每个TRS系统可管理多达1023个数据格式对象。

数据格式对象具有下列属性：

·格式名称
格式名称是TRS数据格式的对象名，即数据格式名，是访问、维护和管理该数据格式的入口。数据格式名不能重复，并且只能由英文字母和数字组成。

·所属分类
即该数据格式属于哪种格式类型。TRS系统把数据格式划分成六种类型：
☆ 纯文本(TEXT)
☆ 格式文档(DOC)
☆ 图像(IMAGE)
☆ 音频(AUDIO)
☆ 视频(VIDEO)
☆ 自定义(BIT)

·文件后缀
文件后缀是指该数据格式的数据文件通常使用的文件名后缀，只能由英文字母和数字组成。

·压缩开关
压缩开关决定该数据格式的数据是否需要进行无损压缩。

·说明信息
说明信息是对数据格式对象进行说明的信息。

TRS系统在安装时，将自动创建下列数据格式对象(名称)：

  • BIT（不确定格式的二进制数据）
  • TEXT（文本数据格式）
  • WORD（Microsoft Word数据格式）
  • WS（WordStar数据格式）
  • WP（WordProfect数据格式）
  • XCL（Microsoft Excel数据格式）
  • WPS（金山WPS数据格式）
  • S2（方正、华光二扫数据格式）
  • DOC（不确定格式的文档数据格式）
  • AUDIO（不确定格式的音频数据格式）
  • IMAGE（通用图像数据格式）
  • VIDEO（不确定格式的视频数据格式）
  • AVI（AVI动画数据格式）
  • MPEG（MPEG压缩动画数据格式）
  • WAVE（Wave音频数据格式）
  • MIDI（MIDI音频数据格式）
  • CDA（CD音频数据格式）
  • PS（PostScript数据格式）
  • GIF（GIF图像数据格式）
  • TIF（TIF图像数据格式）
  • PCX（PCX图像数据格式）
  • BMP（BMP图像数据格式）
  • JPEG（JPEG图像数据格式）
  • HTML（HTML超文本数据格式）
  • PDF（Adobe PDF数据格式）
  • PPT（Microsoft Power Point数据格式）
  • RTF（Rich Text数据格式）
  • XML（XML数据格式）
  • MP3（MP3数据格式）

TRS系统允许用户自己定义新的数据格式，或者修改已有的数据格式。数据格式一旦定义，就不允许删除，所以必须谨慎对待。只有 SYSTEM 用户有权创建新的数据格式。


字段与索引

TRS数据库有以下6种不同类型的字段：

  • 日期型字段(DATE)
  • 数值型字段(NUMBER)
  • 字符串型字段(CHAR)
  • 短语型字段(PHRASE)
  • 全文型字段(DOCUMENT)
  • 二进制型字段(BIT)

索引是为实现快速检索的基础，所有对数据库的查询操作都是在相应的数据库索引上进行的。在TRS系统中，作为检索入口的数据库字段必须建立一定的索引，否则该字段上的值不能被检索。用户可以根据实际需要选择不同的索引策略。


日期型字段

日期型字段(DATE)

日期型字段只能用来存储“年月日时分秒”这类表示日期的数据。这类字段的主要特点是：

  • 允许设置缺省值。
  • 允许限制取值范围。
  • 允许多值。
  • 允许加载时字段值的唯一性检查。
  • 允许加载时空值的检查。
  • 允许建立索引。
  • 不支持倒排索引属性。
  • 字段值必须是一个有效的日期。
  • 数据集中存储。
  • 支持对字段值的排序。


数值型字段

数值型字段(NUMBER)

数值型字段只能用来存储整数或实数。对于实数，可以限制其小数位的长度，在数据库加载时将忽略多余的小数位数。整数或实数不能超出机器的单精度浮点数所能表示的范围，可以使用科学计数法表示这些数据。这类字段的主要特点是：

  • 允许设置小数位的精度。
  • 允许设置缺省值。
  • 允许限制取值范围。
  • 允许多值。
  • 允许加载时字段值的唯一性检查。
  • 允许加载时空值的检查。
  • 允许建立索引。
  • 不支持倒排索引属性。
  • 字段值必须是一个有效的整数或实数。
  • 数据集中存储。
  • 支持对字段值的排序和统计运算。


字符串型字段

字符串型字段(CHAR)

字符串型字段可以用来存储任何形式的字符串。字符串的最大长度可以在建库时指定，但最大不能超过255个字符，在数据库加载时将截断超过规定长度的字符串，而只保留字符串的前部。这类字段的主要特点是：

  • 允许设置字符串的最大长度。
  • 允许设置缺省值。
  • 允许限制取值范围。
  • 允许多值。
  • 允许加载时字段值的唯一性检查。
  • 允许加载时空值的检查。
  • 允许建立索引。
  • 不支持倒排索引属性。
  • 字段值是一个长度不超过255个字符的任意字符串。
  • 数据集中存储。
  • 支持对字段值的排序。如果是多值，则只对第一个字段值进行排序。


短语型字段

短语型字段(PHRASE)

短语型字段可以用来存储任何形式、任意长度的文本数据，最适合作为“标题”这样的字段。短语型字段与字符串型字段的最大差别在于短语型字段支持自动分词，而字符串型字段不支持自动分词，其字段值整体是一个索引键值。这类字段的主要特点是：

  • 没有长度限制。
  • 没有缺省值。
  • 没有取值范围。
  • 不允许多值。
  • 加载时不进行字段值的唯一性检查。
  • 加载时允许空值。
  • 允许建立索引。
  • 支持自动分词，倒排索引属性固定（只有位置索引属性中“位置”）。
  • 字段值必须是文本数据。
  • 数据集中存储。
  • 支持对字段值的排序。进行排序时，只有字段值的前256个字符是有效的。


全文型字段

全文型字段(DOCUMENT)

全文型字段既可以用来存储任何形式、任意长度的文本数据，也可以用来存储其它格式类型的多媒体数据。全文型字段区别于短语型字段的关键所在有四点：

  • 全文型字段的数据有多种存储方式。系统通常是集中存储短语型字段的数据，而分类存储全文型字段的数据，这样有助于提高大规模数据库的检索结果的概览速度（概览不包括全文型字段和二进制型字段的内容）。
  • 全文型字段的字段值可以附加一个源格式数据。
  • 全文型字段的倒排索引属性可以任意指定。
  • 全文型字段不支持对字段值的排序。

综合起来，这类字段的主要特点是：

  • 没有长度限制。
  • 没有缺省值。
  • 没有取值范围。
  • 不允许多值，但允许附加一个源格式数据。
  • 加载时不进行字段值的唯一性检查。
  • 加载时允许空值。
  • 允许建立索引。
  • 支持自动分词，倒排索引属性可任意定义。
  • 字段值可以是多媒体数据。
  • 数据有多种存储方式。


二进制型字段

二进制型字段(BIT)

二进制型字段可以用来存储任何格式类型的多媒体数据，主要特点是：

  • 没有长度限制。
  • 没有缺省值。
  • 没有取值范围。
  • 允许多值。
  • 加载时不进行字段值的唯一性检查。
  • 加载时允许空值。
  • 不建立索引。
  • 字段值可以是任何多媒体数据。
  • 数据有多种存储方式。


索引类型

TRS系统有两种类型的数据库索引：B+树索引和倒排(INVERT)索引。这两种类型的索引相辅相成，互为补充。

B+树索引的突出特点是很好地解决了键值的插入、溢出、删除和空间回收等问题，从而使B+树索引可以适应成批插入、文件易变的情况；B+树索引在操作中可“动态地”进行维护，无须周期性地重新组织文件；还可以采用压缩索引项的办法，提高扇出率，降低树的高度，减少读取次数，加快查找速度。因此B+树索引是组织大型索引文件的一种最主要的方法。

B+树索引实现了索引键值的唯一化，即一个键值在B+树索引中只有一个唯一的入口，而倒排索引则用来存储索引键值在同一个记录和不同记录中出现的情况。倒排索引的建立大大提高了重复键值的查询速度和空间使用率，同时也简化了B+树索引的维护操作。

倒排索引由一系列倒排索引项组成，每个倒排索引项又可包含多个倒排索引属性，但不同的字段类型，所支持的倒排索引属性也不尽相同：

  • DATE、NUMBER和CHAR字段不支持任何倒排索引属性。
  • PHRASE字段上所支持的倒排索引属性是固定的，由系统自动定义。
  • DOCUMENT字段上的倒排索引属性则可在创建数据库时根据实际需要由用户自行定义。


索引策略

对于字母文字，TRS系统总是按“单词”进行索引，但对于表意文字（中文、日文、韩文）TRS系统则有四种类型的索引策略：按词检索的索引策略、按字检索的索引策略、按用户自定义关键词的索引策略，以及二元组索引策略。在实际应用中，采用何种索引策略主要取决于数据的特点、检索的需求和系统的资源等。

不同的索引策略，所需的索引词典也不尽相同。下面是索引策略与索引词典的引用关系：

策略

稀疏词典

分词词典

附加分词词典

停用词典

附加停用词典

按词

置空

必需

可有可无

可有可无

可有可无

按字

置空

置空

可有可无

可有可无

可有可无

按关键词

必需

忽略

忽略

忽略

忽略

二元组

置空

可有可无

可有可无

可有可无

可有可无


按词索引策略

TRS内嵌的汉语自动分词系统是TRS的领先技术，使得TRS在国内外同类全文检索系统中独具特色。对大多数中文全文检索应用来说，按词索引是首选的索引策略。

按词索引策略的优越性在于：

  • 检索的准确率即查准率高。如果采用按词索引策略，则在检索“华人”时，仅包含“中华人民共和国”的记录不会被检索出来。
  • 查询的速度快。测试表明，在大型数据库上，按词索引的查询速度要比按字索引（不进行二元索引）的查询速度快5-10倍。
  • 空间膨胀率低。由于一个词往往包含了多个字，这样按词索引就大大减少了索引量，再加上停用词典的使用，索引文件的空间膨胀率比按字索引的小50-100%。
  • 按词索引是实现智能化概念检索的基础。由于所有辅助知识词典（如主题词典、同义词典、反义词典等）都是基于词的，而不是基于字的，所以只有按词索引，才能进行概念检索。

按词索引策略的不足在于：

  • 词典维护后数据库一般需要重新进行索引。
  • 由于中文词与词之间没有语法上的分隔符，自动分词难免有误，对检索也会有一定的负面影响。但在相同的语境中，“以错对错”的特性将会自动消除这种影响。

使用按词索引策略的方法是：为数据库指定相应的分词词典（全字词典除外）、附加分词词典，或者一部稀疏词典。


按字索引策略

如果数据是文言文或数据库规模很小，可采用按字索引策略。按字索引策略的主要优点是：

  • 不需要自动分词系统，实现相对简单。
  • 没有自动分词的错误，查全率较高。

然而，按字索引策略的不足也是显易而见的，按词索引策略的所有优点均是按字索引策略的致命缺点所以除非需要百分之百的查全率，而不惜牺牲查准率，一般情况下不使用按字索引策略。由于传统意义上的按字索引策略的查询速度太慢，这里的按字索引实际上是一种二元组索引 。

使用“不需要检索单字”的按字索引策略的方法是：
方法1. 数据库不指定任何分词词典、附加分词词典和稀疏词典。
方法2. 在数据库使用按词索引策略的前提下，将需要按字索引的字段的混合索引模式指定为“禁止词模式”。

使用“允许检索单字”的按字索引策略的方法是：
方法1. 为数据库指定分词词典为全字词典。
方法2.在数据库使用按词索引策略的前提下，将需要按字索引的字段的混合索引模式指定为“禁止词模式”，并开启该字段的全字索引开关。


按关键词索引策略

按关键词索引实际上是一种抽词索引技术，是在按词索引策略的基础上只抽取其中的某些词进行索引。所有需要索引的关键词构成一部稀疏词典。一般对专用领域的文献可采用这种索引策略。

按关键词索引策略兼有按词索引策略的优点，并且具有更低的空间膨胀率和更快的检索速度。但由于按关键词索引策略只对“关键词”进行了索引，这样就不能象按词索引策略那样可以用任意的自由词进行全文检索，而只能对“关键词”进行检索。


二元组索引策略

二元组索引策略是指在按词索引时对高频词进行二元组合，或者在按字索引时对高频字串进行二元组合。有分词词典或附加分词词典的二元组索引称为按词二元组索引；反之，如果既没有分词词典，也没有附加分词词典，则称为按字二元组索引。由此可见二元组索引策略并不是一种独立的索引策略，它是按词索引策略和按字索引策略的扩展。二元组索引还依赖于二元组词典（高频词词典），不同的数据库语言对应不同字符集的词典，如果数据库语言与系统主字符集集不一致，则必须通过一次与数据库语言一致的系统升级来自动创建所需要的词典。

二元组索引策略的最大优势是在大数据库中对含有高频词（字串）的短语的查询时，速度有显著提高。但这种索引策略的缺点也同样明显：一是空间膨胀率较高，尤其是对于小数据库；二是装库速度要比单独的按词或按字索引策略慢得多。所以对于小规模数据库，在没有二元组索引的情况下，其查询速度也很快，完全没有必要使用这种索引策略。

特别地，按字二元组索引有两个级别：字之间的二元组索引（一级二元索引）和高频字串（即一级二元组）与字之间的二元组索引（二级二元索引，实际上是三元索引，但由于不是所有的字都进行三元索引，所以这里只把它看成是二元索引的一种优化扩展）。第一级按字二元组索引策略就是按字索引策略（因此，并不是所有的字都能单独查询，如果需要能够检索所有的单字，可以给数据库指定系统中的“所有汉字词典”作为分词词典），而这里所说的按字二元组索引就是指第二级按字二元组索引策略。二元组索引策略的选择不是通过词典的选取来决定的，而是通过数据库的二元组索引开关来决定的。


索引属性

在创建数据库时，可以为一个DOCUMENT字段定义索引属性。索引属性分为两类，即：位置索引属性和格式索引属性。如果索引属性中包含了格式索引属性，则此种索引就称之为全息索引。


位置索引属性

位置索引属性是TRS的传统索引属性，用来标明一个索引项在文本数据中的自然位置，通常包括：所在的段落；所在段落中的句子；所在句子中的位置。位置索引属性隐含在文本中，不需要显式的标注，是通过分词系统自动提取的。

位置索引属性的目的之一就是位置限定运算，如在检索“国际大师”时，“国际艺术大师”中“国际”与“大师”不会命中，因为这里隐含了“国际”与“大师”在位置上必须相邻的限定要求。这只是其中的一种隐式的位置限定运算，位置限定运算还可以通过相关的运算符显式地指定（见《数据库检索》的1.2节）。位置索引属性的另一个目的是为检索结果提供准确的命中点。

TRS系统只支持三种位置索引属性，即：SEG（段落）、SEN（句子）和POS（位置）。“段落”的提取规则是：换行符后面如果还是换行符，或者是空白符，则认为是一个段落的结束；“句子” 的提取规则是：当遇到“句号”、“逗号”、“分号”、“问号”或者“叹号”时，认为是一个句子的结束。“位置”的提取规则是：一个表意字符占一个位置；一个字母单词占一个位置；一个数字串占一个位置；所有的空白符被忽略；其它符号占一个位置。

在位置索引属性中，除POS外，SEG和SEN都不是必须的，这样可能的组合有：<SEG，SEN，POS>、<SEG，POS>、<SEN，POS>和<POS>。在存储的索引中，SEG、SEN和POS都用两个字节表示，对于前三种组合基本足够，但在只有POS属性的情况下，对于超长文本则会丢失一些索引信息，从而导致漏检，因此增加一种位置属性POS4，表示“位置”用四字节存储，但POS4与SEG或SEN组合时等价于POS。

必须特别注意的是：对于一些不规则的文本，一个“字片”可能会被“段落”规则所打断，无论是采用按“词”索引还是采用按“字”索引，都无法检索到，从而影响查全率。要使这样的“字片”也能够检索到，其唯一方法是位置索引属性不包含SEG和SEN。当没有定义SEG索引属性时，如果定义了SEN索引属性，则“段落”的结束将按“句子”的结束处理，如果SEN索引属性也没有定义，则“段落”的结束将被按空白处理。


格式索引属性

格式索引属性是用来标明一个索引项在格式文本中除位置索引属性外的其它所有属性。格式索引属性对纯文本没有意义，必须进行显式地标注，也就是说格式索引属性只对格式化的文档有用，如：XML、HTML、RTF 格式等。

格式索引属性的唯一目的就是在检索时用来限定检索目标，以保证所命中的检索结果能够满足用户对检索目标所具有的格式要求。

与位置索引属性的提取需要分词系统一样，格式索引属性的提取也需要有相应格式文档的分析器，如：对 XML文档，需要XML分析器；对RTF文档，需要RTF分析器。目前系统只提供了XML和HTML分析器，因此TRS只支持对XML和HTML 文档进行全息索引。


权限机制

TRS系统的安全控制是通过权限管理来实现的。TRS系统的权限有四个级别，即：用户级权限、数据库级权限、字段级权限和记录级权限。

对TRS系统中的用户组操作、用户操作、数据库操作、数据库字段操作、视图操作、视图字段操作、词典操作和数据格式操作都必须有相应的权限才能进行。


用户级权限

用户级权限对应于用户的类型。TRS系统有五种类型的用户级权限：

  • 超级用户(SYSTEM)。
  • 数据库管理员(DBA)。
  • 用户组管理员(GDA)。
  • 资源用户(RESOURCE)。
  • 登录用户(CONNECT)。

超级用户所拥有的权限包括：

  • 维护系统配置。
  • 创建和注销用户组，维护所有用户组的属性。
  • 创建和注销用户，维护所有用户的属性。
  • 创建数据格式，维护数据格式的属性。
  • 蕴涵系统数据库管理员的所有权限。

系统数据库管理员所拥有的权限包括：

  • 不经授权就可对系统中的所有数据库、视图，以及词典对象进行所有操作。
  • 蕴涵用户组数据库管理员的所有权限。

用户组数据库管理员所拥有的权限包括：

  • 不经授权就可对系统中与该用户处在同一用户组的用户所拥有的所有数据库、视图，以及词典对象进行所有操作。
  • 蕴涵资源用户的所有权限。

系统资源用户所拥有的权限包括：

  • 有权在系统中创建数据库、视图，以及词典对象。
  • 蕴涵系统登录用户的所有权限。

系统登录用户所拥有的权限包括：

  • 有权登录到系统中。
  • 不经授权就可对系统中自己所拥有的数据库、视图，以及词典对象进行所有操作。
  • 经过授权，可对系统中其他用户所拥有的数据库、视图，以及词典对象进行相应的操作。


数据库级权限

数据库权限、视图权限和词典权限统称数据库级权限。

数据库权限共有五种：

  • 记录检索权(SELECT)。拥有这种权限的用户，能够对数据库进行检索操作。
  • 数据更新权(UPDATE)。拥有这种权限的用户，能够对数据库进行数据库加载、记录插入、删除和修改操作。
  • 数据索引权(INDEX)。拥有这种权限的用户，能够对数据库的索引进行创建、删除、验证和优化操作。
  • 数据库结构修改权(ALTER)。拥有这种权限的用户，能够对数据库的属性及结构进行修改操作，包括增加和删除字段，以及修改字段的属性。
  • 数据库删除权(DROP)。拥有这种权限的用户，能够删除数据库。

这五种数据库权限的蕴涵关系是：ALTER和DROP蕴涵INDEX，INDEX蕴涵UPDATE，UPDATE蕴涵SELECT。当收回被蕴涵的权限时，系统将自动收回蕴涵该权限的所有权限，如收回SELECT权限，则实际将收回所有可能的权限。需要特别说明的是：虽然数据库属性中的公共访问权限也有这种蕴涵关系，但去掉其中的某个公共访问权限时，不会自动去掉蕴涵该公共访问权限的公共访问权限。

非自动模式视图权限共有三种（自动模式视图权限和数据库一样）：

  • 记录检索权(SELECT)。拥有这种权限的用户，能够对视图进行检索操作。
  • 视图结构修改权(ALTER)。拥有这种权限的用户，能够对视图的属性及结构进行修改操作，包括增加和删除字段，以及修改字段的属性。
  • 视图删除权(DROP)。拥有这种权限的用户，能够删除视图。

这三种视图权限的蕴涵关系是：ALTER和DROP蕴涵SELECT。当收回SELECT权限时，系统将自动收回所有可能的权限。需要特别说明的是：虽然视图属性中的公共访问权限也有这种蕴涵关系，但去掉其中的某个公共访问权限时，不会自动去掉蕴涵该公共访问权限的公共访问权限。

词典权限共有三种：

  • 检索引用权(SELECT)。拥有这种权限的用户，能够对词典进行浏览操作，能够在创建数据库或检索时引用词典。该权限对所有用户总是开放的。
  • 更新维护权(UPDATE)。拥有这种权限的用户，能够对词典进行维护操作，包括增加和删除词汇。
  • 删除权(DROP)。拥有这种权限的用户，能够删除词典。

这三种词典权限的蕴涵关系是： DROP蕴涵UPDATE，UPDATE蕴涵SELECT。当收回被蕴涵的权限时，系统将自动收回蕴涵该权限的所有权限，如收回SELECT权限，则实际将收回所有可能的权限。需要特别说明的是：虽然词典属性中的公共访问权限也有这种蕴涵关系，但去掉其中的某个公共访问权限时，不会自动去掉蕴涵该公共访问权限的公共访问权限。


字段级权限

字段级权限包括数据库字段权限和视图字段权限。字段级权限只有一种，即：字段检索权(SELECT)，拥有这种权限的用户，能够在该字段上进行检索操作。


记录级权限

TRS系统中的记录级权限是虚拟权限或逻辑权限，是实际不存在的。记录级权限有两种形式，即：记录检索权和记录浏览权，分别通过视图和对记录进行加密来实现。数据库和无“记录选取条件”视图中的记录的检索权是不受限制的，记录的检索权只能控制该记录不能被检索，而不能控制记录能被检索。记录的浏览权只控制检索到该记录的用户是否有权浏览其内容，而不能控制用户能否检索到该记录。

用视图实现记录级权限的方法如下：

  • 在数据库中确定一个能够分类记录的字段。如果没有这样的字段，则在创建数据库时必须增加一个辅助字段，用以分类记录，并在数据库加载时给出记录的分类值。
  • 按记录的分类值，创建一系列视图，每个视图的“记录选取条件”属性是记录分类的检索表达式。
  • 将这些视图或其字段的记录检索权分别授予相应的用户或用户组，同时收回这些用户和用户组在数据库和其字段上的所有权限。

TRS系统对记录有三种加密方式，即：

  • 密级。用密级加密的记录，只有当用户的密级值不大于记录的密级值时才允许输出。但用户的密级如果是0，则也不允许输出记录。
  • 用户组。用用户组加密的记录，只有当用户所在的用户组是记录所要求的用户组时才允许输出。当该用户组被删除后，加密还是有效，但原用户组中普通用户已无法输出记录，除非更新记录取消用户组加密。
  • 口令。用口令加密的记录，只有当用户提供了正确的口令时才允许输出。

这三种加密方式可组合使用，这时必须满足每种方式的所有条件才允许输出记录。加密方式是在数据库加载、记录插入和记录更新时，与数据一起指定的。

需要说明的是：对记录的加密只有在读取数据库记录时才会起作用，并且根据TRS系统的权限管理规则，还必须满足下列所有条件：

  • 当前用户不是超级用户。

  • 当前用户没有DBA权。

  • 当前用户不是数据库的拥有者。

  • 当前用户没有数据库拥有者所在用户组的GDA权。

  • 数据库没有PUBLIC检索属性。

    •


权限管理

权限管理包括权限授予和收回权限两方面的操作。权限授予是指改变用户级权限，或在数据库、视图、词典和字段上授予用户或用户组一定的操作权限。收回权限是指改变用户级权限，或收回用户或用户组在数据库、视图、词典和字段上的操作权限。权限的授予与收回不能管理记录级权限。

用户级权限的授予与收回：

  • 只有超级用户才能改变用户级权限。

数据库级权限的授予与收回：

  • 超级用户和DBA用户可管理系统中所有数据库、视图和词典的操作权限。
  • GDA用户可管理该用户组的用户所拥有的所有数据库、视图和词典的操作权限。
  • 任何用户可管理自己所拥有的数据库、视图和词典的操作权限。

字段级权限的授予与收回：

  • 超级用户和DBA用户可管理系统中所有数据库和视图的字段的操作权限。
  • GDA用户可管理该用户组的用户所拥有的所有数据库和视图的字段的操作权限。
  • 任何用户可管理自己所拥有的数据库和视图的字段的操作权限。


用户组操作

只有超级用户有权创建、删除和修改用户组。

当删除一个用户组时，该用户组下的所有用户将自动迁移到系统的匿名用户组，并同时删除与该用户组有关的所有权限。


用户操作

只有超级用户有权创建、删除和修改用户。另外，用户“自己”也可修改一些基本属性：

  • 登录口令（超级用户只能删除用户的口令，而不能修改）
  • 登录互斥开关
  • 最大检索历史步数
  • 缺省附加分词词典
  • 缺省附加停用词典
  • 缺省稀疏词典
  • 注释信息

当删除一个用户时，该用户所拥有的所有数据库、视图，以及词典对象的拥有者将自动归为SYSTEM用户所拥有，并同时删除与该用户有关的所有权限。


数据库操作

创建数据库及恢复数据库。如果满足下列条件之一，则有权创建数据库：

  • 超级用户。
  • DBA用户。
  • GDA用户。
  • RESOURCE用户。

删除数据库。如果满足下列条件之一，则有权删除数据库：

  • 超级用户。
  • DBA用户。
  • 数据库的拥有者。
  • 数据库具有公共DROP属性。
  • 数据库拥有者所在用户组的GDA用户。
  • 拥有该数据库的DROP权的用户。

当删除一个数据库时，系统将删除所有用户在该数据库上的权限，同时自动修改映射到该数据库的所有视图的结构，如果这时视图中不再包含任何数据库，则系统将自动删除该视图。

修改数据库、锁定数据库及转成自动模式视图。如果满足下列条件之一，则有权修改数据库或锁定数据库或转成自动模式视图：

  • 超级用户。
  • DBA用户。
  • 数据库拥有者所在用户组的GDA用户。
  • 数据库的拥有者。并且对于转成自动模式视图的操作，当前用户还必须具有创建视图的权限。
  • 数据库具有公共ALTER属性。并且对于转成自动模式视图的操作，当前用户还必须具有创建视图的权限。
  • 拥有该数据库的ALTER权的用户。并且对于转成自动模式视图的操作，当前用户还必须具有创建视图的权限。

当删除一个数据库字段时，系统将删除所有用户在该数据库字段上的权限，同时自动修改映射到该数据库字段的所有视图的字段结构，如果这时视图字段中不再包含任何数据库字段，则系统将自动删除该视图字段，当视图中不再包含任何字段时，也将被自动删除。

解锁数据库。如果满足下列条件之一，则有权解锁数据库：

  • 超级用户。
  • DBA用户。
  • 数据库拥有者所在用户组的GDA用户。
  • 数据库锁的拥有者，并且数据库具有公共ALTER属性或者操作者拥有该数据库的ALTER权。

但如果一个数据库被“拒绝访问锁”锁定，则任何用户都不能解锁，只能由系统内部自动解除，或者重新启动系统。

备份数据库。如果满足下列条件之一，则有权备份数据库：

  • 超级用户。
  • DBA用户。
  • 数据库的拥有者。
  • 数据库拥有者所在用户组的GDA用户。

维护数据库索引及优化数据库。如果满足下列条件之一，则有权维护数据库索引或优化数据库：

  • 超级用户。
  • DBA用户。
  • 数据库的拥有者。
  • 数据库具有公共INDEX属性。
  • 数据库拥有者所在用户组的GDA用户。
  • 拥有该数据库的INDEX或ALTER或DROP权的用户。

维护数据库记录（数据库作为加载、插入、删除、修改和复制记录的目标数据库）。如果满足下列条件之一，则有权维护数据库记录：

  • 超级用户。
  • DBA用户。
  • 数据库的拥有者。
  • 数据库具有公共UPDATE属性。
  • 数据库拥有者所在用户组的GDA用户。
  • 拥有该数据库的UPDATE或INDEX或ALTER或DROP权的用户。

从数据库复制记录。如果满足下列条件之一，则有权从数据库复制记录：

  • 超级用户。
  • DBA用户。
  • 源数据库的拥有者。
  • 源数据库具有公共UPDATE属性。
  • 源数据库拥有者所在用户组的GDA用户。
  • 拥有该源数据库的UPDATE或INDEX或ALTER或DROP权的用户。

检索数据库记录。如果满足下列条件之一，则有权检索数据库记录：

  • 超级用户。
  • DBA用户。
  • 数据库的拥有者。
  • 数据库具有公共SELECT属性。
  • 数据库拥有者所在用户组的GDA用户。
  • 拥有该数据库的SELECT或UPDATE或INDEX或ALTER或DROP权限的用户。


数据库字段操作

如果满足下列条件之一，则有权在数据库字段上进行检索：

  • 数据库字段具有公共SELECT属性。
  • 拥有该字段所在数据库的SELECT权的用户。
  • 拥有该字段的SELECT权的用户。


视图操作

创建视图。如果满足下列条件之一，则有权创建视图：

  • 超级用户。
  • DBA用户。
  • GDA用户。
  • RESOURCE用户。

如果创建者是GDA或RESOURCE用户，则该用户必须对视图字段所映射的数据库字段具有SELECT权。

删除视图。如果满足下列条件之一，则有权删除视图：

  • 超级用户。
  • DBA用户。
  • 视图的拥有者。
  • 视图具有公共DROP属性。
  • 视图拥有者所在用户组的GDA用户。
  • 拥有该视图的DROP权的用户。

当删除一个视图时，系统将自动删除所有用户在该视图上的权限。

修改视图及自动模式视图中添加数据库。如果满足下列条件之一，则有权修改视图或在自动模式视图中添加数据库：

  • 超级用户。
  • DBA用户。
  • 视图的拥有者。
  • 视图具有公共ALTER属性。
  • 视图拥有者所在用户组的GDA用户。
  • 拥有该视图的ALTER权的用户。

如果修改者是GDA或RESOURCE用户，则该用户必须对新增的视图字段所映射的数据库字段具有SELECT权。
当删除一个视图字段时，系统将自动删除所有用户在该视图字段上的权限。

检索视图记录。如果满足下列条件之一，则有权检索视图记录：

  • 超级用户。
  • DBA用户。
  • 视图的拥有者。
  • 视图具有公共SELECT属性。
  • 视图拥有者所在用户组的GDA用户。
  • 拥有该视图的SELECT或ALTER或DROP权的用户。

备份自动模式视图。如果满足下列条件之一，则有权备份自动模式视图：

  • 超级用户。
  • DBA用户。
  • 自动模式视图的拥有者。
  • 自动模式视图拥有者所在用户组的GDA用户
维护自动模式视图索引及优化自动模式视图。如果满足下列条件之一，则有权维护自动模式视图索引或优化自动模式视图：

  • 超级用户。
  • DBA用户。
  • 自动模式视图的拥有者。
  • 自动模式视图具有公共INDEX属性。
  • 自动模式视图拥有者所在用户组的GDA用户。
  • 拥有该自动模式视图的INDEX或ALTER或DROP权的用户。

维护自动模式视图记录（自动模式视图作为加载、插入、删除、修改和复制记录的目标视图）。如果满足下列条件之一，则有权维护自动模式视图记录：

  • 超级用户。
  • DBA用户。
  • 自动模式视图的拥有者。
  • 自动模式视图具有公共UPDATE属性。
  • 自动模式视图拥有者所在用户组的GDA用户。
  • 拥有该自动模式视图的UPDATE或INDEX或ALTER或DROP权的用户。

从视图复制记录。如果满足下列条件之一，则有权从视图复制记录：

  • 超级用户。
  • DBA用户。
  • 视图中的源数据库的拥有者。
  • 视图中的源数据库具有公共UPDATE属性。
  • 视图中的源数据库拥有者所在用户组的GDA用户。
  • 拥有该视图中的源数据库的UPDATE或INDEX或ALTER或DROP权的用户。


视图字段操作

如果满足下列条件之一，则有权在视图字段上进行检索：

  • 视图字段具有公共SELECT属性。
  • 拥有该字段所在视图的SELECT权的用户。
  • 拥有该字段的SELECT权的用户。


词典操作

创建词典。如果满足下列条件之一，则有权创建词典：

  • 超级用户。
  • DBA用户。
  • GDA用户。
  • RESOURCE用户。

删除词典。如果满足下列条件之一，则有权删除词典：

  • 超级用户。
  • DBA用户。
  • 词典的拥有者。
  • 词典具有公共DROP属性。
  • 词典拥有者所在用户组的GDA用户。
  • 拥有该词典的DROP权的用户。

修改词典的属性。如果满足下列条件之一，则有权修改词典的属性：

  • 超级用户。
  • DBA用户。
  • 词典拥有者所在用户组的GDA用户。
  • 词典的拥有者。

更新维护词典。如果满足下列条件之一，则有权更新维护词典：

  • 超级用户。
  • DBA用户。
  • 词典的拥有者。
  • 词典具有公共UPDATE属性。
  • 词典拥有者所在用户组的GDA用户。
  • 拥有该词典的UPDATE或DROP权的用户。

词典的SELECT权限始终是开放的，任何用户都能引用所有的词典。


数据格式操作

只有超级用户有权创建和修改数据格式。


准备加载文件

在进行数据加载前，必须选定一个目标数据库。如果数据库还未建立，则必须借助相应的应用工具创建一个TRS数据库。准备加载文件，是完成数据加载的一个关键步骤。加载文件有两类：一类是数据文件；另一类是控制文件。

数据文件是用来存放待加载的数据的文件。数据文件有两种形式，即数据记录文件和批处理文件。其中，加载DOCUMENT字段和加载BIT字段有特殊的格式。

控制文件用来控制数据的加载过程的配置文件，通过配置控制文件的变量，可以触发系统的内部功能，或改变系统的运行方式。


数据记录文件

数据记录文件实际上是由一个或多个记录数据组成的TRS标记文件，统称为TRS格式文件，有以下五种格式：“标准格式”、“字段内部标识号标记格式”、“字段顺序号标记格式”、“无字段标记格式”、“全文格式”，单个TRS格式文件的大小不能超过2G字节。TRS系统的数据加载，除了支持以上五种TRS格式外，还支持“ISO2709国际标准格式”和“XML格式”这两种格式文件直接入库。

除ISO2709国际标准格式外，每个记录都以标记“<REC>”开始，即标记“<REC>”是记录之间的分隔符。第一个记录前和最后一个记录后的该标记可以省略；如果文件中只有一个记录，则该标记也可以省略。

数据记录文件的一般格式是：

<REC> CRYPT
字段1
字段2
……
字段n

<REC> CRYPT
字段1
字段2
……
字段n

其中：

  • 标记<REC>必须顶格书写。
  • 字段n的描述共有5种不同的格式，分别为“标准格式”、“字段内部标识号标记格式”、“字段顺序号标记格式”、“无字段标记格式”和“全文格式”。
  • 标记<REC>后面的CRYPT是记录的加密描述符。CRYPT必须与标记<REC>写在同一行。加密描述符可以省略。

CRYPT由下列一个或多个分项组成：

  • SecurityCode = CodeValue。其中“SecurityCode”可使用缩写“SC”，不区分大小写。“CodeValue”是一个有效的用户密级（数字，0表示没有密级加密，不允许为空串），表示只有用户的密级不大于该值时才能读出该记录。
  • UserGroup = GroupName。其中“UserGroup”可使用缩写“UG”，不区分大小写。“GroupName”是一个有效的用户组名（不区分大小写，不允许为空串），表示只有该用户组的用户才能读出该记录。
  • Password = PasswordString。其中“Password”可使用缩写“PWD”，不区分大小写。“PasswordString”是一个不超过8个字符的字符串（大小写敏感，不允许为空串，首尾的空白字符无效），表示该记录读出时必须提供相同的口令。

CRYPT中包含多个分项时，分项之间用单字节的逗号“,”或分号“;”或空格分隔，分项之间没有顺序限制，但如果用空格分隔，则给出的分项必须是完整的。如：

<REC> SecurityCode = 10; UserGroup = Adminitrator;
……

<REC> PWD = OnlyMe
……

<REC>
……

下面是一个加载多媒体数据的例子：

<REC>
<正文>= @file1.txt

<REC>
<正文>= @\\server\data\file2.htm ^URL

<REC>
<正文>= @http://server/data/file3.doc ^WORD^CLASS

<REC>
<正文>= @file4.doc | file4.txt ^WORD^CLASS

<REC>
<正文>= @file5.doc ^CLASS | file5.txt ^DUMB

<REC>
<正文>= @//server/data/file6.doc | file7.txt ^URL

<REC>
<图片>= @file8.doc^CLASS; file9.txt

<REC>
<图片>= @\\server\data\file10.doc ^URL; www.server.com\data\file11.html

这里，文件路径中的子目录分隔符没有‘\’和‘/’之分，这两种符号系统能够自动纠正。但对于一个URL，其路径中的子目录分隔符系统不会进行纠正，必须使用实际的目录分隔符。


标准格式

标准格式(STANDARD)

标准格式的TRS数据记录文件的组织格式为：

<REC>
<字段名1>=字段值1……
……
<字段名2>=字段值2……
……
<字段名n>=字段值n……
……

<REC>
<字段名1>=字段值1……
……
<字段名2>=字段值2……
……
<字段名n>=字段值n……
……

其中：

  • 标记引导符“<”必须顶格书写，标记结束符“>=”是一个整体，中间不能有任何其他字符。这两个标记符号都是ASCII码，必须成对出现。
  • 标记引导符“<”之前可以加上一个前缀，以更加准确地指明一个TRS标记的开始。
  • 标记引导符“<”和标记结束符“>=”之间是一个字段名，或者是一个字段的别名。"<字段名n>="必须书写在同一文本行，不能跨行。如果使用字段的别名，则必须在控制文件中用COLUMN_NAME_SEQUENCE变量列出所有需要加载数据的字段所对应的别名，除非设置COLUMN_AUTO_MATCH变量为TRUE。
  • 标记结束符“>=”与下一个标记引导符“<”之间的一行或多行文本为该字段的值。文本前后的空字符不计入字段值，但PHRASE和DOCUMENT字段可通过控制文件的设置（KEEP_TEXT_ACTUAL变量）保持其文本原样。字段值可以为空。
  • 字段之间没有顺序限制。多值字段的值可以用一个"<字段名n>=字段值n"的方式书写，多值之间用特定的字符或字符串分隔（控制文件中MULTI_VALUE_SEPARATER变量的值必须与其相一致）；也可以用多个"<字段名n>=字段值n"的方式书写；这两种方式也可以同时使用。但是如果一个字段不允许多值，则该字段的所有"<字段名n>=字段值n"中，只有第一个有效，其它将被忽略。
  • 对于BIT字段，如果要在一个"<字段名n>=字段值n"格式中存放多个值，则其中的每个值都必须用文件方式给出。
  • 对于PHRASE和DOCUMENT字段，如果在一个记录中出现多次，这根据控制文件的设置（CHECK_TEXT_ITERATIVE变量）进行如下处理：如果控制文件的设置不要求检查这两种字段的重复值，则忽略前面出现的字段值，而只保留最后出现的字段值；否则认为这是一个错误的记录数据。

下面是一个包含两条记录的“专利数据库”的标准格式的数据记录文件：

<REC>
<公告日>=920101
<分类号>=A01B49/02
<公告号>=CN_2091520U
<申请号>=91208300.X
<申请日>=910514
<申请人>=宝鸡县机电设备维修厂
<地址>=721304陕西省宝鸡县钓渭乡
<设计人>=赵志栋
<专利代理机构>=宝鸡市专利事务所
<代理人>=翟中平
<摘要>=耕耙犁
耕耙犁是用于农田深耕、碎土的农机具，它是由主动力输入总成、动力传输箱、左、右传动轴总成、左、右动力输出箱及左、右碎土器等构成。主动力输入总成与动力传输箱连接左、右传动轴总成与动力传输箱连接且位于主动力输入总成的两侧，左、右动力输出箱分别与左、右传动轴总成连接，左、右碎土器与左、右动力输出箱的动力输出轴连接，该农机具具有结构设计新颖、简单、实用的特点，特别适应于在小块田地作业且作业时不留死角，并且能同时完成深耕和碎土两道作业，具有工效高的优点。

<REC>
<公告日>=920101
<分类号>=A01B49/04
<公告号>=CN_2091521U
<申请号>=91206137.5
<申请日>=910411
<申请人>=张岳
<地址>=475000河南省开封市南太平街3号楼2单元付3号
<设计人>=张岳
<设计人>=张龙
<设计人>=范文增
<设计人>=石建峡
<设计人>=阎唯一
<专利代理机构>=开封市专利事务所
<代理人>=黄永武
<代理人>=乔玉萍
<摘要>=牵引式多功能农用机
本实用新型是一种具有施肥、追肥、播种、点种、刨茬、锄草、筑埂、打畦以及碾压封土的多功能农用机。其特征是:设有筑埂打畦器和带圆锥形轮齿的主动轮及采用塔式链轮变速，并结合容器轮的容器槽及连接于容器槽内的容器，实现了不同株距的要求，通过成套部件还可将单机构成全机和并机，可分别适用于人力、畜力、拖拉机牵引。本实用新型结构简单、造价低、操作维修方便，适用于个体户、农场、农机站的需要，具有广阔的市场。

对于DOCUMENT字段，其字段标记还支持标记属性，用以描述说明字段值的特性，这种方式常称为内嵌格式化数据方式。但是如果字段值以外挂文件的方式给出（参见3.1节），则字段标记属性不起作用。用这种方式来加载数据库记录，其数据的传输效率要比外挂文件方式的效率稍高一些。带标记属性的字段标记的格式为：

<字段名 ATTRIBUTE>=字段值……

ATTRIBUTE由下列一个或多个分项组成：

  • Format = FormatName。其中“Format”可以使用缩写“FMT”，不区分大小写。“FormatName”必须是一个有效的数据格式名（不区分大小写），表示字段值的数据库格式。目前只支持TEXT、HTML和XML三种式。
  • Storage = StorageMode。其中“Storage”可使用缩写“STG”，不区分大小写。“StorageMode”必须是一个有效的存储方式控制符（不区分大小写），表示字段值在数据库中的存储方式。有关“存储方式控制符”的详细说明请参见3.1.2节。

当ATTRIBUTE中包含多个分项时，分项之间用单字节的逗号“,”或分号“;”或空格分隔，分项之间没有顺序限制，但如果用空格分隔，则给出的分项必须是完整的，即分项的“=”后面必须有值。下面是一个例子：

$$TRSTAG$$<正文 FORMAT=HTML; STORAGE=Class>= <HTML>
<HEAD>
<TITLE>
Internet 数据库连接程序示例
</TITLE>
</HEAD>
<BODY BACKGROUND="backgrnd.gif" BGCOLOR="FFFFFF">
该页提供了使用 Internet 数据库连接程序的几个示例的链接。尽管 Internet 数据库连接程序能使用任何 32 位开放数据库连接 (ODBC) - 兼容驱动器，该驱动器支持系统数据源名称(DSN)，但这些例子使用了 Microsoft SQL 服务器。
<P>
要不加改动地运行这些示例，您的计算机必须能访问 Microsoft SQL Server <I>sa</I> 账号，而且此账号不要求密码 (该账号是在默认安装 Microsoft SQL Server 时产生的)。如果不能或者不愿在这些示例中使用 <I>sa</I> 账号，可在示例使用的 .idc 文件中编辑“Username field”(如果必要，增加“Password field”)，使其成为合法的用户账号。
<P>
要安装这些例子，须在连接到 SQL 服务器的计算机上创建名为 <B>Web SQL</B> 的 ODBC 系统数据源。使用控制面板上的 ODBC 程序创建系统 DSN，或者单击<A HREF=/scripts/tools/dsnform.exe?SQL+Server>此处</A>，用随 Microsoft Internet Information Server 或 Peer Web Services 一起提供的 <A HREF=/scripts/tools/getdrvrs.exe>ODBC 数据源工具</A>来创建它 。
</BODY>
</HTML>
……

在这个例子中，我们在字段标记“<正文 FORMAT=XML; STORAGE=Class>=”前插入了一串特殊字符“$$TRSTAG$$”，它是一个标记引导符前缀。

数据记录文件采用“标准格式”进行数据加载时，在控制文件中可以指定变量RECORD_FILE_FORMAT为STANDARD，或者缺省。


字段内部标识号标记格式

字段内部标识号标记格式(IDENTSTD)

字段内部标识号标记格式与标准格式的唯一区别在于：标准格式中用标记“<字段名>=”来指示一个字段，而这种格式则用标记“<字段内部标识号>=”来指示一个字段。字段内部标识号是指该字段在数据词典中的唯一标识号。

对于“专利数据库”，假设各个字段的内部标识号为：

字段名 | 字段内部标识号 | 字段名 | 字段内部标识号
公告日 | 1 | 申请人 | 7
分类号 | 2 | 地址 | 8
公告号 | 3 | 设计人 | 9
申请号 | 4 | 专利代理机构 | 10
申请日 | 5 | 代理人 | 11
颁证日 | 6 | 摘要 | 12

下面是这个“专利数据库”的字段内部标识号标记格式的数据记录文件组织：

<REC>
<1>=920101
<2>=A01B49/02
<3>=CN_2091520U
<4>=91208300.X
<5>=910514
<7>=宝鸡县机电设备维修厂
<8>=721304陕西省宝鸡县钓渭乡
<9>=赵志栋
<10>=宝鸡市专利事务所
<11>=翟中平
<12>=耕耙犁
耕耙犁是用于农田深耕、碎土的农机具，它是由主动力输入总成、动力传输箱、左、右传动轴总成、左、右动力输出箱及左、右碎土器等构成。主动力输入总成与动力传输箱连接左、右传动轴总成与动力传输箱连接且位于主动力输入总成的两侧，左、右动力输出箱分别与左、右传动轴总成连接，左、右碎土器与左、右动力输出箱的动力输出轴连接，该农机具具有结构设计新颖、简单、实用的特点，特别适应于在小块田地作业且作业时不留死角，并且能同时完成深耕和碎土两道作业，具有工效高的优点。

<REC>
<1>=920101
<2>=A01B49/04
<3>=CN_2091521U
<4>=91206137.5
<5>=910411
<7>=张岳
<8>=475000河南省开封市南太平街3号楼2单元付3号
<9>=张岳
<9>=张龙
<9>=范文增
<9>=石建峡
<9>=阎唯一
<10>=开封市专利事务所
<11>=黄永武
<11>=乔玉萍
<12>=牵引式多功能农用机
本实用新型是一种具有施肥、追肥、播种、点种、刨茬、锄草、筑埂、打畦以及碾压封土的多功能农用机。其特征是:设有筑埂打畦器和带圆锥形轮齿的主动轮及采用塔式链轮变速，并结合容器轮的容器槽及连接于容器槽内的容器，实现了不同株距的要求，通过成套部件还可将单机构成全机和并机，可分别适用于人力、畜力、拖拉机牵引。本实用新型结构简单、造价低、操作维修方便，适用于个体户、农场、农机站的需要，具有广阔的市场。

数据记录文件采用“字段内部标识号标记格式”进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为IDENTISTD。


字段顺序号标记格式

字段顺序号标记格式(SIMPLESTD)

字段顺序号标记格式与字段内部标识号标记格式非常相似，仅有两点差别：

  • 字段内部标识号标记格式则用标记“<字段内部标识号>=”来指示一个字段，而这种格式是用标记“<字段顺序号>=”来指示一个字段。
  • 字段顺序号是字段在控制文件中（COLUMN_NAME_SEQUENCE变量）给出的字段列表中的次序。第一个字段的顺序号为1，依次类推。

下面是“专利数据库”的字段顺序号标记格式的数据记录文件组织：

<REC>
<1>=920101
<2>=A01B49/02
<3>=CN_2091520U
<4>=91208300.X
<5>=910514
<6>=宝鸡县机电设备维修厂
<7>=721304陕西省宝鸡县钓渭乡
<8>=赵志栋
<9>=宝鸡市专利事务所
<10>=翟中平
<11>=耕耙犁
耕耙犁是用于农田深耕、碎土的农机具，它是由主动力输入总成、动力传输箱、左、右传动轴总成、左、右动力输出箱及左、右碎土器等构成。主动力输入总成与动力传输箱连接左、右传动轴总成与动力传输箱连接且位于主动力输入总成的两侧，左、右动力输出箱分别与左、右传动轴总成连接，左、右碎土器与左、右动力输出箱的动力输出轴连接，该农机具具有结构设计新颖、简单、实用的特点，特别适应于在小块田地作业且作业时不留死角，并且能同时完成深耕和碎土两道作业，具有工效高的优点。

<REC>
<1>=920101
<2>=A01B49/04
<3>=CN_2091521U
<4>=91206137.5
<5>=910411
<6>=张岳
<7>=475000河南省开封市南太平街3号楼2单元付3号
<8>=张岳
<8>=张龙
<8>=范文增
<8>=石建峡
<8>=阎唯一
<9>=开封市专利事务所
<10>=黄永武
<10>=乔玉萍
<11>=牵引式多功能农用机
本实用新型是一种具有施肥、追肥、播种、点种、刨茬、锄草、筑埂、打畦以及碾压封土的多功能农用机。其特征是:设有筑埂打畦器和带圆锥形轮齿的主动轮及采用塔式链轮变速，并结合容器轮的容器槽及连接于容器槽内的容器，实现了不同株距的要求，通过成套部件还可将单机构成全机和并机，可分别适用于人力、畜力、拖拉机牵引。本实用新型结构简单、造价低、操作维修方便，适用于个体户、农场、农机站的需要，具有广阔的市场。

这里假设控制文件中给出的字段列表为：公告日;分类号;公告号;申请号;申请日;申请人;地址;设计人;专利代理机构;代理人;摘要。

数据记录文件采用“字段顺序号标记格式”进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为SIMPLESTD。


无字段标记格式

无字段标记格式(SEQUENCE)

无字段标记格式是指在TRS数据记录文件的一个记录中，字段之间不是用显式的标记来分隔，而是通过自然的文本行来标示不同的字段。这种格式的特点是：

  • 字段的顺序由控制文件（COLUMN_NAME_SEQUENCE变量）定义。
  • 除最后一个字段外，每个字段的值只能占用一行。没有值的字段，如果不是最后一个字段，则也必须用一空行来表示。
  • 最后一个字段的值可以是多行，直到下一个记录的标记引导符“<”。也就是说，字段值多于一行的字段必须是每个记录的最后一个字段。
  • 如果有多个字段的值多于一行，则不能采用这种格式组织数据记录文件。

下面是“专利数据库”的无字段标记格式的数据记录文件组织：

<REC>
920101
A01B49/02
CN_2091520U
91208300.X
910514
宝鸡县机电设备维修厂
721304陕西省宝鸡县钓渭乡
赵志栋
宝鸡市专利事务所
翟中平
耕耙犁
耕耙犁是用于农田深耕、碎土的农机具，它是由主动力输入总成、动力传输箱、左、右传动轴总成、左、右动力输出箱及左、右碎土器等构成。主动力输入总成与动力传输箱连接左、右传动轴总成与动力传输箱连接且位于主动力输入总成的两侧，左、右动力输出箱分别与左、右传动轴总成连接，左、右碎土器与左、右动力输出箱的动力输出轴连接，该农机具具有结构设计新颖、简单、实用的特点，特别适应于在小块田地作业且作业时不留死角，并且能同时完成深耕和碎土两道作业，具有工效高的优点。

<REC>
920101
A01B49/04
CN_2091521U
91206137.5
910411
张岳
475000河南省开封市南太平街3号楼2单元付3号
张岳;张龙;范文增;石建峡;阎唯一
开封市专利事务所
黄永武;乔玉萍
牵引式多功能农用机
本实用新型是一种具有施肥、追肥、播种、点种、刨茬、锄草、筑埂、打畦以及碾压封土的多功能农用机。其特征是:设有筑埂打畦器和带圆锥形轮齿的主动轮及采用塔式链轮变速，并结合容器轮的容器槽及连接于容器槽内的容器，实现了不同株距的要求，通过成套部件还可将单机构成全机和并机，可分别适用于人力、畜力、拖拉机牵引。本实用新型结构简单、造价低、操作维修方便，适用于个体户、农场、农机站的需要，具有广阔的市场。

这里假设控制文件中给出的字段列表为：公告日;分类号;公告号;申请号;申请日;申请人;地址;设计人;专利代理机构;代理人;摘要。

数据记录文件采用“无字段标记格式”进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为SEQUENCE。


全文格式

全文格式(FULLTEXT)

全文格式的特点是：

  • 数据记录文件的每个记录中只有一个字段。
  • 记录中没有字段标记。
  • 如果数据库有多个字段，则目标字段可由控制文件（COLUMN_NAME_SEQUENCE变量）定义，或按其缺省规则自动确定目标字段。如果指定目标字段，则该字段必须是一个DOCUMENT或PHRASE字段，并且只能指定一个字段。

下面是一个包含两条记录的“红楼梦数据库”的全文格式的数据记录文件：

<REC>
第一回 甄士隐梦幻识通灵 贾雨村风尘怀闺秀

此开卷第一回也。作者自云：因曾历过一番梦幻之后，故将真事隐去，而借“通灵”之说，撰此《石头记》一书也。故曰“甄士隐”云云。但书中所记何事何人？自又云“今风尘碌碌，一事无成，忽念及当日所有之女子，一一细考较去，觉其行止见识，皆出于我之上。何我堂堂须眉，诚不若彼裙钗哉？实愧则有余，悔又无益之大无可如何之日也！当此，则自欲将已往所赖天恩祖德，锦衣纨裤之时，饫甘餍肥之日，背父兄教育之恩，负师友规谈之德，以至今日一技无成，半生潦倒之罪，编述一集，以告天下人：我之罪固不免，然闺阁中本自历历有人，万不可因我之不肖，自护己短，一并使其泯灭也。虽今日之茅椽蓬牖，瓦灶绳床，其晨夕风露，阶柳庭花，亦未有妨我之襟怀笔墨者。虽我未学，下笔无文，又何妨用假语村言，敷演出一段故事来，亦可使闺阁昭传，复可悦世之目，破人愁闷，不亦宜乎？故曰“贾雨村”云云。
......

<REC>
第二回 贾夫人仙逝扬州城 冷子兴演说荣国府

诗云
一局输赢料不真，香销茶尽尚逡巡。
欲知目下兴衰兆，须问旁观冷眼人。

却说封肃因听见公差传唤，忙出来陪笑启问。那些人只嚷：“快请出甄爷来！”封肃忙陪笑道：“小人姓封，并不姓甄。只有当日小婿姓甄今已出家一二年了，不知可是问他？”那些公人道：“我们也不知什么‘真’‘假’，因奉太爷之命来问，他既是你女婿，便带了你去亲见太爷面禀，省得乱跑。”说着，不容封肃多言，大家推拥他去了。封家人个个都惊慌，不知何兆。

那天约二更时，只见封肃方回来，欢天喜地。众人忙问端的。他乃说道：“原来本府新升的太爷姓贾名化，本贯胡州人氏，曾与女婿旧日相交。方才在咱门前过去，因见娇杏那丫头买线，所以他只当女婿移住于此。我一一将原故回明，那太爷倒伤感叹息了一回，又问外孙女儿，我说看灯丢了。太爷说：‘不妨，我自使番役务必探访回来。’说了一回话，临走倒送了我二两银子。”甄家娘子听了，不免心中伤感。一宿无话。
......

这里假设控制文件中给出的字段列表为：COLUMN_NAME_SEQUENCE=正文。

数据记录文件采用“全文格式”进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为FULLTEXT。


ISO2709国际标准格式

ISO2709国际标准格式(ISO2709)

TRS能够将ISO2709格式的数据文件的直接加载到数据库中。ISO2709格式是一种国际标准，这里就不再进行说明。

下面是一个包含两条记录的“专利数据库”的ISO2709格式的数据文件：

006400000000001810005500001000110000000200010000110030001200021004000110003300500011000440060001100055007000070006600800038000730090000700111010000010011801100001001190120033800120#1993.01.06#A01K83/04#CN_2126505Y#92203792.2#1992.03.06#1993.01.03#王卫平#100045北京市西城复外真武庙6号楼1604号#王卫平###

防逃式钓鱼器

本实用新型属于一种防逃式钓鱼器。它的作用原理：当鱼咬钩时，把连接固定钩（７）的销（４）从套管（３）中拉出，活动钩连线（８）被拉直，使活动钩（９）张开，活动钩与固定钩共同作用，牢牢卡住鱼嘴。本防逃式钓鱼器结构简单，动作灵敏，鱼一旦上钩不易逃脱。可实现在无人看管的情况下钓鱼。本钓鱼器制作工艺简单，便于成批系列化生产。
##005760000000001810005500001000110000000200009000110030001200020004000110003200500011000430060001100054007000130006500800027000780090002100105010000170012601100015001430120023600158#1993.01.06#A01M9/00#CN_2126506Y#92226804.5#1992.07.09#1993.01.03#北京农业大学#100094北京市圆明园西路二号#巨修练; 崔泌; 孙继新#农业部专利事务所#林祥明; 苟显伦#

手动静电喷粉机及其电晕带电喷头

本实用新型提供了一种手动静电喷粉机及其电晕带电喷头，该手动静电喷粉机可广泛用于施用农药粉剂，防治病虫害。试验证明，使用本实用新型施用农药，其沉积量可提高５０－８０％，靶标反面沉积量可提高３－４倍。
##

这里假设控制文件中给出的字段列表为：公告日;分类号;公告号;申请号;申请日; 颁证日;申请人;地址;设计人;专利代理机构;代理人;摘要。

需要注意的一点：格式中的“目录项标记”域是该字段在控制文件字段列表中的序号（从1开始计数）。参照上例，如“目录项标记”是“012”，则该字段就是数据库中的“摘要”字段。

还有一点：由于TRS不支持子字段，所以ISO2709数据域的各个分项将被当作该字段的多值处理；如果该字段不支持多值，则只有第一个数据分项是有效，其它项将被忽略。

TRS也支持使用格式中的“目录项标记”域作为数据库的字段或别名对数据进行映射，这时需要将控制文件中的NAMIZE_ISO2709_FIELD变量设置成TRUE。请参见4.2.28节的详细说明。

数据记录文件采用ISO2709格式进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为ISO2709。请参见《TRSDatabase6.doc》4.2.1节的说明。


XML格式

XML格式(XML)

和ISO2709一样，XML格式也是一种国际标准，具体说明请参考有关资料，其中子字段也不会被解析

TRS以两种方式支持XML数据的直接入库：一种是记录级的支持，即XML文件的结构对应于一个TRS数据库的结构，该XML文件由许多记录组成，这时可以将XML文件理解成符合XML规范的TRS格式文件；另一种是字段级的支持，即把XML数据作为TRS数据库中的一个字段的值进行加载，自动完成文本过滤并建立索引，在处理上，与HTML没有本质的区别。对于字段级的支持，在加载数据时还可以通过控制文件设置一些选项，请参见4.2.22 ~ 4.2.26节的说明。

这一节所描述的内容都是针对于XML记录级支持的。在这种方式下，不解析字段值中的子标记，用来标记数据的“字段标记”，既可以是字段名，也可以是字段的别名。如果使用字段的别名，则必须在控制文件中用 COLUMN_NAME_SEQUENCE变量列出所有需要加载数据的字段所对应的别名，除非设置COLUMN_AUTO_MATCH变量为TRUE。

下面是一个包含两条记录的“专利数据库”的XML格式的数据文件：

<?xml version="1.0" encoding="gb2312"?>
<!DOCTYPE TRS [
<!ELEMENT TRS (REC) *>
<!ELEMENT REC (公告日,分类号,公告号,申请号,申请日,颁证日,申请人,地址,设计人,专利代理机构,代理人,摘要)>
<!ELEMENT 公告日(#PCDATA)>
<!ELEMENT 分类号(#PCDATA)>
<!ELEMENT 公告号(#PCDATA)>
<!ELEMENT 申请号(#PCDATA)>
<!ELEMENT 申请日(#PCDATA)>
<!ELEMENT 颁证日(#PCDATA)>
<!ELEMENT 申请人(#PCDATA)>
<!ELEMENT 地址(#PCDATA)>
<!ELEMENT 设计人(#PCDATA)>
<!ELEMENT 专利代理机构(#PCDATA)>
<!ELEMENT 代理人(#PCDATA)>
<!ELEMENT 摘要(#PCDATA)>
]>
<TRS>
<REC>
<公告日>1994.01.05</公告日>
<分类号>A01B49/02</分类号>
<公告号>CN_2151607Y</公告号>
<申请号>92243586.3</申请号>
<申请日>1992.12.08</申请日>
<颁证日>1993.10.03</颁证日>
<申请人>刘殿富</申请人>
<地址>154552黑龙江省勃利县双河镇永平村</地址>
<设计人>刘殿富</设计人>
<摘要><![CDATA[
铲耥锄草耕作机

本实用新型公开了一种垄帮、苗间锄草，起垄深松破茬一次完成的铲耥锄草耕作机，是通过牵引带动向位传轮的伞形齿与苗间锄草器立式转动轴的伞型齿相啮合，使苗间锄草器在苗间水平旋转，同时通过动力带动安装在顺梁上的垄帮锄草器、双犁头深松器和齐刃犁头一起工作，就可达到垄帮、苗间锄草，垄沟深松、破茬起垄一次完成的目的。苗间和垄帮锄草可通过调节杆调节入土深度，苗间锄草部可单独与各种牵引，悬挂式三铧犁配套使用，也可用畜力牵引。
]]></摘要>
</REC>
<REC>
<公告日>1994.01.05</公告日>
<分类号>A01C23/04</分类号>
<公告号>CN_2151608Y</公告号>
<申请号>93202243.X</申请号>
<申请日>1993.01.20</申请日>
<颁证日>1993.09.12</颁证日>
<申请人>刘忠厚</申请人>
<地址>161005黑龙江省齐齐哈尔市龙沙区农委</地址>
<设计人>刘忠厚</设计人>
<专利代理机构>齐齐哈尔市专利事务所</专利代理机构>
<代理人>叶仲刚</代理人>
<摘要><![CDATA[
恒压等浓度施肥罐

一种恒压等浓度施肥罐，由罐体、输水管、进水管、施肥管及各种控制阀、压力表和水表组成。在罐体内设置一隔板，将罐体分为上下罐，隔板上有一个气体连通管将上罐连通。当上罐加入化肥或农药溶液密封后，由进水管向下罐注入清水，罐中产生气压，使上罐内的化肥或农药溶液经过施肥管注入输水管。本装置具有施肥均匀度好，肥浓度变化可控制，便于自动化实施，成本低且运行费用少，可制成固定式或移动式。
]]></摘要>
</REC>
</TRS>

对于任何一个XML的DTD定义，TRS目前只检查辨认其中的DOCTYPE声明（定义）以及DOCTYPE的子元素声明（定义）的内容，并且DOCTYPE只允许有一个子元素，同时忽略DTD中的所有其它声明（定义）。这里的DOCTYPE即是XML的顶层标记，DOCTYPE的子元素即是XML的第一层子标记

如果DOCTYPE为TRS，且DOCTYPE的子元素为REC，则XML的DTD部分可以省略，否则必须定义文档的DTD（也只需DOCTYPE声明和DOCTYPE的子元素声明）。对XML字段级的支持，则DTD部分总是可以省略。

如果在XML文件中定义了DTD，且DOCTYPE为TRS，DOCTYPE的子元素为REC，则有以下的特殊支持：

  • 元素REC支持三个属性：SC或SecurityCode；UG或UserGroup； PWD或Password。这三个属性用于对记录的加密，详细说明请参见2.1节。其它属性将被忽略。

  • 如果将“br”定义成一个“空”元素，即定义：<!ELEMENT br EMPTY>，则此时br标记的意义固定为“换行”，而XML数据中原来的所有“自然文本换行”将被忽略。对于字段级的支持，TRS也是这么处理的，除非另有设置。例如：

<!DOCTYPE TRS [
<!ELEMENT TRS (REC)>
<!ELEMENT REC (日期,版次,版名,栏目,标题,作者,正文,br)>
<!ELEMENT 日期 (#PCDATA | br)*>
<!ELEMENT 版次 (#PCDATA | br)*>
<!ELEMENT 版名 (#PCDATA | br)*>
<!ELEMENT 栏目 (#PCDATA | br)*>
<!ELEMENT 标题 (#PCDATA | br)*>
<!ELEMENT 作者 (#PCDATA | br)*>
<!ELEMENT 正文 (#PCDATA | br)*>
<!ELEMENT br EMPTY>
]>

对于XML数据中的实体引用（实体定义被忽略），TRS接受绝大多数ISO标准的实体名，而自己定义的非标准实体则不能识别。不能识别的ISO标准实体和自定义的非标准实体引用，TRS将保持原样，不进行替换。

TRS支持大多数流行的字符集编码格式的XML文件，这些字符集包括：GB2312、GBK、GB18030、BIG5、UTF-8、ISO8859-1 ～ ISO8859-16以及WINDOWS-1250 ～WINDOWS-1258。

数据记录文件采用XML格式进行数据加载时，在控制文件中必须指定变量RECORD_FILE_FORMAT为XML。


批处理数据文件

对数据库进行加载时，数据文件既可以是单个TRS数据记录格式（“标准格式”，或“字段内部标识号标记格式”，或“字段顺序号标记格式”，或“无字段标记格式”，或“全文格式”之一）文件，或者单个 ISO2709格式 或XML格式文件；也可以是一批相同格式（上述7种数据格式文件之一）的数据文件。

批处理数据文件实际上是存储一批数据记录文件名的文件。其基本规则是：

  • 批处理数据文件是一个文本文件。文件的每一自然行存储一个数据记录文件名。
  • 数据记录文件名中既可以包含路径，也可以不包含路径。如果没有路径，则默认文件放在当前工作目录下；如果当前工作目录下不存在指定的数据记录文件，则系统将取批处理数据文件的路径作为数据记录文件的缺省路径。其中路径的子目录分隔符没有‘\’和‘/’之分，TRS能够自动适应这两种符号系统。
  • 文件中所列的全部数据记录文件必须具有相同数据记录格式。

下面是一个批处理数据文件的例子：

D:\DATA\人民日报\97ALL.TRS
D:\DATA\人民日报\9801.TRS
D:\DATA\人民日报\9802.TRS
D:\DATA\人民日报\9803.TRS
D:\DATA\人民日报\9804.TRS
D:\DATA\人民日报\9805.TRS
D:\DATA\人民日报\9806.TRS
D:\DATA\新华社\9806.TRS
D:\DATA\人民日报\9807.TRS
D:\DATA\新华社\9807.TRS
D:\DATA\人民日报\9808.TRS
D:\DATA\新华社\9808.TRS
D:\DATA\人民日报\9809.TRS
D:\DATA\新华社\9809.TRS
D:\DATA\人民日报\9810.TRS
D:\DATA\新华社\9810.TRS
D:\DATA\人民日报\9811.TRS
D:\DATA\新华社\9811.TRS
D:\DATA\人民日报\9812.TRS
D:\DATA\新华社\9812.TRS
D:\DATA\新华社\99ALL.TRS


加载DOCUMENT字段的多媒体数据

DOCUMENT字段的值一般是文本数据，可直接放在6种数据记录文件中。除此之外，DOCUMENT字段还可以接受其他数据格式类型的数据作为字段值，诸如HTML、WORD等等。由于这些类型的数据本身是格式化的，不能当作文本数据直接放在数据记录文件中，往往需要将其置于单独的文件中，然后在数据记录文件中再引用这些文件名。引用的方法是在文件名的前面加上字符‘@’后作为字段值放在数据记录文件中。

DOCUMENT字段的值一般是需要对其进行索引的，但是TRS目前只能对文本格式和HTML格式的数据进行自动索引。至于其他格式类型的数据，如果需要建立索引，则必须事先将其转换成文本格式或HTML格式的数据文件，并与原数据文件一并提供给数据记录文件引用。由原数据文件通过格式转换得到的文件称为DOCUMENT字段值的附加文件。

综合起来，DOCUMENT字段的多媒体数据的有以下三种加载格式：

  • 简单格式： @Source_Name^Format^Store
  • 典型格式： @Source_Name | Affix_Name^Format^Store
  • 完全格式： @Source_Name^Format^Store | Affix_Name^Format^Store

其中：

  • 符号‘@’为单字节ASCII码，是字段值文件引用的引导符。
  • 符号‘|’为单字节ASCII码，是字段值文件与其附加文件之间的分隔符。
  • 符号‘^’为单字节ASCII码，是字段值文件及其附加文件的控制符引导符。字段值文件及其附加文件的控制符有两种类型：数据格式控制符，即格式中的Format符号；存储方式控制符，即格式中的Store符号。

格式中Format可以是所有数据格式控制符。数据格式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件的数据格式的步骤与DOCUMENT字段基本相同，只是字段值文件的默认数据格式为BIT格式，而不是TEXT格式。

格式中Store可以是所有存储方式控制符。存储方式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件的存储方式的方法是：如果控制文件中CLASS_BIT_STORE变量的值不为TRUE，则按系统缺省的存储方式来存储字段值文件，否则按分类方式存储字段值文件。

如果Source_NameX的存储方式控制符为URL，则系统存储其本身，否则当系统自动识别Source_NameX为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Source_NameX，然后完成数据的加载。

在被引用的字段值文件及其附加文件的文件名中，既可以包含路径，也可以不包含路径，系统能够自动确定其正确的路径。方法是：

  • 直接检查文件名所对应的文件是否存在，如果存在，则不对文件名做任何修改，检查结束，否则继续。
  • 检查文件名中是否存在路径，如果存在，则进行错误处理，否则继续。
  • 检查控制文件中是否设置了DATA_PATH_DEFAULT变量，如果没有，则进行错误处理，否则继续。
  • 检查控制文件的DATA_PATH_DEFAULT变量所指定的目录下是否存在这个文件，如果不存在，则进行错误处理，否则继续。
  • 确定DATA_PATH_DEFAULT变量值为文件的路径，检查结束。


加载BIT字段的多媒体数据

对于BIT字段，虽然可以接受直接放在TRS数据记录文件中的文本数据作为字段值，但可作为字段值的其它格式类型的数据是不能直接放在TRS数据记录文件中的，所以DOCUMENT字段引用文件名作为字段值的方法同样适合加载BIT字段的值。但BIT字段对文件的引用格式要比DOCUMENT字段简单得多，只有一种形式：

@Source1_Name^Format^Store; Source2_Name^Format^Store; …

其中：

  • 符号‘@’、‘^’‘Format’以及‘Store’与DOCUMENT字段的引用格式中的相应符号具有相同的意义。
  • 分号‘;’ 为单字节ASCII码，是多个引用文件之间的分隔符，即多值字段值之间的分隔符，也可以用其他字符或者字符串来代替。但不管用什么作为多值之间的分隔符，都要求控制文件中MULTI_VALUE_SEPARATER变量的值必须与其相一致。

格式中Format可以是所有数据格式控制符。数据格式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件的数据格式的步骤与DOCUMENT字段基本相同，只是字段值文件的默认数据格式为BIT格式，而不是TEXT格式。

格式中Store可以是所有存储方式控制符。存储方式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件的存储方式的方法是：如果控制文件中CLASS_BIT_STORE变量的值不为TRUE，则按系统缺省的存储方式来存储字段值文件，否则按分类方式存储字段值文件。

如果Source_NameX的存储方式控制符为URL，则系统存储其本身，否则当系统自动识别Source_NameX为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Source_NameX，然后完成数据的加载。

与DOCUMENT字段一样，在被引用的字段值文件名中，既可以包含路径，也可以不包含路径，系统能够自动确定其正确的路径，确定方法与DOCUMENT字段完全一样。


加载格式说明

DOCUMENT字段多媒体数据有以下三种格式：

·简单格式 @Source_Name^Format^Store
当存储方式控制符为URL时，如果Source_Name对应的数据格式是TEXT或者HTML，则系统将自动从远程获取该URL的所对应的实际文件作为其附加文件，以便建立索引。系统以URL的方式存储Source_Name本身，但并不存储这个临时的附加文件。
系统能够自动识别一个URL，即系统默认以不区分大小写的字符串“www.”或“http://”或“//”引导的Source_Name就是一个URL，另外在Win32下以“\\”引导的Source_Name也是一个URL（网络邻居下的资源）。这样，如果存储方式控制符不是URL，而Source_Name给出的却是一个URL，则系统将自动从远程获取该URL的所对应的实际文件来替换Source_Name，然后完成数据的加载。

·典型格式 @Source_Name | Affix_Name^Format^Store
在这种格式中，数据格式控制符和存储方式控制符的控制对象都是Source_Name，而不是Affix_Name。
如果存储方式控制符为URL，则系统存储Source_Name本身，否则当系统自动识别Source_Name为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Source_Name，然后完成数据的加载。
附加文件Affix_Name的数据格式的确定规则是：如果Affix_Name没有文件名后缀，则默认其数据格式为TEXT，否则进一步判断这个文件名后缀是否对应了一个数据格式，如果有这样的数据格式，则Affix_Name的数据格式即为该格式，否则进行错误处理。
附加文件Affix_Name的存储方式由省略存储方式控制符的情况下确定一个字段值附加文件的存储方式的步骤进行确定。
与Source_Name一样，如果系统自动识别Affix_Name为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Affix_Name，然后完成数据的加载。

·完全格式 @Source_Name^Format^Store | Affix_Name^Format^Store
在这种格式中，Source_Name和Affix_Name具有各自的数据格式控制符和存储方式控制符。控制Affix_Name的Store只能是ALONE、CLASS和DUMB三种存储方式控制符，URL或LINK不能用来控制Affix_Name。
如果Source_Name的存储方式控制符为URL，则系统存储其本身，否则当系统自动识别Source_Name为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Source_Name，然后完成数据的加载。
与Source_Name一样，如果系统自动识别Affix_Name为一个URL时，将自动从远程获取该URL的所对应的实际文件来替换Affix_Name，然后完成数据的加载。


数据格式控制符

数据格式控制符用来描述一个文件的具体数据格式，如： MPEG、WORD、HTML和TEXT等等（不区分大小写）。数据格式控制符在TRS系统中表现为一部词典，用户可以对这部词典进行必要的增补或修改，以达到实际使用的要求。对于同一个文件，不能同时使用多个数据格式控制符来控制。

TRS系统最基本的数据格式控制符有：

控制符 | 数据格式 | 文件后缀
BIT | 不确定格式的二进制数据 | bit
TEXT | 文本数据格式 | txt
WORD | Microsoft Word数据格式 | doc
WS | WordStar数据格式 | ws
WP | WordProfect数据格式 | wp
XCL | Microsoft Excel数据格式 | xls
WPS | 金山WPS数据格式 | wps
S2 | 方正、华光二扫数据格式 | s2
DOC | 不确定格式的文档数据格式 | doc
AUDIO | 不确定格式的音频数据格式 | aud
IMAGE | 通用图像数据格式 | img
VIDEO | 不确定格式的视频数据格式 | vid
AVI | AVI动画数据格式 | avi
MPEG | MPEG压缩动画数据格式 | mpg
WAVE | Wave音频数据格式 | wav
MIDI | MIDI音频数据格式 | mid
CDA | CD音频数据格式 | cda
PS | PostScript数据格式 | ps
GIF | GIF图像数据格式 | gif
TIF | TIF图像数据格式 | tif
PCX | PCX图像数据格式 | pcx
BMP | BMP图像数据格式 | bmp
JPEG | JPEG图像数据格式 | jpg
HTML | HTML超文本数据格式 | htm;html
PDF | Adobe PDF数据格式 | pdf
PPT | Microsoft Power Point数据格式 | ppt;pps
RTF | Rich Text数据格式 | rtf
XML | XML数据格式 | xml
MP3 | MP3数据格式 | mp3

数据格式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件或其附加文件的数据格式的步骤如下：

1. 检查控制文件中FILE_SUFFIX_PRIOR变量的值是否被设置成TRUE，如果是，则继续步骤2，否则转到步骤4。
2. 检查文件是否有文件名后缀，如果有，则继续步骤3，否则转到步骤4。
3. 通过文件名后缀，获取其对应的数据格式控制符。如果文件名后缀存在对应的数据格式控制符，则该数据格式控制符就确定了字段值文件或其附加文件的数据格式，否则进行出错处理。
4. 默认该字段值文件或其附加文件为文本数据。


存储方式控制符

存储方式控制符用来控制字段值文件及其附加文件在数据库中的存储方式，如CLASS和DUMB等等（不区分大小写）。对于同一个文件，不能同时使用多个存储方式控制符来控制。

TRS系统所支持的存储方式控制符有：

控制符 | 存储方式
ALONE | 以独立的文件形式存储
CLASS | 将文件内容集中存储到数据库的按字段类型分类的文件中
URL | 文件名为一个URL，在数据库中存储这个URL
LINK | 文件名为一个URL，在数据库中存储这个URL（与URL相同）
BASE | 说明一个URL为HTML文件中BASE元素的HREF属性值
DUMB | 只存储文件的数据格式等信息，不存储数据

除此之外，系统内部还有一种缺省的存储方式，即集中存储方式。这种方式是将所有数据全部存储在数据库的主文件中。

存储方式控制符可以省略（其引导符也同时省略），在这种情况下，确定一个字段值文件的存储方式的步骤如下：

  • 检查控制文件中CLASS_DOCUMENT_STORE变量的值是否被设置成TRUE，如果是，则按分类方式存储字段值文件，否则转到步骤2。
  • 按系统缺省的存储方式来存储字段值文件。

在省略存储方式控制符的情况下，确定一个字段值附加文件的存储方式的步骤如下：

1. 检查控制文件中WAIVE_DOCUMENT_AFFIX变量的值是否被设置成TRUE，如果是，则按DUMB方式字段值附加文件，否则转到步骤2。
2. 检查控制文件中CLASS_DOCUMENT_STORE变量的值是否被设置成TRUE，如果是，则按分类方式存储字段值附加文件，否则转到步骤3。
3. 按系统缺省的存储方式来存储字段值附加文件。


控制文件的格式

控制文件是指存放那些用以控制数据加载过程的变量配置文件。这个文件是在进行数据加载前由用户编写的。

控制文件的一些基本特性是：

  • 控制文件是一个ASCII文本文件。
  • 一行只能指定一个变量，其格式为：变量名 = 变量值。其中“变量名”、“=”不能省略，“变量名”和“变量值”的的字符串不包括其首尾的空白字符。如果“变量值”省略，则等同于该变量未出现在控制文件中。
  • 变量在文件中的顺序无关。
  • 变量名不区分大小写。除了特别说明的外，变量值也不区分大小写。
  • 在控制文件中，并不是所有的控制变量都必须出现，实际上只需给出那些实际变量值与其缺省值不一致的控制变量。如果用户在数据加载时未指定控制文件，或者只给出了部分控制变量，而那些未出现的控制变量存在缺省值，则系统将自动取其缺省值。
  • 以单字节字符‘#’开始的行为注释行。注释行可以放在任何位置，但必须是单独一行。
  • 如果用户在数据加载时未指定控制文件，系统将取所有变量的缺省值。

下面是一个控制文件的例子：

#This is the control file of loading PeopleDaily database.
RECORD_FILE_FORMAT = STANDARD
BIT_FORMAT_DEFAULT = IMAGE
DATA_PATH_DEFAULT = D:\DATA
DATE_CENTURY_DEFAULT = 19
IGNORE_RECORD_CRYPT = NO
FILE_SUFFIX_PRIOR = OFF
SYNC_CREATE_INDEX = YES
CLASS_BIT_STORE = TRUE
CLASS_DOCUMENT_STORE = TRUE
WAIVE_DOCUMENT_AFFIX = FALSE
KEEP_TEXT_ACTUAL = FALSE
CHECK_TEXT_ITERATIVE = FALSE
MULTI_VALUE_SEPARATER = ;
SECTION_TAG_PREFIX = $$TRSTAG$$
START_RECORD_FROM = 1
PROCESS_RECORD_NUMBER = 50000
MAX_COMMIT_NUMBER = 1000
MAX_ERROR_NUMBER = 1000
COLUMN_NAME_SEQUENCE = 日期;版次;版名;作者;标题;正文;图像


控制文件的变量

控制文件中的变量包括：

变量名 | 说明 | 缺省值
RECORD_FILE_FORMAT | 数据记录文件的格式 | 标准
BIT_FORMAT_DEFAULT | 数据记录文件中BIT字段值文件的缺省数据格式名 | BIT
HTML_BASE_DEFAULT | HTML数据文件中BASE元素的缺省HREF属性值 | 无
DATA_PATH_DEFAULT | 数据记录文件中字段值所引用的数据文件的缺省路径 | 当前数据文件
DATE_CENTURY_DEFAULT | 数据记录文件中DATE字段值的年份的缺省世纪数 | 当前世纪数
IGNORE_RECORD_CRYPT | 是否忽略数据记录文件中的记录加密描述符的开关 | FALSE
FILE_SUFFIX_PRIOR | 当数据记录文件中所引用的字段值文件未指定数据格式控制符时，用文件名的后缀来确定其数据格式的开关 | TRUE
SYNC_CREATE_INDEX | 在加载数据的同时建立索引的开关 | TRUE
CLASS_BIT_STORE | 是否分类存储BIT字段值的开关 | TRUE
CLASS_DOCUMENT_STORE | 是否分类存储DOCUMENT字段值的开关 | TRUE
WAIVE_DOCUMENT_AFFIX | 在数据记录文件中，DOCUMENT字段值的附加文件是否存储在数据库中的开关 | FALSE
WAIVE_OEMFILTER_TEXT | 是否丢弃由OEM过滤器所生成的文本数据的开关 | TRUE
KEEP_TEXT_ACTUAL | 是否保持PHRASE和DOCUMENT字段值文本中首尾空白行的开关 | TRUE
CHECK_TEXT_ITERATIVE | 是否允许在数据记录文件中同一个PHRASE或DOCUMENT字段在同一个记录中重复出现的开关 | FALSE
MULTI_VALUE_SEPARATER | 数据记录文件中多值字段DATE、NUMBER、CHAR、BIT的各个字段值之间的分隔符 | 单字节‘;’
START_RECORD_FROM | 在数据记录文件中数据加载的起始记录号 | 1
SECTION_TAG_PREFIX | TRS标记引导符前缀 | 无
PROCESS_RECORD_NUMBER | 需要加载的最大记录数 | 全部
MAX_COMMIT_NUMBER | 加载时分批提交的最大记录数 | 5000
MAX_ERROR_NUMBER | 加载时允许错误记录的最大个数 | 最大
COLUMN_NAME_SEQUENCE | 需要加载数据的字段名列表 | 全部
XML_SEGMENT_MARK | 数据作为一个字段值入库时，过滤器进行自动分段的标记 | 无
XML_NEWLINE_MARK | 数据作为一个字段值入库时，过滤器进行自动换行的标记 | 无
XML_HITSHOW_MARK | 数据作为一个字段值入库后，检索命中点的指示标记 | 无
XML_FILTER_CDATA | 数据作为一个字段值入库时，过滤器是否处理标记中的内容 | FALSE
XML_OVERWRITE_PI | 数据作为一个字段值入库时，是否需要覆盖数据中已有的关于过滤器的处理指令 | FALSE
COLUMN_AUTO_MATCH | 是否允许自动匹配入库字段 | FALSE
NAMIZE_ISO2709_FIELD | 是否以ISO2709格式的目录标记（以及数据标识符）映射入库字段 | FALSE

在控制文件中，并不是所有的控制变量都必须出现，实际上只需给出那些实际变量值与其缺省值不一致的控制变量。

·RECORD_FILE_FORMAT
该变量指明数据记录文件的组织格式。TRS支持的数据记录数据格式包括：
名称 | 数据记录格式
STANDARD | 标准格式
IDENTISTD | 字段内部标识号标记格式
SIMPLESTD | 字段顺序号标记格式
SEQUENCE | 无字段标记格式
FULLTEXT | 全文格式
ISO2709 | ISO2709国际标准格式
XML | XML格式
该变量的值必须为上述几种格式名之一。如果控制文件中未包含该变量，则系统取其缺省值，即STANDARD。

·BIT_FORMAT_DEFAULT
该变量指明数据记录文件中，BIT字段引用的字段值文件的缺省数据格式控制符。该变量的值必须是一个当前系统中数据格式词典的一个合法数据格式控制符。该变量只有当FILE_SUFFIX_PRIOR变量的值为FALSE，或者当引用的字段值文件名没有后缀时，才有效。
如果控制文件中未包含该变量，则系统取其缺省值，即BIT。

·HTML_BASE_DEFAULT
该变量指明DOCUMENT字段引用的HTML格式的字段值文件中BASE元素的缺省HREF属性值。该变量只对在DOCUMENT字段上以“简单格式”加载HTML数据时有效，其作用相当于在“典型格式”和“完全格式”中使用显式的BASE控制符。
该变量系统没有缺省值。

·DATA_PATH_DEFAULT
该变量指明数据记录文件中，DOCUMENT和BIT字段引用的字段值文件的缺省路径。该变量的值必须是一个当前用户有权访问的合法的目录。缺省路径名是大小写敏感的，并且路径的子目录分隔符没有‘\’和‘/’之分，这两种符号系统能够自动纠正。
如果控制文件中未包含该变量，则系统取其缺省值，即数据记录文件所在的路径。对于批处理数据加载，其缺省值总是当前正在被处理的数据记录文件所在的路径。因此，该变量总是设置了有效值。

·DATE_CENTURY_DEFAULT
TRS支持多种日期字段的入库格式。有的日期格式允许只给出两位数表示年份（如98）。在这种情况下，需要确定该年份所在的世纪数，通过该变量即可设置这一世纪数。如将变量的值设置为19，则年份98表示1998年。如果设置变量的值为0，则表示日期格式中的年份为绝对年份，如98即表示公元98年。该变量的值必须是一个数字。
如果控制文件中未包含该变量，则系统取其缺省值，即当前世纪数。该变量只对那些小于100的年份有效。必须注意的是：如果年份（如80）大于当前实际年份（如07），则默认位是上一世纪的年份（如1980），而不是本世纪的年份（如2080）。

·IGNORE_RECORD_CRYPT
TRS支持对数据记录进行加密。如果数据记录文件中有加密描述的记录，而又想在本次入库时忽略这些加密描述，即不对记录进行加密，则可通过设置这一变量来完成。如果将变量值设置为TRUE（或YES、或ON、或1），则表示忽略所有记录的加密描述；如果变量值设置为FALSE（或NO、或OFF、或0），则表示对那些有加密描述的记录进行加密。
如果控制文件中未包含该变量，则系统取其缺省值，即FALSE。

·FILE_SUFFIX_PRIOR
在TRS数据记录文件中，支持以引用文件名的形式给出DOCUMENT和BIT字段值，同时支持对这些文件显式地指定其数据格式。当未指定数据格式，而又需要系统通过文件名的后缀来自动识别其文件的数据格式时，可通过设置该变量来触发系统的自动识别功能。如果将变量值设置为TRUE（或YES、或ON、或1），则表示可由文件后缀来确定其数据格式；如果变量值设置为FALSE（或NO、或OFF、或0），则表示按字段类型确定其缺省数据格式。DOCUMENT字段值的缺省数据格式为TEXT，BIT字段值的缺省数据格式为BIT_FORMAT_DEFAULT变量的值。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。该变量只对那些没有显式指定其数据格式的字段值文件有效。

·SYNC_CREATE_INDEX
TRS有两种方式来创建数据库的索引：一种是在加载数据本身的同时建立数据的索引，即同步索引方式；另一种是先只加载数据本身，以后再单独建立数据的索引，既异步索引方式。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示以同步方式建立索引；如果变量值设置为FALSE（或NO、或OFF、或0），则表示以异步方式建立索引。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。 特别注意：如果在向数据库中加载、插入或复制新记录时，指定了“不同步建立索引”，则以后加载、插入或复制的新记录也不会建立索引，无论是否指定了“同步建立索引”；甚至在以后修改数据库记录时，如果因修改了PHRASE或DOCUMENT字段的内容，而需要更换物理记录号时，则更新后的整个记录也不会建立索引。除非使用“创建索引”功能为这些尚未建立索引的记录创建索引，以后加载、插入、复制（“同步建立索引”方式）或修改后的新记录才会建立索引。

·CLASS_BIT_STORE
由于BIT字段的数据一般都是数据量较大的诸如声音、图象以及动画之类的多媒体数据，所以对于BIT字段的数据，TRS允许将其存储到数据库的BIT分类文件中，这样就可以缩小数据库主文件的规模，从而有利于提高检索结果的概览速度。
在数据记录文件中，当以引用文件的形式给出字段值时，如果对这些文件没有显式地定义相应的存储方式控制符，而又要求系统按分类方式存储这些字段值，则可通过设置该变量实现这一功能。该变量同样能够控制那些直接放在数据记录文件中文本类型的字段值的存储方式。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示将字段值存储到数据库的BIT分类文件中；如果变量值设置为FALSE（或NO、或OFF、 或0），则表示将字段值集中存储到数据库的主文件中。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。该变量只对那些没有明确指定存储方式的BIT字段的字段值有效。

·CLASS_DOCUMENT_STORE
虽然DOCUMENT字段的数据的数据量一般不是很大，但通常不用于概览，所以从有利于提高检索结果的概览速度的角度出发，TRS也允许将其存储到数据库的DOCUMENT分类文件中，以缩小数据库主文件的规模，达到加速概览的目的。
在数据记录文件中，当以引用文件的形式给出的字段值时，如果没有对这些文件显式地定义相应的存储方式控制符，而又要求系统按分类方式存储这些字段值，则可通过设置该变量实现这一功能。该变量同样能够控制那些直接放在数据记录文件中文本类型的字段值的存储方式。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示将字段值存储到数据库的DOCUMENT分类文件中；如果变量值设置为FALSE（或NO、或OFF、或0），则表示将字段值集中存储到数据库的主文件中。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。该变量只对那些没有明确指定存储方式的DOCUMENT字段的字段值有效。

·WAIVE_DOCUMENT_AFFIX
为了完成对非TEXT、HTML和XML格式的数据进行索引，在没有配置OEM过滤器，或者OEM过滤器不支持所给出的文件的格式情况下，TRS要求外部为其提供一个TEXT、或者HTML、或者XML格式的附加数据文件。对于那些没有明确指定存储方式的附加文件，其存储方式系统将参考该变量和CLASS_DOCUMENT_STORE变量的设置情况综合确定。
如果将该变量的值设置为TRUE（或YES、或ON、或1），则表示数据库中不存储这个附加文件；如果变量值设置为FALSE（或NO、或OFF、或0），则表示数据库中存储这个附加文件，存储方式由CALSS_DOCUMENT_SOTRE变量的设置确定。
如果控制文件中未包含该变量，则系统取其缺省值，即FALSE。该变量只对那些没有明确指定存储方式的DOCUMENT字段值的附加文件有效。

·WAIVE_OEMFILTER_TEXT
TRS支持配置OEM过滤器自动抽取OFFICE文档的文本数据以建立索引。该变量确定将这些文本数据是否存储到数据库中。
如果将该变量的值设置为TRUE（或YES、或ON、或1），则表示数据库中不存储这些文本数据；如果变量值设置为FALSE（或NO、或OFF、或0），则表示数据库中存储这些文本数据，此时，如果源数据的存储方式为URL或LINK，则存储方式取决于变量CLASS_DOCUMENT_STORE的值；如果源数据的存储方式为DUMB，则存储方式取决于变量CLASS_DOCUMENT_STORE的值，并且可达到只存储文本数据，而不存储源文档数据的应用效果；如果源数据采用其它存储方式，则其存储方式与源数据的相同。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。

·KEEP_TEXT_ACTUAL
对于PHRASE和DOCUMENT的文本类型字段值而言，位于其首尾的空白行是无用的，如果需要在数据加载时将它们去掉，则可通过设置该变量来触发系统完成对首尾空白行的过滤。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示保持字段值文本的原样；如果变量值设置为FALSE（或NO、或OFF、或0），则表示过滤字段值文本的首尾空白行。
如果控制文件中未包含该变量，则系统取其缺省值，即TRUE。

·CHECK_TEXT_ITERATIVE
PHRASE和DOCUMENT字段不支持多值。但在数据记录文件中，可能会有各种原因，使得在一个记录中同一个PHRASE或DOCUMENT字段出现一次以上。对于这种情况，系统缺省的处理方式是只保留最后出现的字段值。通过设置该变量可以强制系统进行检查，当发现这种情况时进行错误处理，或者将其合并成一个字段值。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示一个记录中如果多次出现同一个PHRASE或DOCUMENT字段，则认为该记录的数据是错误的，进行错误处理；如果变量值设置为FALSE（或NO、或OFF、或0），则表示按系统的缺省方式进行处理。
如果将变量值设置为JOIN0、或JOIN1、或JOIN2，则表示将多次出现的PHRASE或DOCUMENT字段值进行合并，并在这些值之间分别插入0到2个（取决于JOIN后面的数字）换行符。需要注意的是：只要DOCUMENT字段有一个值是引用的外部文件，就不能进行字段值的合并，而是进行错误处理。
如果控制文件中未包含该变量，则系统取其缺省值：如果数据记录文件的格式是ISO2709或XML，则缺省值为JOIN1，否则为FALSE。

·MULTI_VALUE_SEPARATER
该变量用来给出数据记录文件中，DATE、NUMBER、CHAR以及BIT多值字段的各个值之间所采用的分隔符。多值分隔符既可以是单个字符，也可以是多个字符（如全角字符‘；’），但最多为8个字符，并且大小写敏感。空格不能作为多值分隔符。
如果控制文件中未包含该变量，则系统取其缺省值，即单字节分号‘;’。

·SECTION_TAG_PREFIX
该变量指定TRS格式文件中TRS标记引导符的前缀。TRS支持标记引导符前缀的目的就是要排除数据中的干扰，所以标记引导符前缀应该选择一个在数据中不会出现的字符序列，至少不会在一行的开头出现。一个引导符前缀的最大长度为30个字符，并且其首尾的空白字符将被忽略，即首尾的空白字符不是引导符前缀的有效部分。
该变量系统没有缺省值。

·START_RECORD_FROM
该变量指定从数据记录文件中第几个记录开始加载。对于批处理方式，该变量只对第一个数据记录文件有效，对于其他数据记录文件，总是从第一个记录开始加载。
如果控制文件中未包含该变量，则系统默认从第1个记录开始加载。如果设置该变量，则其值必须大于0。

·PROCESS_RECORD_NUMBER
该变量指定要处理的总记录数，包括加载成功的记录和错误记录。如果控制文件中未包含该变量，则系统默认加载给出的所有数据记录文件中的全部记录。如果设置该变量，则其值必须大于0。

·MAX_COMMIT_NUMBER
该变量就是通常所说“最大提交数”。一个数据记录文件往往包含许多记录，系统总是将这些记录分批地加载到数据库中，该变量就是用来设定每批加载的最大记录数的。每一批实际加载多少个记录，系统内部还需要根据机器内存的大小综合考虑，但不会超过这一数。
最大提交数与数据的加载速度有一定的关系，合适的值会提高加载速度，反之则减慢加载速度，尤其是在数据库采用按字索引策略或二元组索引策略的情况下更为突出。对不同的数据有不同的最佳值，一般选在2000到6000之间比较合适，以5K字节大小为参考，数据记录较大时使用较小的数，数据记录较小时使用较大的数。
如果控制文件中未包含该变量，则每一批实际加载的记录数由系统完全根据机器内存的大小自动确定。

·MAX_ERROR_NUMBER
该变量指定：如果在加载过程中所遇到的错误记录数超过了这一数，则结束加载过程。如果控制文件中未包含该变量，则系统默认加载过程不受错误记录数的控制。如果设置该变量，则其值必须大于0。

·COLUMN_NAME_SEQUENCE
该变量用来指定需要加载数据的字段名（或别名）列表，字段名之间用单字节的分号‘;’、逗号‘,’或空格分隔。在下列几种情况下需要设置该变量：
只需从数据记录文件中加载部分数据库字段的值。
☆ 数据记录文件的记录中存在不属于当前加载的数据库的字段。
☆ 数据记录文件的格式为SIMPLESTD或SENQUENCE或ISO2709，而数据记录文件的记录中字段的顺序与数据库字段的物理顺序（即输出时的顺序）不一致。
☆ 数据记录文件的格式为FULLTEXT，而加载的目标字段不是数据库的最后一个DOCUMENT字段；或者数据库没有DOCUMENT字段，而加载的预期字段不是数据库的最后一个PHRASE字段。
对于同一个字段，如果这里给出的是字段名，则数据文件中只能用字段名作为"字段标记"；如果这里给出的是字段别名，则数据文件中不能用其它字段别名作为"字段标记"，但字段名始终可以"字段标记"；除非将变量COLUMN_AUTO_MATCH设置为TRUE。
该变量的系统缺省值要依数据格式而定：当数据格式为FULLTEXT时，如果数据库存在DOCUMENT字段，则取数据库的最后一个DOCUMENT字段，如果数据库存在PHRASE字段，则取数据库的最后一个PHRASE字段，其他情况则不能进行数据加载；对于其他数据格式，则取数据库的所有字段，并按其物理顺序排列。

·XML_SEGMENT_MARK
该变量用来指定XML数据作为一个字段值入库时，通知过滤器进行自动分段的标记，它必须是这个XML数据中的一个有效的以成对方式出现的标记。在这一标记对之间的数据为一自然段落。一般情况下，为了控制XML数据的显示效果，通常会在XML数据中插入必要的标记以使相应的解释器进行分段处理，这样的标记就可作为变量XML_SEGMENT_MARK的值，注意该标记的大小写是敏感的，最大长度是60个字符。
在一个段落中，过滤器将忽略所有的回车换行符，以避免一个词被TRS分词系统中的换段规则所打断而无法检索。
该变量系统没有缺省值。在没有分段标记的情况下，系统将根据内部规则，按“换行”状态自动确定文本的段落。对于那些游离于所有分段标记对之外的内容也按这种方式处理。

下面举一个例子：
<paragraph id="d11">
存储器可以存放最后一次接受的参考生物特征图像。存储器可以<br/>
存放过去输入的多个的参考生物特征图像，其包括以前接受的生物特<br/>
<!-- 1 -->
<dp n="d1"/>
征图像。确定器可以计算输入生物特征图像和各参考生物特征图像之<br/>
间的相似程度，当所有计算的相似程度小于预定阈值时，确定器确定<br/>
输入的生物特征图像可以接受。<br/>
</paragraph>
在这个例子中，标记"paragraph"是XSL用来进行换段控制的，所以我们就将XML_SEGMENT_MARK变量指向这个标记。如果不设置该变量，过滤器无论如何处理，其中第三个"特征"将不能被检索。

·XML_NEWLINE_MARK
该变量用来指定XML数据作为一个字段值入库时，通知过滤器进行自动换行的标记，它必须是该XML数据中的一个有效标记，否则过滤器将不会输出任何换行符（因为不可能遇到这个标记）。一般情况下，为了控制XML数据的显示效果，通常会在XML数据中插入必要的标记以使相应的XML浏览器进行换行，这样的标记就可作为变量XML_NEWLINE_MARK的值，注意该标记的大小写是敏感的，最大长度是60个字符。如"br"标记。
如果设置了变量XML_NEWLINE_MARK，过滤器将忽略XML数据中的回车换行符，而在遇到由该变量所指定的标记时才进行自动换行，否则将以XML数据中原有的回车换行符作为过滤器的换行符。但正如4.2.22节所说明的，过滤器将忽略处在变量 XML_SEGMENT_MARK所指定的段落标记中的换行标记，以及XML数据中原有的回车换行符。
与指定分段标记一样，指定换行标记也有避免一个词被TRS分词系统中的换段规则所打断而无法检索的作用。
该变量系统没有缺省值。但是，如果在XML文件中定义了DTD，且DOCTYPE为TRS，DOCTYPE的子元素为REC的前提下，将“br”定义成一个“空”元素，即定义：，则取br标记作为该变量的缺省值（请参见2.2）。除此之外，系统将以XML文件中的自然换行符作为文本的换行符。

·XML_HITSHOW_MARK
该变量用来指定XML数据作为一个字段值入库后，指示检索命中点的标记。这个标记有以下几个特点：
☆ 其大小写是敏感的，并且被浏览器所识别，最大长度是60个字符。
☆ 在入库前，XML数据中并不存在这个标记。
☆ 在检索时，由TRS系统自动在输出的XML数据中插入。
☆ 标记以成对方式出现：在命中点之前插入起始标记，在命中点之后插入结束标记。
☆ 在起始标记中可能会出现一个名为"ID"的属性，其值为命中点的从"1"开始计数的序号。没有出现这个属性的起始标记，说明是一个命中点被其它标记所打断后的重新开始。属性值也有为"-1"的情况。
该变量系统没有缺省值。

下面举一个例子：
<paragraph id="d11">
存储器可以存放最后一次接受的参考生物<TRSHL ID="1">特征</TRSHL>图像。存储器可以<br/>存放过去输入的多个的参考生物<TRSHL ID="2">特征</TRSHL>图像，其包括以前接受的生物<TRSHL ID="3">特</TRSHL><br/>
<!-- 1 -->
<dp n="d1"/>
<TRSHL>征</TRSHL>图像。确定器可以计算输入生物<TRSHL ID="4">特征</TRSHL>图像和各参考生物<TRSHL ID="5">特征</TRSHL>图像之<br/>间的相似程度，当所有计算的相似程度小于预定阈值时，确定器确定<br/>输入的生物<TRSHL ID="6">特征</TRSHL>图像可以接受。<br/>
</paragraph>
在这个例子中，"TRSHL"是由XML_HITSHOW_MARK变量指定标记。注意其中第三个"特征"命中点被其它标记所打断。"TRSHL"标记在XSL中可以用下面的方式进行处理（用红色反显）：
<xsl:template match="TRSHL">
<font color="red"><xsl:value-of select="."/></font>
</xsl:template>

·XML_FILTER_CDATA
该变量用来指定XML数据作为一个字段值入库时，过滤器是否处理CDATA标记部分的内容。一般情况下，CDATA数据不需要（或者说不能）进行索引，但有的XML数据中的CDATA部分也要求能被检索，有时还要求标记命中点。
☆ 如果将变量XML_FILTER_CDATA设置成FALSE（或NO、或OFF、或0），则表示不过滤CDATA数据中的任何标记，所有内容及标记都建立索引。检索结果输出时，如果其中有命中点，则由XML_HITSHOW_MARK变量所指定的命中点标记不是直接在CDATA数据中插入，而是在其结束符后插入一个空标记（标记之间没有任何数据），其"ID"属性的值为"-1"。
☆ 如果设置成TRUE（或YES、或ON、或1），则表示过滤CDATA数据中的所有标记，只索引CDATA数据中非标记部分。检索命中点的输出方式与取值为FALSE时相同。
☆ 如果设置成HIT，则表示过滤CDATA数据中的所有标记，只索引CDATA数据中非标记部分。检索结果输出时，如果其中有命中点，则由XML_HITSHOW_MARK变量所指定的命中点标记直接在CDATA数据中的准确位置插入。
☆ 如果设置成ROW，则表示不过滤CDATA数据中的任何标记，但去掉所有回车换行符和多余的空白符，全部有效内容及标记都在一行上进行索引。检索命中点的输出方式与取值为FALSE时相同。
☆ 如果设置成ANY，则表示去掉CDATA数据中的全部内容，即任何内容（标记和非标记）都不建立索引。
该变量的缺省值为FALSE。

·XML_OVERWRITE_PI
该变量用来指定XML数据作为一个字段值入库时，是否需要覆盖XML数据中已有的关于过滤器的处理指令。
为了能够在XML中准确指示检索命中点的位置，命中点跟踪器也需要使用过滤器完全一致的参数，所以TRS系统会根据控制文件给出的各个相关变量，在XML数据入库时，自动插入一条XML处理指令。XML过滤器以及跟踪器都将引用这条处理指令，其格式如下：
<?trs-parser ATTRIBUTE?>

ATTRIBUTE由下列一个或多个分项组成：
☆ SegmentMark = "Mark"。其中"Mark"是由变量XML_SEGMENT_MARK指定的段落标记，大小写有关，最大长度是60个字符。没有缺省值。
☆ NewLineMark = "Mark"。其中"Mark"是由变量XML_NEWLINE_MARK指定的换行标记，大小写有关，最大长度是60个字符。没有缺省值。
☆ HitShowMark = "Mark"。其中"Mark"是由变量XML_HITSHOW_MARK指定的命中点指示标记，大小写有关，最大长度是60个字符。没有缺省值。
☆ FilterCData = "Mode"。其中"Mode"的取值包括："no"、"yes"、"hit"、"row"以及"any"，分别对应于变量XML_FILTER_CDATA的取值："FALSE"、"TRUE"、"HIT"、"ROW"和"ANY"。缺省值为"no"。其中"no"可用"FALSE"、"OFF"、"0"替代；"yes"可用"TRUE"、"ON"、"1"替代。

你也可以手工创建或修改这条指令，但必须注意ATTRIBUTE的书写要遵循XML的规范，分项之间用空格分隔，给出的每个分项都必须是完整的。指令中，作为属性值的标记名是区分大小写的，其他字符则是大小写无关的。指令必须出现在XML的DTD部分之前，并只允许出现一次。下面是一个例子：
<?xml version="1.0" encoding="GB2312"?>
<?xml-stylesheet type="text/xsl" href="xsl0117.xsl"?>
<?trs-parser segmentmark=" paragraph" newlinemark="br" hitshowmark="trshl"?>
<!DOCTYPE patent SYSTEM "dtd0117.dtd">
……
在一般情况下，如果过滤器发现XML数据中已经有了这条处理指令，无论其属性如何，都会优先使用指令中给出的属性参数，而忽略控制文件给出的变量值。但是，有的情况可能需要用控制文件中给出的变量值重新构造这条处理指令。
如果将变量XML_OVERWRITE_PI设置成FALSE（或NO、或OFF、或0），则表示不覆盖XML数据中已有的过滤器处理指令；如果将其设置成TRUE（或YES、或ON、或1），则表示重新构造并覆盖XML数据中已有的过滤器处理指令。
该变量的缺省值为FALSE。

·COLUMN_AUTO_MATCH
为了方便，无论COLUMN_NAME_SEQUENCE变量设置与否，有时都需要TRS在数据入库时，能够根据数据中的实际给出的"字段标记"自适应地与数据库字段进行映射。这个功能只要将COLUMN_AUTO_MATCH变量设置成TRUE（或YES、或ON、或1）即可实现，此时COLUMN_NAME_SEQUENCE变量的唯一作用是指明哪些字段需要加载数据。但是这个功能有些情况会影响系统性能：在数据中存在错误的"字段标记"；同一个字段的多个别名混合使用，同时作为"字段标记"。因此一般情况不建议使用该功能。
如果变量值设置为FALSE（或NO、或OFF、或0），则表示不允许TRS系统自适应地进行字段映射：当COLUMN_NAME_SEQUENCE变量被设置时，只有出现在列表中的"字段标记"所标记的数据才会被加载；当COLUMN_NAME_SEQUENCE变量缺省时，只有数据库的字段名所对应"字段标记"才是合法的。
如果控制文件中未包含该变量，则系统取其缺省值，即FALSE。

·NAMIZE_ISO2709_FIELD
对于ISO2709格式的入库，缺省情况是：ISO2709格式中的"目录项标记"对应于COLUMN_NAME_SEQUENCE变量（或缺省值）给出的字段列表中的字段所在的顺序号。通过NAMIZE_ISO2709_FIELD的设置可以改变这种映射关系。
如果将变量值设置为TRUE（或YES、或ON、或1），则表示将ISO2709格式中的"目录项标记"（如"010"）将对应于数据库字段的字段名或别名（如字段名或别名为"010"的字段）；同时还支持抽取数据域的各个子项分别单独入库，即将"目录项标记"（如"010"）与数据域的各个子项标识符（如"a"）进行结合，形成一个"子字段名"（如"010a"），如果在入库目标字段列表中存在该字段名，则对应的数据子项将单独加载到这个数据库字段中。另外，由于数据库的字段名是不区分大小写的，当子项标识符是一个大写字母时，必须按特殊规则处理：将"目录项标记"（如"010"）与数据子项标识符（如"A"）进行结合时用下划线进行连接（如"010_A"），因此其对应的数据库字段名或别名也必须遵循这一规则。如果使用字段的别名，则必须在控制文件中用COLUMN_NAME_SEQUENCE变量列出所有需要加载数据的字段所对应的别名，除非设置COLUMN_AUTO_MATCH变量为TRUE。
如果变量值设置为FALSE（或NO、或OFF、或0），则表示格式中的"目录项标记"域是该字段在控制文件字段列表中的序号（从1开始计数）。
如果控制文件中未包含该变量，则系统取其缺省值，即FALSE。


日期的入库格式

日期的入库格式有通用格式、英文格式、无分隔符格式和中文格式四种类型。

·通用格式
Year[/Month[/Day[/Hour[/Minute[/Second]]]]][A[M]]
[Year]/Month[/Day[/Hour[/Minute[/Second]]]][A[M]]
[Year]/[Month]/Day[/Hour[/Minute[/Second]]][A[M]]
[Year]/[Month]/[Day]/Hour[/Minute[/Second]][A[M]]
[Year]/[Month]/[Day]/[Hour]/Minute[/Second][A[M]]
[Year]/[Month]/[Day]/[Hour]/[Minute]/Second[A[M]]

其中：
☆ Year为四位表示的年(如1998)或者二位表示的年(如98)。
☆ Month、Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ A/M可用P/PM替换。A/AM表示上午，P/PM表示下午，大小写无关。如果它们出现在格式中，则“Hour”不能缺省。
☆ 单字节除号‘/’分隔符可分别用单字节的逗号‘,’、句号‘.’、冒号‘:’、减号‘-’以及空格任意替代。
☆ 用方括号引起的部分表示可以省略（模糊日期）。
☆ Year、Month、Day、Hour、Minute、Second都可以用一个或多个单字节的问号‘?’、百分号‘%’替代，表示模糊日期。

·英文格式
Month[Day[,Year[ Hour[:Minute[:Second]]]]][A[M]]
Month[Day],Year[ Hour[:Minute[:Second]]][A[M]]
Month[Day],Year[ Hour]:Minute[:Second][A[M]]
Month[Day],Year[ Hour]:[Minute]:Second[A[M]]
[Day-]Month[-Year[ Hour[:Minute[:Second]]]][A[M]]
[Day-]Month[-Year[ Hour]:Minute[:Second]][A[M]]
[Day-]Month[-Year[ Hour]:[Minute]:Second][A[M]]
DayMonthYear[ Hour[:Minute[:Second]]][A[M]]
DayMonthYear[[ Hour]:Minute[:Second]][A[M]]
DayMonthYear[[ Hour]:[Minute]:Second][A[M]]

其中：
☆ Year为四位表示的年(如1998)或者二位表示的年(如98)。
☆ Month为英文表示的月份：Jan. Feb. Mar. Apr. May Jun. Jul. Aug. Sept. Oct. Nov. Dec.；或：January February March April May June July August September October November December。
☆ Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ A/M可用P/PM替换。A/AM表示上午，P/PM表示下午，大小写无关。如果它们出现在格式中，则“Hour”不能缺省。
☆ Year与Hour之间用单字节空格分隔；‘,’‘:’‘-’分别为单字节的逗号、冒号、减号。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

·无分隔格式
Year[MonthDay[Hour[Minute[Second]]]]]
YY[MonthDay]

其中：
☆ Year为四位表示的年(如1998)；YY为二位表示的年份(如98)。
☆ Month、Day、Hour、Minute、Second分别为二位表示的月、日、时、分、秒。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

·中文格式
中文格式包括所有用全角字符表示的上述几种格式，另外还支持如下的格式：
[Year年][Month月][Day日][Hour时][Minute分][Second秒][上午]

其中：
☆ Year为四位表示的年(如1998或一九九八或壹玖玖捌)或者二位表示的年(如98或九八或玖捌)。其中数字既可为半角，也可为全角。
☆ Month、Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ 格式中“上午”可用“下午”替换。如果“上午”或“下午”出现在格式中，则“Hour时”不能缺省。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

另外，还支持$DATE和$TIME特殊日期（不区分大小写）的入库，其中前者表示当前日期的“年月日”，后者表示当前日期的“年月日时分秒”。


表达式

TRS的表达式分为统计表达式和检索表达式两种，表达式由键值、运算符、函数等元素组成，用于数据库/视图检索、记录更新和记录维护等操作中。

TRS既支持在 DATE 、 NUMBER 和 CHAR 字段上通过键值进行数据库查询，同时也支持在 PHRASE和DOCUMENT 字段上用任意自由词、词串以及数值进行检索，此外还支持特殊键值的检索。

TRS的运算符有7类，分别是：算术运算符、比较运算符、逻辑运算符、重复逻辑运算符、属性运算符、限定运算符和加权运算符。运算符不区分大小写，共计28种，其中部分运算符有其等价运算符。算术运算符只能在统计运算表达式中使用，而其他运算符只能在检索表达式中使用。运算符与字段之间有一定的适用关系规则，所有的运算符都不能作用于BIT字段。

TRS的函数有统计函数和检索函数两种，共29个。其中统计函数用于统计表达式中，检索函数用于检索表达式中。


统计表达式

统计表达式分为两类：

一类是计算总的命中结果记录数。这是缺省形式，其表示非常简单，只有一个单字节的星号‘*’。另一类是对NUMBER型字段在命中结果集上进行算术运算。这类统计表达式较为复杂，下面将详细说明其表达式的结构。

·“统计表达式”的组成：
☆ *
☆ 子统计表达式
☆ 子统计表达式, 子统计表达式, ……, 子统计表达式
其中，单字节的逗号‘,’是一种语法符号，是“统计表达式”的一部分，用于分隔多个“子统计表达式”。省略号“……”表示可有多个“子统计表达式”。每个“子统计表达式”都会有一个统计结果。

·“子统计表达式”的组成：
☆ 数值
☆ 统计函数
☆ -子统计表达式
☆ (子统计表达式)
☆ 子统计表达式 ArithOP 子统计表达式
“子统计表达式”的组成具有自递归的特点。其中“ArithOP”代表所有的算术运算符。单字节的‘-’是一元“负”运算。单字节的括号‘(’和‘)’用以改变运算优先级，括号中的“子统计表达式”优先计算。

·统计表达式中算术运算符的优先级为：(同级运算遵循左结合律)
高 (、)
-(负数)
*、/、%
低 +、-


检索表达式

检索表达式的构成非常复杂，总的来说包含这样一些基本要素：检索健值、检索函数、检索历史引用、物理记录号、检索健值列表、物理记录号列表以及各种运算符。

·“检索表达式”的组成：
☆ 逻辑运算表达式
☆ 限定运算表达式

·“逻辑运算表达式”的组成：
☆ 检索键值
☆ 检索函数
☆ @检索历史号
☆ DOCID CompOP 记录号
☆ DOCID = 记录号列表
☆ DOCID != 记录号列表
☆ ENTRY CompOP 检索键值
☆ ENTRY = (字段逻辑表达式)
☆ ENTRY != (字段逻辑表达式)
☆ ENTRY, ENTRY, ……, ENTRY RepeatOP 检索键值
☆ ENTRY, ENTRY, ……, ENTRY RepeatOP (字段逻辑表达式)
☆ 逻辑运算表达式 LogicOP 逻辑运算表达式
☆ (逻辑运算表达式)
☆ 限定运算表达式

“检索表达式”的组成具有自递归的特点。其中，“ENTRY”是字段名或字段别名，单字节的逗号‘,’是语法符号，是“检索表达式”的一部分，用于分隔多个“ENTRY”，省略号“……”表示可有多个“ENTRY”。“CompOP”代表所有的比较运算符。“RepeatOP”代表所有的重复逻辑运算符。“LogicOP”代表所有的逻辑运算符。

·“字段逻辑表达式”的组成：
☆ 检索键值
☆ 检索函数
☆ 检索键值列表
☆ 字段逻辑表达式 LogicOP 字段逻辑表达式
☆ (字段逻辑表达式)
☆ 限定运算表达式

“字段逻辑表达式”的组成具有自递归的特点。其中，“LogicOP”代表所有的逻辑运算符。

·“检索键值列表”的组成：
☆ 精确检索键值
☆ 精确检索键值 TO 精确检索键值
☆ 检索键值列表, 检索键值列表, ……, 检索键值列表

“检索键值列表”的组成具有自递归的特点。其中，单字节的逗号‘,’是语法符号，是“检索键值列表”的一部分，用于分隔多个“检索键值列表”，省略号“……”表示可有多个“检索键值列表”。“TO”表示一个连续的检索键值区间 ，等价于检索函数BETWEEN[ ]。对于多个键值的检索，应该优先使用“检索键值列表, 检索键值列表, ……, 检索键值列表”或者“精确检索键值 TO 精确检索键值”或者BETWEEN函数的高效形式，而不要采用将多个“ENTRY = 检索键值”子表达式进行逻辑运算的低效形式。

·“记录号列表”的组成：
☆ 记录号
☆ 记录号 TO 记录号
☆ 记录号列表, 记录号列表, ……, 记录号列表

“记录号列表”的组成具有自递归的特点。其中，单字节的逗号‘,’是语法符号，是“记录号列表”的一部分，用于分隔多个“记录号列表”，省略号“……”表示可有多个“记录号列表”。“TO”表示一个连续的记录号区间 。

·“限定运算表达式”的组成：
☆ 检索键值
☆ 检索函数
☆ 检索键值/Limit
☆ 检索函数/Limit(除Range、between、beyond外)
☆ 限定运算表达式 LimitOP 限定运算表达式
☆ (限定运算表达式)

“限定运算表达式”的组成具有自递归的特点。其中，“LimitOP”代表所有的属性运算符。“Limit”代表所有的限定运算符和加权运算符。单字节的括号‘(’和‘)’用以改变运算优先级，括号中的表达式优先计算。

·检索表达式中各种运算符的优先级为：(同级运算遵循左结合律)
高 (、)
=、!=、>、<、>=、<=、*=、^=、-=、+=
adj、equ/n、&/n[#/L]、&/sen[=n]、*/n[#/L]、*/sen[=n]
^/n[#/L]、^/sen[=n]
-/n[#/L]、-/sen[=n]
+/sen=n
&/seg[=n]、&/title、&/text、*/seg[=n]、*/title、*/text
^/seg[=n]、^/title、^/text
-/seg[=n]、-/title、-/text
+/seg=n、+/title、+/text
*/attr[=v]
^/attr[=v]
-/attr[=v]
+/attr=v
*
^
-
低 +

这里需要特别提醒的是：比较运算符（‘=’、‘!=’、‘>’、‘<’、‘>=’、‘<=’）和重复逻辑运算符（‘*=’、‘^=’、‘-=’、‘+=’）的优先级仅次于括号‘(’和‘)’的优先级，因此，如果这些运算符的右边是一个表达式，则必须用括号括起来，否则产生的结果就不是你需要的结果。


算术运算符

作用于NUMBER字段。

符号 含义和作用 举例
* 数值型数据相乘 select sum(salary)*0.10 from person
/ 数值型数据相除 select sum(salary)/20 from person
% 数值型数据求余数 select sum(salary)%20 from person
+ 数值型数据相加 select avg(age)+10 from person
- 数值型数据相减或求负数 select avg(age)-10 from person


比较运算符

作用于NUMBER、DATE、CHAR字段。但‘=’和‘!=’可作用于PHRASE和DOCUMENT字段。

符号 | 含义和作用 | 举例
= 等于 作者=李力
!=或<> | 不等于 | 版面!=国际
> 大于 工资>1000
< 小于 工资<1000
>= 大于等于 工资>=1000
<= 小于等于 工资<=1000
  • 比较运算符的左值必须是一个的检索入口（字段名或其别名）。
  • 比较运算符作用于NUMBER、DATE、CHAR字段。但‘=’和‘!=’可作用于PHRASE和DOCUMENT字段。
  • 只有当字段类型为DATE、NUMBER和CHAR时，比较运算符的右值才可以是一个值列表，并且只有比较运算符‘=’和‘!=’支持右值为一个值列表。
  • 如果检索条件不是单个词，而是一个表达式，则该表达式应该用圆括号“(”和“)”括起来。


逻辑运算符

作用于除BIT之外的所有字段。逻辑运算符不仅能够连接两个检索词，也可以连接两个检索子表达式，从而构造出非常复杂的检索表达式。

符号 含义和作用 举例
and
或 * 		“与”。必须同时满足AND算符联结的检索词（字段检索条件） 中国 * 美国
page=1 and 玫瑰
xor
或 ^ 		“异或”。两个检索词（字段检索条件）只能满足其一 苏联 xor 俄罗斯
not
或 - 		“非”。只出现前一个而不出现后一个检索词（字段检索条件） 中国 - 美国
page=1 not 美国
or
或 + 		“或”。必须至少满足OR算符联结的检索词（字段检索条件）中的一个 中国 + 美国
page=1 or 改革


重复逻辑运算符

作用于除BIT之外的所有字段。

符号 含义和作用 举例
*= 检索各个字段上满足同一条件的记录 c1,c2 *= (中国 * 香港)
^= 检索只有一个字段上满足条件的记录 c1,c2 ^= (中国 * 香港)
-= 检索只有第一个字段满足条件的记录 c1,c2 -= (中国 * 香港)
+= 检索任意字段上同时满足条件的记录 c1,c2 += (中国 * 香港)
  • 重复逻辑运算符的左值必须是由单字节的逗号‘,’分隔的两个或两个以上的检索入口（字段名或其别名）。
  • 重复逻辑运算符实际上是在各个指定的字段上用相同的条件式进行检索后，再在各个字段之间进行指定的逻辑运算。
  • 如果检索条件不是单个词，而是一个表达式，则该表达式应该用圆括号“(”和“)”括起来。


属性运算符

作用于DOCUMENT字段。

符号

含义和作用

举例

adj

两者邻接，前者先出现

中国 adj 香港

equ/n

两者正好相距n个字先后同时出现

中国 equ/10 香港

pre/n

两者相距至多n个字先后同时出现

中国 pre/10 香港

pre/n#

两者正好相距n个字先后同时出现

中国 pre/10# 香港

pre/nL

两者相距至少n个字先后同时出现

中国 pre/10L 香港

pre/pos=n

两者正好相距n个字先后同时出现

中国 pre/pos=10 香港

pre/sen

两者在同一句中先后同时出现

中国 pre/sen 香港

pre/sen=n

两者在指定的句中先后同时出现

中国 pre/sen=1 香港

pre/seg

两者在同一段中先后同时出现

中国 pre/seg 香港

pre/seg=n

两者在指定的段中先后同时出现

中国 pre/seg=1 香港

pre/tit

两者在标题中先后同时出现

中国 pre/tit 香港

pre/txt

两者在正文中先后同时出现

中国 pre/txt 香港

pre/att

两者在指定属性的节点先后同时出现

中国 pre/文 香港

pre/att=v

两者在指定属性值的节点先后同时出现

中国 pre/章=2 香港

pre/att$sub=v

两者在指定特征值的节点先后同时出现

中国 pre/文$色=红 香港

and/n

两者相距至多n个字同时出现

中国 and/10 香港

and/n#

两者正好相距n个字同时出现

中国 and/10# 香港

and/nL

两者相距至少n个字同时出现

中国 and/10L 香港

and/pos=n

两者正好相距n个字同时出现

中国 and/pos=10 香港

and/sen

在同一句中两者同时出现

中国 and/sen 香港

and/sen=n

在指定的句中两者同时出现

中国 and/sen=2 香港

and/seg

在同一段中两者同时出现

中国 and/seg 香港

and/seg=n

在指定的段中两者同时出现

中国 and/seg=2 香港

and/tit

在标题中两者同时出现

中国 and/tit 香港

and/txt

在正文中两者同时出现

中国 and/txt 香港

and/att

在指定属性的节点两者同时出现

中国 and/文 香港

and/att=v

在指定属性值的节点两者同时出现

中国 and/章=2 香港

and/att$sub=v

在指定特征值的节点两者同时出现

中国 and/文$色=红 香港

xor/n

同一句中不能在n个字之内同时出现

中国 xor/10 香港

xor/n#

同一句中不能正好相距n个字同时出现

中国 xor/10# 香港

xor/nL

同一句中不能在n个字之外同时出现

中国 xor/10L 香港

xor/pos=n

同一句中不能正好相距n个字同时出现

中国 xor/pos=10 香港

xor/sen

在同一句中只能出现其一

中国 xor/sen 香港

xor/sen=n

在指定的句中只能出现其一

中国 xor/sen=1 香港

xor/seg

在同一段中只能出现其一

中国 xor/seg 香港

xor/seg=n

在指定的段中只能出现其一

中国 xor/seg=1 香港

xor/tit

在标题中只能出现其一

中国 xor/tit 香港

xor/txt

在正文中只能出现其一

中国 xor/txt 香港

xor/att

在指定属性的节点只能出现其一

中国 xor/文 香港

xor/att=v

在指定属性值的节点只能出现其一

中国 xor/章=2 香港

xor/att$sub=v

在指定特征值的节点只能出现其一

中国 xor/文$色=红 香港

not/n

同一句中不能在n个字之内出现后者

中国 not/10 香港

not/n#

同一句中不能正好相距n个字出现后者

中国 not/10# 香港

not/nL

同一句中不能在n个字之外出现后者

中国 not/10L 香港

not/pos=n

同一句中不能正好相距n个字出现后者

中国 not/pos=10 香港

not/sen

在同一句中只能出现前者

中国 not/sen 香港

not/sen=n

在指定的句中只能出现前者

中国 not/sen=1 香港

not/seg

在同一段中只能出现前者

中国 not/seg 香港

not/seg=n

在指定的段中只能出现前者

中国 not/seg=1 香港

not/tit

在标题中只能出现前者

中国 not/tit 香港

not/txt

在正文中只能出现前者

中国 not/txt 香港

not/att

在指定属性的节点只能出现前者

中国 not/文 香港

not/att =v

在指定属性值的节点只能出现前者

中国 not/章=2 香港

not/att$sub=v

在指定特征值的节点只能出现前者

中国 not/文$色=红 香港

or/sen=n

在指定的句中至少出现一个

中国 or/sen=1 香港

or/seg=n

在指定的段中至少出现一个

中国 or/seg=1 香港

or/tit

在标题中至少出现一个

中国 or/tit 香港

or/att

在指定属性的节点至少出现一个

中国 or/文 香港

or/att=v

在指定属性值的节点至少出现一个

中国 or/章=2 香港

or/att$sub=v

在指定特征值的节点至少出现一个

中国 or/文$色=红 香港

  • 属性运算符只作用于DOCUMENT字段。但adj、X/n、X/n#、X/nL和X/pos=n运算符可作用于PHRASE字段。其中‘X’代表‘pre’、‘and’、‘or’、‘not’和‘xor’，以下同，不再特别说明。
  • 属性运算符X/att、X/att=v以及X/att$sub=v中的att对应一个具体的格式索引属性别名（如果没有别名，则为格式索引属性名，其本身不是一个法定的语法符号，而只是用来说明语法的合法属性的表示符）；sub对应一个具体的格式索引属性的特征别名（如果特征没有别名，则为特征名，其本身不是一个法定的语法符号，而只是用来说明语法的合法特征的表示符），如果这个特征是该格式索引属性所定义的唯一特征，或者是第一个特征，则$sub部分可以省略；v是一个格式索引属性或其特征的值，值的形式与具体的编码方式有关。如果att之前加上“~”符，则表示是属性限定条件的“非”运算，如“and/~att$sub=v”的意义是“两者同时出现，且不满足‘att的sub特征值为v’的条件”。
  • 运算符pre/att、pre/att=v和pre/att$sub=v不是合法的，但att、att=v和att$sub=v可与pos、sen、seg、tit、txt等一起使用，如属性运算符pre/txt/att$sub=v则是合法的。
  • 属性运算符中的“=”可以用其他任意比较运算符替代。但X/att=v和X/att$sub=v中的“=”可以用哪些比较运算符替代，取决于格式索引属性或其特征的编码方式。
  • 属性运算符X/sen=n和X/seg=n中的n，都从0开始计数。
  • 属性运算符X/n[#/L]的隐含条件是它们在同一句中。N的计算方法是位置在前的检索词的词尾到位置在后的检索词的词首之间的字母单词或中文字的个数。其中字母L大小写无关，表示Leastwise。这里X/n等价于X/pos<=n；X/n#等价于X/pos=n；X/nL等价于X/pos>=n。
  • 属性运算符adj等价于pre/0；equ/n等价于pre/n#。运算符adj和equ/n只是为了向下兼容而设计的，应尽量避免使用。
  • 属性运算符X/txt不等价于X/seg>0(或X/seg!=0), 并且不能与/sen[=n]和/n[#/L]属性同时使用。X/txt不要求两个运算对象满足“段号相等”的条件。
  • 属性运算符X/tit等价于X/seg=0。


限定运算符

作用于DOCUMENT字段。

表示符号

含义和作用

使用举例

/pos=n

检索词在指定的位置出现

中国/pos=0

/sen=n

检索词在指定的句中出现

中国/sen=12

/seg=n

检索词在指定的段中出现

中国/seg=10

/tit

检索词在标题中

中国/tit

/txt

检索词在正文中

中国/txt

/att

检索词具有att属性

中国/文

/att=v

检索词具有att属性，且值为v

中国/章=2

/att$sub=v

检索词具有att属性，且sub特征值为v

中国/文$色=红

/frec=n 检索词在记录中的频率必须满足要求 中国/frec>5

/fre=n

输出满足词频数条件的索引词（值）

%/fre>=1000000

/rec=n

输出满足命中数条件的索引词（值）

%/rec>=1000000

  • 限定符/rec=n和/fre=n只能用于输出索引词（或字段值），而不能用于检索，可作用于除BIT之外的所有字段。
  • 限定符/pos=n只用于检索，可作用于DOCUMENT和PHRASE字段，
  • 其它限定符只能用于在DOCUMENT字段上的检索。
  • 限定符/att、/att=v以及/att$sub=v中的att对应一个具体的格式索引属性别名（如果没有别名，则为格式索引属性名，其本身不是一个法定的语法符号，而只是用来说明语法的合法属性的表示符）；sub对应一个具体的格式索引属性的特征别名（如果特征没有别名，则为特征名，其本身不是一个法定的语法符号，而只是用来说明语法的合法特征的表示符），如果这个特征是该格式索引属性所定义的唯一特征，或者是第一个特征，则$sub部分可以省略；v是一个格式索引属性或其特征的值，值的形式与具体的编码方式有关。如果att之前加上“~”符，则表示是限定条件的“非”运算，如“/~att$sub=v”的意义是“检索词不满足‘具有att属性，且sub特征值为v’的条件”。
  • 限定符中的“=”可以用其他任意比较运算符替代。但/att=v和/att$sub=v中的“=”可以用哪些比较运算符替代，取决于格式索引属性或其特征的编码方式。
  • 限定符中的n，都从0开始计数。其中/pos=n中的n是指检索词在句中出现的起始位置，一个字/词在句中的位置的计算规则请参见3.4.1节的说明。限定符/pos=n与属性运算符X/pos=n是有差别的。
  • 限定符/txt等价于/seg>0(或/seg!=0)，并且可以与/sen=n和/pos=n同时使用，这一点与运算符X/txt不同。
  • 限定符/tit等价于/seg=0。


加权运算符

作用于DOCUMENT和PHRASE字段。

表示符号 | 含义和作用 | 使用举例
/n | 指定某个检索词在查询中的权重 | 计算机/10
  • 权重n是一个不小于1的正整数。权重只有在对检索结果进行相关性排序时才能体现出来。
  • 检索词在查询中的缺省权重是1，字段在查询中的缺省权重是0。但对于缺省检索字段，如果其它所有的字段的权重都缺省，则其缺省权重是1；只要有一个字段指定了非0权重，则其缺省权重就是0。权重为缺省值0的字段实际不参与相关性排序。
  • 只有字段允许参与相关性排序时，对该字段的加权才有效。
  • 检索词的权重只对允许参与相关性排序的DOCUMENT或PHRASE字段。在进行相关性排序前，系统需要根据固定的算法自动计算每个检索词对一个命中记录的相关度的作用因子（即贡献率），权重的作用就是用来倍增放大这个词的“作用因子”的。


等价运算符

下表列出了TRS中的所有等价运算符:

常规运算符

!=

ADJ

PRE

AND

XOR

NOT

OR

等价运算符

<>

space

&

*

^

-

+


运算符与字段的关系

各种运算符与字段之间的适用关系如下表：

运算符

DATE

NUMBER

CHAR

PHRASE

DOCUMENT

=

√

√

√

√

√

!=

√

√

√

√

√

>

√

√

√

<

√

√

√

>=

√

√

√

<=

√

√

√

*=

√

√

√

√

√

^=

√

√

√

√

√

-=

√

√

√

√

√

+=

√

√

√

√

√

adj

√

√

equ/n

√

√

pre/n[#/L]

√

√

pre/pos=n

√

√

pre/sen[=n]

√

pre/seg[=n]

√

pre/tit

√

pre/txt

√

pre/[~]att[[$sub]=v]

√

and

√

√

√

√

√

and/n[#/L]

√

√

and/pos=n

√

√

and/sen[=n]

√

and/seg[=n]

√

and/tit

√

and/txt

√

and/[~]att[[$sub]=v]

√

xor

√

√

√

√

√

xor/n[#/L]

√

√

xor/pos=n

√

√

xor/sen[=n]

√

xor/seg[=n]

√

xor/tit

√

xor/txt

√

xor/[~]att[[$sub]=v]

√

not

√

√

√

√

√

not/n[#/L]

√

√

not/pos=n

√

√

not/sen[=n]

√

not/seg[=n]

√

not/tit

√

not/txt

√

not/[~]att[[$sub]=v]

√

or

√

√

√

√

√

or/sen=n

√

or/seg=n

√

or/tit

√

or/txt

√

or/[~]att[[$sub]=v]

√

/pos=n

√

√

/sen=n

√

/seg=n

√

/tit

√

/txt

√

/[~]att[[$sub]=v]

√

/rec=n

√

√

√

√

√

/fre=n

√

√

√

√

√

/n

√

√

  • 表中的“√ ”表示该字段支持这种运算符。
  • 算术运算符不能用于检索表达式，所以任何字段都不支持。
  • 所有运算符都不能作用于BIT字段。
  • 运算符中的‘[’和‘]’（如and/[~]att[[$sub]=v]）不是运算符的一部分，表示被包括的部分可以省略。但省略与否，其运算符的含义是有差别的。


统计函数

统计函数只能用于统计表达式中，有如下5个：

函数名 含义和作用

AVG(字段名)

求数据库中满足条件的记录中某个数值型字段的平均值

MAX(字段名)

求数据库中满足条件的记录中某个数值型字段的最大值

MIN(字段名)

求数据库中满足条件的记录中某个数值型字段的最小值

SUM(字段名)

求数据库中满足条件的记录中某个数值型字段的和

COUNT(*)

用于统计数据库中满足条件的记录有多少

  • 统计函数只能用于统计表达式。
  • 函数参数中的“字段名”也可以使用字段的别名。
  • 只有NUMBER型字段的字段名才能作为统计函数的参数。


检索函数

检索函数用于检索表达式中，有如下24个：

函数名 | 含义和作用

BT(主题词[,词典])

获得某个主题词的上位词

NT(主题词[,词典])

获得某个主题词的下位词

PT(主题词[,词典])

获得某个主题词的等同词

UF(主题词[,词典])

获得某个主题词的替代词

AB(主题词[,词典])

获得某个主题词的缩略词

ABF(主题词[,词典])

获得某个缩略词所代表的主题词

RT(主题词[,词典])

获得某个主题词的相关词

LE(主题词[,词典])

获得某个主题词的外文等同词

ALLBT(主题词[,词典])

获得某个检索词的所有层次的上位词

ALLNT(主题词[,词典])

获得某个检索词的所有层次的下位词

ST(检索词[,词典])

获得某个检索词的广义同义词

AT(检索词[,词典])

获得某个检索词的反义词

BETWEEN(值1，值2)

获取在指定范围之内的字段值

BEYOND(值1，值2)

获取在指定范围之外的字段值

EXACT(值)

对值不进行任何处理，直接在索引进行精确查找

INCLUDE(词串)

对词串不进行分词处理，并加上前后模糊

AMB(词串)

用扩展查找的方法来解决由于分词错误所引起的漏检问题，或者满足非词检索的要求，又称邻接检索

ALL(词串)

对词串进行分词处理，并包含词串本身

RANGE(词串 = 值)

进行数值范围检索

LOWER(词串)

转化为小写，只对英文

UPPER(词串)

转化为大写，只对英文

TOCHINESE(词串)

把词串中的半角字母数字转化为全角

TOASCII(词串)

把词串中的全角字母数字转化为半角

CASE(词串)

进行大小写无关检索，只对英文

LIKE(词串[, 开关] ) | 对词串进行分词处理，忽略词之间的位置关系，进行简单的逻辑运算
DATA(值列表 ) | 直接扫描数据进行精确匹配，无参数时表示空值查找
  • 检索函数BETWEEN和BEYOND只能作用于DATE、NUMBER以及CHAR字段；EXACT、LOWER、UPPER、TOCHINESE、TOASCII和CASE检索函数可作用于除BIT之外的所有字段；DATA函数可作用于包括BIT字段在内的所有字段；其他检索函数则只能作用于PHRASE和DOCUMENT两个可进行全文检索的字段。其中LOWER、UPPER、TOCHINESE、TOASCII和CASE检索函数在以英文为字符集的数据库中无效，即不进行任何转换。
  • TRS系统支持辅助知识自动扩展检索，这一功能涵盖了大部分的检索函数，包括：BT、NT、PT、UF、AB、ABF、RT、LE、ALLBT、ALLNT、ST、AT以及TOCHINESE和TOASCII。自动扩展检索可以对检索表达式里的所有词自动施加这些函数调用，无须显式调用。
  • 检索函数BETWEEN和BEYOND的参数表的圆括号‘(’和‘)’可以分别使用方括号‘[’和‘]’替换。‘(’表示值1不包含在范围之内，而‘[’表示值1包含在范围之内；‘]’表示值2不包含在范围之内，而‘)’表示值2包含在范围之内，并且值1和值2都不支持模糊字段值。
  • 函数BT、NT、PT、UF、AB、ABF、RT、LE、ALLBT、ALLNT、ST、AT的参数中的‘[’和‘]’不是参数的一部分，表示词典可以省略。当词典省略时，系统将根据被检索的数据的语言类型，获取系统缺省的相应类型的词典作为被引用的词典，其中函数ST所引用的词典必须是同义词典，函数AT所引用的词典必须是反义词典，其它函数所引用的词典必须是主题词典。如果指定词典，则无论是函数调用，还是自动扩展检索，都要求词典的字符集必须与所检索的数据库的字符集保持一致，否则无效。
  • RANGE函数中比较运算符‘=’可以用其他任意比较运算符替代。
  • DATA函数的参数形式与3.2节中“检索键值列表”的形式是一致的。参数表的圆括号对‘(’和‘)’可以使用方括号对‘[’和‘]’替换，表示：作用于CHAR型字段时，不区分字母的大小写；作用于DATE型字段时，进行精确匹配。如果DATA函数作用于PHRASE、DOCUMENT和BIT字段，则只允许无参数调用。
  • 函数EXACT、LOWER、UPPER、TOCHINESE、TOASCII和CASE检索函数，以及参数列表只有单个值的DATA函数的结果值可用于进行字段值大小比较的表达式中，如：“字段名>function(…)”，其它函数则不能出现在这样的表达式中，而只能用于“等于”或“不等于”的表达式中。
  • LIKE函数主要用来改变全文检索的方式。常规的全文检索方式是：对于给定的短语（词串），经过分词处理后，各词之间要进行严格的位置运算。而LIKE函数则是对参数给定的短语（词串），经过分词处理后，各词之间不进行位置运算，而只按下列四种模式进行简单的逻辑运算
    • ：
    1. 完全“与”模式。参数表以圆括号对‘(’和‘)’表示，即LIKE(…)；第二个参数表示是否忽略二元索引：取值为‘TRUE’（大小写无关）或者‘1’、或者缺省时，表示忽略二元索引，以提高查全率，尽可能地取得更多的结果；取值为‘FALSE’（大小写无关）或者‘0’时，表示不忽略二元索引，以提高检索速度。这种模式允许附加所有合法的限定运算符和加权运算符。
    2. 有限“与”模式：参数表以圆括号对‘(’和‘)’表示，即LIKE(…)；第二个参数，如果是2到9之间的数字，则表示检索结果限定在“忽略二元索引，并且在限定范围内出现的词数不能少于该参数所对应的数目”，如果是10到100之间的数值，则表示检索结果限定在“忽略二元索引，并且在限定范围内出现的词数与第一个参数所含总词数的百分比不能少于该参数所对应的数值”。其中的限定范围由附加的属性运算决定，缺省限定范围是记录。这种模式允许附加所有合法的限定运算符和加权运算符。
    3. 完全“或”模式：参数表以方括号对‘[’和‘]’表示，即LIKE[…]；第二个参数的意义与完全“与”模式相同。除了“/seg”和“/sen”外，这种模式允许附加其它合法的限定运算符和加权运算符。
    4. 有限“或”模式：参数表以方括号对‘[’和‘]’表示，即LIKE[…]；第二个参数的意义与有限“与”模式相同。这种模式允许附加所有合法的限定运算符和加权运算符。
    这里，“与”模式与“或”模式的区别在于限定运算符“/sen>n”和“/seg>n”的解释不同(其中的“>”可用“>=”、“<”、“<=”和“!=”替代)。“与”模式要求相关的词必须出现同一句/段中，并且其句/段号必须满足给定的条件；“或”模式不要求相关的词出现在同一句/段中，只要求其句/段号都满足给定的条件。对于某些限定运算，有限“与”模式和有限“或”模式则是等价的，如：“LIKE(词串, 80)/sen”等价于“LIKE[词串, 80]/sen”。这里需要特别指出的是：对于限定运算符“/pos=n”，如果有“/sen”显式的同句限定，或者在“与”模式下有“/sen=n” 隐式的同句限定，则意义发生改变，表示词之间的相对距离；否则仍然仍维持原意，表示词自身的位置。 有限“与”模式的作用是扩大完全“与”模式的结果集，以满足更宽泛的查询需求；而有限“或”模式的作用则是缩小完全“或”模式的结果集，以满足更精确的查询需求。


DATE型字段上的键值

在检索表达式中，DATE键值的格式有通用格式、英文格式、无分隔符格式和中文格式四种类型。下列格式中，用‘[’和‘]’包括的部分表示可以省略。

·通用格式
Year[/Month[/Day[/Hour[/Minute[/Second]]]]][A[M]]
[Year]/Month[/Day[/Hour[/Minute[/Second]]]][A[M]]
[Year]/[Month]/Day[/Hour[/Minute[/Second]]][A[M]]
[Year]/[Month]/[Day]/Hour[/Minute[/Second]][A[M]]
[Year]/[Month]/[Day]/[Hour]/Minute[/Second][A[M]]
[Year]/[Month]/[Day]/[Hour]/[Minute]/Second[A[M]]

其中：
☆ Year为一到四位表示的完全年份(如1998)。
☆ Month、Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ A/M可用P/PM替换。A/AM表示上午，P/PM表示下午，大小写无关。如果它们出现在格式中，则“Hour”不能缺省。
☆ 单字节除号‘/’分隔符可分别用单字节的逗号‘,’、句号‘.’、冒号‘:’、减号‘-’以及空格任意替代。
☆ 用方括号引起的部分表示可以省略（模糊日期）。
☆ Year、Month、Day、Hour、Minute、Second都可以用一个或多个单字节的问号‘?’、百分号‘%’替代，表示模糊日期。

·英文格式
Month[Day[,Year[ Hour[:Minute[:Second]]]]][A[M]]
Month[Day],Year[ Hour[:Minute[:Second]]][A[M]]
Month[Day],Year[ Hour]:Minute[:Second][A[M]]
Month[Day],Year[ Hour]:[Minute]:Second[A[M]]
[Day-]Month[-Year[ Hour[:Minute[:Second]]]][A[M]]
[Day-]Month[-Year[ Hour]:Minute[:Second]][A[M]]
[Day-]Month[-Year[ Hour]:[Minute]:Second][A[M]]
DayMonthYear[ Hour[:Minute[:Second]]][A[M]]
DayMonthYear[[ Hour]:Minute[:Second]][A[M]]
DayMonthYear[[ Hour]:[Minute]:Second][A[M]]

其中：
☆ Year为一到四位表示的完全年份(如1998)。
☆ Month为英文表示的月份：Jan. Feb. Mar. Apr. May Jun. Jul. Aug. Sept. Oct. Nov. Dec.；或：January February March April May June July August September October November December。
☆ Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ A/M可用P/PM替换。A/AM表示上午，P/PM表示下午，大小写无关。如果它们出现在格式中，则“Hour”不能缺省。
☆ Year与Hour之间用单字节空格分隔；‘,’‘:’‘-’分别为单字节的逗号、冒号、减号。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

·无分隔格式
YearMonth[Day[Hour[Minute[Second]]]]]

其中：
☆ Year为固定四位表示的完全年份(如1998)。
☆ Month、Day、Hour、Minute、Second分别为二位表示的月、日、时、分、秒。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

·中文格式
中文格式包括所有用全角字符表示的上述几种格式，另外还支持如下的格式：
[Year年][Month月][Day日][Hour时][Minute分][Second秒][上午]

其中：
☆ Year为一到四位表示的完全年份(如1998或一九九八或壹玖玖捌)。其中数字既可为半角，也可为全角。
☆ Month、Day、Hour、Minute、Second分别为二位或一位数字表示的月、日、时、分、秒。
☆ 格式中“上午”可用“下午”替换。如果“上午”或“下午”出现在格式中，则“Hour时”不能缺省。
☆ 用方括号引起的部分表示可以省略（模糊日期）。

另外，还支持$DATE和$TIME特殊日期（不区分大小写）的检索，其中前者表示当前日期的“年月日”，后者表示当前日期的“年月日时分秒”。

对于一个不完全的日期，TRS系统缺省以模糊日期处理，如日期“1998”将检索到“1998.1.1”到“1998.12.31”以及“1998”中没有确定的月和日的所有日期。如果需要将“1998”当作一个精确日期来处理，即不要命中有确定的月或日的日期，则可使用“EXACT”函数进行检索，如“EXACT(1998)”。

在阅读《TRS4.0数据库加载格式规范》时会发现，其日期格式中的“年份”与这里所要求的不一样：加载时的“年份”可以省略“世纪数”，而检索时的“年份”没有缺省“世纪数”，无论多少位都表示的是完全年份，如“98”表示“公元98年”，而不是“公元1998年”。在检索时，无分隔格式中的“年份”必须是四位，如日期“190610”表示“1906年10月”，但在数据库加载时则表示“1919年6月10日”（假设缺省世纪数为19）。之所以存在这种差别，主要原因是在数据库加载时，往往是大批量的日期数据，通过加载控制文件指定年份的缺省世纪数可以支持按习惯方法表示的日期，而检索时则没有必要使用这种方法指定年份的缺省世纪数，直接写出完全的年份更为简捷方便。


CHAR型字段上的键值

在检索表达式中，CHAR键值是一个字符串。这个字符串可以单引号引起来，也可以不用。对于普通的键值，是否被引号引起来，或是否被转义，都具有相同的含义。

一般情况下，给出的键值必须是一个完整的字段值，而不是字段值的一部分，但TRS也支持对键值的模糊匹配。用通配符“?”表示一个字母字符或汉字，用“%”表示0到多个字母字符或汉字。通配符可出现在键值中的任意位置。这两个通配符的组合‘%??…?’表示在字符串中至多可以通配n个字母字符或汉字；而其它组合，例如‘??…?%’，则表示在字符串中至少需要通配n个字母字符或汉字，其中的n都是‘?’的个数。但是如果一个给定的键值只包含有‘?’和‘%’，而没有其它任何字符，则无论其格式如何都表示全模糊查找。

例如：

  • 表达式“作者=%国庆”将检索出所有作者为“张国庆”、“欧阳国庆”、“国庆”等的记录；
  • 表达式“作者=张%”将检索出所有作者为“张国庆”、“张三”、“张”等的记录；
  • 表达式“作者=张%庆”将检索出所有作者为“张国庆”、“张大庆”、“张庆”等的记录；
  • 表达式“作者=张?庆”将检索出所有作者为“张国庆”、“张大庆”等的记录，而作者为“张庆”的记录不会被检索出来。

另外，还支持$USER特殊键值（不区分大小写）的检索，表示检索字段值等于当前操作的用户名。


NUMBER型字段上的键值

在检索表达式中，NUMBER型键值是一个实数。NUMBER型字段上不支持模糊检索。


PHRASE和DOCUMENT型字段上的键值

在检索表达式中，PHRASE和DOCUMENT的键值是一个字、词、短语，或者句子。它们可以单引号引起来，也可以不用。对于普通的键值，是否被引号引起来，或是否被转义，都具有相同的含义，并且是经过分词处理后再进行检索。

对于含有“?”或“%”的模糊键值，也需要先分词再检索，因此这类键值的检索要比CHAR键值的检索复杂得多，其中“?”和“%”的意义可能不完全等同于CHAR键值中规定的意义，比如：“张?庆”将检索出包含“张国庆”、“张大庆”等的记录，同时也将检索出包含“张庆”的记录。

但是，如果模糊键值在分词词典中有对应的词（即用该键值查询分词词典时有结果），则“?”和“%”的意义与CHAR键值的相同。例如：“中国”、“中立国”和“中华民国”都是词，则“中?国”不能命中“中国”和“中华民国”。


特殊键值

TRS检索表达式中有四类语法符号：

  • 第一类：‘(’、‘)’、‘，’、‘/’、‘@’、 ‘=’、‘>’、‘<’、‘!’、‘&’、‘*’、‘^’、‘-’、‘+’、‘[’、‘]’。
  • 第二类：‘ADJ’、‘EQU’、‘PRE’、‘AND’、‘XOR’、‘NOT’、‘OR’、‘TO’、空格、函数名。
  • 第三类：‘%’、‘?’。
  • 第四类：单引号和转义符‘\’。

检索表达式的键值必须对这些符号进行特殊处理：

  • 如果键值中含有第一类语法符号，则必须将该键值用单引号引起来，或者用转义符将这些语法符号进行转义。如：日期键值‘,,8’、\,\,8。
  • 如果第二类语法符号是一个键值，则必须将该键值用单引号引起来，或者用转义符将这些语法符号进行转义。如：‘AND’、\AND。
  • 如果第三类语法符号是键值的值的一部分，则必须使用EXACT函数进行检索。如：EXACT(10%)。
  • 如果第四类语法符号是键值的值的一部分，则必须用转义符将它们再转义后进行检索。

    • 需要注意的是：

    1. 对于其它一些非文字符号，如果需要在PHRASE或DOCUMENT字段中能够被检索，则应该将这些符号从数据库所引用的停用词典中去掉。
    2. 特别地，单字节的“惊叹号”、“逗号”、“分号”、“句号”和“问号”，以及各语种自己的多字节编码的“惊叹号”、“逗号”、“分号”、“句号”和“问号”是分词系统法定的“分句”符号，一般情况下会被忽略。如果需要在PHRASE字段中能够被检索，则也应该将这些符号从数据库所引用的停用词典中去掉；如果需要在DOCUMENT字段中能够被检索，则不但应该将这些符号从数据库所引用的停用词典中去掉，而且DOCUMENT字段的索引属性中不能包含有位置属性“SEN”。


TRS保留字

AB | ABF | ADJ | ALL | ALLBT
ALLNT | AMB | AND | AT | AVG
BETWEEN | BEYOND | BT |  |
CASE | COUNT |  |  |
DATA | DOCID |  |  |
EQU | EXACT |  |  |
INCLUDE |  |  |  |
LE | LIFO | LIKE | LOWER |
MAX | MIN |  |  |
NEAR | NOT | NT |  |
OR |  |  |  |
PRE | PT |  |  |
RANGE | RELEVANCE | RT |  |
SPELL | ST | SUM |  |
TO | TOASCII | TOCHINESE |  |
UF | UPPER |  |  |
XOR |  |  |  |


启动TRS管理员

TRS管理员运行于中文Windows XP/2003或以上版本平台，并且安装Microsoft Internet Explorer，否则将无法浏览检索结果中的源文件以及联机帮助。如要登录到TRS服务器，必须保证该服务器的指定端口上安装了TRS全文数据库（推荐6.0以上版本，4.x和5.x也可兼容），并且该TRS服务进程处于启动状态。

双击安装时在桌面上生成的“TRS管理员”图标，或在开始菜单中选择“TRS全文数据库”程序组中的“TRS管理员”菜单项，或以资源管理器、命令行或其它方式运行TRSAdmin.exe程序，即可启动TRS管理员。在欢迎信息框显示完毕以后，TRS管理员将弹出如下“启动”对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
登录信息 | 包括服务器地址和端口、用户帐号和口令等。输入的登录信息将会保存到注册表中，作为下一次启动的缺省设置。
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如“192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。
保存密码 | 是否保存所输入的密码标志，密码会加密保存。

自动打开 | 登录成功后自动打开的窗口，可为以下选项之一：对象管理窗口、数据库/视图。
对象管理窗口 | 登录成功后自动打开对象管理窗口，为缺省设置。
数据库/视图 | 登录成功后自动打开指定的数据库/视图，如总是对某个数据库/视图进行操作可选择该选项。右边的组合框中列出的是以前打开过的最后十个数据库/视图名。

显示启动对话框 | 启动时是否显示“启动”对话框标志。如清除该选项，则下次启动时将不再显示本对话框。
最大化窗口 | 是否最大化子窗口标志。如设置该选项，则所有子窗口都将占满整个主窗口的空间。

在登录组内依次填入服务器地址、服务器端口、用户帐号名和用户口令字，然后按确定，TRS管理员会尝试与指定服务器建立连接。如连接成功，会打开用户在自动打开组内指定的窗口。输入的登录信息以及其它设置将会成为下一次运行时的缺省配置。


新增特性

TRS管理员在上一版本的基础上，作出了以下几个方面的重大改进：

  • 界面风格焕然一新，提供标签页式多文档管理，新增可浮动的导航和属性面板
  • 新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示
  • 树形管理用户组、用户和数据格式，可筛选所属对象
  • 属性表式管理各种对象属性，可直接修改更新，结构和权限独立出来
  • 采用新的文本方式导入/导出对象，方便修改和将来扩展
  • 支持生成多级导航树，概览增加字段排序和记录标志，细览实现图文混合显示和命中点定位
  • 可自定义表单编辑记录界面，下拉列表提供日期/字符型字段可能值选择
  • 改进了装库控制文件生成和结果报告查看对话框

·界面风格焕然一新，提供标签页式多文档管理，新增可浮动的导航和属性面板

界面右侧是一个多标签页的窗口设置，已打开的窗口以标签页的方式显示，想要查看某一窗口，只需要点击上部的窗口标签或者点击最右侧的“活动文件”按钮在激活窗口列表中选择一个窗口即 可进行切换，同时相应的菜单、工具栏和属性、导航窗口也进行相应的切换。在标签页顶部点击右键会弹出“关闭当前”和“关闭所有”两个菜单，点击“关闭当前”即关闭当前激活窗口，点击“关闭所有”则关闭除对象管理窗口以为的所有窗口。

本版本中，增加了两个新的窗口——导航窗口和属性窗口。导航窗口用来显示用户及用户组列表、数据格式列表和某一对象对应的检索导航树。属性窗口用来显示各个对象，字段的具体属性，并能完成修改及更新功能。

这两个窗口采用了新的界面形式，点击隐藏按钮后窗口可隐藏在界面最左边，如下图：

窗口既可以停靠在界面的四边，也可以悬浮于窗口的任何位置。如下图所示，属性窗口停靠在界面的下边，导航窗口悬浮于界面的右侧：

此外，当两个窗口关闭后，可以点击工具栏上 [image] 按钮和 [image] 按钮，再次打开这两个窗口，且所在位置与窗口关闭前的位置一致。

·新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示

系统选择对话框也采用了新的属性框。单击对话框左部图片框中的图标可分别查看各页面的具体选项的设置。点击每一个属性项时，下方的注释框显示其相应的注释。

·树形管理用户组、用户和数据格式，可筛选所属对象

本版本中，以树型结构的形式显示用户组、用户及它们之间的所属关系。用户组的各个子字节对应的用户属于此用户组，若父节点为根节点的用户表示不属于任何用户组。 在此列表树中还可以通过拖拽将用户移动到别的用户组。

此外，数据格式的类别也以树形结构的形式显示。点击各个类别，对象管理窗口即显示当前类别包含的所有数据格式列表。

·属性表式管理各种对象属性，可直接修改更新，结构和权限独立出来

属性窗口采用新的属性框进行属性的显示。各属性可在其中直接修改，被改变的属性以粗体显示。点击各个属性项时，相应的注释将显示于下方注释框中。同时结构和权限被独立出来，作为弹出对话框显示，如下图：

属性框有下面几种控制项：

    ☆ 编辑框，直接在编辑框里输入内容

    ☆ 数字微调框，点击右边的微调按钮直接对数字进行更改，此外，需要输入数字的属性项有输入限制，非数字禁止输入。

    ☆ 复选框，当点击出现对勾时，表示本属性项值为TRUE，否则为FALSE。

    ☆ 下拉组合框，点击时，会显示下拉箭头按钮，点此箭头将会展开下拉框。

    ☆ 弹出组合框，点击时，出现 [image] 按钮，点此按钮弹出相应的对话框。

·采用新的文本方式导入/导出对象，方便修改和将来扩展

本版本的Admin将采用新的“.tof”格式文件存储导出的对象信息和结构，此种格式的文件可以文本的方式打开，直接进行编辑和修改，并且可以将用户组与用户的信息保存到同一个文件中。

·支持生成多级导航树，概览增加字段排序和记录标志，细览实现图文混合显示和命中点定位

记录维护窗口对应的导航树新增了检索条件具有蕴含关系的多级导航功能，即在继承根节点的检索条件下根据二级导航节点再次进行检索。以此类推，还可进行更多级的检索。但需要注意的是，此多级导航功能只有在使用“自动生成”功能的情况下才能生成，其他情况下生成的多级导航中，根节点和子节点代表的检索条件没有蕴含关系。

概览窗口中可按字段排序，点击字段名可按才字段升序或降序排列，字段名旁边的三角形尖角向上表示升序，尖角向下表示降序。 同时，经过加密、修改或者删除等操作的记录前面会有相应的标志以示区别。

下方细览窗口采用浏览器的方式实现了图文混合显示，同时支持命中点定位，利用上部的工具栏可定位到上一或者下一命中点处。

·可自定义表单编辑记录界面，下拉列表提供日期/字符型字段可能值选择

本版本中的表单编辑界面可以自己对其中编辑框的大小和位置进行调整，调整后点击 [image] ，即可保存所做修改，下次再打开此对象的表单窗口时，将自动恢复上一次对各编辑框的设置。 下图即为控件设计状态，用户可自己对编辑框的位置和大小进行调整：

同时，日期、字符型字段可以进行可能值的选择。

·改进了装库控制文件生成和结果报告查看对话框

装库控制文件生成对话框也采用了新的属性框进行各项属性的显示。

结果报告对话框添加了“生成报告”和“打开报告查看”的选项，在结果报告很大时，可以设置为只生成报告而不打开报告查看，节约了时间。


对象管理窗口

对象管理窗口用于管理和维护各种TRS对象，包括：数据库、视图、词典和数据格式。左侧上部对应的导航窗口显示用户列表树或者数据格式列表树，左 侧下部对应的属性窗口显示当前所选对象的具体属性。点击导航窗口工具栏中不同的对象， 或者列表树的不同节点，对象管理窗口将显示相应对象的列表，同时左下部属性窗口显示其属性。对象列表可以四种方式显示：大图标、小图标、列表和详细信息，缺省情况下为详细信息方式，如下图：

对象管理窗口对应的工具栏上包含了一些常用的菜单命令，状态栏的中间部分显示当前的对象总数以及选定的对象个数。另外，对象管理窗口提供了一些快捷键和快捷菜单用于快速执行菜单命令。

对象管理窗口有以下六个菜单：

pointblue.gif (904 bytes) 文件菜单
新建 | 创建新对象或文件
打开 | 打开已存在的文件
重命名 | 重命名当前选中的对象
导入/导出 | 把对象保存到文件或从文件里恢复对象
结构 | 查看和修改当前选中对象的结构
权限 | 查看和修改当前选中对象的权限
检索 | 对当前选择的数据库/视图/词典进行检索
显示属性 | 若属性窗口关闭，打开属性窗口
MRU文件列表 | 重新打开最近曾经用过的文件
退出 | 退出TRS管理员
pointblue.gif (904 bytes) 编辑菜单
撤消 | 取消上一次操作
剪切 | 删除所选对象并把它放到剪贴板上
复制 | 把所选对象复制到剪贴板上
粘贴 | 把剪贴板内容复制到当前服务器
删除 | 删除当前所选的对象
全部选定 | 选定当前所有的对象
pointblue.gif (904 bytes) 查看菜单
工具栏 | 显示/隐藏工具栏
状态栏 | 显示/隐藏状态栏
大图标 | 以大图标方式显示对象
小图标 | 以小图标方式显示对象
列表 | 显示对象的列表
详细信息 | 显示对象的详细信息
排列图标 | 按一定顺序排列图标
字体 | 改变显示字体和颜色
显示导航 | 若导航窗口关闭，打开导航窗口
刷新 | 刷新当前的对象列表
对象管理 | 显示并激活对象管理器窗口
命令语言 | 打开命令语言处理工具
pointblue.gif (904 bytes) 工具菜单
登录 | 登录到TRS服务器
退出登录 | 切断与TRS服务器的链接
装入记录 | 装入新的数据到数据库/自动模式视图/词典中
复制记录 | 把记录从源数据库/自动模式视图复制到目标数据库/自动模式视图里
解锁数据库 | 解锁选择的数据库
备份数据 | 把数据库/自动模式视图备份到指定设备
恢复数据 | 从外围设备恢复数据库/自动模式视图
优化数据 | 优化指定的数据库/自动模式视图
索引维护 | 索引的建立、删除和验证
选项 | 修改服务器的配置和TRS管理员的选项
pointblue.gif (904 bytes) 窗口菜单
水平平铺 | 水平平铺所有子窗口
垂直平铺 | 垂直平铺所有子窗口
层叠 | 层叠排列所有子窗口
排列图标 | 把所有最小化的图标排列在窗口底部
pointblue.gif (904 bytes) 帮助菜单
帮助主题 | 显示TRS管理员的帮助主题
TRS主页 | 打开TRS公司的主页
关于 | 显示TRS管理员的版本信息


导航窗口

当右侧显示的是对象管理窗口时，导航窗口主要有以下功能：

  • 显示用户列表树。这是一个用树型结构显示各用户组及用户之间关系的列表。 用户组的各个子字节对应的用户属于此用户组，若父节点为根节点的用户表示不属于任何用户组。点击各个节点，对象管理窗口显示当前用户或用户组拥有的相应对象列表，同时下方属性窗口显示其属性。

    • 各节点和前面图标的对应关系如下：

    用户组
    系统数据库管理员DBA
    用户组数据库管理员GDA
    系统资源用户RESOURCE
    系统登录用户CONNECT

    用户列表树各个节点的维护通过快捷菜单来完成，选择相应节点并单击鼠标右键即可调出快捷菜单。 如当前选择节点为根节点，快捷菜单如下：

    新建用户组 | 创建新的用户组对象
添加导航 | 新建具有筛选功能的导航节点
粘贴 | 插入剪贴板内容
查看源文件 | 打开查看当前用户列表树对应的导航文件

    如当前选择节点不是根节点，快捷菜单如下：

    新建用户 | 创建新的用户对象，若当前所选节点为用户组，则新建属于此用户组的用户。若当前所选节点为用户，则新建与此用户同组的用户
添加导航 | 新建具有筛选功能的导航节点
剪切 | 删除所选对象并把它放到剪贴板上
复制 | 复制所选对象到剪贴板上
粘贴 | 把剪贴板内容复制到当前服务器
删除 | 插入剪贴板内容
重命名 | 重命名当前选中的对象
属性 | 显示选定中对象的属性，若属性窗口关闭，重新打开属性窗口

    若在导航窗口的空白处点击右键，快捷菜单如下：

    新建对象 | 创建新的用户组或者用户对象
添加导航 | 新建具有筛选功能的导航节点
刷新 | 刷新当前窗口

    用户列表树还支持节点的拖动，但只支持用户移动到别的用户组。操作方法是：按住所要移动的用户节点，并把它拖动到目标节点下，然后放开鼠标左键，如果移动合法的话，此用户将被移动到新的用户组中，同时用户的所属用户组属性也将改变。

  • 显示数据格式列表树。这是一个用树型结构显示数据格式类别的列表。各个子节点表示当前服务器拥有的数据格式类别。点击各个节点，对象管理窗口显示当前类别包含的所有数据格式列表。同时下方属性窗口显示其属性。

    • 窗口上方的工具栏主要实现当前列表树的变换和对象管理窗口当前显示对象类别的变换。工具栏中的每个按钮的功能如下：

    此按钮按下时，显示用户列表树，同时右边“数据库”按钮自动选中，对象管理窗口显示所有的数据库列表
    此按钮按下时，显示数据格式列表树，同时对象管理窗口显示所有的数据格式列表
    此按钮按下时，“用户”按钮即自动选中，对象管理窗口显示所有数据库列表；当点击用户列表树的某一节点时，对象管理窗口显示当前所选用户组或用户拥有的所有数据库列表
    此按钮按下时，“用户”按钮即自动选中，对象管理窗口显示所有视图列表；当点击用户列表树的某一节点时，对象管理窗口显示当前所选用户组或用户拥有的所有视图列表
    此按钮按下时，“用户”按钮即自动选中，对象管理窗口显示所有词典列表；当点击用户列表树的某一节点时，对象管理窗口显示当前所选用户组或用户拥有的所有词典列表

    数据格式列表树各个节点的维护通过快捷菜单来完成，快捷菜单如下：

    新建格式 | 创建新的数据格式对象，若当前所选节点为数据格式类别，则新建属于此类别的数据格式
属性 | 显示选定中对象的属性，若属性窗口关闭，重新打开属性窗口


属性窗口

当右侧显示的是对象管理窗口时，属性窗口显示各个对象或者导航节点的属性，并且可以查看和修改当前选中对象或节点的属性、结构和权限等信息。如要对数据库、视图、词典的属性进行修改，则当前用户必须是DBA用户，或为选中对象的拥有者，或对选中对象有ALTER权限。只有SYSTEM用户才能修改用户组/用户的属性。

窗口最上部是一个对象列表框，其下拉框中列有最近曾经显示过属性的对象列表，选择相应的对象，下方属性框中将显示其属性。

工具栏中的每个按钮的功能如下：

打开对象结构对话框
打开对象权限对话框
保存所修改的对象属性
重置当前对象的属性，即恢复到上次已存的的属性

当点击对象管理窗口的对象或者导航窗口的节点时，属性窗口会显示所选对象的属性。对于不同类型的对象，属性窗口显示的属性列表各不相同，具体如下：

  • 数据库 数据库属性、数据库结构、访问权限。
  • 视图 视图属性、视图结构、访问权限。
  • 词典 词典属性、访问权限。
  • 用户组 常规属性。
  • 用户 常规属性。
  • 数据格式 常规属性。
  • 筛选对象的导航节点 导航节点属性。


对象管理窗口的工具栏

对象管理窗口的工具栏如下图：

工具栏上各按钮的功能如下：
FileNew.gif (923 bytes) 新建 | 创建新对象
FileOpen.gif (938 bytes) 打开 | 打开已存在的文档
FileRename.gif (938 bytes) 重命名 | 重命名当前选中的对象
ViewOpenNavi.gif (948 bytes) 显示导航 | 若导航窗口关闭，打开导航窗口
FileProperties.gif (941 bytes) 显示属性 | 若属性窗口关闭，打开属性窗口
EditCut.gif (928 bytes) 剪切 | 删除所选对象并把它放到剪贴板上
EditCopy.gif (943 bytes) 复制 | 复制所选对象到剪贴板上
EditPaste.gif (959 bytes) 粘贴 | 插入剪贴板内容
EditClear.gif (918 bytes) 删除 | 删除所选对象
EditUndo.gif (915 bytes) 撤消 | 撤消上一次操作
ViewResh.gif (915 bytes) 刷新 | 刷新当前窗口
ViewIcon.gif (917 bytes) 大图标 | 以大图标方式显示对象
ViewSmallIcon.gif (910 bytes) 小图标 | 以小图标方式显示对象
ViewObjList.gif (926 bytes) 列表 | 显示对象列表
ViewReport.gif (918 bytes) 详细信息 | 显示对象的详细信息
执行检索 | 直接按照检索历史框里的检索表达式进行检索
高级检索/排序 | 高级的筛选和排序
HelpContent.gif (956 bytes) 帮助主题 | 显示TRS管理员的帮助主题

工具栏上的检索历史组合框用于保存检索历史和输入检索表达式。先在对象列表里选择检索目标数据库/视图(可选择多个)，然后在检索历史组合框里输入或选择检索条件，再按回车键 或者点击 [image] 按钮，即可对所选对象进行检索。
单击工具栏最右方的 Company.gif (948 bytes) 图标可打开TRS公司主页。


对象管理窗口的状态栏

对象管理窗口的状态栏如下图：

状态栏最左边部分用于显示菜单命令、工具栏按钮、操作结果等提示信息，中间的部分显示当前选定对象数和对象总数，后边的两个状态框分别显示键盘的数字键和大小写状态。最右边的 Manager.gif (943 bytes) 和 Command.gif (971 bytes) 按钮则分别用于显示对象管理窗口和打开命令语言处理工具。


对象管理窗口的快捷键

对象管理窗口可用的快捷键如下：

Ctrl+N
Ctrl+O
Ctrl+T
Ctrl+R
Alt+Enter
Enter

Ctrl+Z
Ctrl+X
Ctrl+C
Ctrl+V
Del
Ctrl+A

Ctrl+Tab
F1
F2
F3
F5 		“文件|新建”命令，创建新对象或文件
“文件|打开”命令，打开已存在的文件
“文件|结构”命令，查看和修改当前选中对象的结构
“文件|权限”命令，查看和修改当前选中对象的权限
“文件|显示属性”命令，查看和修改当前选中对象的属性
对数据库/视图/词典进行检索，并打开相应的维护界面，对其它对象同Alter+Enter

“编辑|撤消”命令，撤消上一次操作
“编辑|剪切”命令，删除所选对象并把它放到剪贴板上
“编辑|复制”命令，复制所选对象到剪贴板上
“编辑|粘贴”命令，插入剪贴板内容
“编辑|删除”命令，删除所选对象
“编辑|全部选定”命令，选定所有对象

在不同的对象类型之间切换
显示当前所在窗口、菜单、控制的帮助信息
“查看|对象管理”命令，显示并激活对象管理器窗口
“查看|命令语言”命令，打开命令语言处理工具
“查看|刷新”命令，刷新当前的对象列表


对象管理窗口的快捷菜单

在对象列表控制里单击鼠标右键，即可调出对象管理窗口的快捷菜单。快捷菜单分两种情况，当目前没有对象被选择时，快捷菜单包含以下命令：

查看
排列图标
新建
撤消
粘贴
刷新 		改变对象列表的显示方式
按一定顺序排列图标
创建新对象
撤消上一次操作
插入剪贴板内容
刷新当前的对象列表

如果当前有对象被选择，快捷菜单包含的命令如下：

结构
权限
剪切
复制
删除
重命名
属性
删除所有记录
转成自动模式视图
加入数据库 		查看和修改当前选中对象的结构
查看和修改当前选中对象的权限
删除所选对象并把它放到剪贴板上
复制所选对象到剪贴板上
删除所选对象
重命名当前选中的对象
查看和修改当前选中对象的属性,若属性窗口关闭，重新打开属性窗口
删除当前对象的所有记录
将指定的数据库转化为能够自动分裂数据库的视图
将一个已经存在的数据库放到自动模式视图中


文件|新建 命令

创建新对象或文档。
选择“文件|新建”命令后，TRS管理员弹出如下对话框：

可创建的对象/文件类型包括如下几种：

  • 数据库
  • 视图
  • 词典
  • 用户组
  • 用户
  • 数据格式
  • 导航文件
  • 数据文件
  • 批装库文件
  • 控制文件
  • 脚本文件
  • 文本文件

在“新建”对话框中选择要创建的对象/文件类型（虚显的表示不能创建），然后按[确定]按钮，或直接双击相应的图标，将打开创建指定类型对象/文件的对话框。按[取消]按钮，则放弃创建操作，关闭对话框。

提示：当对象管理窗口为活动窗口时，按工具栏上的 FileNew.gif (923 bytes) 按钮则自动新建当前指定类型的对象；当文件编辑窗口为活动窗口时，按工具栏上的 FileNew.gif (923 bytes) 按钮则自动新建文本文件。


文件|打开 命令

打开已存在的文件。
选择“文件|打开”命令后，TRS管理员弹出如下对话框：

在搜索组合框里选择文件所在的路径，再在文件类型组合框里选择要打开的文件类型（可为TRS导航文件、TRS数据文件、TRS控制文件、文本文件或所有文件之一），然后在文件列表框里选择文件或直接在文件名编辑框里输入文件名，最后按[打开]按钮即可在TRS管理员里打开指定的文件。注意：每次只能打开一个文件，并且该文件必须是文本文件，对非文本文件将无法正确显示其内容。

提示：要打开最近使用过的文件，可在“文件”菜单底部选择最近曾经使用过的文件名。


文件|重命名 命令

重命名当前对象。操作用户必须拥有DBA权限或为当前对象的拥有者。
先选中要改名的对象，然后选择“文件”菜单上的“重命名”，或按工具栏上的 FileRename.gif (938 bytes) 按钮，或直接按空格键，当前对象名字的位置上将出现一编辑框；在编辑框中输入新的名字，然后按ENTER键，所选对象将被重新命名为所输入的名字；如要取消重命名操作，可按ESC键。


文件|导入/导出 命令

把对象导出到文件中，或从文件里恢复对象（当前用户必须具备Resource权限）。使用此功能，可以在重新安装TRS后恢复原有的对象（包括对象信息和结构，但不包括数据库的记录），或把对象从一个服务器复制到另一个服务器（两台服务器的平台可以不一样）。

本版本的Admin将采用新的“.tof”格式文件存储导出的对象信息和结构，此种格式的文件可以文本的方式打开，直接进行编辑和修改，并且 可以将用户组与用户的信息保存到同一个文件中。以前版本的“.sav”文件可以通过此对话框导入，但是无法再修改里面的内容。

在对象管理窗口里选择要导出的对象，然后选择“文件|导入/导出”命令，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
保存文件 | 导入对象的源文件名或对象导出的目标文件名，可按右边的 OpenFile.gif (157 bytes) 按钮选择导入对象的源文件名 ，或按 SaveFile.gif (156 bytes) 按钮选择导出对象的目标文件名。
现有对象 | 当前服务器上的对象列表，可按右边的 MoveRight.gif (925 bytes) 按钮把所选的对象添加到保存对象列表框里。
保存对象 | 当前指定文件里包含的对象列表（以红色字体显示以示与服务器上现有对象的区别），可按左边的 MoveLeft.gif (923 bytes) 按钮把所选的对象添加到现有对象列表框里（在导入文件里仍保留该对象），或按 [image] 按钮把所选对象从导入文件里删除。
恢复路径 | 导入数据库对象时，指定恢复的目标路径。必须是系统配置中的数据和索引路径之一，缺省为系统配置中的第一个数据路径。可以在下拉列表里选择。

设定好要导入/导出的对象，以及保存文件和恢复路径后，按[确定]按钮，TRS管理员会先从指定文件中把相应对象恢复到当前服务器中，然后把加入到保存对象列表框里的对象的属性/结构信息存储在指定文件里（除被明确删除的对象以外，保存文件中原有的对象信息继续保留）。按[取消]按钮则关闭对话框。

注意：只有当导入源文件中包含的对象类型与当前“现有对象”列表框中的对象类型一致时，源文件中包含的对象列表才会显示于“保存对象”列表框中。


文件|结构 命令

查看和修改当前选中对象的结构，本命令只对数据库和视图有效。如要对选中对象的结构进行修改，操作者必须是DBA用户，或为选中对象的拥有者，或对选中对象有ALTER权限。

先选中要查看结构的对象，然后选择菜单上的“文件|结构”命令，或按属性窗口工具栏上的 FileDesign.gif (948 bytes) 按钮，TRS管理员会根据选中对象的类型分别打开数据库结构和视图结构对话框。修改完毕后，按[确定]将保存所作的修改并关闭对话框，按[取消]则放弃所作的修改并关闭对话框。


文件|权限 命令

查看和修改当前选中对象的结构，本命令只对数据库、视图和词典有效。如要修改选中对象或其字段的公共属性，当前用户必须是DBA用户，或为选中对象的拥有者，或对选中对象有ALTER权限。只有SYSTEM用户才能修改某个用户组/用户对对象及其字段的访问权限。

先选中要查看权限的对象，然后选择菜单上的“文件|权限”命令，或按属性窗口工具栏上的 FileRight.gif (947 bytes) 按钮，TRS管理员会根据选中对象的类型分别打开数据库权限、视图权限和词典权限对话框。修改完毕后，按[确定]将保存所作的修改并关闭对话框，按[取消]则放弃所作的修改并关闭对话框。对某个用户组/用户对对象/字段的访问权限的修改将在按下权限复选框之后马上进行修改。


文件|检索 命令

对当前选择的数据库/视图/词典进行检索，并打开记录维护窗口。
先在对象管理窗口中选择一个或多个数据库、视图或词典，然后选择“文件|检索”命令，根据对象类型的不同将弹出不同的对话框，对应关系如下表：

对象类型 | 相应的对话框
数据库/视图 | “高级检索/排序”对话框
索引词典 | “索引词典维护”对话框
主题词典 | “主题词典维护”对话框
同义词典 | “同义词典维护”对话框
反义词典 | “反义词典维护”对话框

如当前选择对象为数据库/视图，设置好检索条件、统计条件、排序字段、检索选项等参数以后，按[确定]，TRS管理员会以所设参数对所有目标对象进行检索，并打开记录维护窗口，用户可以在该窗口里对检索结果进行浏览和维护，或重新进行检索。按[取消]则放弃检索，关闭对话框。

如当前选择对象为词典，则TRS管理员会根据词典类型打开相应的词典维护窗口。用户可在该窗口里进行词典的查询、添加、修改、删除等操作，按[确定]则保存所作修改并关闭对话框，按[关闭]则放弃所作修改。此外，还可按[另存为]按钮把查询结果的部分或全部保存到一个文件里。


文件|显示属性 命令

若属性窗口关闭，打开属性窗口。
因采用新的界面形式，属性窗口可以停靠在界面的四边，可以悬浮于界面的任何位置，也可以关闭。当属性窗口关闭时，点击此命令，可重新打开 属性窗口，且所在位置与属性窗口关闭前的位置一致。


文件|MRU列表

重新打开最近曾经用过的文件。
文件菜单的下面列有TRS管理员最近曾经打开过的四个文件，选择列表中的文件名，可以打开该文件。


文件|退出 命令

退出TRS管理员。
选择了“文件|退出”命令后，如当前所打开的对象或文件中有尚未保存的，TRS管理员将提示保存修改结果。保存完毕后，TRS管理员将关闭所有打开的窗口，并切断与当前登录的TRS服务器的链接，最后关闭主窗口。


编辑|撤消 命令

取消上一次编辑操作。仅对创建对象、重命名、剪切、粘贴和删除操作有效。

注：若上一次操作为剪切/删除数据库对象，只能恢复刚被删除的数据库对象的结构。


编辑|剪切 命令

删除所选对象并把它放到剪贴板上。
使用此功能可以在服务器之间快速地移动对象。先选择需要移动的对象，再选择“编辑|剪切”命令把所选对象剪切到剪贴板，然后登录到目标服务器，最后选择“编辑|粘贴”命令粘贴剪贴板里的对象。

注意：对数据库、视图和词典只针对其结构进行操作，对其记录不起作用。


编辑|复制 命令

把当前所选对象复制到剪贴板。
要想快速复制对象，可先选择需要复制的对象，再选择“编辑|复制”命令把所选对象复制到剪贴板，然后选择“编辑|粘贴”命令粘贴剪贴板里的对象。使用此功能不仅可以在当前服务器上创建对象的副本，还可以在不同服务器之间复制对象。

注意：对数据库、视图和词典只复制其结构，要想复制记录请用“工具|复制记录”命令。


编辑|粘贴 命令

把剪贴板内容复制到当前服务器。如剪贴板里包含的是数据库、视图或词典对象，则当前用户必须具有Resouce权限；如是用户组/用户对象，则当前操作者必须是SYSTEM用户。
利用“编辑|剪切”和“编辑|复制”命令与此命令结合可快速地移动/复制对象。先选择需要移动/复制的对象，再用剪切/复制命令把所选对象放到剪贴板上，然后登录到目标服务器，最后选择“编辑|粘贴”命令把把剪贴板内容复制到当前服务器。如果当前服务器上已有同名的对象，则TRS管理员会提示用户输入新的对象名。

注意：对数据库、视图和词典只针对其结构进行操作，对其记录不起作用。


编辑|删除 命令

删除当前所选对象。如所选为数据库、视图或词典对象，则当前操作者必须是DBA用户或是所选对象的拥有者，或对所选对象有Drop权限；如所选对象为用户组/用户，则当前操作者必须为SYSTEM用户；数据格式不能被删除。
要删除对象时，首先选择要删除的对象（可选择多个），然后选择“编辑|删除”命令，TRS管理员会列出所有选中对象的名字，然后提示用户是否确定删除所选的对象，按[是]表示确定删除，按[否]表示不删除。


编辑|全部选定 命令

选定当前的全部对象。


查看|工具栏 命令

显示/隐藏工具栏。
该菜单命令为一开关命令：如当前工具栏为显示状态，则把它隐藏起来；如为隐藏状态，则把它重新显示出来。菜单命令的左侧标明目前工具栏的显示状态。


查看|状态栏 命令

显示/隐藏状态栏。
该菜单命令为一开关命令：如当前状态栏为显示状态，则把它隐藏起来；如为隐藏状态，则把它重新显示出来。菜单命令的左侧标明目前状态栏的显示状态。


查看|大图标 命令

用大图标方式显示对象。每个图标表示一个对象，并只列出对象的名字。要想查看对象的其它信息，请关注属性窗口。


查看|小图标 命令

用小图标方式显示对象。每个图标表示一个对象，并只列出对象的名字。要想查看对象的其它信息，请关注属性窗口。


查看|列表 命令

显示对象的列表。每个图标表示一个对象，并只列出对象的名字。要想查看对象的其它信息，请关注属性窗口。


查看|详细信息 命令

显示对象的详细信息。对每个对象均显示其对象名、拥有者、创建日期、说明等信息。要想查看对象的其它信息，请关注属性窗口。


查看|排列图标 命令

按一定的顺序排列图标。排列方式有：按名称排列、按拥有者排列、按日期排列、按类型排列四种方式。如当前是以详细信息方式显示，单击栏目标题可设定按该栏目排列图标 ，栏目标题旁边的三角形尖角向上表示升序，尖角向下表示降序。在以大图标或小图标方式显示对象列表时，可以用“对齐图标”命令调整位置。如想在窗口大小改变时自动对齐图标，请选中“自动排列”选项。


查看|字体 命令

改变显示字体和颜色。
选择“查看|字体”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
字体 | 列出和选择可用的字体，只列出等宽的字体。字体名前有 TrueType.gif (855 bytes) 标志的为TrueType字体。
字形 | 列出和选择指定字体可用的字形。
大小 | 列出和选择指定字体可用的字号。

效果 | 指定显示文字的颜色和风格。
加删除线 | 选中表示在字体的中间加删除线。
加下划线 | 选中表示在字体的下面加下划线。
颜色 | 选择字体的显示颜色。

示例 | 显示所选字体的范例。
字符集 | 选择显示字体的语言。

选择好显示字体及其颜色、效果、语言等属性以后，按[确定]，将关闭对话框并以新字体显示界面文字。 所设字体对窗口/对话框（不包括系统对话框）内除标题/菜单以外的部分起作用，其中字体大小和颜色只影响对象维护和文件编辑文字，并且下次打开管理员的时候仍然有效。按[取消]则关闭对话框但不改变显示字体。


显示导航

查看|显示导航 命令

若导航窗口关闭，打开导航窗口。
因采用新的界面形式，导航窗口可以停靠在界面的四边，可以悬浮于界面的任何位置，也可以关闭。当导航窗口关闭时，点击此命令，可重新打开导航窗口，且所在位置与导航窗口关闭前的位置一致。


查看|刷新 命令

刷新当前的对象列表。当对象列表可能被其它应用程序或其它TRS管理员实例修改时，最好使用本命令刷新对象列表，以得到最新的对象信息。同时，相应的导航窗口和属性窗口也将被刷新。


查看|对象管理 命令

显示并激活对象管理器窗口。
如当前对象管理窗口处于隐藏状态，显示对象管理窗口。如对象管理窗口当前为最小化，把它设为正常显示状态。最后把它移到主窗口的最前端，并设为当前活动窗口。单击状态栏右端的 Manager.gif (943 bytes) 按钮也能起到同样效果。


查看|命令语言 命令

打开命令语言处理工具。
命令语言处理工具是独立于TRS管理员以外的一个仿命令行工具，用于输入和执行TRS命令语句。单击状态栏右端的 Command.gif (971 bytes) 按钮也能起到同样效果。


工具|登录 命令

登录到TRS服务器。
必须首先登录到TRS服务器，然后才能对服务器上的对象和数据进行操作。选择“工具|登录”命令后，TRS管理员弹出如下“登录”对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。

分别填写各项登录信息，然后按[确定]。TRS管理员将首先关闭所有打开的浏览窗口，并从目前登录中退出，然后再尝试登录到指定服务器。如登录成功，主窗口的标题栏上会显示当前所登录的服务器的地址和端口号，以及登录的用户名。如对象管理窗口处于显示状态，则自动刷新对象列表。


工具|退出登录 命令

切断与TRS服务器的链接。
当不再需要在当前登录的服务器上执行TRS操作时，选择“工具|退出登录”命令，系统将弹出一个提问对话框请求确认“是否决定退出登录？”。选择[是(Y)]，将切断与当前TRS服务器的链接，并关闭所有打开的浏览窗口，如对象管理处于显示状态则清除对象列表；选择[否(N)]，将继续保持当前链接。退出登录后，如要再执行TRS操作，必须重新登录到服务器。


工具|装入记录 命令

装入新的数据到数据库/词典/自动模式视图中。
选择“工具|装入记录”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
装库目标 | 待装入记录的数据库/词典/自动模式视图名。
数据文件 | 待装入的文件列表，可一次装入多个数据文件或批装库文件，或指定一个目录下的所有装库文件。按 [image] 按钮可添加装库数据文件或批装库文件，按 [image] 按钮可添加某个目录下的所有装库文件， 按 [image] 按钮对选定的文件/目录进行编辑修改，按 [image] 按钮可删除选定的文件/目录，用 [image] 和 [image] 按钮可调整文件/目录的顺序。单击列表中的某一项可修改该文件/目录名。
控制文件 | 装库控制文件，用于设置装库参数，为空则取系统缺省值。按 [image] 按钮可选择装库控制文件，按 [image] 按钮可以对话框的方式设置具体的装库参数。
记录格式 | 数据记录文件的格式，缺省为标准TRS格式。
直通模式 | 选中表示以“直通模式”加载数据。 如果数据加载所涉及到所有原始数据文件、批处理文件、控制文件，服务器的启动帐号都有读取权限，则可使用直通模式进行数据加载。由于直通模式下服务器直接读取原始数据文件，从而减少了中间环节，所以效率会更高。

设定好装库目标、数据文件和控制文件后，按[确定]按钮则开始装入记录，按[取消]按钮则关闭对话框。由于装库是一个耗时的过程，因此，装库过程中有“装库进度”对话框显示当前正在装入的文件、已装记录数和本批加载完成的百分数。如想终止装库过程，可按下对话框里的[终止]按钮。装库结束后，TRS管理员会弹出“结果报告”对话框，显示装库的起始时间、终止时间、花费时间、成功记录数、失败记录数、致命错误等结果信息。当装入有失败记录时，如要查看错误报告文件，可选中[打开报告查看]复选框，然后按[生成报告]，即可打开查看错误报告，也可设置为只生成报告而不打开报告查看，节约了时间。


工具|复制记录 命令

把符合指定条件的记录从一个数据库/自动模式视图复制到另一个数据库/自动模式视图中。
选择“工具|复制记录”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
复制目标 | 复制记录的目标数据库/自动模式视图名。
源数据库 | 复制记录的源数据库/自动模式视图名。
字段列表 | 待复制的字段列表。每次改变复制目标或数据来源时，字段列表框里会自动列出两者共同的字段（字段名和字段类型均一致），用户可以选择需要复制的字段（如不选择表示复制全部字段）。点击“字段名”和“类型”标题可进行排序，三角形尖角向上表示升序，尖角向下表示降序。
复制条件 | 复制记录的条件，数据来源里只有符合此条件的记录才会被复制到复制目标中。点击 [image] 按钮弹出“ 表达式生成器”对话框，帮助用户生成检索表达式。
排序方式 | 复制记录时所用的排序方式，可直接输入也可在下拉列表里选择。点击 [image] 按钮弹出“选择排序方式”对话框，帮助用户生成排序方式表达式。
同步索引 | 选中表示在复制记录的过程中同时建立索引，否则用户必须在复制完毕以后手动建立索引。缺省为选中。

设定好复制目标、数据来源、字段列表、复制条件和排序方式等参数后，按[确定]按钮则开始复制记录，按[取消]按钮则关闭对话框。由于复制记录是一个耗时的过程，因此，复制过程中有“复制进度”对话框显示当前已复制的记录数和本批复制完成的百分数。如想终止复制过程，可按下对话框里的[终止]按钮。复制记录结束后，TRS管理员会弹出“结果报告”对话框，显示复制的起始时间、终止时间、花费时间、复制记录数、致命错误等结果信息。


工具|解锁数据库 命令

为状态异常的数据库解锁（设为共享模式），使数据库可被访问。
操作者如果满足下列条件之一，则有权解锁数据库（数据库的异常一般是由数据库操作的意外中断引起 ）:
1.超级用户。
2.DBA用户。
3.数据库拥有者所在用户组的GDA用户。
4.数据库锁的拥有者，并且数据库具有公共ALTER属性或者操作者拥有该数据库的ALTER权。
但如果一个数据库被“拒绝访问锁”锁定，则任何用户都不能解锁，只能由系统内部自动解除，或者重新启动系统。
选择“工具|解锁数据库”命令后，TRS管理员弹出如下对话框：

对话框里的“数据库”列表框里列出了当前已加锁的数据库及其状态。选择需要解锁的数据库，然后按[确定]，TRS管理员会把所选择的数据库恢复到共享状态，并在状态条显示成功信息。按[取消]则放弃解锁操作并关闭对话框。


工具|备份数据 命令

把指定的数据库/自动模式视图备份到磁带或文件中，每次操作可以备份多个数据库（自动模式视图则只能选一个）。操作用户必须为DBA用户、拥有者所在组的GDA用户或对象的拥有者。（注：备份操作不备份权限信息。）
选择“工具|备份数据”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
备份对象 | 待备份的数据库/自动模式视图列表，如是数据库可一次选择多个，自动模式视图则只能选一个。
备份设备 | 备份目标的设备名，缺省值为系统的备份路径。当登录本地服务器时，可点击 [image] 按钮选择本地路径，点击 [image] 按钮选择备份目录名。

选择[数据库]或[视图]单选项，然后在[备份对象]列表框中选择需要备份的对象，在[备份设备]编辑框中输入备份的设备名或文件名，然后按[确定]，TRS管理员将开始进行备份操作，按[取消]按钮则关闭对话框。由于备份数据是一个耗时的过程，因此，备份过程中有“备份进度”对话框显示当前正在备份的对象、当前备份的进度和总进度的百分数。如想终止备份过程，可按下对话框里的[终止]按钮。备份数据库结束后，TRS管理员会弹出“结果报告”对话框，显示备份的起始时间、终止时间、花费时间、备份对象数、致命错误等结果信息。


工具|恢复数据 命令

从指定的设备恢复数据库/自动模式视图，每次操作可以恢复多个数据库（自动模式视图只能是一个）。操作用户必须为DBA用户、GDA用户或Resource用户。（注：数据库/自动模式视图恢复后，需要对它进行授权，否则该库只有DBA用户或对象的拥有者才能访问。）
选择“工具|恢复数据”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
备份设备 | 备份包的设备名，可以是磁带名或文件名。输入备份设备后，按 [image] 按钮可在[数据库]列表中列出该备份设备里包含的所有数据库 或者自动模式视图。当登录本地服务器时，可点击 [image] 按钮选择本地路径 ，点击 [image] 按钮选择备份目录名。
恢复对象 | 待恢复的对象列表。可选择一个或多个对象进行恢复。
恢复路径 | 恢复的目标路径，必须是系统配置包含的数据库或索引路径，为空表示系统配置中数据路径的第一个。

在[备份设备]里输入备份设备名，在[数据库]列表框中选择需要恢复的数据库，在[恢复路径]里选择目标路径，然后按[确定]，TRS管理员将开始进行恢复操作，按[取消]按钮则关闭对话框。由于恢复数据库是一个耗时的过程，因此，恢复过程中有“恢复进度”对话框显示当前正在恢复的数据库、当前恢复数据库的进度和总进度的百分数。如想终止恢复过程，可按下对话框里的[终止]按钮。恢复数据库结束后，TRS管理员会弹出“结果报告”对话框，显示恢复的起始时间、终止时间、花费时间、恢复数据库数、致命错误等结果信息。


工具|优化数据 命令

优化选择的数据库/自动模式视图。即对数据文件和索引文件进行优化重组，以达到提高检索速度和提高存储空间利用率的目的，一般在数据装载结束或进行数据库维护操作之后进行。操作用户必须为DBA用户、或拥有者所在组的GDA用户、或为所选对象的拥有者，或对所选数据库有Index权限。
选择“工具|优化数据”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
优化对象 | 待优化的数据库/自动模式视图名。
字段列表 | 待优化的数据库字段列表，可选择一个或多个字段，不选表示对所有字段进行优化。点击“字段名”或“类型”标题可进行排序，三角形尖角向上表示升序，尖角向下表示降序。
工作空间 | 优化时使用的临时目录，为空表示缺省目录。 当登录本地服务器时，可点击 [image] 按钮选择本地路径。

在[优化对象]组合框中选中要进行优化的数据库/自动模式视图，在[字段列表]列表框中选择需要优化的字段（不选表示对所有字段索引以及数据文件进行优化；如指定了字段则只优化指定字段的索引），在[工作空间]编辑框里输入优化的临时目录，然后按[确定]开始进行优化，按[取消]按钮则关闭对话框。由于优化数据是一个耗时的过程，因此，优化过程中有“优化进度”对话框显示当前正在优化的字段名及当前优化进度的百分数。如想终止优化过程，可按下对话框里的[终止]按钮。优化数据库结束后，TRS管理员会弹出“结果报告”对话框，显示优化的起始时间、终止时间、花费时间、优化字段数、致命错误等结果信息。


工具|索引维护 命令

索引维护是指对数据库/自动模式视图的索引进行创建、删除或验证操作。操作用户必须为DBA用户、或拥有者所在组的GDA用户、或对象的拥有者，或对所选对象有Index权限。
选择“工具|索引维护”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
维护对象 | 待进行索引维护的数据库/自动模式视图名。
字段列表 待进行索引维护的字段列表（设置了“不建索引”标志的字段除外），可选择一个或多个字段，点击“字段名”或“类型”标题可进行排序，三角形尖角向上表示升序，尖角向下表示降序。
按 [image] 按钮可对所选字段创建索引，对数据库需要输入创建索引的终止记录号（为零表示为所有记录创建索引），对自动模式视图只能全部创建。
按 [image] 按钮可删除所选字段上的索引，对数据库需要输入删除索引的起始记录号（为零表示删除所有记录的索引），对自动模式视图只能全部删除。
按 [image] 按钮可验证所选字段上的索引的正确性，如果验证表明某个字段的索引不正确，说明该字段的索引文件可能已被损坏，可以删除该字段的索引，然后重建，以保持索引的正确性。
有 [image] 标志的字段表示索引不完整，前面标有 [image] 标志的字段表示已验证过索引的正确性。
临界记录号 | 当前选中字段上建立索引的临界记录号，该记录号之前（包含该记录号）的记录已经建立索引，该记录号之后的记录则还没有建立索引。
最大记录号 | 当前选中字段上已经加载数据的最大记录号。
检查 | 对当前所有数据库和自动模式视图进行字段索引的不完整性检查，检查完后上方的下拉框列表中只显示字段索引不完整的数据库或自动模式视图，此时[检查]按钮变为[重置]按钮，点击重置按钮后重新显示所有的数据库和自动模式视图。

创建索引、删除索引和验证索引均为耗时操作。创建/删除索引过程中会显示进度对话框显示操作成功的总记录数和当前正在提交的索引进度的百分数。验证索引过程中会显示“验证进度”对话框，以显示正在验证索引的字段名和验证进度的百分数，验证完成后会弹出“结果报告”对话框，显示验证的起始时间、终止时间、花费时间、验证字段数、致命错误等结果信息。操作过程中按下进度对话框的里的[终止]按钮按中断操作。索引维护操作完成后，按[关闭]按钮关闭对话框。


工具|选项 命令

修改服务器的配置和TRS管理员的选项。
选择“工具|选项”命令后，TRS管理员弹出“选项”对话框。该对话框共有五页：缺省登录、集成环境、检索维护、系统配置和知识词典。其中前两页为TRS管理员的集成环境选项，后两页为当前链接的服务器的x系统配置，只有SYSTEM用户才能修改系统配置。如当前没有登录到服务器，则对话框将只含第一页。

单击对话框左部图片框中的图标可分别查看各页面的具体选项的设置。如对选项作了修改，按[确定]按钮可保存所作的修改并关闭对话框，按[应用]按钮可保存所作的修改而不关闭对话框，按[取消]按钮则放弃所作的修改并关闭对话框。


窗口|水平平铺 命令

水平平铺所有子窗口，并把所有最小化的图标排列在窗口底部。


窗口|垂直平铺 命令

垂直平铺所有子窗口，并把所有最小化的图标排列在窗口底部。


窗口|层叠 命令

层叠排列所有子窗口，并把所有最小化的图标排列在窗口底部。


窗口|排列图标 命令

把所有最小化的图标排列在窗口底部。


帮助|帮助主题 命令

显示TRS管理员的帮助主题。
由于TRS管理员的帮助系统采用HTML方式，因此，如要浏览帮助，必须确保当前的操作系统上安装了Microsoft Internet Explorer 6.0或以上版本。


帮助|TRS主页 命令

打开TRS公司站点的主页。单击工具栏右上方的 Company.gif (948 bytes) 标志也可达到同一效果。
在TRS公司的站点上，你可以了解到公司的简要介绍、最新动态、产品系列、解决方案等内容，并可获得最新的版本更新和技术支持信息。


帮助|关于 命令

显示TRS管理员的版本信息。第三行显示的是当前所登录服务器的版本（没有登录的话不显示），当前服务器不具备的功能在管理员界面里将会被屏蔽。“关于”对话框如下所示：

点击“服务器详情”按钮将弹出以下对话框，显示服务器系统和设备信息：


记录维护窗口

记录维护窗口用于数据库/视图的检索、浏览结果和维护记录。该窗口可有四种方式：只有概览、只有细览、上下分隔、表单编辑，一般缺省为上下分隔方式（上方为概览窗口，下方为细览窗口，边界可以上下调整）。左侧上部的导航窗口显示当前对象对应的导航树，左侧下部的属性窗口显示当前对象的检索属性和 上方导航树的属性。下图为上下分隔时的记录维护窗口：

记录维护窗口对应的工具栏上包含了一些常用的菜单命令，状态栏的中间部分为记录定位，显示当前记录号，并可快速定位到某条记录。另外，记录维护窗口提供了一些快捷键用于快速执行菜单命令，而窗口的每个组成部分各有相应的快捷菜单。

浏览窗口共有八个菜单：

pointblue.gif (904 bytes) 文件菜单
新建 | 创建新对象或文件
打开 | 打开已存在的文件
保存 | 保存修改过的导航和记录
另存为 | 把当前检索结果保存为文本文件
发送 | 把当前检索结果发送到其他用户
打印 | 打印当前检索结果
页面设置 | 改变打印的页面设置
显示属性 | 若属性窗口关闭，打开属性窗口
MRU文件列表 | 重新打开最近曾经用过的文件
退出 | 退出TRS管理员
pointblue.gif (904 bytes) 编辑菜单
撤消 | 撤消上一次操作
剪切 | 删除所选内容并把它放到剪贴板上
复制 | 复制所选内容到剪贴板上
粘贴 | 插入剪贴板内容
删除 | 删除所选内容
全部选定 | 选定所有内容
pointblue.gif (904 bytes) 查看菜单
工具栏 | 显示/隐藏工具栏
状态栏 | 显示/隐藏状态栏
只有概览 | 当前显示方式为只显示概览窗口
只有细览 | 当前显示方式为只显示细览窗口
上下分隔 | 当前显示方式为上方概览窗口，下方细览窗口
表单编辑 | 当前显示方式为只显示表单窗口
表格列 | 修改单元格的显示标题和宽度
字体 | 改变概览/细览的显示字体和颜色
显示导航 | 若导航窗口关闭，打开导航窗口
刷新 | 刷新当前的检索结果
对象管理 | 显示并激活对象管理器窗口
命令语言 | 打开命令语言处理工具
pointblue.gif (904 bytes) 检索菜单
按选定内容检索 | 显示所有包含当前选择内容的记录
内容排除检索 | 显示所有不包含当前选择内容的记录
升序排列 | 按当前列内容的升序排列记录
降序排列 | 按当前列内容的降序排列记录
高级检索/排序 | 高级的筛选和排序
取消检索/排序 | 取消所有的筛选和排序动作
分类统计 | 按字段值对结果进行分类统计
查询索引词 | 查询数据库或者视图里的索引词
窗口标题 | 改变记录维护窗口的标题
显示字段 | 设置概览和细览的字段
记录范围 | 指定显示记录的范围
控制选项 | 设置读取结果和记录维护的控制选项
附加参数 | 设置导航的附加参数
pointblue.gif (904 bytes) 记录菜单
直接定位 | 直接跳到指定记录
首记录 | 定位到第一条记录
上一记录 | 定位到上一条记录
下一记录 | 定位到下一条记录
尾记录 | 定位到最后一条记录
上一命中点 | 定位到上一命中点处
下一命中点 | 定位到下一命中点处
上一附件 | 打开当前记录的上一个附件
下一附件 | 打开当前记录的下一个附件
添加新记录 | 添加新记录到数据库/自动模式视图
批量更新记录 | 更新数据库/自动模式视图中的记录
批量删除记录 | 从数据库/自动模式视图中删除记录
编辑当前记录 | 进入表单方式编辑当前记录
删除选定记录 | 从数据库/自动模式视图中删除所选记录
当前记录密码 | 设置当前记录的密码
pointblue.gif (904 bytes) 工具菜单
登录 | 登录到TRS服务器
退出登录 | 切断与TRS服务器的链接
装入记录 | 装入新的数据到数据库/自动模式视图/词典中
复制记录 | 把记录从源数据库/自动模式视图复制到目标数据库/自动模式视图里
解锁数据库 | 解锁选择的数据库
备份数据 | 把数据库/自动模式视图备份到指定设备
恢复数据 | 从外围设备恢复数据库/自动模式视图
优化数据 | 优化指定的数据库/自动模式视图
索引维护 | 索引的建立、删除和验证
选项 | 修改服务器的配置和TRS管理员的选项
pointblue.gif (904 bytes) 窗口菜单
水平平铺 | 水平平铺所有子窗口
垂直平铺 | 垂直平铺所有子窗口
层叠 | 层叠排列所有子窗口
排列图标 | 把所有最小化的图标排列在窗口底部
pointblue.gif (904 bytes) 帮助菜单
帮助主题 | 显示TRS管理员的帮助主题
TRS主页 | 打开TRS公司的主页
关于 | 显示TRS管理员的版本信息


导航窗口

当右侧显示为记录维护窗口时，导航窗口显示导航树。导航树为一树型导航结构，每一个节点记录了检索条件、排序方式、统计表达式以及检索选项等信息，选中一个节点将根据这些信息重新进行检索，并按节点设置的显示方式显示检索结果。

本版本的导航窗口新增了检索条件具有蕴含关系的多级导航功能，即在继承根节点的检索条件下根据二级导航节点再次进行检索，如下图中，即是在：“读者来信”的检索结果中按照“日期”进行了第二次检索。以此类推，还可进行更多级的检索。但需要注意的是，此多级导航功能只 有在使用“自动生成”功能 的情况下才能生成，其他情况下生成的多级导航中，根节点和子节点代表的检索条件没有蕴含关系。

导航树的维护可直接在该窗口内进行，也可以在外部编辑一个导航文件，并把它载入到当前窗口里。同样，当前窗口的导航树也可以导出到一个外部的文件中。

通过工具栏各个按钮的点击，实现对导航树的维护，工具栏中的每个按钮的功能如下：

自动生成导航树
添加新导航节点
重命名当前导航节点
从外部文件里导入导航信息
把导航信息存储到外部文件里

导航树的直接维护通过快捷菜单来完成，选择相应节点并单击鼠标右键即可调出快捷菜单。在导航窗口里，如当前选择节点为根节点，快捷菜单如下：

自动生成
添加导航
重命名
粘贴
载入
导出
查看源文件
清除导航
属性 		自动生成导航树
添加新导航节点
重命名当前导航节点
插入剪贴板内容
从外部文件里导入导航信息
把导航信息存储到外部文件里
打开查看当前导航树对应的导航文件
删除当前对象对应的导航文件
修改当前导航节点的属性，若属性窗口已关闭，重新打开属性窗口

如当前选择节点不是根节点，快捷菜单如下：

自动生成
添加导航
重命名
剪切
复制
粘贴
删除
上移
下移
属性 		自动生成导航树
添加新导航节点
重命名当前导航节点
删除当前导航节点并把它放到剪贴板上
复制当前导航节点到剪贴板上
插入剪贴板内容
删除当前导航节点
当前导航节点位置上移
当前导航节点位置下移
修改当前导航节点的属性，若属性窗口已关闭，重新打开属性窗口

若在导航窗口的空白处点击右键，快捷菜单如下：

自动生成
添加导航
刷新 		自动生成导航树
添加新导航节点
刷新当前窗口

导航窗口支持节点的拖动，可以通过鼠标把一个节点及其所有子节点移动/复制到其它位置。操作方法是：按住所要移动/复制的导航节点，并把它拖动到目标节点下，然后放开鼠标左键，然后根据需要选择以下的快捷菜单命令之一：

移动到子节点
移动到邻接节点
复制到子节点
复制到邻接节点
取消 		把源节点移动到目标节点下
把源节点移动到目标节点的下一节点
把源节点复制到目标节点下
把源节点复制到目标节点的下一节点
取消节点的拖放操作

在导航窗口中，还可以用以下快捷键编辑导航树：

Insert
Delete
Space
Shift+↑
Shift+↓
Shift+Enter 		“导航|添加”命令，添加新导航节点
“导航|删除”命令，删除当前导航节点
“导航|重命名”命令，重命名当前导航节点
“导航|上移”命令，当前导航节点位置上移
“导航|下移”命令，当前导航节点位置下移
“导航|属性”命令，修改当前导航节点的属性 ，若属性窗口已关闭，重新打开属性窗口


属性窗口

当右侧显示的是记录维护窗口时，属性窗口显示当前导航节点属性和当前进行检索对象的检索信息。

窗口最上部是一个节点列表框，其下拉框中列有最近曾经显示过属性的导航节点列表，选择相应的导航节点，下方属性框中将显示其属性。

属性框里的控制显示当前的属性和当前检索对象的检索信息，具体如下：

控制名称 | 功能简介
导航参数　 | 当前导航节点的属性。
导航书签 | 导航项显示的标题。长度在1-31个字符之间，不能包含半角冒号。
统计条件 | 导航项设置的统计表达式。点击 [image] 按钮打开“表达式生成器”对话框，帮助用户生成 统计表达式。
检索条件 | 导航项设置的检索表达式。点击 [image] 按钮打开“表达式生成器”对话框，帮助用户生成检索表达式。
排序方式 | 导航项对应的结果记录的排序方式。点击点击 [image] 按钮打开“选择排序方式”对话框，帮助用户生成排序方式表达式。
缺省字段及选项 | 打开“检索选项”对话框，设置导航项的检索选项，包括自动缺省目标字段、自动扩展检索等。
按字检索 | 选中表示表意文字按字进行检索。
忽略高频词 | 忽略检索表达式所涉及到的所有高频词。
忽略停用词典 | 选中表示检索时忽略停用词典。
后进先出备选 | 当命中记录数超过了系统配置的最高限值而不能排序检索结果时，LIFO将作为备选方式排序检索结果。
总是允许排序 | 在命中记录数不超过系统配置的最高限值的情况下，“总是”允许排序检索结果。

检索信息 | 当前检索对象的检索属性。
对象列表 | 进行统计的对象，可对所有对象进行综合统计或分别对每个对象进行单独统计。
字段数 | 检索结果的字段数，相当于所有检索目标数据库的共同字段（字段名和类型都相同的字段）的总数。
总记录数 | 检索结果的总命中记录数。
有效记录数 | 实际有效的、能够读取的结果记录数。
命中点数 | 检索结果的总命中点数，只有在检索时没有指定“无命中点”选项才有效。
检索消耗时间 | 检索请求所消耗的时间（毫秒数）。如果为0，则表示服务器（可能是版本较低）没有进行时间统计。
估算部分结果 | 选中表示结果集是估算检索的部分结果，否则表示结果集是精确检索的完整结果。
统计结果 | 各统计子表达式的值。属性项左边显示一个统计子表达式，属性项右边显示其统计结果值。 若统计条件只为count(*)时，因其结果实际上就是命中记录数，所以此种情况下统计结果不作显示。

如对导航节点的属性进行了修改，点击工具栏按钮 [image] ，即可保存相关修改 ；点击工具栏按钮 [image] ，重置当前对象的属性，即恢复到上次已存的的属性 。


概览窗口

概览窗口以表格方式显示用户指定的概览字段值。如下图：

字段名显示在表格最上面的标题栏，第一列显示记录号和相关度。表格最左边的复选框为选择记录之用，可选定部分记录进行删除、更新、保存等操作。当当前记录改变的时候，细览窗口的内容会相应地作出改变。显示的字段列表可以通过选择“检索|显示字段”命令或设置导航节点的显示方式来改变，每一栏的宽度可通过拖动边界或选择“查看|表格列”来设定，缺省宽度由数据库字段的显示宽度属性决定。点击字段名可进行排序，三角形尖角向上表示升序，尖角向下表示降序 。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时排序取消。

此外，在本版本中，不同的记录增设了不同的标志，各种标志及对应记录如下：

当前记录已设密码
当前操作者的密级不够查看当前记录
当前操作者不属于当前记录的开放用户组
当前记录已被开锁
当前记录已被修改
读取当前记录失败
当前记录已在别处被删除

在概览窗口中，可以用以下编辑键移动当前记录：

←或↑
→或↓
Ctrl+Home
Ctrl+End
Tab
Shift+Tab
PageUp
PageDown 		移到上一行
移到下一行
移到整个表格第一行
移到整个表格最后一行
移到当前行的左边一列
移到当前行的右边一列
移到上一页第一行
移到下一页最后一行


细览窗口

细览窗口以浏览器的方式显示用户指定的细览字段值 ，可直接显示记录所带的图片，其他类型的附件在默认状态下以链接形式显示，单击带下划线的文字以打开或保存该文件或连接。但处于直接浏览记录附件状态（即 [image] 按钮按下）时，点击记录时将直接显示该记录所带的附件，或者弹出对话框询问用户是否打开或保存所带的附件，选择[打开]，将在细览窗口中直接打开此附件，选择[保存]，则可将此附件保存到指定的目录中。显示的字段列表可以通过选择“检索|显示字段”命令或设置导航节点的显示方式来改变。

上方工具栏 最前端是一个字段列表框，其下拉框中列有当前细览字段的列表，选择相应的字段会直接定位到该字段处。工具栏上其他各按钮的具体功能如下：

定位到上一命中点处
定位到下一命中点处
返回显示细览字段和附件列表的主页
打开当前记录的上一个附件
打开当前记录的下一个附件
直接浏览记录的附件
直接显示记录所带的jpg或者gif类型图片
停止显示当前件附件
重新装入并显示当前附件

细览窗口的快捷菜单如下所示：

按选定内容检索
内容排除检索
复制
全部选定 		显示所有包含当前选择内容的记录
显示所有不包含当前选择内容的记录
复制所选内容到剪贴板上
选定所有内容

在细览窗口中，可以用以下编辑键移动选择文本：

←
Ctrl+←
→
Ctrl+→
↑
↓
Home
End
PageUp
PageDown
Shift+移动键

Ctrl+Home
Ctrl+End
Ctrl+PageUp
Ctrl+PageDown 		插入点左移一个字符
插入点左移一个单词
插入点右移一个字符
插入点左移一个单词
插入上移一行
插入点下移一行
插入点移到行首
插入点移到行尾
屏幕上滚一屏
屏幕下滚一屏
选择文本

滚动到文本的头一个字符
滚动到文本的最后一个字符
滚动到屏幕最顶端
滚动到屏幕最底端


表单窗口

表单窗口以表单方式显示用户指定的字段值，每一个字段对应一个编辑框，可直接在编辑框里修改字段值。对于DOCUMENT/BIT型字段可点击右边按钮 [image] 或者 [image] 打开“选择文件”对话框添加文件，点击按钮 [image] 删除文件。显示的字段列表可以通过选择“检索|显示字段”命令或设置导航节点的显示方式来改变。
本版本表单窗口新增了编辑框位置和大小的设计。点击 [image] 按钮，所有编辑框变灰，表单窗口处于控件设计状态。点击某一个编辑框，可对其大小进行改变或者随意拖动其位置。修改完以后点击 [image] 按钮即可保存这些设置，下次再打开此对象的表单窗口时，将自动恢复上一次对各编辑框的设置。

同时，日期、字符型字段可以进行可能值的选择：

上方工具栏最前端是当前记录的标志图标，不同的标志代表不同的记录状态，如下所示：

当前记录为新纪录
当前记录已设密码
当前操作者的密级不够查看当前记录
当前操作者不属于当前记录的开放用户组
当前记录已被开锁
当前记录已被修改
读取当前记录失败
当前记录已在别处被删除

下图即为控件设计状态，用户可自己对编辑框的位置和大小进行调整：

标志后面是一个字段列表框，其下拉框中列有当前可修改的各字段的列表，选择某一字段，输入焦点将定位到相应的字段编辑框处。工具栏上其它按钮的具体功能如下：

保存当前所做的修改并返回原先的浏览状态
放弃当前所做修改并返回原先的浏览状态
对当前窗口中各编辑框的大小及位置进行修改
所选控件靠左对齐
所选控件水平居中对齐
所选控件靠右对齐
所选控件靠上对齐
所选控件垂直居中对齐
所选控件靠下对齐
使所选控件的宽度相同
使所选控件的高度相同
使所选控件的大小相同
以网格方式显示界面
弹出“布局设置”对话框，对网格的间距和标签的宽度等进行设置

表单窗口的快捷菜单如下所示（仅针对窗口里当前拥有输入焦点的编辑框）：

按选定内容检索
内容排除检索
撤消
剪切
复制
粘贴
删除
全部选定 		显示所有包含当前选择内容的记录
显示所有不包含当前选择内容的记录
撤消上一次操作
删除所选内容并把它放到剪贴板上
复制所选内容到剪贴板上
插入剪贴板内容
删除所选内容
选定所有内容

在表单窗口中，可以用以下编辑键切换当前编辑框和编辑文本：

←
Ctrl+←
→
Ctrl+→
↑
↓
Home
End
PageUp
PageDown
Shift+移动键

Enter
Delete
Ctrl+Delete
Back
Ctrl+Back
Ctrl+Home
Ctrl+End
Ctrl+PageUp
Ctrl+PageDown
Ctrl+Shift+Tab

Tab
Shift+Tab 		插入点左移一个字符
插入点左移一个单词
插入点右移一个字符
插入点左移一个单词
插入上移一行
插入点下移一行
插入点移到行首
插入点移到行尾
屏幕上滚一屏
屏幕下滚一屏
选择文本

换行
删除插入点后的字符或所选内容
删除插入点后的单词
删除插入点前的字符
删除插入点前的单词
滚动到文本的头一个字符
滚动到文本的最后一个字符
滚动到屏幕最顶端
滚动到屏幕最底端
插入一个制表符

把输入焦点转移到下一编辑框
把输入焦点转移到上一编辑框


记录维护窗口的工具栏

记录维护窗口的工具栏如下图：

工具栏上各按钮的功能如下：
FileNew.gif (923 bytes) 新建 | 创建新对象或文档
FileOpen.gif (938 bytes) 打开 | 打开已存在的文档
FileSave.gif (935 bytes) 保存 | 保存修改过的导航和记录
ViewOpenNavi.gif (948 bytes) 显示导航 | 若导航窗口关闭，打开导航窗口
FileProperties.gif (941 bytes) 显示属性 | 若属性窗口关闭，打开属性窗口
EditCut.gif (928 bytes) 剪切 | 删除所选内容并把它放到剪贴板上
EditCopy.gif (943 bytes) 复制 | 复制所选内容到剪贴板上
EditPaste.gif (959 bytes) 粘贴 | 插入剪贴板内容
EditClear.gif (918 bytes) 删除 | 删除所选内容
EditUndo.gif (915 bytes) 撤消 | 撤消上一次操作
ViewResh.gif (915 bytes) 刷新 | 刷新当前窗口
ViewIcon.gif (917 bytes) 按选定内容检索 | 显示所有包含当前选择内容的记录
ViewSmallIcon.gif (910 bytes) 内容排除检索 | 显示所有不包含当前选择内容的记录
ViewDetail.gif (918 bytes) 取消检索/排序 | 取消所有的筛选和排序动作
分类统计 | 按字段值对检索结果进行分类统计
执行检索 | 直接按照检索历史框里的检索表达式进行检索
ViewList.gif (926 bytes) 高级检索/排序 | 高级的筛选和排序
HelpContent.gif (956 bytes) 帮助主题 | 显示TRS管理员的帮助主题

工具栏上的检索历史组合框用于保存检索历史和输入检索表达式。在检索历史组合框里输入或选择检索条件，再按回车键或者点击 [image] 按钮，即可按新检索条件重新进行检索（注意：检索结果是相对于当前导航的二次检索）。
单击工具栏最右方的 Company.gif (948 bytes) 图标可打开TRS公司主页。


记录维护窗口的状态栏

记录维护窗口的状态栏如下图：

状态栏最左边部分用于显示菜单命令、工具栏按钮、操作结果等提示信息。中间为记录定位部分，显示当前记录号，并可快速定位到某条记录。后边的两个状态框分别显示键盘的数字键和大小写状态。最右边的 Manager.gif (943 bytes) 和 Command.gif (971 bytes) 按钮则分别用于显示对象管理窗口和打开命令语言处理工具。

记录定位部分中间的编辑框显示当前记录号，最右端显示当前检索结果的总记录数。如要直接定位到某条记录，请在该编辑框内输入目标记录的序号，然后按回车键。记录定位部分还有几个小图标按钮，它们的作用分别是：

RecordFirst.gif (843 bytes) 首记录 | 定位到第一条记录
RecordPrev.gif (831 bytes) 上一记录 | 定位到上一条记录
RecordNext.gif (830 bytes) 下一记录 | 定位到下一条记录
RecordLast.gif (845 bytes) 尾记录 | 定位到最后一条记录
RecordInsert.gif (829 bytes) 添加新记录 | 添加新记录到数据库/自动模式视图
修改当前记录 | 进入表单方式编辑当前记录
RecordDelete.gif (848 bytes) 删除选定记录 | 从数据库/自动模式视图中删除所选记录


记录维护窗口的快捷键和编辑键

记录维护窗口的快捷键

浏览管理窗口可用的快捷键如下：

Ctrl+N
Ctrl+O
Ctrl+S
Ctrl+M
Ctrl+P
Alt+Enter

Ctrl+Z
Ctrl+X
Ctrl+C
Ctrl+V
Del
Ctrl+A

Ctrl+L
Alt+Home
Alt+↑
Alt+↓
Alt+End
Alt+PgUp
Alt+PgDn
Shift+Enter
Alt+←
Alt+→
Ctrl+I
Ctrl+U
Ctrl+D

Ctrl+Tab
F1
F2
F3
F5 		“文件|新建”命令，创建新对象或文件
“文件|打开”命令，打开已存在的文件
“文件|保存”命令，保存修改过的导航和记录
“文件|发送”命令，把当前检索结果发送到其他用户
“文件|打印”命令，打印当前检索结果
“文件|检索属性”命令，显示检索结果属性

“编辑|撤消”命令，撤消上一次操作
“编辑|剪切”命令，删除所选内容并把它放到剪贴板上
“编辑|复制”命令，复制所选内容到剪贴板上
“编辑|粘贴”命令，插入剪贴板内容
“编辑|删除”命令，删除所选内容
“编辑|全部选定”命令，选定所有内容

“记录|直接定位”命令，直接跳到指定记录
“记录|首记录”命令，定位到首记录
“记录|上一记录”命令，定位到上一条记录
“记录|下一记录”命令，定位到下一条记录
“记录|尾记录”命令，定位到尾记录
记录上翻一屏，例如一屏有10条记录则定位到当前记录后的第10条记录
记录下翻一屏，例如一屏有10条记录则定位到当前记录前的第10条记录
打开当前插入点所在位置的文件
“记录|上一个文件”命令，打开当前记录字段的上一个文件
“记录|下一个文件”命令，打开当前记录字段的下一个文件
“记录|添加记录”命令，添加新记录到数据库
“记录|更新记录”命令，更新数据库中的记录
“记录|删除记录”命令，从数据库中删除记录

在浏览窗口的各个部分之间切换
显示当前所在窗口、菜单、控制的帮助信息
“查看|对象管理”命令，显示并激活对象管理器窗口
“查看|命令语言”命令，打开命令语言处理工具
“查看|刷新”命令，刷新当前的检索结果


文件|保存 命令

保存导航文件以及插入/修改的记录。
选择“文件|保存”命令，或按工具栏上的 FileSave.gif (935 bytes) 按钮，TRS管理员将把修改后的导航信息保存到导航文件里，然后把插入/修改的记录更新到数据库里，最后重新刷新检索结果。


文件|另存为 命令

把当前检索结果的全部或部分保存为文本文件。
选择“文件|另存为”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
目标文件名 | 保存的目标文件名，可按右边的 [image] 按钮来选择目标文件名。
字段列表 | 需要保存的字段列表。可按右边的 Select.gif (956 bytes) 按钮来选择字段列表。

记录范围 | 需要保存的记录的范围，缺省为所有记录。
当前记录 | 只保存当前记录。
所有记录 | 保存检索结果里的所有记录。
指定范围 | 保存指定范围的记录，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。
每批读取 | 设置每批读取的记录数，最大值是5120，不设置即和系统的默认值一致。
每文件存限制 | 设置每个文件存放记录的条数，清空或为零表示不限制，最大值为FFFFFFFD。

保存格式 | 结果保存的格式，缺省为TRS装库数据格式。
记录文件 | 以记录数据格式保存检索结果，一般只需浏览检索结果时选择此格式。
装库文件 | 以TRS装库数据格式保存检索结果，所保存的文件可以用来重新进行装库。
ISO2709文件 | 以ISO2709国际标准格式保存检索结果。
XML文件 | 以XML格式保存检索结果。
传输装库文件 | 以传输格式保存检索结果。传输格式是数据加载时用于传输一批记录的内部格式文件。这种格式的一个最大优点是能够将文本与非文本数据打包在一个文件里，避免大量外挂文件可能引起的性能问题。
保存记录ID | 保存记录时保存记录的ID。
压缩字段值 | 存储字段值时进行压缩，仅可与传输格式组合使用。
添加记录前缀 | 记录及字段标记前添加的引导前缀，只对装库文件格式有效。

文件选项 | 保存的目标文件和保存附件的相关选项。
保存附件方式 | 保存记录里包含的源文件的模式。
附件存放目录 | 指定记录所含附件存放的目录。
每组容纳文件 | 指记录附件存放的目录中，每个目录容纳多少个附件，最大值为32768。若为0或者清空表示不限制，即所有附件存入目标文件所在的目录中；若指定了数值比如为10，则每个目录中存储10个附件，附件目录自动按顺序号生成。
最大文件长度 | 设置保存的目标文件的最大长度，清空或为零时取缺省值2G。若当前所要保存的记录大小超过此数值，将自动分为N个大小为此数值的目标文件进行保存，如Demo2_1.trs、Demo2_2.trs...
超时重试时间 | 读取记录超时后等待重试的时间，以秒为单位。

输入目标文件名，设置保存字段、记录范围、保存格式等选项以后，按[确定]，TRS管理员将开始保存检索结果到目标文件里。按[取消]则放弃保存操作并关闭对话框。由于保存检索结果是一个耗时过程，因此保存过程中有“保存进度“对话框显示目前已保存的记录数和保存完成的百分比。如要终止保存过程，可按[终止]按钮。


文件|发送 命令

把当前检索结果的一部分或全部发送到其他用户。
选择“文件|发送”命令，TRS管理员将首先打开“另存为”对话框，把检索结果的指定部分保存到一个临时文件里（文件名由TRS管理员决定）。然后将调用相应的邮件处理软件（如Microsoft Outlook Express等），用户可以利用该软件把检索结果临时文件发送到其他用户手里。最后，TRS管理员自动删除检索结果临时文件。


文件|打印 命令

打印当前检索结果的一部分或全部。
选择“文件|打印”命令，TRS管理员将首先打开“另存为”对话框，把检索结果的指定部分保存到一个临时文件里（文件名由TRS管理员决定），然后弹出如下对话框：

在对话框中选择目标打印机，输入打印份数后，按[确定]键后，TRS管理员将开始打印检索结果临时文件，按[取消]则放弃打印操作。由于打印文件是一个耗时过程，因此打印过程中会显示“打印进度”对话框，显示当前已打印的页数和打印完成的百分比，按[终止]按钮将中断打印过程。打印完毕后，TRS管理员将自动删除检索结果临时文件。


文件|页面设置 命令

设置打印纸张及打印的页面参数。
选择“文件|页面设置”命令，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
纸张 | 指定打印纸张的大小和来源。
大小 | 指定要使用的纸张或信封大小。
来源 | 指定纸张在打印机上的位置。不同打印机有不同的纸张来源，如上层纸盒、信封送纸器和手动送纸器等。

方向 | 显示整个文档在整个页面上的位置。
纵向 | 纵向打印文件。
横向 | 横向打印文件。

页边距 | 设置页面的打印区域。此处设置的边距不在打印范围内。
左 | 设置页面的左边距，缺省为10mm。
右 | 设置页面的右边距，缺省为10mm。
上 | 设置页面的上边距，缺省为10mm。
下 | 设置页面的下边距，缺省为10mm。

每改变一个选项，对话框上部的预览画面都会相应地作出调整。按[确定]，所作设置将作为打印时的页面设置；按[取消]将放弃所作的设置并关闭对话框；按[打印机]将选择打印的目标打印机。


编辑|撤消 命令

取消上一次编辑操作。
该命令只对细览窗口和表单编辑窗口有效，对导航窗口无效。


编辑|剪切 命令

删除所选内容并把它放到剪贴板。
在细览窗口或表单编辑窗口中，剪切当前编辑框中所选的文本；在导航窗口中，剪切当前的导航节点（根节点除外）。使用此功能可以在快速地移动文本/导航节点。先选择需要移动的文本/导航节点，再选择“编辑|剪切”命令把所选文本/导航节点剪切到剪贴板，然后选择待移动的目标位置，最后选择“编辑|粘贴”命令粘贴剪贴板里的文本/导航节点（目标节点必须是文件夹节点）。


编辑|复制 命令

把当前选择内容复制到剪贴板。
在细览窗口或表单编辑窗口中，复制当前编辑框中所选的文本；在导航窗口中，复制当前的导航节点。使用此功能可以在快速地复制文本/导航节点。先选择需要复制的文本/导航节点，再选择“编辑|剪切”命令把所选文本/导航节点剪切到剪贴板，然后选择待复制的目标位置，最后选择“编辑|粘贴”命令粘贴剪贴板里的文本/导航节点（目标节点必须是文件夹节点）。


编辑|粘贴 命令

把剪贴板内容插入到当前位置。
在细览窗口或表单编辑窗口中，剪贴板里的文本插入到编辑框中；在导航窗口中，把剪贴板里的导航节点插入当前节点里（当前节点必须是一个文件夹节点）。使用此功能可以在快速地移动/复制文本/导航节点。先选择需要移动/复制的文本/导航节点，再选择“编辑|剪切”或“编辑|复制”命令把所选文本/导航节点剪切/复制到剪贴板，然后选择待移动/复制的目标位置，最后选择“编辑|粘贴”命令粘贴剪贴板里的文本/导航节点（目标节点必须是文件夹节点）。


编辑|删除 命令

删除当前选择内容。
在细览窗口或表单编辑窗口中，删除当前编辑框中所选的文本；在导航窗口中，删除当前的导航节点（根节点除外）。


编辑|全部选定 命令

选定当前的全部内容。
在细览窗口或表单窗口中，选择当前编辑框所有文本；在导航窗口中，该命令无效。


查看|只有概览 命令

当前记录维护窗口的显示方式为只显示概览窗口。
如检索结果没有DOCUMENT/BIT字段，则默认采取“只有概览”显示方式。


查看|只有细览 命令

当前记录维护窗口的显示方式为只显示细览窗口。
如检索结果没有DATE、NUMBER、CHAR、PHRASE字段则默认采取“只有细览”显示方式。


查看|上下分隔 命令

当前记录维护窗口的显示方式为上方为概览窗口，下方为细览窗口，边界可以上下调整。
如检索结果既有DOCUMENT/BIT字段，也有DATE、NUMBER、CHAR、PHRASE字段，则默认采取“只有概览”显示方式。


查看|表单编辑 命令

当前记录维护窗口的显示方式为只显示表单窗口。


查看|表格列 命令

修改单元格的显示标题和宽度。
选择“查看|表格列”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
字段列表 | 当前显示的所有概览字段。
显示标签 | 当前选定字段的显示标题，缺省为该字段的字段名。
显示宽度 | 当前选定字段的显示宽度，缺省情况下为字段规定的显示宽度（以字符为单位）。
缺省宽度 | 选中表示把该字段的显示宽度设为缺省值。

修改完各概览字段的显示标题和宽度后，按[确定]，所作修改将影响概览窗口的显示。按[取消]则放弃所作修改并关闭对话框。注意：所作修改并不影响下一次打开该记录维护窗口，如要修改字段标题和宽度的缺省设置，请修改字段的显示标题和显示宽度属性。


查看|刷新 命令

刷新检索结果。
选择“查看|刷新”命令后，用当前检索条件和排序方式重新进行检索，并刷新概览/细览窗口的内容。


检索|按选定内容检索 命令

显示所有当前字段包含当前选择内容的记录。
此命令仅对细览窗口和表单编辑窗口有效，且检索结果是针对当前检索结果的二次检索。如想在当前导航结果的基础上进行检索，请先选择“检索|取消检索/排序”命令，或直接在工具栏上的检索表达式组合框里输入检索条件并按回车。

注意：如果被选字段是多值字段，而且您选定的检索内容也是多值字段的话，您需要将检索表达式对话框中显示的表达式中的“;”替换为“'*'”。例如：作者多值字段：“王一;李二”，检索表达式：“作者='王一;李二'”，修改检索表达式为：“作者='王一'*作者='李二'”。


检索|内容排除检索 命令

显示所有当前字段不包含当前选择内容的记录。
此命令仅对细览窗口和表单编辑窗口有效，且检索结果是针对当前检索结果的二次检索。如想在当前导航结果的基础上进行检索，请先选择“检索|取消检索/排序”命令，或直接在工具栏上的检索表达式组合框里输入检索条件并按回车。

注意：如果被选字段是多值字段，而且您选定的检索内容也是多值字段的话，您需要将检索表达式对话框中显示的表达式中的“;”替换为“'*'”。例如：作者多值字段：“王一;李二”，检索表达式：“作者<>'王一;李二'”，修改检索表达式为：“作者<>'王一'*作者<>'李二'”。


检索|升序排列 命令

按当前列内容的升序排列记录。
此命令仅对细览窗口和表单编辑窗口有效，且排序只针对当前检索结果，在上一次排序的基础上重新进行排序。如想在当前导航结果的基础上进行排序，请先选择“检索|取消检索/排序”命令。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时排序取消。


检索|降序排列 命令

按当前列内容的降序排列记录。
此命令仅对细览窗口和表单编辑窗口有效，且只针对当前检索结果，在上一次排序的基础上重新进行排序。如想在当前导航结果的基础上进行排序，请先选择“检索|取消检索/排序”命令。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时排序取消。


检索|高级检索/排序 命令

高级的筛选和排序。
选择“检索|高级检索/排序”命令，或者选择“文件|检索”命令，或者点击工具栏上 [image] 按钮，将出现以下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
检索条件 | 检索条件表达式。缺省情况下为当前检索结果的检索条件。
按字检索 | 选中表示表意文字按字进行检索。
忽略高频词 | 忽略检索表达式所涉及到的所有高频词。
忽略停用词典 | 选中表示检索时忽略停用词典。

统计条件 | 统计结果表达式，多个表达式之间以逗号分隔，可为空。所设统计条件应用于以后的各次检索中。要查看统计结果，可选择记录维护窗口的“文件|检索信息”命令。

排序方式 | 结果记录的排序方式，可直接输入，也可以点击旁边的 Order.gif (957 bytes) 按钮打开“选择排序方式”对话框进行排序字段和选项的设置。
统一排序 | 选中表示对检索结果进行统一排序，否则将按各数据库/视图分别排序。
后进先出备选 | 当命中记录数超过了系统配置的最高限值而不能排序检索结果时，LIFO将作为备选方式排序检索结果。
总是允许排序 | 在命中记录数不超过系统配置的最高限值的情况下，“总是”允许排序检索结果。

表达式 | 打开“表达式生成器”对话框，帮助用户生成检索表达式。
索引词 | 打开“查询索引词”对话框，对数据库或者视图的索引词进行查询。
选项 | 打开“检索选项”对话框，设置检索的选项，所设选项将应用于以后的所有检索中。

设置好检索条件、统计条件、排序字段、检索选项等参数以后，按[确定]，TRS管理员会以所设参数对当前检索目标对象进行检索，并刷新记录维护窗口。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时检索排序取消。按[取消]则放弃检索，关闭对话框。


检索|取消检索/排序 命令

取消所有的筛选和排序动作，按当前导航项的检索条件和排序方式重新进行检索。


检索|分类统计 命令

按字段值对检索结果进行分类统计。
选择“检索|分类统计”命令，将出现以下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
分类字段 | 指定按值分类的字段，可以是日期、数值或字符类型字段。
关注列表 | 指定分类时只需关注的字段值，也就是说只对这些字段值所对应的结果记录进行分类统计和存储，每个值为一行（注意不是用其它符号作为分隔符）。如果为空，则缺省为所指定的字段的所有字段值。但类别的总数（识别的字段值个数）取决于系统配置所设定的最大数。
排序方式 | 结果记录的排序方式，为空表示不改变原来的排序方式。点击 [image] 按钮弹出“选择排序方式”对话框，帮助用户生成排序方式表达式。
统一排序 | 选中表示在检索结果所涉及的所有数据库上进行混合排序，否则将在每个视图或物理数据库中进行独立排序。
正则表达式 | 选中表示关注列表里给出的是一个正则表达式，用以筛选符合条件的字段值。
区分大小写 | 选中表示字段值区分大小写。
保留记录 | 每个类中保留结果记录的个数：0表示对结果记录只进行类别统计，而不改变结果记录的存储；65535表示对结果记录进行类别统计，并按类别存储和保留所有的结果记录；其它值表示对结果记录进行类别统计，并按类别存储，每个所保留的结果记录数不超过这里所指定的值。
结果列表 | 分类统计的结果列表，每行显示其类别名、总记录数和有效记录数。单击“类别名”、“总记录”和“有效记录”标题可改变其排列顺序，三角形尖角向上表示升序，尖角向下表示降序，缺省为升序排列。 其中，单击“总记录”标题只有在保留个数为0时才能对其排序。

分类 | 执行分类统计并把结果显示在列表里。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时分类取消。
关闭 | 关闭“分类统计结果”对话框。

设置好分类字段、关注列表、排序方式、保留个数等参数以后，按[分类]，TRS管理员会以所设参数对当前检索结果进行分类统计，并把结果显示在列表里。按[关闭]则关闭对话框，如果分类操作对检索结果作了改变将刷新浏览窗口，直至重新进行检索或排序操作。


检索|查询索引词 对话框

查询索引词 对话框

查询数据库或者视图里的索引词。
在记录维护窗口选择“检索|高级检索/排序”命令，或者在“高级检索/排序”对话框里，按[索引词]按钮，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行索引词查询，并把结果显示在结果列表里。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时查询取消。
显示个数 | 显示结果的个数，缺省为不设置。
当前页面 | 当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。
结果列表 | 查询结果的索引词列表，每页显示个数可在“选项|集成环境”里设定，缺省为100个。每个索引词显示其词语、命中数和词频数，如词语前方带 PrevPage.gif (876 bytes) 表示按词索引，带 PrevPage.gif (876 bytes) 表示按字索引，带 PrevPage.gif (876 bytes) 表示字词混合索引。要看其它页的索引词信息，可用 PrevPage.gif (876 bytes) 和 NextPage.gif (876 bytes) 按钮进行前后翻页。点击“词语”、“命中数”和“词频数”标题可进行排序，三角形尖角向上表示升序，尖角向下表示降序。
对象名 | 待查询的目标数据库名或者视图名。改变查询对象将重新检索索引词并刷新检索列表。
字段名 | 待查询的字段名，为空表示不进行查询。改变查询字段将重新检索索引词并刷新检索列表。

复制 | 把结果列表里当前选中的检索词复制到“高级检索/排序”对话框的检索条件编辑框里。
关闭 | 关闭“查询索引词”对话框。
另存为 | 打开“词语导出”对话框，把当前查询结果的一部分或全部保存到一个文件里。

查询完毕后，按[复制]或直接双击结果列表的索引词项将把指定索引词复制到“高级检索/排序”对话框的检索条件编辑框里。按[关闭]则关闭对话框。


检索|窗口标题 命令

改变记录维护窗口的标题。
选择“检索|窗口标题”命令后，将弹出对话框要求用户记录维护窗口的标题。输入完毕后按[确定]，当前浏览窗口的标题将被变为所输入的新字符串，并把标题保存在导航文件的修改记载里，保存修改结果时会把这些设置写入导航文件，这样下一次打开此窗口时将自动恢复上一次设置的标题。


检索|显示字段 命令

指定显示的概览字段和细览字段。
选择“检索|显示字段”命令，将出现以下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
字段列表 | 未选择的字段列表，该列表里的字段将不在记录维护窗口里显示。按上边的 MoveRight.gif (925 bytes) 按钮可把当前选中的字段加入概览字段列表中，按下边的 MoveRight.gif (925 bytes) 按钮可把当前选中的字段加入细览字段列表中。
概览字段 | 显示的概览字段列表，该列表里的字段将按指定顺序显示在概览窗口中。按上边的 MoveLeft.gif (923 bytes) 按钮把当前选中字段清除出概览字段列表，用概览字段列表框右边的 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮可调整概览字段的顺序。
细览字段 | 显示的细览字段列表，该列表里的字段将按指定顺序显示在细览窗口中。按下边的 MoveLeft.gif (923 bytes) 按钮把当前选中字段清除出细览字段列表，用细览字段列表框右边的 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮可调整细览字段的顺序。
全部清除 | 清除所有概览/细览字段，重新进行设置。
自动重置 | 自动将全文型(DOCUMENT)字段和二进制型(BIT)字段设为细览字段，其他类型的字段设为概览字段。

设置好概览/细览字段列表以后，按[确定]将改变概览/细览窗口的显示字段，并把所有设置保存在导航文件的修改记载里，保存修改结果时会把这些设置写入导航文件，这样下一次打开此对象时将自动恢复上一次的设置。按[取消]放弃所有设置并关闭对话框。


检索|记录范围 命令

指定显示记录的范围。
当检索结果记录数太多时，可用此命令设置只显示一定范围的记录，以方便查看。选择“检索|记录范围”命令，将出现以下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
记录范围 | 显示记录的范围。列表里的每一项为一个分段，每个分段可以是单个记录的逻辑记录号，也可以用“起始记录号-终止记录号”的形式表示一定范围内的记录，多个分段之间不能重叠。可用 [image] 按钮添加新的分段，也可用 [image] 按钮删除当前选中的分段，或者用 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮调整记录分段的顺序。
全部清除 | 清除所有记录范围的列表，重新进行设置。

设置好记录范围以后，按[确定]将改变当前显示记录的范围，在此范围之外的记录将不会被显示出来。记录范围的设置将保存在导航文件的修改记载里，保存修改结果时会把这些设置写入导航文件，这样下一次打开此对象时将自动恢复上一次的设置。按[取消]放弃所有设置并关闭对话框。


记录|数据控制参数 菜单

检索|控制选项 命令

设置读取结果和记录维护的控制选项。

选择“检索|控制选项”命令，将看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
读取记录 | 读取结果记录内容的选项。
多值分隔 | 数据记录文件中多值字段DATE、NUMBER、CHAR、BIT的各个字段值之间的分隔符，缺省为单字节“;”。
自动折行 | 只对DOCUMENT和PHRASE字段有效，其中"所有文本不分行"选项一般用于细览字段以便于控制其显示格式，"段落文本不分行"一般用于细览字段以便于自动换行。
提取格式化文本 | 只对DOCUMENT字段有效，表示只存储了单个格式化文档字段值的字段，尽量提取文本并给出命中点。
输出原始的相关度值 | 选中表示对URL(统一资源定位)输出其对应的文件(如HTML等)，而不是输出URL本身。缺省值为清除。
对URL输出对应文件 | 输出记录的原始（绝对）相关度值，而不是缺省方式的相对相关度值。

控制文件 | 设置用于插入/更新记录的装库控制文件。按 [image] 按钮可选择装库控制文件，按 [image] 按钮可以对话框的方式设置具体的装库参数。


检索|附加参数 命令

设置导航的附加参数，供用户保存一些附加导航信息以及供将来扩展时所用。
选择“检索|附加参数”命令后，将弹出如下对话框：

对话框中各控制的含义如下：

控制名称 | 功能简介
参数列表 | 显示当前设置的附加参数，这些参数将保存在导航文件里。右上角的 [image] 、 [image] 和 [image] 按钮分别用于添加、修改和删除参数。

设置好参数列表以后，按[确定]将把参数列表保存在导航文件的修改记载里，保存修改结果时会把这些设置写入导航文件，这样下一次打开此对象时将自动恢复上一次的设置。按[取消]放弃所有修改并关闭对话框。


记录|直接定位 命令

直接跳到指定记录。
选择“记录|直接定位”命令以后，TRS管理员会弹出对话框提示用户输入需要定位的目标记录。输入完毕以后按[确定]，则直接跳到指定记录，按[取消]则放弃定位并关闭对话框。有一种简便的方法也可以实现此功能：直接在状态栏的“记录定位”编辑框里输入目标记录的逻辑记录号，然后按回车，即可快速定位到指定记录。


记录|首记录 命令

定位到首记录。快捷键为Alt+Home，或按状态栏上的 RecordFirst.gif (843 bytes) 按钮。


记录|上一记录 菜单

记录|上一记录 命令

定位到上一记录。 快捷键为Alt+↑，或按状态栏上的 RecordPrev.gif (831 bytes) 按钮。


记录|下一记录 命令

定位到下一记录。 快捷键为Alt+↓，或按状态栏上的 RecordNext.gif (830 bytes) 按钮。


记录|尾记录 命令

定位到尾记录。快捷键为Alt+End，或按状态栏上的 RecordLast.gif (845 bytes) 按钮。


记录|上一命中点 菜单

记录|上一命中点 命令

定位到上一个命中点处。
对当前对象进行检索后，细览窗口中短语型(PHRASE)和全文型(DOCUMENT)字段中的命中点会以特殊的颜色显示，便于查看。点击此命令 后，将定位到当前位置前的上一个命中点处，命中点以蓝色反显。


记录|下一命中点 菜单

记录|下一命中点 命令

定位到下一个命中点处。
对当前对象进行检索后，细览窗口中短语型(PHRASE)和全文型(DOCUMENT)字段中的命中点会以特殊的颜色显示，便于查看。点击此命令后，将定位到当前位置 后的下一个命中点处，命中点以蓝色反显。


记录|上一附件 菜单

记录|上一附件 命令

打开当前记录的上一个附件。
若当前处于附件直接浏览状态（即 [image] 按钮按下），且当前所浏览的附件不是当前记录的头一个附件时，选择此命令可以浏览本记录的上一个附件。本命令的快捷键为Alt+←。


记录|下一附件 命令

打开当前记录的下一个文件。
若当前处于附件直接浏览状态（即 [image] 按钮按下时），且当前所浏览的附件不是当前记录的最后一个附件时，选择此命令可以浏览本记录的下一个附件。本命令的快捷键为Alt+ →。


记录|添加新记录 菜单

记录|添加新记录 命令

添加新记录到数据库/自动模式视图。
选择“记录|添加记录”命令，或按下状态栏上的 RecordInsert.gif (829 bytes) 按钮后，浏览窗口将会 切换到表单编辑方式，并在最后增加一条空白记录。用户可以填入各字段的值，之后还可以继续添加其它的记录。选择“文件|保存”命令，或按工具栏上的 FileSave.gif (935 bytes) 按钮后，这些新记录将被添加到数据库/自动模式视图中。


记录|批量更新记录 菜单

记录|批量更新记录 命令

更新数据库/自动模式视图中的记录，分为“指定字段值”和“指定文件”两种方式。
更新单条记录可以直接在表单窗口当中修改，概览/细览模式下按状态栏上的 [image] 按钮，会进入表单编辑模式，可对记录进行修改后按“保存修改”按钮，将保存更新并返回原显示状态。本命令主要是针对批量更新记录而设置的 ，选择“记录|批量更新记录”命令，将看到如下对话框：

选择“指定文件”方式，则变为下图形式：

对话框中各控制的说明如下：

控制名称 | 功能简介
指定字段值 | 通过指定字段值方式对记录进行批量更新，每一行表示一个需要更新的字段及对应的取值。按 [image] 按钮会弹出“添加字段值”对象框，选择需要更新的字段及对应的字段值，更新的字段名不能重复，即已加入列表框的字段不能再被选择；也可以按 [image] 按钮修改当前选中的字段值；或按 [image] 按钮删除当前选中的字段值。
记录范围 | 需要更新的记录的范围，缺省为当前记录。
当前记录 | 只更新当前记录。
所有记录 | 更新检索结果里的所有记录。
指定范围 | 更新指定范围的记录，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。
指定条件 | 更新指定条件的记录，该条件和当前检索条件的与就是待更新的记录的范围。

指定文件 | 通过记录格式文件对记录进行批量更新。
数据文件 | 即用来批量修改记录的记录格式文件。按 [image] 按钮可选择数据文件的路径。
影射字段 | 指定要批量修改的字段名，或者DOCID。比如选择字段“标题”，在数据文件中又有若干<标题>=value的记录，那么这些记录中的数据即会用来修改原数据库中“标题”为value的记录 。
记录格式 | 数据记录文件的格式，缺省为标准TRS格式。
直通模式 | 选中表示以“直通模式”加载数据。如果数据加载所涉及到所有原始数据文件、批处理文件、控制文件，服务器的启动帐号都有读取权限，则可使用直通模式进行数据加载。由于直通模式下服务器直接读取原始数据文件，从而减少了中间环节，所以效率会更高。
允许新记录 | 选中表示允许源记录格式文件中出现的新记录，即记录格式文件中的某些记录在原数据库中不存在 。

控制文件 | 设置用于更新记录的装库控制文件。按 [image] 按钮可选择装库控制文件，按 [image] 按钮可以对话框的方式设置具体的装库参数。
密码 | 打开“记录密码”对话框，设置记录的密码、安全级别和公开用户组名等安全设置。

设置好各指定项后按[确定]，TRS管理员将开始更新指定范围的记录，更新完毕后刷新检索结果。更新过程中会弹出对话框显示更新的进度。若此操作费时较长，可在过程中按Ctrl+Break中断操作，后面还未更新的记录将不再更新，前面已更新了的记录保持更新。按[取消]则放弃更新操作并关闭对话框。


记录|批量删除记录 菜单

记录|批量删除记录 命令

从数据库/自动模式视图中删除记录。
选择“记录|批量删除记录”命令，将看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
记录范围 | 需要删除的记录的范围，缺省为当前记录。
当前记录 | 只删除当前记录。
所有记录 | 删除检索结果里的所有记录。
指定范围 | 删除指定范围的记录，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。
指定条件 | 删除指定条件的记录，该条件和当前检索条件的与就是待删除的记录的范围。

快速逻辑删除 | 选中表示只在所删记录上作个标记，而并不真正从数据库中删除它，这些删除的记录只有在优化数据库的时候才会被真正地清除。快速删除可加快删除的操作速度，为缺省设置。

设置好删除范围后，按[确定]，TRS管理员将开始删除指定范围的记录，删除完毕后刷新检索结果。删除过程中会弹出对话框显示删除的进度。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时删除取消。按[取消]则放弃删除操作并关闭对话框。如要快速删除当前选择的记录而不刷新检索结果，可按状态栏上的 RecordDelete.gif (848 bytes) 按钮，这些记录会在保存修改结果的时候从数据库里删除。


记录|编辑当前记录 菜单

记录|编辑当前记录 命令

切换到表单编辑状态修改当前记录。
选择“记录|修改记录”命令，或按下状态栏上的 [image] 按钮后，浏览窗口将会 切换到表单编辑方式。用户可以修改记录中各字段的值，也可以移动到其他记录继续编辑。选择“文件|保存”命令，或按工具栏上的 FileSave.gif (935 bytes) 按钮后， 修改的结果将被保存到数据库/自动模式视图中。


记录|删除选定记录 菜单

记录|删除选定记录 命令

快速逻辑删除当前选择的记录。
选择“记录|删除选定记录”命令，或按下状态栏上的 RecordDelete.gif (848 bytes) 按钮后， 管理员将弹出提示对话框，确认并选择“文件|保存”命令、或按工具栏上的 FileSave.gif (935 bytes) 按钮后， 这些选择的记录将从数据库/自动模式视图中快速逻辑删除。


记录|记录密码 菜单

记录|当前记录密码 命令

设置当前记录的密码、安全级别和开放用户组名等安全设置。
选择“记录|当前记录密码”命令，或在“更新记录”对话框里按下“密码”按钮后，将弹出以下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
设置密码 | 设置记录的访问密码。为保密起见，所输入的字符以“*”显示 。密码有效长度是1-8个字符。此控制项初始化为8个“*”，在第一次设置该记录密码时，表示密码为空；在修改记录的密码时，表示保持原密码。若此控制项为空，表示没有密码。当所输入密码首尾出现空格时，Admin会自动将其去除，但密码中间可以包含空格。
确认密码 | 确认记录的访问密码，必须与设置密码一致。为保密起见，所输入的字符以“*”显示。
安全级别 | 赋予记录的安全级别，访问这些记录时操作者的安全级别必须不大于此安全级别。为零表示访问此记录无须经过安全级别检查。缺省值为空，表示不进行设置。
开放组名 | 记录对外开放的用户组，该用户组的所有用户无须经过权限检查就可访问这些记录。为“(不作限制)”表示不限制开放组，即对所有组开放。缺省为空串，表示不修改上次的设置。

输入记录的新密码、安全级别，选择好开放组名后，按[确定]，这些设置将被保存起来。在保存修改或更新记录的时候，这些设置将被更新到数据库里。以后需要读取记录时，如设置了记录的密码，TRS管理员将弹出对话框要求输入该记录的正确密码，如所输密码不正确，将无法浏览该记录。


文件编辑窗口

文件编辑窗口用于创建和编辑文本文件。它的用法与Windows的记事本类似，功能有所增强，并能编辑大于64K的文件。TRS管理员还提供了针对不同类型文件的向导，用于快速地生成导航文件、装库数据文件、批装库文件和装库控制文件的模板。 左侧的属性窗口同时显示当前文件的属性。以下是打开了一个".txt"文件的编辑窗口：

文件编辑窗口对应的工具栏上包含了一些常用的菜单命令，状态栏的中间部分显示当前插入点所在的行和列。另外，文件编辑窗口提供了一些快捷键和快捷菜单用于快速执行菜单命令。

文本编辑窗口共有以下六个菜单：

pointblue.gif (904 bytes) 文件菜单
新建 | 创建新对象或文件
打开 | 打开已存在的文件
保存 | 保存当前文件
另存为 | 把当前文件以新名字保存
发送 | 把当前文件发送到其他用户
打印 | 打印当前文件
页面设置 | 改变打印的页面设置
显示属性 | 若属性窗口关闭，打开属性窗口
MRU文件列表 | 重新打开最近曾经用过的文件
退出 | 退出TRS管理员
pointblue.gif (904 bytes) 编辑菜单
撤消 | 取消上一次编辑操作
剪切 | 删除所选内容并把它放到剪贴板上
复制 | 复制所选内容到剪贴板上
粘贴 | 把剪贴板内容插入到当前位置
删除 | 删除所选内容
全部选定 | 选定所有内容
pointblue.gif (904 bytes) 查看菜单
工具栏 | 显示/隐藏工具栏
状态栏 | 显示/隐藏状态栏
制表位 | 修改编辑控制的制表符字符数
自动折行 | 改变文本自动折行开关
查找 | 查找指定的文本
替换 | 用新的内容替代指定的文本
重复 | 重复上一次的查找/替换操作
编码 | 改变已打开文件的编码
字体 | 改变显示的字体和颜色
显示导航 | 若导航窗口关闭，打开导航窗口
对象管理 | 显示并激活对象管理器窗口
命令语言 | 打开命令语言处理工具
pointblue.gif (904 bytes) 工具菜单
登录 | 登录到TRS服务器
退出登录 | 切断与TRS服务器的链接
装入记录 | 装入新的数据到数据库/自动模式视图/词典中
复制记录 | 把记录从源数据库/自动模式视图复制到目标数据库/自动模式视图里
解锁数据库 | 解锁选择的数据库
备份数据 | 把数据库/自动模式视图备份到指定设备
恢复数据 | 从外围设备恢复数据库/自动模式视图
优化数据 | 优化指定的数据库/自动模式视图
索引维护 | 索引的建立、删除和验证
选项 | 修改服务器的配置和TRS管理员的选项
pointblue.gif (904 bytes) 窗口菜单
水平平铺 | 水平平铺所有子窗口
垂直平铺 | 垂直平铺所有子窗口
层叠 | 层叠排列所有子窗口
排列图标 | 把所有最小化的图标排列在窗口底部
pointblue.gif (904 bytes) 帮助菜单
帮助主题 | 显示TRS管理员的帮助主题
TRS主页 | 打开TRS公司的主页
关于 | 显示TRS管理员的版本信息


属性窗口

当右侧显示的是文件编辑窗口时，属性窗口显示的是当前文件的属性。

属性框里的控制显示当前文件的属性，具体如下：

控制名称 | 功能简介
文件类型 | 文件的类型，可为：导航文件、数据文件、控制文件、文本文件之一。
所在位置 | 文件存放的目录。
文件大小 | 文件占用的空间大小（以K字节计算）。
创建时间 | 文件的创建日期和时间。
修改时间 | 文件的最后一次修改日期和时间。
访问时间 | 文件的最后一次访问日期。
只读文件 | 选中表示该文件为只读文件，含有该属性的文件通常不会被误删。
隐藏文件 | 选中表示该文件为隐藏文件，含有该属性的文件在默认情况下不显示在文件列表中。
档案文件 | 选中表示该文件为档案文件，有些系统利用此属性来控制是否备份该文件。
系统文件 | 选中表示该文件为系统文件，系统文件是系统运行时有用到的，默认情况下不显示在文件列表中，请不要删除含有此标志的文件。

如对文件的属性进行了修改，点击工具栏按钮 [image] ，即可保存相关修改；点击工具栏按钮 [image] ，重置当前对象的属性，即恢复到上次已存的的属性 。


文件编辑窗口的工具栏

文件编辑窗口的工具栏如下图：

工具栏上各按钮的功能如下：
FileNew.gif (923 bytes) 新建 | 创建新对象或文档
FileOpen.gif (938 bytes) 打开 | 打开已存在的文档
FileSave.gif (938 bytes) 保存 | 保存当前文件
ViewOpenNavi.gif (948 bytes) 显示导航 | 若导航窗口关闭，打开导航窗口
FileProperties.gif (941 bytes) 显示属性 | 若属性窗口关闭，打开属性窗口
EditCut.gif (928 bytes) 剪切 | 删除所选对象并把它放到剪贴板上
EditCopy.gif (943 bytes) 复制 | 复制所选对象到剪贴板上
EditPaste.gif (959 bytes) 粘贴 | 插入剪贴板内容
EditClear.gif (918 bytes) 删除 | 删除所选对象
EditUndo.gif (915 bytes) 撤消 | 撤消上一次操作
FileSend.gif (948 bytes) 发送 | 把当前文件发送到其他用户
FilePrint.gif (947 bytes) 打印 | 打印当前文件
ViewTabSize.gif (917 bytes) 制表位 | 修改编辑控制的制表符字符数
自动折行 | 改变文本自动折行开关
ViewReplace.gif (918 bytes) 替换 | 用新的内容替代指定的文本
执行检索 | 直接按照检索历史框里的检索表达式进行检索
查找 | 查找指定的文本
HelpContent.gif (956 bytes) 帮助主题 | 显示TRS管理员的帮助主题

工具栏上的检索历史组合框用于保存检索历史和输入检索表达式，在当前窗口为文件编辑窗口时还可用于查找文本。在检索历史组合框里输入欲查找的文本，再按回车键即可开始查找所输入的文本。
单击工具栏最右方的 Company.gif (948 bytes) 图标可打开TRS公司主页。


文件编辑窗口的状态栏

文件编辑窗口的状态栏如下图：

状态栏最左边部分用于显示菜单命令、工具栏按钮、操作结果等提示信息。中间部分显示当前插入点所在行和列。后边的两个状态框分别显示键盘的数字键和大小写状态。最右边的 Manager.gif (943 bytes) 和 Command.gif (971 bytes) 按钮则分别用于显示对象管理窗口和打开命令语言处理工具。


文件编辑窗口的快捷键和编辑键

文件编辑窗口可用的快捷键如下：

Ctrl+N
Ctrl+O
Ctrl+S
Ctrl+M
Ctrl+P
Alt+Enter

Ctrl+Z
Ctrl+X
Ctrl+C
Ctrl+V
Del
Ctrl+A

Ctrl+F
Ctrl+H
F4

F1
F2
F3 		“文件|新建”命令，创建新对象或文件
“文件|打开”命令，打开已存在的文件
“文件|保存”命令，保存当前文件
“文件|发送”命令，把当前文件发送到其他用户
“文件|打印”命令，打印当前文件
“文件|文件属性”命令，显示当前文件的属性

“编辑|撤消”命令，撤消上一次操作
“编辑|剪切”命令，删除所选内容并把它放到剪贴板上
“编辑|复制”命令，复制所选内容到剪贴板上
“编辑|粘贴”命令，插入剪贴板内容
“编辑|删除”命令，删除所选内容
“编辑|全部选定”命令，选定所有内容

“查看|查找”命令，查找指定的文本
“查看|替换”命令，用新的内容替代指定的文本
“查看|重复”命令，重复上一次的查找/替换操作

显示当前所在窗口、菜单、控制的帮助信息
“查看|对象管理”命令，显示并激活对象管理器窗口
“查看|命令语言”命令，打开命令语言处理工具

文件编辑窗口可以用以下编辑键编辑文本：

←
Ctrl+←
→
Ctrl+→
↑
↓
Home
End
PageUp
PageDown
Shift+移动键

Enter
Delete
Ctrl+Delete
Back
Ctrl+Back
Ctrl+Home
Ctrl+End
Ctrl+PageUp
Ctrl+PageDown 		插入点左移一个字符
插入点左移一个单词
插入点右移一个字符
插入点右移一个单词
插入上移一行
插入点下移一行
插入点移到行首
插入点移到行尾
屏幕上滚一屏
屏幕下滚一屏
选择文本

换行
删除插入点后的字符或所选内容
删除插入点后的单词
删除插入点前的字符
删除插入点前的单词
滚动到文本的头一个字符
滚动到文本的最后一个字符
滚动到屏幕最顶端
滚动到屏幕最底端


文本编辑窗口的快捷菜单

在文本编辑窗口里单击鼠标右键即可调出以下快捷菜单：

撤消
剪切
复制
粘贴
删除
全部选定 		撤消上一次操作
删除所选内容并把它放到剪贴板上
复制所选内容到剪贴板上
插入剪贴板内容
删除所选内容
选定所有内容


文件|保存 命令

保存当前文件。
如当前文件是新建文件，则会自动打开“另存为”对话框提示用户输入文件名。


文件|另存为 命令

当前文件以一个新文件名保存。
选择“文件|另存为”命令后，TRS管理员弹出如下对话框：

在保存在组合框里选择保存文件的路径，再在文件类型组合框里选择要保存的文件类型（可为TRS导航文件、TRS数据文件、TRS控制文件、文本文件或所有文件之一），然后在文件列表框里选择文件或直接在文件名编辑框里输入文件名，最后按[保存]按钮即可在把当前文件以新名保存。


文件|发送 命令

把当前文件发送到其他用户。
选择“文件|发送”命令，或按工具栏上的 [image] 按钮，TRS管理员将调用相应的邮件处理软件（如Microsoft Outlook Express等），用户可以利用该软件把当前文件发送到其他用户手里。


文件|打印 命令

打印当前文件。
选择“文件|打印”命令，或按工具栏上的 FilePrint.gif (937 bytes) 按钮，TRS管理员弹出如下对话框：

在对话框中选择目标打印机，输入打印份数后，按[确定]键后，TRS管理员将开始打印当前文件，按[取消]则放弃打印操作。由于打印文件是一个耗时过程，因此打印过程中会显示“打印进度”对话框，显示当前已打印的页数和打印完成的百分比，按[终止]按钮将中断打印过程。


文件|页面设置 命令

设置打印纸张及打印的页面参数。
选择“文件|打印”命令，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
纸张 | 指定打印纸张的大小和来源。
大小 | 指定要使用的纸张或信封大小。
来源 | 指定纸张在打印机上的位置。不同打印机有不同的纸张来源，如上层纸盒、信封送纸器和手动送纸器等。

方向 | 显示整个文档在整个页面上的位置。
纵向 | 纵向打印文件。
横向 | 横向打印文件。

页边距 | 设置页面的打印区域。此处设置的边距不在打印范围内。
左 | 设置页面的左边距，缺省为10mm。
右 | 设置页面的右边距，缺省为10mm。
上 | 设置页面的上边距，缺省为10mm。
下 | 设置页面的下边距，缺省为10mm。

每改变一个选项，对话框上部的预览画面都会相应地作出调整。按[确定]，所作设置将作为打印时的页面设置；按[取消]将放弃所作的设置并关闭对话框；按[打印机]将选择打印的目标打印机。


编辑|撤消 命令

取消上一次编辑操作。


编辑|剪切 命令

删除当前选择内容并复制到剪贴板。
使用此功能可以快速地移动文字。先选择需要移动的文字，再选择“编辑|剪切”命令把所选文字剪切到剪贴板，然后定位到目标位置，最后选择“编辑|粘贴”命令插入剪贴板里的文字。


编辑|复制 命令

把当前选择内容复制到剪贴板。
使用此功能可以快速地复制文字。先选择需要复制的文字，再选择“编辑|复制”命令把所选文字复制到剪贴板，然后定位到目标位置，最后选择“编辑|粘贴”命令插入剪贴板里的文字。


编辑|粘贴 命令

把剪贴板内容插入到当前位置。
使用此功能可以快速地移动/复制文字。先选择需要移动/复制的文字，再选择“编辑|剪切”或“编辑|复制”命令把所选文字剪切/复制到剪贴板，然后定位到目标位置，最后选择“编辑|粘贴”命令插入剪贴板里的文字。


编辑|删除 命令

清除当前选择内容。


编辑|全部选定 命令

选定文件的全部内容。


查看|制表位 命令

修改编辑控制的制表符字符数，在1-256之间，缺省值为8。所设制表位字符数将对以后打开的所有文件编辑窗口有效。


查看|自动折行 命令

设置一行中的文本长度超过显示窗口宽度时是否自动折行，为一开关选项，缺省为不自动折行。所设自动折行标志将对以后打开的所有文件编辑窗口有效。


查看|查找 命令

在当前显示文本中查找指定的字符串。
选择“查看|查找”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查找目标 | 要查找的文字。
全字匹配 | 选中表示只查找整个单词，而不查找包含此单词的长字符串。
区分大小写 | 选中表示只查找与输入文字大小写一致的字符串。

输入要查找的文字，设置好查找选项，按[查找下一个]，TRS管理员将从文件编辑窗口的当前位置开始查找键入文字下一次出现的位置。由于查找对话框是一个无模式对话框，所以可以执行多次查找而不关闭对话框，并可切换到文件编辑窗口进行文本编辑。如要关闭对话框，请按[取消]。


查看|替换 命令

在当前显示文本中查找指定的字符串并用另一指定字符串替换。
选择“查看|替换”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查找目标 | 要查找的文字。
替换成为 | 用于替代查找文字的新字符串。
全字匹配 | 选中表示只查找整个单词，而不查找包含此单词的长字符串。
区分大小写 | 选中表示只查找与输入文字大小写一致的字符串。

输入要查找的文字或用于替换查找文字的字符串，设置好查找选项，按[查找下一个]，TRS管理员将从文件编辑窗口的当前位置开始查找键入文字下一次出现的位置；按[替换]，将搜索查找文字下一次出现的位置，并把它替换为新的字符串；按[全部替换]，将把文件编辑窗口中所有的查找文字全部替换成新的字符串。由于替换对话框是一个无模式对话框，所以可以执行多次查找/替换而不关闭对话框，并可切换到文件编辑窗口进行文本编辑。如要关闭对话框，请按[取消]。


查看|重复 命令

重复上一次查找/替换操作。


查看|编码 命令

改变已打开文件的编码。有GB18030、BIG5、UTF8、Unicode和Unicode(big endian)几种编码选择。


启动TRS命令语言

命令语言是独立于TRS管理员以外的一个仿命令行工具，用于输入和执行TRS命令语句。它的操作方法和MS-DOS的命令行工具基本一致，但增加了一些辅助的界面功能以方便用户的使用。有关命令语言的详细语法请参阅语法参考部分。

在开始菜单中选择“TRS全文数据库”程序组中的“TRS命令语言”菜单项，或以资源管理器、命令行或其它方式运行TRSL.exe程序，即可启动TRS命令语言。 单击TRS管理员状态栏右下角的 [image] 按钮或者在TRS管理员中选择“查看|命令语言”命令也可打开命令语言工具。如果TRS命令语言未自动登录，将弹出如下“登录”对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。
保存密码 | 是否保存所输入的密码标志，密码会加密保存。
分别填写各项登录信息，然后按[确定]。TRS管理员将首先从目前登录中退出，然后再尝试登录到指定服务器。如登录成功，主窗口的标题栏上会显示当前所登录的服务器的地址和端口号，以及登录的用户名；否则显示登录失败信息。使用LOGIN语句也能起到同样作用。


新增特性

TRS命令语言在上一版本的基础上，作出了以下几个方面的重大改进：

  • 采用全新的标签页式多文档管理及浮动窗口的主界面
  • 新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示
  • 语句中不同类型词法符号的彩色显示
  • 语句输入过程提供多种提示功能
  • 修改装入记录等语句的进度显示方式，可实现进度百分数等信息不断刷新显示
  • DROP、UPDATE、DELETE等语句增加了提示确认的功能，防止误操作
  • 支持打开多个脚本文件进行编辑，同时还提供了若干新功能

采用全新的标签页式多文档管理及浮动窗口的主界面

主界面采用了分割式窗体，将输入的语句命令和输出的界面分开。上方输出窗口为语句执行结果的显示窗口，包括语句执行的一般结果，检索结果的概览和细览都将在这个窗口中显示。除输出窗口外，还以标签页方式排列文件编辑窗口，可打开多个脚本文件和文本文件进行查看编辑。

下方设置了命令窗口、检索历史、操作日志和用户变量四个浮动窗口。用法与TRS管理员中的属性窗口和导航窗口一致。

新的系统选项对话框，采用属性表方式显示选项，每一项均有概要提示

系统选择对话框也采用了新的属性框。单击对话框左部图片框中的图标可分别查看各页面的具体选项的设置。点击每一个属性项时，下方的注释框显示其相应的注释。

语句中不同类型词法符号的彩色显示

新版本增加了关键字着色功能，各种不同的关键字采用不同的颜色显示，便于区分。每种关键字显示的颜色可以在选项的语法颜色中进行更改。 命令窗口和脚本编辑窗口都有此功能。

语句输入过程提供多种提示功能

新版本还增加了命令语句的提示功能，使语句的输入更加容易。这些提示功能包括语法提示对话框、语法选项列表对话框和语法选项的语法提示框三种。输入语句的过程中，按左右键(→ ←)后 ，将会弹出语法提示对话框显示该语句的完整语法，当前输入的某个参数将会以粗体显示；当输入到某个参数，并点击空格键以后，将会弹出语法选项列表对话框，提示此参数的可能取值；当语法选项列表中的值被选中，点击上下键(↑↓)选择列表中的参数时，在列表框的旁边会出现一个语法提示框，显示此参数的具体语法。

修改装入记录等语句的进度显示方式，可实现进度百分数等信息不断刷新显示

如下图所示，在进行复制优化等耗时操作时，在输出窗口中会显示进度百分数，使操作更加直观。

DROP、UPDATE、DELETE等语句增加了提示确认的功能，防止误操作

如下图所示，对于DROP、UPDATE、DELETE等不可逆的语句，在操作时会提示确认，以防止误操作。

支持打开多个脚本文件进行编辑，同时还提供了若干新功能

新的TRS命令语言以标签页方式排列文件编辑窗口，可打开多个脚本文件和文本文件进行查看编辑。其中脚本文件也具有前面已经提到过的关键字着色和命令语句的提示功能。详细叙述见脚本编辑窗口。

脚本运行过程支持Ctrl+Break中断。在运行比较长的脚本时，增加了中断功能，只要按下Ctrl+Break键就能中断当前脚本的执行，这样更有利于用户的操作。同时，SHOW语句输出结果列表过程中增加暂停和中断输出功能。

此外还增加了定时执行脚本功能。可以预先设置好需要运行的脚本和时间，当系统时间和某一项设置的运行时间一致时，系统会自动运行设置的脚本文件。


命令语言处理工具

命令语言

命令语言是独立于TRS管理员以外的一个仿命令行工具，用于输入和执行TRS命令语句。它的操作方法和MS-DOS的命令行工具基本一致，但增加了一些辅助的界面功能以方便用户的使用。有关命令语言的详细语法请参阅语法参考部分。

新版本的命令语言工具在布局上做了比较大的调整(如下图所示)，主界面采用了分割式窗体，将输入的语句命令和输出的界面分开。上方输出窗口为语句执行结果的显示窗口，包括语句执行 的一般结果，检索结果的概览和细览都将在这个窗口中显示。下方命令窗口，用户输入的所有TRS命令语句都在这个窗口中显示。

界面上方除输出窗口外，还以标签页方式排列文件编辑窗口，可打开多个脚本文件和文本文件进行查看编辑。

下方除了命令窗口以外，还设置了检索历史、操作日志和用户变量三个子窗口。分别显示最近执行过的检索的历史表，最近执行过的命令行及执行结果，和当前定义的用户变量。这些内容以窗口列表的形式列出，将更加直观，用户在进行检索的同时，可以随时进行查看。

在开始菜单中选择“TRS全文数据库”程序组中的“TRS命令语言”菜单项，或以资源管理器、命令行或其它方式运行TRSL.exe程序，即可启动TRS命令语言。TRS命令语言的界面如下：

命令语言处理工具对应的工具栏上包含了一些常用的菜单命令，状态栏的中间部分显示当前的光标所在位置。另外，命令语言处理工具提供了一些快捷键和快捷菜单用于快速执行菜单命令。

命令语言处理工具有以下六个菜单：

pointblue.gif (904 bytes) 文件菜单
新建 | 新建TRS命令语言的脚本文件或者文本文件
打开 | 打开已存在的文件
另存为 | 把窗口里的文本保存到文件里
发送 | 把窗口里的文本内容发送给其他用户
打印 | 直接打印当前窗口里的文本内容
页面设置 | 改变打印选项
MRU文件列表 | 重新打开最近曾经用过的文件
退出 | 退出命令语言处理工具
pointblue.gif (904 bytes) 编辑菜单
撤消 | 撤消最后一步操作
剪切 | 剪切被选文本并将其置于剪贴板上
复制 | 复制被选文本并将其置于剪贴板上
粘贴 | 在当前位置插入剪贴板内容
删除 | 删除被选文本
全部选定 | 选择所有文本内容
pointblue.gif (904 bytes) 查看菜单
工具栏 | 显示/隐藏工具栏
状态栏 | 显示/隐藏状态栏
执行结果视图 | 输出窗口显示执行结果视图
概览视图 | 输出窗口显示概览视图
细览视图 | 输出窗口显示细览视图
其他窗口 | 若下方面板窗口关闭，打开此窗口
清屏 | 清除所有显示内容
字体 | 改变显示字体和颜色
背景 | 设置窗口的背景颜色
自动折行 | 自动折行开关
pointblue.gif (904 bytes) 检索菜单 | 在查看检索结果的概览和细览时出现，其他时候隐藏
按选定内容检索 | 显示所有包含当前选择内容的记录
内容排除检索 | 显示所有不包含当前选择内容的记录
升序排列 | 按当前列内容的升序排列记录
降序排列 | 按当前列内容的降序排列记录
取消检索/排序 | 取消所有的筛选和排序动作
pointblue.gif (904 bytes) 记录菜单 | 在查看检索结果的概览和细览时出现，其他时候隐藏
直接定位 | 直接跳到指定记录
首记录 | 定位到第一条记录
上一记录 | 定位到上一条记录
下一记录 | 定位到下一条记录
尾记录 | 定位到最后一条记录
上一命中点 | 定位到上一命中点处
下一命中点 | 定位到下一命中点处
上一附件 | 打开当前记录的上一个附件
下一附件 | 打开当前记录的下一个附件
pointblue.gif (904 bytes) 工具菜单
登录 | 连接到TRS服务器
断开 | 切断与TRS服务器的链接
表达式生成器 | 构造检索表达式
定时运行脚本 | 设置定时运行脚本的时间
选项 | 设置命令语言的选项
pointblue.gif (904 bytes) 窗口菜单
水平平铺 | 水平平铺所有子窗口
垂直平铺 | 垂直平铺所有子窗口
层叠 | 层叠排列所有子窗口
排列图标 | 把所有最小化的图标排列在窗口底部
pointblue.gif (904 bytes) 帮助菜单
帮助主题 | 显示TRS命令语言的帮助主题
TRS主页 | 打开TRS公司的主页
关于 | 显示TRS命令语言的版本信息


输出窗口

输出窗口用来显示TRSL语句执行的结果，检索结果的概览和细览。因显示的结果分为三类，输出窗口的显示状态也分为三种不同的视图。

  • 执行结果视图: 用于显示TRSL语句执行的结果，是输出窗口最常用的状态，也是登录以后输出窗口显示的状态。当下方的命令窗口运行各种指令后，会有一些运行结果需要显示，这些结果将会显示于执行结果视图中，与下面的用户的指令分开，这样更加直观。

    其中，本次所执行的语句以符号“$”开头并以蓝色显示，后面即为语句的执行结果。黑色代表一般的信息，绿色代表执行过程的信息，红色代表错误信息。当输出窗口显示的是检索结果的细览或者概览时，点击工具栏上的 [image] 按钮即可返回执行结果视图。

  • 概览视图：用于显示检索结果的概览。进行检索后，输入“BROWSE”指令，输出窗口将转换为一个列表框，进行检索结果的概览显示，即概览视图。概览视图里面显示检索结果的概览字段值，与Admin中的概览窗口类似。

    若执行结果视图显示的是检索结果的细览或者语句执行结果时，点击工具栏上的 [image] 按钮即可返回概览视图。

  • 细览视图：用于显示检索结果的细览。在显示的概览结果中，双击其中一条记录，窗口即转换为如下图所示的第三种视图，即细览视图。可直接显示记录所带的图片，其他类型的附件在默认状态下以链接形式显示， 单击带下划线的文字以打开或保存该文件或连接。此窗口与Admin的细览窗口功能类似。

    若输出窗口显示的是检索结果的概览或者语句执行结果时，点击工具栏上的 [image] 按钮即可返回细览视图。


命令窗口

命令窗口是一个可输入窗口，用户在里面输入需要执行的TRS命令语句。它和检索历史窗口、操作日志窗口、用户变量窗口以浮动面板的形式出现 ，刚登录时都停靠在界面的下方。若命令窗口被关闭或者隐藏时，点击主工具栏上的 [image] 按钮或者点击菜单“查看|其他窗口”下的“命令”菜单项即可打开命令窗口。

如上图所示，每行的"TRSL> "后输入的便是需要执行的TRS命令语句。新版本增加了关键字着色功能，各种不同的关键字采用不同的颜色显示，便于区分。每种关键字显示的颜色可以在选项 的语法颜色中进行更改。点击工具栏上的 [image] 按钮将复制操作日志里的上一条命令到命令窗口中，点击 [image] 按钮将复制操作日志里的下一条命令到命令窗口中，点击 [image] 按钮清除命令窗口中的所有语句，点击 [image] 按钮执行当前输入的语句，点击此按钮旁边的 [image] 可以选择回车键作为换行使用还是作为执行语句的快捷键，此外， Ctrl+Enter执行语句，Shift+Enter换行。

另外，新版本还增加了命令语句的提示功能，使语句的输入更加容易。

  • 语法提示对话框: 对整个语句的语法进行提示，当输入一条指令，按左右键(→ ←)后，将会弹出一个提示框显示该语句的完整语法，当前输入的某个参数将会以粗体显示。

    •

  • 语法选项列表对话框: 当输入到某个参数，并点击空格键以后，将会弹出一个提示框，提示此参数的可能取值。用户可以对照提示框直接输入可能的取值，当输入的值与列表中的值有匹配时，列表中的值会被选中，此时点击上下键(↑↓)可以上下选择列表中的参数，点击空格或者回车键，被选中的参数将自动写入语句后面，列表框消失。同时也可以直接在提示框中双击所需要的值，点击的值将会自动写入语句后面，列表框消失。

  • 语法选项的语法提示框: 当语法选项列表中的值被选中，点击上下键(↑↓)选择列表中的参数时，在列表框的旁边会出现一个语法提示框，显示此参数的具体语法 ，便于选择时查看。


检索历史窗口

检索历史窗口用来显示最近执行过的检索的历史列表，为只读窗口。列表中列出里最近每次检索的表达式、数据库/视图名、命中记录数、命中点数等信息。若检索历史窗口 被关闭或者隐藏时，点击主工具栏上的 [image] 按钮或者点击菜单“查看|其他窗口”下的“检索历史”命令即可打开检索历史窗口。

点击 [image] 按钮可清除所有的检索历史；双击日志中的某一列表项或者点击 [image] 按钮可把当前选中的检索表达式复制到命令窗口中的插入点位置。


操作日志窗口

操作日志窗口用来查看最近执行过的命令行及执行结果，列表中列出里最近执行过的每条命令及执行的时间和结果。若操作日志窗口 被关闭或者隐藏时，点击主工具栏上的 [image] 按钮或者点击菜单“查看|其他窗口”下的“操作日志”命令即可打开操作日志窗口。

如图所示，点击 [image] 按钮可清除 所有的操作日志；双击日志中的某一列表项或者点击 [image] 按钮可把当前选中的命令复制到命令窗口的插入点位置，以便于执行。


用户变量窗口

用户变量窗口用来显示TRSL中定义的各个用户变量的名称及对应的变量值，并可对变量进行增加、删除或者修改。若用户变量窗口 被关闭或者隐藏时，点击主工具栏上的 [image] 按钮或者点击菜单“查看|其他窗口”下的“用户变量”命令即可打开用户变量窗口。

如上图所示，可以直接点击列表，在出现的编辑框里面进行变量名和变量值的编辑修改，编辑完成以后回车即可保存。点击 [image] 按钮 ，将增加一行列表项，在对应的编辑框里面输入新增的变量名和变量值即可，点击 [image] 按钮对已存在的变量进行修改，点击 [image] 按钮删除当前变量。


命令语言的工具栏

命令语言处理工具的工具栏如下图：

工具栏上各按钮的功能如下：
FileNew.gif (956 bytes) 新建 | 新建TRS命令语言的脚本文件或者文本文件
FileNew.gif (956 bytes) 打开 | 打开已存在的文件
FileSaveAs.gif (956 bytes) 另存为 | 把窗口里的文本保存到文件里
FileSend.gif (948 bytes) 发送 | 把窗口里的文本内容发送给其他用户
FilePrint.gif (947 bytes) 打印 | 直接打印当前窗口里的文本内容
FilePrint.gif (947 bytes) 命令 | 若命令窗口关闭，打开命令窗口
FilePrint.gif (947 bytes) 检索历史 | 若检索历史窗口关闭，打开检索历史窗口
FilePrint.gif (947 bytes) 操作日志 | 若操作日志窗口关闭，打开操作日志窗口
FilePrint.gif (947 bytes) 用户变量 | 若用户变量窗口关闭，打开用户变量窗口
EditCut.gif (928 bytes) 剪切 | 剪切被选文本并将其置于剪贴板上
EditCopy.gif (943 bytes) 复制 | 复制被选文本并将其置于剪贴板上
EditPaste.gif (959 bytes) 粘贴 | 在当前位置插入剪贴板内容
EditClear.gif (918 bytes) 删除 | 删除被选文本
EditUndo.gif (915 bytes) 撤消 | 撤消上一次操作
EditUndo.gif (915 bytes) 执行结果视图 | 打开执行结果视图
EditUndo.gif (915 bytes) 概览视图 | 打开概览视图
EditUndo.gif (915 bytes) 细览视图 | 打开细览视图
执行检索 | 把当前检索表达式加入到检索语句中
构造检索表达式 | 打开表达式生成器构造检索表达式
HelpContent.gif (956 bytes) 帮助主题 | 显示TRS命令语言的帮助主题

工具栏上的检索历史组合框用于保存检索历史和输入检索表达式。在检索历史组合框里输入或选择检索条件，再按回车键即可把检索条件插入到命令行的当前位置。
单击工具栏最右方的 Company.gif (948 bytes) 图标可打开TRS公司主页。


命令语言的状态栏

命令语言处理工具的状态栏如下图：

状态栏最左边部分用于显示菜单命令、工具栏按钮、操作结果等提示信息。中间部分显示当前插入点所在行和列。最右边的两个状态框分别显示键盘的数字键和大小写状态。


命令语言的快捷键和编辑键

命令语言处理工具可用的快捷键如下：

Ctrl+S
Ctrl+P

Ctrl+Z
Ctrl+X
Ctrl+C
Ctrl+V
Del
Ctrl+A

F1

Ctrl+Tab
Esc
Shift+Tab
Ctrl+Q
Ctrl+W
Ctrl+E 		“文件|另存为”命令，把窗口里的文本保存到文件里
“文件|打印”命令，直接打印当前窗口里的文本内容

“编辑|撤消”命令，撤消上一次操作
“编辑|剪切”命令，删除所选内容并把它放到剪贴板上
“编辑|复制”命令，复制所选内容到剪贴板上
“编辑|粘贴”命令，插入剪贴板内容
“编辑|删除”命令，删除所选内容
“编辑|全部选定”命令，选定所有内容

显示当前所在窗口、菜单、控制的帮助信息

程序主窗口下方命令、检索历史、操作日志和用户变量这四个浮动窗口相互切换的快捷键；程序主窗口上方输出窗口和多个脚本窗口或者文本窗口相互切换的快捷键
按照细览视图、概览视图、执行结果视图、命令窗口的顺序，按Esc键焦点依次到达
程序主窗口上方输出窗口、脚本窗口、文本窗口与下方四个浮动窗口切换的快捷键
输出窗口切换到执行结果视图
输出窗口切换到概览视图
输出窗口切换到细览视图

可以用以下编辑键编辑当前命令行（不能编辑当前命令行以外的文本）：

· 移动和选择键：
←
Ctrl+←
→
Ctrl+→
Home
End
Shift+移动键 		插入点左移一个字符
插入点左移一个单词
插入点右移一个字符
插入点右移一个单词
插入点移到行首
插入点移到行尾
选择文本
· 行编辑键：
Esc
Enter
Delete
Back
Ctrl+Back
Ctrl+Delete 		清除整行
换行，把当前行加到操作日志，并执行该命令
删除插入点后的字符或所选内容
删除插入点前的字符
删除插入点前的单词
删除插入点后的单词
· 操作日志键：
↑
↓
PageUp
PageDown 		复制操作日志里的上一条命令
复制操作日志里的下一条命令
在命令窗口中表示复制操作日志里向上的第十条命令，在输出窗口中表示屏幕上滚一屏
在命令窗口中表示复制操作日志里向下的第十条命令，在输出窗口中表示屏幕下滚一屏
· 屏幕滚动键：
Ctrl+Up
Ctrl+Down
Ctrl+PageUp
Ctrl+PageDown
Ctrl+Home
Ctrl+End 		在命令窗口中屏幕上滚一行，但插入点位置不变
在命令窗口中屏幕下滚一行，但插入点位置不变
在命令窗口中屏幕上滚一屏，但插入点位置不变
在命令窗口中屏幕下滚一屏，但插入点位置不变
在命令窗口和输出窗口中屏幕滚动到最顶端，但插入点位置不变
在命令窗口和输出窗口中屏幕滚动到最底端，但插入点位置不变
执行语句过程中，当输出的结果多于一屏时，输出窗口里的内容会自动向上滚动。当窗口里的内容超过一定范围的时候，最早输出的部分会自动从窗口里清除。如要清除窗口里的所有内容，请选择“查看|清屏”菜单或执行CLEAR语句，此时窗口将回到初始状态，并重新显示提示符。滚动过程中可以按PAUSE键暂停执行过程，暂停后按任意键即可继续执行。如果要终止执行过程，可按CTRL+BREAK键 。


命令语言的快捷菜单

在命令语言的主窗口里单击鼠标右键即可调出以下快捷菜单：

撤消
剪切
复制
粘贴
删除
全部选定 		撤消上一次操作
删除所选内容并把它放到剪贴板上
复制所选内容到剪贴板上
插入剪贴板内容
删除所选内容
选定所有内容


文件|新建 命令

新建TRS命令语言的脚本文件或者文本文件。

TRS命令语言脚本文件提供了以批方式操纵TRS数据库的灵活手段，文件中可以存放数量不限的TRSL语句（包括可执行语句如SELECT、INSERT等及非执行语句如REM、SPOOL等），每个TRSL语句必须以单字节分号(;)结束，最后一个TRSL语句可以没有分号结束符。选择“文件|新建”命令下的“脚本文件”，或者点击主工具栏上的 [image] 按钮，将会打开一个空白的文件编辑窗口。用户可 以在命令窗口中，并用RUN语句运行该文件。

需要新建文本文件时，选择“文件|新建”命令下的“文本文件”，将会打开一个空白的文件编辑窗口。


文件|打开 命令

打开已存在的文件。选择“文件|打开”命令后，TRS命令语言弹出如下对话框：

在搜索组合框里选择文件所在的路径，再在文件类型组合框里选择要打开的文件类型（可为TRS脚本文件、文本文件或所有文件之一），然后在文件列表框里选择文件或直接在文件名编辑框里输入文件名，最后按[打开]按钮即可在TRSL里打开指定的文件。注意：每次只能打开一个文件，并且该文件必须是文本文件，对非文本文件将无法正确显示其内容。

提示：要打开最近使用过的文件，可在“文件”菜单底部选择最近曾经使用过的文件名。


文件|另存为 命令

把输出窗口里的文本保存到文件里或者把当前检索结果的全部或部分保存为文本文件。
因输出窗口显示的结果分为三类，所以选择“文件|另存为”命令后，TRS命令语言弹出的对话框也分为两种。

  • 保存输出窗口的文本：当输出窗口显示的是语句执行结果时，TRSL弹出的对话框如下图所示：

    在保存在组合框里选择保存文件的路径，然后在文件列表框里选择文件或直接在文件名编辑框里输入文件名，最后按[保存]按钮即可把输出窗口里的文本保存到文件里，供以后查看或编辑。

  • 保存当前检索结果：当输出窗口显示的是检索结果的概览或者细览时，TRSL弹出的对话框如下图所示：

    • 对话框中各控制的说明如下：

    控制名称 | 功能简介
目标文件名 | 保存的目标文件名，可按右边的 [image] 按钮来选择目标文件名。
字段列表 | 需要保存的字段列表。可按右边的 Select.gif (956 bytes) 按钮来选择字段列表。
记录范围 | 需要保存的记录的范围，缺省为所有记录。
当前记录 | 只保存当前记录。
所有记录 | 保存检索结果里的所有记录。
指定范围 | 保存指定范围的记录，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。
每文件存放条数 | 设置每个文件存放记录的条数，清空或为零表示不限制。
保存格式 | 结果保存的格式，缺省为TRS装库数据格式。
记录文件 | 以记录数据格式保存检索结果，一般只需浏览检索结果时选择此格式。
装库文件 | 以TRS装库数据格式保存检索结果，所保存的文件可以用来重新进行装库。
ISO2709文件 | 以ISO2709国际标准格式保存检索结果。
XML文件 | 以XML格式保存检索结果。
传输装库文件 | 以传输格式保存检索结果。传输格式是数据加载时用于传输一批记录的内部格式文件。这种格式的一个最大优点是能够将文本与非文本数据打包在一个文件里，避免大量外挂文件可能引起的性能问题。
保存记录ID | 保存记录时保存记录的ID。
添加记录前缀 | 记录前加引导前缀$$TRSTAG$$，可与以上格式组合，但只对装库数据格式和镜像装库格式有效。
文件选项 | 保存的目标文件和保存附件的相关选项。
保存附件方式 | 保存记录里包含的源文件的模式。
附件存放目录 | 指定记录所含附件存放的目录。
每组容纳记录 | 指记录附件存放的目录中，每组容纳多少条记录的附件。若为0或者清空表示不限制，即所有附件全部直接存入指定的文件中；若指定了数值比如为10，则生成若干个文件分别存放附件，每个文件中存储10条记录的附件。
最大文件长度 | 设置保存的目标文件的最大长度，清空或为零时取缺省值2G。若当前所要保存的记录大小超过此数值，将自动分为N个大小为此数值的目标文件进行保存，如Demo2_1.trs、Demo2_2.trs...

    输入目标文件名，设置保存字段、记录范围、保存格式等选项以后，按[确定]，TRSL将开始保存检索结果到目标文件里。按[取消]则放弃保存操作并关闭对话框。由于保存检索结果是一个耗时过程，因此保存过程中有“保存进度“对话框显示目前已保存的记录数和保存完成的百分比。如要终止保存过程，可按[终止]按钮。


文件|发送 命令

把命令语言窗口里的内容发送到其他用户。
选择“文件|发送”命令，或按工具栏上的 FileSend.gif (933 bytes) 按钮，TRS命令语言将调用相应的邮件处理软件（如Microsoft Outlook Express等），用户可以利用该软件把命令语言窗口里的内容发送到其他用户手里。


文件|打印 命令

打印命令语言窗口里的文本。
选择“文件|打印”命令，TRS命令语言将弹出如下对话框：

在对话框中选择目标打印机，输入打印份数后，按[确定]键后，TRS命令语言将开始打印命令语言窗口里的内容，按[取消]则放弃打印操作。


文件|页面设置 命令

设置打印纸张及打印的页面参数。
选择“文件|页面设置”命令，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
纸张 | 指定打印纸张的大小和来源。
大小 | 指定要使用的纸张或信封大小。
来源 | 指定纸张在打印机上的位置。不同打印机有不同的纸张来源，如上层纸盒、信封送纸器和手动送纸器等。

方向 | 显示整个文档在整个页面上的位置。
纵向 | 纵向打印文件。
横向 | 横向打印文件。

页边距 | 设置页面的打印区域。此处设置的边距不在打印范围内。
左 | 设置页面的左边距，缺省为10mm。
右 | 设置页面的右边距，缺省为10mm。
上 | 设置页面的上边距，缺省为10mm。
下 | 设置页面的下边距，缺省为10mm。

每改变一个选项，对话框上部的预览画面都会相应地作出调整。按[确定]，所作设置将作为打印时的页面设置；按[取消]将放弃所作的设置并关闭对话框；按[打印机]将选择打印的目标打印机。


文件|MRU列表

重新打开最近曾经用过的文件。
文件菜单的下面列有TRS命令语言最近曾经打开过的四个文件，选择列表中的文件名，可以打开该文件。


文件|退出 命令

退出TRS命令语言处理工具。
选择了“文件|退出”命令后，TRS命令语言处理工具将切断与当前登录的TRS服务器的链接，并关闭主窗口。在命令行下执行EXIT或QUIT语句也能起到同样的作用。


编辑|全部选定 命令

选定所有文本内容。


查看|执行结果视图 命令

输出窗口显示执行结果视图。

当输出窗口显示的是检索结果的细览或者概览时，点击“查看|执行结果视图”命令即可返回显示语句执行结果的执行结果视图。


查看|概览视图 命令

输出窗口显示概览视图。

当执行检索语句和“browse”语句以后，选择“查看|概览视图”命令，输出窗口即显示概览视图，用户可查看检索结果的概览。


查看|细览视图 命令

输出窗口显示细览视图。

当执行检索语句和“browse”语句以后，选择“查看|细览视图”命令，输出窗口即显示细览视图，用户可查看检索结果的细览。


查看|其他窗口 命令

若下方以面板形式出现的窗口被关闭或者隐藏，打开这些窗口，分别为命令窗口、检索历史窗口、操作日志窗口和用户变量窗口。

因采用新的界面形式，下方的四个面板窗口可以停靠在界面的四边，可以悬浮于界面的任何位置，也可以关闭。当这些窗口被关闭或者隐藏时，点击此命令下对应的窗口命令，可重新打开窗口，且所在位置与窗口关闭前的位置一致。


查看|清屏 命令

清除命令语言窗口中的所有内容，包括输出窗口和命令窗口的内容，并重新在命令窗口中显示命令行提示符。在命令窗口中执行CLEAR语句也能起到同样作用。


查看|字体 命令

改变窗口显示的字体和颜色。
选择“查看|字体”命令后，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
字体 | 列出和选择可用的字体，只列出等宽的字体。字体名前有 TrueType.gif (855 bytes) 标志的为TrueType字体。
字形 | 列出和选择指定字体可用的字形。
大小 | 列出和选择指定字体可用的字号。

效果 | 指定显示文字的颜色和风格。
加删除线 | 选中表示在字体的中间加删除线。
加下划线 | 选中表示在字体的下面加下划线。
颜色 | 选择字体的显示颜色。

示例 | 显示所选字体的范例。
字符集 | 选择显示字体的语言。

选择好显示字体及其颜色、效果、语言等属性以后，按[确定]，将关闭对话框并以新字体显示整个命令语言窗口的内容，所设字体将保存到注册表里，对以后启动的TRS命令语言同样有效。按[取消]则关闭对话框但不改变显示字体。


查看|背景 命令

改变窗口的背景颜色。
选择“查看|背景”命令后，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
基本颜色 | 显示可用的基本颜色，单击可选择为背景颜色。
自定义颜色 | 显示已定义的自定义颜色，单击可选择为背景颜色。如要增加自定义颜色，请按[规定自定义颜色]按钮，并在颜色阵列中选择需要的颜色，然后按[添加到自定义颜色]按钮。

选择好字体颜色以后按[确定]，将关闭对话框并以新颜色作为命令语言窗口的背景，所设颜色将保存到注册表里，并在以后启动的TRS命令语言 中同样有效。按[取消]则关闭对话框但不改变背景颜色。


查看|自动折行 命令

设置一行中的文本长度超过显示窗口宽度时是否自动折行，为一开关选项，缺省为不自动折行。所设自动折行标志将保存到注册表里，并对以后启动的TRS命令语言同样有效。


检索|按选定内容检索 命令

显示所有当前字段包含当前选择内容的记录。
此命令仅对细览视图有效，且检索结果是针对当前检索结果的二次检索。如想在当前检索结果的基础上进行检索，请先选择“检索|取消检索/排序”命令，或直接在工具栏上的检索表达式组合框里输入检索条件并按回车。

注意：如果被选字段是多值字段，而且您选定的检索内容也是多值字段的话，您需要将检索表达式对话框中显示的表达式中的“;”替换为“'*'”。例如：作者多值字段：“王一;李二”，检索表达式：“作者='王一;李二'”，修改检索表达式为：“作者='王一'*作者='李二'”。


检索|内容排除检索 命令

显示所有当前字段不包含当前选择内容的记录。
此命令仅对细览视图有效，且检索结果是针对当前检索结果的二次检索。如想在当前检索结果的基础上进行检索，请先选择“检索|取消检索/排序”命令，或直接在工具栏上的检索表达式组合框里输入检索条件并按回车。

注意：如果被选字段是多值字段，而且您选定的检索内容也是多值字段的话，您需要将检索表达式对话框中显示的表达式中的“;”替换为“'*'”。例如：作者多值字段：“王一;李二”，检索表达式：“作者<>'王一;李二'”，修改检索表达式为：“作者<>'王一'*作者<>'李二'”。


检索|升序排列 命令

按当前列内容的升序排列记录。
此命令排序只针对当前检索结果，在上一次排序的基础上重新进行排序。如想在当前检索结果的基础上进行排序，请先选择“检索|取消检索/排序”命令。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时排序取消。


检索|降序排列 命令

按当前列内容的降序排列记录。
此命令只针对当前检索结果，在上一次排序的基础上重新进行排序。如想在当前检索结果的基础上进行排序，请先选择“检索|取消检索/排序”命令。若此操作费时较长，可在过程中按Ctrl+Break中断操作，此时排序取消。


检索|取消检索/排序 命令

取消所有的筛选和排序动作，按前一句执行的检索语句的检索条件和排序方式重新进行检索。


记录|直接定位 命令

直接跳到指定记录。
选择“记录|直接定位”命令以后，TRS命令语言会弹出对话框提示用户输入需要定位的目标记录。输入完毕以后按[确定]，则直接跳到指定记录，按[取消]则放弃定位并关闭对话框。有一种简便的方法也可以实现此功能：直接在 细览视图工具栏的“记录定位”编辑框里输入目标记录的逻辑记录号，然后按回车，即可快速定位到指定记录。


记录|首记录 命令

定位到首记录。快捷键为Alt+Home。


记录|上一记录 菜单

记录|上一记录 命令

定位到上一记录。 快捷键为Alt+↑。


记录|下一记录 命令

定位到下一记录。 快捷键为Alt+↓。


记录|尾记录 命令

定位到尾记录。快捷键为Alt+End。


记录|上一命中点 菜单

记录|上一命中点 命令

定位到上一个命中点处。
对当前对象进行检索后，细览窗口中短语型(PHRASE)和全文型(DOCUMENT)字段中的命中点会以特殊的颜色显示，便于查看。点击此命令后，将定位到当前位置前的上一个命中点处，命中点以蓝色反显。


工具|登录 命令

登录到TRS服务器。
必须首先登录到TRS服务器，然后才能对服务器上的对象和数据进行操作。选择“工具|登录”命令后，TRS管理员弹出如下“登录”对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。

分别填写各项登录信息，然后按[确定]。TRS管理员将首先从目前登录中退出，然后再尝试登录到指定服务器。如登录成功，主窗口的标题栏上会显示当前所登录的服务器的地址和端口号，以及登录的用户名；否则显示登录失败信息。使用LOGIN语句也能起到同样作用。


工具|断开 命令

切断与当前TRS服务器的连接。
当不再需要在当前登录的服务器上执行TRS操作时，选择“工具|断开”命令，系统将弹出一个提问对话框请求确认“是否决定断开连接？”。选择[是(Y)]，将切断与当前TRS服务器的连接；选择[否(N)]，将继续保持当前连接。退出登录后，如要再执行TRS操作，必须重新登录到服务器。退出TRS命令语言时会自动断开与当前TRS服务器的连接。


工具|表达式生成器 命令

帮助用户生成检索表达式，对初学者尤为有用。
选择“工具|表达式生成器”命令后，TRS命令语言将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
表达式 | 生成的检索表达式。
运算符按钮 | 从 Plus.gif (887 bytes) 到 Bracket.gif (889 bytes) 为常用的运算符按钮，按下按钮会把相应运算符复制到表达式编辑框里。
字段名 | 所有数据库/视图的字段列表，双击数据库/视图名可显示出该对象的所有字段名，双击字段名可把字段名复制到表达式编辑框里。
运算符/函数 | TRS的运算符和函数列表。运算符分为算术运算符、比较运算符、逻辑运算符、重复逻辑运算符、属性运算符、限定运算符和加权运算符，函数分为统计函数、检索函数和词典函数。双击文件夹可显示该项包含的所有运算符/函数列表，再双击某一项则可把该运算符/函数复制到表达式编辑框里。
检索历史 | 检索历史列表，列出最近用到的20个检索表达式，双击可把检索历史项复制到表达式编辑框里。
索引词 | 打开“查询索引词”对话框，对数据库或者视图的索引词进行查询。

生成合适的检索表达式后，按[确定]，将关闭“表达式生成器”对话框并把生成的检索表达式复制到命令窗口的当前位置。按[取消]则关闭对话框。


工具|定时运行脚本 命令

设置定时运行脚本的时间。

选择“工具|定时运行脚本”命令后，TRS命令语言弹出如下对话框：

点击 [image] 添加一项新的定时运行时间和脚本路径，点击 [image] 修改当前选中项的运行时间和脚本路径，点击 [image] 删除当前选中项。运行列表编辑完成后点击[确定]将保存列表中的各项，并保存到注册表，当前系统时间和某一项设置的运行时间一致时，系统会自动运行设置的脚本文件。


工具|选项 命令

修改命令语言的选项。
选择“工具|选项”命令后，TRS命令语言弹出“选项”对话框。该对话框共有缺省登录、集成环境、检索选项和语法颜色四页。

单击对话框上部属性页的标签可分别查看各页面的具体选项的设置。如对选项作了修改，按[确定]按钮可保存所作的修改并关闭对话框，按[应用]按钮可保存所作的修改而不关闭对话框，按[取消]按钮则放弃所作的修改并关闭对话框。


窗口|Windows List

窗口|Windows List 命令

已打开窗口列表。
窗口菜单的最下面列有TRS命令语言当前打开窗口的列表，前面有对勾的表示当前激活窗口。


帮助|帮助主题 命令

打开TRS管理员的帮助，并定位于命令语言部分的起始页面。
由于TRS管理员的帮助系统采用HTML方式，因此，如要浏览帮助，必须确保当前的操作系统上安装了Microsoft Internet Explorer 6.0或以上版本。


帮助|关于 命令

显示TRS命令语言的版本信息。“关于”对话框如下所示：


脚本编辑窗口

脚本编辑窗口用于创建编辑文本文件或者脚本文件。它的用法与Windows的记事本类似，功能有所增强，并能编辑大于64K的文件 。以下是打开了一个".tsf"和一个".txt"文件的编辑窗口：

如图所示，脚本编辑窗口打开时以标签页的形式出现，可以同时打开多个脚本文件和文本文件。

脚本文件是包含许多TRS命令语句的文本文件，以便于在执行语句“Run”时，可以一次性执行多条语句。新版本中，在编辑脚本文件时，增加了关键字着色功能，各种不同的关键字采用不同的颜色显示，便于区分。每种关键字显示的颜色可以在选项的语法颜色中进行更改。 此外还增加了命令语句的提示功能，使语句的输入更加容易。

  • 语法提示对话框: 对整个语句的语法进行提示，当输入一条指令，按左右键(→ ←)后，将会弹出一个提示框显示该语句的完整语法，当前输入的某个参数将会以粗体显示。

    •

  • 语法选项列表对话框: 当输入到某个参数，并点击空格键以后，将会弹出一个提示框，提示此参数的可能取值。用户可以对照提示框直接输入可能的取值， 当输入的值与列表中的值有匹配时，列表中的值会被选中，此时点击上下键(↑↓)可以上下选择列表中的参数，点击空格或者回车键，被选中的参数将自动写入语句后面，列表框消失。同时也可以直接在提示框中双击所需要的值，点击的值将会自动写入语句后面 ，列表框消失。

  • 语法选项的语法提示框: 当语法选项列表中的值被选中，点击上下键(↑↓)选择列表中的参数时，在列表框的旁边会出现一个语法提示框，显示此参数的具体语法 ，便于选择时查看。

文件编辑窗口对应的工具栏上包含了一些常用的菜单命令，状态栏的中间部分显示当前插入点所在的行和列。另外，文件编辑窗口提供了一些快捷键和快捷菜单用于快速执行菜单命令。

文本编辑窗口共有以下六个菜单：

pointblue.gif (904 bytes) 文件菜单
新建 | 创建新对象或文件
打开 | 打开已存在的文件
保存 | 保存当前文件
另存为 | 把当前文件以新名字保存
发送 | 把当前文件发送到其他用户
打印 | 打印当前文件
页面设置 | 改变打印的页面设置
MRU文件列表 | 重新打开最近曾经用过的文件
退出 | 退出TRS命令语言
pointblue.gif (904 bytes) 编辑菜单
撤消 | 取消上一次编辑操作
剪切 | 删除所选内容并把它放到剪贴板上
复制 | 复制所选内容到剪贴板上
粘贴 | 把剪贴板内容插入到当前位置
删除 | 删除所选内容
全部选定 | 选定所有内容
pointblue.gif (904 bytes) 查看菜单
工具栏 | 显示/隐藏工具栏
状态栏 | 显示/隐藏状态栏
执行选定结果 | 执行脚本编辑窗口被选中的语句
制表位 | 修改编辑控制的制表符字符数
自动折行 | 改变文本自动折行开关
查找 | 查找指定的文本
替换 | 用新的内容替代指定的文本
重复 | 重复上一次的查找/替换操作
编码 | 改变已打开文件的编码
字体 | 改变显示的字体和颜色
pointblue.gif (904 bytes) 工具菜单
登录 | 连接到TRS服务器
断开 | 切断与TRS服务器的链接
表达式生成器 | 构造检索表达式
定时运行脚本 | 设置定时运行脚本的时间
选项 | 设置命令语言的选项
pointblue.gif (904 bytes) 窗口菜单
水平平铺 | 水平平铺所有子窗口
垂直平铺 | 垂直平铺所有子窗口
层叠 | 层叠排列所有子窗口
排列图标 | 把所有最小化的图标排列在窗口底部
pointblue.gif (904 bytes) 帮助菜单
帮助主题 | 显示TRS命令语言的帮助主题
TRS主页 | 打开TRS公司的主页
关于 | 显示TRS命令语言的版本信息


文件编辑窗口的工具栏

文件编辑窗口的工具栏如下图：

工具栏上各按钮的功能如下：
FileNew.gif (923 bytes) 新建 | 创建新对象或文档
FileOpen.gif (938 bytes) 打开 | 打开已存在的文档
FileSave.gif (938 bytes) 保存 | 保存当前文件
EditCut.gif (928 bytes) 剪切 | 删除所选对象并把它放到剪贴板上
EditCopy.gif (943 bytes) 复制 | 复制所选对象到剪贴板上
EditPaste.gif (959 bytes) 粘贴 | 插入剪贴板内容
EditClear.gif (918 bytes) 删除 | 删除所选对象
EditUndo.gif (915 bytes) 撤消 | 撤消上一次操作
FileSend.gif (948 bytes) 发送 | 把当前文件发送到其他用户
FilePrint.gif (947 bytes) 打印 | 打印当前文件
FilePrint.gif (947 bytes) 执行选定脚本 | 执行脚本编辑窗口被选中的语句
ViewTabSize.gif (917 bytes) 制表位 | 修改编辑控制的制表符字符数
自动折行 | 改变文本自动折行开关
ViewReplace.gif (918 bytes) 替换 | 用新的内容替代指定的文本
执行检索 | 直接按照检索历史框里的检索表达式进行检索
查找 | 查找指定的文本
HelpContent.gif (956 bytes) 帮助主题 | 显示TRS命令语言的帮助主题

工具栏上的检索历史组合框用于保存检索历史和输入检索表达式，在当前窗口为文件编辑窗口时还可用于查找文本。在检索历史组合框里输入欲查找的文本，再按回车键即可开始查找所输入的文本。
单击工具栏最右方的 Company.gif (948 bytes) 图标可打开TRS公司主页。


文件编辑窗口的快捷键和编辑键

文件编辑窗口可用的快捷键如下：

Ctrl+N
Ctrl+O
Ctrl+M
Ctrl+E
Ctrl+P

Ctrl+Z
Ctrl+X
Ctrl+C
Ctrl+V
Del
Ctrl+A

Ctrl+F
Ctrl+H
F4

F1 		“文件|新建”命令，创建新对象或文件
“文件|打开”命令，打开已存在的文件
“文件|保存”命令，保存当前文件
“文件|发送”命令，把当前文件发送到其他用户
“文件|打印”命令，打印当前文件

“编辑|撤消”命令，撤消上一次操作
“编辑|剪切”命令，删除所选内容并把它放到剪贴板上
“编辑|复制”命令，复制所选内容到剪贴板上
“编辑|粘贴”命令，插入剪贴板内容
“编辑|删除”命令，删除所选内容
“编辑|全部选定”命令，选定所有内容

“查看|查找”命令，查找指定的文本
“查看|替换”命令，用新的内容替代指定的文本
“查看|重复”命令，重复上一次的查找/替换操作

显示当前所在窗口、菜单、控制的帮助信息

文件编辑窗口可以用以下编辑键编辑文本：

←
Ctrl+←
→
Ctrl+→
↑
↓
Home
End
PageUp
PageDown
Shift+移动键

Enter
Delete
Ctrl+Delete
Back
Ctrl+Back
Ctrl+Home
Ctrl+End
Ctrl+PageUp
Ctrl+PageDown 		插入点左移一个字符
插入点左移一个单词
插入点右移一个字符
插入点右移一个单词
插入上移一行
插入点下移一行
插入点移到行首
插入点移到行尾
屏幕上滚一屏
屏幕下滚一屏
选择文本

换行
删除插入点后的字符或所选内容
删除插入点后的单词
删除插入点前的字符
删除插入点前的单词
滚动到文本的头一个字符
滚动到文本的最后一个字符
滚动到屏幕最顶端
滚动到屏幕最底端


文件|另存为 命令

当前文件以一个新文件名保存。
选择“文件|另存为”命令后，TRS命令语言弹出如下对话框：

在保存在组合框里选择保存文件的路径，再在文件类型组合框里选择要保存的文件类型（可为TRS脚本文件或者文本文件），然后在文件列表框里选择文件或直接在文件名编辑框里输入文件名，最后按[保存]按钮即可在把当前文件以新名保存。


文件|发送 命令

把当前文件发送到其他用户。
选择“文件|发送”命令，或按工具栏上的 [image] 按钮，TRS命令语言将调用相应的邮件处理软件（如Microsoft Outlook Express等），用户可以利用该软件把当前文件发送到其他用户手里。


文件|打印 命令

打印当前文件。
选择“文件|打印”命令，或按工具栏上的 FilePrint.gif (937 bytes) 按钮，TRS命令语言弹出如下对话框：

在对话框中选择目标打印机，输入打印份数后，按[确定]键后，TRS命令语言将开始打印当前文件，按[取消]则放弃打印操作。由于打印文件是一个耗时过程，因此打印过程中会显示“打印进度”对话框，显示当前已打印的页数和打印完成的百分比，按[终止]按钮将中断打印过程。


文件|页面设置 命令

设置打印纸张及打印的页面参数。
选择“文件|打印”命令，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
纸张 | 指定打印纸张的大小和来源。
大小 | 指定要使用的纸张或信封大小。
来源 | 指定纸张在打印机上的位置。不同打印机有不同的纸张来源，如上层纸盒、信封送纸器和手动送纸器等。

方向 | 显示整个文档在整个页面上的位置。
纵向 | 纵向打印文件。
横向 | 横向打印文件。

页边距 | 设置页面的打印区域。此处设置的边距不在打印范围内。
左 | 设置页面的左边距，缺省为10mm。
右 | 设置页面的右边距，缺省为10mm。
上 | 设置页面的上边距，缺省为10mm。
下 | 设置页面的下边距，缺省为10mm。

每改变一个选项，对话框上部的预览画面都会相应地作出调整。按[确定]，所作设置将作为打印时的页面设置；按[取消]将放弃所作的设置并关闭对话框；按[打印机]将选择打印的目标打印机。


查看|执行选定脚本 命令

执行脚本编辑窗口被选中的语句。

当脚本编辑窗口中有语句被选中时，点击此菜单项或者点击工具栏上的 [image] 按钮，TRS命令语言会将所选中的语句复制到命令窗口中，并执行。


查看|制表位 命令

修改编辑控制的制表符字符数，在1-256之间，缺省值为8。所设制表位字符数将对以后打开的所有脚本编辑窗口有效。


查看|自动折行 命令

设置一行中的文本长度超过显示窗口宽度时是否自动折行，为一开关选项，缺省为不自动折行。所设自动折行标志将对以后打开的所有脚本编辑窗口有效。


查看|查找 命令

在当前显示文本中查找指定的字符串。
选择“查看|查找”命令后，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查找目标 | 要查找的文字。
全字匹配 | 选中表示只查找整个单词，而不查找包含此单词的长字符串。
区分大小写 | 选中表示只查找与输入文字大小写一致的字符串。

输入要查找的文字，设置好查找选项，按[查找下一个]，TRS命令语言将从脚本编辑窗口的当前位置开始查找键入文字下一次出现的位置。由于查找对话框是一个无模式对话框，所以可以执行多次查找而不关闭对话框，并可切换到 脚本编辑窗口进行文本编辑。如要关闭对话框，请按[取消]。


查看|替换 命令

在当前显示文本中查找指定的字符串并用另一指定字符串替换。
选择“查看|替换”命令后，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查找目标 | 要查找的文字。
替换成为 | 用于替代查找文字的新字符串。
全字匹配 | 选中表示只查找整个单词，而不查找包含此单词的长字符串。
区分大小写 | 选中表示只查找与输入文字大小写一致的字符串。

输入要查找的文字或用于替换查找文字的字符串，设置好查找选项，按[查找下一个]，TRS命令语言将从脚本编辑窗口的当前位置开始查找键入文字下一次出现的位置；按[替换]，将搜索查找文字下一次出现的位置，并把它替换为新的字符串；按[全部替换]，将把 脚本编辑窗口中所有的查找文字全部替换成新的字符串。由于替换对话框是一个无模式对话框，所以可以执行多次查找/替换而不关闭对话框，并可切换到脚本编辑窗口进行脚本编辑。如要关闭对话框，请按[取消]。


查看|字体 命令

改变显示字体和颜色。
选择“查看|字体”命令后，TRS命令语言弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
字体 | 列出和选择可用的字体，只列出等宽的字体。字体名前有 TrueType.gif (855 bytes) 标志的为TrueType字体。
字形 | 列出和选择指定字体可用的字形。
大小 | 列出和选择指定字体可用的字号。

效果 | 指定显示文字的颜色和风格。
加删除线 | 选中表示在字体的中间加删除线。
加下划线 | 选中表示在字体的下面加下划线。
颜色 | 选择字体的显示颜色。

示例 | 显示所选字体的范例。
字符集 | 选择显示字体的语言。

选择好显示字体及其颜色、效果、语言等属性以后，按[确定]，将关闭对话框并以新字体显示界面文字。 所设字体对窗口/对话框（不包括系统对话框）内除标题/菜单以外的部分起作用，其中字体大小和颜色只影响对象维护和文件编辑文字，并且下次打开命令语言的时候仍然有效。按[取消]则关闭对话框但不改变显示字体。


TRS命令语言概述

TRSL语法概述

TRS命令语言简称TRSL，是TRS全文数据库对外提供的一套SQL语句集合，用于快速执行各种TRS操作，尤其适合于批处理方式，能大大地简化操作步骤。TRSL共包含35条语句，对每条TRSL语句，按目的、前提、语法、参数、要点、举例和参考的顺序描述。下面首先介绍TRSL的基本语法描述的约定:

lx.gif (91 bytes) 语法规定
大写粗体英文词
TRSL保留字。如SELECT * FROM newsbase语句中的SELECT和FROM均为保留字。但用户在输入时大小写无关。
小写英文词或者汉字
用户输入的信息。如CREATE DATABASE newsbase(txt DOCUMENT)语句中的newsbase和txt分别为数据库名和字段名。
.
用户名和数据库对象名的分隔符。如SELECT * FROM system.newbase语句中的用户名system和数据库名newsbase之间的圆点。
[]
表示可选项。如NOTEPAD [file_name] 语句中的方括号内的file_name表示可选项。
{}
表示至少出现一个元素。如CREATE DATABASE [user.]database_name({...})语句中的大括号表示每个数据库至少有一个字段。
()
系统语法要求，必须输入。
<>
为可选圆括号（语句格式符“( )”）的简写，即等价于“[(] [)]”，用于消除歧义。表示圆括号可以出现，也可以不出现。
字符串
规定用户在输入字符串时必须带单引号，字段值或全文检索词则既可以带也可以不带单引号。如：CREATE DATABASE newbase(txt DOCUMENT DISPLAY '全文'); SELECT * FROM newbase WHERE 中国;
;
TRSL语句结束符(回车也是TRSL语句结束符)。多个TRSL语句之间必须以分号隔开，脚本文件中的TRSL语句之间必须带分号。
|
“|”所连接的项最多只能出现一个。如BROWSE FORMAT [RECORD|TRS]语句中的方括号内的RECORD和TRS表示可选项只能有一个。
,
多个对象之间的分隔符。如SELECT newsbase, hlm WHERE 宝玉 语句中数据库newsbase和数据库hlm之间的逗号。
_
下划线表示缺省值。

删除线表示当与语句不使用时的缺省值，与下划线不同。

在输入TRSL语句时，系统对大小写是不敏感的，你可以输入大写或小写，甚至大小写混合。但要记住，不能使用TRSL保留字作为数据库对象名(如数据库名、字段名等)。TRSL语法的另一个特点是各子句的顺序无关，如：
TRSL> SELECT * FROM newsbase WHERE 中国 */sen 美国;
也可以写为：
TRSL> SELECT * WHERE 中国 */sen 美国 FROM newsbase;

TRS脚本文件中可以使用注释，单行注释以//开头，从//开始到本行结束均为注释内容。也可以使用/*和*/把其间的一段文字标明为注释内容。
TRSL里可以使用变量，变量以$开头，变量名和TRS对象的命名规则一致。
lx.gif (91 bytes) 语句列表
 | ALTER | 修改对象 | NOTEPAD | 编辑文件
 | BACKUP | 备份数据库 | OPTIMIZE | 优化数据库
 | BROWSE | 浏览检索结果 | PRINT | 打印检索结果
 | CLEAR | 清除屏幕内容 | QUIT | 退出并清除操作日志
 | CONNECT | 登录到服务器 | RECOVER | 恢复数据库
 | COPY | 复制记录 | REM | 注释语句
 | CREATE | 创建新对象 | RENAME | 为对象改名
 | DELETE | 删除记录 | REVOKE | 回收用户的权限
 | DROP | 删除对象 | RUN | 运行脚本文件
 | ECHO | 显示控制 | SAVE | 保存检索结果
 | EDIT | 编辑检索结果 | SELECT | 执行检索
 | EXIT | 退出命令语言 | SET | 设置系统参数
 | GRANT | 给用户授权 | SHOW | 显示信息
 | HELP | 显示帮助信息 | SORT | 检索结果重新排序
 | INSERT | 插入新记录 | SPOOL | 输出到文件
 | LOAD | 把记录装进数据库 | UPDATE | 更新记录
 | LOCK | 为数据库解锁 | VALIDATE | 验证索引
 | MAIL | 发送检索结果 |  |

lx.gif (91 bytes) 参考内容
 检索表达式
保留字


ALTER 修改对象属性和结构

Pointer.gif (1201 bytes) ALTER 修改对象属性和结构

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改数据库、视图、词典、用户组、用户、数据格式的属性和结构。

Button.gif (91 bytes) 前提
只有SYSTEM用户才有权修改用户组、用户和数据格式的属性；修改数据库、视图、词典的属性和结构时，操作用户必须对指定对象有ALTER权限。

Button.gif (91 bytes) 语法
本部分只列出语法规则，具体的参数说明、要点、例子等参见各小节的说明。
1. 修改数据库/词典的属性和结构
ALTER DATABASE database_name
[ADD {({<basecol_element> [,...]}) | AS {{[owner.]source_database_name [({column_name [,...]})]} [,...]}}]
[MODIFY ({<mod_basecol_element> [,...]})]
[DROP {column_name [,...]}]
[COMMENT {comment | NULL}]
[CHARSET {DEFAULT | GB18030 | BIG5 | ENGLISH | UTF8}]
[ALIAS {alias [,...] | NULL}]
[DEFCOL column_name]
[PATH data_path]
[HOST {data_host | NULL}]
[SEGMENT {[owner.]segment_dic | DEFAULT | NULL}]
[SEGMENTEX {[owner.]segmentex_dic | DEFAULT | NULL}]
[STOP {[owner.]stop_dic | DEFAULT | NULL}]
[STOPEX {[owner.]stopex_dic | DEFAULT | NULL}]
[SPARSE {[owner.]sparse_dic | DEFAULT | NULL}]
[STEM {ON|OFF}]
[CASE {ON|OFF}]
[NUMBER {ON|OFF}]
[BIGRAM {ON|OFF}]
[COMPRESS {ON | OFF}]
[BANSTOP {ON | OFF}]
[PUBLIC {{ALTER, DROP, INDEX, SELECT, UPDATE} | NULL}]

2. 修改视图的属性和结构
ALTER VIEW view_name
[ADD ({({<viewcol_element> [,...]}) | [column_name [,...] | ALL] FROM {[owner.]database_name [,...]}]
[MODIFY {({<viewcol_element> [,...]}) | [{column_name [,...]} | ALL] {INSERT | DELETE} {[owner.]database_name [,...]}}]
[DROP {column_name [,...]}]
[WHERE {condition | NULL}]
[COMMENT {comment | NULL}]
[ALIAS {alias [,...] | NULL}]
[DEFCOL default_column]
[PUBLIC {{ALTER, DROP, SELECT} | NULL}]

3. 修改用户组的属性
ALTER GROUP group_name
[COMMENT {comment | NULL}]

4. 修改用户的属性
ALTER USER user_name
[TYPE {DBA| GDA| RESOURCE| CONNECT}]
[PASSWORD { password| NULL}]
[GROUP {group_name|NULL}]
[COMMENT {comment | NULL}]
[HISTORY history]
[DOWNLOAD download]
[SECURITY security]
[SEGMENTEX [owner.]segmentex_dic| NULL}]
[STOPEX {[owner.]stopex_dic| NULL}]
[SPARSE {[owner.]sparse_dic| NULL}]
[EXCLUSIVE {ON|OFF}]

5. 修改数据格式的属性
ALTER FORMAT format_name
[CLASS {class | NULL}]
[SUFFIX {{suffix [,...]} | NULL}]
[COMMENT {comment | NULL}]
[COMPRESS {ON|OFF}]

Button.gif (91 bytes) 参数
见语法部分。

Button.gif (91 bytes) 要点
见语法部分。

Button.gif (91 bytes) 举例
见语法部分。


BACKUP 备份数据库

Pointer.gif (1201 bytes) BACKUP 备份数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把一个或多个TRS数据库备份到服务器端的文件或设备里。

Button.gif (91 bytes) 前提
操作用户必须是DBA用户，或是数据库拥有者所在组的GDA用户，或者是所有待备份的数据库的拥有者。

Button.gif (91 bytes) 语法
BACKUP [ALL | {[owner.]database_name [,...]} | [owner.]auto_view_name]
TO backup_file

Button.gif (91 bytes) 参数
ALL：
如果当前操作者是DBA用户，则备份所有的数据库；否则备份当前操作用户的所有数据库。此选项是缺省情况。
owner：
数据库的拥有者，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
database_name/auto_view_name：
需要备份的数据库/自动模式视图名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
backup_file：
存放数据库备份集的目标设备名，可以是服务器端的文件名或磁带名。不指定目标设备名时自动备份到系统缺省备份设备。

Button.gif (91 bytes) 要点
1. 除了数据库中的数据和索引被备份外，下列信息也将被备份到备份集中：数据库的属性、字段的属性、索引的属性等数据词典信息，但权限信息不进行备份。
2. 数据库被备份时，处于UPDATE锁定状态，系统中的TRS用户不能修改数据库中的内容，但可以进行查询操作。
3. 如果用户希望从数据库中下载(Download)一部分数据，可以使用检索并存贮检索结果的功能，而不使用BACKUP功能。
4. 备份集中的数据是格式化文件，只能用于数据库恢复。由于不同平台的数据格式可能存在差异，TRS并不总能保证在一种平台上备份的数据库可以在其它平台上进行数据库恢复，一个数据库从一种平台上移到另外一种平台的最可靠方法是把数据库记录以TRS格式文件存储，从另一个台装库。

Button.gif (91 bytes) 举例
TRSL> BACKUP demo TO /trshome/temp/demo.bak
这条语句的作用是把当前用户的demo数据库备份到服务器的/trshome/temp/demo.bak文件里。

TRSL> BACKUP ALL TO /dev/rst0;
这条语句的作用是把当前用户的所有数据库备份到服务器的/dev/rst0设备下。


BROWSE 浏览检索结果

Pointer.gif (1201 bytes) BROWSE 浏览检索结果

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对当前检索结果进行浏览。

Button.gif (91 bytes) 前提
当前存在检索结果记录集，并且操作用户对所浏览的字段有SELECT权限。

Button.gif (91 bytes) 语法
BROWSE [RECORD {ALL | {{n,[ TILL m ]} [,...]}] [DETAIL]
[COLUMN {ALL | {column_name [,...]}}]

Button.gif (91 bytes) 参数
RECORD：
选择需要浏览的记录号(或记录号集合)，用TILL关键字连接两个记录号可指定一定范围的记录。取值ALL表示浏览所有的命中记录，为缺省值 。
DETAIL：
表示直接显示检索结果的细览。
COLUMN：
选择显示的字段名(或字段名集合)，取值ALL表示显示所有的字段，为缺省值。

Button.gif (91 bytes) 要点
1. 当不指定COLUMN、RECORD参数时，浏览所有的命中结果。
2. column_name为需显示的字段名，当BROWSE后不带字段选择参数时，将显示所有字段。
3. 当指定需要浏览的记录时，所指定的记录号是命中的记录号，不是记录的内部顺序号，当需要按内部记录号进行查询时，可以使用以下TRSL语句：
TRSL> SELECT FROM 库名 WHERE DOCID=docid

 4. 本命令只能浏览文本数据，不能浏览记录中的多媒体数据（如图象）、格式化文件（如WPS文件）、复合文档（MS WORD文件）等。

Button.gif (91 bytes) 举例
TRSL> BROWSE
这条不带任何参数的BROWSE语句表示显示所有的查询结果。

TRSL> BROWSE COLUMN name RECORD 1,3 TILL 5,9
表示浏览字段name，浏览的命中记录为1，3，4，5，9共5个记录。


CLASSIFY 字段值分类

Pointer.gif (1201 bytes) CLASSIFY 字段值分类

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
按字段值对检索结果进行分类统计。

Button.gif (91 bytes) 前提
当前存在检索结果记录集。

Button.gif (91 bytes) 语法
CLASSIFY column_name
[AS [{<regular_expression> [,...]} | VALUES {<focus_value> [,...]}] [NOCASE]]
[ORDER BY [{RELEVANCE | {column_name [ASC | DESC]}} [,...]] [LIFO] [{PRUNE | VALID} record_number] [MIXED] [MISCOL] [NOCASE]]
[CUTSIZE class_cutsize]
[LIST BY [NAME | COUNT] [ASC | DESC]]

Button.gif (91 bytes) 参数
column_name：
指定按值分类的字段。
AS：
指定分类时关注的字段值。
ORDER BY：
记录的排列顺序。对每个column_name可用ASC或DESC分别指定按升序/降序方式排列。字段名也可为RELEVANCE，表示按相关性排序，但只能按升序排列。也可指定为LIFO，表示按后进先出顺序排列。对于参数record_number，若前面选择PRUNE时则代表排序并裁减保存的结果记录数，同时自动设置“非精确命中点”模式；选择VALID时则代表有效排序结果记录数，即部分排序，按排序表达式排序的结果只保证前一部分记录是有序的 。MIXED表示对检索结果进行混合统一排序。MISCOL则表示对排序表达式中不存在的字段，按字段无值时情况处理。NOCASE表示排序表达式中的字段值，其字符是大小写无关的 。
CUTSIZE：
每个类中保留结果记录的个数。
LIST BY：
显示结果的排列方式。NAME指按类别名排序，COUNT值按每个类别的记录数排序。排序方式分为ASC升序和DESC降序排列两种。

Button.gif (91 bytes) 要点
1. 必须首先进行对数据库/视图进行检索，并取得有效的检索句柄。
2. 重新排序后，分类统计将失效，检索结果恢复为原来的记录集。
3. 当设置了CUTSIZE后，LIST BY排序将不起作用。

Button.gif (91 bytes) 举例
TRSL> CLASSIFY 版次 LIST BY COUNT DESC
表示按字段“版次”分类，显示结果按每个类别的记录数降序排列。


CLEAR 清除屏幕内容

Pointer.gif (1201 bytes) CLEAR 清除屏幕内容

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
清屏。

Button.gif (91 bytes) 前提
无，任何TRS用户均可操作。

Button.gif (91 bytes) 语法
CLEAR

Button.gif (91 bytes) 参数
无。

Button.gif (91 bytes) 要点
CLEAR操作将把当前屏幕中的所有内容清除，并在屏幕的最后一行显示命令行提示符TRSL> 。

Button.gif (91 bytes) 举例
TRSL> CLEAR

Button.gif (91 bytes) 参考
无。


COPY 复制数据库记录

Pointer.gif (1201 bytes) COPY 复制数据库记录

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把符合条件的记录从一个数据库/视图复制到目标数据库中。

Button.gif (91 bytes) 前提
操作用户必须对目标数据库有UPDATE权限，并且对源数据库/视图有SELECT权限。

Button.gif (91 bytes) 语法
COPY {[owner.]source_database_name | [owner.]source_auto_view_name} [({column_name [,...]})] [RAPIDLY]
[INTO {[owner.]target_database_name | [owner.]target_auto_view_name}
[WHERE expression]
[ORDER BY [{RELEVANCE | {column_name [ASC | DESC]}} [,...]] [LIFO] [{PRUNE | VALID} record_number] [NOCASE]]
 [RELEVANT {NULL | NORMAL | GLOBAL | NORMPOS | GLOBPOS | WORDS | WFREQ}]

Button.gif (91 bytes) 参数
owner：
待复制的数据库/视图的拥有者。
source_database_name/source_auto_view_name：
待复制的数据库/视图名。
column_name：
待复制的字段名，必须同时存在于目标数据库和源数据库/视图中，并且具有相同的字段类型，不指定时表示复制所有字段。字段名可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
RAPIDLY：
如果复制记录时不需要同步创建索引，则可使用RAPIDLY选项。
INTO：
owner表示目标数据库的拥有者。target_database_name和target_auto_view_name分别表示目标数据库/视图名。
WHERE：
复制记录的条件，只有符合条件的记录才会被复制到目标数据库中。不指定时表示复制所有记录。
ORDER BY：
记录的排列顺序。对每个column_name可用ASC或DESC分别指定按升序/降序方式排列。字段名也可为RELEVANCE，表示按相关性排序，但只能按升序排列。也可指定为LIFO，表示按后进先出顺序排列。对于参数record_number，若前面选择PRUNE时则代表排序并裁减保存的结果记录数，同时自动设置“非精确命中点”模式；选择VALID时则代表有效排序结果记录数，即部分排序，按排序表达式排序的结果只保证前一部分记录是有序的 。NOCASE表示不区分大小写。
RELEVANT：
以相关性模式和IDF模式组合的相关性排序选项。NULL表示由系统配置决定；NORMAL表示忽略词的位置和使用基于单个数据库范围的IDF值；GLOBAL表示忽略词的位置和词IDF值不参与相关性计算；NORMPOS表示考虑词的位置和使用基于单个数据库范围的IDF值； GLOBPOS考虑词的位置和词IDF值不参与相关性计算；WORDS表示用一个记录中命中词的单位向量长度（每个命中词只计算一次）作为记录的相关；WFRE表示用一个记录中命中词的单位向量长度，以及命中词的词频和作为记录的相关度。

Button.gif (91 bytes) 要点
无。

Button.gif (91 bytes) 举例
TRSL> COPY demo2 (日期,标题,正文) INTO demo1 WHERE 中国*北京
这条语句的作用是把demo2数据库里包含“中国”和“北京”的记录复制到demo1数据库里，只复制日期、标题和正文三个字段 。


CREATE 创建新对象

Pointer.gif (1201 bytes) CREATE 创建新对象

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的数据库、视图、词典、用户组、用户、数据格式和索引。

Button.gif (91 bytes) 前提
只有SYSTEM用户才有权创建用户组、用户和数据格式；创建数据库、视图、词典时，操作用户必须具有Resource权限；创建索引时，当前操作者必须对数据库拥有INDEX权限。

Button.gif (91 bytes) 语法
本部分只列出语法规则，具体的参数说明、要点、例子等参见各小节的说明。
1. 创建数据库/词典
CREATE DATABASE database_name
{({<basecol_element> [,...]}) | AS {{[owner.]source_database_name [({column_name [,...]})]} [,...]}}
[TYPE {NORMAL|SEGMENT|SEGMENTEX|STOP|STOPEX|SPARSE|THESAURUS|SYNONYM|ANTONYM}]
[COMMENT {comment | NULL}]
[CHARSET {DEFAULT | GB18030 | BIG5 | ENGLISH | UTF8}]
[ALIAS {{{alias [,...]} | NULL}]
[DEFCOL default_column]
[PATH data_path]
[HOST {data_host | NULL}]
[SEGMENT {[owner.]segment_dic | DEFAULT | NULL}]
[SEGMENTEX {[owner.]segmentex_dic | DEFAULT | NULL}]
[STOP {[owner.]stop_dic | DEFAULT | NULL}]
[STOPEX {[owner.]stopex_dic | DEFAULT | NULL}]
[SPARSE {[owner.]sparse_dic | DEFAULT | NULL}]
[STEM {ON|OFF}]
[CASE {ON|OFF}]
[NUMBER {ON|OFF}]
[BIGRAM {ON|OFF}]
[COMPRESS {ON|OFF}]
[BANSTOP {ON | OFF}]
[PUBLIC {{ALTER, DROP, INDEX, SELECT, UPDATE} | NULL}]

2. 创建视图
CREATE VIEW view_name
{({<viewcol_element> [,...]}) | AS {[owner.]database_name [,...]} [SELECT {column_name [,...}] | SPLIT [owner.]database_name}
[WHERE {condition | NULL}]
[COMMENT {comment | NULL}]
[ALIAS {{alias [,...]} | NULL}]
[DEFCOL default_column]
[PUBLIC {{ALTER, DROP, SELECT} | NULL}]
3. 创建用户组
CREATE GROUP group_name
[COMMENT comment| NULL}]

4. 创建用户
CREATE USER user_name
[TYPE {DBA|GDA|RESOURCE|CONNECT}]
[PASSWORD {password | NULL}]
[GROUP {group_name | NULL}]
[COMMENT {comment | NULL}]
[HISTORY history]
[DOWNLOAD download]
[SECURITY security]
[SEGMENTEX {{[owner.]segmentex_dic | NULL}]
[STOPEX {[owner.]stopex_dic | NULL}]
[SPARSE {[owner.]sparse_dic | NULL}]
[EXCLUSIVE {ON|OFF}]

5. 创建数据格式
CREATE FORMAT format_name
[CLASS {class | NULL}]
[SUFFIX {suffix [,...]} | NULL}]
[COMMENT {comment | NULL}]
[COMPRESS {ON|OFF}]

6. 创建索引
CREATE INDEX {[owner.]database_name | [owner.]auto_view_name} [({column_name [, …]})]
[TILL record]

Button.gif (91 bytes) 参数
见语法部分。

Button.gif (91 bytes) 要点
见语法部分。

Button.gif (91 bytes) 举例
见语法部分。


DELETE 删除数据

Pointer.gif (1201 bytes) DELETE 删除 数据

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
从数据库中删除记录。

Button.gif (91 bytes) 前提
操作用户对数据库有UPDATE权限。

Button.gif (91 bytes) 语法
DELETE FROM {[owner.]database_name | [owner.]auto_view_name} [FINALLY]
[WHERE condition]

Button.gif (91 bytes) 参数
owner：
目标数据库的拥有者。
database_name/auto_view_name：
目标数据库/自动模式视图名。
FINALLY：
彻底删除数据与索引。
WHERE：
待删除记录的条件，只有满足条件的记录才会被删除。也可用DOCID=id表示物理记录号为id的记录。除此之外，本子句还可以指定删除词语。

Button.gif (91 bytes) 要点
1. 如果不指定删除条件，则默认为删除数据库中的所有记录。
2. 本语句同样可以删除词典中的词语，对于主题词典、同义词典、反义词典用法和数据库一致，对其它词典则只需在WHERE子句中指定待删除的词语列表就行了。

Button.gif (91 bytes) 举例
TRSL> DELETE FROM newsbase WHERE 苏联 FINALLY
这条语句的作用是完全删除数据库newsbase中所有含有词“苏联”的记录。

TRSL> DELETE FROM mysegdic WHERE '苏联,民主德国'
这条语句的作用是删除词典mysegdic中指定的词语。


DROP 删除对象

Pointer.gif (1201 bytes) DROP 删除对象

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
删除数据库、视图、词典、用户组或用户对象，或删除字段上的索引。

Button.gif (91 bytes) 前提
删除用户组或用户时，当前操作者必须是SYSTEM用户；删除数据库/视图时，当前操作者必须对该对象有DROP权限；删除索引时，当前操作者必须对数据库拥有INDEX权限。

Button.gif (91 bytes) 语法
1. 删除对象
DROP [DATABASE | VIEW | GROUP | USER]
[owner.]object_name, [[owner.]object_name]...

2. 删除索引
DROP INDEX [[owner.]database_name
[(column_name [,column_name]...)]
[FROM record]

Button.gif (91 bytes) 参数
DATABASE：
指明为删除数据库，为缺省值。由于词典是一种特殊的数据库，此参数也用于能删除词典。
VIEW：
指明为删除视图。
GROUP：
指明为删除用户组。
USER：
指明为删除用户。
INDEX：
指明为删除字段上的索引。
object_name：
待删除的对象名，删除数据库/视图时可由owner指定对象的拥有者。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
database_name：
删除索引时，指定索引字段所在的数据库名，可由user指定数据库的拥有者。
column_name：
删除索引时，指定索引所在的字段名。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
record：
删除索引的起始记录号，不指定时表示删除所有记录的索引。

Button.gif (91 bytes) 要点
1. 本语句不能删除字段和数据格式。要删除字段请用ALTER语句，数据格式不能被删除。
2. 一次可以删除多个对象，或删除多个字段上的索引。
3. 数据库/视图被删除后，数据库/视图上所有的数据文件、索引文件和权限信息都被删除，和数据库有关的视图也被删除。
4. 删除一个用户组以后，该组里的所有用户的所在组名将变为空。
5. 字段索引被删除后，在此字段上不能再进行检索。一般情况下，索引由系统自动维护，只在如下几种情况下才需要手动删除索引：
· 在此字段上不需按条件进行查询；
· 为了进行空间整理，临时删除字段上的索引
· 字段索引文件被破坏。

Button.gif (91 bytes) 举例
TRSL> DROP DATABASE pub.newsbase
这条语句的作用是删除数据库pub.newsbase。

TRSL> DROP USER tom, jenny
这条语句的作用是删除用户tom和jenny。

TRSL> DROP INDEX patent(标题, 摘要)
这条语句的作用是删除数据库patent的标题和摘要字段上的索引。


ECHO 显示控制

Pointer.gif (1201 bytes) ECHO 显示控制

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
 对TRSL语句执行结果信息的显示进行控制。

Button.gif (91 bytes) 前提
 无。

Button.gif (91 bytes) 语法
ECHO { ON│OFF }

Button.gif (91 bytes) 参数
ON：
显示执行过程和结果。
OFF：
不显示执行过程和结果。

Button.gif (91 bytes) 要点
1. 当指定为ON时，TRSL 语句执行结果的提示显示在屏幕上，如建立数据库，建立成功或失败均有显示，为OFF则不显示。缺省值是ON。
2. 本语句单独在TRSL窗口中使用没有什么意义，但在运行TRSL脚本文件时，如果ECHO语句和SPOOL语句配合使用，可以不显示脚本文件的运行过程，但执行的过程和结果全部输出到外部文件中，适合于长时间的脚本文件运行操作。

Button.gif (91 bytes) 举例
以下是一个简单的TRS脚本文件的内容：

ECHO OFF;
SPOOL batch.log;
SELECT * FROM newsbase WHERE 检索;
SELECT * FROM newsbase WHERE 经济 * 日期>=1993;
SPOOL OFF;
ECHO ON;

这个脚本文件的作用是关闭屏幕显示，并把其后两次检索的结果写到batch.log文件里，最后恢复屏幕显示。


EDIT 编辑检索结果

Pointer.gif (1201 bytes) EDIT 编辑检索结果

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对检索结果进行编辑。

Button.gif (91 bytes) 前提
当前存在检索结果记录集，并且操作用户对所编辑的字段有SELECT权限。

Button.gif (91 bytes) 语法
EDIT [RECORD {ALL | {{n [,...]} [ TILL m ]} [,...]}]
[COLUMN {ALL | {column_name [,...]}}]
[FORMAT [NORMAL | ISO2709 | XML] [DOCID] [PREFIX prefix]]

Button.gif (91 bytes) 参数
RECORD：
选择需要编辑的记录号(或记录号集合)，用TILL关键字连接两个记录号可指定一定范围的记录。取值ALL表示编辑所有的命中记录，为缺省值。
COLUMN：
选择编辑的字段名(或字段名集合)，取值ALL表示编辑所有的字段，为缺省值。
FORMAT：
指明以何种格式编辑数据库记录。NORMAL是缺省的编辑方式，如果要以TRS格式文件中TRS记录格式来编辑 ，为默认格式。如果要以ISO2709或XML格式文件进行发送，取值为ISO2709/XML。DOCID表示加上记录的物理记录号，以支持恢复数据镜像。PREFIX表示添加记录前缀。

Button.gif (91 bytes) 要点
1. 当不指定COLUMN、RECORD参数时，编辑所有的命中结果。
2. column_name为需编辑的字段名，当EDIT后不带字段选择参数时，将编辑所有字段。
3. 当指定需要编辑的记录时，所指定的记录号是命中的记录号，不是记录的内部顺序号，当需要按内部记录号进行查询时，可以使用以下TRSL语句：
TRSL> SELECT FROM 库名 WHERE DOCID=docid

4. EDIT语句使用的缺省编辑器是 命令语言中的脚本编辑窗口，将以文本文件的方式打开检索结果，如果数据中有非ASCII数据（多媒体数据或复合文档），则不处理这些数据。如果用户需要使用其它的编辑器，则可先用SAVE语句将结果存于文件中，然后再进行编辑。

Button.gif (91 bytes) 举例
TRSL> SELECT FROM newsbase WHERE 中国 */sen 经济改革
TRSL> EDIT RECORD 1,2,3,4
上面第一条语句的作用是对newsbase数据库进行查询，第二条语句的作用是编辑前四个命中记录。

TRSL> SELECT FROM newsbase,hlm WHERE 宝玉
TRSL> EDIT COLUMN tx RECORD 1
上面第一条语句的作用是在两个数据库newsbase和hlm上进行查询，第二条语句的作用是编辑命中的第一条记录的tx字段。


EXIT 退出命令语言处理工具

Pointer.gif (1201 bytes) EXIT 退出命令语言处理工具

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
退出TRS命令语言处理工具。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
EXIT

Button.gif (91 bytes) 参数
无。

Button.gif (91 bytes) 要点
1. 用户使用EXIT从TRSL中退出后，操作日志和检索历史将保留。
2. TRSL的QUIT语句也可以退出命令语言处理工具，EXIT语句和QUIT语句的区别在于EXIT语句保留操作日志，而QUIT语句将删除操作日志。
3. 退出TRSL时会自动清除当前的检索结果，并断开与当前服务器的连接。

Button.gif (91 bytes) 举例
TRSL> EXIT


GRANT 给用户授权

Pointer.gif (1201 bytes) GRANT 给用户授权

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把数据库、视图、词典、字段的操作权限授予用户组/用户。

Button.gif (91 bytes) 前提
当前操作用户必须是DBA用户，或是指定对象拥有者所在组的GDA用户，或是指定对象的拥有者。

Button.gif (91 bytes) 语法
GRANT [ALL | {ALTER, DROP, INDEX, SELECT, UPDATE}]
TO {user_name | group_name} [,...}
ON [owner.]object_name [({column_name [,...]})]

Button.gif (91 bytes) 参数
ALL/ALTER/DROP/INDEX/SELECT/UPDATE：
授予的权限类型，对不同的对象有不同的取值范围。对数据库可为SELECT、UPDATE、INDEX、ALTER、DROP，对视图可为SELECT、ALTER、DROP，对词典可为SELECT、UPDATE、DROP，对字段只能为SELECT。指定为ALL表示所有权限，为缺省设置。为了提高效率，若授予的权限对象不支持，将不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。
user_name/group_name：
待授予权限的用户/用户组。用户组和用户名均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。其中“*”表示所有用户组，“用户组.*”表示该用户组里的所有用户，“*.*”表示所有用户。
object_name：
授予权限的目标对象，可用user指定对象的拥有者。
column_name：
待授予权限的字段名，不指定时表示对对象授权。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。

Button.gif (91 bytes) 要点
1. 一次可以给多个用户组/用户授权，授权的目标数据库、视图、词典只能有一个，但可同时针对多个字段授予权限。
2. 对DBA用户、对象拥有者所在组的GDA用户、或指定对象的拥有者授权没有实际意义。

Button.gif (91 bytes) 举例
TRSL> GRANT SELECT, UPDATE TO tom, product.* ON newsbase
这条语句的作用是把数据库newsbase的SELECT和UPDATE权限授予用户tom和product组里的所有用户。

TRSL> GRANT TO *.* ON personnel(resume)
这条语句的作用是把数据库personnel的字段resume上的所有权限授予所有用户。


HELP 显示帮助信息

Pointer.gif (1201 bytes) HELP 显示帮助信息

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
显示TRSL的帮助信息。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
HELP [keyword]

Button.gif (91 bytes) 参数
keyword
需要查看帮助信息的语句，如不指定则显示语法概述和语句列表。

Button.gif (91 bytes) 要点
无。

Button.gif (91 bytes) 举例
TRSL> HELP create
这条语句的作用是显示create语句的帮助信息。

Button.gif (91 bytes) 参考
无。


INSERT 插入新记录

Pointer.gif (1201 bytes) INSERT 插入新记录

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
向数据库中插入新的记录。

Button.gif (91 bytes) 前提
操作用户对数据库有UPDATE权限。

Button.gif (91 bytes) 语法
INSERT INTO {[owner.]database_name | [owner.]auto_view_name} [({column_name [,...]})]
VALUES ({<value> [,...]})
[SEPARATOR separator]
[PASSWORD {password | NULL}]
[GROUP {group_name | NULL}]
[SECURITY security_code]
[CONTROL control_file]

Button.gif (91 bytes) 参数
owner：
目标数据库的拥有者。
database_name/auto_view_name：
目标数据库/自动模式视图名。
column_name：
字段名。如果不指定字段名列表，则表示对词典进行操作。
VALUES：
字段值列表，与字段名列表里指定的字段一一对应。
SEPARATOR：
多值字段的分隔符。为字符串类型，仅对DATE、NUMBER和CHAR类型字段有效，缺省为';'。
PASSWORD：
记录的访问密码，取该记录内容时必须提供正确的密码。
GROUP：
记录对外开放的用户组。
SECURITY：
赋予记录的安全级别，访问这些记录时操作者的安全级别必须不大于此安全级别。取值范围为0到0xFFFFFFFD， 缺省为零，表示访问此记录无须经过安全级别检查。
CONTROL：
加载控制的文件名。

Button.gif (91 bytes) 要点
1. 本语句每次只能插入一个记录，要批量加载记录请使用LOAD语句。
2. 插入新记录时，如果字段上已经建立了索引，则索引会自动调整，但如果数据库字段上没有建立索引，则不调整索引。这和LOAD语句不一样，对LOAD语句来说，如果数据库的同步索引控制开关为ON，则自动调整数据库字段索引，无论用户是否已经在数据库字段上创建了索引。
3. 使用本语句同样可以向词典中插入词语。对于主题词典、同义词典和反义词典，用法和数据库一致；对于其它词典，则直接在VALUES后面指定多个要添加的词语就可以了，无须且不能指定字段名。

Button.gif (91 bytes) 举例
TRSL> INSERT INTO personnel(name,age,resume) VALUES('Scott',27,'@scott.res')
这条语句的作用是向数据库personnel中插装入一条记录。符号@表示从文件中获得字段数据。

TRSL> INSERT INTO newsbase(正文) VALUES('@test.doc|test.txt^WORD') PASSWORD test
这条语句的作用是在数据库newsbase中插入一条记录，并把该记录的密码设为test。字段值对应newbase的头一个字段，符号@表示从文件中获得数据，原始数据文件名为test.doc，它是一MS WORD格式的文件，test.txt为从test.doc转换后的ASCII文本文件。

TRSL> INSERT INTO mysegdic VALUES(中关村,亚运村)
这条语句的作用是向词典mysegdic中插装入两条词语。


LOAD 把记录装进数据库

Pointer.gif (1201 bytes) LOAD 把记录装进数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把TRS装库文件里的数据装到目标数据库中。

Button.gif (91 bytes) 前提
操作用户必须对指定数据库有UPDATE权限。

Button.gif (91 bytes) 语法
LOAD [BATCH] source_file
[THROUGHT] INTO {[owner.]database_name | [owner.]auto_view_name}
[FORMAT format]
[CONTROL control_file]

Button.gif (91 bytes) 参数
source_file：
装库数据文件或批装库文件名，文件的类型默认为单TRS装库数据文件，若指明为BATCH则表示 批TRS装库文件。
THROUGHT：
允许以“直通模式”加载数据。如果数据加载所涉及到所有原始数据文件、批处理文件、控制文件，服务器的启动帐号都有读取权限，则可使用直通模式进行数据加载。由于直通模式下服务器直接读取原始数据文件，从而减少了中间环节，所以效率会更高。
owner：
装库的目标数据库的拥有者。
database_name/owner.]auto_view_name：
装库的目标数据库\自动模式视图名。
FORMAT：
装库文件格式。
CONTROL：
装库控制文件名，不指定时由系统决定装库参数的值。

Button.gif (91 bytes) 要点
1. source_file为被装库的数据文件名，当选单TRS数据文件装库时，该文件的内容为一条或多条TRS记录；当选用BATCH模式装库时，该文件中的每一行为一个文件名，其内容是一条或多条TRS记录。文件名可以带路径，也可以在装库控制文件中由DATA_PATH_DEFAULT参数来指定。如果没有指定装库控制文件，则由系统决定装库参数的缺省值。
2. 本语句除了可以向数据库中加载记录以外，还可以向词典里加载记录。每次可装入一条记录或一批记录。
3. 有关TRS装库数据文件和装库控制文件的格式请参见《数据库加载格式规范》。

Button.gif (91 bytes) 举例
TRSL> LOAD e:\demo.trs INTO demo1
这条语句的作用是把一个TRS装库数据文件demo.trs装入数据库demo1中。

TRSL> LOAD BATCH e:\temp\trs_gp.tbl INTO trs_group CONTROL trs_gp.ctr
这条语句的作用是把一个TRS批装库文件trs_gp.tbl里包含的所有TRS数据文件装入数据库trs_group中，装库参数由trs_gp.ctr控制文件指定。


LOCK 锁定数据库

Pointer.gif (1201 bytes) LOCK 锁定数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对数据库进行锁定操作。

Button.gif (91 bytes) 前提
当前操作用户必须是DBA用户，或是数据库拥有者所在组的GDA用户，或是数据库的拥有者。

Button.gif (91 bytes) 语法
LOCK {[owner.]database_name [, …]}
IN {EXCLUSIVE | UPDATE} MODE

Button.gif (91 bytes) 参数
owner：
数据库的拥有者，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
database_name ：
指明要锁定的数据库名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
EXCLUSIVE / UPDATE：
加锁的模式。分别为访问互斥锁和修改互斥锁。

Button.gif (91 bytes) 要点
1. 锁定操作是由系统自动管理的，通常情况下不需要干预。只有当数据库由于某种原因处于不正确锁定状态时，才需要使用本语句把数据库重新置为共享状态。
2. TRS 中数据库的锁定模式有下列几种：
· ACCESS_EXCL： 访问互斥锁，当前用户独占数据库，其它用户不能对此数据库进行任何操作。
· UPDATE_EXCL： 修改锁，不允许其它用户在数据库上作维护操作，但允许进行查询操作。
· UPDATE_WAIT： 修改等待锁，一直等待直到能给数据库加上修改锁为止，访问规则同修改锁。
· ACCESS_DENY： 这种锁表明数据库处于禁止访问状态，其它用户不能进行任何操作，也不能使用其它锁对数据库进行锁定。

Button.gif (91 bytes) 举例
TRSL> LOCK demo2 IN UPDATE MODE
 这条语句的作用是把demo2数据库设置为修改互斥状态。


LOGIN 登录到服务器

Pointer.gif (1201 bytes) LOGIN 登录到服务器

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
登录到TRS服务器。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
LOGIN [address:port] [USER user_name] [PASSWORD password]]

Button.gif (91 bytes) 参数
address:
服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。
port:
服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。
USER:
用户的帐号名，必须是指定服务器中已经存在的用户名。
PASSWORD:
用户的口令字，区分大小写。

Button.gif (91 bytes) 要点
1. 如果没有指定参数，则命令语言处理工具会弹出对话框提示输入服务器地址、服务器端口、用户名和口令字，并进行登录。如只指定了用户账号而没有给出服务器地址和端口，则表示用不同的用户和密码重新登录当前服务器，此时如没有连接到服务器则 会报错。
2. 必须首先登录到服务器，然后才能执行其它TRS操作。
3. 退出命令语言处理工具时会自动断开与TRS服务器的连接。

Button.gif (91 bytes) 举例
TRSL> LOGIN alpha:8888 USER system PASSWORD manager
TRSL> LOGIN

 第一条语句直接用system用户名登录到alpha:8888服务器上，第二条语句则打开对话框进行登录操作。

Button.gif (91 bytes) 参考
LOGOUT 注销登录。


LOGOUT 注销登录

Pointer.gif (1201 bytes) LOGOUT 注销登录

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
注销登录。

Button.gif (91 bytes) 前提
必须首先登录到TRS服务器。

Button.gif (91 bytes) 语法
LOGOUT

Button.gif (91 bytes) 参数
无。

Button.gif (91 bytes) 要点
连接终止后，不能再执行除登录和网络操作外的任何TRS操作。

Button.gif (91 bytes) 举例
TRSL> LOGOUT
 这条语句的作用终止用户与TRS服务器之间的连接。


MAIL 发送检索结果

Pointer.gif (1201 bytes) MAIL 发送检索结果

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把当前检索结果发送给其他用户。

Button.gif (91 bytes) 前提
当前存在检索结果记录集，并且操作用户对所发送的字段有SELECT权限。

Button.gif (91 bytes) 语法
MAIL [RECORD {ALL | {{n [,...]} [ TILL m ]} [,...]}]
[COLUMN {ALL | {column_name [,...]}}]
[FORMAT [PLAIN | NORMAL | ISO2709 | XML] [DOCID] [PREFIX prefix]]
[SUBJECT mail_subject]
[TO {{user_name | mail_box} [,...]}]
[CC {{user_name | mail_box} [,...]}]

Button.gif (91 bytes) 参数
RECORD：
选择需要发送的记录号(或记录号集合)，用TILL关键字连接两个记录号可指定一定范围的记录。取值ALL表示发送所有的命中记录，为缺省值。
COLUMN：
选择发送的字段名(或字段名集合)，取值ALL表示发送所有的字段，为缺省值。
FORMAT：
指明以何种格式发送数据库记录。PLAIN表示记录文件格式；NORMAL表示TRS装库文件格式 ，为默认格式；如果要以ISO2709或XML格式文件进行发送，取值为ISO2709/XML。DOCID表示加上记录的物理记录号，以支持恢复数据镜像。PREFIX表示添加记录前缀。
SUBJECT：
选邮件的主题。
TO：
邮件接收者。
CC：
邮件的抄送者。

Button.gif (91 bytes) 要点
1. 当不指定COLUMN、RECORD参数时，发送所有的命中结果。
2. column_name为需发送的字段名，当MAIL后不带字段选择参数时，将发送所有字段。
3. 当指定需要发送的记录时，所指定的记录号是命中的记录号，不是记录的内部顺序号，当需要按内部记录号进行查询时，可以使用以下TRSL语句：
TRSL> SELECT FROM 库名 WHERE DOCID=docid
 4. 发送检索结果时，记录中的多媒体数据（如图象）、格式化文件（如WPS文件）、复合文档（MS WORD文件）等将被滤掉。
5. MAIL语句执行结束后，检索结果会以附件的形式放入邮件中等待发送。

Button.gif (91 bytes) 举例
TRSL> SELECT FROM newsbase WHERE 中国 */sen 经济改革
TRSL> MAIL RECORD 1,2,3,4
上面第一条语句的作用是进行查询，第二条语句的作用发送命中记录集合中的前四个记录。

TRSL> SELECT FROM newsbase,hlm WHERE 宝玉
TRSL> MAIL COLUMN tx RECORD 1 FORMAT ISO2709
上面第一条语句的作用是在两个数据库newsbase和hlm上进行查询，第二条语句的作用是把命中的第一条记录的tx字段内容发送给其他用户（由用户在邮件发送程序里指定），发送格式为ISO2709格式。


MODIFY 修改记录

Pointer.gif (1201 bytes) MODIFY 修改记录

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
以数据文件方式更新记录。

Button.gif (91 bytes) 前提
当前操作者必须对目标数据库/自动模式视图/词典有UPDATE权。

Button.gif (91 bytes) 语法
MODIFY [INCREMENT] {[owner.]database_name | [owner.]auto_view_name} [({column_name [,...]})]
[THROUGHT] JOIN source_file [BY {DOCID | column_name}]
[SEPARATOR separator]
[PASSWORD {password | NULL}]
[GROUP {group_name | NULL}]
[SECURITY security_code]
[FORMAT format]
[CONTROL control_file]

Button.gif (91 bytes) 参数
INCREMENT：
表示批量更新记录时，允许源记录格式文件中出现的新记录。
owner：
目标数据库/自动模式视图/词典的拥有者。
database_name/auto_view_name：
目标数据库/自动模式视图/词典名。
THROUGHT：
允许以“直通模式”加载数据。如果数据加载所涉及到所有原始数据文件、批处理文件、控制文件，服务器的启动帐号都有读取权限，则可使用直通模式进行数据加载。由于直通模式下服务器直接读取原始数据文件，从而减少了中间环节，所以效率会更高。注意，此处用到的source_file在生成时必须指定生成格式为DOCID。
JOIN：
更新源数据库文件及更新条件。source_file表示更新的源数据库文件。DOCID表示以指定物理记录号列表的方式更新，column_name为指定的字段名。
BY：
用于指定作为记录映射的字段名。
SEPARATOR：
多值字段的分隔符。为字符串类型，仅对DATE、NUMBER和CHAR类型字段有效，缺省为';'。
PASSWORD：
记录的访问密码。
GROUP：
记录对外开放的用户组。
SECURITY：
赋予记录的安全级别，访问这些记录时操作者的安全级别必须不大于此安全级别。取值范围为0到0xFFFFFFFD， 缺省为零，表示访问此记录无须经过安全级别检查。
FORMAT ：
更新源数据库文件的格式。
CONTROL：
加载控制文件名。

Button.gif (91 bytes) 要点
无。

Button.gif (91 bytes) 举例
TRSL> MODIFY demo2 JOIN C:\\DEMO.DAT
上面第一条语句的作用是以数据文件DEMO.DAT的内容更新数据库demo2中的记录。

Button.gif (91 bytes) 参考
无。


NOTEPAD 编辑文件

Pointer.gif (1201 bytes) NOTEPAD 编辑文件

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
调用Windows的记事本NOTEPAD编辑文件。

Button.gif (91 bytes) 前提
Windows下有NOTEPAD应用程序。

Button.gif (91 bytes) 语法
NOTEPAD [file_name]

Button.gif (91 bytes) 参数
file_name:
用户需要编辑的文件名，为可选项，不带路径时表示为当前目录。如果用户没有指定文件名，则新建一个空文件。

Button.gif (91 bytes) 要点
1. NOTEPAD语句一般用来编辑TRS脚本文件、TRS装库控制文件等。
2. 用户可以在其它WINDOWS编辑器中编辑文件，但TRSL的RUN语句可执行的必须是ASCII文本文件。

Button.gif (91 bytes) 举例
TRSL> NOTEPAD
TRSL> NOTEPAD test.trs

第一条TRSL语句没有带文件名，Windows将打开一个空的记事本；第二条语句是编辑文件test.trs。

Button.gif (91 bytes) 参考
 无。


OPTIMIZE 优化数据库

Pointer.gif (1201 bytes) OPTIMIZE 优化数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对数据库进行优化，提高查询速度并整理空间。

Button.gif (91 bytes) 前提
操作用户必须对指定数据库有INDEX权限。

Button.gif (91 bytes) 语法
OPTIMIZE {[owner.]database_name | [owner.]auto_view_name} [({column_name [,...]})]
[TEMP temp_path]

Button.gif (91 bytes) 参数
owner：
待优化的数据库的拥有者。
database_name/auto_view_name：
待优化的数据库自动模式视图名。
column_name：
待优化的字段名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。不指定字段列表时表示优化所有字段。
TEMP：
优化时使用的临时工作空间路径，必须是服务器配置中包含的数据路径。不指定时自动取系统缺省的数据路径。

Button.gif (91 bytes) 要点
1. 数据库优化时处于UPDATE锁定状态，其他TRS用户不能对此数据库进行维护操作，但可以进行查询。
2. 优化操作需要较多的磁盘空间，因此指定临时目录时，应该确认服务器上有足够的磁盘空间。
3. 由于优化操作需要较长的时间和占有较多的机器资源，建议在作业较少时进行数据库优化操作。
4. 系统能够自动检测数据库的数据文件和索引文件是否需要优化，并直接跳过那些不需要优化的数据和索引文件。

Button.gif (91 bytes) 举例
TRSL> OPTIMIZE newsbase(作者, 正文) TEMP /trshome/ibase
这条语句的作用是在/trshome/ibase目录下对数据库newsbase的“作者”和“正文”字段进行优化。


PRINT 打印检索结果

Pointer.gif (1201 bytes) PRINT 打印检索结果

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
打印当前检索结果。

Button.gif (91 bytes) 前提
当前存在检索结果记录集，并且操作用户对所打印的字段有SELECT权限。

Button.gif (91 bytes) 语法
PRINT [RECORD { ALL | {{n [,...]} [ TILL m ]} [,...]}
[COLUMN {ALL | {column_name [,...]}}]
[FORMAT [PLAIN | NORMAL | ISO2709 | XML] [DOCID] [PREFIX prefix]]

Button.gif (91 bytes) 参数
RECORD：
选择需要打印的记录号(或记录号集合)，用TILL关键字连接两个记录号可指定一定范围的记录。取值ALL表示打印所有的命中记录，为缺省值。
COLUMN：
选择打印的字段名(或字段名集合)，取值ALL表示打印所有的字段，为缺省值。
FORMAT：
指明以何种格式打印数据库记录。PLAIN表示记录文件格式；NORMAL表示TRS装库文件格式 ，为默认格式；如果要以ISO2709或XML格式文件进行发送，取值为ISO2709/XML。DOCID表示加上记录的物理记录号，以支持恢复数据镜像。PREFIX表示添加记录前缀。

Button.gif (91 bytes) 要点
1. 当不指定COLUMN、RECORD参数时，打印所有的命中结果。
2. column_name为需打印的字段名，当PRINT后不带字段选择参数时，将打印所有字段。
3. 当指定需要打印的记录时，所指定的记录号是命中的记录号，不是记录的内部顺序号，当需要按内部记录号进行查询时，可以使用以下TRSL语句：
TRSL> SELECT FROM 库名 WHERE DOCID=docid

 4. 当前必须配置了可用的打印机，且打印机处于准备状态。
5. 在打印检索结果时，记录中的多媒体数据（如图象）、格式化文件（如WPS文件）、复合文档（MS WORD文件）等将不被打印。

Button.gif (91 bytes) 举例
TRSL> SELECT FROM newsbase WHERE 中国 */sen 经济改革
TRSL> PRINT RECORD 1,2,3,4
上面第一条语句的作用是对newsbase数据库进行查询，第二条语句的作用是打印命中记录集合中的前四条记录。

TRSL> SELECT FROM newsbase, hlm WHERE 宝玉
TRSL> PRINT COLUMN tx RECORD 1
上面第一条语句的作用是在两个数据库newsbase和hlm上进行查询，第二条语句的作用是打印在命中的第一条记录的tx字段内容。


QUIT 退出并清除操作日志

Pointer.gif (1201 bytes) QUIT 退出并清除操作日志

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
退出命令语言处理工具，并清除操作日志。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
QUIT

Button.gif (91 bytes) 参数
无。

Button.gif (91 bytes) 要点
1. 用户使用QUIT从TRSL中退出后，操作日志将被删除，检索历史将被保留。
2. TRSL的EXIT语句也可以从TRSL窗口中退出，QUIT语句和EXIT语句的区别在于EXIT语句保留操作日志，而QUIT语句将删除操作日志。
3. 退出TRSL时会自动清除当前的检索结果，并断开与当前服务器的连接。

Button.gif (91 bytes) 举例
TRSL> QUIT


RECOVER 恢复数据库

Pointer.gif (1201 bytes) RECOVER 恢复数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
从指定文件或设备恢复数据库。

Button.gif (91 bytes) 前提
当前用户必须具备Resource权限。

Button.gif (91 bytes) 语法
RECOVER [ALL | {[owner.]database_name [, …]} | [owner.]auto_view_name]
FROM backup_file
[TO data_path]

Button.gif (91 bytes) 参数
ALL：
表示恢复指定备份包里的所有数据库，为缺省设置。当只恢复某个或某些数据库时，应列出具体的数据库名，一次可以恢复多个数据库。
owner：
数据库/自动模式视图的拥有者，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
database_name/auto_view_name：
待恢复的数据库/自动模式视图名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
FROM：
备份包所在的设备名，可以是服务器端的文件名或磁带名。不指定时表示从系统缺省备份设备恢复。
TO：
数据库恢复后的路径，必须是服务器配置中包含的数据路径，不指定时表示恢复到系统缺省的数据路径。

Button.gif (91 bytes) 要点
1. 如果被恢复的数据库在系统中不存在，系统将把这个库加到TRS数据库中；如果被恢复的数据库在系统中已存在，则自动更换库名（更换后的库名由原来的库名后加一编号构成）。如果要使用原来的数据库名，则需先删除或重命名原有的数据库，并把恢复后的数据库改为原来的名字。
2. 由于权限信息不进行备份，因此数据库恢复后也不存在授权信息（但数据库拥有者除外）。

Button.gif (91 bytes) 举例
TRSL> RECOVER newsbase FROM /dev/rst0 TO /trshome/ibase
这条语句的作用是把备份集/dev/rst0中的newsbase数据库恢复到/trshome/ibase目录下。

TRSL> RECOVER ALL FROM /trshome/temp/demo.bak
这条语句的作用是把/trshome/temp/demo.bak备份包里的所有数据库恢复到系统缺省的数据路径下。


REM 注释语句

Pointer.gif (1201 bytes) REM 注释语句

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
注释信息。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
REM remark

Button.gif (91 bytes) 参数
 remark:
为注释信息，内容可为除分号和单引号外的任何字符（包括空格），在一行中书写，长度无限制。字符串可用单引号括起来，也可以直接书写。

Button.gif (91 bytes) 要点
REM语句一般用于TRSL脚本文件中作为提示，执行脚本文件时仅显示，不作任何处理。

Button.gif (91 bytes) 举例
以下是一个简单的TRS脚本文件的内容：

REM Select operation will start right now:
SELECT FROM rmrb WHERE 中国;

这个脚本文件的作用是先显示一条开始检索的信息，然后执行检索操作。

Button.gif (91 bytes) 参考
无。


RENAME 为对象改名

Pointer.gif (1201 bytes) RENAME 为对象改名

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
为数据库、视图、词典、用户组、用户、数据格式和字段改名。

Button.gif (91 bytes) 前提
修改用户组、用户或数据格式名时，当前操作者必须是SYSTEM用户；为数据库/视图改名时，当前操作者必须对该对象有ALTER权限；修改字段名时，当前操作者必须对字段所在的数据库/视图有ALTER权限。

Button.gif (91 bytes) 语法
1.修改数据库及字段名
RENAME DATABASE [old_owner.]database_old_name
TO [new_owner.]database_new_name

RENAME DATABASE [owner.]database_name (column_old_name)
 TO column_new_name

2.修改数据格式名
RENAME FORMAT format_old_name
TO format_new_name

3.修改用户组名
RENAME GROUP group_old_name
TO group_new_name

4.修改用户名
RENAME USER user_old_name
TO user_new_name

5.修改视图或字段名
RENAME VIEW [old_owner.]view_old_name
TO [new_owner.]view_new_name

RENAME VIEW [owner.]view_name (column_old_name)
TO column_new_name

Button.gif (91 bytes) 参数
DATABASE：
指明为数据库或者数据库字段改名。由于词典是一种特殊的数据库，此参数也用于能修改词典名。old_owner指数据库原来的拥有者，new_owner指数据库修改后的拥有者；database_old_name指数据库的旧名字，database_new_name指数据库的新名字。database_name.column_old_name指旧的字段名，column_new_name指新的字段名。
VIEW：
指明为视图或者视图字段改名。old_owner指原来的视图的拥有者，new_owner 指修改后的视图的拥有者；view_old_name指视图的旧名字，view_new_name指视图的新名字。view_name.column_old_name指旧的字段名，column_new_name指新的字段名。
GROUP：
指明为用户组改名。group_old_name 指数据格式的旧名字，group_new_name指数据格式的新名字。
USER：
指明为用户改名。user_old_name 指数据格式的旧名字，user_new_name指数据格式的新名字
FORMAT：
指明为数据格式改名。format_old_name指数据格式的旧名字，format_new_name指数据格式的新名字。

Button.gif (91 bytes) 要点
对象被改名后，和它有关的对象也进行修改。如数据库名修改后，和数据库有关的视图等信息全部要修改，以保证数据词典信息的一致性。

Button.gif (91 bytes) 举例
TRSL> RENAME system.新闻资料数据库 TO pub.newsbase
这条语句的作用是把数据库新闻资料数据库改名为newsbase，并把此数据库的拥有者从system改为pub。

TRSL> RENAME abstract(摘要) TO science
这条语句的作用是把数据库abstract的字段'摘要'改名为'science'。

TRSL> RENAME USER administrator TO admin
这条语句的作用是把用户administrator改名为admin。


REVOKE 收回权限

Pointer.gif (1201 bytes) REVOKE 收回用户的权限

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
收回用户组/用户对数据库、视图、词典、字段上的操作权限。

Button.gif (91 bytes) 前提
当前操作用户必须是DBA用户，或是指定对象拥有者所在组的GDA用户，或是指定对象的拥有者。

Button.gif (91 bytes) 语法
REVOKE [ALL | {ALTER, DROP, INDEX, SELECT, UPDATE}]
FROM {{user_name | group_name} [,...]}
ON [owner.]object_name [({column_name [,...]})]

Button.gif (91 bytes) 参数
ALL /ALTER/DROP/INDEX/ SELECT/UPDAT：
回收的权限类型，对不同的对象有不同的取值范围。对数据库可为SELECT、UPDATE、INDEX、ALTER、DROP，对视图可为SELECT、ALTER、DROP，对词典可为SELECT、UPDATE、DROP，对字段只能为SELECT。指定为ALL表示所有权限，为缺省设置。 为了提高效率，若收回的权限对象不支持，将不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。
user_name/group_name：
待回收权限的用户/用户组。用户组和用户名均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。其中“*”表示所有用户组，“用户组.*”表示该用户组里的所有用户，“*.*”表示所有用户。
object_name：
回收权限的目标对象，可用user指定对象的拥有者。
column_name：
待回收权限的字段名，不指定时表示收回对象的权限。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。

Button.gif (91 bytes) 要点
1. 一次可以回收多个用户组/用户的权限，回收权限的目标数据库、视图、词典只能有一个，但可同时针对多个字段回收权限。
2. DBA用户、对象拥有者所在组的GDA用户、和指定对象的拥有者对对象的操作权限不能被收回。

Button.gif (91 bytes) 举例
TRSL> REVOKE SELECT, ALTER FROM tom ON newsbase
这条语句的作用是把数据库newsbase的SELECT和ALTER权限从用户tom收回。

TRSL> REVOKE FROM * ON personnel(resume)
这条语句的作用是把数据库personnel的字段resume上的所有权限从所有用户组收回。


RUN 运行脚本文件

Pointer.gif (1201 bytes) RUN 运行脚本文件

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
批处理运行TRS语句。

Button.gif (91 bytes) 前提
指定的脚本文件存在。

Button.gif (91 bytes) 语法
RUN [script_file]

Button.gif (91 bytes) 参数
script_file:
脚本文件名，不带路径时表示为当前目录。用户不指定脚本文件名时，命令语言处理工具会弹出对话框让用户选择文件。

Button.gif (91 bytes) 要点
1. TRS中用户可以以一个文件的形式编辑要执行的TRSL语句，文件中可以存放数量不限的TRSL语句（包括可执行语句如SELECT、INSERT等及非执行语句如REM、SPOOL等），每个TRSL语句必须以单字节分号(;)结束，最后一个TRSL语句可以没有分号结束符，这个文件在TRS中被称为脚本文件。脚本文件提供了以批方式操纵TRS数据库的灵活手段。
2. 脚本文件为客户端的DOS文件名，可以带路径。

Button.gif (91 bytes) 举例
下面是一个TRSL脚本文件demo.trs的例子，其内容为：

SELECT * FROM newsbase WHERE 中国 */sen 经济 */sen 改革;
SAVE RECORD 1 TILL 10 TO myresult1.dat;
SELECT * FROM hlm WHERE 黛玉 * 葬花;
SAVE TO myresult2.dat;

运行上述TRSL脚本文件的语句为：
TRSL> RUN demo.trs


SAVE 保存检索结果

Pointer.gif (1201 bytes) SAVE 保存检索结果

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把当前的检索结果保存到文件里。

Button.gif (91 bytes) 前提
当前存在检索结果记录集，并且操作用户对所保存的字段有SELECT权限。

Button.gif (91 bytes) 语法
SAVE [RECORD { ALL | {{n [,...]} [ TILL m ]} [,...]}]
[COLUMN {ALL | {column_name [,...]}}]
[FORMAT [PLAIN | NORMAL | ISO2709 | XML | BINARY] [DOCID] [PREFIX prefix]]
[AFFIX [source_path [, file_count]] [IN {NULL | DEFAULT | ALONE | CLASS | LINK | DUMB}]]
[DIVIDE max_count [, max_size]]
[BATCH batch_count]
[TO file_name]

Button.gif (91 bytes) 参数
RECORD：
选择需要保存的记录号(或记录号集合)，用TILL关键字连接两个记录号可指定一定范围的记录。取值ALL表示保存所有的命中记录，为缺省值。
COLUMN：
选择保存的字段名(或字段名集合)，取值ALL表示保存所有的字段，为缺省值。
FORMAT：
指明以何种格式保存数据库记录。PLAIN表示记录文件格式；NORMAL表示TRS装库文件格式 ，为默认格式；如果要以ISO2709或XML格式文件进行发送，取值为ISO2709/XML。DOCID表示加上记录的物理记录号，以支持恢复数据镜像。PREFIX表示添加记录前缀。
AFFIX：
附件目录和每组存放文件数。source_path指定记录所含附件存放的目录。file_count指定每组存放的文件数，0或者不设置表示不限制 ，最大值为FFFFFFFD。
IN：
保存附件的方式。DEFAULT表示按缺省方式保存源文件；ALONE表示以独立的文件形式存储；CLASS 表示按字段类型分类存储；LINK表示存储文件名所指定的URL；DUMB表示只存储文件信息，不存储数据。
DIVIDE：
每个文件允许存放的最大记录数和尺寸。max_count表示记录附件存放的目录中 ，每组容纳多少条记录的附件，最大值为32768；若为0或者不指定数值则表示不限制，即所有附件全部直接存入指定的文件中；若指定了数值比如为10，则生成若干个文件分别存放附件，每个文件中存储10条记录的附件。max_size指设置保存的目标文件的最大长度， 不设置或为零时取缺省值2G。若当前所要保存的记录大小超过此数值，将自动分为N个大小为此数值的目标文件进行保存，如Demo2_1.trs、Demo2_2.trs...。
BATCH：
指定每批读取的记录数。
TO：
结果文件名，为客户端的文件名，可以带路径，不指定文件名时将报错。

Button.gif (91 bytes) 要点
1. 当不指定COLUMN、RECORD参数时，保存所有的命中结果。
2. column_name为需保存的字段名，当SAVE后不带字段选择参数时，将保存所有字段。
3. 当指定需要保存的记录时，所指定的记录号是命中的记录号，不是记录的内部顺序号，当需要按内部记录号进行查询时，可以使用以下TRSL语句：
TRSL> SELECT FROM 库名 WHERE DOCID=docid

 4. 对于有BIT字段的记录在存储时，BIT字段将单独作为文件存放，在记录文件中的BIT字段处写入该字段存放的文件名。
5. 如果您发现无法存贮检索结果，这可能是没有足够的磁盘空间。

Button.gif (91 bytes) 举例
TRSL> SAVE TO tmp.dat
不带任何选项的这条语句表示存贮所有的检索结果到文件tmp.dat中。

TRSL> SAVE COLUMN name RECORD 1,3 TILL 5,9 TO tmp.dat
表示存贮检索结果到tmp.dat文件中，存贮字段为name，存贮的命中记录为1，3，4，5，9共5个记录。


SELECT 对数据库/视图进行检索

Pointer.gif (1201 bytes) SELECT 对数据库/视图进行检索

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对数据库/视图进行检索，为TRS用户最常用的操作。

Button.gif (91 bytes) 前提
当前操作者对被检索的数据库/视图有SELECT权限。

Button.gif (91 bytes) 语法
SELECT [* | COUNT(*) | {stat_expression [,...]}]
[FROM {[owner.]object_name [,...]}
[WHERE search_expression [LOWFREQ] [BANSTOP] [NONWORD]]
[ORDER BY [{RELEVANCE | {column_name [ASC | DESC]}} [,...]] [LIFO] [{PRUNE | VALID} record_number] [MIXED] [MISCOL] [NOCASE] [ALWAYS]]
[RELEVANT {NULL | NORMAL | GLOBAL | NORMPOS | GLOBPOS | WORDS | WFREQ}]
[HITPOINT {NULL | EXACT | IGNORE | INEXACT}]
[DEFCOL {column_name [,...]} [[AS] SINGLE] [[IN] {AND | OR | NOT | XOR}]]
[QUICKEND quickend_prune]
[RETRYCOL {NULL | DEFAULT | DUMMY | column_name}]
[KNOWASS {NULL | {ST, AT, PT, UF, AB, ABF, RT, BT, NT, ALLBT, ALLNT, LE, TXS, FXH}}]
[THESAURUS {thesaurus_dic | NULL}]
[SYNONYM {synonym_dic | NULL}]
[ANTONYM {antonym_dic | NULL}]

Button.gif (91 bytes) 参数
stat_expression：
统计结果表达式，多个表达式之间以逗号分隔，可省略。在TRS中，选择输出的字段在结果处理语句中定义，因此这里不能使用字段名。 当只有COUNT(*)这一个统计表达式时，COUNT(*)将被被忽略，当与其他统计表达一起出现时，COUNT(*)才有效 。
owner：
检索目标数据库/视图的拥有者。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
object_name：
检索目标数据库/视图名。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
search_expression：
检索条件表达式，它是由检索条件通过TRSL操作符和TRSL函数适当联结构成的。
ORDER BY：
记录的排列顺序。对每个column_name可用ASC或DESC分别指定按升序/降序方式排列。字段名也可为RELEVANCE，表示按相关性排序，但只能按升序排列。也可指定为LIFO，表示按后进先出顺序排列。对于参数record_number，若前面选择PRUNE时则代表排序并裁减保存的结果记录数，同时自动设置“非精确命中点”模式；选择VALID时则代表有效排序结果记录数，即部分排序，按排序表达式排序的结果只保证前一部分记录是有序的 。MIXED表示对检索结果进行混合统一排序。MISCOL则表示对排序表达式中不存在的字段，按字段无值时情况处理。NOCASE表示排序表达式中的字段值，其字符是大小写无关的。ALWAYS表示在命中记录数不超过系统配置的最高限值的情况下，“总是”允许排序检索结果 。
RELEVANT：
相关性的计算模式和IDF模式选项。
HITPOINT：
命中点的存储模式选项。NULL表示由系统配置决定；EXACT表示存储精确的命中点；IGNORE表示检索过程中忽略命中点；INEXACT表示 存储非精确的命中点。
DEFCOL：
检索条件表达式中缺省字段名及逻辑。column_name表示检索条件表达式中缺省字段的子检索表达式的目标字段名集，为‘*’表示在所有DOCUMENT字段和所有PHRASE字段上同时进行检索。AS表示缺省字段检索的字段逻辑优先于检索表达式中的逻辑。多个字段之间的关系可为AND、OR、NOT或XOR。
QUICKEND：
集群对后台检索结果的裁减选项。高16位为选项。低16位的意义是：0表示不作限制；1~9表示集群至少需要等待相应数量的后台返回结果；10~99表示集群至少需要等待相应比例的后台返回结果；100及以上表示至少需要返回的结果记录数。
RETRYCOL：
对于检索表达式中不存在的字段的处理方式。
KNOWASS：
进行知识扩展检索时的主题词典。后面为利用知识辅助词典自动进行知识扩展检索的选项，可为下表中的值之一，多个值之间以 逗号分隔。为NULL则表示取消所有自动扩展功能。

选项

说明

ST

自动进行“同义词”扩展检索

AT

自动进行“反义词”扩展检索

PT

自动进行“等同词”扩展检索

UF

自动进行“替代词”扩展检索

AB

自动进行“缩略词”扩展检索

ABF

自动进行“被缩略词”扩展检索

RT

自动进行“相关词”扩展检索

BT

自动进行“上位词”扩展检索

NT

自动进行“下位词”扩展检索

ALLBT

自动进行“所有上位词”扩展检索

ALLNT

自动进行“所有下位词”扩展检索

LE

自动进行“外文等同词”扩展检索

TXS

自动进行"繁体/简体中文"扩展检索

FXH

自动进行"全角/半角字符"扩展检索

THESAURUS：
进行知识扩展检索时的同义词典。
SYNONYM：
进行知识扩展检索时的反义词典。
ANTONYM：
进行知识扩展检索的选项。

Button.gif (91 bytes) 要点
1. SELECT语句只显示检索的命中记录数、命中点数和统计结果等信息，要浏览检索结果请用BROWSE或EDIT等检索结果处理函数。
2. 本次检索结果会一直保存到重新进行检索，或重新进行登录，或退出命令语言为止。

Button.gif (91 bytes) 举例
TRSL> SELECT FROM newsbase WHERE 中国 AND/SEG 美国
这条语句的作用是在数据库newsbase中查找有关“中国”和“美国”在同一段中的资料。

TRSL> SELECT FROM newsbase, rmrb WHERE 红学研究 ORDER BY 日期 MIXSORT
这条语句的作用是在数据库newsbase和数据库rmrb中查找有关“红学研究”的资料，检索结果按日期对两个数据库的命中记录进行统一排序。

TRSL> SELECT AVG(column1)/10 FROM Dbase WHERE column2 = '开发'
这条语句的作用是对数据库Dbase上所有column2的值等于“开发”的那些记录求字段column1上的平均值的十分之一。


SET 设置系统参数

Pointer.gif (1201 bytes) SET 设置系统参数

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
设置当前服务器的服务器配置，控制文件变量，命令语言的环境变量或用户自定义变量。

Button.gif (91 bytes) 前提
只有SYSTEM用户能修改系统配置，对环境变量和用户变量的修改没有限制。

Button.gif (91 bytes) 语法
1. 修改服务器配置
SET SYSTEM
[KNOWASS {<knowass_element> [,...]}]
[PATH {data_path [,...]}]
[TEMP temp_path]
[BACKUP backup_path]
[CHARSET {GB18030|BIG5|ENGLISH|UTF8}]
[OFFLINE [max_time] [, min_time]
[IDLE [start_time] [, end_time]]
[MEMORY memory_size]
[HISTORY history]
[DOWNLOAD download]
[TIMEOUT search_time]
[MAXSORT sort_record]
[STEM {ON|OFF}]
[CASE {ON|OFF}]
[NUMBER {ON|OFF}]

KNOWASS：
维护知识词典选项，参见knowass_element的说明。
PATH：
系统允许存放数据库的目录集。目录名之间可用单字节的分号‘;’、逗号‘,’、空格或制表符分隔。系统缺省值为系统安装路径下的ibase和dict，不允许为空。在修改数据库的目录集时，其格式如下：
· 如果某目录名有单字节的前缀‘+’（加号），则表示在目录集中增加这个目录。
· 如果某目录名有单字节的前缀‘-’（减号），则表示从目录集中删除这个目录。
· 如果某目录名是由单字节的中缀‘*’（星号）连接的两个目录，则表示用‘*’后面的目录替换‘*’前面的目录。

其中，前缀和中缀符号都必须紧跟目录名，不能间隔任何目录名之间的分隔符。系统对不带任何前缀或中缀符号的目录，不做任何处理（如果是目录集中的目录，则保持不变，否则忽略该目录）。
TEMP：
系统缺省的临时文件路径。缺省为TRS安装目录下的temp目录。
BACKUP：
系统缺省的备份设备，可以是磁带名或文件名。缺省为TRS安装目录下的temp目录。
CHARSET：
系统缺省的语言环境，可为GB18030、BIG5、ENGLISH、UTF8之一。
max_time：
允许一个用户实例最长的空闲时间，以分计，超时将自动Logout。缺省值为零，表示不限制。
min_time：
一个用户应该保持的最小有效时间（除非Logout），以秒计，在此期间内不允许自动Logout。缺省值为零，表示不限制。
start_time：
当系统空闲时，允许自动进行系统或数据库维护的起始时间，以小时计，在0到23之间。24表示禁止系统进行自动维护，缺省值为23。
end_time：
允许自动进行系统或数据库维护的截止时间，以小时计，在0到23之间。缺省值为24，表示不限制。
MEMORY：
服务器的物理内存总量，以兆字节计算。缺省值为64。
HISTORY：
系统缺省的最大检索历史步数，缺省值为20，取值范围为0到6553。创建用户时作为用户最大检索历史步数的缺省值。
DOWNLOAD：
系统缺省的一次最大下载记录数，缺省值为1000，取值范围为0到0xFFFFFFFD。创建用户时作为用户最大下载记录数的缺省值。
TIMEOUT：
一次检索操作的最长执行时间，以秒计算，零表示不限制，缺省值为10。
MAXSORT：
对检索结果进行排序的最大记录数，为零表示不限制，缺省值为10000。
STEM：
系统缺省的只建立词根索引标志，缺省为OFF。
CASE：
系统缺省的大小写敏感标志，缺省为ON。
NUMBER：
系统缺省的对数字进行索引标志，缺省为ON。

2. 设置控制文件变量
SET CONTROL filename
[ADD] VARIABLE {RECORD_FILE_FORMAT=<value>, SYNC_CREATE_INDEX=<value>,...}

filename：
控制文件名。
VARIABLE：
装库控制参数和值。ADD表示增加变量。

3. 设置运行环境参数
SET LOCALE
[TEMP temp_path]
[BUFFER buffer_size]
[BATCH batch_count]
[SEPARATOR {separator | NULL}]
[DRAWTEXT {ON|OFF}]
[AUTOWRAP {OFF | ALL | SEGMENT}]
[URLFILE {ON | OFF}]
[QUICKEND quickend_prene]
[SORTSAVE [sort_prune] [, sort_valid]]
[RELEVANT {NULL | NORMAL | GLOBAL | NORMPOS | GLOBPOS | WORDS | WFREQ}]
[HITPOINT {NULL | EXACT | IGNORE | INEXACT}]
[THESAURUS {thesaurus_dic | NULL}]
[SYNONYM {synonym_dic | NULL}]
[ANTONYM {antonym_dic | NULL}]
[KNOWASS {NULL | {ST, AT, PT, UF, AB, ABF, RT, BT, NT, ALLBT, ALLNT, LE, TXS, FXH}}]
[LIST BY {NULL | {NAME | OWNER | TYPE | CREATE | COUNT | COMMENT} [ASC | DESC]}]
[RIGHT {NULL | {ALTER, DROP, INDEX, SELECT, UPDATE}}]
[HIDESPLIT {ON | OFF}]
[LOGIN {{address:port, user_name, password} | NULL}]
[PROXY {{name, address:port, quiz} | NULL}]
[TIMEOUT connect_time]
[COMPRESS {ON | OFF}]
[ENCRYPT {ON | OFF}]
TEMP：
读取检索结果时临时文件所存放的目录，缺省为操作系统的临时文件目录。 为了提高效率，设置路径时不会检查有效性，只是在底层产生临时文件时才会报错。如果没有设置这个参数，会使用集成环境里的缓冲路径设置。
BUFFER：
检索结果缓冲区大小，以记录为单位，缺省为128。
BATCH：
读取检索结果时每次取记录数，缺省为16。
SEPARATOR：
多值字段的分隔符，为字符串类型，仅对DATE、NUMBER和CHAR类型字段有效，缺省为';'。
DRAWTEXT：
对格式化文档尽量提取文本。
AUTOWRAP：
浏览文本自动折行模式。OFF表示不自动折行；ALL表示所有文本不分行；SEGMENT表示段落文本不分行。
URLTOFILE：
为ON表示对URL(统一资源定位)输出其对应的文件(如HTML等)，而不是输出URL本身。缺省值为OFF。
QUICKEND：
集群对后台检索结果的裁减。
SORTSAVE：
排序裁减和有效排序结果记录数。
RELEVANT：
以相关性模式和IDF模式组合的相关性排序选项。NULL表示由系统配置决定；NORMAL表示忽略词的位置和使用基于单个数据库范围的IDF值；GLOBAL表示忽略词的位置和词IDF值不参与相关性计算；NORMPOS表示考虑词的位置和使用基于单个数据库范围的IDF值； GLOBPOS考虑词的位置和词IDF值不参与相关性计算；WORDS表示用一个记录中命中词的单位向量长度（每个命中词只计算一次）作为记录的相关；WFRE表示用一个记录中命中词的单位向量长度，以及命中词的词频和作为记录的相关度。
HITPOINT：
命中点的存储模式。
THESAURUS：
利用知识辅助词典自动进行知识扩展检索时的主题词典。不指定时使用系统配置的缺省主题词典。
SYNONYM：
利用知识辅助词典自动进行知识扩展检索时的同义词典。不指定时使用系统配置的缺省同义词典。
ANTONYM：
利用知识辅助词典自动进行知识扩展检索时的反义词典。不指定时使用系统配置的缺省反义词典。
KNOWASS：
利用知识辅助词典自动进行知识扩展检索的选项，可为下表中的值之一，多个值之间以 逗号分隔。为NULL则表示取消所有自动扩展功能。

说明

ST

自动进行“同义词”扩展检索

AT

自动进行“反义词”扩展检索

PT

自动进行“等同词”扩展检索

UF

自动进行“替代词”扩展检索

AB

自动进行“缩略词”扩展检索

ABF

自动进行“被缩略词”扩展检索

RT

自动进行“相关词”扩展检索

BT

自动进行“上位词”扩展检索

NT

自动进行“下位词”扩展检索

ALLBT

自动进行“所有上位词”扩展检索

ALLNT

自动进行“所有下位词”扩展检索

LE

自动进行“外文等同词”扩展检索

TXS

自动进行"繁体/简体中文"扩展检索

FXH

自动进行"全角/半角字符"扩展检索

LIST BY：
显示对象的排列顺序。排列的顺序包括对NAME(名称)、OWNER(拥有者)、TYPE(类型)、CREATE(创建日期)、COUNT(字段数)、COMMENT(说明信息)的升序ASC和降序DESC排列。
RIGHT：
显示对象列表时的权限条件。可为SELECT、UPDATE、INDEX、ALTER、DROP之一，使用NULL可把该标志设为零，表示显示所有对象。
HIDESPLIT：
为ON表示隐藏自动分裂数据库。
LOGIN：
缺省登录信息设置。address、port、user_name、password分别表示登录的服务器地址、端口，用户名及密码。
PROXY：
代理服务器设置。name、address、port、quiz分别表示代理服务器的服务器的类型、IP地址、端口号和安全验证码。
TIMEOUT：
建立网络连接过程的超时时间。
COMPRESS：
为ON表示在传输数据时进行压缩。
ENCRYPT：
为ON表示在传输数据时进行加密。
4. 设置用户自定义变量
SET [VARIABLE] {{NAME=<value>} [,...]}

VARIABLE：
用户自定义变量名和值，以 NAME=<value>的形式出现。
Button.gif (91 bytes) 参数
 见语法部分。

Button.gif (91 bytes) 要点
见语法部分。

Button.gif (91 bytes) 举例
TRSL> SET SYSTEM PATH '+C:\TRS4\user1' IDLE 20,23 NUMBER OFF
 这条语句的作用是向增加数据库目录集里添加一个新的目录'C:\TRS4\user1',并把自动维护起始时间设为20，自动维护终止时间设为23，数字索引时间设为OFF。

TRSL> SET LOCALE BUFFERPATH D:\Temp URLTOFILE ON
 这条语句的作用是把存放检索结果文件的目录设为D:\Temp，并把URL自动转换为文件。

TRSL> SET LOCALE THESAURUS mythes KNOWASS RT, BT, NT
 这条语句的作用是把自动扩展检索的主题词典名设为mythes，并自动进行RT、BT、NT扩展检索。

TRSL> SET VARIABLE basename=system.demo, cond='中国*美国'
 这条语句的作用是basename变量设为system.demo，把cond变量设为中国*美国'。


SHOW 显示信息

Pointer.gif (1201 bytes) SHOW 显示信息

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
显示系统配置、对象列表和其它信息。

Button.gif (91 bytes) 前提
合法的TRS用户，已经登录到TRS服务器中。

Button.gif (91 bytes) 语法
1. 显示当前的日期和时间
SHOW TIME

2. 显示当前服务器的系统配置
SHOW SYSTEM [DETAIL]

服务器的配置信息包括系统路径、知识词典和其它配置三大类。如果当前操作者是SYSTEM用户，可以用SET语句修改系统设置的值。DETAIL选项表示显示系统资源以及版本信息等 。

3. 显示运行环境参数
SHOW LOCALE [DETAIL]

TRSL环境变量是TRSL内部保存的一组运行状态的值，包括临时文件路径、自动扩展检索、读取结果设置、记录维护选项等。每次TRSL启动时自动复位，任何用户均可用SET语句修改这些环境变量的值。DETAIL选项表示显示运行环境资源以及版本信息等 。

4. 显示当前的用户自定义变量值
SHOW VARIABLE

TRSL的用户自定义变量是由用户自己设置的一些参数值，在执行TRSL时可以代替具体的对象名、表达式等用户输入的信息。变量的命名规则和对象名一致，但使用时要在前面加上'$'符号。每次退出TRSL时自动清除，任何用户均可用SET语句修改这些变量的值。

5. 显示数据库信息
SHOW DATABASE
[[owner.]database_name [({column_name [,...]})]] [DETAIL] [INDEX] [SIZE]
[TYPE {NORMAL, {{SEGMENT, SEGMENTEX, STOP, STOPEX, SPARSE, THESAURUS, SYNONYM, ANTONYM} | KNOWASS}}]
[LIST BY {NULL | {NAME | OWNER | TYPE | CREATE | COUNT | COMMENT} [ASC | DESC]}]
[RIGHT {NULL | {ALTER, DROP, INDEX, SELECT, UPDATE}}]

当DATABASE后面不带参数，显示符合指定条件的数据库的列表；如果指定了database_name，但后面没有其它参数，则显示符合条件的数据库列表；如果后面跟DETAIL参数，则显示由database_name指定的数据库的信息；如果后面跟SIZE参数，则显示该数据库占用的空间大小；如数据库名后跟INDEX参数，则显示该数据库包含的字段列表；如数据库名后跟字段列表，则显示这些指定数据库字段的属性。owner、database_name、column_name均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。可用TYPE子句限定显示的数据库类型， 分别可为NORMAL、SEGMENT、SEGMENTEX、STOP、STOPEX、SPARSE、THESAURUS、SYNONYM、ANTONYM、KNOWASS(表示所有词典)之一，多种词典类型之间以逗号分隔。LIST BY是指显示对象以NAME(名称)、OWNER(拥有者)、TYPE(类型)、CREATE(创建日期)、COUNT(字段数)、COMMENT(说明信息)的升序ASC或者降序DESC之一排列。RIGHT表示显示对象列表时的权限条件 。

6. 显示视图信息
SHOW VIEW [[owner.]view_name [({column_name [,...]})]] [DETAIL]
[LIST BY {NULL | {NAME | OWNER | CREATE | COMMENT} [ASC | DESC]}]
[RIGHT {NULL | {ALTER, DROP, SELECT}}]

当VIEW后面不带参数，显示符合指定条件的视图的列表；如果指定了view_name ，但后面没有其它参数，则显示符合条件的视图列表；如果后面跟DETAIL参数，则显示由view_name指定的视图的信息；如视图名后跟字段列表，则显示这些指定视图字段的属性。owner、view_name、column_name均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。LIST BY是指显示对象以NAME(名称)、OWNER(拥有者)、CREATE(创建日期)、COMMENT(说明信息)的升序ASC或者降序DESC之一排列。RIGHT表示显示对象列表时的权限条件 。

7. 显示用户组信息
SHOW GROUP [group_name [DETAIL]]
[LIST BY {NULL | {NAME | CREATE | COMMENT} [ASC | DESC]}]

如果GROUP后不带参数，显示所有用户组的列表；如果指定了group_name，但没有跟DETAIL参数，则显示符合指定条件的用户组的列表；否则显示指定用户组的详细属性信息。group_name里可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。LIST BY是指显示对象以NAME(名称)、CREATE(创建日期)、COMMENT(说明信息)的升序ASC或者降序DESC之一排列。

8. 显示用户信息
SHOW USER [[group.]user_name [DETAIL]]
[LIST BY {NULL | {NAME | GROUP | TYPE | CREATE | COMMENT} [ASC | DESC]}]

如果USER后不带参数，显示所有用户的列表；如果指定了group.user_name，但没有跟DETAIL参数，则显示符合指定条件的用户的列表；否则显示指定用户的详细属性信息。group和user_name里均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。LIST BY是指显示对象以NAME(名称)、GROUP(拥有者)、TYPE(类型)、CREATE(创建日期)、COMMENT(说明信息)的升序ASC或者降序DESC之一排列。

9. 显示数据格式信息
SHOW FORMAT [[class.]format_name [DETAIL]]
[LIST BY {NULL | {NAME | CLASS | SUFFIX | COMMENT} [ASC | DESC]}]

如果FORMAT后不带参数，显示所有数据格式的列表；如果指定了class.format_name，但没有跟DETAIL参数，则显示符合指定条件的数据格式的列表；否则显示指定数据格式的详细属性信息。class和format_name里均可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。LIST BY是指显示对象以NAME(名称)、CLASS(所属分类)、SUFFIX(后缀列表)、COMMENT(说明信息)的升序ASC或者降序DESC之一排列。

10. 显示访问权限信息
SHOW RIGHT [{group_name | user_name} [,...]]
ON [owner.]object_name [({column_name [,...]})]

group_name/user_name为用户组/用户名，如不指定则表示所有用户组和用户。owner为数据库/视图的拥有者，object_name为数据库/视图名。column_name为字段名，如不指定字段名表示要显示数据库级权限信息。其中，group_user和column_name可使用通配符，用'?'匹配单个字符，用'*'匹配任何字符。执行该语句将显示指定用户组/用户在数据库/视图/字段上的访问权限信息。

11. 显示索引词信息
SHOW WORDS {[owner.]database_name | [owner.]auto_view_name} [(column_name)]
[WHERE condition]
[LIST BY {NULL | {NAME | RECORD | WFREQ } [ASC | DESC]}]
[PRUNE prune_count]

database_name/auto_view_name表示查询的数据库/自动模式视图名。column_name指定查询的字段，如没有给出column_name则在缺省字段上进行查询。。condition为检索的目标条件，为字符串类型，可以使用通配符，以'?'匹配单个字符，用'%'匹配任何字符，缺省时表示所有词语。user.database_name指定查询的数据库，column_name指定查询的字段，如没有给出column_name则在缺省字段上进行查询。LIST BY是指显示对象以NAME(名称)、RECORD(字段值/词的命中记录数)、WFREQ(字段值/词的词频数)的升序ASC或者降序DESC之一排列。PRUNE 表示显示结果词语的个数。

12. 显示控制文件设置
SHOW CONTROL filename

filename为控制文件名。

Button.gif (91 bytes) 参数
见语法部分。

Button.gif (91 bytes) 要点
见语法部分。

Button.gif (91 bytes) 举例
TRSL> SHOW TIME
这条语句的作用是显示当前的日期和时间。

TRSL> SHOW LOCALE
这条语句的作用是显示当前所有的TRS环境变量的值。

TRSL> SHOW DATABASE system.*
这条语句显示TRS中的SYSTEM用户的所有数据库。

TRSL> SHOW DATABASE newsbase STRUCTURE
这条语句的作用是显示数据库newsbase的结构。

TRSL> SHOW VIEW demo_view (正文, 图象)
这条语句的作用是显示视图demo_view的“正文”和“图象”字段的属性。

TRSL> SHOW GROUP PRODUCT
这条语句的作用是显示PRODUCT用户组的属性。

TRSL> SHOW USER PRODUCT.*
这条语句的作用是显示PRODUCT组里所有用户的列表。

TRSL> SHOW RIGHT PRODUCT.* ON newsbase(正文)
这条语句的作用是显示PRODUCT组里所有用户对newsbase数据库的“正文”字段的访问权限。

TRSL> SHOW WORDS '中国%' ON newsbase
这条语句的作用是在数据库newsbase的缺省字段上显示所有以“中国”开始的检索词的命中数和词频数。


SORT 对检索结果重新排序

Pointer.gif (1201 bytes) SORT 对检索结果重新排序

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
对当前的检索结果重新进行排序。

Button.gif (91 bytes) 前提
当前存在检索结果记录集。

Button.gif (91 bytes) 语法
SORT BY { RELEVANCE | {column_name [ASC | DESC]} [,...] | LIFO} [{PRUNE | VALID} record_number]
[MIXED] [MISCOL] [NOCASE]

Button.gif (91 bytes) 参数
column_name：
指定检索结果排序的字段名，必须在源数据库/视图里存在。对每个排序字段可用ASC或DESC分别指定按升序/降序方式排列。字段名也可为RELEVANCE，表示按相关性排序，但只能按升序排列。也可指定为LIFO，表示按后进先出规则排序。 对于参数record_number，若前面选择PRUNE时则代表排序并裁减保存的结果记录数，同时自动设置“非精确命中点”模式；选择VALID时则代表有效排序结果记录数，即部分排序，按排序表达式排序的结果只保证前一部分记录是有序的 。
MIXED：
表示对检索结果进行混合统一排序。
MISCOL：
表示对排序表达式中不存在的字段，按字段无值时情况处理。
NOCASE：
表示排序表达式中的字段值，其字符是大小写无关的。

Button.gif (91 bytes) 要点
1. 只有在成功地进行了SELECT操作以后，才能对检索结果进行重新排序。
2. 本次排序的结果在重新进行检索或排序、或检索结果被清除前一直有效。

Button.gif (91 bytes) 举例
TRSL> SELECT FROM demo1, demo2 WHERE 中国
TRSL> SORT BY 日期 DESC, 版次 MIXED
 上一条语句在demo1和demo2数据库里查询含有“中国”的记录，下一条语句对检索结果先按日期的降序、再按版次的升序重新排列，对两个数据库进行统一排序。


SPOOL 输出到文件

Pointer.gif (1201 bytes) SPOOL 输出到文件

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
把TRSL的执行过程和结果输出到文件中。

Button.gif (91 bytes) 前提
无。

Button.gif (91 bytes) 语法
SPOOL { file_name | OFF }

Button.gif (91 bytes) 参数
file_name：
输出文件名，为客户端的DOS文件名，可以带路径。
OFF：
取消输出设置，关闭上次SPOOL语句中设置的输出文件。

Button.gif (91 bytes) 要点
使用该命令可以将执行的过程和结果以文件方式保留起来，可供以后查阅。缺省值是OFF。

Button.gif (91 bytes) 举例
TRSL> SPOOL result.doc
TRSL> SELECT * FROM rmrb
TRSL> SPOOL OFF

 上面三条语句的功能是把在rmrb数据库上进行检索的结果信息保存到result.doc文件里。


UNLOCK 解锁数据库

Pointer.gif (1201 bytes) UNLOCK 解锁数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
解除数据库的锁定。

Button.gif (91 bytes) 前提
 当前操作用户必须是DBA用户，或是数据库拥有者所在组的GDA用户，或是数据库的拥有者。

Button.gif (91 bytes) 语法
UNLOCK {[owner.]database_name [,...]}

Button.gif (91 bytes) 参数
owner：
数据库的拥有者，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
database_name：
指明要解锁的数据库名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。

Button.gif (91 bytes) 要点
无。

Button.gif (91 bytes) 举例
TRSL> UNLOCK demo2
 这条语句的作用是解除demo2的锁定。


UPDATE 更新数据库记录

Pointer.gif (1201 bytes) UPDATE 更新数据库记录

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改数据库记录。

Button.gif (91 bytes) 前提
操作用户对数据库有UPDATE权限。

Button.gif (91 bytes) 语法
UPDATE {[owner.]database_name | [owner.]auto_view_name}
[SET {{column_name=<value>} [,...]}]
[WHERE condition]
[SEPARATOR separator]
[PASSWORD {password | NULL}]
[GROUP {group_name | NULL}]
[SECURITY security_code]
[CONTROL control_file]

Button.gif (91 bytes) 参数
owner：
目标数据库/自动模式视图的拥有者。
database_name/auto_view_name：
目标数据库/自动模式视图名。
SET：
设置新的字段名和新值。column_name为待修改的字段名，可同时修改多个字段；value表示修改后的字段值，与column_name一一对应。 如果不指定字段名，则表示对词典进行操作。
WHERE：
待更新记录的条件，只有满足条件的记录才会被更新。也可用DOCID=id表示物理记录号为id的记 录。除此之外，本子句还可以指定删除词语。
SEPARATOR：
多值字段的分隔符。为字符串类型，仅对DATE、NUMBER和CHAR类型字段有效，缺省为';'。
PASSWORD：
记录的访问密码，取该记录内容时必须提供正确的密码。
GROUP：
记录对外开放的用户。
SECURITY：
赋予记录的安全级别，访问这些记录时操作者的安全级别必须不大于此安全级别。取值范围为0到0xFFFFFFFD， 缺省为零，表示访问此记录无须经过安全级别检查。
CONTROL：
加载的控制文件名。

Button.gif (91 bytes) 要点
1. 本语句可一次可以更新多条记录。
2. 如果不指定修改条件时，默认为修改数据库中的所有记录。
3. 本语句不能更新词典中的数据。

Button.gif (91 bytes) 举例
TRSL> UPDATE personnel SET name= '张三'，resume='@zhang.res' WHERE name='ZHANG SAN'
这条语句的作用是把数据库personnel中满足条件name='ZHANG SAN'的记录修改为name= '张三'，resume= '@zhang.res'。

TRSL> UPDATE personnel SET salary= 3000 WHERE position='enginneer'
这条语句的作用是将那些职务(字段position)为工程师(engineer)的员工的工资 修改为3000。


VALIDATE 验证索引

Pointer.gif (1201 bytes) VALIDATE 验证索引

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
验证数据库文件的索引文件的正确性。

Button.gif (91 bytes) 前提
操作用户必须对指定数据库有INDEX权限。

Button.gif (91 bytes) 语法
VALIDATE INDEX {[owner.]database_name | [owner.]auto_view_name} [({column_name [,...]})]

Button.gif (91 bytes) 参数
owner：
待验证索引的数据库的拥有者。
database_name/auto_view_name：
待验证索引的数据库/自动模式视图名。
column_name：
待验证的字段名，可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。不指定字段列表时表示验证所有字段。

Button.gif (91 bytes) 要点
1. 索引的出错信息登记在文件TRSValididx.log中。
2. 如果验证的结果表明索引不正确，用户可用DROP INDEX和CREATE INDEX语句删除索引和重新创建索引。

Button.gif (91 bytes) 举例
TRSL> VALIDATE INDEX zlbase(c1, c2)
这条语句的作用是验证数据库zlbase中c1、c2字段上索引文件的正确性。


ALTER DATABASE 修改数据库的属性和结构

Pointer.gif (1201 bytes) ALTER DATABASE 修改数据库的属性和结构

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改数据库的属性和结构。

Button.gif (91 bytes) 前提
操作用户必须对数据库有ALTER权限。

Button.gif (91 bytes) 语法
ALTER DATABASE database_name
[ADD {({<basecol_element> [,...]}) | AS {{[owner.]source_database_name [({column_name [,...]})]} [,...]}}]
[MODIFY ({<mod_basecol_element> [,...]})]
[DROP {column_name [,...]}]
[COMMENT {comment | NULL}]
[CHARSET {DEFAULT | GB18030 | BIG5 | ENGLISH | UTF8}]
[ALIAS {alias [,...] | NULL}]
[DEFCOL column_name]
[PATH data_path]
[HOST {data_host | NULL}]
[SEGMENT {[owner.]segment_dic | DEFAULT | NULL}]
[SEGMENTEX {[owner.]segmentex_dic | DEFAULT | NULL}]
[STOP {[owner.]stop_dic | DEFAULT | NULL}]
[STOPEX {[owner.]stopex_dic | DEFAULT | NULL}]
[SPARSE {[owner.]sparse_dic | DEFAULT | NULL}]
[STEM {ON|OFF}]
[CASE {ON|OFF}]
[NUMBER {ON|OFF}]
[BIGRAM {ON|OFF}]
[COMPRESS {ON | OFF}]
[BANSTOP {ON | OFF}]
[PUBLIC {{ALTER, DROP, INDEX, SELECT, UPDATE} | NULL}]

Button.gif (91 bytes) 参数
database_name：
待修改的数据库名。
ADD：
增加数据库字段，basecol_element的定义请参见数据库字段的说明。
MODIFY：
修改数据库字段的属性。mod_basecol_element的定义请参见数据库字段的说明。
DROP：
删除的数据库字段。
COMMENT：
数据库的注释，为字符串类型。
CHARSET：
数据库所用的语言，可为 GB18030、BIG5、ENGLISH、UTF8 之一。
缺省 DEFAULT 为系统配置中的缺省语言环境。
ALIAS：
数据库的别名，一个数据库可有多个别名。
DEFCOL：
进行全文检索的缺省全文字段名。缺省为最后一个DOCUMENT或者PHRASE字段，DOCUMENT字段优先。
PATH：
数据库存放的路径，必须是系统配置中的数据和索引路径之一。
HOST：
数据库存放的位置。如果不为空，表明实际数据集中存储在一个数据宿主服务器中，并指向存储服务器的有关信息的字符串，如'ORACLE'。
SEGMENT：
数据库所用的主分词词典名。
SEGMENTEX：
数据库所用的附加分词词典名。
STOP：
数据库所用的主停用词典名。
STOPEX：
数据库所用的附加主停用词典名。
SPARSE：
数据库所用的稀疏词典名。
STEM：
为ON表示只建立词根索引。
CASE：
为ON表示建立索引时区分英文词的大小写。
NUMBER：
为OFF表示建立索引时忽略数字串。
BIGRAM：
为ON表示建立二元组索引。
COMPRESS：
为ON表示压缩索引。
BANSTOP：
为ON表示创建索引时禁止启用停用词典。
PUBLIC：
数据库的公共访问标志，对于用户自定义数据库可为SELECT、UPDATE、INDEX、ALTER、DROP之一，对于词典可为SELECT、UPDATE、DROP之一。使用NULL可把公共访问标志设为空。为了提高效率，若设置的权限对象不支持时不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。

Button.gif (91 bytes) 要点
1. 除数据库名外，其它参数都可以不指定，不指定时保持数据库原来的属性值。
2. 本语句不能修改字段名，要修改字段名请用RENAME语句。
3. 当数据库中已有数据时，数据库的CHARSET、DEFCOL、PATH和HOST属性不能修改。当数据库中已有数据且已有字段建立了索引时，数据库的所有索引标志和使用词典属性均不能被修改。修改字段属性时，若某字段已经有了数据，则此字段的TYPE、INDEX、MULTI、UNIQUE、NULL、PATH、ATTR等属性不能修改，字段长度只能增加，不能减小。由以上要点可以看出，当数据库中已经存在数据时，修改数据库结构的操作有很多限制，定义数据库时，应预先作比较周到的考虑，尽量不要在数据已经入库后再修改数据库的属性。

Button.gif (91 bytes) 举例
TRSL> ALTER DATABASE trs_group
ADD (address CHAR(20) INDEX)
MODIFY (photo MULTI)
DROP department, office
PUBLIC SELECT

这条语句的作用是为数据库trs_group增加一个新的字段address，类型为CHAR型，定长20个字符，且此字段为索引字段，同时把photo字段改为MUTLI字段，删除department和office字段，并把该数据库设为公共检索数据库。


ALTER FORMAT 修改数据格式的属性

Pointer.gif (1201 bytes) ALTER FORMAT 修改数据格式的属性

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改数据格式的属性。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户。

Button.gif (91 bytes) 语法
ALTER FORMAT format_name
[CLASS {class | NULL}]
[SUFFIX {{suffix [,...]} | NULL}]
[COMMENT {comment | NULL}]
[COMPRESS {ON|OFF}]

Button.gif (91 bytes) 参数
format_name：
待修改的数据格式名。
CLASS：
数据格式的分类名。
SUFFIX：
数据格式所对应的文件的后缀名列表，为字符串类型，内容需加上单引号，一种文件格式可有多个文件后缀名，多个文件后缀名之间以分号或者逗号分隔，如'HTM;HTML'。
COMMENT：
数据格式的注释。
COMPRESS：
为ON表示进行无损压缩，为OFF表示不进行压缩。

Button.gif (91 bytes) 要点
除数据格式名以外，其它参数都可以不指定，不指定时保持数据格式原来的属性值。

Button.gif (91 bytes) 举例
TRSL> ALTER FORMAT html SUFFIX 'htm,html,htx ' COMPRESS ON
 这条语句的作用是把数据格式html的后缀名列表改为htm、html、htx，对这种文件进行压缩处理。


ALTER GROUP 修改用户组的属性

Pointer.gif (1201 bytes) ALTER GROUP 修改用户组的属性

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改用户组的属性。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户。

Button.gif (91 bytes) 语法
ALTER GROUP group_name
[COMMENT {comment | NULL}]

Button.gif (91 bytes) 参数
group_name：
待修改创建的用户组名。
COMMENT：
用户组的注释，为字符串类型，缺省值为空。

Button.gif (91 bytes) 要点
除用户组名外，其它参数都可以不指定，不指定时保持用户组原来的属性值。

Button.gif (91 bytes) 举例
TRSL> ALTER GROUP product COMMENT 'Product department'
 这条语句的作用是把Product用户组的说明信息改为Product department。


ALTER USER 修改用户的属性

Pointer.gif (1201 bytes) ALTER USER 修改用户的属性

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改用户的属性。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户或被修改的用户本身。

Button.gif (91 bytes) 语法
ALTER USER user_name
[TYPE {DBA| GDA| RESOURCE| CONNECT}]
[PASSWORD { password| NULL}]
[GROUP {group_name|NULL}]
[COMMENT {comment | NULL}]
[HISTORY history]
[DOWNLOAD download]
[SECURITY security]
[SEGMENTEX [owner.]segmentex_dic| NULL}]
[STOPEX {[owner.]stopex_dic| NULL}]
[SPARSE {[owner.]sparse_dic| NULL}]
[EXCLUSIVE {ON|OFF}]

Button.gif (91 bytes) 参数
user_name：
待修改的用户名。
TYPE：
用户的类型，可为DBA、GDA、RESOURCE或CONNECT之一。
PASSWORD：
用户的新密码，为NULL表示没有密码。
GROUP：
用户所在的组名，为NULL表示它不属于任何特定的组。
COMMENT：
用户的注释，为字符串类型。
HISTORY：
用户的最大检索历史步数，不设置或者为零时取缺省值，即系统配置中设定的最大检索历史步数 。取值范围为0到6553。
DOWNLOAD：
用户的最大下载记录数。不设置或者为零时取缺省值，即系统配置中设定的最大下载记录数。 取值范围为0到0xFFFFFFFD。
SECURITY：
用户的安全控制级别，用户只能访问安全级别不小于自己的安全控制级别的记录。取值范围为0到0xFFFFFFFD，缺省值为零，表示该用户不能查看任何用密级加密的记录。
SEGMENTEX：
用户缺省的附加分词词典名。创建该用户的数据库时，如不指定附加分词词典，则自动取此词典作为数据库的附加分词词典。
STOPEX：
用户缺省的附加停用词典名。创建该用户的数据库时，如不指定附加停用词典，则自动取此词典作为数据库的附加停用分词词典。
SPARSE：
用户缺省的稀疏词典名。创建该用户的数据库时，如不指定稀疏词典，则自动取此词典作为数据库的稀疏词典。
EXCLUSIVE：
为ON表示不允许多个IP地址上的Client用户同时用该用户名登录。

Button.gif (91 bytes) 要点
1. 除用户名外，其它参数都可以不指定，不指定时保持用户原来的属性值。
2. 任何用户可修改“自己”的某些属性，这些属性包括：PASSWORD、HISTORY、SEGMENTEX、STOPEX、SPARSE、COMMENT。其它项只能由SYSTEM用户管理。
 3. 用户的口令只能由用户自己修改，但SYSTEM用户能删除任何用户的口令。

Button.gif (91 bytes) 举例
TRSL> ALTER USER bill TYPE CONNECT GROUP product
 这条语句的作用是把bill用户改为CONNECT类型，并把该用户的所在组改为product。 这些属性必须由SYSTEM用户来修改。

Button.gif (91 bytes) 参考
CREATE USER 修改用户
RENAME 为对象改名
DROP 删除对象。


ALTER VIEW 修改视图的属性和结构

Pointer.gif (1201 bytes) ALTER VIEW 修改视图的属性和结构

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改视图的视图和结构。

Button.gif (91 bytes) 前提
操作用户对视图有ALTER权限，并对所有的源数据库有SELECT权限。

Button.gif (91 bytes) 语法
 ALTER VIEW view_name
[ADD ({({<viewcol_element> [,...]}) | [column_name [,...] | ALL] FROM {[owner.]database_name [,...]}]
[MODIFY {({<viewcol_element> [,...]}) | [{column_name [,...]} | ALL] {INSERT | DELETE} {[owner.]database_name [,...]}}]
[DROP {column_name [,...]}]
[WHERE {condition | NULL}]
[COMMENT {comment | NULL}]
[ALIAS {alias [,...] | NULL}]
[DEFCOL default_column]
[PUBLIC {{ALTER, DROP, SELECT} | NULL}]

Button.gif (91 bytes) 参数
view_name：
待修改的视图名。
ADD：
增加视图字段，viewcol_element的定义请参见视图字段的说明。
MODIFY：
修改视图字段的属性。viewcol_element的定义请参见视图字段的说明。
DROP：
删除的视图字段。
WHERE：
视图的创建条件。
COMMENT：
视图的注释，为字符串类型。
ALIAS：
视图的别名，一个视图可有多个别名。
DEFCOL：
进行全文检索的缺省全文字段名。缺省为最后一个DOCUMENT或者PHRASE字段，DOCUMENT字段优先。
PUBLIC：
视图的公共访问标志，可为SELECT、ALTER、DROP之一，若为自动模式视图还包含UPDATE和INDEX权限。使用NULL可把公共访问标志设为空。为了提高效率，若设置的权限对象不支持时不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。

Button.gif (91 bytes) 要点
1. 除视图名外，其它参数都可以不指定，不指定时保持视图原来的属性值。
2. 本语句不能修改字段名，要修改字段名请用RENAME语句。
3. 视图涉及的数据库的结构可以不同。

Button.gif (91 bytes) 举例
 TRSL> ALTER VIEW vnews
ADD (标题(demo1.标题, demo2.题目), 作者(demo1.作者, demo2.author))
DROP (版次, 栏目)
WHERE 中国*美国

这条语句的作用是向视图vnews里增加标题和作者两个字段，同时删除版次和栏目两个字段，并把创建条件改为‘中国*美国’。


数据库字段属性

Pointer.gif (1201 bytes) 数据库字段属性

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
在创建数据库或修改数据库结构时，对字段的属性进行描述。

Button.gif (91 bytes) 前提
数据库字段属性不是能单独执行的TRSL语句，它必须在创建数据库或修改数据库结构语句中使用。

Button.gif (91 bytes) 语法
column_name
[{ DATE|NUMBER[(length)]│CHAR[(length)]|PHRASE|DOCUMENT|BIT }]
[COMMENT {comment | NULL}]
[ALIAS {{alias [,...]} | NULL}]
[FORMAT {format | @filename} | NULL}]
[VALUES [NULL | MUST] [MULTI | SINGLE] [UNIQUE | ITERATIVE]]
[RANGE {value [,...] | @filename | NULL}]
[DEFAULT {NULL | default_vaue | @filename }]
[PATH {index_path | NULL}]
[INDEX {OFF | [ON | index_attr | @filename] [NORMAL | REDUCHAR | REDUFULL | REDUHALF | REDUZERO] [ALLIDEO | NOTIDEO]}]
[LANGUAGE {stem_language | NULL}]
[DISPLAY {title | NULL}]
[WIDTH width]
[HEIGHT height]
[CACHE {ON | OFF}]
[RELEVANCE {ON | OFF}]
[DUMMY {ON | OFF | DEFCOL}]
[PUBLIC {SELECT | NULL}]

Button.gif (91 bytes) 参数
column_name：
数据库字段名。
DATE：
日期型字段，用来存储“年月日时分秒”这类表示日期的数据。
NUMBER：
数值型字段，用来存储整数或实数。对于实数，可以用length限制其小数位的长度，在数据库加载时将忽略多余的小数位数。整数或实数不能超出机器的单精度浮点数所能表示的范围，可以使用科学计数法表示这些数据。
CHAR：
字符串型字段，可以用来存储任何形式的字符串。字符串的最大长度可以用length指定，但不能超过255个字符，在数据库加载时将截断超过规定长度的字符串，而只保留字符串的前部。
PHRASE：
短语型字段，可以用来存储任何形式、任意长度的文本数据，最适合作为“标题”这样的字段。短语型字段与字符串型字段的最大差别在于短语型字段支持自动分词，而字符串型字段不支持自动分词，其字段值整体是一个索引键值。
DOCUMENT：
全文型字段，既可以用来存储任何形式、任意长度的文本数据，也可以用来存储其它格式类型的多媒体数据。
BIT：
二进制型字段，可以用来存储任何格式类型的多媒体数据。
COMMENT：
数据库字段的注释，为字符串类型，缺省值为空。
ALIAS：
数据库字段的别名列表，一个数据库字段可以有多个别名。缺省值为空。
FORMAT：
数据库字段的输入输出格式，为字符串类型。
对于CHAR型字段，其格式规定为：
· A 表示在相应位置上必须出现一个英文字母；
· 9 表示在相应位置上必须出现一个数字；
· 空格 表示在相应位置上必须出现一个空格；
· X 表示在相应位置上可出现任意字符。
对于DATE和NUMBER型字段，则为字段值的输出限定格式，并且格式由用户确定，如““Y.MM.DD HH:MM:SS”、“L.DP”等。
如果限定格式第一个字符为‘@’，则表示其中存储的是限定格式所在文件的文件名。缺省值为空，表示字段的值没有格式限制。
VALUES：
字段的索引标志。MUST表示必须有值，缺省为NULL；MULTI为缺省值，表示允许多值（PHRASE和DOCUMENT字段除外）；SINGLE表示不允许多值；UNIQUE表示取值不允许重复，仅对DATE、NUMBER和CHAR型字段有效，缺省 为ITERATIVE。
RANGE：
DATE、NUMBER或CHAR型字段的取值范围。取值范围的定义格式包括：
· 枚举定义：格式为V1,V2,V3,Vn，即枚举该字段上所有可能取值；
· 区间定义：格式为V1,...,V2，表示该字段上所有可能取值必须在最小值V1和最大值V2之间；
· 混合定义：格式为V1,V2,...,V3,Vn，是以上两种方式的混合。
以上各格式中的逗号和点号都必须是半角符号。CHAR型字段的取值范围所给出的每个值串首尾不允许空格。DATE型字段的取值范围所给出的每个日期中只支持绝对（完全）年份，而不支持缺省世纪数的短格式年份，即总是认为缺省世纪数为0。只有DATE型字段的取值范围支持模糊格式，即允许日期格式中缺省一些成份，但对于区间定义定义的范围，其中的V1和V2“前模糊”的成份必须是相同的，即在“年月日时分秒”的顺序下，V1和V2的第一个确定的日期成份的位置必须是相同的。如果第一个字符为‘@’，则表示其中存储的是取值范围所在文件的文件名。缺省值为空，表示字段的值没有范围限制。
DEFAULT：
DATE、NUMBER或CHAR型字段的缺省值。如果第一个字符为‘@’，则表示其中存储的是缺省值所在文件的文件名。缺省值为空，表示没有缺省值。
PATH：
数据库字段索引的存放路径，必须是系统配置中的数据和索引路径之一。缺省值为空，表示字段索引路径和数据库存放路径一致。
INDEX：
字段的索引属性。 index_attr为DOCUMENT型字段的倒排索引属性名，为字符串类型。多个属性名之间用‘;’分隔，如“SEG;SEN;POS”等。对DOCUMENT字段缺省值为“POS”，对其它类型的字段缺省值为空。对DOCUMENT和PHRASE字段进行字词混合索引时，混合索引的模式有NORMAL（不进行字词混合索引）、REDUCHAR（禁止按词索引）、REDUFULL（全冗余模式） 、 REDUHALF（半冗余模式） 、REDUZERO（零冗余模式）五种；ALLIDEO表示允许进行单字检索，缺省值为NOTIDEO。
LANGUAGE：
文本型字段索引进行词根处理时的语种。
DISPLAY：
数据库字段的显示标题，为字符串类型，只供界面使用。缺省值为字段名。
WIDTH：
数据库字段的显示宽度，只供界面使用，缺省值为零。
HEIGHT：
数据库字段的显示高度，只供界面使用，缺省值为零。
CACHE：
允许进行检索缓冲标志。
RELEVANCE：
是否参与相关性排序标志。
DUMMY：
是否为虚拟逻辑字段/缺省虚拟逻辑字段标志。
PUBLIC：
数据库字段的公共访问标志，只能为 SELECT 标志。

Button.gif (91 bytes) 要点
1. 一般情况下，除字段名和字段类型以外，其它属性都可以不指定。在创建新数据库或插入字段时，没有指定的属性会自动取缺省值；修改字段属性时，没有指定的属性值（包括字段类型）自动保持原来的值。
2. 修改数据库字段属性时，若某字段已经有了数据，则此字段的类型、INDEX、MULTI、UNIQUE、NULL、PATH、ATTR等属性不能修改，字段长度只能增加，不能减小。

Button.gif (91 bytes) 举例
无。


CREATE DATABASE 创建数据库

Pointer.gif (1201 bytes) CREATE DATABASE 创建数据库

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的数据库。

Button.gif (91 bytes) 前提
操作用户有Resource权限。

Button.gif (91 bytes) 语法
CREATE DATABASE database_name
{({<basecol_element> [,...]}) | AS {{[owner.]source_database_name [({column_name [,...]})]} [,...]}}
[TYPE {NORMAL|SEGMENT|SEGMENTEX|STOP|STOPEX|SPARSE|THESAURUS|SYNONYM|ANTONYM}]
[COMMENT {comment | NULL}]
[CHARSET {DEFAULT | GB18030 | BIG5 | ENGLISH | UTF8}]
[ALIAS {{{alias [,...]} | NULL}]
[DEFCOL default_column]
[PATH data_path]
[HOST {data_host | NULL}]
[SEGMENT {[owner.]segment_dic | DEFAULT | NULL}]
[SEGMENTEX {[owner.]segmentex_dic | DEFAULT | NULL}]
[STOP {[owner.]stop_dic | DEFAULT | NULL}]
[STOPEX {[owner.]stopex_dic | DEFAULT | NULL}]
[SPARSE {[owner.]sparse_dic | DEFAULT | NULL}]
[STEM {ON|OFF}]
[CASE {ON|OFF}]
[NUMBER {ON|OFF}]
[BIGRAM {ON|OFF}]
[COMPRESS {ON|OFF}]
[BANSTOP {ON | OFF}]
[PUBLIC {{ALTER, DROP, INDEX, SELECT, UPDATE} | NULL}]

Button.gif (91 bytes) 参数
database_name：
待创建的新数据库名。
basecol_element：
数据库字段及其属性，参见数据库字段描述。
AS：
从一个已存在的数据库中选择部分字段产生一个新的数据库。字段可属于一个数据库，也可分别属于不同的数据库。但如果指定了source_database_name，则所有的column_name都默认为source_database_name的字段，此时不能为字段指定数据库。
TYPE：
数据库或词典的类型，可为NORMAL、SEGMENT、SEGMENTEX、STOP、STOPEX、SPARSE、THESAURUS、SYNONYM、ANTONYM之一，缺省为NORMAL。
COMMENT：
数据库的注释，为字符串类型，缺省值为空。
CHARSET：
数据库所用的语言，可为 GB18030、BIG5、ENGLISH和UTF8 之一。缺省 DEFAULT 为系统配置中的缺省语言环境。
ALIAS：
数据库的别名，一个数据库可有多个别名。缺省值为空。
DEFCOL：
进行全文检索的缺省全文字段名， 缺省为最后一个DOCUMENT或者PHRASE字段，DOCUMENT字段优先。
PATH：
数据库存放的路径，必须是系统配置中的数据和索引路径之一，缺省为系统配置中的第一个数据路径。
HOST：
数据库存放的位置。如果不为空，表明实际数据集中存储在一个数据宿主服务器中，并指向存储服务器的有关信息的字符串，如'ORACLE'。缺省值为空。
SEGMENT：
数据库所用的主分词词典名。缺省为系统配置中相应语言的缺省主分词词典名。
SEGMENTEX：
数据库所用的附加分词词典名。缺省为数据库拥有者的缺省附加分词词典名。
STOP：
数据库所用的主停用词典名。缺省为系统配置中相应语言的缺省主停用词典名。
STOPEX：
数据库所用的附加主分词词典名。缺省为数据库拥有者的缺省附加停用词典名。
SPARSE：
数据库所用的稀疏词典名。缺省为数据库拥有者的缺省稀疏词典名。
STEM：
为ON表示只建立词根索引，缺省为系统配置中设定的只建立词根索引标志。
CASE：
为ON表示建立索引时区分英文词的大小写，缺省为系统配置中设定的大小写敏感标志。
NUMBER：
为ON表示建立索引时不忽略数字串，缺省为系统配置中设定的忽略数字串标志。
BIGRAM：
为ON表示建立二元组索引，缺省为OFF。
COMPRESS：
为ON表示压缩索引，缺省为OFF。
BANSTOP：
为ON表示创建索引时禁止启用停用词典。
PUBLIC：
数据库的公共访问标志，对于用户自定义数据库可为SELECT、UPDATE、INDEX、ALTER、DROP之一，对于词典可为SELECT、UPDATE、DROP之一。不指定时所有操作都不是公共的。 为了提高效率，若设置的权限对象不支持时不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。

Button.gif (91 bytes) 要点
1. 除数据库名外，其它参数都可以不指定，不指定时自动取缺省值（定义方式下）或源数据库的值（选择方式下）。
2. 由于词典是一种特殊的数据库，所以此语句也能创建词典，但只能用定义方式，用TYPE子句指定词典的类型，并且不能指定字段。词典的属性只有ALIAS、CHARSET、PATH、HOST、COMMENT和PUBLIC有效。
3. 以选择方式建库时只建立数据库的结构，并不从源数据库里复制记录。要复制记录可使用COPY语句。

Button.gif (91 bytes) 举例
1、以定义方式创建新数据库
TRSL> CREATE DATABASE newsbase(
日期 DATE,
版次 NUMBER,
版面 CHAR(10),
标题 PHRASE,
作者 CHAR(10) MULTI,
正文 DOCUMENT,
图象 BIT MULTI)
PATH /trshome/ibase
SEGMENT system.syssegdic
STOP system.sysstopdic
NUMBER OFF
COMMENT '新闻资料数据库 '

这条语句的功能是：创建一个名为newsbase的数据库，共有7个字段，数据存放在服务器上的/trshome/ibase目录下，此数据库使用的分词词典为用户system.syssegdic，停用词典为system.sysstopdic，记录中的数字不建索引，因此不能用数字作为检索条件，备注中说明此数据库为'新闻资料数据库'。该语句中没有定义其它数据库属性，这些属性由TRS数据库服务器根据系统配置自动确定。

2、以选择方式创建新数据库
TRSL> CREATE DATABASE rmrb1999
AS rmrb(日期,标题,作者,正文,图象)
 COMMENT '人民日报1999年 '

这条语句的功能是：以rmrb数据库的日期、标题、作者、正文、图象字段作为模板，创建一个名为rmrb1999的新数据库，新数据库的注释为'人民日报1999年'，其它属性取rmrb数据库的属性值。

3、创建一部同义词典
TRSL> CREATE DATABASE mysynodic TYPE SYNONYM PUBLIC SELECT, UPDATE
这条语句的功能是：创建一个名为mysynodic的新同义词典，所有用户均可对此词典进行检索和记录维护操作。


CREATE FORMAT 创建数据格式

Pointer.gif (1201 bytes) CREATE FORMAT 创建数据格式

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的数据格式。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户。

Button.gif (91 bytes) 语法
CREATE FORMAT format_name
[CLASS {class | NULL}]
[SUFFIX {suffix [,...]} | NULL}]
[COMMENT {comment | NULL}]
[COMPRESS {ON|OFF}]

Button.gif (91 bytes) 参数
format_name：
待创建的数据格式名。
class：
数据格式的分类名。缺省值为空。
SUFFIX：
数据格式所对应的文件的后缀名列表，为字符串类型，内容需加上单引号，一种文件格式可有多个文件后缀名，多个文件后缀名之间以分号 或者逗号分隔，如'HTM;HTML'。缺省值为空。
comment：
数据格式的注释，为字符串类型，缺省值为空。
COMPRESS：
为ON表示进行无损压缩，为OFF表示不进行压缩，缺省值为ON。

Button.gif (91 bytes) 要点
除数据格式名以外，其它参数都可以不指定，不指定时自动取缺省值。

Button.gif (91 bytes) 举例
TRSL> CREATE FORMAT mp3 CLASS audio SUFFIX 'mp1;mp2;mp3 ' COMPRESS OFF
 这条语句的作用是创建一种名为mp3的新的audio数据格式，文件后缀名可为mp1、mp2或mp3，对这种文件不进行压缩。


CREATE GROUP 创建用户组

Pointer.gif (1201 bytes) CREATE GROUP 创建用户组

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的用户组。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户。

Button.gif (91 bytes) 语法
CREATE GROUP group_name
[COMMENT comment| NULL}]

Button.gif (91 bytes) 参数
group_name：
待创建的用户组名。
COMMENT：
用户组的注释，为字符串类型，缺省值为空。

Button.gif (91 bytes) 要点
除用户组名外，其它参数都可以不指定，不指定时自动取缺省值。

Button.gif (91 bytes) 举例
TRSL> CREATE GROUP product
 这条语句的作用是创建名为product的新用户组。


CREATE INDEX 创建索引

Pointer.gif (1201 bytes) CREATE INDEX 创建索引

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
为数据库字段建立索引。

Button.gif (91 bytes) 前提
操作用户对数据库有INDEX权限。

Button.gif (91 bytes) 语法
CREATE INDEX {[owner.]database_name | [owner.]auto_view_name} [({column_name [,...]})]
[TILL record]

Button.gif (91 bytes) 参数
database_name/auto_view_name：
创建索引时，指定索引字段所在的数据库/自动模式视图名，可由owner指定数据库/视图的拥有者。
column_name：
创建索引时，指定索引所在的字段名。可使用通配符，用‘?’匹配单个字符，用‘*’匹配任何字符。
record：
创建索引的终止记录号，不指定时表示创建所有记录的索引。

Button.gif (91 bytes) 要点
1. 一次可为多个字段创建索引。
2. 一般情况下，索引由系统自动维护，只有该字段上的索引被删除，或不需要在该字段上进行检索时才有必要手动创建索引。

Button.gif (91 bytes) 举例
TRSL> CREATE INDEX personnel(resume)
这条语句的作用是对数据库personnel的resume字段，为所有的记录建立索引。


CREATE USER 创建用户

Pointer.gif (1201 bytes) CREATE USER 创建用户

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的用户。

Button.gif (91 bytes) 前提
操作用户必须是SYSTEM用户。

Button.gif (91 bytes) 语法
CREATE USER user_name
[TYPE {DBA|GDA|RESOURCE|CONNECT}]
[PASSWORD {password | NULL}]
[GROUP {group_name | NULL}]
[COMMENT {comment | NULL}]
[HISTORY history]
[DOWNLOAD download]
[SECURITY security]
[SEGMENTEX {{[owner.]segmentex_dic | NULL}]
[STOPEX {[owner.]stopex_dic | NULL}]
[SPARSE {[owner.]sparse_dic | NULL}]
[EXCLUSIVE {ON|OFF}]

Button.gif (91 bytes) 参数
user_name：
待创建的新用户名。
TYPE：
用户的类型，可为DBA、GDA、RESOURCE或CONNECT之一，缺省为CONNECT。
PASSWORD：
用户的密码。
GROUP：
用户所在的组名。
COMMENT：
用户的注释，为字符串类型，缺省值为空。
HISTORY：
用户的最大检索历史步数，不设置或者为零时取缺省值，即系统配置中设定的最大检索历史步数 。取值范围为0到65533。
DOWNLOAD：
用户的最大下载记录数，不设置或者为零时取缺省值，即系统配置中设定的最大下载记录数 。取值范围为0到0xFFFFFFFD。
SECURITY：
用户的安全控制级别，用户只能访问安全级别不小于自己的安全控制级别的记录。 取值范围为0到0xFFFFFFFD，缺省值为零，表示该用户不能查看任何用密级加密的记录。
SEGMENTEX：
用户缺省的附加分词词典名。创建该用户的数据库时，如不指定附加分词词典，则自动取此词典作为数据库的附加分词词典。缺省值为NULL。
STOPEX：
用户缺省的附加停用词典名。创建该用户的数据库时，如不指定附加停用词典，则自动取此词典作为数据库的附加停用分词词典。缺省值为NULL。
SPARSE：
用户缺省的稀疏词典名。创建该用户的数据库时，如不指定稀疏词典，则自动取此词典作为数据库的稀疏词典。缺省值为NULL。
EXCLUSIVE：
为ON表示不允许多个IP地址上的Client用户同时用该用户名登录。缺省值为OFF。

Button.gif (91 bytes) 要点
除用户名外，其它参数都可以不指定，不指定时自动取缺省值。

Button.gif (91 bytes) 举例
TRSL> CREATE USER newuser TYPE RESOURCE PASSWORD trs40 SEGMENTEX mysegdic
这条语句的作用是创建一个名为newuser的新资源用户，密码为trs40，并把该用户创建的数据库的缺省附加分词词典设为mysegdic。

Button.gif (91 bytes) 参考
ALTER USER 修改用户
RENAME 为对象改名
DROP 删除对象。


CREATE VIEW 创建视图

Pointer.gif (1201 bytes) CREATE VIEW 创建视图

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
创建新的视图。

Button.gif (91 bytes) 前提
操作用户有Resource权限，并对所有的源数据库有SELECT权限。

Button.gif (91 bytes) 语法
CREATE VIEW view_name
{({<viewcol_element> [,...]}) | AS {[owner.]database_name [,...]} [SELECT {column_name [,...}] | SPLIT [owner.]database_name}
[WHERE {condition | NULL}]
[COMMENT {comment | NULL}]
[ALIAS {{alias [,...]} | NULL}]
[DEFCOL default_column]
[PUBLIC {{ALTER, DROP, SELECT} | NULL}]

Button.gif (91 bytes) 参数
view_name：
待创建的新视图名。
viewcol_element：
视图字段及其属性，参见视图字段描述。
AS：
从几个已存在的数据库中选择部分字段产生一个新的视图。字段可属于一个数据库，也可分别属于不同的数据库。SELECT表示指定某个database_name中或者某几个database_name中具有相同名称和类型的column_name产生一个新的视图 字段。如果不使用SELECT子句，则自动从所指定的database_name中选择名称类型相同的column_name生成新字段。
SPLIT：
表示将一个数据库转换成自动模式视图。
WHERE：
视图的创建条件。缺省值为空。
COMMENT：
视图的注释，为字符串类型，缺省值为空。
ALIAS：
视图的别名，一个视图可有多个别名。缺省值为空。
DEFCOL：
进行全文检索的缺省全文字段名，缺省为最后一个DOCUMENT或者PHRASE字段，DOCUMENT字段优先。
PUBLIC：
数据库的公共访问标志，可为SELECT、ALTER、DROP之一，不指定时所有操作都不是公共的。为了提高效率，若设置的权限对象不支持时不会报错，只是当请求发送到SERVER端后不支持的权限标志将会被忽略。

Button.gif (91 bytes) 要点
1. 除视图名外，其它参数都可以不指定，不指定时自动取缺省值。
2. 在检索系统中，一个重要的查询功能是实现跨数据库查找，TRS提供的CREATE VIEW功能为这种检索提供了方便的措施，一旦定义了视图，就不再需要每次检索时选择多个数据库，只要对视图进行检索就可以了。比如：要同时查询多个库的某一个字段，则可创建一个视图，定义其字段取自多个库的某个字段。
3. 视图的功能之一是实现记录一级的安全控制，通过WHERE条件，可限制对数据库中某些数据的访问，如在人事档案数据库中普通职员不能查阅部门经理信息等需求。
4. 视图涉及的数据库的结构可以不同。

Button.gif (91 bytes) 举例
1、以定义方式创建新视图
TRSL> CREATE VIEW vnews(
新闻(news90.正文, news91.正文, news92.正文, news93.正文))
WHERE 版面=摄影
PUBLIC SELECT
这条语句的作用是把news90、news91、news92、news93四个数据库的正文字段定义为一个视图，视图的字段名为“新闻”，创建条件为‘版面=摄影’。四个数据库跨库查询可直接在视图vnews上进行，并且所有用户都可对该视图进行检索。

2、以选择方式创建新视图
TRSL> CREATE VIEW engineer
AS personnel SELECT 标题
这条语句的作用是对数据库personnel创建一个视图，并取“标题”字段作为新视图的字段。


知识词典集配置

Pointer.gif (1201 bytes) 知识词典集配置

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
修改系统配置时，指定知识词典集的配置。

Button.gif (91 bytes) 前提
知识词典集的配置不是能单独执行的TRSL语句，它必须在设置系统配置语句里使用。

Button.gif (91 bytes) 语法
CHARSET {GB18030|BIG5|ENGLISH|UTF8}
[SEGMENT {segment_dic|NULL}]
[STOP {stop_dic|NULL}]
[THESAURUS {thesaurus_dic|NULL}]
[SYNONYM {synonym_dic|NULL}]
[ANTONYM {antonym_dic|NULL}]

Button.gif (91 bytes) 参数
LANGUAGE：
需要修改的知识词典集的语言，可为GB18030、BIG5、ENGLISH、UTF8之一。
SEGMENT：
缺省的主分词词典名，建库时作为缺省的数据库主分词词典，可为NULL。
STOP：
缺省的主停用词典名，建库时作为缺省的数据库主停用词典，可为NULL。
THESAURUS：
缺省的主题词典名，检索时作为缺省的自动扩展主题词典，可为NULL。
SYNONYM：
缺省的同义词典名，检索时作为缺省的自动扩展同义词典，可为NULL。
ANTONYM：
缺省的反义词典名，检索时作为缺省的自动扩展反义词典，可为NULL。

Button.gif (91 bytes) 要点
除知识词典集的语言必须提供以外，其它词典可以不指定，此时对词典集中相应词典的配置将不作修改。

Button.gif (91 bytes) 举例
无。


视图字段属性

Pointer.gif (1201 bytes) 视图字段属性

Arrow.gif (846 bytes) 目的 Arrow.gif (846 bytes) 前提 Arrow.gif (846 bytes) 语法 Arrow.gif (846 bytes) 参数 Arrow.gif (846 bytes) 要点 Arrow.gif (846 bytes) 举例 Arrow.gif (846 bytes) 参考
 Line.gif (2310 bytes)

Button.gif (91 bytes) 目的
在创建视图或修改视图结构时，对字段的属性进行描述。

Button.gif (91 bytes) 前提
视图字段属性不是能单独执行的TRSL语句，它必须在创建视图或修改视图结构语句中使用。

Button.gif (91 bytes) 语法
column_name
[({[owner.]source_database.column [,...]})]
[COMMENT {comment | NULL}]
[ALIAS {{alias [,...]} | NULL}]
[DISPLAY {title | NULL}]
[WIDTH width]
[HEIGHT height]
[PUBLIC {SELECT | NULL}]

Button.gif (91 bytes) 参数
column_name：
视图字段名。
source_database.column：
视图字段对应的源数据库字段名，字段所在的数据库由[owner.]source_database指定。一个视图字段可对应多个数据库字段，但这些字段的类型必须一致。
COMMENT：
视图字段的注释，为字符串类型，缺省值为空。
ALIAS：
视图字段的别名列表，一个视图字段可以有多个别名。缺省值为空。
DISPLAY：
视图字段的显示标题，为字符串类型，只供界面使用。缺省值为字段名。
WIDTH：
视图字段的显示宽度，只供界面使用，缺省值为零。
HEIGHT：
视图字段的显示高度，只供界面使用，缺省值为零。
PUBLIC：
视图字段的公共访问标志，只能为SELECT。

Button.gif (91 bytes) 要点
一般情况下，除字段名和源数据库字段列表以外，其它属性都可以不指定。在创建新视图或插入字段时，没有指定的属性会自动取缺省值；修改字段属性时，没有指定的属性值（包括源数据库字段列表）自动保持原来的值。

Button.gif (91 bytes) 举例
无。


选项|语法颜色 属性页

“语法颜色”属性页如下所示：

本属性页主要用于设置语句分析时各种不同类型语法符号的颜色，包括命令窗口和文件编辑窗口中的脚本文件编辑，各选项的含义如下：

控制名称 | 功能简介
语句结束符 | 语句结束符的颜色。
未知符号 | 语句中无法分辨的未知符号的颜色。
注释 | 语句注释部分的颜色。
保留字 | 语句中保留字的颜色。
标识符 | 语句中标识符的颜色。
字符串 | 语句中字符串的颜色。
数值 | 语句中数值的颜色。
密码 | 语句中密码的颜色。
文件路径 | 语句中文件路径的颜色。
表达式 | 语句中表达式的颜色。
操作符 | 语句中操作符的颜色。

其他选项请参见缺省登录、集成环境和检索选项属性页。


选项|集成环境 属性页

“集成环境”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
显示对象范围 | 当对象个数太多，不便于查看时，可设置对象的显示范围。
筛选条件 | 显示对象的筛选条件，可使用通配符：用'?'匹配单个字符，用'*'匹配任何字符。缺省为“*.*”，表示所有对象。
筛选权限 | 只显示具有选定权限的对象。
可检索的 | 如选中表示只显示可以检索的对象，对仅对数据库、视图和词典有效。
可更新的 | 如选中表示只显示可以更新的对象，对仅对数据库和词典有效。
可索引的 | 如选中表示只显示可以建立索引的对象，对仅对数据库有效。
可修改的 | 如选中表示只显示可以修改结构的对象，对仅对数据库和视图有效。
可删除的 | 如选中表示只显示可以删除的对象，对仅对数据库、视图和词典有效。
隐藏自动分裂数据库 | 如选中表示不显示自动分裂视图对应的物理数据库。
排列顺序 | 显示对象的排列顺序。

记录维护设置 | 检索结果浏览/维护窗口的选项设置。
缓冲路径 | 存放检索结果源文件的临时路径，按右边的 [image] 按钮可选择缓冲文件存放的目录，缺省为TRS管理员安装路径下的Temp子目录。
缓冲大小 | 检索结果缓冲区大小。缓冲区大小以记录为单位，缺省为128。
每次读取记录数 | 读取检索结果时每次读取的记录数，仅对取概览内容时有效，缺省为16。
截断长度 | PHRASE、DOCUMENT和BIT字段的截断长度，为零表示不进行截断。缺省为1024。
每页词语数 | 查询数据库的索引词和词典的时候，每页显示的词语数，其数值不能大于上面设置的缓冲大小，缺省值为 100。
多值字段的分隔符 | 多值字段的分隔符，仅对DATE、NUMBER和CHAR类型字段有效。为空串表示取系统缺省值‘;’。
文本自动折行模式 | 只对DOCUMENT和PHRASE字段有效，其中"所有文本不分行"选项一般用于细览字段以便于控制其显示格式，"段落文本不分行"一般用于细览字段以便于自动换行。
提取格式文档文本 | 只对DOCUMENT字段有效，表示只存储了单个格式化文档字段值的字段，尽量提取文本并给出命中点。
对URL输出对应文件 | 选中表示对URL(统一资源定位)输出其对应的文件(如HTML等)，而不是输出URL本身。缺省值为清除。
命令执行 | 命令执行的相关选项。
重要操作提示确认 | 选中表示在执行DROP、UNLOCK、RECOVER、UPDATE、MODIFY和DELETE这些操作前提示确认，缺省值为选中。

其他选项请参见缺省登录、检索选项和语法颜色属性页。


选项|缺省登录 属性页

“缺省登录”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
本地字符集 | 本地所用的字符集，可为“中文GB2312/GBK/GB18030”、“中文BIG5”、“统一码UTF8”或“不设置（与原来兼容）”，缺省为第一个选项。
登录信息 | 启动时缺省的登录信息，包括服务器地址和端口、用户帐号和口令等。输入的登录信息将会保存到注册表中，作为下一次启动的缺省设置。
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。
代理服务器 | 代理服务器的相关选项。
服务器类型 | 不为空表示将通过代理连接到目的服务器，目前仅支持“TRS”的代理服务器。
IP地址 | 如果服务器类型不为空，则此属性必须指定代理服务器的有效IP地址。
端口号 | 如果服务器类型不为空，则此属性必须指定代理服务器的有效端口号。
安全验证码 | 如果服务器类型不为空，则此属性可以指定一个代理服务器所需要的安全验证码 。
超时时间 | 设置登录时的超时时间，以秒为单位，超过指定时间仍未连接上则报错。为零则超时时间为网络系统的缺省值，一般为75秒到几分钟不等。
在传输数据时压缩 | 选中表示在传输数据时进行压缩，压缩算法由内部确定，对于本地客户端无效。
在传输数据时加密 | 选中表示在传输数据时进行加密，加密算法由内部确定，对于本地客户端无效。
自动登录 | 启动TRS命令语言时是否自动用缺省登录信息进行登录选项，缺省为设置。

其他选项请参见集成环境、检索选项和语法颜色属性页。


选项|检索选项 属性页

“检索选项”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
集群裁减设置 | 集群对后台检索结果的裁减设置。0表示不作限制；1~9表示集群至少需要等待相应数量的后台返回结果；10~99表示集群至少需要等待相应比例的后台返回结果；100及以上表示至少需要返回的结果记录数。
排序并裁减记录数 | 存储之前完成排序，并只存储排在前面的部分记录，同时自动设置“非精确命中点”模式。0表示由系统配置决定，缺省是不进行裁减。如果值等于65535，则表示则表示忽略系统配置，关闭排序裁减功能。
有效排序记录数 | 即部分排序，只保证前一部分记录是有序的。0表示由系统配置决定，缺省是全部排序。如果值等于65535，则表示则表示忽略系统配置，关闭部分排序功能。只有在排序裁减记录数为0的情况下才可能有效。
命中点的存储模式 | 不同的命中点存储模式，不但影响检索速度，还会影响相关性排序结果。
相关性排序选项 | 不同的相关性的计算模式和IDF模式组合下会有不同的排序结果。 分为7种情况：由系统配置决定；忽略词的位置和使用基于单个数据库范围的IDF值；忽略词的位置和词IDF值不参与相关性计算；考虑词的位置和使用基于单个数据库范围的IDF值；考虑词的位置和词IDF值不参与相关性计算；用一个记录中命中词的单位向量长度（每个命中词只计算一次）作为记录的相关；用一个记录中命中词的单位向量长度，以及命中词的词频和作为 记录的相关度。
自动扩展检索 | 自动扩展检索的相关选项。
主题词典 | 利用知识辅助词典自动进行知识扩展检索时的主题词典。
同义词典 | 利用知识辅助词典自动进行知识扩展检索时的同义词典。
反义词典 | 利用知识辅助词典自动进行知识扩展检索时的反义词典。
进行知识扩展检索的选项 | 进行知识扩展检索的各个选项。
同义词 | 选中表示自动进行“同义词”扩展检索。
反义词 | 选中表示自动进行“反义词”扩展检索。
等同词 | 选中表示自动进行“等同词”扩展检索。
替代词 | 选中表示自动进行“替代词”扩展检索。
缩略词 | 选中表示自动进行“缩略词”扩展检索。
被缩略词 | 选中表示自动进行“被缩略词”扩展检索。
相关词 | 选中表示自动进行“相关词”扩展检索。
上位词 | 选中表示自动进行“上位词”扩展检索。
下位词 | 选中表示自动进行“下位词”扩展检索。
所有上位词 | 选中表示自动进行“所有上位词”扩展检索。
所有下位词 | 选中表示自动进行“所有下位词”扩展检索。
外文等同词 | 选中表示自动进行“外文等同词”扩展检索。
简体/繁体 | 选中表示自动进行“简体/繁体”扩展检索。
全角/半角 | 选中表示自动进行“全角/半角”扩展检索。

其他选项请参见缺省登录、集成环境和语法颜色属性页。


查询索引词 对话框

查询数据库或者视图里的索引词。
在“高级检索/排序”对话框里，按[索引词]按钮，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行索引词查询，并把结果显示在结果列表里。
显示个数 | 显示结果的个数，缺省为不设置。
当前页面 | 当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。
结果列表 | 查询结果的索引词列表，每页显示个数可在“选项|集成环境”里设定，缺省为100个。每个索引词显示其词语、命中数、词频数和它相对于主题词的深度。要看其它页的索引词信息，可用 PrevPage.gif (876 bytes) 和 NextPage.gif (876 bytes) 按钮进行前后翻页。
对象名 | 待查询的目标数据库名或者视图名。改变查询对象将重新检索索引词并刷新检索列表。
字段名 | 待查询的字段名，为空表示在缺省全文字段上查询。改变查询字段将重新检索索引词并刷新检索列表。

复制 | 把结果列表里当前选中的检索词复制到“表达式生成器“对话框的检索条件编辑框里。
关闭 | 关闭“查询索引词”对话框。

查询完毕后，按[复制]或直接双击结果列表的索引词项将把指定索引词复制到“表达式生成器”对话框的检索条件编辑框里。按[关闭]则关闭对话框。


选项|系统配置 属性页

“系统配置”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
系统路径
数据路径 | 允许存放数据库数据和索引文件的目录集，至少必须包含一个目录路径。缺省为TRS安装目录下的ibase和dict目录。创建数据库或索引时如不指定路径，则缺省为目录集的第一个目录。 当登录本地服务器时，可点击 [image] 按钮选择本地路径，自己编辑时可 按CTRL+ENTER输入回车。
临时路径 | 系统缺省的临时文件路径。缺省为TRS安装目录下的temp目录。 当登录本地服务器时，可点击 [image] 按钮选择本地路径。
备份设备 | 系统缺省的备份设备，可以是磁带名或文件名。缺省为TRS安装目录下的temp目录。 当登录本地服务器时，可点击 [image] 按钮选择本地路径。

其他配置选项
物理内存 | 服务器的物理内存总量，以兆字节计算。缺省值根据服务器端配置决定。
最长空闲时间 | 允许一个用户实例最长的空闲时间，以分计，超时将自动Logout。为零表示不限制，缺省为30分钟。
最小有效时间 | 一个用户应该保持的最小有效时间（除非退出登录），以秒计，在此期间内不允许自动退出登录。为零表示不限制，缺省为10秒。
维护起始时间 | 当系统空闲时，允许自动进行系统或数据库维护的起始时间，以小时计，在0到23之间。24表示禁止系统进行自动维护，缺省值为1。
维护终止时间 | 允许自动进行系统或数据库维护的截止时间，以小时计，在0到23之间。缺省值为3。
最大检索历史步数 | 系统缺省的最大检索历史步数，缺省值为20。创建用户时作为用户最大检索历史步数的缺省值。
最长检索时间 | 一次检索操作的最长执行时间，以秒计算，零表示不限制，缺省值为10。
最大排序数 | 对检索结果进行排序的最大记录数，为零表示不限制，缺省值为10000。
最大下载数 | 系统缺省的一次最大下载记录数，缺省值为1000。创建用户时作为用户最大下载记录数的缺省值。

缺省建库选项 | 系统缺省的索引标志，启动Admin后第一次新建数据库时若没有指定这些标志，则自动取以下配置的值。 其后在没有重新启动Admin以前再新建数据库的话，则自动继承上一次新建时的设置。
词根索引 | 系统缺省的只建立词根索引标志，缺省为 清除。
大小写敏感 | 系统缺省的大小写敏感标志，缺省为 清除。
忽略数字 | 系统缺省的忽略数字串标志，缺省为 清除。

其他选项请参见：缺省登录、集成环境、检索维护和知识词典。


选项|集成环境 属性页

“集成环境”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
显示对象范围 | 当对象个数太多，不便于查看时，可设置对象的显示范围。
筛选条件 | 显示对象的筛选条件，可使用通配符：用'?'匹配单个字符，用'*'匹配任何字符。缺省为“*.*”，表示所有对象。
筛选权限 | 只显示具有选定权限的对象。
可检索的 | 如选中表示只显示可以检索的对象，仅对数据库和视图有效。
可更新的 | 如选中表示只显示可以更新的对象，仅对数据库、自动模式视图和词典有效。 普通视图没有更新权限，将不被显示。
可索引的 | 如选中表示只显示可以建立索引的对象，仅对数据库和自动模式视图有效。 普通视图和词典没有索引权限，将不被显示。
可修改的 | 如选中表示只显示可以修改结构的对象，仅对数据库和视图有效。 词典没有修改权限，将不被显示。
可删除的 | 如选中表示只显示可以删除的对象，仅对数据库、视图和词典有效。
隐藏自动分裂数据库 | 如选中表示不显示自动分裂视图对应的物理数据库。
窗口显示风格 | 概览/细览窗口的显示颜色。
背景颜色 | 概览/细览窗口的背景颜色，按下右边的下拉按钮可打开“颜色”对话框以选择背景颜色。
字段名色 | 细览窗口的字段标题显示颜色，按下右边的下拉按钮可打开“颜色”对话框以选择字段名显示颜色。
命中点色 | 细览窗口的命中点显示颜色，按下右边的下拉按钮可打开“颜色”对话框以选择命中点显示颜色。
文件名色 | 细览窗口的文件名显示颜色，按下右边的下拉按钮可打开“颜色”对话框以选择文件名显示颜色。
本地路径 | 检索结果浏览/维护窗口的选项设置，对已经打开的记录维护窗口不起作用。
缓冲路径 | TRS管理员存放检索结果源文件的临时路径，按右边的 [image] 按钮可选择缓冲文件存放的目录，缺省为TRS管理员安装路径下的Temp子目录。
导航路径 | TRS管理员存放导航文件的路径，按右边的 [image] 按钮可导航文件存放的目录，缺省为TRS管理员安装路径下的Navigate子目录。
插件配置 | 插件配置文件名，文件的格式参见《TRS全文数据库系统 用户手册》。缺省为空，按右边的 [image] 按钮可选择新的插件配置文件。
控制文件 | 数据加载的控制文件，用于添加/更新记录中（因集成环境选项里已有设置，其中的多值分隔符不起作用），以及作为装入记录的缺省控制文件。缺省为空，表示取系统缺省值。按 [image] 按钮可选择装库控制文件。

其他选项请参见：缺省登录、系统配置、检索维护和知识词典


选项|知识词典 属性页

“知识词典”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
语言环境 | 系统缺省的语言环境，有四种取值：中文GB2312/GBK/GB18030、中文BIG5、英语、统一码UTF8，缺省为选项一。
知识词典集 | 当前语言对应的缺省知识词典集，包括下面列出的五种词典。
分词词典 | 当前语言对应的缺省主分词词典名，建库时作为缺省的数据库主分词词典。缺省为系统安装时建立的分词词典。
停用词典 | 当前语言对应的缺省的主停用词典名，建库时作为缺省的数据库主停用词典。缺省为系统安装时建立的停用词典。
主题词典 | 当前语言对应的缺省的主题词典名，检索时作为缺省的自动扩展主题词典。缺省为系统安装时建立的主题词典。
同义词典 | 当前语言对应的缺省的同义词典名，检索时作为缺省的自动扩展同义词典。缺省为系统安装时建立的同义词典。
反义词典 | 当前语言对应的缺省的反义词典名，检索时作为缺省的自动扩展反义词典。缺省为系统安装时建立的反义词典。

其他选项请参见：缺省登录、集成环境、检索维护和系统配置。


选项|缺省登录 属性页

“缺省登录”属性页如下所示：

属性框中各选项的含义如下：

控制名称 | 功能简介
本地字符集 | 本地所用的字符集，可为“中文GB2312/GBK/GB18030”、“中文BIG5”、“统一码UTF8”或“不设置（与原来兼容）”，缺省为“中文GB2312/GBK/GB18030”。
登录信息 | 启动时缺省的登录信息，包括服务器地址和端口、用户帐号和口令等。输入的登录信息将会保存到注册表中，作为下一次启动的缺省设置。
服务器地址 | 服务器所在的主机，既可以是TRS服务器在网络中的IP地址（如“199.9.200.80”），也可以是服务器所在主机的名称（如“ALPHA”）。如果输入的是服务器主机的名称则要求该主机名是当前所使用的网络驱动系统的数据库文件hosts的一个入口项（如 “192.9.200.80 alpha”）。服务器地址可以从TRS的系统管理员处获得。
服务器端口 | 服务器端口既可以是TRS服务器的INTERNET端口（如“8000”），也可以是TRS服务器的名称（如“trsserver”）。如果输入的是服务器的名称，则要求该名称是当前所使用的网络驱动系统的数据库文件services的一个TCP协议入口项（如“trsserver 8000/tcp”）。服务器端口可以从TRS的系统管理员处获得。
用户帐号名 | 用户的帐号名，必须是指定服务器中已经存在的用户名。用户的帐号由SYSTEM用户创建。
用户口令字 | 用户的密码，区分大小写。为防止泄密，输入字符将用‘*’号显示。用户的密码可由用户自己修改。

代理服务器 | 代理服务器的相关选项。
服务器类型 | 不为空表示将通过代理连接到目的服务器，目前仅支持“TRS”的代理服务器。
IP地址 | 如果服务器类型不为空，则此属性必须指定代理服务器的有效IP地址。
端口号 | 如果服务器类型不为空，则此属性必须指定代理服务器的有效端口号。
安全验证码 | 如果服务器类型不为空，则此属性可以指定一个代理服务器所需要的安全验证码。
自动打开 | 登录成功后自动打开的窗口，可为以下选项之一：对象管理窗口、数据库/视图。
超时时间 | 设置登录时的超时时间，以秒为单位，超过指定时间仍未连接上则报错。为零则超时时间为网络系统的缺省值，一般为75秒到几分钟不等。
在传输数据时压缩 | 选中表示在传输数据时进行压缩，压缩算法由内部确定，对于本地客户端无效。
在传输数据时加密 | 选中表示在传输数据时进行加密，加密算法由内部确定，对于本地客户端无效。
显示启动对话框 | 启动时是否显示“启动”对话框标志。如清除该选项，则下次启动时将不再显示“启动”对话框。
最大化窗口 | 是否最大化子窗口标志。如设置该选项，则所有子窗口都将占满整个主窗口的空间。

其他选项请参见：集成环境、系统配置、检索维护和知识词典。


选项|检索维护 属性页

“检索维护”属性页如下所示：

属性页中各选项的含义如下：

控制名称 | 功能简介
高级检索选项 | 检索时设置的默认参数。
命中点的存储模式 | 不同的命中点存储模式，不但影响检索速度，还会影响相关性排序结果。
估算分段单位 | 使用估算检索模式，其值为数据的分段单位(记录数)。
估算终止条件 | 使用估算检索模式，其值为检索终止条件(记录数)。
标题加权系数(倍) | 命中点在标题(第0段/第0句)位置上的加权系数(倍数)。
知识扩展权重(%) | 知识扩展检索(主题/同义/反义)词的权重系数(百分比)。
命中分支权重 | 命中分支数的权重系数。
检索超时时间(秒) | 检索的超时时间(秒数，不能大于系统的的超时时间设置)。如果值为0，表示使用系统的的超时时间设置。
中断时输出部分结果 | 选中表示当检索过程被中断时也输出已经得到的部分检索结果，否则按出错处理。
忽略不存在的索引属性 | 对于不存在的索引属性，简单地忽略，不按出错处理。
集群裁减设置 | 集群对后台检索结果的裁减设置。0表示不作限制；1~9表示集群至少需要等待相应数量的后台返回结果；10~99表示集群至少需要等待相应比例的后台返回结果；100及以上表示至少需要返回的结果记录数。

排序选项 | 排序时设置的默认参数。
排序并裁减记录数 | 存储之前完成排序，并只存储排在前面的部分记录，同时自动设置“非精确命中点”模式。0表示由系统配置决定，缺省是不进行裁减。如果值等于65535，则表示忽略系统配置，关闭排序裁减功能。
有效排序记录数 | 即部分排序，只保证前一部分记录是有序的。0表示由系统配置决定，缺省是全部排序。如果值等于65535，则表示则表示忽略系统配置，关闭部分排序功能。只有在排序裁减记录数为0的情况下才可能有效。
相关性排序选项 | 不同的相关性的计算模式和IDF模式组合下会有不同的排序结果。 分为7种情况：由系统配置决定；忽略词的位置和使用基于单个数据库范围的IDF值；忽略词的位置和词IDF值不参与相关性计算；考虑词的位置和使用基于单个数据库范围的IDF值；考虑词的位置和词IDF值不参与相关性计算；用一个记录中命中词的单位向量长度（每个命中词只计算一次）作为记录的相关；用一个记录中命中词的单位向量长度，以及命中词的词频和作为 记录的相关度。
加权表示优先顺序 | 相关性排序时表达式中多字段的加权表示优先顺序。
中文排序方式 | 中文的排序方式，可选择按内码、拼音、多音字拼音或笔画数排序。

记录维护设置 | 检索结果浏览/维护窗口的选项设置，对已经打开的记录维护窗口不起作用。
缓冲区大小 | 检索结果缓冲区大小。缓冲区大小以记录为单位，缺省为128。
每次读取记录数 | 读取检索结果时每次读取的记录数，不能大于缓冲区的大小，仅对取概览内容时有效，缺省为16。
概览截断长度 | PHRASE、DOCUMENT和BIT字段的截断长度，为零表示不进行截断。缺省为1024。
每页词语数 | 查询数据库的索引词和词典的时候，每页显示的词语数，其数值不能大于上面设置的缓冲大小，缺省值为100。
多值字段的分隔符 | 多值字段的分隔符，仅对DATE、NUMBER和CHAR类型字段有效。为空串表示取系统缺省值‘;’。
文本自动折行模式 | 只对DOCUMENT和PHRASE字段有效，其中"所有文本不分行"选项一般用于细览字段以便于控制其显示格式，"段落文本不分行"一般用于细览字段以便于自动换行。
提取格式文档文本 | 只对DOCUMENT字段有效，表示只存储了单个格式化文档字段值的字段，尽量提取文本并给出命中点。
对URL输出对应文件 | 选中表示对URL(统一资源定位)输出其对应的文件(如HTML等)，而不是输出URL本身。缺省值为清除。
输出原始的相关度值 | 输出记录的原始（绝对）相关度值，而不是缺省方式的相对相关度值。

其他选项请参见：缺省登录、集成环境、系统配置和知识词典。


转成自动模式视图 命令

从对象管理窗口中数据库页的快捷菜单中选择“转成自动模式视图”命令，TRS管理员弹出如下对话框：

对话框里的“数据库”列表框里列出了当前所有可以转化为自动模式视图的数据库。“分裂条件”用来描述数据库分裂的条件，目前支持的条件是记录数，其表示方法为：$RECORD=n，n是一个10000到20000000之间的任意数，当视图中最后一个数据库的记录数不小于n时将分裂出一个新的数据库。
选择需要转化的数据库（可一次选择多个），输入分裂条件，然后按[确定]，TRS管理员会把所选择的数据库化为能自动分裂数据库的视图，并在状态条显示成功信息。按[取消]则放弃操作并关闭对话框。


加入数据库 命令

从对象管理窗口中视图页的快捷菜单中选择“加入数据库”命令，TRS管理员弹出如下对话框：

对话框里的“目标自动模式视图”列表框里列出了当前所有自动模式视图，从“加入数据库名”列表中选择需要加入的数据库（可一次选择多个），然后按[确定]，TRS管理员会把所选择的数据库添加到指定自动模式视图里，并在状态条显示成功信息。按[取消]则放弃操作并关闭对话框。


结果报告 对话框

显示刚才所做操作的起始时间、终止时间、花费时间、备份对象数、致命错误等结果信息。 若用户进行“备份数据”，“复制记录”，“恢复数据”，“索引维护”，“优化数据”和“装入记录”等操作，操作完成后都会弹出如下对话框，

对话框中各控制的说明如下：

控制名称 | 功能简介
起始时间 | 操作的开始时间。
结束时间 | 操作的结束时间。
花费时间 | 操作一共花费的时间。
成功记录数 | 操作成功的数据库\记录\字段数，视操作的类型而定。
终止错误 | 操作过程中发生的致命错误的信息，“(无)”表示操作正常完成。
失败记录数 | 操作失败的记录数。
打开报告查看 | 选中表示直接查看结果信息报告，当结果信息报告较大时，可设置为只生成报告而不打开报告查看，以节约时间。
生成报告 | 点击后可选择结果信息报告储存的路径，直接生成储存报告。
关闭 | 关闭对话框，不保存任何更改。


新建|数据库

创建新的数据库。必须是具有Resource权限的用户才可以创建数据库。
选择“文件|新建”命令，在“新建”对话框里双击数据库图标，或者当对象管理窗口显示数据库列表且焦点也在其上时，按工具栏上的 [image] 按钮 或者在对象管理框按鼠标右键，出现菜单后选择新建，将会开始执行“创建数据库向导”，该向导共有如下三步：

  • 第一步：输入数据库名、拥有者名、说明信息、公共属性等信息，并可选择一个已存在的数据库作为模板；
  • 第二步：设置数据库的别名列表、使用语言、存放路径、数据宿主、索引词典和索引标志等属性；
  • 第三步：设计数据库的字段结构以及各字段的具体属性等。

在向导的执行过程中，按[上一步]按钮可返回上一步，按[下一步]按钮可前进到下一步，按[取消]则放弃创建操作并退出向导。在第三步做完后，按[完成]按钮可结束向导，并创建新数据库。


新建|数据库 第一步

创建数据库向导第一步的对话框如下：

对话框里各控制的说明如下：

控制名称 | 功能简介
数据库名 | 新建数据库的名字，不能包含中文、字母、数字或下划线以外的字符，大小写无关。名字长度在1-31个字符之间，不能是TRS保留字，也不能和拥有者的数据库、视图和词典重名。
拥有者名 | 新建数据库所属的拥有者名，缺省为当前登录用户的用户名。
说明信息 | 不超过63个字符长度的数据库说明信息。

模板数据库 | 现有的所有数据库的列表，可选择其中之一作为新数据库的模板。缺省时不选择模板。
字段列表 | 所选模板数据库的字段列表，可选择一个或多个字段作为新数据库字段的模板。缺省时选择全部字段。

公共属性 | 数据库的公共访问标志集，包含下面所列的几个标志。
公共检索 | 选中表示所有用户均可对该数据库进行检索。
公共更新 | 选中表示所有用户均可对该数据库进行记录维护。
公共索引 | 选中表示所有用户均可对该数据库的索引进行维护。
公共修改 | 选中表示所有用户均可修改该数据库的结构。
公共删除 | 选中表示所有用户均可删除该数据库。

输入数据库名、拥有者名、说明信息、公共属性，选择好模板数据库和字段列表以后，按[下一步]按钮进入向导的第二步。按[取消]则退出创建数据库向导。


新建|数据库 第二步

创建数据库向导第二步的对话框如下：

对话框里各控制的说明如下：

控制名称 | 功能简介
别名列表 | 数据库的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。缺省值为空。
存放路径 | 数据库存放的路径，必须是系统配置中的数据和索引路径之一，缺省为系统配置中的第一个数据路径。可以在下拉列表里选择。
数据宿主系统 | 数据库存放的位置。如果不为空，表明实际数据集中存储在一个数据宿主服务器中，并指向存储服务器的有关信息的字符串，如“ORACLE”。缺省值为空。

使用语言 | 数据库所用的语言，有如下几种取值（缺省为系统配置中的缺省语言环境）：中文GB2312/GBK/GB18030、中文BIG5、英语、统一码UTF8。
主分词词典 | 该数据库按词索引时所引用的词典。缺省为系统配置中相应语言的缺省主分词词典名。
附加分词词典 | 该数据库按词索引时所引用的扩充词典。缺省为数据库拥有者的缺省附加分词词典名。
停用词典 | 该数据库按词索引时所引用的不允许索引的词典。缺省为系统配置中相应语言的缺省主停用词典名。
附加停用词典 | 数据库按词索引时所引用的不允许索引的扩充词典。缺省为数据库拥有者的缺省附加停用词典名。
稀疏词典 | 该数据库按词索引时所引用的允许索引的词典。缺省为数据库拥有者的缺省稀疏词典名。

词根索引 | 决定数据库的短语型和全文型字段数据中的字母单词是否按词根进行索引，缺省为系统配置中设定的只建立词根索引标志。
大小写敏感 | 决定数据库的字符型、短语型和全文型字段数据中的字母串是否区分大小写进行索引，缺省为系统配置中设定的大小写敏感标志。
忽略数字串 | 选中表示建立索引时忽略数字串，缺省为系统配置中设定的忽略数字串标志。
二元组索引 | 决定数据库的短语型和全文型字段是否建立二元组索引，缺省为清除。
禁止压缩 | 决定数据库是否对数据和索引进行压缩。对于CPU速度慢而IO速度较快的系统，不压缩数据与索引对数据库的入库与检索速度会略有提高，但空间膨胀率会显著增大，所以在实际使用时总是压缩索引，以获得较好的时空比，缺省为清除。
禁止停用词典 | 禁止停用词典开关的作用是允许建立停用词的索引（即创建数据的索引不启用停用词典），检索时停用词是否参与运算由应用进行选择。此功能为TRS全文数据库6.50.4000版本新增。

设置好数据库的别名列表、使用语言、存放路径、数据宿主、索引词典和索引标志等属性以后，按[下一步]按钮进入向导的第三步。按[上一步]可返回向导的第一步，按[取消]则退出创建数据库向导。


新建|数据库 第三步

创建数据库向导第三步的对话框如下：

数据库字段列表控制里列出新建数据库的所有字段，第一次进入时显示的是第一步里选择的模板字段。字段列表的每一行分别显示字段的名字、类型和说明，字段名前有 [image] 标志的字段为新增字段，有 [image] 标志的字段为数据库进行全文检索的缺省全文字段名， 不指定的话自动设为最后一个DOCUMENT字段（没有DOCUMENT字段的话则选择最后一个PHRASE字段）。用户可在模板字段的基础上进行添加字段、修改字段属性、删除字段、为字段改名、调整字段顺序(仅限于新字段)等操作。数据库字段列表控制的右上角有六个按钮，它们的作用分别如下：

添加新字段，快捷键为Insert
删除当前选中字段，快捷键为Delete
为当前选中字段改名，快捷键为空格，直接在字段名上单击也能起到同样作用
当前选中字段位置上移，仅限于新字段，快捷键为Shift+↑
当前选中字段位置下移，仅限于新字段，快捷键为Shift+↓
把当前选中字段设为缺省字段，快捷键为Shift+空格

数据库字段列表控制下面是字段属性组框，组框里的控制显示当前数据库字段列表控制里选中的字段的各项属性，具体如下：

控制名称 | 功能简介
别名列表 | 数据库字段的别名列表，多个别名之间以半角分号、逗号或空格分隔。缺省值为空。
显示标签 | 数据库字段的显示标题，如不为空，概览时将作为列标题，细览时作为字段引导符。
格式限定 数据库字段的输入输出格式。
对于CHAR型字段，其格式规定为：
· A 表示在相应位置上必须出现一个英文字母；
· 9 表示在相应位置上必须出现一个数字；
· 空格 表示在相应位置上必须出现一个空格；
· X 表示在相应位置上可出现任意字符。
对于DATE和NUMBER型字段，则为字段值的输出限定格式，并且格式由用户确定，如“Y.MM.DD HH:MM:SS”、“L.DP”等。
如果限定格式第一个字符为‘@’，则表示其中存储的是限定格式所在文件的文件名，按右边的 [image] 按钮可打开“格式限定”编辑对话框，在此对话框中可以直接进行编辑或者浏览格式限定文件。缺省值为空，表示字段的值没有格式限制。
缺省取值 | DATE、NUMBER或CHAR型字段的缺省值。如果第一个字符为‘@’，则表示其中存储的是缺省值所在文件的文件名，按右边的 [image] 按钮可打开“缺省取值”编辑对话框，在此对话框中可以直接进行编辑或者浏览缺省取值文件。缺省值为空，表示没有缺省值。
取值范围 DATE、NUMBER或CHAR型字段的取值范围。取值范围的定义格式包括：
· 枚举定义：格式为V1,V2,V3,Vn，即枚举该字段上所有可能取值；
· 区间定义：格式为V1,...,V2，表示该字段上所有可能取值必须在最小值V1和最大值V2之间；
· 混合定义：格式为V1,V2,...,V3,Vn，是以上两种方式的混合。
以上各格式中的逗号和点号都必须是半角符号。CHAR型字段的取值范围所给出的每个值串首尾不允许空格。DATE型字段的取值范围所给出的每个日期中只支持绝对（完全）年份，而不支持缺省世纪数的短格式年份，即总是认为缺省世纪数为0。只有DATE型字段的取值范围支持模糊格式，即允许日期格式中缺省一些成份，但对于区间定义定义的范围，其中的V1和V2“前模糊”的成份必须是相同的，即在“年月日时分秒”的顺序下，V1和V2的第一个确定的日期成份的位置必须是相同的。如果第一个字符为‘@’，则表示其中存储的是取值范围所在文件的文件名，按右边的 [image] 按钮可打开“取值范围”编辑对话框，在此对话框中可以直接进行编辑或者浏览取值范围文件。缺省值为空，表示字段的值没有范围限制。
索引路径 | 数据库字段索引的存放路径，必须是系统配置中的数据和索引路径之一。缺省值为空，表示字段索引路径和数据库存放路径一致。
索引属性 按右边的 [image] 按钮可打开“索引属性”编辑对话框，在此对话框中可以直接进行编辑或者浏览索引属性文件。
  • 对DOCUMENT字段来说，即倒排索引属性名。多个属性名之间用‘;’分隔，如“SEG;SEN;POS”等。如果第一个字符为‘@’，则表示其中存储的是索引属性所在文件的文件名。对DOCUMENT字段缺省值为“SEG;SEN;POS”，对其它类型的字段缺省值为空。
  • 对于CHAR字段来说，索引属性是用来定义冗余索引模式的。CHAR字段的冗余索引是从原字段值中按规则抽取部分值的组合并进行索引，允许从字段值中抽取多个冗余值。抽取规则采用正则表达式语法，每个正则表达式对应一个冗余值，正则表达式之间用换行符分隔，每行一个正则表达式。表达式语法规则请参见附录三。
  • 对BIT字段来说，只有它被设置成虚拟逻辑字段时才支持索引属性。虚拟逻辑字段的索引属性存储的是该虚拟逻辑字段所对应的实际字段列表（至少包含一个字段）及其逻辑关系和运算优先模式，如：“字段1,字段2,*&”。 定义中的‘*’是‘字段1’和‘字段2’之间的逻辑关系（AND运符算），还可以是‘+’（OR运算符）、‘^’（XOR运算符）和‘-’（NOT运算符），逻辑关系缺省时默认为OR运算；‘&’是运算优先模式符号，表示“字段逻辑优先”，即虚拟逻辑在每个检索原子（检索键值）上进行扩展，缺省时表示“表达式逻辑优先”，即虚拟逻辑在虚拟逻辑字段所限定的最大子表达式上进行扩展。 字段及逻辑关系之间必须用单字节的逗号‘,’进行分隔，逻辑关系符和运算优先模式也必须是单字节的，并且也必须放在最后。
            •
    词根索引语种 | 对DOCUMENT和PHRASE字段的索引进行词根处理时字段值的语种。可为Alpha（根据字母表确定一个主要的语种）、English（英语）、Russian（俄语）、French（法语）、Spanish（西班牙语）、Portuguese（葡萄牙语）、Italian（意大利语）、German（德语）、Dutch（荷兰语）、Swedish（瑞典语）、Norwegian（挪威语）、Danish（丹麦语）、Finnish（芬兰语）之一。缺省为Alpha。
    混合索引模式 | 对DOCUMENT和PHRASE字段进行字词混合索引时，索引混合存储模式开关,可为可为None（不进行字词混合索引）、Char（禁止按词索引）、Full（全冗余模式）、Half（半冗余模式）、Zero（零冗余模式）之一。缺省为None。该开关只有当数据库指定了分词词典、扩展分词词典或稀疏词典时才有效。
    最大长度或最大精度 | 数据库字段的长度限定。对CHAR字段为最大的取值长度，为零表示字段所允许的最大长度，超过规定长度的字符将被忽略，此时直接在后面的编辑框中进行编辑，缺省值为零；对NUMBER字段表示数值的小数位精度，此时 可以点击右边的 [image] 按钮打开“最大精度”对话框，进行具体的精度选择，缺省值为100，表示双精度型数值，不带小数位；对其它类型的字段无意义。
    显示大小 | 数据库字段在用户界面上显示的宽度和高度。

    允许多值 | 选中表示允许多值（PHRASE和DOCUMENT型字段除外），缺省为选中。
    不建索引 | 选中表示不建立索引（BIT型字段除外），对BIT型字段缺省值选中，对其它类型字段缺省值为清除。
    值唯一性 | 选中表示取值不允许重复，仅对DATE、NUMBER和CHAR型字段有效，缺省为清除。
    禁止空值 | 选中表示不允许空值，仅对DATE、NUMBER和CHAR型字段有效，缺省为清除。
    缓冲数据 | 选中表示允许进行检索缓冲，缓冲可以提高检索时有关操作的速度。此开关决定该字段的“数据”是否集中存储，并在“检索缓冲”启动的情况下时，允许进入内存缓冲。虽然所有类型的字段都允许进行缓冲，但DOCUMENT和BIT类型的字段只存储一个标志，表示字段是否有值，而不是存储实际的字段值 。缺省为清除。
    公共检索 | 选中表示所有用户均可对本数据库字段进行检索，缺省为清除。
    允许单字检索 | 对DOCUMENT和PHRASE字段进行字词混合索引时，字索引的方式开关：如果选中，表示所有的表意文字都可被单独查询，否则表示单个表意文字不能查询。该开关只有当数据库指定了分词词典，并且对该字段进行字词混合索引时才有效。缺省为清除。
    允许相关排序 | 选中表示检索命中该字段时，该字段参与相关性排序，缺省为清除。对BIT字段该开关无效。
    虚拟逻辑字段 | 如果虚拟逻辑字段开关被打开，则表示该字段被设置成一个虚拟字段。虚拟字段不能存储数据和索引，而只能在该字段的索引属性中定义一些它所对应的实际字段及其逻辑关系，在检索时作为单一的字段使用。只有BIT字段才能设置为虚拟逻辑字段。此功能为TRS全文数据库6.50.4000版本新增。
    缺省虚拟字段 | 如果缺省虚拟字段开关被打开，则表示在检索时该虚拟逻辑字段的字段名可以用特殊的字符串“$DUMMY”来替代，以便于检索表达式的书写或选项的指定。此功能为TRS全文数据库6.50.4000版本新增。

    设计好数据库的字段结构以及各字段的具体属性后，按[完成]可结束向导，并创建数据库。按[上一步]可返回向导的第二步，按[取消]则退出创建数据库向导。


新建|词典

创建知识词典。只有具备Resource权限的用户才能创建知识词典。
选择“文件|新建”命令，在“新建”对话框里双击词典图标，或者当对象管理窗口显示词典列表切焦点也在其上时，按工具栏上的 [image] 按钮或者在对象管理框按鼠标右键，出现菜单后选择新建，将会看到如下对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
词典名称 | 新建词典的名字，不能包含中文、字母、数字或下划线以外的字符，大小写无关。名字长度在1-31个字符之间，不能是TRS保留字，也不能和拥有者的数据库、视图和词典重名。
拥有者名 | 新建词典所属的拥有者名，缺省为当前登录用户的用户名。
词典类型 | 新建词典的类型，可为以下几种类型之一：分词词典、附加分词词典、停用词典、附加停用词典、稀疏词典、主题词典、同义词典、反义词典。
说明信息 | 不超过63个字符长度的词典说明信息。

别名列表 | 词典的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。
使用语言 | 词典所用的语言，有如下几种取值（缺省为系统配置中的缺省语言环境）：中文GB2312/GBK/GB18030、中文BIG5、英语、统一码UTF8。
存放路径 | 词典存放的路径，必须是系统配置中的数据和索引路径之一，缺省为系统安装路径下的dict子目录。可以在下拉列表里选择。

公共属性 | 词典的公共访问标志集，包含下面所列的几个标志。
公共检索 | 选中表示所有用户均可对该词典进行检索，总是选中。
公共维护 | 选中表示所有用户均可对该词典进行维护。
公共删除 | 选中表示所有用户均可删除该词典。

设定好词典名、拥有者、词典类型、说明信息以及其他词典属性后，按[确定]，TRS管理员将在当前服务器上建立新的词典。如想放弃新建词典，请按[取消]。


新建|数据格式

创建新的数据格式。
选择“文件|新建”命令，在“新建”对话框里双击数据格式图标，或者当对象管理窗口显示数据格式列表且焦点也在其上时，然后按工具栏上的 FileNew.gif (923 bytes) 按钮 或者在对象管理框按鼠标右键，出现菜单后选择新建，将会看到如下对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
格式名称 | 新建数据格式的名字，不能包含英文字母或数字以外的字符，大小写无关。名字长度在1-15个字符之间，不能是TRS保留字，也不能和已存在的数据格式重名。
所属分类 | 数据格式的分类名，可以从已存在的分类名中选择，或置为空。分类名长度不能超过15个字符。
后缀列表 | 数据格式所对应的文件的后缀名列表，多个后缀名间以半角分号、逗号或空格分隔。其长度不超过31个字符，缺省值为空。
说明信息 | 不超过63个字符长度的数据格式说明信息。
无损压缩 | 选中表示对该格式的文件进行无损压缩。缺省为选中。

设定好格式名称、所属分类、后缀列表、说明信息等属性后，按[确定]，TRS管理员将在当前服务器上建立新的数据格式。如想放弃新建数据格式，请按[取消]。

注意：由于创建后的数据格式不能被删除，请在创建前考虑清楚是否应该创建该数据格式。


新建|用户组

创建新的用户组。只有SYSTEM用户才能创建用户组。
选择“文件|新建”命令，在“新建”对话框里双击用户组图标，或者当焦点在导航窗口的“所有用户”节点上时，按工具栏上的 [image] 按钮 或者按鼠标右键，出现菜单后选择新建，将会看到如下对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
用户组名 | 新建用户组的名字，不能包含中文、字母、数字或下划线以外的字符，大小写无关。名字长度在1-31个字符之间，不能是TRS保留字，也不能和已存在的用户组/用户重名。
说明信息 | 不超过63个字符长度的用户组说明信息。
用户列表 | 新用户组包含的用户列表。
已选用户 | 已选入新用户组的用户列表。可按 MoveRight.gif (925 bytes) 按钮从已选用户列表里清除。此操作将使选中用户脱离当前用户组。
可选用户 | 没有选入新用户组的用户列表。可按 MoveLeft.gif (925 bytes) 按钮加到已选用户列表里。此操作将使选中用户脱离原用户组，并加入到当前用户组中。

设定好用户组名、说明信息和用户列表后，按[确定]，TRS管理员将在当前服务器上建立新的用户组，并把所有已选用户列表里的用户移到新建的用户组里。如想放弃新建用户组，请按[取消]。


新建|对象

创建新的对象。
若当前焦点在对象管理窗口上时，按工具栏上的“新建”按钮，根据对象管理窗口当前对象的不同，分别创建以下相应类型的对象：

  • 数据库
  • 视图
  • 词典
  • 数据格式

若当前焦点在导航窗口上时，按工具栏上的“新建”按钮，根据当前点击节点的类型不同，分别创建以下相应类型的对象：

  • 用户组
  • 用户
  • 数据格式


新建|用户

创建新的用户。只有SYSTEM用户才能创建新用户。
选择“文件|新建”命令，在“新建”对话框里双击用户图标，或者当焦点在导航窗口除根节点以外的其他节点上时，按工具栏上的 [image] 按钮 或者按鼠标右键，出现菜单后选择新建，将会看到如下对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
用户帐号 | 新建用户的帐号名，不能包含中文、字母、数字或下划线以外的字符，大小写无关。名字长度在1-31个字符之间，不能是TRS保留字，也不能和已存在的用户组/用户重名。
用户组名 | 用户所在的组名，可以是已存在的用户组之一，也可以是空，表示不属于任何用户组。
用户类型 | 用户的类型，有四种选择：系统数据库管理员(DBA)、用户组数据库管理员(GDA)、系统资源用户(Resource)、系统登录用户(Connect)。
说明信息 | 不超过63个字符长度的用户说明信息。
设置密码 | 新建用户的口令。为保密起见，输入字符以“*”显示。密码的有效长度是1-31个字符。若此控制项为空， 即表示没有密码。
确认密码 | 确认用户的密码，必须与设置密码一致。为保密起见，输入字符以“*”显示。

附加分词 | 用户缺省的附加分词词典名。创建该用户的数据库时，如不指定附加分词词典，则自动取此词典作为数据库的附加分词词典。缺省值为空。
附加停用 | 用户缺省的附加停用词典名。创建该用户的数据库时，如不指定附加停用词典，则自动取此词典作为数据库的附加停用分词词典。缺省值为空。
稀疏词典 | 用户缺省的稀疏词典名。创建该用户的数据库时，如不指定稀疏词典，则自动取此词典作为数据库的稀疏词典。缺省值为空。

最大检索历史步数 | 用户的最大检索历史步数，清空或为零时取缺省值，即系统配置中设定的最大检索历史步数。
最大下载记录数 | 用户的最大下载记录数，清空或为零时取缺省值，即系统配置中设定的最大下载记录数。
密级 | 密级定义了该用户在TRS系统的接触机密数据的级别。数值越小，级别越高。对于数据库中使用密级加密的数据记录，只有当用户的密级值不大于记录的密级值时，才能看到该记录的内容。0密级是一个特殊密级，表示该用户不能查看任何用密级加密的记录。
登录互斥开关 | 选中表示不允许该用户同时从多个不同的IP地址进行登录，但来自本机IP地址的用户登录不计算在内。缺省为清除状态。

设定好用户组名和用户的各项属性后，按[确定]，TRS管理员将在当前服务器上建立新的用户。如想放弃新建用户，请按[取消]。


新建|视图

创建新的视图。只有具备Resource权限的用户才能创建视图。
选择“文件|新建”命令，在“新建”对话框里双击视图图标，或者当对象管理窗口显示视图列表切焦点也在其上时，按工具栏上的 [image] 按钮 或者在对象管理框按鼠标右键，出现菜单后选择新建，将会开始执行“创建视图向导”，该向导共有如下三步：

  • 第一步：输入视图名、拥有者名、说明信息、公共属性等信息，并可选择一个已存在的视图作为模板；
  • 第二步：设置视图的别名列表、创建条件和源数据库等属性；
  • 第三步：设计视图库的字段结构以及各字段的具体属性等。

在向导的执行过程中，按[上一步]按钮可返回上一步，按[下一步]按钮可前进到下一步，按[取消]则放弃创建操作并退出向导。在第三步做完后，按[完成]按钮可结束向导，并创建新视图。


新建|视图 第一步

创建视图向导第一步的对话框如下：

对话框里各控制的说明如下：

控制名称 | 功能简介
视图名称 | 新建视图的名字，不能包含中文、字母、数字或下划线以外的字符，大小写无关。名字长度在1-31个字符之间，不能是TRS保留字，也不能和拥有者的数据库、视图和词典重名。
拥有者名 | 新建视图所属的拥有者名，缺省为当前登录用户的用户名。
说明信息 | 不超过63个字符长度的视图说明信息。

模板视图 | 现有的所有视图的列表，可选择其中之一作为新视图的模板。缺省时不选择模板。
字段列表 | 所选模板视图的字段列表，可选择一个或多个字段作为新视图字段的模板。缺省时选择全部字段。

公共属性 | 视图的公共访问标志集，包含下面所列的几个标志。
公共检索 | 选中表示所有用户均可对该视图进行检索。
公共修改 | 选中表示所有用户均可修改该视图的结构。
公共删除 | 选中表示所有用户均可删除该视图。

输入视图名、拥有者名、说明信息、公共属性，选择好模板视图和字段列表以后，按[下一步]按钮进入向导的第二步。按[取消]则退出创建视图向导。


新建|视图 第二步

创建视图向导第二步的对话框如下：

对话框里各控制的说明如下：

控制名称 | 功能简介
别名列表 | 视图的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。缺省值为空。
记录选取条件 | 视图的创建条件。缺省值为空。长度不能超过1023个字符。
源数据库集 | 视图对应的源数据库集。点击 [image] 按钮弹出“选择源数据库”对话框，对视图对应的源数据库集进行选择或更改。

设置好视图的别名列表、创建条件和源数据库等属性以后，按[下一步]按钮进入向导的第三步。按[上一步]可返回向导的第一步，按[取消]则退出创建视图向导。


新建|视图 第三步

创建视图向导第三步的对话框如下：

视图字段列表控制里列出新建视图的所有字段，第一次进入时显示的是第一步里选择的模板字段 ，若没有选择模板，则自动将所选的各源数据库中名称类型相同的字段列出，字段属性取第一个字段的相应属性。字段列表的每一行分别显示字段的名字、类型和说明，字段名前有 [image] 标志的字段为新增字段，有 [image] 标志的字段为视图进行全文检索的缺省全文字段名，不指定的话自动设为最后一个DOCUMENT字段（没有DOCUMENT字段的话则选择最后一个PHRASE字段）。用户可在模板字段的基础上进行添加字段、修改字段属性、删除字段、为字段改名、调整字段顺序(仅限于新字段)等操作。视图字段列表控制的右上角有六个按钮，它们的作用分别如下：

添加新字段，快捷键为Insert，点击此按钮后将弹出“选择源数据库字段”对话框， 选定源数据库字段以后，点击[确定]将自动生成一个相应的字段，类型和源数据库字段类型一样
删除当前选中字段，快捷键为Delete
为当前选中字段改名，快捷键为空格，直接在字段名上单击也能起到同样作用
当前选中字段位置上移，仅限于新字段，快捷键为Shift+↑
当前选中字段位置下移，仅限于新字段，快捷键为Shift+↓
把当前选中字段设为缺省字段，快捷键为Shift+空格

视图字段列表控制下面是字段属性组框，组框里的控制显示当前视图字段列表控制里选中的字段的各项属性，具体如下：

控制名称 | 功能简介
别名列表 | 视图字段的别名列表，多个别名之间以半角分号、逗号或空格分隔。缺省值为空。
显示标签 | 视图字段的显示标题，如不为空，概览时将作为列标题，细览时作为字段引导符。
源数据库字段列表 | 视图字段对应的源数据库字段列表，每个数据库字段名的表示方式为：“拥有者.数据库名.字段名”，源数据库字段数必须大于零。当视图字段对应多个源数据库字段时，这些源数据库字段的类型必须一致。按 [image] 按钮弹出“选择源数据库字段”对话框，对视图对应的源数据库字段进行选择或更改。
显示大小 | 视图字段的显示宽度和高度。
公共检索 | 选中表示所有用户均可对本视图字段进行检索。

设计好视图的字段结构以及各字段的具体属性后，按[完成]可结束向导，并创建视图。按[上一步]可返回向导的第二步，按[取消]则退出创建视图向导。


反义词典维护 对话框

对反义词典进行查询和维护。
在对象管理窗口里双击反义词典对象，或选中需要查询和维护的反义词典，并按回车或选择“文件|检索”命令，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行词典查询，并把结果显示在结果列表里。
结果列表 | 命中词语的列表。每页显示个数可在“选项|集成环境”里设定，缺省为100个。要看其它页的词语信息，可用右上角的 PrevPage.gif (876 bytes) 和 NextPage.gif (876 bytes) 按钮进行前后翻页。按 [image] 按钮可向词典里添加新词语，按 DelWord.gif (857 bytes) 可把当前选中词语从词典里删除，不过添加和删除必须在执行了保存操作以后才会保存到词典里。
当前页面

当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。

反义词属性

当前选中的反义词的属性。

同义词表 | 当前选中词语的同义词语列表。在上面的输入框里输入新的词语，并按右上角的 [image] 按钮或按回车键，该词语将被添加到同义词表里。从同义词表里选择要删除的词语，再按 DelWord.gif (857 bytes) 按钮将把该词语从同义词表里删除。
反义词表 | 当前选中词语的反义词语列表。在上面的输入框里输入新的词语，并按右上角的 [image] 按钮或按回车键，该词语将被添加到反义词表里。从反义词表里选择要删除的词语，再按 DelWord.gif (857 bytes) 按钮将把该词语从反义词表里删除。

保存 | 保存当前所作的修改（包括添加、删除和修改属性操作）。
另存为 | 打开“词典导出”对话框，把当前查询结果的一部分或全部保存到一个文件里。

修改完毕后按[确定]，当前所作的添加、删除、修改操作将会保存到词典里，并关闭对话框。按[关闭]则放弃所作的修改，并关闭对话框。


索引词典维护 对话框

对索引词典（包括主分词词典、附加分词词典、主停用词典、附加停用词典、稀疏词典）进行查询和维护。
在对象管理窗口里双击索引词典对象，或选中需要查询和维护的索引词典，并按回车或选择“文件|检索”命令，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值（对分词词典不能使用"%"）。按右边的 Select.gif (956 bytes) 按钮进行词典查询，并把结果显示在结果列表里。
结果列表 | 命中词语的列表。每页显示个数可在“选项|集成环境”里设定，缺省为100个。要看其它页的词语信息，可用右上角的 PrevPage.gif (876 bytes) 和 [image] 按钮进行前后翻页。按 [image] 按钮可把上面输入框内的词语添加到词典里， 按 [image] 按钮可对当前选中词语进行修改，按 DelWord.gif (857 bytes) 可把当前选中词语从词典里删除，不过添加 、修改和删除必须在执行了保存操作以后才会保存到词典里。
当前页面

当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。

保存 | 保存当前所作的修改（包括添加、删除和修改属性操作）。
另存为 | 打开“词典导出”对话框，把当前查询结果的一部分或全部保存到一个文件里。

修改完毕后按[确定]，当前所作的添加、删除、修改操作将会保存到词典里，并关闭对话框。按[关闭]则放弃所作的修改，并关闭对话框。


词典导出 对话框

词语导出 对话框

把当前词语查询结果的一部分或全部保存到一个文件里。
在词典维护或索引词查询对话框里按[另存为]按钮后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
目标文件名 | 保存的目标文件名，可按右边的 [image] 按钮来选择目标文件名。

词语范围 | 需要保存的词语的范围，缺省为所有词语。
当前记录 | 只保存当前记录。
所有记录 | 保存检索结果里的所有记录。
指定范围 | 保存指定范围的记录，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。在保存索引词查询结果时，还可用">词频数"或">=词频数"的方式指定保存索引词的范围。

保存格式 | 结果保存的格式，对索引词典和索引词查询无效，缺省为TRS装库数据格式。
记录文件 | 以记录数据格式保存检索结果，一般只需浏览检索结果时选择此格式。
装库文件 | 以TRS装库数据格式保存检索结果，所保存的文件可以用来重新进行装库。
ISO2709 | 以ISO2709国际标准格式保存检索结果。
XML | 以XML格式保存检索结果。
保存词频数 | 在保存索引词查询结果时，指定是否保存各索引词的词频数。在词典维护时无此项控制。

输入目标文件名，设置词语范围、保存格式等选项以后，按[确定]，TRS管理员将开始保存查询结果到目标文件里。按[取消]则放弃保存操作并关闭对话框。由于保存查询结果是一个耗时过程，因此保存过程中有“保存进度“对话框显示目前已保存的记录数和保存完成的百分比。如要终止保存过程，可按[终止]按钮。


同义词典维护 对话框

对同义词典进行查询和维护。
在对象管理窗口里双击同义词典对象，或选中需要查询和维护的同义词典，并按回车或选择“文件|检索”命令，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行词典查询，并把结果显示在结果列表里。
结果列表 | 命中词语的列表。每页显示个数可在“选项|集成环境”里设定，缺省为100个。要看其它页的词语信息，可用右上角的 PrevPage.gif (876 bytes) 和 NextPage.gif (876 bytes) 按钮进行前后翻页。按 [image] 按钮可向词典里添加新词语，按 DelWord.gif (857 bytes) 可把当前选中词语从词典里删除，不过添加和删除必须在执行了保存操作以后才会保存到词典里。
当前页面

当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。

同义词属性

当前选中的同义词的属性。

同义词表 | 当前选中词语的同义词语列表。在上面的输入框里输入新的词语，并按右上角的 [image] 按钮或按回车键，该词语将被添加到同义词表里。从同义词表里选择要删除的词语，再按 DelWord.gif (857 bytes) 按钮将把该词语从同义词表里删除。

保存 | 保存当前所作的修改（包括添加、删除和修改属性操作）。
另存为 | 打开“词典导出”对话框，把当前查询结果的一部分或全部保存到一个文件里。

修改完毕后按[确定]，当前所作的添加、删除、修改操作将会保存到词典里，并关闭对话框。按[关闭]则放弃所作的修改，并关闭对话框。


主题词典维护 对话框

对主题词典进行查询和维护。
在对象管理窗口里双击主题词典对象，或选中需要查询和维护的主题词典，并按回车或选择“文件|检索”命令，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行词典查询，并把结果显示在结果列表里。
查询目标 | 主题词典查询的目标字段，缺省为空，表示按主题词查询。
排序字段 | 主题词典查询的排序方式，缺省为空，表示不进行排序。
结果列表 | 命中词语的列表。每页显示个数可在“选项|集成环境”里设定，缺省为100个。要看其它页的词语信息，可用右上角的 PrevPage.gif (876 bytes) 和 NextPage.gif (876 bytes) 按钮进行前后翻页。按 [image] 按钮可向词典里添加新词语，按 DelWord.gif (857 bytes) 可把当前选中词语从词典里删除，不过添加和删除必须在执行了保存操作以后才会保存到词典里。
当前页面

当前显示的页数。在编辑框中输入想要跳转的页数以后点击回车键，将会跳转到指定的页数。

主题词属性

当前选中的主题词的属性。

主题词 | 主题词名，是主题词典的关键词。
族首词 | 族首词(Lead Term)，概念上外延最广的主题词。如“木刻”的族首词是“美术”。
上位词 | 上位词(Broader Term)，概念上外延较广的主题词。如 “木刻”的上位词是“版画”。
下位词 | 下位词(Narrower Term)，概念上内涵更窄的主题词。如“木刻”的下位词有“水印木刻”和“套色木刻”。
等同词 | 等同词(Equivalence,Preferred Term)，也称正式主题词或规范主题词。如“电子计算机”是“电脑”的等同词。
替代词 | 替代词(用代词)(Used For,Non-Preferred Term)，也称非正式主题词或非规范主题词。如“电脑”、“计算机”是“电子计算机”的替代词。
相关词 | 相关词(Related Term)，概念相近但不是等关系的主题词。如“计算机应用”和“自动控制”是相关关系。
缩略词 | 缩略词(Abbreviation)，主题词的缩略词。如“Database Management System”的缩略词为“DBMS”。
被缩略词 | 被所略词(Abbreviation For)，缩略词的正式名称。如“DBMS”的正式名称为“Database Management System”。
组合概念 | 组合概念(Combined Concepts)，为将来TRS版本预留。
历史注释 | 历史注释(History Note)，对主题词的历史进行说明。
范围注释 | 范围注释(Scope Note)，对主题词的适用范围进行说明。
外文等同词 | 外文等同词(Language Equivalent)，其它语种的等同词 “计算机”的英文等同词是“Computer”。
后组配概念 | 后组配概念(Post-coordinated Concept)，为将来TRS版本预留。

保存 | 保存当前所作的修改（包括添加、删除和修改属性操作）。
另存为 | 打开“词典导出”对话框，把当前查询结果的一部分或全部保存到一个文件里。

修改完毕后按[确定]，当前所作的添加、删除、修改操作将会保存到词典里，并关闭对话框。按[关闭]则放弃所作的修改，并关闭对话框。


数据库属性

查看和修改数据库的具体属性。
在对象管理窗口里选中要查看属性的数据库对象，属性窗口将会看到如下图：

属性框里各控制的说明如下：

控制名称 | 功能简介

常规属性

数据库的常规属性。
内部编号 | 数据库在系统中的内部标识号。
对象名称 | 名称是数据库的对象名，即数据库名，是访问、维护和管理该数据库的入口。数据库名不能与属于同一用户的其它数据库、视图以及各种词典同名。
拥有者 | 表明哪个用户拥有该数据库。所有者与名称（别名）唯一确定一个数据库对象。所有者对该数据库能够进行任何操作，而不受其它数据安全控制的制约。
对象类型 | 对象的类型。附有“（自动分裂）”字样的为自动模式视图包含的数据库，这种数据库的属性、结构和权限均不允许修改。
说明信息 | 不超过63个字符长度的数据库说明信息。
创建时间 | 数据库的创建时间。
修改时间 | 数据库的最后一次修改时间。
字段数 | 数据库的字段数。
记录数 | 数据库的记录数。
锁定状态 | 数据库的当前访问状态，以对数据库的维护操作进行同步，保证数据及索引的一致性，有如下几种取值： 共享锁(SHARE)、访问互斥锁(ACCESS_EXCL)、修改锁(UPDATE_EXCL)、修改等待锁(UPDATE_WAIT)、拒绝访问锁(ACCESS_DENY)。
锁定用户 | 锁定数据库的用户名。
占用空间 | 点击打开“数据库大小”对话框，统计数据库所占用的磁盘文件空间，包括总占用空间、数据空间、索引空间和各字段索引的大小。

高级属性

数据库的高级属性。
别名列表 | 数据库的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。
存放路径 | 数据库存放的路径，必须是系统配置中的数据和索引路径之一。可以在下拉列表中选择。
数据宿主系统 | 有一类应用：TRS系统只管理和维护索引，而数据存储在其它系统中。数据宿主系统就是用来描述存储数据的系统的信息。描述信息对TRS没有实际的意义，如果数据库没有数据宿主系统，则TRS系统负责管理数据库的数据。不存储数据不针对日期型、数值型和字符型字段，因一些特殊应用和性能要求，这三种字段值始终存储。
使用语言 | 指存储在数据库中的数据所使用的字符集编码，有如下几种取值：中文GB2312/GBK/GB18030、中文BIG5、英语、统一码UTF8。特别注意：当没有指定系统字符集时，字符集不支持统一码。
主分词词典 | 该数据库按词索引时所引用的词典。如果不为数据库指定分词词典，则该数据库将按字索引。
附加分词词典 | 该数据库按词索引时所引用的扩充词典。
停用词典 | 该数据库按词索引时所引用的不允许索引的词典。
附加停用词典 | 该数据库按词索引时所引用的不允许索引的扩充词典。
稀疏词典 | 该数据库按词索引时所引用的允许索引的词典。如果不为数据库指定稀疏词典，则该数据库索引所有不属于停用词典和附加停用词典中的词汇。
词根索引 | 决定数据库的短语型和全文型字段数据中的字母单词是否按词根进行索引。如果设置该开关，则索引不区分大小写。
大小写敏感 | 决定数据库的字符型、短语型和全文型字段数据中的字母串是否区分大小写进行索引。
忽略数字串标志 | 选中表示建立索引时忽略数字串。
二元组索引 | 决定数据库的短语型和全文型字段是否建立二元组索引。
禁止压缩 | 决定数据库是否对数据和索引进行压缩。对于CPU速度慢而IO速度较快的系统，不压缩数据与索引对数据库的入库与检索速度会略有提高，但空间膨胀率会显著增大，所以在实际使用时总是压缩索引，以获得较好的时空比 。
禁止停用词典 | 禁止停用词典开关的作用是允许建立停用词的索引（即创建数据的索引不启用停用词典），检索时停用词是否参与运算由应用进行选择。此功能为TRS全文数据库6.50.4000版本新增。

公共属性

数据库的公共属性。
公共检索 | 选中表示所有用户均可对该数据库进行检索。
公共更新 | 选中表示所有用户均可对该数据库进行记录维护。
公共索引 | 选中表示所有用户均可对该数据库的索引进行维护。
公共修改 | 选中表示所有用户均可修改该数据库的结构。
公共删除 | 选中表示所有用户均可删除该数据库。

如对数据库的属性作了修改，按 [image] 将保存所作的修改 。


数据库 访问权限

查看和修改数据库的访问权限。数据库的访问权限有检索权限、更新权限、索引权限、修改权限和删除权限五种，字段只有检索权限。
若当前属性窗口显示的对象为数据库，直接选择菜单上的“文件|权限”命令，或按工具栏上的 FileRight.gif (947 bytes) 按钮，将会看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
用户组/用户 | 当前服务器上所有用户组/用户的列表。用户组/用户名前面的小图标表明了该用户组/用户的类型： Group.gif (905 bytes) 表示用户组、 DBA.gif (875 bytes) 表示全域管理员用户、 GDA.gif (879 bytes) 表示组管理员用户、 Resource.gif (875 bytes) 表示资源用户、 Connect.gif (878 bytes) 表示登录用户。
字段 | 对象名及其所有字段的列表。

访问权限 | 当前选中的用户组/用户对指定对象/字段的访问权限，包括以下所列几项。直接单击组里的复选框可修改所有处于选择状态的用户组/用户对所有选择的对象/字段的访问权限，不需按“确定”或“应用”即可立刻生效。
检索权限 | 选中表示当前用户组/用户对数据库和指定字段有检索权限。
更新权限 | 选中表示当前用户组/用户对数据库有记录更新权限。
索引权限 | 选中表示当前用户组/用户对数据库有索引维护权限。
修改权限 | 选中表示当前用户组/用户对数据库有结构修改权限。
删除权限 | 选中表示当前用户组/用户对数据库有删除权限。

按[确定]或[取消]将并关闭对话框。


用户属性

数据库大小 对话框

统计数据库所占用的磁盘文件空间，包括总占用空间、数据空间、索引空间和各字段索引的大小。点击数据库属性“占用空间”一栏就会弹出如下对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介

占用空间

数据库总的占用磁盘文件的空间。
数据大小 | 数据文件占用的磁盘文件空间。
字段索引 | 索引文件占用的磁盘文件空间。
列表 | 各个字段索引分别占用的磁盘文件空间。


数据库 结构信息

查看和修改数据库的结构。
若当前属性窗口显示的对象为数据库，直接选择菜单上的“文件|结构”命令，或点击工具栏上的 FileDesign.gif (948 bytes) 按钮，将会看到如下对话框：

数据库字段列表控制里列出数据库的所有字段。字段列表的每一行分别显示字段的名字、类型和说明，字段名前有 [image] 标志的字段为新增字段，有 [image] 标志的字段为数据库进行全文检索的缺省全文字段名，不指定的话自动设为最后一个DOCUMENT字段（没有DOCUMENT字段的话则选择最后一个PHRASE字段）。用户可在字段列表上进行添加字段、修改字段属性、删除字段、为字段改名、调整字段顺序(仅限于新字段)等操作。数据库字段列表控制的右上角有六个按钮，它们的作用分别如下：

添加新字段，快捷键为Insert
删除当前选中字段，快捷键为Delete
为当前选中字段改名，快捷键为空格，直接在字段名上单击也能起到同样作用
当前选中字段位置上移，仅限于新字段，快捷键为Shift+↑
当前选中字段位置下移，仅限于新字段，快捷键为Shift+↓
把当前选中字段设为缺省字段，快捷键为Shift+空格

数据库字段列表控制下面是字段属性框，属性框里的控制显示当前数据库字段列表控制里选中的字段的各项属性（类型不同的字段属性有个别不同），具体如下：

控制名称 | 功能简介
内部编号 | 数据库字段在系统中的内部标识号，新字段不显示此属性。
别名列表 | 数据库字段的别名列表，多个别名之间以半角分号、逗号或空格分隔。
显示标签 | 数据库字段的显示标题，如不为空，概览时将作为列标题，细览时作为字段引导符。
格式限定 数据库字段的输入输出格式。
对于CHAR型字段，其格式规定为：
· A 表示在相应位置上必须出现一个英文字母；
· 9 表示在相应位置上必须出现一个数字；
· 空格 表示在相应位置上必须出现一个空格；
· X 表示在相应位置上可出现任意字符。
对于DATE和NUMBER型字段，则为字段值的输出限定格式，并且格式由用户确定，如“Y.MM.DD HH:MM:SS”、“L.DP”等。
如果限定格式第一个字符为‘@’，则表示其中存储的是限定格式所在文件的文件名。按右边的 [image] 按钮可 打开“格式限定”编辑对话框，在此对话框中可以直接进行编辑或者浏览格式限定文件。
缺省取值 | 指在数据库加载时，对于未给出字段值的DATE、NUMBER或CHAR型字段所对应的缺省取值。如果第一个字符为‘@’，则表示其中存储的是缺省值所在文件的文件名。按右边的 [image] 按钮可 打开“缺省取值”编辑对话框，在此对话框中可以直接进行编辑或者浏览缺省取值文件。
取值范围 DATE、NUMBER或CHAR型字段的取值范围。取值范围的定义格式包括：
· 枚举定义：格式为V1,V2,V3,Vn，即枚举该字段上所有可能取值；
· 区间定义：格式为V1,...,V2，表示该字段上所有可能取值必须在最小值V1和最大值V2之间；
· 混合定义：格式为V1,V2,...,V3,Vn，是以上两种方式的混合。
以上各格式中的逗号和点号都必须是半角符号。CHAR型字段的取值范围所给出的每个值串首尾不允许空格。DATE型字段的取值范围所给出的每个日期中只支持绝对（完全）年份，而不支持缺省世纪数的短格式年份，即总是认为缺省世纪数为0。只有DATE型字段的取值范围支持模糊格式，即允许日期格式中缺省一些成份，但对于区间定义定义的范围，其中的V1和V2“前模糊”的成份必须是相同的，即在“年月日时分秒”的顺序下，V1和V2的第一个确定的日期成份的位置必须是相同的。如果第一个字符为‘@’，则表示其中存储的是取值范围所在文件的文件名。按右边的 [image] 按钮可 打开“取值范围”编辑对话框，在此对话框中可以直接进行编辑或者浏览取值范围文件。
索引路径 | 数据库字段索引的存放路径，必须是系统配置中的数据和索引路径之一。缺省值为空，表示字段索引路径和数据库存放路径一致。
索引属性 按右边的 [image] 按钮可 打开“索引属性”编辑对话框，在此对话框中可以直接进行编辑或者浏览索引属性文件。
  • 对DOCUMENT字段来说，即倒排索引属性名。多个属性名之间用‘;’分隔，如“SEG;SEN;POS”等。如果第一个字符为‘@’，则表示其中存储的是索引属性所在文件的文件名。对DOCUMENT字段缺省值为“SEG;SEN;POS”，对其它类型的字段缺省值为空。
  • 对于CHAR字段来说，索引属性是用来定义冗余索引模式的。CHAR字段的冗余索引是从原字段值中按规则抽取部分值的组合并进行索引，允许从字段值中抽取多个冗余值。抽取规则采用正则表达式语法，每个正则表达式对应一个冗余值，正则表达式之间用换行符分隔，每行一个正则表达式。表达式语法规则请参见附录三。
  • 对BIT字段来说，只有它被设置成虚拟逻辑字段时才支持索引属性。虚拟逻辑字段的索引属性存储的是该虚拟逻辑字段所对应的实际字段列表（至少包含一个字段）及其逻辑关系和运算优先模式，如：“字段1,字段2,*&”。 定义中的‘*’是‘字段1’和‘字段2’之间的逻辑关系（AND运符算），还可以是‘+’（OR运算符）、‘^’（XOR运算符）和‘-’（NOT运算符），逻辑关系缺省时默认为OR运算；‘&’是运算优先模式符号，表示“字段逻辑优先”，即虚拟逻辑在每个检索原子（检索键值）上进行扩展，缺省时表示“表达式逻辑优先”，即虚拟逻辑在虚拟逻辑字段所限定的最大子表达式上进行扩展。 字段及逻辑关系之间必须用单字节的逗号‘,’进行分隔，逻辑关系符和运算优先模式也必须是单字节的，并且也必须放在最后。
    • 词根索引语种 | 对DOCUMENT和PHRASE字段的索引进行词根处理时字段值的语种。可为Alpha（根据字母表确定一个主要的语种）、English（英语）、Russian（俄语）、French（法语）、Spanish（西班牙语）、Portuguese（葡萄牙语）、Italian（意大利语）、German（德语）、Dutch（荷兰语）、Swedish（瑞典语）、Norwegian（挪威语）、Danish（丹麦语）、Finnish（芬兰语）之一。
    混合索引模式 | 对DOCUMENT和PHRASE字段进行字词混合索引时，索引混合存储模式开关,可为可为None（不进行字词混合索引）、Char（禁止按词索引）、Full（全冗余模式）、Half（半冗余模式）、Zero（零冗余模式）之一。该开关只有当数据库指定了分词词典、扩展分词词典或稀疏词典时才有效。
    最大长度或最大精度 | 数据库字段的长度限定。对CHAR字段为最大的取值长度，为零表示字段所允许的最大长度，超过规定长度的字符将被忽略，此时直接在后面的编辑框中进行编辑；对NUMBER字段表示数值的小数位精度，此时 可以点击右边的 [image] 按钮打开“最大精度”对话框，进行具体的精度选择；对其它类型的字段无意义。
    显示大小 | 数据库字段在用户界面上显示的宽度和高度。

    允许多值 | 选中表示允许存在多个值（PHRASE和DOCUMENT型字段除外）。
    不建索引 | 选中表示不建立索引（BIT型字段除外）。
    值唯一性 | 选中表示取值不允许重复，仅对DATE、NUMBER和CHAR型字段有效。
    禁止空值 | 选中表示不允许空值，仅对DATE、NUMBER和CHAR型字段有效。
    缓冲数据 | 选中表示允许进行检索缓冲，缓冲可以提高检索时有关操作的速度。此开关决定该字段的“数据”是否集中存储，并在“检索缓冲”启动的情况下时，允许进入内存缓冲。虽然所有类型的字段都允许进行缓冲，但DOCUMENT和BIT类型的字段只存储一个标志，表示字段是否有值，而不是存储实际的字段值 。
    公共检索 | 选中表示所有用户均可对本数据库字段进行检索。
    允许单字检索 | 对DOCUMENT和PHRASE字段进行字词混合索引时，字索引的方式开关：如果选中，表示所有的表意文字都可被单独查询，否则表示单个表意文字不能查询。该开关只有当数据库指定了分词词典，并且对该字段进行字词混合索引时才有效。
    允许相关排序 | 选中表示检索命中该字段时，该字段参与相关性排序。对BIT字段该开关无效。
    虚拟逻辑字段 | 如果虚拟逻辑字段开关被打开，则表示该字段被设置成一个虚拟字段。虚拟字段不能存储数据和索引，而只能在该字段的索引属性中定义一些它所对应的实际字段及其逻辑关系，在检索时作为单一的字段使用。只有BIT字段才能设置为虚拟逻辑字段。此功能为TRS全文数据库6.50.4000版本新增。
    缺省虚拟字段 | 如果缺省虚拟字段开关被打开，则表示在检索时该虚拟逻辑字段的字段名可以用特殊的字符串“$DUMMY”来替代，以便于检索表达式的书写或选项的指定。此功能为TRS全文数据库6.50.4000版本新增。

    如对数据库的结构作了修改，按[确定]将保存所作的修改并关闭对话框。


词典属性

查看和修改词典的具体属性。
在对象管理窗口里选中要查看属性的词典对象，属性窗口将会看到如下图：

属性框里各控制的说明如下：

控制名称 | 功能简介

常规属性

词典的常规属性。
内部编号 | 词典在系统中的内部标识号。
对象名称 | 词典的对象名，即词典名，是访问、维护和管理该词典的入口。词典名不能与属于同一用户的其它视图、数据库以及各种词典同名。
拥有者 | 表明哪个用户拥有该词典。所有者与名称（别名）唯一确定一个词典对象。所有者对该词典能够进行任何操作，而不受其它数据安全控制的制约。
对象类型 | 词典的类型，有八种取值：主分词词典、附加分词词典、主停用词典、附加停用词典、稀疏词典、主题词典、同义词典、反义词典。
说明信息 | 不超过63个字符长度的词典说明信息。
创建时间 | 词典的创建时间。
修改时间 | 词典的最后一次修改时间。
字段数 | 词典的字段数。
记录数 | 词典的记录数。
锁定状态 | 词典的当前访问状态，有如下几种取值： 共享锁(SHARE)、访问互斥锁(ACCESS_EXCL)、修改锁(UPDATE_EXCL)、修改等待锁(UPDATE_WAIT)、拒绝访问锁(ACCESS_DENY)。
锁定用户 | 锁定词典的用户名。

高级属性

词典的高级属性。
别名列表 | 词典的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。
使用语言 | 词典所用的语言，有如下几种取值：中文GB2312/GBK/GB18030、中文BIG5、英语、统一码UTF8。
存放路径 | 词典存放的路径，必须是系统配置中的数据和索引路径之一。不可修改。

公共属性

词典的公共属性。
公共检索 | 选中表示所有用户均可对该数据库进行检索，总是选中。
公共更新 | 选中表示所有用户均可对该数据库进行记录维护。
公共删除 | 选中表示所有用户均可删除该数据库。

如对词典的属性作了修改，按 [image] 将保存所作的修改 。


词典 访问权限

查看和修改词典的访问权限。词典的访问权限只有检索权限、更新权限和删除权限三种，词典没有字段级权限。
若当前属性窗口显示的对象为词典，直接选择菜单上的“文件|权限”命令，或按工具栏上的 FileRight.gif (947 bytes) 按钮，将会看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
用户组/用户 | 当前服务器上所有用户组/用户的列表。用户组/用户名前面的小图标表明了该用户组/用户的类型： Group.gif (905 bytes) 表示用户组、 DBA.gif (875 bytes) 表示全域管理员用户、 GDA.gif (879 bytes) 表示组管理员用户、 Resource.gif (875 bytes) 表示资源用户、 Connect.gif (878 bytes) 表示登录用户。
字段 | 对象名及其所有字段的列表。对词典对象该列表只有词典名。

访问权限 | 当前选中的用户组/用户对指定对象/字段的访问权限，包括以下所列几项。直接单击组里的复选框可修改所有处于选择状态的用户组/用户对所有选择的对象/字段的访问权限，不需按“确定”或“应用”即可立刻生效。。
检索权限 | 选中表示当前用户组/用户对词典有检索权限，总是被选中，不能修改。
更新权限 | 选中表示当前用户组/用户对词典有记录更新权限。
删除权限 | 选中表示当前用户组/用户对词典有删除权限。

按[确定]或[取消]将并关闭对话框。


数据格式属性

查看和修改数据格式的具体属性。
在对象管理窗口或者导航窗口里选中要查看属性的数据格式对象，属性窗口将会看到如下图：

属性框里各控制的说明如下：

控制名称 | 功能简介
内部编号 | 数据格式在系统中的内部标识号。
对象名称 | 数据格式的对象名，即数据格式名，是访问、维护和管理该数据格式的入口。数据格式名不能重复，并且只能由英文字母和数字组成。
所属分类 | 数据格式的分类名，可以从已存在的分类名中选择，或置为空。分类名长度不能超过15个字符。
对象类型 | 对象的类型，恒为“数据格式”。
后缀列表 | 数据格式所对应的文件的后缀名列表，多个后缀名间以半角分号、逗号或空格分隔，只能由英文字母和数字组成。
说明信息 | 不超过63个字符长度的数据格式说明信息。
无损压缩 | 选中表示对该格式的文件进行无损压缩。

如对数据格式属性作了修改，按 [image] 将保存所作的修改 。


用户组属性

查看和修改用户组的具体属性。
在导航窗口里选中要查看属性的用户组对象，属性窗口将会看到如下图：

属性框中各控制的说明如下：

控制名称 | 功能简介
内部编号 | 用户组在系统中的内部标识号。
对象名称 | 用户组的创建者，恒为“SYSTEM”。
对象类型 | 对象的类型，恒为“用户组”。
创建时间 | 用户组的创建时间。
修改时间 | 用户组的最后一次修改时间。
说明信息 | 不超过63个字符长度的用户组说明信息。
用户列表 | 点击 [image] 按钮将弹出用户列表选择对话框，对所属于当前用户组的用户进行选择或更改。

如对用户组属性作了修改，按 [image] 将保存所作的修改 。

用户列表选择对话框

以上对话框中各控制的说明如下：

控制名称 | 功能简介
已选用户 | 已选入新用户组的用户列表。可按 MoveRight.gif (925 bytes) 按钮从已选用户列表里清除。此操作将使选中用户脱离当前用户组。
可选用户 | 没有选入新用户组的用户列表。可按 MoveLeft.gif (925 bytes) 按钮加到已选用户列表里。此操作将使选中用户脱离原用户组，并加入到当前用户组中。

注意：点击[确定]后，对用户组的用户列表更改即已生效。不需要再点击属性窗口工具栏中的 [image] 按钮进行更改。


导航节点属性

查看和修改导航节点的具体属性。

在导航窗口里选中要查看属性的导航节点，属性窗口将会看到如下图：

属性框中各控制的说明如下：

控制名称 | 功能简介
筛选书签 | 定义当前筛选对象的节点名。长度在1-31个字符之间，不能包含半角冒号。
筛选条件 | 显示对象的筛选条件，可使用通配符：用'?'匹配单个字符，用'*'匹配任何字符。缺省为“*.*”，表示所有对象。
可检索 | 如选中表示只显示可以检索的对象。
可更新 | 如选中表示只显示可以更新的对象。
可索引 | 如选中表示只显示可以建立索引的对象。
可修改 | 如选中表示只显示可以修改结构的对象。
可删除 | 如选中表示只显示可以删除的对象。


用户属性

查看和修改用户的具体属性。
在导航窗口里选中要查看属性的用户对象，属性窗口将会看到如下图：

属性框里各控制的说明如下：

控制名称 | 功能简介

常规属性

用户的常规属性。
内部编号 | 用户在系统中的内部标识号。
对象名称 | 名称是用户对象名，即用户帐号名，也就是用户名。用户名与用户名之间，以及用户名与用户组名之间不能重复。
所在组 | 用户所在的组名，可以是已存在的用户组之一，也可以是空，表示不属于任何用户组。但一个用户只能属于一个组。
用户类型 | 用户的类型，有四种取值：系统数据库管理员(DBA)、用户组数据库管理员(GDA)、系统资源用户(Resource)、系统登录用户(Connect)。
创建时间 | 用户的创建时间。
修改时间 | 用户的最后一次修改时间。
说明信息 | 不超过63个字符长度的用户说明信息。

高级属性

用户的高级属性。
设置密码 | 用户的口令。为保密起见，输入字符以“*”显示。密码有效长度是1-31个字符。此控制项初始化为31个“*”，表示保持原密码。 若此控制项为空，表示没有密码。
确认密码 | 确认用户的密码，必须与设置密码一致。为保密起见，输入字符以“*”显示。
附加分词词典 | 用户缺省的附加分词词典名。创建该用户的数据库时，如不指定附加分词词典，则自动取此词典作为数据库的附加分词词典。
附加停用词典 | 用户缺省的附加停用词典名。创建该用户的数据库时，如不指定附加停用词典，则自动取此词典作为数据库的附加停用分词词典。
稀疏词典 | 用户缺省的稀疏词典名。创建该用户的数据库时，如不指定稀疏词典，则自动取此词典作为数据库的稀疏词典。
最大检索历史步数 | 用户在进行数据库查询时，需要保存的最大检索历史步数。保存的检索历史可以在以后检索中直接引用，而不需要重新检索。
最大下载记录数 | 用户在进行数据库查询时，允许一次下载的最大检索结果记录数。但该限制的实现需由具体的应用自己完成。
密级 | 密级定义了该用户在TRS系统的接触机密数据的级别。数值越小，级别越高。对于数据库中使用密级加密的数据记录，只有当用户的密级值不大于记录的密级值时，才能看到该记录的内容。0密级是一个特殊密级，表示该用户不能查看任何用密级加密的记录 。
登录互斥 | 选中表示不允许该用户同时从多个不同的IP地址进行登录，但来自本机IP地址的用户登录不计算在内。

如对用户属性作了修改，按 [image] 将保存所作的修改 。


视图属性

查看和修改视图的具体属性。
在对象管理窗口里选中要查看属性的视图对象，属性窗口将会看到如下图：

属性框中各控制的说明如下：

控制名称 | 功能简介

常规属性

视图的常规属性。
内部编号 | 视图在系统中的内部标识号。
对象名称 | 视图的对象名，即视图名，是访问、维护和管理该视图的入口。视图名不能与属于同一用户的其它视图、数据库以及各种词典同名。
拥有者 | 表明哪个用户拥有该视图。所有者与名称（别名）唯一确定一个视图对象。所有者对该视图能够进行任何操作，而不受其它数据安全控制的制约。
对象类型 | 对象的类型。
说明信息 | 不超过63个字符长度的视图说明信息。
创建时间 | 视图的创建时间。
修改时间 | 视图的最后一次修改时间。
字段数 | 视图的字段数。
数据库数 | 视图对应的源数据库数。

高级属性

视图的高级属性。
别名列表 | 视图的别名列表，多个别名之间以半角分号、逗号或空格分隔，长度不能超过63个字符。
记录选取条件 | 实际上是一个对该视图所包含的每个数据库进行检索的检索表达式。记录选取条件中的检索目标字段（包括缺省的目标字段）动态地对应于该视图所包含的每个数据库中的字段，而不是该视图的字段。如果从多个数据库中选取数据的条件不一致，则可在各个数据库中建立“空字段”（不存储任何数据的字段）进行相互映射，以保证选取条件中的字段在各个数据库中都存在。 其长度不能超过1023个字符。
源数据库集 | 视图对应的源数据库集。此处为只读选项，添加或删除源数据库在“视图结构”对话框中的添加新字段操作时进行。注意： 只有当所包含的数据库字段成为视图的源数据库字段以后，新增加的数据库才会保存入视图的源数据库列表中，否则在提交更新后，服务器会自动将其从源数据库列表中剔除。

公共属性

视图的公共属性。
公共检索 | 选中表示所有用户均可对该视图进行检索。
公共更新 | 选中表示所有用户均可对该视图进行记录维护（仅限自动模式视图）。
公共索引 | 选中表示所有用户均可对该视图的索引进行维护（仅限自动模式视图）。
公共修改 | 选中表示所有用户均可修改该视图的结构。
公共删除 | 选中表示所有用户均可删除该视图。

如对视图的属性作了修改，按 [image] 将保存所作的修改。


选择源数据库 对话框

选择当前视图对应的源数据库。

以上对话框中各控制的说明如下：

控制名称 | 功能简介
已选数据库 | 已选入视图源数据库集的数据库列表，源数据库数必须大于零。按 [image] 按钮把当前选中的数据库清除出源数据库列表，或用 [image] 和 [image] 按钮调整源数据库的前后顺序。
可选数据库 | 未选入视图源数据库集的数据库列表。双击数据库名或按 [image] 按钮 ，即可将选中的数据库加入源数据库列表。

注意：只有当所包含的数据库字段成为视图的源数据库字段以后，当前新增加的数据库才会保存入视图的源数据库列表中，否则在提交更新后，服务器会自动将其从源数据库列表中剔除。


选择源数据库字段 对话框

选择当前视图字段对应的源数据库字段。

以上对话框中各控制的说明如下：

控制名称 | 功能简介
已选数据库字段 | 已选入源数据库字段列表的字段。按 [image] 按钮将当前选中的字段从源数据库字段列表中清除，或用 [image] 和 [image] 按钮调整源数据库字段的前后顺序。
可选数据库字段 | 未选入源数据库字段列表的字段。在此控制上方的下拉框中选择源数据库，下方列表框将显示此数据库中当前可用类型的字段名，双击此字段名或按 [image] 按钮，即可将此字段加入到源数据库字段列表中。 此外，还可以点击旁边的 [image] 按钮弹出“选择源数据库”对话框，进行源数据库的选择。


视图 访问权限

查看和修改视图的访问权限。视图的访问权限有检索权限、修改权限和删除权限三种，字段只有检索权限。
若当前属性窗口显示的对象为视图，直接选择菜单上的“文件|权限”命令，或按工具栏上的 FileRight.gif (947 bytes) 按钮，将会看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
用户组/用户 | 当前服务器上所有用户组/用户的列表。用户组/用户名前面的小图标表明了该用户组/用户的类型： Group.gif (905 bytes) 表示用户组、 DBA.gif (875 bytes) 表示全域管理员用户、 GDA.gif (879 bytes) 表示组管理员用户、 Resource.gif (875 bytes) 表示资源用户、 Connect.gif (878 bytes) 表示登录用户。
字段 | 对象名及其所有字段的列表。

访问权限 | 当前选中的用户组/用户对指定对象/字段的访问权限，包括以下所列几项。直接单击组里的复选框可修改所有处于选择状态的用户组/用户对所有选择的对象/字段的访问权限，不需按“确定”或“应用”即可立刻生效。
检索权限 | 选中表示当前用户组/用户对数据库和指定字段有检索权限。
更新权限 | 选中表示当前用户组/用户对数据库有记录更新权限（仅限自动模式视图）。
索引权限 | 选中表示当前用户组/用户对数据库有索引维护权限（仅限自动模式视图）。
修改权限 | 选中表示当前用户组/用户对数据库有结构修改权限。
删除权限 | 选中表示当前用户组/用户对数据库有删除权限。

按[确定]或[取消]将并关闭对话框。


视图 结构信息

查看和修改视图的字段结构。
若当前属性窗口显示的对象为视图，直接选择菜单上的“文件|结构”命令，或点击工具栏上的 FileDesign.gif (948 bytes) 按钮，将会看到如下对话框：

视图字段列表控制里列出视图的所有字段。字段列表的每一行分别显示字段的名字、类型和说明，字段名前有 [image] 标志的字段为新增字段，有 [image] 标志的字段为视图进行全文检索的缺省全文字段名 ，不指定的话自动设为最后一个DOCUMENT字段（没有DOCUMENT字段的话则选择最后一个PHRASE字段）。用户可在字段列表上进行添加字段、修改字段属性、删除字段、为字段改名、调整字段顺序(仅限于新字段)等操作。视图字段列表控制的右上角有六个按钮，它们的作用分别如下：

添加新字段，点击后弹出“选择源数据库字段”对话框，对源数据库字段列表进行选择或更改。快捷键为Insert
删除当前选中字段，快捷键为Delete
为当前选中字段改名，快捷键为空格，直接在字段名上单击也能起到同样作用
当前选中字段位置上移，仅限于新字段，快捷键为Shift+↑
当前选中字段位置下移，仅限于新字段，快tan捷键为Shift+↓
把当前选中字段设为缺省字段，快捷键为Shift+空格

视图字段列表控制下面是字段属性框，属性框里的控制显示当前视图字段列表控制里选中的字段的各项属性，具体如下：

控制名称 | 功能简介
内部编号 | 视图字段在系统中的内部标识号，新字段不显示此属性。
别名列表 | 视图字段的别名列表，多个别名之间以半角分号、逗号或空格分隔。
显示标签 | 视图字段的显示标题，如不为空，概览时将作为列标题，细览时作为字段引导符。
源数据库字段列表 | 视图字段对应的源数据库字段列表，每个数据库字段名的表示方式为：“拥有者.数据库名.字段名”，源数据库字段数必须大于零。当视图字段对应多个源数据库字段时，这些源数据库字段的类型必须一致。按 [image] 按钮弹出“选择源数据库字段”对话框，对源数据库字段列表进行选择或更改。
显示大小 | 视图字段的显示宽度和高度。
缓冲数据 | 选中表示允许进行检索缓冲，缓冲可以提高检索时有关操作的速度。此开关决定该字段的“数据”是否集中存储，并在“检索缓冲”启动的情况下时，允许进入内存缓冲。虽然所有类型的字段都允许进行缓冲，但DOCUMENT和BIT类型的字段只存储一个标志，表示字段是否有值，而不是存储实际的字段值。此属性只有自动模式视图拥有。
允许相关性排序 | 选中表示检索命中该字段时，该字段参与相关性排序，缺省为清除。对BIT字段该开关无效。此属性只有自动模式视图拥有。
公共检索 | 选中表示所有用户均可对本视图字段进行检索。

如对视图的字段结构作了修改，按[确定]将保存所作的修改并关闭对话框。


导航|添加导航

新建具有筛选功能的导航节点。

点击此命令后，将在当前节点下新建一个子节点，节点名为“新节点N”，节点对应的名称、筛选条件及其他属性可在下方的属性窗口中进行修改。添加筛选条件后，再次点击此新建节点将在右部的对象管理窗口中显示符合此筛选条件的对象列表。


导航|查看源文件

打开查看当前用户列表树对应的导航文件。

导航文件中存储了用户列表树中各导航节点的属性，用户可以查看或根据自己的需要修改列表树的各属性。


查看|显示方式 命令

改变对象管理窗口的显示方式，有四种选择：大图标、小图标、列表和详细信息。


细览|直接浏览 命令

直接显示记录所带的附件。
此按钮处于按下状态时，点击记录时将直接显示该记录所带的附件，或者弹出对话框询问用户是否打开或保存所带的附件，选择[打开]，将在细览窗口中直接打开此附件，选择[保存]，则可将此附件保存到指定的目录中。


细览|主页 命令

返回显示细览字段和附件列表的主页。
在此版本中，细览窗口直接用浏览器的方式对细览字段进行显示 ，记录包含的图片被直接显示，记录包含的其他类型的附件以链接的方式显示。如果当前显示的是记录所带附件，点击此命令按钮，将返回显示细览字段和附件列表的主页。


细览|显示图片 命令

直接显示记录所带的jpg或者gif类型图片。
此按钮处于按下状态时，点击记录将直接显示该记录所带的jpg或者gif类型图片，若是其他类型的图片还是显示其链接；若此按钮未按下，点击记录时则只显示连接而不显示实际的图片。


细览|停止 命令

停止显示当前件附件。
在显示当前记录所带附件时，若附件过大或过多，显示时间较长，可点击此命令停止显示当前附件。


表单|放弃 命令

放弃当前所做修改并返回原先的浏览状态。
不论当前是对字段具体的值进行的修改还是对编辑框的大小位置所做的修改，点击此命令都会撤销这些修改并返回原先的浏览状态。


表单|设计 命令

对当前窗口中各编辑框的大小及位置进行修改。
此按钮按下时，所有编辑框变灰，表单窗口处于控件设计状态。点击某一个编辑框，可对其大小进行改变或者随意拖动其位置。修改完以后点击 [image] 按钮即可保存这些设置，下次再打开此对象的表单窗口时，将自动恢复上一次对各编辑框的设置。


表单|保存 命令

保存当前所做的修改并返回原先的浏览状态。
当 [image] 按钮处于按下状态时，当前所有的编辑框变灰，表单窗口处于控件设计状态，若此时点击此命令，对各个编辑框的大小、位置所做的修改将被写入文件保存起来，下一次再打开此对象的表单窗口时，将自动恢复上一次对各编辑框的设置。


导航|自动生成 命令

根据某一字段自动生成导航项。
在导航窗口的快捷菜单里选择“自动生成”命令，或者点击工具栏 [image] 按钮，将看到如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
查询条件 | 查询表达式。可为“目标词”或“函数名(目标词, …)”形式，其中“目标词”既可是一个确定的词汇或字段值，也可是一个符合TRS规范的模糊词汇或模糊字段值。按右边的 Select.gif (956 bytes) 按钮进行索引词查询，并把结果显示在结果列表里。若此操作费时较长，可在过程中按Ctrl+Break中断操作。
显示个数 | 显示结果的个数，缺省为“选项|集成环境”里设置的每页显示词语数。
结果列表 | 查询结果的词语列表，每个索引词显示其词语、命中数、词频数和它相对于主题词的深度。该结果集里的所有词语将作为自动生成的导航树的节点。按右上角的 [image] 和 [image] 按钮可调整当前选择词语位置 ； 按 [image] 按钮为当前 词语改名，即当前词语作为导航节点时以新的名字表示；按 [image] 按钮把当前词语从结果集里删除，即不把它作为导航节点。点击“词语”和“命中数”标题可进行排序，三角形尖角向上表示升序，尖角向下表示降序。
查询对象 | 待查询的目标对象名。改变查询对象将重新检索索引词并刷新检索列表。
查询字段 | 待查询的字段名，不包括DOCUMENT型、BIT型和PHRASE型字段。改变查询字段将重新检索索引词并刷新检索列表。
继承父节点 | 选中表示生成的所有子节点自动继承当前根节点的检索条件。
二级导航 | 进行再次检索时依据的字段。再次检索即在当前根节点检索条件得到的检索结果中根据二级导航节点再次进行检索。只有当“继承父节点”选中时此控制项才能进行选择。
分类条件 | 二次检索时只需关注的字段值， 比如上图所示，即，二次检索时只生成检索条件为“版名=要闻”的导航节点。输入时每个值为一行（注意不是用其它符号作为分隔符）。如果为空，则缺省为依据字段字段的所有字段值。
正则表达式 | 选中表示通过正则表达式从所有字段值中选取符合条件的字段值作为目标类别，并容许抽取某些匹配项进行组合而形成新的类别。正则表达式的具体规则见《TRSDatabase6.doc》4.2节。
区分大小写 | 选中表示检索的字段值区分大小写。

把查询结果调整到符合自己的要求以后，按[确定]将关闭对话框，并在导航窗口的当前节点下自动生成导航树。按[取消]将关闭对话框而不做任何操作。


导航|清除导航 命令

删除当前对象对应的导航文件。
因导航文件记录了当前对象对应的导航节点、显示标题、编辑框位置及大小等信息，点击此命令后，对应的导航节点将被删除，上述各值也将会归为默认值。


导航|删除 命令

删除当前导航节点。
在导航窗口的快捷菜单里选择“删除”命令，或按Delete键，TRS管理员将提示是否删除当前导航节点。确认后，当前导航节点将从导航树里删除（注意：不能删除根节点）。如所删节点为组节点，则它包含的所有叶节点也将被删除。导航的修改结果会被保存到文件里，并对下一次打开生效。


导航|载入 命令

从外部文件里导入导航信息。
在导航树根节点的快捷菜单里选择“载入”命令，或者点击工具栏 [image] 按钮，TRS管理员将弹出“选择导航文件”对话框提示用户选择要载入的导航文件名，选择完毕后按“确定”，TRS管理员将读入该文件，并刷新当前浏览窗口的导航信息和导航树。


导航|添加导航 命令

添加新导航项。
在导航窗口的快捷菜单里选择“添加”命令，或按Insert键，在导航树中将增加一个新节点，节点名默认为“新节点n”，可按 [image] 按钮进行改名，下方属性窗口会显示相应的各项配置，可在其中对新节点的各个属性进行设置 ，设置完以后点击 [image] 按钮即可保存。

如当前导航节点为组节点，则新节点将添加到当前组节点的最后；如当前导航节点为叶节点，则新节点将添加到当前节点的下面。导航节点的属性将被保存到文件里，并对下一次打开生效。


导航|下移 命令

导航|上移 命令

当前导航节点位置上移。
在导航窗口的快捷菜单里选择“上移”命令，或按Shift+↑键，TRS管理员将把当前节点上移一个位置。导航的修改结果会被保存到文件里，并对下一次打开生效。


导航|上移 命令

导航|下移 命令

当前导航节点位置下移。
在导航窗口的快捷菜单里选择“下移”命令，或按Shift+↓键，TRS管理员将把当前节点下移一个位置。导航的修改结果会被保存到文件里，并对下一次打开生效。


导航|导出 命令

把导航信息存储到外部文件里。
在导航树根节点的快捷菜单里选择“导出”命令，或者点击工具栏按钮 [image] ，TRS管理员将弹出“选择导航文件”对话框提示用户选择要导出的导航文件名，输入完毕后按“确定”，TRS管理员将把当前的导航信息和导航树写入到指定的文件里。


导航|重命名 命令

重命名当前导航节点。
在导航窗口的快捷菜单里选择“重命名”命令，或按空格键，TRS管理员将在当前节点的位置显示一个编辑框 ，输入新导航书签以后按回车；或者直接在属性窗口的“导航标签”属性项中进行修改，修改后点击工具栏按钮 [image] ，当前导航节点的书签将被修改为新值。导航的修改结果 将被保存到文件里，并对下一次打开生效。


导航|查看源文件

打开查看当前导航树对应的导航文件。

导航文件中存储了导航树中各导航节点的属性，用户可以查看或根据自己的需要修改导航树的各属性。


添加字段值 命令

选择需要更新的字段及对应的字段值。

对话框中各控制的说明如下：

控制名称 | 功能简介
字段名 | 从下拉列表里选择需要更新的字段名。
字段值 | 输入字段对应的字段值。
浏览 | 点击打开“选择文件”对话框选择DOCUMENT/BIT型字段对应的文件。


选择文件 命令

选择DOCUMENT/BIT型字段对应的文件。

对话框中各控制的说明如下：

控制名称 | 功能简介
原始文件 | 点击按钮 [image] 选择需要的文件，可以同时多选。
文件格式 | 原始文件存储的文件格式。
存储方式 | 文件存储的方式。


检索|检索选项 对话框

检索选项 对话框

设置检索的高级选项。
在“高级检索/排序”对话框里，按[选项]按钮，或者在导航节点的“缺省字段及选项”属性项中，点击 [image] 按钮，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
缺省目标字段 | 检索条件表达式中缺省字段的子检索表达式的目标字段名集列表以及字段间的逻辑关系。
字段列表 | 检索条件表达式中缺省字段的子检索表达式的目标字段名集列表，字段名之间以半角分号分隔。为空表示在数据库的数据词典中指定的字段上进行检索；为‘*’表示在所有DOCUMENT字段和所有PHRASE字段上同时进行检索。 点击 [image] 按钮，可弹出选择缺省字段对话框，对缺省字段进行选择。
逻辑关系 | 检索条件表达式中缺省字段的子检索表达式的目标字段名集各字段间的逻辑关系，可为：与、或、非、异或四种方式之一。
  优先于表达式中的逻辑 | 缺省字段检索的字段逻辑优先于检索表达式中的逻辑。

自动扩展检索 | 利用知识辅助词典自动进行知识扩展检索的词典和选项。
主题词典 | 利用知识辅助词典自动进行知识扩展检索时的主题词典。
同义词典 | 利用知识辅助词典自动进行知识扩展检索时的同义词典。
反义词典 | 利用知识辅助词典自动进行知识扩展检索时的反义词典。
同义词 | 选中表示自动进行“同义词”扩展检索。
反义词 | 选中表示自动进行“反义词”扩展检索。
等同词 | 选中表示自动进行“等同词”扩展检索。
替代词 | 选中表示自动进行“替代词”扩展检索。
缩略词 | 选中表示自动进行“缩略词”扩展检索。
被缩略词 | 选中表示自动进行“被缩略词”扩展检索。
相关词 | 选中表示自动进行“相关词”扩展检索。
上位词 | 选中表示自动进行“上位词”扩展检索。
下位词 | 选中表示自动进行“下位词”扩展检索。
所有上位词 | 选中表示自动进行“所有上位词”扩展检索。
所有下位词 | 选中表示自动进行“所有下位词”扩展检索。
同根词 | 选中表示自动进行“同根词”扩展检索。
外文等同词 | 选中表示自动进行“外文等同词”主题控制扩展检索。
全角/半角 | 选中表示自动进行“半角/全角字符”扩展检索。
简体/繁体 | 选中表示自动进行“中文简体/繁体”扩展检索。

估算/加权选项　 | 估算检索和加权系数选项。
估算分段单位 | 使用估算检索模式，其值为数据的分段单位(记录数)。
估算终止条件 | 使用估算检索模式，其值为检索终止条件(记录数)。
标题加权系数 | 命中点在标题(第0段/第0句)位置上的加权系数(倍数)。
知识扩展权重 | 知识扩展检索(主题/同义/反义)词的权重系数(百分比)。
命中分支权重 | 命中分支数的权重系数。

命中点存储方式 | 不同的命中点存储模式，不但影响检索速度，还会影响相关性排序结果。
检索超时时间 | 检索的超时时间(秒数，不能大于系统的的超时时间设置)。如果值为0，表示使用系统的的超时时间设置。
集群裁减设置 | 集群对后台检索结果的裁减设置，仅在所登录的服务器为集群时才有效，按右边的 [image] 按钮可打开对话框进行设置。0表示不作限制；1~9表示集群至少需要等待相应数量的后台返回结果；10~99表示集群至少需要等待相应比例的后台返回结果；100及以上表示至少需要返回的结果记录数。
中断时输出部分结果 | 选中表示当检索过程被中断时也输出已经得到的部分检索结果，否则按出错处理。
忽略不存在的索引属性 | 对于不存在的索引属性，简单地忽略，不按出错处理。

设置好缺省目标字段和自动扩展检索选项以后，按[确定]保存这些选项并关闭对话框，所设选项将用于以后所有的检索操作中。如不想改变原有选项，按[取消]键关闭对话框。


选择排序方式 对话框

设置排序方式和选项，在“高级/检索排序”、“分类统计”、“复制记录”等对话框里，按 Order.gif (957 bytes) 按钮，或者在导航节点的排序方式属性项中，点击 [image] 按钮，将弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
排序字段 | 可以作为排序字段的字段列表，包括检索目标的所有共同非正文/二进制字段（字段名和类型都一样）和RELEVANCE（相关排序）。选择字段名，然后点击旁边的 Order.gif (957 bytes) 按钮 可把该字段的排序方式设为升序（前面显示 [image] 图标，RELEVANCE除外）；点 Order.gif (957 bytes) 设为降序（前面显示 [image] 图标）；对于NUMBER字段点 Order.gif (957 bytes) 按钮可把该字段设为按相关性排序时将相关度调整为“计算所得相关度值 * 该字段的值”（前面显示 [image] 图标）；对DATE字段点 Order.gif (957 bytes) 按钮则弹出“分级排序”对话框，分别设置小时、天、周（顺序无关，内部将自动调整），表示以当前日期为起点，将记录中的日期字段值分级进行降序排序（前面显示 [image] 图标）。用 Order.gif (957 bytes) 和 Order.gif (957 bytes) 按钮可调整已选字段的顺序。 若字段前无任何图标，则表示此字段与排序方式无关。
裁减记录 | 存储之前完成排序，并只存储排在前面的部分记录，同时自动设置“非精确命中点”模式。0表示由系统配置决定，缺省是不进行裁减。如果值等于65535，则表示忽略系统配置，关闭排序裁减功能。
有效记录 | 即部分排序，只保证前一部分记录是有序的。0表示由系统配置决定，缺省是全部排序。如果值等于65535，则表示则表示忽略系统配置，关闭部分排序功能。
中文排序 | 中文的排序方式，可选择按内码、拼音、多音字拼音或笔画数排序。
相关性计算 | 不同的相关性的计算模式和IDF模式组合下会有不同的排序结果。 分为7种情况：由系统配置决定；忽略词的位置和使用基于单个数据库范围的IDF值；忽略词的位置和词IDF值不参与相关性计算；考虑词的位置和使用基于单个数据库范围的IDF值；考虑词的位置和词IDF值不参与相关性计算；用一个记录中命中词的单位向量长度（每个命中词只计算一次）作为记录的相关；用一个记录中命中词的单位向量长度，以及命中词的词频和作为 记录的相关度。
表达式中多字段的加权表示优先顺序 | 相关性排序时表达式中多字段的加权表示优先顺序。
大小写无关 | 选中表示忽略大小写。
后进先出 | 选中表示按记录的物理记录号的降序排列，不能和其它排序方式混用。


检索|表达式生成器 对话框

表达式生成器 对话框

帮助用户生成检索表达式或者统计条件，对初学者尤为有用。根据当前焦点停留的编辑框的不同，弹出的表达式生成器显示不同的生成条件。
在“高级检索/排序”对话框里，按[表达式]按钮，或者“复制记录”对话框和“新建导航文件”对话框里，按 [image] 按钮，或者在导航节点的“检索条件”\“统计条件”属性中，点击 [image] 按钮， 都会弹出此对话框。

若当前焦点停留的编辑框为“检索条件”编辑框，表达式生成器如下图所示：

若当前焦点停留的编辑框为“统计条件”编辑框，表达式生成器如下图所示：

对话框中各控制的说明如下：

控制名称 | 功能简介
表达式 | 生成的检索表达式或者统计条件。
运算符按钮 | 从 Plus.gif (887 bytes) 到 Bracket.gif (889 bytes) 为常用的运算符按钮，按下按钮会把相应运算符复制到表达式编辑框里。
字段名 | 检索目标的所有共同字段（字段名和类型都一样）列表。双击可把字段名复制到表达式编辑框里。
运算符/函数 | TRS的运算符和函数列表。运算符分为 逻辑运算符、重复逻辑运算符、属性运算符、限定运算符，函数分为检索函数和词典函数；当生成统计条件时函数为统计函数。双击文件夹可显示该项包含的所有运算符/函数列表，再双击某一项则可把该运算符/函数复制到表达式编辑框里。
历史检索表达式 | 历史检索表达式列表，列出最近用到的20个检索表达式，双击可把检索历史项复制到表达式编辑框里。 当生成统计条件时此列表框无用。

生成合适的检索表达式或统计条件后，按[确定]，将关闭“表达式生成器”对话框并把检索表达式或统计条件复制到相应对话框的检索条件编辑框 或统计条件编辑框里。按[取消]则关闭对话框。


新建|批装库文件

创建批装库文件。批处理数据文件实际上是存储一批数据记录文件名的文件。。
 选择“文件|新建”命令，在“新建”对话框里双击批装库文件图标，TRS管理员打开如下“创建批装库文件”对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
数据文件 | 待生成批装库文件的文件列表。按 [image] 按钮可添加装库数据文件或批装库文件，按 [image] 按钮可添加某个目录下的所有装库文件，按 [image] 按钮可删除选定的文件/目录，用 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮可调整文件/目录的顺序。单击列表中的某一项可修改该文件/目录名。

设定好各项的内容以后，按[确定]，TRS管理员将生成批装库文件模板并打开文件编辑窗口。按[取消]则放弃生成模板。如上例生成的装库数据文件如下：

D:\Temp\Load\Patent.trs
D:\Temp\Load\BJWB.trs
D:\Temp\demo.trs
D:\Temp\Demo\RMRB2000.trs
D:\Temp\Demo\RMRB2001.trs
D:\Temp\Demo\RMRB2002.trs

用户可以根据需要对此模板进行编辑（添加、删除、修改装库数据文件），然后把它保存到文件里。


新建|控制文件

创建控制文件。控制文件用来控制数据的加载过程的配置文件，通过配置控制文件的变量，可以触发系统的内部功能，或改变系统的运行方式。
 选择“文件|新建”命令，在“新建”对话框里双击数据文件图标，TRS管理员打开如下“创建数据文件”对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
通用参数
记录格式 | 数据记录文件的格式，缺省为标准TRS格式。
缺省格式 | 数据记录文件中BIT字段值文件的缺省数据格式名，缺省为BIT。
缺省HREF

指明DOCUMENT字段引用的HTML格式的字段值文件中BASE元素的缺省HREF属性值，只对DOCUMENT字段的HTML字段值有效，显式BASE控制符优先于该变量。此变量没有缺省值。

缺省路径 | 数据记录文件中字段值所引用的数据文件的缺省路径，缺省为当前数据文件所在目录。
字段列表 | 需要加载数据的字段名列表，缺省为全部字段。可按编辑框右边的 [image] 按钮来选择字段列表。
标记前缀 | TRS标记引导符前缀，缺省为空。
高级参数
起始记录 | 在数据记录文件中数据加载的起始记录号，缺省为1。
最大记录 | 需要加载的最大记录数，缺省为全部记录。
每批提交 | 加载时分批提交的最大记录数，缺省为5000。
最大错误 | 加载时允许错误记录的最大个数，缺省为没有限制。
缺省世纪 | 数据记录文件中DATE字段值的年份的缺省世纪数，缺省为当前世纪。
多值分隔 | 数据记录文件中多值字段DATE、NUMBER、CHAR、BIT的各个字段值之间的分隔符，缺省为单字节“;”。
检查重复文本字段 | 是否允许在数据记录文件中同一个PHRASE或DOCUMENT字段在同一个记录中重复出现的开关。如果数据记录文件的格式是ISO2709或XML，则缺省值为JOIN1，否则为FALSE。

装库标志
忽略记录加密 | 是否忽略数据记录文件中的记录加密描述符的开关，缺省为清除。
后缀决定文件格式 | 当数据记录文件中所引用的字段值文件未指定数据格式控制符时，用文件名的后缀来确定其数据格式的开关，缺省为设置。
同步建立索引 | 在加载数据的同时建立索引的开关，缺省为设置。
保持文本数据空白 | 是否保持PHRASE和DOCUMENT字段值文本中首尾空白行的开关，缺省为设置。
分类存储BIT字段 | 是否分类存储BIT字段值的开关，缺省为设置。
分类存储DOC字段 | 是否分类存储DOCUMENT字段值的开关，缺省为设置。
不存Office文本 | 是否丢弃由OEM过滤器所生成的文本数据的开关，缺省为设置。
不存储附加文件 | 在数据记录文件中，DOCUMENT字段值的附加文件是否存储在数据库中的开关，缺省为清除。
允许自动匹配字段 | 是否允许自动匹配入库字段，缺省为清除。
以ISO2709映射字段 | 是否以ISO2709格式的目录标记（以及数据标识符）映射入库字段，缺省为清除。

XML参数
分段标记 | XML数据作为一个字段值入库时，过滤器进行自动分段的标记。
分句标记 | XML数据作为一个字段值入库时，过滤器进行自动分句的标记。此功能为TRS全文数据库6.50.4000版本新增。
换行标记 | XML数据作为一个字段值入库时，过滤器进行自动换行的标记。
命中点标记 | XML数据作为一个字段值入库后，检索命中点的指示标记。
CDATA标记 | XML数据作为一个字段值入库时，过滤器是否处理标记中的内容，缺省值为FALSE。
覆盖过滤器指令 | XML数据作为一个字段值入库时，是否需要覆盖数据中已有的关于过滤器的处理指令，缺省为清除。

以上控制变量并不要求全部设置，只须修改需要设置的参数，其它项会自动取缺省值，按[重置]也可把所有选项设回缺省值。设定好各项的内容以后，按[确定]，TRS管理员将生成装库数据文件模板并打开文件编辑窗口。按[取消]则放弃生成模板。如上例生成的装库控制文件如下：

RECORD_FILE_FORMAT= STANDARD
BIT_FORMAT_DEFAULT= BIT
HTML_BASE_DEFAULT=
DATA_PATH_DEFAULT= C:\Temp
SECTION_TAG_PREFIX=
DATE_CENTURY_DEFAULT=
MULTI_VALUE_SEPARATER= ;
START_RECORD_FROM= 1
PROCESS_RECORD_NUMBER= 10000
MAX_COMMIT_NUMBER= 4000
MAX_ERROR_NUMBER= 1000
IGNORE_RECORD_CRYPT= FALSE
FILE_SUFFIX_PRIOR= TRUE
SYNC_CREATE_INDEX= TRUE
CLASS_BIT_STORE= TRUE
CLASS_DOCUMENT_STORE= TRUE
KEEP_TEXT_ACTUAL= TRUE
CHECK_TEXT_ITERATIVE=
WAIVE_OEMFILTER_TEXT= TRUE
WAIVE_DOCUMENT_AFFIX= FALSE
COLUMN_AUTO_MATCH= FALSE
NAMIZE_ISO2709_FIELD= FALSE
COLUMN_NAME_SEQUENCE= 日期;版次;版名;栏目;标题;作者;正文;图像
XML_SEGMENT_MARK=
XML_NEWLINE_MARK=
XML_HITSHOW_MARK=
XML_FILTER_CDATA= false
XML_OVERWRITE_PI= FALSE

用户可以根据需要对此模板进行编辑（修改控制变量的值），然后把它保存到文件里。


新建|数据文件

创建装库数据文件。装库数据文件是用来存放待加载的数据的文件。
 选择“文件|新建”命令，在“新建”对话框里双击数据文件图标，TRS管理员打开如下“创建数据文件”对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
装库目标 | 装库文件对应的目标数据库/自动模式视图名。
装库字段 | 选定作为装库字段的字段列表。
可选字段 | 可以作为装库字段的字段列表，初始为当前对象中的所有字段。可用 MoveRight.gif (925 bytes) 按钮加入已选字段列表。
已选字段 | 已选择作为装库字段的字段列表，可用 MoveLeft.gif (923 bytes) 按钮把当前选中字段清除出已选字段列表，或用 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮调整装库字段的顺序。

设定好各项的内容以后，按[确定]，TRS管理员将生成装库数据文件模板并打开文件编辑窗口。按[取消]则放弃生成模板。如上例生成的装库数据文件如下：

<REC>
<日期>=
<版次>=
<版名>=
<标题>=
<作者>=
<正文>=

用户可以根据需要对此模板进行编辑（填入相应的字段值以及增加记录等），然后把它保存到文件里。


新建|文件

创建新的文本文件。
当前窗口为文件编辑窗口时，按工具栏上的“新建”按钮，将直接打开一个空的文本编辑窗口。


新建|导航文件

创建导航文件。导航文件是建立位于浏览窗口左侧的导航窗口内的树型数据导航而用的。
选择“文件|新建”命令，在“新建”对话框里双击导航文件图标，TRS管理员打开如下“创建导航文件”对话框：

对话框里各控制的说明如下：

控制名称 | 功能简介
源对象名 | 创建导航的对象名，可为数据库或视图。
窗口标题 | 导航文件对应的记录维护窗口的标题，如不指定则自动取对象名作为标题。
概览字段 | 浏览时以概览方式显示的字段列表，字段名间以“;”分隔。可按编辑框右边的 Select.gif (956 bytes) 按钮来选择字段列表。如概览和细览字段都没有指定则浏览时自动取所有DATE、NUMBER、CHAR、PHRASE型字段作为概览字段。
细览字段 | 浏览时以细览方式显示的字段列表，字段名间以“;”分隔。可按编辑框右边的 Select.gif (956 bytes) 按钮来选择字段列表。如概览和细览字段都没有指定则浏览时自动取所有DOCUMENT和BIT型字段作为细览字段。
记录范围 | 浏览时显示的逻辑记录范围，可用“起始记录号-终止记录号”的方式表示一定范围的记录，或仅用单个数字表示一条记录，多个分段之间以“,”分隔，各分段不能重叠。可按编辑框右边的 Select.gif (956 bytes) 按钮来设置记录范围。如不指定则显示检索结果集里的所有记录。

导航列表 | 本导航文件所包含的导航项的列表。下方列表框里列出了各个导航项的标题及对应的检索条件。按 [image] 按钮弹出“自动生成导航”对话框，帮助用户生成导航列表 ，此种情况下只能生成一级导航；按 [image] 按钮删除当前导航项。按 MoveUp.gif (917 bytes) 和 MoveDown.gif (918 bytes) 按钮调整导航 项的顺序。

显示方式 | 浏览窗口显示的模式。
缺省方式 | 根据字段的类型决定显示的方式，为缺省设置。
只有概览 | 只显示窗口的概览部分，隐藏细览部分。
只有细览 | 只显示窗口的细览部分，隐藏概览部分。
上下分隔 | 在浏览窗口的上部显示概览，窗口下部显示细览。
表单编辑 | 每一个字段对应一个编辑框，可直接在编辑框里修改字段值。

显示导航 | 选中表示显示导航窗口，否则为隐藏。缺省为显示。
显示属性 | 选中表示显示属性窗口，否则为隐藏。缺省为显示。

设定好各项的内容以后，按[确定]，TRS管理员将生成导航文件模板并打开文件编辑窗口。按[取消]则放弃生成模板。如上例生成的导航文件如下：

' SYSTEM.DEMO2
:WindowTitle= 人民日报演示库
:SummarySet= 日期;版次;版名;栏目;标题;作者
:DetailSet= 正文;图像
:RecBounds= 1-1000
:DisplayMode= 0
:ShowNavigate= TRUE

0+
1- 版名: 版名=''

其中，以“'”开头的为注释行（如第一行），以“:”开头的为参数定义行，最后一个参数定义行以下为导航树定义部分。导航树定义的每一行均以数字开头，数字表示该行所处的层次（0表示根节点），其后跟节点状态表示符（“+”表示打开的文件夹，“-”表示关闭的文件夹，没有表示为页节点），状态表示符以后到“:”前为节点标题，“:”之后为检索条件，检索条件以后还可以带“#sort=”子句指定排序方式。用户可以根据自己的需要定义相应的导航树，然后保存到系统指定的导航目录里，也可以在记录维护窗口里联机编辑导航树。


新建|脚本文件

创建TRS命令语言（简称TRSL）脚本文件。
脚本文件提供了以批方式操纵TRS数据库的灵活手段，文件中可以存放数量不限的TRSL语句（包括可执行语句如SELECT、INSERT等及非执行语句如REM、SPOOL等），每个TRSL语句必须以单字节分号(;)结束，最后一个TRSL语句可以没有分号结束符。

选择“文件|新建”命令，在“新建”对话框里双击脚本文件图标，将会打开一个空白的文件编辑窗口。用户可打开命令语言处理工具，并用RUN语句运行该文件。


新建|文本文件

创建文本文件。
选择“文件|新建”命令，在“新建”对话框里双击文本文件图标，或者在当前窗口为文件编辑窗口时，按工具栏上的 FileNew.gif (923 bytes) 按钮，将会打开一个空白的文件编辑窗口。


查看|背景颜色 命令

改变窗口的背景颜色。
选择“查看|背景颜色”命令后，TRS管理员弹出如下对话框：

对话框中各控制的说明如下：

控制名称 | 功能简介
基本颜色 | 显示可用的基本颜色，单击可选择为背景颜色。
自定义颜色 | 显示已定义的自定义颜色，单击可选择为背景颜色。如要增加自定义颜色，请按[规定自定义颜色]按钮，并在颜色阵列中选择需要的颜色，然后按[添加到自定义颜色]按钮。

选择好字体颜色以后按[确定]，将关闭对话框并以新颜色作为文件编辑窗口的背景，所设颜色将对以后打开的所有文件编辑窗口有效。按[取消]则关闭对话框但不改变背景颜色。