概述

概述 软件包 类 使用 树 索引 帮助
上一个 下一个 框架 无框架
软件包
com.trs.was
com.trs.was.config
com.trs.was.tree

概述 软件包 类 使用 树 索引 帮助
上一个 下一个 框架 无框架


上一个 下一个 框架 无框架

所有软件包的分层结构

软件包分层结构：
com.trs.was, com.trs.was.config, com.trs.was.tree

类分层结构

  • java.lang.Object
    • com.trs.was.config.AppConfig
    • com.trs.was.config.ConfigData
    • com.trs.was.config.DataSource
    • com.trs.was.config.FieldData (implements java.lang.Cloneable)
    • com.trs.was.config.LoginConfig (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • com.trs.was.config.MapDataSource
    • com.trs.was.config.MapFieldData (implements java.lang.Cloneable)
    • com.trs.was.tree.MapTree
      • com.trs.was.config.MapChannel
      • com.trs.was.config.MapGroup
    • com.trs.was.tree.Node (implements java.lang.Cloneable)
      • com.trs.was.config.ChannelNode
      • com.trs.was.config.WASGroup
    • com.trs.was.config.RequestOperation
    • com.trs.was.config.SearchData
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.was.config.WASException
    • com.trs.was.tree.Tree
      • com.trs.was.config.ChannelTree
    • com.trs.was.WASResultSet
    • com.trs.was.config.WASRole
    • com.trs.was.WASTools
    • com.trs.was.config.WASUser (implements java.lang.Cloneable, java.io.Serializable)
概述 软件包 类 使用 树 索引 帮助


com.trs.was

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.was

类摘要
WASResultSet | WAS结果集对象
WASTools | WAS工具类。

概述 软件包 类 使用 树 索引 帮助
上一个软件包 下一个软件包 框架 无框架


com.trs.was 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.was 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.was.WASResultSet
    • com.trs.was.WASTools
概述 软件包 类 使用 树 索引 帮助


软件包 com.trs.was 的使用

上一个 下一个 框架 无框架

软件包 com.trs.was
的使用

使用 com.trs.was 的软件包
com.trs.was

com.trs.was 使用的 com.trs.was 中的类
WASResultSet
WAS结果集对象

概述 软件包 类 使用 树 索引 帮助


WASResultSet

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was
类 WASResultSet

java.lang.Object
    继承者  com.trs.was.WASResultSet

public class WASResultSet
extends java.lang.Object

WAS结果集对象

构造函数摘要
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)
方法摘要
void | close() 关闭WAS结果集.
int | getBinaryObjectCount(java.lang.String strColumnName) 获得指定字段二进制对象的个数。
int | getBinaryObjectRealCount(java.lang.String strColumnName) 获得指定字段二进制对象的个数。
java.io.InputStream | getBinaryStream(java.lang.String strColumnName, int iMultiIndex) 获得当前记录指定字段名称和多值序号的对象的输入流对象。
byte[] | getBytes(java.lang.String strColumnName, int iMulti) 获取字段内容的字节数组
java.lang.String | getChannelID() 获取频道ID
int | getColHitNum(java.lang.String strColumn) 获取字段命中点数
int | getColumnMultiValue(java.lang.String strColumnName) 获取字段的多值个数
int | getColumnType(java.lang.String strColName) 获得当前记录中指定字段的类型。
java.lang.String | getContentType(java.lang.String strColumnName, int iMultiIndex) 该方法返回当前记录的二进制字段的指定对象的 ContentType
java.lang.String | getDate(java.lang.String strColumnName, java.lang.String strFormat) 获取日期字段指定格式的内容
java.lang.String[] | getDetailFields() 获得检索结果对象对应的频道的细览字段
java.lang.String[] | getDownloadFields() 获得检索结果对象对应的频道的下载字段
java.lang.String | getFile(java.lang.String strColumnName, int iMultiIndex) 获得指定二进制字段的文件名。
float | getFloat(java.lang.String strColumnName) 获取指定NUMBER字段FLOAT类型内容
long | getHitNum() 获取命中点个数
int | getInt(java.lang.String strColumnName) 获取指定NUMBER字段INT类型内容
java.lang.String | getLicenseCode() 获取连接许可证
java.lang.String[] | getMailFields() 获得检索结果对象对应的频道的推荐字段
java.lang.String | getPrimaryKey() 获得当前检索结果集的主键
java.lang.String | getPrimaryKeyPair() 获得当前检索记录的主键名值对
long | getRecordCount() 获取命中记录数
double | getRelevance() 获取当前记录的相关度
double | getSearchTime() 获取检索耗时
java.lang.String | getSearchWord() 获取检索条件表达式
java.lang.String | getSources() 获取检索对象列表
java.lang.String | getString(java.lang.String strColumnName) 获得指定字段的字段值内容
java.lang.String | getString(java.lang.String strColumnName, java.lang.String strHitColor, int iCutSize) 获取指定字段带命中点反显标记的内容
com.trs.client.TRSConnection | getTRSConnection() 获取TRS连接对象.
com.trs.client.TRSConnection | getTRSReConnection(java.lang.String strLicenseCode) 利用系统许可证获取TRS连接.
com.trs.client.TRSResultSet | getTrsRS() 获取TRSResultSet对象
boolean | moveTo(int iMoveFlag, long lNewNo) 移动到检索结果记录集的指定记录
void | setChannelID(java.lang.String strChannelID) 设置频道ID
void | setCutSize(int iNewCutSize, boolean bClear) 设置取字段时的截断长度。
void | setHitNum(long iHitNum) 设置命中点个数
void | setLicenseCode(java.lang.String strLicenseCode) 设置连接许可证
void | setSearchTime(double dSearchTime) 设置检索耗时
void | setSearchWord(java.lang.String strSearchWord) 设置检索条件表达式
void | setSources(java.lang.String strSources) 设置检索对象列表
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

WASResultSet

public WASResultSet(AppConfig appConfig,
                    ConfigData wasConfig,
                    LoginConfig loginConfig,
                    SearchData searchData,
                    java.lang.String strChannelID)
             throws WASException
抛出：
WASException
方法详细信息

close

public void close()
关闭WAS结果集.

getBinaryObjectCount

public int getBinaryObjectCount(java.lang.String strColumnName)
                         throws WASException
获得指定字段二进制对象的个数。

参数：
strColumnName - 字段名称
返回：
返回指定字段二进制对象的个数
抛出：
WASException

getBinaryObjectRealCount

public int getBinaryObjectRealCount(java.lang.String strColumnName)
                             throws WASException
获得指定字段二进制对象的个数。

参数：
strColumnName - 字段名称
返回：
返回指定字段二进制对象的个数。
抛出：
WASException

getBinaryStream

public java.io.InputStream getBinaryStream(java.lang.String strColumnName,
                                           int iMultiIndex)
                                    throws java.io.IOException,
                                           WASException
获得当前记录指定字段名称和多值序号的对象的输入流对象。

参数：
strColumnName - 字段名称
iMultiIndex - 多值序号
返回：
返回输入流对象
抛出：
java.io.IOException
WASException

getBytes

public byte[] getBytes(java.lang.String strColumnName,
                       int iMulti)
                throws WASException
获取字段内容的字节数组

参数：
strColumnName - 字段名称
iMulti - 多值序号
返回：
字段内容的字节数组
抛出：
WASException

getChannelID

public java.lang.String getChannelID()
获取频道ID

返回：
返回频道ID

getColHitNum

public int getColHitNum(java.lang.String strColumn)
                 throws WASException
获取字段命中点数

返回：
返回字段命中点数
抛出：
WASException

getColumnMultiValue

public int getColumnMultiValue(java.lang.String strColumnName)
                        throws WASException
获取字段的多值个数

参数：
strColumnName - 字段名称
返回：
返回字段的多值个数
抛出：
WASException

getColumnType

public int getColumnType(java.lang.String strColName)
                  throws WASException
获得当前记录中指定字段的类型。

参数：
strColName - 字段名称
返回：
返回字段类型
抛出：
WASException

getContentType

public java.lang.String getContentType(java.lang.String strColumnName,
                                       int iMultiIndex)
                                throws WASException
该方法返回当前记录的二进制字段的指定对象的 ContentType

参数：
strColumnName - 字段名称
iMultiIndex - 二进制字段的多值序号，从零开始。
返回：
返回对象的ContentType
抛出：
WASException

getDate

public java.lang.String getDate(java.lang.String strColumnName,
                                java.lang.String strFormat)
                         throws WASException
获取日期字段指定格式的内容

参数：
strColumnName - 字段名称
strFormat - 日期格式
返回：
返回日期字段指定格式的内容
抛出：
WASException

getDetailFields

public java.lang.String[] getDetailFields()
                                   throws WASException
获得检索结果对象对应的频道的细览字段

返回：
频道细览字段名称数组
抛出：
WASException

getDownloadFields

public java.lang.String[] getDownloadFields()
                                     throws WASException
获得检索结果对象对应的频道的下载字段

返回：
频道下载字段名称数组
抛出：
WASException

getFile

public java.lang.String getFile(java.lang.String strColumnName,
                                int iMultiIndex)
                         throws java.io.IOException,
                                WASException
获得指定二进制字段的文件名。

参数：
strColumnName - 字段名称
iMultiIndex - 多值序号
返回：
返回指定二进制字段的文件名
抛出：
java.io.IOException
WASException

getFloat

public float getFloat(java.lang.String strColumnName)
               throws WASException
获取指定NUMBER字段FLOAT类型内容

参数：
strColumnName - 字段名称
返回：
返回指定NUMBER字段FLOAT类型内容
抛出：
WASException

getHitNum

public long getHitNum()
获取命中点个数

返回：
返回命中点个数

getInt

public int getInt(java.lang.String strColumnName)
           throws WASException
获取指定NUMBER字段INT类型内容

参数：
strColumnName - 字段名称
返回：
返回指定NUMBER字段INT类型内容
抛出：
WASException

getLicenseCode

public java.lang.String getLicenseCode()
获取连接许可证

返回：
返回连接许可证

getMailFields

public java.lang.String[] getMailFields()
                                 throws WASException
获得检索结果对象对应的频道的推荐字段

返回：
频道推荐字段名称数组
抛出：
WASException

getPrimaryKey

public java.lang.String getPrimaryKey()
                               throws WASException
获得当前检索结果集的主键

返回：
当前检索结果集的主键
抛出：
WASException

getPrimaryKeyPair

public java.lang.String getPrimaryKeyPair()
                                   throws WASException
获得当前检索记录的主键名值对

返回：
主键名值对
抛出：
WASException

getRecordCount

public long getRecordCount()
                    throws WASException
获取命中记录数

返回：
返回命中记录数
抛出：
WASException

getRelevance

public double getRelevance()
                    throws WASException
获取当前记录的相关度

返回：
返回当前记录的相关度
抛出：
WASException

getSearchTime

public double getSearchTime()
获取检索耗时

返回：
返回检索耗时

getSearchWord

public java.lang.String getSearchWord()
获取检索条件表达式

返回：
返回检索条件表达式

getSources

public java.lang.String getSources()
获取检索对象列表

返回：
返回检索对象列表

getString

public java.lang.String getString(java.lang.String strColumnName)
                           throws WASException
获得指定字段的字段值内容

参数：
strColumnName -
返回：
字段内容的字符串
抛出：
WASException

getString

public java.lang.String getString(java.lang.String strColumnName,
                                  java.lang.String strHitColor,
                                  int iCutSize)
                           throws WASException
获取指定字段带命中点反显标记的内容

参数：
strColumnName - 字段名称
strHitColor - 反显颜色
iCutSize - 截断长度
返回：
返回指定字段带命中点反显标记的内容
抛出：
WASException

getTRSConnection

public com.trs.client.TRSConnection getTRSConnection()
                                              throws WASException
获取TRS连接对象.

返回：
TRS连接对象
抛出：
WASException

getTRSReConnection

public com.trs.client.TRSConnection getTRSReConnection(java.lang.String strLicenseCode)
                                                throws WASException
利用系统许可证获取TRS连接.

参数：
strLicenseCode - 系统连接许可证
返回：
TRS连接对象
抛出：
WASException

getTrsRS

public com.trs.client.TRSResultSet getTrsRS()
获取TRSResultSet对象

返回：
返回TRSResultSet对象

moveTo

public boolean moveTo(int iMoveFlag,
                      long lNewNo)
               throws WASException
移动到检索结果记录集的指定记录

参数：
iMoveFlag - 移动方式目前有两种可能的取值:取0意味着第二个参数是绝对移动量，取1意味着第二个参数是相对移动量。
lNewNo - 如果是绝对移动量，则是逻辑记录号;如果是相对移动量，则是对于当前位置的偏移量，正数意味着向后移动，负数意味着向前移动。
返回：
成功返回true，失败返回false。
抛出：
WASException

setChannelID

public void setChannelID(java.lang.String strChannelID)
设置频道ID

参数：
strChannelID - 频道ID

setCutSize

public void setCutSize(int iNewCutSize,
                       boolean bClear)
                throws WASException
设置取字段时的截断长度。

参数：
iNewCutSize - 新的字段截断长度，小于零表示不修改。
bClear - 如果为true则清除检索结果缓冲区。
抛出：
WASException

setHitNum

public void setHitNum(long iHitNum)
设置命中点个数

参数：
iHitNum - 命中点个数

setLicenseCode

public void setLicenseCode(java.lang.String strLicenseCode)
设置连接许可证

参数：
strLicenseCode - 连接许可证

setSearchTime

public void setSearchTime(double dSearchTime)
设置检索耗时

参数：
dSearchTime - 要设置的检索耗时

setSearchWord

public void setSearchWord(java.lang.String strSearchWord)
设置检索条件表达式

参数：
strSearchWord - 检索条件表达式

setSources

public void setSources(java.lang.String strSources)
设置检索对象列表

参数：
strSources - 检索对象名称列表
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


WASTools

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was
类 WASTools

java.lang.Object
    继承者  com.trs.was.WASTools

public class WASTools
extends java.lang.Object

WAS工具类。

构造函数摘要
WASTools()
方法摘要
static java.lang.String | buildSQL(java.lang.String strSQL1, java.lang.String strSQL2, java.lang.String strRelation) 返回组合检索条件。
static int | classResultForTimeLine(WASResultSet wasRS, java.lang.String column, boolean isRegExp) 分类统计，用于时间轴
static java.lang.String | ConverXSS(java.lang.String value) 将HTML中的字符实体如"<", ">", "("等等替换为字符
static java.lang.String | convOutput(java.lang.String strInput) 将字符如"(", ")", "<", ">"等字符替换为HTML字符实体
static void | freeWASResultSet(javax.servlet.ServletRequest request) 释放WAS结果集
static void | freeWASResultSet(javax.servlet.ServletRequest request, java.lang.String strChannelID) 释放WAS结果集
static ChannelNode | getChannel(ConfigData wasConfig, java.lang.String strChannelID) 获取频道对象
static java.lang.String | getChannelID(LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取频道ID
static java.lang.String | getChannelNames(ConfigData wasConfig, java.lang.String strChannelIDs) 获得操作的频道名。
static java.lang.String | getChannelSources(ConfigData configData, java.lang.String strChannelID) 获取频道的TRS数据库名称。
static java.lang.String | getOrderBy(ChannelNode channelNode, SearchData searchData) 获取频道排序条件.
static SearchData | getSearchDataFromRequest(javax.servlet.http.HttpServletRequest request) 从请求中获取检索条件对象.
static java.lang.String[][] | getTimeLine(WASResultSet wasRS, int classnum, java.lang.String commonPart, int showNum, int span, java.lang.String currentDate, int endNode) 获取时间轴
static java.lang.String | getURL(javax.servlet.http.HttpServletRequest request, SearchData searchData, LoginConfig loginConfig, java.lang.String strChannelID) 组合请求中的参数返回
static WASResultSet | getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取WAS结果集对象
static LoginConfig | loadLoginConfig(javax.servlet.http.HttpSession session, ConfigData wasConfig) 获取登录对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

WASTools

public WASTools()
方法详细信息

buildSQL

public static java.lang.String buildSQL(java.lang.String strSQL1,
                                        java.lang.String strSQL2,
                                        java.lang.String strRelation)
返回组合检索条件。

参数：
strSQL1 - 条件1
strSQL2 - 条件2
strRelation - 连接运算符
返回：
组合后的检索条件

classResultForTimeLine

public static int classResultForTimeLine(WASResultSet wasRS,
                                         java.lang.String column,
                                         boolean isRegExp)
                                  throws WASException
分类统计，用于时间轴

参数：
wasRS - was结果集
column - 分类字段名
isRegExp - 是否用正则表达式分类（用正则表达式效率较高）
返回：
字段值分类的结果个数
抛出：
WASException

ConverXSS

public static java.lang.String ConverXSS(java.lang.String value)
将HTML中的字符实体如"<", ">", "("等等替换为字符

参数：
value - 含有字符实体的字符串
返回：
替换后的字符串

convOutput

public static java.lang.String convOutput(java.lang.String strInput)
将字符如"(", ")", "<", ">"等字符替换为HTML字符实体

参数：
strInput - 含有要替换字符的字符串
返回：
替换之后的字符串

freeWASResultSet

public static void freeWASResultSet(javax.servlet.ServletRequest request)
                             throws WASException
释放WAS结果集

参数：
request - servlet请求
抛出：
WASException

freeWASResultSet

public static void freeWASResultSet(javax.servlet.ServletRequest request,
                                    java.lang.String strChannelID)
                             throws WASException
释放WAS结果集

参数：
request - servlet请求
strChannelID - 频道ID
抛出：
WASException

getChannel

public static ChannelNode getChannel(ConfigData wasConfig,
                                     java.lang.String strChannelID)
                              throws WASException
获取频道对象

参数：
wasConfig - 配置信息对象
strChannelID - 频道ID号
返回：
频道对象
抛出：
WASException

getChannelID

public static java.lang.String getChannelID(LoginConfig loginConfig,
                                            SearchData searchData,
                                            java.lang.String strChannelID)
                                     throws WASException
获取频道ID

参数：
loginConfig - 登录对象
searchData - 检索参数对象
strChannelID - 频道号
返回：
频道ID
抛出：
WASException

getChannelNames

public static java.lang.String getChannelNames(ConfigData wasConfig,
                                               java.lang.String strChannelIDs)
                                        throws WASException
获得操作的频道名。

参数：
wasConfig - 配置信息对象
strChannelIDs - 频道ID号
返回：
频道名称
抛出：
WASException

getChannelSources

public static java.lang.String getChannelSources(ConfigData configData,
                                                 java.lang.String strChannelID)
                                          throws WASException
获取频道的TRS数据库名称。

参数：
configData - 配置信息对象
strChannelID - 频道ID号
返回：
TRS数据库名称
抛出：
WASException

getOrderBy

public static java.lang.String getOrderBy(ChannelNode channelNode,
                                          SearchData searchData)
                                   throws WASException
获取频道排序条件.

参数：
channelNode - 频道对象
searchData - 检索条件对象
返回：
频道排序条件表达式
抛出：
WASException

getSearchDataFromRequest

public static SearchData getSearchDataFromRequest(javax.servlet.http.HttpServletRequest request)
                                           throws WASException
从请求中获取检索条件对象.

参数：
request - Servlet请求
返回：
检索条件对象
抛出：
WASException

getTimeLine

public static java.lang.String[][] getTimeLine(WASResultSet wasRS,
                                               int classnum,
                                               java.lang.String commonPart,
                                               int showNum,
                                               int span,
                                               java.lang.String currentDate,
                                               int endNode)
                                        throws WASException
获取时间轴

参数：
wasRS - was结果集（已进行分类统计）
classnum - 类别总数
commonPart - 日期中相同的起始部分
showNum - 显示节点数
span - 节点之间的跨度
currentDate - 当前日期（格式：yyyy.mm.dd）
endNode - 结束节点值，0表示以最新数据为结束节点
返回：
表示时间轴的二维数组
抛出：
WASException

getURL

public static java.lang.String getURL(javax.servlet.http.HttpServletRequest request,
                                      SearchData searchData,
                                      LoginConfig loginConfig,
                                      java.lang.String strChannelID)
                               throws WASException
组合请求中的参数返回

参数：
request - Servlet请求对象
searchData - 检索条件对象
loginConfig - 登录对象
strChannelID - 当前频道ID
返回：
返回组合的参数
抛出：
WASException

getWASResultSet

public static WASResultSet getWASResultSet(javax.servlet.http.HttpServletRequest request,
                                           AppConfig appConfig,
                                           ConfigData wasConfig,
                                           LoginConfig loginConfig,
                                           SearchData searchData,
                                           java.lang.String strChannelID)
                                    throws WASException
获取WAS结果集对象

参数：
request - Servlet请求
appConfig - 基本配置对象
wasConfig - 配置信息对象
loginConfig - 登录对象
searchData - 检索条件对象
strChannelID - 频道ID号
返回：
WAS结果集对象
抛出：
WASException

loadLoginConfig

public static LoginConfig loadLoginConfig(javax.servlet.http.HttpSession session,
                                          ConfigData wasConfig)
                                   throws WASException
获取登录对象

参数：
session - Session对象
wasConfig - 配置信息对象
返回：
登录对象
抛出：
WASException
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


com.trs.was.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.was.config

类摘要
AppConfig | 基本配置信息类，用于读取wasconfig.properties文件。
ChannelNode | 频道节点对象，用于存储频道对象信息。
ChannelTree | 频道树类，扩展了Tree类
ConfigData | 存储系统所有配置信息类，用于储存频道，导航等对象信息。
DataSource | 数据源对象类。
FieldData | 字段对象。
LoginConfig | 用户登录配置信息类。
MapChannel | 频道树对象集合类。
MapDataSource | 数据源对象集合类。
MapFieldData | 存储频道相应的数据库字段对象的集合类
MapGroup | 用户组树对象集合类。
RequestOperation | 请求参数处理类,用于对HTTP请求参数进行相应的编码处理.
SearchData | 用于储存标准检索请求参数。
WASGroup | 用户组信息类,用于存储用户组信息
WASRole | 用户角色类
WASUser | 用户信息类,用于存储用户信息

异常摘要
WASException 系统异常类,用于处理异常信息

概述 软件包 类 使用 树 索引 帮助


com.trs.was.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.was.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.was.config.AppConfig
    • com.trs.was.config.ConfigData
    • com.trs.was.config.DataSource
    • com.trs.was.config.FieldData (implements java.lang.Cloneable)
    • com.trs.was.config.LoginConfig (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • com.trs.was.config.MapDataSource
    • com.trs.was.config.MapFieldData (implements java.lang.Cloneable)
    • com.trs.was.tree.MapTree
      • com.trs.was.config.MapChannel
      • com.trs.was.config.MapGroup
    • com.trs.was.tree.Node (implements java.lang.Cloneable)
      • com.trs.was.config.ChannelNode
      • com.trs.was.config.WASGroup
    • com.trs.was.config.RequestOperation
    • com.trs.was.config.SearchData
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.was.config.WASException
    • com.trs.was.tree.Tree
      • com.trs.was.config.ChannelTree
    • com.trs.was.config.WASRole
    • com.trs.was.config.WASUser (implements java.lang.Cloneable, java.io.Serializable)


软件包 com.trs.was.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.was.config
的使用

使用 com.trs.was.config 的软件包
com.trs.was
com.trs.was.config
com.trs.was.tree

com.trs.was 使用的 com.trs.was.config 中的类
AppConfig
基本配置信息类，用于读取wasconfig.properties文件。
ChannelNode
频道节点对象，用于存储频道对象信息。
ConfigData
存储系统所有配置信息类，用于储存频道，导航等对象信息。
LoginConfig
用户登录配置信息类。
SearchData
用于储存标准检索请求参数。
WASException
系统异常类,用于处理异常信息

com.trs.was.config 使用的 com.trs.was.config 中的类
CacheItem
已过时。
ChannelNode
频道节点对象，用于存储频道对象信息。
ConfigData
存储系统所有配置信息类，用于储存频道，导航等对象信息。
DataSource
数据源对象类。
FieldData
字段对象。
HttpMultiFormPart
已过时。
MapChannel
频道树对象集合类。
MapDataSource
数据源对象集合类。
MapFieldData
存储频道相应的数据库字段对象的集合类
MapGrantRight
已过时。
MapGroup
用户组树对象集合类。
MapNavigate
已过时。
MapWASStyle
已过时。
WASException
系统异常类,用于处理异常信息
WASStyle
已过时。
WASUser
用户信息类,用于存储用户信息

com.trs.was.tree 使用的 com.trs.was.config 中的类
NavigateNode
已过时。
WASException
系统异常类,用于处理异常信息

概述 软件包 类 使用 树 索引 帮助


AppConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 AppConfig

java.lang.Object
    继承者  com.trs.was.config.AppConfig

public class AppConfig
extends java.lang.Object

基本配置信息类，用于读取wasconfig.properties文件。

构造函数摘要
AppConfig()
默认构造方法，读取wasconfig.properties配置文件，初始化各成员变量
AppConfig(javax.servlet.ServletContext application)
构造方法，读取wasconfig.properties配置文件，初始化各成员变量，保存在ServletContext对象中
方法摘要
java.lang.String | getAppServerEncoding() 获得应用服务器编码
java.lang.String | getBaseDir() 获取应用根目录路径
static boolean | getBoolProperties(java.lang.String strKey) 获取布尔型配置值
boolean | getCheckPermit() 是否需要验证用户权限
int | getDebugLevel() 获得调试级别
java.lang.String | getDemoPath() 获取演示数据库路径
int | getDownloadType() 获取下载类型
java.lang.String | getErrorFile() 获取错误文件名
boolean | getForceReload() 获取是否强制定时重新加载配置文件
static int | getIntProperties(java.lang.String strKey) 获取整数型配置值
java.lang.String | getOutFilePath() 获取外部文件路径
static java.lang.String | getProperties(java.lang.String strKey) 获取系统配置值
java.util.Properties | getProperty() 获取系统配置属性
int | getReloadTime() 获得重新加载时间
java.lang.String | getSysDriver() 获得数据库驱动
java.lang.String | getSysPasswd() 获得数据库登录密码
java.lang.String | getSysURL() 获取系统URL
java.lang.String | getSysUser() 获得数据库登录用户
java.lang.String | getTempletFilePath() 获取模板文件保存路径
java.lang.String | getTempPath() 获取模板保存路径
int | getTRSFlag() 获得TRS标识
boolean | isCrypted() 配置文件中系统数据库密码是否加密处理
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

AppConfig

public AppConfig()
          throws WASException
默认构造方法，读取wasconfig.properties配置文件，初始化各成员变量

抛出：
WASException

AppConfig

public AppConfig(javax.servlet.ServletContext application)
          throws WASException
构造方法，读取wasconfig.properties配置文件，初始化各成员变量，保存在ServletContext对象中

参数：
application - ServletContext对象
抛出：
WASException
方法详细信息

getAppServerEncoding

public java.lang.String getAppServerEncoding()
获得应用服务器编码

返回：
应用服务器

getBaseDir

public java.lang.String getBaseDir()
获取应用根目录路径

返回：
返回应用根目录路径

getBoolProperties

public static boolean getBoolProperties(java.lang.String strKey)
获取布尔型配置值

参数：
strKey - 配置名称
返回：
配置值

getCheckPermit

public boolean getCheckPermit()
是否需要验证用户权限

返回：
返回是否需要验证用户权限

getDebugLevel

public int getDebugLevel()
获得调试级别

返回：
调试级别

getDemoPath

public java.lang.String getDemoPath()
获取演示数据库路径

返回：
返回演示数据库路径

getDownloadType

public int getDownloadType()
获取下载类型

返回：
返回下载类型

getErrorFile

public java.lang.String getErrorFile()
获取错误文件名

返回：
错误文件名称

getForceReload

public boolean getForceReload()
获取是否强制定时重新加载配置文件

返回：
返回是否强制定时重新加载配置文件

getIntProperties

public static int getIntProperties(java.lang.String strKey)
获取整数型配置值

参数：
strKey - 配置名称
返回：
配置值

getOutFilePath

public java.lang.String getOutFilePath()
获取外部文件路径

返回：
返回外部文件路径

getProperties

public static java.lang.String getProperties(java.lang.String strKey)
获取系统配置值

参数：
strKey - 配置名称
返回：
配置值

getProperty

public java.util.Properties getProperty()
获取系统配置属性

返回：
属性Properties对象

getReloadTime

public int getReloadTime()
获得重新加载时间

返回：
重新加载时间

getSysDriver

public java.lang.String getSysDriver()
获得数据库驱动

返回：
数据库驱动

getSysPasswd

public java.lang.String getSysPasswd()
获得数据库登录密码

返回：
数据库登录密码

getSysURL

public java.lang.String getSysURL()
获取系统URL

返回：
返回系统URL

getSysUser

public java.lang.String getSysUser()
获得数据库登录用户

返回：
数据库登录用户

getTempletFilePath

public java.lang.String getTempletFilePath()
获取模板文件保存路径

返回：
返回模板文件保存路径

getTempPath

public java.lang.String getTempPath()
获取模板保存路径

返回：
返回模板保存路径

getTRSFlag

public int getTRSFlag()
获得TRS标识

返回：
TRS标识

isCrypted

public boolean isCrypted()
配置文件中系统数据库密码是否加密处理

返回：
系统数据库密码是否加密处理
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


ChannelNode

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 ChannelNode

java.lang.Object
    继承者  com.trs.was.tree.Node
        继承者  com.trs.was.config.ChannelNode
所有已实现的接口：
java.lang.Cloneable
public class ChannelNode
extends Node

频道节点对象，用于存储频道对象信息。

构造函数摘要
ChannelNode()
默认构造方法，初始化各成员变量
方法摘要
java.lang.Object | clone() 克隆对象
FieldData | deleteField(java.lang.String strFieldName) 从频道的字段集合中删除字段对象
java.lang.String | getAdvSearchTemplate() 获得高级搜索模板
java.lang.String | getAllFieldInfo() 返回所有字段信息字符串.
java.lang.String | getAllSources() 返回所有数据库/视图名称.
java.lang.String | getAntonymDic() 获取用于频道检索的反义词典名称
java.lang.String[] | getAReduplicate() 获取去重属性数组
java.lang.String | getAutoExtend() 获取保存自动扩展选项的字符串
java.lang.String | getBindFormID() 获取绑定表单ID
java.lang.String | getChannelName() 获得频道名称
java.lang.String | getChannelSQL() 获取频道条件
int | getCheckType() 获得频道控制类型
java.lang.String | getComment() 获得频道的说明信息
java.sql.Date | getCreateTime() 获得创建日期
java.lang.String | getDataSourceId() 获得数据源Id
java.lang.String | getDefaultSearchFieldString() 获取频道的默认检索字段字符串，不同字段以逗号分隔
java.lang.String[] | getDefaultSearchFieldStringArray() 获取频道的默认检索字段数组
java.lang.String | getDetailFieldString() 获取频道的细览字段字符串，不同字段以逗号分隔
java.lang.String[] | getDetailFieldStringArray() 获取频道的细览字段数组
java.lang.String | getDetailTemplate() 获得细览模板
java.lang.String | getDownloadFieldString() 获取频道的下载字段字符串，不同字段以逗号分隔
java.lang.String[] | getDownloadFieldStringArray() 获取频道的下载字段数组
long | getEstimatestop() 获取快速检索时，至少返回的记录数
long | getEstimateunit() 获取估算检索时，每个逻辑段包含的记录数
java.lang.String | getExtendOpt() 获取保存扩展检索选项的字符串
java.util.Hashtable | getExtraCfg() 获取频道其它配置
java.lang.String | getExtraString() 获取频道其他配置
FieldData | getField(java.lang.String strFieldName) 从频道的字段集合中获取指定字段对象
FieldData[] | getFieldArray() 获取所有字段对象
java.lang.String | getGrantRight() 获取存放WAS4升级的权限数据
java.lang.String | getHitType() 获取命中点类型
java.lang.String | getIndexTemplet() 获取主页模板
java.lang.String | getKeyWordFieldString() 获取频道的关键词字段字符串
java.lang.String[] | getKeyWordFieldStringArrary() 获取频道的关键词字段数组
java.sql.Date | getLastChangeTime() 获得最后一次修改日期
java.lang.String | getMailFieldString() 获取频道的推荐字段字符串，不同字段以逗号分隔
java.lang.String[] | getMailFieldStringArray() 获取频道的推荐字段数组
java.lang.String | getMailTemplate() 获得邮件推荐模板
MapFieldData | getMapFieldData() 获得数据库字段集合
java.lang.String | getOrderBy() 获得频道的排序方式
java.lang.String | getOutfileFieldString() 获取频道的外部文件字段字符串，不同字段以逗号分隔
java.lang.String[] | getOutfileFieldStringArray() 获取频道的外部文件字段数组
java.lang.String | getOutlineFieldString() 获取频道的概览字段字符串，不同字段以逗号分隔
java.lang.String[] | getOutlineFieldStringArray() 获取频道的概览字段数组
java.lang.String | getOutlineTemplate() 获得概览模板
java.lang.String | getPrimaryFieldString() 获取频道的主键字段字符串，不同字段以逗号分隔
java.lang.String[] | getPrimaryFieldStringArray() 获取频道的主键字段数组
java.lang.String | getPrintTemplate() 获得打印模板
java.lang.String | getQuickSelectOpt() 获取估算检索设置参数
java.lang.String | getReadTimeFieldString() 获取频道的阅读次数字段字符串
java.lang.String[] | getReadTimeFieldStringArray() 获取频道的阅读次数字段数组
java.lang.String | getReduplicateString() 获取保存去重属性的字符串
java.lang.String | getRelationFieldString() 获取频道的相关阅读字段字符串
java.lang.String[] | getRelationFieldStringArray() 获取频道的相关阅读字段数组
java.lang.String | getSearchFormFieldString() 获取频道的检索表单字段字符串，不同字段以逗号分隔
java.lang.String[] | getSearchFormFieldStringArray() 获取频道的检索表单字段数组
java.lang.String | getSearchOpt() 获取保存检索选项的字符串
java.lang.String | getSourceFileFieldString() 获取频道的源文件字段字符串，不同字段以逗号分隔
java.lang.String[] | getSourceFileFieldStringArray() 获取频道的源文件字段数组
java.lang.String[] | getSources() 获得检索的TRS数据库/视图
java.lang.String | getSQL() 获得频道的检索表达式
java.lang.String | getStatFieldString() 获取频道的分类统计字段字符串
java.lang.String[] | getStatFieldStringArrary() 获取频道的分类统计字段数组
java.lang.String | getStyleName() 获得显示风格名称
java.lang.String | getSynonymDic() 获取用于频道检索的同义词典名称
java.lang.String | getTempletCombo() 获取模板组合
java.lang.String | getThesaurusDic() 获取用于频道检索的主题词典名称
java.lang.String | getTimeLineFieldString() 获取频道的时间轴字段字符串
java.lang.String[] | getTimeLineFieldStringArrary() 获取频道的时间轴字段数组
java.lang.String | getTreeName() 获得所属频道树名称
boolean | hasAutoExtend(java.lang.String strOpt) 频道自动扩展选项中是否含有指定的配置项
boolean | hasExtendOpt(java.lang.String strOpt) 频道扩展检索选项中是否含有指定的配置项
boolean | hasHitType(java.lang.String strOpt) 频道命中点类型中是否含有指定的类型
boolean | hasSearchOpt(java.lang.String strOpt) 频道检索选项中是否含有指定的配置项
void | inherit(ChannelNode parentNode) 继承父节点的属性
boolean | isQuickSelect() 是否进行估算检索
void | removeAllFields() 从频道的字段集合中删除所有字段对象
void | setAdvSearchTemplate(java.lang.String strAdvSearchTemplate) 设置高级搜索模板
void | setAllSources(java.lang.String strSources) 设置数据库/视图名称
void | setAntonymDic(java.lang.String dic) 设置用于频道检索的反义词典名称
void | setAutoExtend(java.lang.String autoExtend) 设置自动扩展选项
void | setBindFormID(java.lang.String bindFormID) 设置绑定表单ID
void | setChannelName(java.lang.String strChannelName) 设置频道名称
void | setChannelSQL(java.lang.String m_strChannelSQL) 设置频道条件
void | setCheckType(int iCheckType) 设置频道控制类型
void | setComment(java.lang.String strComment) 设置频道的说明信息
void | setCreateTime(java.sql.Date createTime) 设置创建日期
void | setDataSourceId(java.lang.String strDataSourceId) 设置数据源Id
void | setDetailTemplate(java.lang.String strDetailTemplate) 设置细览模板
void | setExtendOpt(java.lang.String extendOpt) 设置扩展检索选项
void | setExtraCfg(java.util.Hashtable m_extraCfg) 设置频道其它配置
void | setExtraString(java.lang.String opt) 设置频道其它配置
void | setField(FieldData field) 在频道的字段集合中添加字段对象
void | setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中
void | setFieldsByString(java.lang.String strFieldsString) 从字符串中解析出DataField信息并写入到m_mapFieldData中
void | setGrantRight(java.lang.String strGrantRight) 设置存放WAS4升级的权限数据
void | setHitType(java.lang.String hitType) 设置命中点类型
void | setIndexTemplet(java.lang.String indexTemplet) 设置主页模板
void | setLastChangeTime(java.sql.Date lastChangeTime) 设置最后一次修改日期
void | setMailTemplate(java.lang.String strMailTemplate) 设置邮件推荐模板
void | setMapFieldData(MapFieldData mapFieldData) 设置数据库字段集合
void | setOrderBy(java.lang.String strOrderBy) 设置频道的排序方式
void | setOutlineTemplate(java.lang.String strOutlineTemplate) 设置概览模板
void | setPrintTemplate(java.lang.String strPrintTemplate) 设置打印模板
void | setReduplicate(java.lang.String reduplicate) 设置去重属性
void | setSearchOpt(java.lang.String searchOpt) 设置检索选项
void | setSources(java.lang.String[] strSources) 设置检索的TRS数据库/视图
void | setSQL(java.lang.String strSQL) 设置频道的检索表达式
void | setStyleName(java.lang.String strStyleName) 设置显示风格名称
void | setSynonymDic(java.lang.String dic) 设置用于频道检索的同义词典名称
void | setTempletCombo(java.lang.String templetCombo) 设置模板组合
void | setThesaurusDic(java.lang.String dic) 设置用于频道检索的主题词典名称
void | setTreeName(java.lang.String strTreeName) 设置所属频道树名称
从类 com.trs.was.tree.Node 继承的方法
getID, getLevel, getNextID, getNextNode, getParentID, getParentNode, getPreID, getPreNode, getSonID, getSonNode, setID, setLevel, setNextID, setNextNode, setParentID, setParentNode, setPreID, setPreNode, setSonID, setSonNode
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

ChannelNode

public ChannelNode()
默认构造方法，初始化各成员变量

方法详细信息

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
克隆对象

覆盖：
类 Node 中的 clone
抛出：
java.lang.CloneNotSupportedException

deleteField

public FieldData deleteField(java.lang.String strFieldName)
                      throws WASException
从频道的字段集合中删除字段对象

参数：
strFieldName - 指定字段对象名
返回：
被删除的字段对象
抛出：
WASException - m_mapFieldData操作出错

getAdvSearchTemplate

public java.lang.String getAdvSearchTemplate()
获得高级搜索模板

返回：
高级搜索模板

getAllFieldInfo

public java.lang.String getAllFieldInfo()
                                 throws WASException
返回所有字段信息字符串.

返回：
所有字段信息字符串
抛出：
WASException - 参数strSources为空

getAllSources

public java.lang.String getAllSources()
返回所有数据库/视图名称.

返回：
所有数据库/视图名称

getAntonymDic

public java.lang.String getAntonymDic()
获取用于频道检索的反义词典名称

返回：
反义词典名称

getAReduplicate

public java.lang.String[] getAReduplicate()
获取去重属性数组

返回：
去重属性数组

getAutoExtend

public java.lang.String getAutoExtend()
获取保存自动扩展选项的字符串

返回：
保存自动扩展选项的字符串

getBindFormID

public java.lang.String getBindFormID()
获取绑定表单ID

返回：
绑定表单ID

getChannelName

public java.lang.String getChannelName()
获得频道名称

返回：
频道名称

getChannelSQL

public java.lang.String getChannelSQL()
获取频道条件

返回：
频道条件

getCheckType

public int getCheckType()
获得频道控制类型

返回：
频道控制类型

getComment

public java.lang.String getComment()
获得频道的说明信息

返回：
频道的说明信息

getCreateTime

public java.sql.Date getCreateTime()
获得创建日期

返回：
创建日期

getDataSourceId

public java.lang.String getDataSourceId()
获得数据源Id

返回：
数据源Id

getDefaultSearchFieldString

public java.lang.String getDefaultSearchFieldString()
                                             throws WASException
获取频道的默认检索字段字符串，不同字段以逗号分隔

返回：
频道的默认检索字段字符串
抛出：
WASException - m_mapFieldData为null

getDefaultSearchFieldStringArray

public java.lang.String[] getDefaultSearchFieldStringArray()
                                                    throws WASException
获取频道的默认检索字段数组

返回：
频道的默认检索字段数组
抛出：
WASException

getDetailFieldString

public java.lang.String getDetailFieldString()
                                      throws WASException
获取频道的细览字段字符串，不同字段以逗号分隔

返回：
频道的细览字段字符串
抛出：
WASException - m_mapFieldData为null

getDetailFieldStringArray

public java.lang.String[] getDetailFieldStringArray()
                                             throws WASException
获取频道的细览字段数组

返回：
频道的细览字段数组
抛出：
WASException - m_mapFieldData为null

getDetailTemplate

public java.lang.String getDetailTemplate()
获得细览模板

返回：
细览模板

getDownloadFieldString

public java.lang.String getDownloadFieldString()
                                        throws WASException
获取频道的下载字段字符串，不同字段以逗号分隔

返回：
频道的下载字段字符串
抛出：
WASException - m_mapFieldData为null

getDownloadFieldStringArray

public java.lang.String[] getDownloadFieldStringArray()
                                               throws WASException
获取频道的下载字段数组

返回：
频道的下载字段数组
抛出：
WASException - m_mapFieldData为null

getEstimatestop

public long getEstimatestop()
获取快速检索时，至少返回的记录数

返回：
至少返回的记录数

getEstimateunit

public long getEstimateunit()
获取估算检索时，每个逻辑段包含的记录数

返回：
每个逻辑段包含的记录数

getExtendOpt

public java.lang.String getExtendOpt()
获取保存扩展检索选项的字符串

返回：
保存扩展检索选项的字符串

getExtraCfg

public java.util.Hashtable getExtraCfg()
获取频道其它配置

返回：
保存频道其它配置的哈希表

getExtraString

public java.lang.String getExtraString()
获取频道其他配置

返回：
表示频道其他配置的字符串

getField

public FieldData getField(java.lang.String strFieldName)
                   throws WASException
从频道的字段集合中获取指定字段对象

参数：
strFieldName - 指定字段对象名
返回：
指定字段对象
抛出：
WASException - m_mapFieldData操作出错

getFieldArray

public FieldData[] getFieldArray()
                          throws WASException
获取所有字段对象

返回：
所有的字段对象
抛出：
WASException - m_mapFields为null

getGrantRight

public java.lang.String getGrantRight()
获取存放WAS4升级的权限数据

返回：
存放WAS4升级的权限数据

getHitType

public java.lang.String getHitType()
获取命中点类型

返回：
命中点类型

getIndexTemplet

public java.lang.String getIndexTemplet()
获取主页模板

返回：
主页模板

getKeyWordFieldString

public java.lang.String getKeyWordFieldString()
                                       throws WASException
获取频道的关键词字段字符串

返回：
频道的关键词字段字符串
抛出：
WASException

getKeyWordFieldStringArrary

public java.lang.String[] getKeyWordFieldStringArrary()
                                               throws WASException
获取频道的关键词字段数组

返回：
频道的关键词字段数组
抛出：
WASException

getLastChangeTime

public java.sql.Date getLastChangeTime()
获得最后一次修改日期

返回：
最后一次修改日期

getMailFieldString

public java.lang.String getMailFieldString()
                                    throws WASException
获取频道的推荐字段字符串，不同字段以逗号分隔

返回：
频道的推荐字段字符串
抛出：
WASException - m_mapFieldData为null

getMailFieldStringArray

public java.lang.String[] getMailFieldStringArray()
                                           throws WASException
获取频道的推荐字段数组

返回：
频道的推荐字段数组
抛出：
WASException - m_mapFieldData为null

getMailTemplate

public java.lang.String getMailTemplate()
获得邮件推荐模板

返回：
邮件推荐模板

getMapFieldData

public MapFieldData getMapFieldData()
获得数据库字段集合

返回：
数据库字段集合

getOrderBy

public java.lang.String getOrderBy()
获得频道的排序方式

返回：
频道的排序方式

getOutfileFieldString

public java.lang.String getOutfileFieldString()
                                       throws WASException
获取频道的外部文件字段字符串，不同字段以逗号分隔

返回：
频道的外部文件字段字符串
抛出：
WASException - m_mapFieldData为null

getOutfileFieldStringArray

public java.lang.String[] getOutfileFieldStringArray()
                                              throws WASException
获取频道的外部文件字段数组

返回：
频道的外部文件字段数组
抛出：
WASException - m_mapFieldData为null

getOutlineFieldString

public java.lang.String getOutlineFieldString()
                                       throws WASException
获取频道的概览字段字符串，不同字段以逗号分隔

返回：
频道的概览字段字符串
抛出：
WASException - m_mapFieldData为null

getOutlineFieldStringArray

public java.lang.String[] getOutlineFieldStringArray()
                                              throws WASException
获取频道的概览字段数组

返回：
频道的概览字段数组
抛出：
WASException - m_mapFieldData为null

getOutlineTemplate

public java.lang.String getOutlineTemplate()
获得概览模板

返回：
概览模板

getPrimaryFieldString

public java.lang.String getPrimaryFieldString()
                                       throws WASException
获取频道的主键字段字符串，不同字段以逗号分隔

返回：
频道的主键字段字符串
抛出：
WASException - m_mapFieldData为null

getPrimaryFieldStringArray

public java.lang.String[] getPrimaryFieldStringArray()
                                              throws WASException
获取频道的主键字段数组

返回：
频道的主键字段数组
抛出：
WASException - m_mapFieldData为null

getPrintTemplate

public java.lang.String getPrintTemplate()
获得打印模板

返回：
打印模板

getQuickSelectOpt

public java.lang.String getQuickSelectOpt()
获取估算检索设置参数

返回：
表示估算检索设置参数的字符串

getReadTimeFieldString

public java.lang.String getReadTimeFieldString()
                                        throws WASException
获取频道的阅读次数字段字符串

返回：
频道的阅读次数字段字符串
抛出：
WASException - m_mapFieldData为null

getReadTimeFieldStringArray

public java.lang.String[] getReadTimeFieldStringArray()
                                               throws WASException
获取频道的阅读次数字段数组

返回：
频道的阅读次数字段数组
抛出：
WASException - m_mapFieldData为null

getReduplicateString

public java.lang.String getReduplicateString()
获取保存去重属性的字符串

返回：
保存去重属性的字符串

getRelationFieldString

public java.lang.String getRelationFieldString()
                                        throws WASException
获取频道的相关阅读字段字符串

返回：
频道的相关阅读字段字符串
抛出：
WASException - m_mapFieldData为null

getRelationFieldStringArray

public java.lang.String[] getRelationFieldStringArray()
                                               throws WASException
获取频道的相关阅读字段数组

返回：
频道的相关阅读字段数组
抛出：
WASException - m_mapFieldData为null

getSearchFormFieldString

public java.lang.String getSearchFormFieldString()
                                          throws WASException
获取频道的检索表单字段字符串，不同字段以逗号分隔

返回：
频道的检索表单字段字符串
抛出：
WASException - m_mapFieldData为null

getSearchFormFieldStringArray

public java.lang.String[] getSearchFormFieldStringArray()
                                                 throws WASException
获取频道的检索表单字段数组

返回：
频道的检索表单字段数组
抛出：
WASException - m_mapFieldData为null

getSearchOpt

public java.lang.String getSearchOpt()
获取保存检索选项的字符串

返回：
保存检索选项的字符串

getSourceFileFieldString

public java.lang.String getSourceFileFieldString()
                                          throws WASException
获取频道的源文件字段字符串，不同字段以逗号分隔

返回：
频道的源文件字段字符串
抛出：
WASException - m_mapFieldData为null

getSourceFileFieldStringArray

public java.lang.String[] getSourceFileFieldStringArray()
                                                 throws WASException
获取频道的源文件字段数组

返回：
频道的源文件字段数组
抛出：
WASException - m_mapFieldData为null

getSources

public java.lang.String[] getSources()
获得检索的TRS数据库/视图

返回：
检索的TRS数据库/视图

getSQL

public java.lang.String getSQL()
获得频道的检索表达式

返回：
频道的检索表达式

getStatFieldString

public java.lang.String getStatFieldString()
                                    throws WASException
获取频道的分类统计字段字符串

返回：
频道的分类统计字段字符串
抛出：
WASException

getStatFieldStringArrary

public java.lang.String[] getStatFieldStringArrary()
                                            throws WASException
获取频道的分类统计字段数组

返回：
频道的分类统计字段数组
抛出：
WASException

getStyleName

public java.lang.String getStyleName()
获得显示风格名称

返回：
显示风格名称

getSynonymDic

public java.lang.String getSynonymDic()
获取用于频道检索的同义词典名称

返回：
同义词典名称

getTempletCombo

public java.lang.String getTempletCombo()
获取模板组合

返回：
模板组合

getThesaurusDic

public java.lang.String getThesaurusDic()
获取用于频道检索的主题词典名称

返回：
主题词典名称

getTimeLineFieldString

public java.lang.String getTimeLineFieldString()
                                        throws WASException
获取频道的时间轴字段字符串

返回：
频道的时间轴字段字符串
抛出：
WASException

getTimeLineFieldStringArrary

public java.lang.String[] getTimeLineFieldStringArrary()
                                                throws WASException
获取频道的时间轴字段数组

返回：
频道的时间轴字段数组
抛出：
WASException

getTreeName

public java.lang.String getTreeName()
获得所属频道树名称

覆盖：
类 Node 中的 getTreeName
返回：
所属频道树名称

hasAutoExtend

public boolean hasAutoExtend(java.lang.String strOpt)
频道自动扩展选项中是否含有指定的配置项

参数：
strOpt - 指定的配置项名称
返回：
含有则返回true，否则返回false

hasExtendOpt

public boolean hasExtendOpt(java.lang.String strOpt)
频道扩展检索选项中是否含有指定的配置项

参数：
strOpt - 指定的配置项名称
返回：
含有则返回true，否则返回false

hasHitType

public boolean hasHitType(java.lang.String strOpt)
频道命中点类型中是否含有指定的类型

参数：
strOpt - 指定的命中点类型
返回：
含有则返回true，否则返回false

hasSearchOpt

public boolean hasSearchOpt(java.lang.String strOpt)
频道检索选项中是否含有指定的配置项

参数：
strOpt - 指定的配置项名称
返回：
含有则返回true，否则返回false

inherit

public void inherit(ChannelNode parentNode)
             throws WASException
继承父节点的属性

参数：
parentNode - 父节点
抛出：
WASException

isQuickSelect

public boolean isQuickSelect()
是否进行估算检索

返回：
进行估算检索返回true，否则返回false

removeAllFields

public void removeAllFields()
                     throws WASException
从频道的字段集合中删除所有字段对象

抛出：
WASException - m_mapFieldData操作出错

setAdvSearchTemplate

public void setAdvSearchTemplate(java.lang.String strAdvSearchTemplate)
设置高级搜索模板

参数：
strAdvSearchTemplate - 高级搜索模板

setAllSources

public void setAllSources(java.lang.String strSources)
                   throws WASException
设置数据库/视图名称

参数：
strSources - 数据库/视图名称
抛出：
WASException - 参数strSources为空

setAntonymDic

public void setAntonymDic(java.lang.String dic)
设置用于频道检索的反义词典名称

参数：
dic - 反义词典名称

setAutoExtend

public void setAutoExtend(java.lang.String autoExtend)
设置自动扩展选项

参数：
autoExtend - 保存自动扩展选项的字符串

setBindFormID

public void setBindFormID(java.lang.String bindFormID)
设置绑定表单ID

参数：
bindFormID - 绑定表单ID

setChannelName

public void setChannelName(java.lang.String strChannelName)
设置频道名称

参数：
strChannelName - 频道名称

setChannelSQL

public void setChannelSQL(java.lang.String m_strChannelSQL)
设置频道条件

参数：
m_strChannelSQL - 频道条件

setCheckType

public void setCheckType(int iCheckType)
设置频道控制类型

参数：
iCheckType - 频道控制类型

setComment

public void setComment(java.lang.String strComment)
设置频道的说明信息

参数：
strComment - 频道的说明信息

setCreateTime

public void setCreateTime(java.sql.Date createTime)
设置创建日期

参数：
createTime - 创建日期

setDataSourceId

public void setDataSourceId(java.lang.String strDataSourceId)
设置数据源Id

参数：
strDataSourceId - 数据源Id

setDetailTemplate

public void setDetailTemplate(java.lang.String strDetailTemplate)
设置细览模板

参数：
strDetailTemplate - 细览模板

setExtendOpt

public void setExtendOpt(java.lang.String extendOpt)
设置扩展检索选项

参数：
extendOpt - 保存扩展检索选项的字符串

setExtraCfg

public void setExtraCfg(java.util.Hashtable m_extraCfg)
设置频道其它配置

参数：
m_extraCfg - 保存频道其它配置的哈希表

setExtraString

public void setExtraString(java.lang.String opt)
设置频道其它配置

参数：
opt - 表示频道其它配置的字符串，格式为：配置名称=配置值，多个配置以"#"分割

setField

public void setField(FieldData field)
              throws WASException
在频道的字段集合中添加字段对象

参数：
field - 字段对象
抛出：
WASException - m_mapFieldData操作出错

setFieldsByArray

public void setFieldsByArray(FieldData[] fieldDataArray)
                      throws WASException
添加字段对象数组到频道的字段集合中

参数：
fieldDataArray - 字段对象数组
抛出：
WASException - m_mapFieldData操作出错

setFieldsByString

public void setFieldsByString(java.lang.String strFieldsString)
                       throws WASException
从字符串中解析出DataField信息并写入到m_mapFieldData中

参数：
strFieldsString - DataField信息
抛出：
WASException - m_mapFieldData操作出错

setGrantRight

public void setGrantRight(java.lang.String strGrantRight)
设置存放WAS4升级的权限数据

参数：
strGrantRight - 存放WAS4升级的权限数据

setHitType

public void setHitType(java.lang.String hitType)
设置命中点类型

参数：
hitType - 命中点类型

setIndexTemplet

public void setIndexTemplet(java.lang.String indexTemplet)
设置主页模板

参数：
indexTemplet - 主页模板名称

setLastChangeTime

public void setLastChangeTime(java.sql.Date lastChangeTime)
设置最后一次修改日期

参数：
lastChangeTime - 最后一次修改日期

setMailTemplate

public void setMailTemplate(java.lang.String strMailTemplate)
设置邮件推荐模板

参数：
strMailTemplate -

setMapFieldData

public void setMapFieldData(MapFieldData mapFieldData)
设置数据库字段集合

参数：
mapFieldData - 数据库字段集合

setOrderBy

public void setOrderBy(java.lang.String strOrderBy)
设置频道的排序方式

参数：
strOrderBy - 频道的排序方式

setOutlineTemplate

public void setOutlineTemplate(java.lang.String strOutlineTemplate)
设置概览模板

参数：
strOutlineTemplate - 概览模板

setPrintTemplate

public void setPrintTemplate(java.lang.String strPrintTemplate)
设置打印模板

参数：
strPrintTemplate - 打印模板

setReduplicate

public void setReduplicate(java.lang.String reduplicate)
设置去重属性

参数：
reduplicate - 保存去重属性的字符串

setSearchOpt

public void setSearchOpt(java.lang.String searchOpt)
设置检索选项

参数：
searchOpt - 保存检索选项的字符串

setSources

public void setSources(java.lang.String[] strSources)
设置检索的TRS数据库/视图

参数：
strSources - 检索的TRS数据库/视图

setSQL

public void setSQL(java.lang.String strSQL)
设置频道的检索表达式

参数：
strSQL - 频道的检索表达式

setStyleName

public void setStyleName(java.lang.String strStyleName)
设置显示风格名称

参数：
strStyleName - 显示风格名称

setSynonymDic

public void setSynonymDic(java.lang.String dic)
设置用于频道检索的同义词典名称

参数：
dic - 同义词典名称

setTempletCombo

public void setTempletCombo(java.lang.String templetCombo)
设置模板组合

参数：
templetCombo - 模板组合

setThesaurusDic

public void setThesaurusDic(java.lang.String dic)
设置用于频道检索的主题词典名称

参数：
dic - 主题词典名称

setTreeName

public void setTreeName(java.lang.String strTreeName)
设置所属频道树名称

覆盖：
类 Node 中的 setTreeName
参数：
strTreeName - 所属频道树名称
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


ChannelTree

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 ChannelTree

java.lang.Object
    继承者  com.trs.was.tree.Tree
        继承者  com.trs.was.config.ChannelTree

public class ChannelTree
extends Tree

频道树类，扩展了Tree类

构造函数摘要
ChannelTree()
默认构造方法，调用父类的构造方法
方法摘要
从类 com.trs.was.tree.Tree 继承的方法
containNode, deleteAllSonNodes, deleteNode, getAllParents, getAllParentsID, getAllSons, getAllSonsID, getLastSonNode, getMapNodes, getNode, getNode, getRootNode, getSonOrder, getTreeName, getTreeSize, haveChildrens, insertNode, insertNode, moveNodes
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

ChannelTree

public ChannelTree()
默认构造方法，调用父类的构造方法

概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


ConfigData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 ConfigData

java.lang.Object
    继承者  com.trs.was.config.ConfigData

public class ConfigData
extends java.lang.Object

存储系统所有配置信息类，用于储存频道，导航等对象信息。

构造函数摘要
ConfigData()
构造方法，初始化各私有变量，对各私有变量赋予初值
方法摘要
java.lang.String | getAnonyAccount() 获得匿名帐号
java.lang.String | getAnonyGroup() 获取匿名用户所在组织
java.lang.String | getAnonyRole() 获取匿名用户所在角色
java.util.Hashtable | getCfgHash() 获取系统配置信息集合
com.trs.was.pool.ConnectionPool | getConnPool() 获得数据库连接池对象
java.lang.String | getDefaultAdvSearch() 获得默认高级搜索模板
java.lang.String | getDefaultDetail() 设置默认细览模板
java.lang.String | getDefaultMail() 获得默认邮件发送模板
java.lang.String | getDefaultOutline() 获得默认概览模板
java.lang.String | getDefaultPrint() 获得默认打印模板
java.util.Hashtable | getExpTempMap() 获取表达式模板集合
java.util.Hashtable | getFilterMap() 获取过滤词集合
java.util.Hashtable | getFormMap() 获取表单集合
java.util.Hashtable | getHotWord() 获取热搜词集合
java.util.Hashtable | getIpFilterMap() 获取IP限制集合
int | getLogLevel() 获得系统日志级别
java.lang.String | getMailAccount() 获得邮件服务器帐号
java.lang.String | getMailAddress() 获得发送邮件地址
java.lang.String | getMailPwd() 获得邮件服务器密码
MapChannel | getMapChannel() 获得频道树集合
MapDataSource | getMapDataSource() 获得数据源集合
MapGroup | getMapGroup() 获取用户组集合
boolean | getNeedReload() 获得是否需要重新加载
java.lang.String | getSMTPServer() 获得邮件服务器名称
java.util.Hashtable | getUserMap() 获取用户集合
boolean | isAnonymous() 获得是否允许匿名登录
void | setAnonyAccount(java.lang.String strAnonyAccount) 设置匿名帐号
void | setAnonyGroup(java.lang.String strAnonyGroup) 设置匿名用户所在组织
void | setAnonyRole(java.lang.String strAnonyRole) 设置匿名用户所在角色
void | setCfgHash(java.util.Hashtable hash) 设置系统配置信息集合
void | setConnPool(com.trs.was.pool.ConnectionPool connPool) 设置数据库连接池对象
void | setDefaultAdvSearch(java.lang.String strDefaultAdvSearch) 设置默认高级搜索模板
void | setDefaultDetail(java.lang.String strDefaultDetail) 设置默认细览模板
void | setDefaultOutline(java.lang.String strDefaultOutline) 设置默认概览模板
void | setExpTempMap(java.util.Hashtable expTempMap) 设置表达式模板集合
void | setFilterMap(java.util.Hashtable map) 设置过滤词集合
void | setFormMap(java.util.Hashtable map) 设置表单集合
void | setHotWord(java.util.Hashtable word) 设置热搜词集合
void | setIpFilterMap(java.util.Hashtable m_ipFilterMap) 设置IP限制集合
void | setLogLevel(int iLogLevel) 设置系统日志级别
void | setMailAccount(java.lang.String strMailAccount) 设置邮件服务器帐号
void | setMailAddress(java.lang.String strMailAddress) 设置发送邮件地址
void | setMailPwd(java.lang.String strMailPwd) 设置邮件服务器密码
void | setMapChannel(MapChannel mapChannel) 设置频道树集合
void | setMapDataSource(MapDataSource mapDataSource) 设置数据源集合
void | setMapGroup(MapGroup m_mapGroup) 设置用户组集合
void | setNeedReload(boolean bNeedReload) 设置是否需要重新加载
void | setSMTPServer(java.lang.String strSMTPServer) 设置邮件服务器名称
void | setUserMap(java.util.Hashtable m_userMap) 设置用户集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

ConfigData

public ConfigData()
           throws WASException
构造方法，初始化各私有变量，对各私有变量赋予初值

抛出：
WASException - 初始化私有变量时出错
方法详细信息

getAnonyAccount

public java.lang.String getAnonyAccount()
获得匿名帐号

返回：
匿名帐号

getAnonyGroup

public java.lang.String getAnonyGroup()
获取匿名用户所在组织

返回：
组织名称

getAnonyRole

public java.lang.String getAnonyRole()
获取匿名用户所在角色

返回：
角色名称

getCfgHash

public java.util.Hashtable getCfgHash()
获取系统配置信息集合

返回：
返回配置信息集合

getConnPool

public com.trs.was.pool.ConnectionPool getConnPool()
获得数据库连接池对象

返回：
数据库连接池对象

getDefaultAdvSearch

public java.lang.String getDefaultAdvSearch()
获得默认高级搜索模板

返回：
默认高级搜索模板

getDefaultDetail

public java.lang.String getDefaultDetail()
设置默认细览模板

返回：
默认细览模板

getDefaultMail

public java.lang.String getDefaultMail()
获得默认邮件发送模板

返回：
默认邮件发送模板

getDefaultOutline

public java.lang.String getDefaultOutline()
获得默认概览模板

返回：
默认概览模板

getDefaultPrint

public java.lang.String getDefaultPrint()
获得默认打印模板

返回：
默认打印模板

getExpTempMap

public java.util.Hashtable getExpTempMap()
获取表达式模板集合

返回：
返回表达式模板集合

getFilterMap

public java.util.Hashtable getFilterMap()
获取过滤词集合

返回：
返回过滤词集合

getFormMap

public java.util.Hashtable getFormMap()
获取表单集合

返回：
返回表单集合

getHotWord

public java.util.Hashtable getHotWord()
获取热搜词集合

返回：
返回热搜词集合

getIpFilterMap

public java.util.Hashtable getIpFilterMap()
获取IP限制集合

返回：
返回IP限制集合

getLogLevel

public int getLogLevel()
获得系统日志级别

返回：
系统日志级别

getMailAccount

public java.lang.String getMailAccount()
获得邮件服务器帐号

返回：
邮件服务器帐号

getMailAddress

public java.lang.String getMailAddress()
获得发送邮件地址

返回：
发送邮件地址

getMailPwd

public java.lang.String getMailPwd()
获得邮件服务器密码

返回：
邮件服务器密码

getMapChannel

public MapChannel getMapChannel()
获得频道树集合

返回：
频道树集合

getMapDataSource

public MapDataSource getMapDataSource()
获得数据源集合

返回：
数据源集合

getMapGroup

public MapGroup getMapGroup()
获取用户组集合

返回：
返回用户组集合

getNeedReload

public boolean getNeedReload()
获得是否需要重新加载

返回：
是否需要重新加载

getSMTPServer

public java.lang.String getSMTPServer()
获得邮件服务器名称

返回：
邮件服务器名称

getUserMap

public java.util.Hashtable getUserMap()
获取用户集合

返回：
返回用户集合

isAnonymous

public boolean isAnonymous()
获得是否允许匿名登录

返回：
是否允许匿名登录

setAnonyAccount

public void setAnonyAccount(java.lang.String strAnonyAccount)
设置匿名帐号

参数：
strAnonyAccount - 匿名帐号

setAnonyGroup

public void setAnonyGroup(java.lang.String strAnonyGroup)
设置匿名用户所在组织

参数：
strAnonyGroup -

setAnonyRole

public void setAnonyRole(java.lang.String strAnonyRole)
设置匿名用户所在角色

参数：
strAnonyRole - 角色名称

setCfgHash

public void setCfgHash(java.util.Hashtable hash)
设置系统配置信息集合

参数：
hash - 要设置的系统配置信息集合

setConnPool

public void setConnPool(com.trs.was.pool.ConnectionPool connPool)
设置数据库连接池对象

参数：
connPool - 数据库连接池对象

setDefaultAdvSearch

public void setDefaultAdvSearch(java.lang.String strDefaultAdvSearch)
设置默认高级搜索模板

参数：
strDefaultAdvSearch - 默认高级搜索模板

setDefaultDetail

public void setDefaultDetail(java.lang.String strDefaultDetail)
设置默认细览模板

参数：
strDefaultDetail - 默认细览模板

setDefaultOutline

public void setDefaultOutline(java.lang.String strDefaultOutline)
设置默认概览模板

参数：
strDefaultOutline - 默认概览模板

setExpTempMap

public void setExpTempMap(java.util.Hashtable expTempMap)
设置表达式模板集合

参数：
expTempMap - 要设置的表达式模板集合

setFilterMap

public void setFilterMap(java.util.Hashtable map)
设置过滤词集合

参数：
map - 要设置的过滤词集合

setFormMap

public void setFormMap(java.util.Hashtable map)
设置表单集合

参数：
map - 要设置的表单集合

setHotWord

public void setHotWord(java.util.Hashtable word)
设置热搜词集合

参数：
word - 要设置的热搜词集合

setIpFilterMap

public void setIpFilterMap(java.util.Hashtable m_ipFilterMap)
设置IP限制集合

参数：
m_ipFilterMap - 要设置的IP限制集合

setLogLevel

public void setLogLevel(int iLogLevel)
设置系统日志级别

参数：
iLogLevel - 系统日志级别

setMailAccount

public void setMailAccount(java.lang.String strMailAccount)
设置邮件服务器帐号

参数：
strMailAccount - 邮件服务器帐号

setMailAddress

public void setMailAddress(java.lang.String strMailAddress)
设置发送邮件地址

参数：
strMailAddress - 发送邮件地址

setMailPwd

public void setMailPwd(java.lang.String strMailPwd)
设置邮件服务器密码

参数：
strMailPwd - 邮件服务器密码

setMapChannel

public void setMapChannel(MapChannel mapChannel)
设置频道树集合

参数：
mapChannel - 频道树集合

setMapDataSource

public void setMapDataSource(MapDataSource mapDataSource)
设置数据源集合

参数：
mapDataSource - 数据源集合

setMapGroup

public void setMapGroup(MapGroup m_mapGroup)
设置用户组集合

参数：
m_mapGroup - 要设置的用户组集合

setNeedReload

public void setNeedReload(boolean bNeedReload)
设置是否需要重新加载

参数：
bNeedReload - 是否需要重新加载

setSMTPServer

public void setSMTPServer(java.lang.String strSMTPServer)
设置邮件服务器名称

参数：
strSMTPServer - 邮件服务器名称

setUserMap

public void setUserMap(java.util.Hashtable m_userMap)
设置用户集合

参数：
m_userMap - 要设置的用户集合
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


DataSource

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 DataSource

java.lang.Object
    继承者  com.trs.was.config.DataSource

public class DataSource
extends java.lang.Object

数据源对象类。

构造函数摘要
DataSource()
方法摘要
int | getCurrentUserType() 获取当前用户权限级别
java.lang.String | getDataSourceId() 获得数据源id
java.lang.String | getDataSourceName() 获得数据源名称
java.lang.String | getFullVersion() 获取数据源TRS服务器完整的版本号
double | getServerVersion() 获取数据源TRS服务器版本号
java.lang.String | getTrsIP() 获得TRS服务器IP
java.lang.String | getTrsPassword() 获得TRS用户密码
java.lang.String | getTrsPort() 获得TRS服务器端口
java.lang.String | getTrsUserName() 获得TRS用户帐号
boolean | isCluster() 判断数据源是否是集群
void | setCurrentUserType(int currentUserType) 设置当前用户权限级别
void | setDataSourceId(java.lang.String strDataSourceId) 设置数据源id
void | setDataSourceName(java.lang.String strDataSourceName) 设置数据源名称
void | setFullVersion(java.lang.String version) 设置数据源TRS服务器完整的版本号
void | setIsCluster(boolean isCluster) 设置数据源是否是集群
void | setTrsIP(java.lang.String strTrsIP) 设置TRS服务器IP
void | setTrsPassword(java.lang.String strTrsPassword) 设置TRS用户密码
void | setTrsPort(java.lang.String strTrsPort) 设置TRS服务器端口
void | setTrsUserName(java.lang.String strTrsUserName) 设置TRS用户帐号
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

DataSource

public DataSource()
方法详细信息

getCurrentUserType

public int getCurrentUserType()
获取当前用户权限级别

返回：
当前用户权限级别

getDataSourceId

public java.lang.String getDataSourceId()
获得数据源id

返回：
the m_strDataSourceId

getDataSourceName

public java.lang.String getDataSourceName()
获得数据源名称

返回：
数据源名称

getFullVersion

public java.lang.String getFullVersion()
获取数据源TRS服务器完整的版本号

返回：
数据源TRS服务器的版本号

getServerVersion

public double getServerVersion()
获取数据源TRS服务器版本号

返回：
数据源TRS服务器版本号

getTrsIP

public java.lang.String getTrsIP()
获得TRS服务器IP

返回：
TRS服务器IP

getTrsPassword

public java.lang.String getTrsPassword()
获得TRS用户密码

返回：
TRS用户密码

getTrsPort

public java.lang.String getTrsPort()
获得TRS服务器端口

返回：
TRS服务器端口

getTrsUserName

public java.lang.String getTrsUserName()
获得TRS用户帐号

返回：
TRS用户帐号

isCluster

public boolean isCluster()
判断数据源是否是集群

返回：
是集群返回true，否则返回false

setCurrentUserType

public void setCurrentUserType(int currentUserType)
设置当前用户权限级别

参数：
currentUserType - 当前用户权限级别

setDataSourceId

public void setDataSourceId(java.lang.String strDataSourceId)
设置数据源id

参数：
strDataSourceId - the m_strDataSourceId to set

setDataSourceName

public void setDataSourceName(java.lang.String strDataSourceName)
设置数据源名称

参数：
strDataSourceName - 数据源名称

setFullVersion

public void setFullVersion(java.lang.String version)
设置数据源TRS服务器完整的版本号

参数：
version - 数据源TRS服务器的版本号

setIsCluster

public void setIsCluster(boolean isCluster)
设置数据源是否是集群

参数：
isCluster - 是否是集群

setTrsIP

public void setTrsIP(java.lang.String strTrsIP)
设置TRS服务器IP

参数：
strTrsIP - TRS服务器IP

setTrsPassword

public void setTrsPassword(java.lang.String strTrsPassword)
设置TRS用户密码

参数：
strTrsPassword - TRS用户密码

setTrsPort

public void setTrsPort(java.lang.String strTrsPort)
设置TRS服务器端口

参数：
strTrsPort - TRS服务器端口

setTrsUserName

public void setTrsUserName(java.lang.String strTrsUserName)
设置TRS用户帐号

参数：
strTrsUserName - TRS用户帐号
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


FieldData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 FieldData

java.lang.Object
    继承者  com.trs.was.config.FieldData
所有已实现的接口：
java.lang.Cloneable
public class FieldData
extends java.lang.Object
implements java.lang.Cloneable

字段对象。

构造函数摘要
FieldData()
默认构造方法。
方法摘要
void | addSpecialType(int iSpecialType) 为该字段对象添加指定特殊类型
java.lang.Object | clone() 克隆对象
java.lang.String | getColumnType() 获得字段类型
java.lang.String | getFieldDisName() 获得字段显示名
java.lang.String | getFieldName() 获得字段名
java.lang.String | getFieldSeq() 获取字段所有特殊类型的字段序号
int | getFieldSpecialType() 获得字段特殊类型
int | getFieldType() 获得字段类型
int | getSeq(int iFieldSpecialType) 根据字段特殊类型获取字段序号
boolean | isSpecialType(int iSpecialType) 判断该字段是否包含指定的特殊类型
void | removeSpecialType(int iSpecialType) 为该字段移除指定的特殊类型
void | setColumnType(java.lang.String strColumnType) 设置字段类型
void | setFieldDisName(java.lang.String strFieldDisName) 设置字段显示名
void | setFieldName(java.lang.String strFieldName) 设置字段名
void | setFieldSeq(java.lang.String strFieldSeq) 解析字段序号字符串
void | setFieldSpecialType(int iFieldSpecialType) 设置字段特殊类型
void | setFieldType(int iFieldType) 设置字段类型
void | setSeq(int iFieldSpecialType, int iSeq) 根据字段特殊类型设置字段序号
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

FieldData

public FieldData()
默认构造方法。

方法详细信息

addSpecialType

public void addSpecialType(int iSpecialType)
为该字段对象添加指定特殊类型

参数：
iSpecialType - 特殊类型

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
克隆对象

覆盖：
类 java.lang.Object 中的 clone
抛出：
java.lang.CloneNotSupportedException

getColumnType

public java.lang.String getColumnType()
获得字段类型

返回：
字段类型

getFieldDisName

public java.lang.String getFieldDisName()
获得字段显示名

返回：
字段显示名

getFieldName

public java.lang.String getFieldName()
获得字段名

返回：
字段名

getFieldSeq

public java.lang.String getFieldSeq()
                             throws WASException
获取字段所有特殊类型的字段序号

返回：
所有特殊类型的字段序号
抛出：
WASException

getFieldSpecialType

public int getFieldSpecialType()
获得字段特殊类型

返回：
字段特殊类型

getFieldType

public int getFieldType()
获得字段类型

返回：
字段类型

getSeq

public int getSeq(int iFieldSpecialType)
           throws WASException
根据字段特殊类型获取字段序号

参数：
iFieldSpecialType - 字段特殊类型
返回：
字段序号
抛出：
WASException

isSpecialType

public boolean isSpecialType(int iSpecialType)
判断该字段是否包含指定的特殊类型

参数：
iSpecialType - 特殊类型
返回：
特殊类型

removeSpecialType

public void removeSpecialType(int iSpecialType)
为该字段移除指定的特殊类型

参数：
iSpecialType - 特殊类型

setColumnType

public void setColumnType(java.lang.String strColumnType)
设置字段类型

参数：
strColumnType - 字段类型

setFieldDisName

public void setFieldDisName(java.lang.String strFieldDisName)
设置字段显示名

参数：
strFieldDisName - 字段显示名

setFieldName

public void setFieldName(java.lang.String strFieldName)
设置字段名

参数：
strFieldName - 字段名

setFieldSeq

public void setFieldSeq(java.lang.String strFieldSeq)
                 throws WASException
解析字段序号字符串

参数：
strFieldSeq -
抛出：
WASException

setFieldSpecialType

public void setFieldSpecialType(int iFieldSpecialType)
设置字段特殊类型

参数：
iFieldSpecialType - 字段特殊类型

setFieldType

public void setFieldType(int iFieldType)
设置字段类型

参数：
iFieldType - 字段类型

setSeq

public void setSeq(int iFieldSpecialType,
                   int iSeq)
            throws WASException
根据字段特殊类型设置字段序号

参数：
iFieldSpecialType - 字段特殊类型
iSeq - 字段序号值
抛出：
WASException
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


LoginConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 LoginConfig

java.lang.Object
    继承者  com.trs.was.config.LoginConfig
所有已实现的接口：
java.io.Serializable, java.util.EventListener, javax.servlet.http.HttpSessionBindingListener
public class LoginConfig
extends java.lang.Object
implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable

用户登录配置信息类。

另请参见：
序列化表格

构造函数摘要
LoginConfig()
默认构造方法，初始化各成员变量
方法摘要
java.lang.String | getCurrentChannel() 获得当前频道
java.lang.String | getUserName() 返回当前用户名，用于兼容was4
WASUser | getWasUser() 获得当前登录用户
boolean | login(java.sql.Connection conn, java.lang.String strUserName, java.lang.String strPassword) 登录操作
void | setWasUser(WASUser wasUser) 设置当前登录用户
void | valueBound(javax.servlet.http.HttpSessionBindingEvent event) 对象插入到SESSION时触发的操作
void | valueUnbound(javax.servlet.http.HttpSessionBindingEvent event) 对象从SESSION中删除时触发的操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

LoginConfig

public LoginConfig()
默认构造方法，初始化各成员变量

方法详细信息

getCurrentChannel

public java.lang.String getCurrentChannel()
获得当前频道

返回：
当前频道

getUserName

public java.lang.String getUserName()
返回当前用户名，用于兼容was4

返回：
用户名称

getWasUser

public WASUser getWasUser()
获得当前登录用户

返回：
当前登录用户

login

public boolean login(java.sql.Connection conn,
                     java.lang.String strUserName,
                     java.lang.String strPassword)
              throws WASException,
                     java.sql.SQLException
登录操作

参数：
conn - 数据库连接
strUserName - 用户名
strPassword - 密码
返回：
登录是否成功
抛出：
WASException - 登录异常
java.sql.SQLException - 关于数据库访问错误或其他错误信息的异常

setWasUser

public void setWasUser(WASUser wasUser)
设置当前登录用户

参数：
wasUser - 当前登录用户对象

valueBound

public void valueBound(javax.servlet.http.HttpSessionBindingEvent event)
对象插入到SESSION时触发的操作

指定者：
接口 javax.servlet.http.HttpSessionBindingListener 中的 valueBound

valueUnbound

public void valueUnbound(javax.servlet.http.HttpSessionBindingEvent event)
对象从SESSION中删除时触发的操作

指定者：
接口 javax.servlet.http.HttpSessionBindingListener 中的 valueUnbound
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


MapChannel

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 MapChannel

java.lang.Object
    继承者  com.trs.was.tree.MapTree
        继承者  com.trs.was.config.MapChannel

public class MapChannel
extends MapTree

频道树对象集合类。

构造函数摘要
MapChannel()
默认构造方法，无实现
MapChannel(java.util.Hashtable trees)
构造方法
方法摘要
从类 com.trs.was.tree.MapTree 继承的方法
buildTree, getNode, getSize, getTree, getTreeNames, getTrees, removeTree, setTree
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

MapChannel

public MapChannel()
默认构造方法，无实现

MapChannel

public MapChannel(java.util.Hashtable trees)
           throws WASException
构造方法

参数：
trees - 存储树集合的哈希表
抛出：
WASException - 生成树的过程中的异常
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


MapDataSource

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 MapDataSource

java.lang.Object
    继承者  com.trs.was.config.MapDataSource

public class MapDataSource
extends java.lang.Object

数据源对象集合类。

构造函数摘要
MapDataSource()
默认构造方法，初始化各成员变量。
方法摘要
boolean | contains(java.lang.String strDataSourceId) 查找指定strDataSourceId对应的数据源是否存在于数据源对象集合中
boolean | containsName(java.lang.String strDataSourceName) 查找指定strDataSourceName对应的数据源是否存在于数据源对象集合中
DataSource | getDataSource(java.lang.String strDataSourceId) 从数据源对象集合中取出指定strDataSourceId对应的数据源
java.lang.String | getIdFromName(java.lang.String strDataSourceName) 查找指定strDataSourceName对应的id
java.util.Enumeration | getKeys() 返回hashtable的key
void | removeDataSource(java.lang.String strDataSourceId) 从数据源对象集合中删除指定strDataSourceId对应的数据源
void | setDataSource(DataSource dataSource) 向数据源对象集合中写入指定strDataSourceId对应的数据源
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

MapDataSource

public MapDataSource()
默认构造方法，初始化各成员变量。

方法详细信息

contains

public boolean contains(java.lang.String strDataSourceId)
                 throws WASException
查找指定strDataSourceId对应的数据源是否存在于数据源对象集合中

参数：
strDataSourceId - 数据源Id
返回：
对应的数据源是否存在于数据源对象集合中
抛出：
WASException - m_mapDataSource为null

containsName

public boolean containsName(java.lang.String strDataSourceName)
                     throws WASException,
                            java.sql.SQLException
查找指定strDataSourceName对应的数据源是否存在于数据源对象集合中

参数：
strDataSourceName - 数据源名
返回：
对应的数据源是否存在于数据源对象集合中
抛出：
WASException - m_mapDataSource为null
java.sql.SQLException

getDataSource

public DataSource getDataSource(java.lang.String strDataSourceId)
                         throws WASException
从数据源对象集合中取出指定strDataSourceId对应的数据源

参数：
strDataSourceId - 数据源Id
返回：
对应的数据源
抛出：
WASException - m_mapDataSource为null

getIdFromName

public java.lang.String getIdFromName(java.lang.String strDataSourceName)
                               throws WASException
查找指定strDataSourceName对应的id

参数：
strDataSourceName - 数据源名称
返回：
strDataSourceName对应的id
抛出：
WASException - m_mapDataSource为null
java.sql.SQLException

getKeys

public java.util.Enumeration getKeys()
                              throws WASException
返回hashtable的key

返回：
hashtable的key
抛出：
WASException - m_mapDataSource为null

removeDataSource

public void removeDataSource(java.lang.String strDataSourceId)
                      throws WASException
从数据源对象集合中删除指定strDataSourceId对应的数据源

参数：
strDataSourceId - 数据源Id
抛出：
WASException - m_mapDataSource为null

setDataSource

public void setDataSource(DataSource dataSource)
                   throws WASException
向数据源对象集合中写入指定strDataSourceId对应的数据源

参数：
dataSource - 数据源
抛出：
WASException - m_mapDataSource为null
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


MapFieldData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 MapFieldData

java.lang.Object
    继承者  com.trs.was.config.MapFieldData
所有已实现的接口：
java.lang.Cloneable
public class MapFieldData
extends java.lang.Object
implements java.lang.Cloneable

存储频道相应的数据库字段对象的集合类

构造函数摘要
MapFieldData()
默认构造方法，初始化成员变量
方法摘要
java.lang.Object | clone() 克隆对象
FieldData | getField(java.lang.String strFieldName) 获取指定名称的字段对象
FieldData[] | getFieldArray() 获取所有字段对象
FieldData | getFieldByDisplayName(java.lang.String strDisplayName) 根据字段显示名称获取指定字段对象
java.util.Enumeration | getFieldNames() 枚举频道的字段名称
int | getFieldNum() 获取字段个数
FieldData[] | getFieldsByType(int iSpecialType) 根据字段特殊类型获取指定字段对象
java.lang.String[] | getFieldStringArrayByType(int iSpecialType) 根据字段特殊类型获取指定字段对象的名称数组
java.lang.String | getFieldStringByType(int iSpecialType) 根据字段类型获取指定字段对象的名称串
void | removeAllFields() 删除频道字段集合中的所有字段对象
FieldData | removeField(java.lang.String strFieldName) 从频道字段集合中删除指定名称的字段对象
void | setField(FieldData field) 添加字段对象到频道的字段集合中
void | setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中
void | setFieldsByString(java.lang.String strFieldsString) 从字符串中解析出DataField信息并写入到m_mapFields
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

MapFieldData

public MapFieldData()
默认构造方法，初始化成员变量

方法详细信息

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
克隆对象

覆盖：
类 java.lang.Object 中的 clone
抛出：
java.lang.CloneNotSupportedException

getField

public FieldData getField(java.lang.String strFieldName)
                   throws WASException
获取指定名称的字段对象

参数：
strFieldName - 字段名
返回：
对应的字段对象
抛出：
WASException - m_mapFields为null

getFieldArray

public FieldData[] getFieldArray()
                          throws WASException
获取所有字段对象

返回：
所有的字段对象
抛出：
WASException - m_mapFields为null

getFieldByDisplayName

public FieldData getFieldByDisplayName(java.lang.String strDisplayName)
                                throws WASException
根据字段显示名称获取指定字段对象

参数：
strDisplayName - 字段显示名
返回：
对应的字段对象
抛出：
WASException - m_mapFields为null

getFieldNames

public java.util.Enumeration getFieldNames()
                                    throws WASException
枚举频道的字段名称

返回：
Enumeration类型的频道的字段名称
抛出：
WASException - m_mapFields为null

getFieldNum

public int getFieldNum()
                throws WASException
获取字段个数

返回：
字段个数
抛出：
WASException - m_mapFields为null

getFieldsByType

public FieldData[] getFieldsByType(int iSpecialType)
                            throws WASException
根据字段特殊类型获取指定字段对象

参数：
iSpecialType - 字段特殊类型
返回：
对应的字段对象
抛出：
WASException - m_mapFields为null

getFieldStringArrayByType

public java.lang.String[] getFieldStringArrayByType(int iSpecialType)
                                             throws WASException
根据字段特殊类型获取指定字段对象的名称数组

参数：
iSpecialType - 字段特殊类型
返回：
对应的字段对象名称数组
抛出：
WASException - m_mapFields为null

getFieldStringByType

public java.lang.String getFieldStringByType(int iSpecialType)
                                      throws WASException
根据字段类型获取指定字段对象的名称串

参数：
iSpecialType - 字段特殊类型
返回：
以","分隔的指定字段对象的名称字符串
抛出：
WASException - m_mapFields为null

removeAllFields

public void removeAllFields()
                     throws WASException
删除频道字段集合中的所有字段对象

抛出：
WASException - m_mapFields为null

removeField

public FieldData removeField(java.lang.String strFieldName)
                      throws WASException
从频道字段集合中删除指定名称的字段对象

参数：
strFieldName - 字段名
返回：
被删除的字段对象
抛出：
WASException - m_mapFields为null

setField

public void setField(FieldData field)
              throws WASException
添加字段对象到频道的字段集合中

参数：
field - 字段对象
抛出：
WASException - m_mapFields为null

setFieldsByArray

public void setFieldsByArray(FieldData[] fieldDataArray)
                      throws WASException
添加字段对象数组到频道的字段集合中

参数：
fieldDataArray - 字段对象数组
抛出：
WASException - m_mapFields为null

setFieldsByString

public void setFieldsByString(java.lang.String strFieldsString)
                       throws WASException
从字符串中解析出DataField信息并写入到m_mapFields

参数：
strFieldsString - 包含字段信息的字符串
抛出：
WASException - m_mapFields为null
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


MapGroup

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 MapGroup

java.lang.Object
    继承者  com.trs.was.tree.MapTree
        继承者  com.trs.was.config.MapGroup

public class MapGroup
extends MapTree

用户组树对象集合类。

构造函数摘要
MapGroup()
默认构造方法，无实现
MapGroup(java.util.Hashtable trees)
构造方法
方法摘要
从类 com.trs.was.tree.MapTree 继承的方法
buildTree, getNode, getSize, getTree, getTreeNames, getTrees, removeTree, setTree
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

MapGroup

public MapGroup()
默认构造方法，无实现

MapGroup

public MapGroup(java.util.Hashtable trees)
         throws WASException
构造方法

参数：
trees - 存储树集合的哈希表
抛出：
WASException - 生成树的过程中的异常
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


RequestOperation

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 RequestOperation

java.lang.Object
    继承者  com.trs.was.config.RequestOperation

public class RequestOperation
extends java.lang.Object

请求参数处理类,用于对HTTP请求参数进行相应的编码处理.

构造函数摘要
RequestOperation()
方法摘要
static boolean | getBoolParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的布尔类型参数值
static boolean | getBoolParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, boolean bDefaultValue) 获取请求中布尔类型的参数值
static boolean[] | getBoolParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取多个布尔类型参数的值
static int | getIntParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的整数类型参数值
static int | getIntParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, int iDefaultValue) 获取请求中的整数类型参数值
static int[] | getIntParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的多个整数类型参数值。
static long | getLongParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, int lDefaultValue) 获取请求中长整型参数的参数值
static java.lang.String | getParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的参数值。
static java.lang.String | getParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strEncoding, java.lang.String strParameterName) 获取请求中的参数值。
static java.lang.String[] | getParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的多个参数值。
static java.lang.String[] | getParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strEncoding, java.lang.String strParameterName) 获取请求中的多个参数值。
static java.lang.String | getStrParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, java.lang.String strDefaultValue) 获取请求中字符串型参数值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

RequestOperation

public RequestOperation()
方法详细信息

getBoolParameter

public static boolean getBoolParameter(javax.servlet.http.HttpServletRequest request,
                                       java.lang.String strParameterName)
                                throws WASException
获取请求中的布尔类型参数值

参数：
request - 请求对象
strParameterName - 参数名称
返回：
参数值
抛出：
WASException

getBoolParameter

public static boolean getBoolParameter(javax.servlet.http.HttpServletRequest request,
                                       java.lang.String strParameterName,
                                       boolean bDefaultValue)
                                throws WASException
获取请求中布尔类型的参数值

参数：
request - 请求对象
strParameterName - 参数名称
bDefaultValue - 出现异常时返回的默认值
返回：
返回参数值
抛出：
WASException

getBoolParameterValues

public static boolean[] getBoolParameterValues(javax.servlet.http.HttpServletRequest request,
                                               java.lang.String strParameterName)
                                        throws WASException
获取多个布尔类型参数的值

参数：
request - 请求对象
strParameterName - 参数名称
返回：
返回参数值数组
抛出：
WASException

getIntParameter

public static int getIntParameter(javax.servlet.http.HttpServletRequest request,
                                  java.lang.String strParameterName)
                           throws WASException
获取请求中的整数类型参数值

参数：
request - Servlet请求
strParameterName - 参数名称
返回：
参数值
抛出：
WASException

getIntParameter

public static int getIntParameter(javax.servlet.http.HttpServletRequest request,
                                  java.lang.String strParameterName,
                                  int iDefaultValue)
                           throws WASException
获取请求中的整数类型参数值

参数：
request - Servlet请求
strParameterName - 参数值
iDefaultValue - 当出现异常时返回的默认值
返回：
返回参数值
抛出：
WASException

getIntParameterValues

public static int[] getIntParameterValues(javax.servlet.http.HttpServletRequest request,
                                          java.lang.String strParameterName)
                                   throws WASException
获取请求中的多个整数类型参数值。

参数：
request - 请求对象
strParameterName - 参数名称
返回：
返回参数值数组
抛出：
WASException

getLongParameter

public static long getLongParameter(javax.servlet.http.HttpServletRequest request,
                                    java.lang.String strParameterName,
                                    int lDefaultValue)
                             throws WASException
获取请求中长整型参数的参数值

参数：
request - 请求对象
strParameterName - 参数名称
lDefaultValue - 出现异常时返回的参数值
返回：
返回参数值
抛出：
WASException

getParameter

public static java.lang.String getParameter(javax.servlet.http.HttpServletRequest request,
                                            java.lang.String strParameterName)
                                     throws WASException
获取请求中的参数值。

参数：
request - Servlet请求
strParameterName - 参数名称
返回：
参数值
抛出：
WASException

getParameter

public static java.lang.String getParameter(javax.servlet.http.HttpServletRequest request,
                                            java.lang.String strEncoding,
                                            java.lang.String strParameterName)
                                     throws WASException
获取请求中的参数值。

参数：
request - Servlet请求
strEncoding - 编码类型
strParameterName - 参数名称
返回：
参数值
抛出：
WASException

getParameterValues

public static java.lang.String[] getParameterValues(javax.servlet.http.HttpServletRequest request,
                                                    java.lang.String strParameterName)
                                             throws WASException
获取请求中的多个参数值。

参数：
request - SERVLET请求
strParameterName - 参数名称
返回：
参数值数组
抛出：
WASException

getParameterValues

public static java.lang.String[] getParameterValues(javax.servlet.http.HttpServletRequest request,
                                                    java.lang.String strEncoding,
                                                    java.lang.String strParameterName)
                                             throws WASException
获取请求中的多个参数值。

参数：
request - SERVLET请求
strEncoding - 编码类型
strParameterName - 参数名称
返回：
参数值数组
抛出：
WASException

getStrParameter

public static java.lang.String getStrParameter(javax.servlet.http.HttpServletRequest request,
                                               java.lang.String strParameterName,
                                               java.lang.String strDefaultValue)
                                        throws WASException
获取请求中字符串型参数值

参数：
request - 请求对象
strParameterName - 参数名称
strDefaultValue - 出现异常时返回的默认值
返回：
返回参数值
抛出：
WASException
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


SearchData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 SearchData

java.lang.Object
    继承者  com.trs.was.config.SearchData

public class SearchData
extends java.lang.Object

用于储存标准检索请求参数。

构造函数摘要
SearchData()
方法摘要
java.lang.String | getAllSearchWord() 获取所有检索条件。
int | getBack() 获取回退操作的步数
java.lang.String | getChannelID() 获取频道ID号
java.lang.String | getClassColumn() 获取分类统计字段名称
java.lang.String | getClassRoot() 获取分类树根节点
java.lang.String | getClassSQL() 获取分类统计条件表达式
java.lang.String | getCustomExpr() 获取自定义表达式
java.lang.String | getDefaultSearchColumn() 获取缺省检索字段
long | getEstimateStops() 获取至少返回的记录数（用于快速返回）
long | getEstimateUnit() 获取每个逻辑段包含的记录数（用于快速检索）
java.lang.String | getExtendOpt() 获取扩展检索选项
java.lang.String | getExtension() 获取扩展检索方式
java.lang.String | getHitType() 获取命中点类型
int[] | getIRecords() 获取当前记录号数组
java.lang.String | getKeyWord() 获取关键词，即检索框内的检索词
java.lang.String | getLicenseCode() 获取系统许可证
java.lang.String | getOrderBy() 获取排序方式
int | getOutlinePage() 获取概览导航显示页码数
int | getPage() 获取当前页面号
int | getPerpage() 获取每页记录数
java.lang.String | getPreSearchWord() 获取上一次检索表达式
java.lang.String | getPrimaryKeyValue() 获取主键值
long | getResultNum() 获取结果记录总数
java.lang.String | getSearchOption() 获取检索选项
java.lang.String | getSearchWord() 获取检索表达式
boolean | getSecondSearch() 获取是否二次检索
java.lang.String | getSortField() 获取排序方式表达式
java.lang.String[] | getSRecords() 获取当前记录号数组
java.lang.String | getStrRecords() 获得记录号
java.lang.String | getTempletFile() 获取模板文件
java.lang.String | getTimeLineExpr() 获取用于显示时间轴的检索表达式
java.lang.String | getToken() 获取预览校验
boolean | isIgnoreTimeLine() 是否忽略时间轴表达式
boolean | isQuickSelect() 是否使用快速返回
boolean | isRelationSearch() 获取是否使用相关文章检索
void | setBack(java.lang.String strBack) 设置回退操作的步数
void | setChannelID(java.lang.String strChannelID) 设置频道ID号
void | setClassColumn(java.lang.String classColumn) 设置分类统计字段名称
void | setClassRoot(java.lang.String classRoot) 设置分类书根节点
void | setClassSQL(java.lang.String m_strClassSQL) 设置分类统计条件表达式
void | setCustomExpr(java.lang.String m_strCustomExpr) 设置自定义表达式
void | setDefaultSearchColumn(java.lang.String strDefaultSearchColumn) 设置缺省检索字段
void | setEstimateStops(long lEstimateStops) 设置至少返回的记录数（用于快速返回）
void | setEstimateUnit(long lEstimateUnit) 设置每个逻辑段包含的记录数（用于快速检索）
void | setExtendOpt(java.lang.String m_strExtendOpt) 设置扩展检索选项
void | setExtension(java.lang.String strExtension) 设置扩展检索方式
void | setHitType(java.lang.String hitType) 设置命中点类型
void | setIgnoreTimeLine(boolean bIgnoreTimeLine) 设置是否忽略时间轴表达式
void | setIRecords(int[] iaRecords) 设置当前记录号数组
void | setKeyWord(java.lang.String strKeyWord) 设置关键词，即检索框内的检索词
void | setLicenseCode(java.lang.String strLicenseCode) 设置系统许可证
void | setOrderBy(java.lang.String strOrderBy) 设置排序方式
void | setOutlinePage(int outlinePage) 设置概览导航显示页码数
void | setPage(java.lang.String strPage) 设置当前页面号
void | setPerpage(int perpage) 设置每页记录数
void | setPreSearchWord(java.lang.String strPreSearchWord) 设置上一次检索表达式
void | setPrimaryKeyValue(java.lang.String strPrimaryKeyValue) 设置主键值
void | setQuickSelect(boolean bQuickSelect) 设置是否使用快速返回
void | setRelationSearch(boolean m_bRelationSearch) 设置是否使用相关文章检索
void | setResultNum(long lResultNum) 设置结果记录总数
void | setSearchOption(java.lang.String strSearchOption) 设置检索选项
void | setSearchWord(java.lang.String strSearchWord) 设置检索表达式
void | setSecondSearch(java.lang.String strSecondSearch) 设置是否二次检索
void | setSortField(java.lang.String strSortField) 设置排序方式表达式
void | setSRecords(java.lang.String[] saRecords) 设置当前记录号数组
void | setTempletFile(java.lang.String strTempletFile) 设置模板文件
void | setTimeLineExpr(java.lang.String timeLineExpr) 设置用于显示时间轴的检索表达式
void | setToken(java.lang.String m_strToken) 设置预览校验
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

SearchData

public SearchData()
方法详细信息

getAllSearchWord

public java.lang.String getAllSearchWord()
获取所有检索条件。

getBack

public int getBack()
获取回退操作的步数

返回：
返回回退操作的步数

getChannelID

public java.lang.String getChannelID()
获取频道ID号

返回：
返回频道ID号

getClassColumn

public java.lang.String getClassColumn()
获取分类统计字段名称

返回：
返回分类统计字段名称

getClassRoot

public java.lang.String getClassRoot()
获取分类树根节点

返回：
返回分类树根节点

getClassSQL

public java.lang.String getClassSQL()
获取分类统计条件表达式

返回：
返回分类统计条件表达式

getCustomExpr

public java.lang.String getCustomExpr()
获取自定义表达式

返回：
返回自定义表达式

getDefaultSearchColumn

public java.lang.String getDefaultSearchColumn()
获取缺省检索字段

返回：
返回缺省检索字段

getEstimateStops

public long getEstimateStops()
获取至少返回的记录数（用于快速返回）

返回：
至少返回的记录数

getEstimateUnit

public long getEstimateUnit()
获取每个逻辑段包含的记录数（用于快速检索）

返回：
返回每个逻辑段包含的记录数

getExtendOpt

public java.lang.String getExtendOpt()
获取扩展检索选项

返回：
返回扩展检索选项

getExtension

public java.lang.String getExtension()
获取扩展检索方式

返回：
返回扩展检索方式

getHitType

public java.lang.String getHitType()
获取命中点类型

返回：
返回命中点类型

getIRecords

public int[] getIRecords()
获取当前记录号数组

返回：
返回当前记录号数组

getKeyWord

public java.lang.String getKeyWord()
获取关键词，即检索框内的检索词

返回：
返回关键词

getLicenseCode

public java.lang.String getLicenseCode()
获取系统许可证

返回：
返回系统许可证

getOrderBy

public java.lang.String getOrderBy()
获取排序方式

返回：
返回排序方式

getOutlinePage

public int getOutlinePage()
获取概览导航显示页码数

返回：
返回概览导航显示页码数

getPage

public int getPage()
获取当前页面号

返回：
返回当前页面号

getPerpage

public int getPerpage()
获取每页记录数

返回：
返回每页记录数

getPreSearchWord

public java.lang.String getPreSearchWord()
获取上一次检索表达式

返回：
返回上一次检索表达式

getPrimaryKeyValue

public java.lang.String getPrimaryKeyValue()
获取主键值

返回：
返回主键值

getResultNum

public long getResultNum()
获取结果记录总数

返回：
返回结果记录总数

getSearchOption

public java.lang.String getSearchOption()
获取检索选项

返回：
返回检索选项

getSearchWord

public java.lang.String getSearchWord()
获取检索表达式

返回：
返回检索表达式

getSecondSearch

public boolean getSecondSearch()
获取是否二次检索

返回：
返回是否二次检索

getSortField

public java.lang.String getSortField()
获取排序方式表达式

返回：
返回排序方式表达式

getSRecords

public java.lang.String[] getSRecords()
获取当前记录号数组

返回：
返回当前记录号数组

getStrRecords

public java.lang.String getStrRecords()
                               throws WASException
获得记录号

返回：
记录号，多个之间用逗号分隔
抛出：
WASException - 出现异常

getTempletFile

public java.lang.String getTempletFile()
获取模板文件

返回：
返回模板文件

getTimeLineExpr

public java.lang.String getTimeLineExpr()
获取用于显示时间轴的检索表达式

返回：
返回用于显示时间轴的检索表达式

getToken

public java.lang.String getToken()
获取预览校验

返回：
返回预览校验

isIgnoreTimeLine

public boolean isIgnoreTimeLine()
是否忽略时间轴表达式

返回：
是否忽略时间轴表达式

isQuickSelect

public boolean isQuickSelect()
是否使用快速返回

返回：
是否使用快速返回

isRelationSearch

public boolean isRelationSearch()
获取是否使用相关文章检索

返回：
是否使用相关文章检索

setBack

public void setBack(java.lang.String strBack)
             throws WASException
设置回退操作的步数

参数：
strBack - 回退操作的步数
抛出：
WASException

setChannelID

public void setChannelID(java.lang.String strChannelID)
设置频道ID号

参数：
strChannelID - 频道ID号

setClassColumn

public void setClassColumn(java.lang.String classColumn)
设置分类统计字段名称

参数：
classColumn - 要设置的分类统计字段名称

setClassRoot

public void setClassRoot(java.lang.String classRoot)
设置分类书根节点

参数：
classRoot - 要设置的分类书根节点

setClassSQL

public void setClassSQL(java.lang.String m_strClassSQL)
设置分类统计条件表达式

参数：
m_strClassSQL - 要设置的分类统计条件表达式

setCustomExpr

public void setCustomExpr(java.lang.String m_strCustomExpr)
设置自定义表达式

参数：
m_strCustomExpr - 要设置的自定义表达式

setDefaultSearchColumn

public void setDefaultSearchColumn(java.lang.String strDefaultSearchColumn)
设置缺省检索字段

参数：
strDefaultSearchColumn - 缺省检索字段

setEstimateStops

public void setEstimateStops(long lEstimateStops)
设置至少返回的记录数（用于快速返回）

参数：
lEstimateStops - 要设置的至少返回的记录数

setEstimateUnit

public void setEstimateUnit(long lEstimateUnit)
设置每个逻辑段包含的记录数（用于快速检索）

参数：
lEstimateUnit - 要设置的每个逻辑段包含的记录数

setExtendOpt

public void setExtendOpt(java.lang.String m_strExtendOpt)
设置扩展检索选项

参数：
m_strExtendOpt - 要设置的扩展检索选项

setExtension

public void setExtension(java.lang.String strExtension)
设置扩展检索方式

参数：
strExtension - 扩展检索方式

setHitType

public void setHitType(java.lang.String hitType)
设置命中点类型

参数：
hitType - 要设置的命中点类型

setIgnoreTimeLine

public void setIgnoreTimeLine(boolean bIgnoreTimeLine)
设置是否忽略时间轴表达式

参数：
bIgnoreTimeLine - 是否忽略时间轴表达式标志

setIRecords

public void setIRecords(int[] iaRecords)
设置当前记录号数组

参数：
iaRecords - 当前记录号数组

setKeyWord

public void setKeyWord(java.lang.String strKeyWord)
设置关键词，即检索框内的检索词

参数：
strKeyWord - 要设置的关键词

setLicenseCode

public void setLicenseCode(java.lang.String strLicenseCode)
设置系统许可证

参数：
strLicenseCode - 系统许可证

setOrderBy

public void setOrderBy(java.lang.String strOrderBy)
设置排序方式

参数：
strOrderBy - 排序方式

setOutlinePage

public void setOutlinePage(int outlinePage)
设置概览导航显示页码数

参数：
outlinePage - 要设置的概览导航显示页码数

setPage

public void setPage(java.lang.String strPage)
             throws WASException
设置当前页面号

参数：
strPage - 当前页面号
抛出：
WASException

setPerpage

public void setPerpage(int perpage)
设置每页记录数

参数：
perpage - 要设置的每页记录数

setPreSearchWord

public void setPreSearchWord(java.lang.String strPreSearchWord)
设置上一次检索表达式

参数：
strPreSearchWord - 上一次检索表达式

setPrimaryKeyValue

public void setPrimaryKeyValue(java.lang.String strPrimaryKeyValue)
设置主键值

参数：
strPrimaryKeyValue - 主键值

setQuickSelect

public void setQuickSelect(boolean bQuickSelect)
设置是否使用快速返回

参数：
bQuickSelect - 是否使用快速返回标志

setRelationSearch

public void setRelationSearch(boolean m_bRelationSearch)
设置是否使用相关文章检索

参数：
m_bRelationSearch - 是否使用相关文章检索标志

setResultNum

public void setResultNum(long lResultNum)
设置结果记录总数

参数：
lResultNum - 结果记录总数

setSearchOption

public void setSearchOption(java.lang.String strSearchOption)
设置检索选项

参数：
strSearchOption - 检索选项

setSearchWord

public void setSearchWord(java.lang.String strSearchWord)
设置检索表达式

参数：
strSearchWord - 检索表达式

setSecondSearch

public void setSecondSearch(java.lang.String strSecondSearch)
设置是否二次检索

参数：
strSecondSearch - 是否二次检索

setSortField

public void setSortField(java.lang.String strSortField)
设置排序方式表达式

参数：
strSortField - 要设置的排序方式表达式

setSRecords

public void setSRecords(java.lang.String[] saRecords)
设置当前记录号数组

参数：
saRecords - 当前记录号数组

setTempletFile

public void setTempletFile(java.lang.String strTempletFile)
设置模板文件

参数：
strTempletFile - 模板文件

setTimeLineExpr

public void setTimeLineExpr(java.lang.String timeLineExpr)
设置用于显示时间轴的检索表达式

参数：
timeLineExpr - 用于显示时间轴的检索表达式

setToken

public void setToken(java.lang.String m_strToken)
设置预览校验

参数：
m_strToken - 要设置的预览校验
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


WASGroup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 WASGroup

java.lang.Object
    继承者  com.trs.was.tree.Node
        继承者  com.trs.was.config.WASGroup
所有已实现的接口：
java.lang.Cloneable
public class WASGroup
extends Node

用户组信息类,用于存储用户组信息

构造函数摘要
WASGroup()
方法摘要
java.lang.String | getComment() 获取用户组说明
java.util.Date | getCreateDate() 获取用户组创建时间
java.lang.String | getName() 获取用户组名称
void | setComment(java.lang.String comment) 设置用户组说明
void | setCreateDate(java.util.Date date) 设置用户组创建时间
void | setName(java.lang.String name) 设置用户组名称
从类 com.trs.was.tree.Node 继承的方法
clone, getID, getLevel, getNextID, getNextNode, getParentID, getParentNode, getPreID, getPreNode, getSonID, getSonNode, getTreeName, setID, setLevel, setNextID, setNextNode, setParentID, setParentNode, setPreID, setPreNode, setSonID, setSonNode, setTreeName
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

WASGroup

public WASGroup()
方法详细信息

getComment

public java.lang.String getComment()
获取用户组说明

返回：
返回用户组说明

getCreateDate

public java.util.Date getCreateDate()
获取用户组创建时间

getName

public java.lang.String getName()
获取用户组名称

返回：
返回用户组名称

setComment

public void setComment(java.lang.String comment)
设置用户组说明

参数：
comment - 用户组说明

setCreateDate

public void setCreateDate(java.util.Date date)
设置用户组创建时间

参数：
date - 用户组创建时间

setName

public void setName(java.lang.String name)
设置用户组名称

参数：
name - 用户组名称
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


WASRole

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 WASRole

java.lang.Object
    继承者  com.trs.was.config.WASRole

public class WASRole
extends java.lang.Object

用户角色类

构造函数摘要
WASRole()
方法摘要
java.lang.String | getComment() 获取角色说明信息
java.util.Date | getCreateDate() 获取角色创建日期
int | getRoleID() 获取角色ID
java.lang.String | getRoleName() 获取角色名称
void | setComment(java.lang.String comment) 设置角色说明信息
void | setCreateDate(java.util.Date date) 设置角色创建日期
void | setRoleID(int roleID) 设置角色ID
void | setRoleName(java.lang.String roleName) 设置角色名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

WASRole

public WASRole()
方法详细信息

getComment

public java.lang.String getComment()
获取角色说明信息

返回：
角色说明信息

getCreateDate

public java.util.Date getCreateDate()
获取角色创建日期

返回：
角色创建日期对象

getRoleID

public int getRoleID()
获取角色ID

返回：
角色ID

getRoleName

public java.lang.String getRoleName()
获取角色名称

返回：
角色名称

setComment

public void setComment(java.lang.String comment)
设置角色说明信息

参数：
comment - 角色说明信息

setCreateDate

public void setCreateDate(java.util.Date date)
设置角色创建日期

参数：
date - 角色创建日期对象

setRoleID

public void setRoleID(int roleID)
设置角色ID

参数：
roleID - 角色ID

setRoleName

public void setRoleName(java.lang.String roleName)
设置角色名称

参数：
roleName - 角色名称
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


WASUser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 WASUser

java.lang.Object
    继承者  com.trs.was.config.WASUser
所有已实现的接口：
java.io.Serializable, java.lang.Cloneable
public class WASUser
extends java.lang.Object
implements java.lang.Cloneable, java.io.Serializable

用户信息类,用于存储用户信息

另请参见：
序列化表格

构造函数摘要
WASUser()
方法摘要
java.lang.String | getComment() 获取用户说明
java.util.Date | getCreateDate() 获取用户创建时间
java.lang.String | getPassword() 获取用户密码
java.lang.String | getUserGroup() 获取所属用户组
java.lang.String | getUserId() 获取用户Id
java.lang.String | getUserName() 获取用户名称
java.lang.String | getUserRole() 获取用户角色名称
int | getUserType() 获取用户类型
boolean | isEnable() 用户是否启用
void | setComment(java.lang.String comment) 设置用户说明
void | setCreateDate(java.util.Date date) 设置用户创建时间
void | setEnable(boolean enable) 设置用户是否启用
void | setPassword(java.lang.String password) 设置用户密码
void | setUserGroup(java.lang.String userGroup) 设置所属用户组
void | setUserId(java.lang.String strUserId) 设置用户Id
void | setUserName(java.lang.String userName) 设置用户名称
void | setUserRole(java.lang.String userRole) 设置用户角色名称
void | setUserType(int userType) 设置用户类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

WASUser

public WASUser()
方法详细信息

getComment

public java.lang.String getComment()
获取用户说明

返回：
返回用户说明

getCreateDate

public java.util.Date getCreateDate()
获取用户创建时间

返回：
返回用户创建时间

getPassword

public java.lang.String getPassword()
获取用户密码

返回：
返回用户密码

getUserGroup

public java.lang.String getUserGroup()
获取所属用户组

返回：
返回所属用户组

getUserId

public java.lang.String getUserId()
获取用户Id

返回：
用户Id

getUserName

public java.lang.String getUserName()
获取用户名称

返回：
返回用户名称

getUserRole

public java.lang.String getUserRole()
获取用户角色名称

返回：
用户角色名称

getUserType

public int getUserType()
获取用户类型

返回：
返回用户类型

isEnable

public boolean isEnable()
用户是否启用

返回：
启用则返回true，否则返回false

setComment

public void setComment(java.lang.String comment)
设置用户说明

参数：
comment - 用户说明

setCreateDate

public void setCreateDate(java.util.Date date)
设置用户创建时间

参数：
date - 创建时间

setEnable

public void setEnable(boolean enable)
设置用户是否启用

参数：
enable -

setPassword

public void setPassword(java.lang.String password)
设置用户密码

参数：
password - 用户密码

setUserGroup

public void setUserGroup(java.lang.String userGroup)
设置所属用户组

参数：
userGroup - 所属用户组

setUserId

public void setUserId(java.lang.String strUserId)
设置用户Id

参数：
strUserId - 用户Id

setUserName

public void setUserName(java.lang.String userName)
设置用户名称

参数：
userName - 用户名称

setUserRole

public void setUserRole(java.lang.String userRole)
设置用户角色名称

参数：
userRole - 用户角色名称

setUserType

public void setUserType(int userType)
设置用户类型

参数：
userType - 用户类型
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


WASException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.config
类 WASException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.was.config.WASException
所有已实现的接口：
java.io.Serializable
public class WASException
extends java.lang.Exception

系统异常类,用于处理异常信息

另请参见：
序列化表格

构造函数摘要
WASException()
WASException(java.lang.String s)
WASException(java.lang.String s, java.lang.Exception ex)
方法摘要
java.lang.String | getAbortURL() 获取出错后选择放弃时去往的页面
java.lang.String | getChannelID() 获取出错的频道ID号
java.lang.String | getError() 获取错误说明
java.lang.String | getErrorDetail() 获取详细的出错信息
java.lang.String | getErrorFrom() 获取出错处
int | getErrorNumber() 获取错误号
java.lang.String | getErrorServlet() 获取出错时的Servlet或JSP位置，便于记录日志
java.lang.String | getErrorURL() 获取出错时所在页面，用于未登录等操作回到原来的页面
java.lang.String | getRetryURL() 获取出错后选择重试时去往的页面
void | setAbortURL(java.lang.String abortURL) 设置出错后选择放弃时去往的页面
void | setChannelID(java.lang.String channelID) 设置出错的频道ID号
void | setError(java.lang.String error) 设置错误说明
void | setErrorDetail(java.lang.String errorDetail) 设置详细的出错信息
void | setErrorFrom(java.lang.String errorFrom) 设置出错处
void | setErrorNumber(int errorNumber) 设置错误号
void | setErrorServlet(java.lang.String errorServlet) 设置出错时的Servlet或JSP位置，便于记录日志
void | setErrorURL(java.lang.String errorURL) 设置出错时所在页面，用于未登录等操作回到原来的页面
void | setRetryURL(java.lang.String retryURL) 设置出错后选择重试时去往的页面
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造函数详细信息

WASException

public WASException()

WASException

public WASException(java.lang.String s)

WASException

public WASException(java.lang.String s,
                    java.lang.Exception ex)
方法详细信息

getAbortURL

public java.lang.String getAbortURL()
获取出错后选择放弃时去往的页面

返回：
返回出错后选择放弃时去往的页面

getChannelID

public java.lang.String getChannelID()
获取出错的频道ID号

返回：
返回出错的频道ID号

getError

public java.lang.String getError()
获取错误说明

返回：
返回错误说明

getErrorDetail

public java.lang.String getErrorDetail()
获取详细的出错信息

返回：
返回详细的出错信息

getErrorFrom

public java.lang.String getErrorFrom()
获取出错处

返回：
返回出错处

getErrorNumber

public int getErrorNumber()
获取错误号

返回：
返回错误号

getErrorServlet

public java.lang.String getErrorServlet()
获取出错时的Servlet或JSP位置，便于记录日志

返回：
返回出错时的Servlet或JSP位置，便于记录日志

getErrorURL

public java.lang.String getErrorURL()
获取出错时所在页面，用于未登录等操作回到原来的页面

返回：
返回出错时所在页面，用于未登录等操作回到原来的页面

getRetryURL

public java.lang.String getRetryURL()
获取出错后选择重试时去往的页面

返回：
返回出错后选择重试时去往的页面

setAbortURL

public void setAbortURL(java.lang.String abortURL)
设置出错后选择放弃时去往的页面

参数：
abortURL - 出错后选择放弃时去往的页面

setChannelID

public void setChannelID(java.lang.String channelID)
设置出错的频道ID号

参数：
channelID - 出错的频道ID号

setError

public void setError(java.lang.String error)
设置错误说明

参数：
error - 错误说明

setErrorDetail

public void setErrorDetail(java.lang.String errorDetail)
设置详细的出错信息

参数：
errorDetail - 详细的出错信息

setErrorFrom

public void setErrorFrom(java.lang.String errorFrom)
设置出错处

参数：
errorFrom - 出错处

setErrorNumber

public void setErrorNumber(int errorNumber)
设置错误号

参数：
errorNumber - 错误号

setErrorServlet

public void setErrorServlet(java.lang.String errorServlet)
设置出错时的Servlet或JSP位置，便于记录日志

参数：
errorServlet - 出错时的Servlet或JSP位置，便于记录日志

setErrorURL

public void setErrorURL(java.lang.String errorURL)
设置出错时所在页面，用于未登录等操作回到原来的页面

参数：
errorURL - 出错时所在页面，用于未登录等操作回到原来的页面

setRetryURL

public void setRetryURL(java.lang.String retryURL)
设置出错后选择重试时去往的页面

参数：
retryURL - 出错后选择重试时去往的页面
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


com.trs.was.tree

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.was.tree

类摘要
MapTree | 树对象集合类，用于存储多棵树对象。
Node | 节点基类对象
Tree | 树对象基类,可继承为频道或导航树,提供树结构的基本操作.

概述 软件包 类 使用 树 索引 帮助
上一个软件包 下一个软件包 框架 无框架


com.trs.was.tree 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.was.tree 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.was.tree.MapTree
    • com.trs.was.tree.Node (implements java.lang.Cloneable)
    • com.trs.was.tree.Tree
概述 软件包 类 使用 树 索引 帮助


软件包 com.trs.was.tree 的使用

上一个 下一个 框架 无框架

软件包 com.trs.was.tree
的使用

使用 com.trs.was.tree 的软件包
com.trs.was.config
com.trs.was.tree

com.trs.was.config 使用的 com.trs.was.tree 中的类
MapTree
树对象集合类，用于存储多棵树对象。
Node
节点基类对象
Tree
树对象基类,可继承为频道或导航树,提供树结构的基本操作.

com.trs.was.tree 使用的 com.trs.was.tree 中的类
Node
节点基类对象
Tree
树对象基类,可继承为频道或导航树,提供树结构的基本操作.

概述 软件包 类 使用 树 索引 帮助


MapTree

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.tree
类 MapTree

java.lang.Object
    继承者  com.trs.was.tree.MapTree
直接已知子类：
MapChannel, MapGroup
public class MapTree
extends java.lang.Object

树对象集合类，用于存储多棵树对象。

构造函数摘要
MapTree()
构造方法
MapTree(java.util.Hashtable trees)
构造方法
方法摘要
void | buildTree(Tree tree, java.util.Hashtable nodes, Node root) 构造树对象。
Node | getNode(int iNodeID) 获取指定ID号的节点对象。
int | getSize() 获取集合中树的个数。
Tree | getTree(java.lang.String strTreeName) 在集合中获取指定名称的树对象。
java.util.Enumeration | getTreeNames() 获取集合中所有树的名称。
Tree[] | getTrees() 从集合中获取所有的树对象。
Tree | removeTree(java.lang.String strTreeName) 从集合中移除指定的树
void | setTree(Tree tree) 将树对象添加到哈希表中。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

MapTree

public MapTree()
构造方法

MapTree

public MapTree(java.util.Hashtable trees)
        throws WASException
构造方法

参数：
trees - 存储树集合的哈希表
抛出：
WASException
方法详细信息

buildTree

public void buildTree(Tree tree,
                      java.util.Hashtable nodes,
                      Node root)
               throws WASException
构造树对象。

参数：
tree - 待构造的树对象
nodes - 存储用于构造树的所有节点对象的哈希表
root - 根节点对象
抛出：
WASException

getNode

public Node getNode(int iNodeID)
             throws WASException
获取指定ID号的节点对象。

参数：
iNodeID - 节点ID号
返回：
返回节点对象
抛出：
WASException

getSize

public int getSize()
            throws WASException
获取集合中树的个数。

返回：
返回集合中树的个数。
抛出：
WASException

getTree

public Tree getTree(java.lang.String strTreeName)
             throws WASException
在集合中获取指定名称的树对象。

参数：
strTreeName - 指定名称的树对象。
返回：
返回指定名称的树对象。
抛出：
WASException

getTreeNames

public java.util.Enumeration getTreeNames()
                                   throws WASException
获取集合中所有树的名称。

返回：
返回集合中所有树的名称。
抛出：
WASException

getTrees

public Tree[] getTrees()
                throws WASException
从集合中获取所有的树对象。

返回：
返回所有的树对象。
抛出：
WASException

removeTree

public Tree removeTree(java.lang.String strTreeName)
                throws WASException
从集合中移除指定的树

参数：
strTreeName - 树名称
返回：
被移除的树对象
抛出：
WASException

setTree

public void setTree(Tree tree)
             throws WASException
将树对象添加到哈希表中。

参数：
tree - 待插入的树对象
抛出：
WASException
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


Node

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法

com.trs.was.tree
类 Node

java.lang.Object
    继承者  com.trs.was.tree.Node
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
ChannelNode, WASGroup
public class Node
extends java.lang.Object
implements java.lang.Cloneable

节点基类对象

构造函数摘要
Node()
构造方法
方法摘要
java.lang.Object | clone() 克隆对象
int | getID() 获取节点ID
int | getLevel() 获取节点层次
int | getNextID() 获取下一个兄弟节点ID
Node | getNextNode() 获取下一个兄弟节点对象
int | getParentID() 获取父节点ID
Node | getParentNode() 获取父节点对象
int | getPreID() 获取上一个兄弟节点ID
Node | getPreNode() 获取上一个兄弟节点对象
int | getSonID() 获取第一个子节点ID
Node | getSonNode() 获取第一个子节点对象
java.lang.String | getTreeName() 获取节点的树名称
void | setID(int id) 设置节点ID
void | setLevel(int iLevel) 设置节点层次
void | setNextID(int iNextID) 设置下一个兄弟节点ID
void | setNextNode(Node nextNode) 设置下一个兄弟节点对象
void | setParentID(int iParentID) 设置父节点ID
void | setParentNode(Node parentNode) 设置父节点对象
void | setPreID(int iPreID) 设置上一个兄弟节点ID
void | setPreNode(Node preNode) 设置上一个兄弟节点对象
void | setSonID(int iSonID) 设置第一个子节点ID
void | setSonNode(Node sonNode) 设置第一个子节点对象
void | setTreeName(java.lang.String strTreeName) 设置节点的树名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

Node

public Node()
构造方法

方法详细信息

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
克隆对象

覆盖：
类 java.lang.Object 中的 clone
抛出：
java.lang.CloneNotSupportedException

getID

public int getID()
获取节点ID

返回：
返回节点ID

getLevel

public int getLevel()
获取节点层次

返回：
返回节点层次

getNextID

public int getNextID()
获取下一个兄弟节点ID

返回：
返回下一个兄弟节点ID

getNextNode

public Node getNextNode()
获取下一个兄弟节点对象

返回：
返回下一个兄弟节点对象

getParentID

public int getParentID()
获取父节点ID

返回：
返回父节点ID

getParentNode

public Node getParentNode()
获取父节点对象

返回：
返回父节点对象

getPreID

public int getPreID()
获取上一个兄弟节点ID

返回：
返回上一个兄弟节点ID

getPreNode

public Node getPreNode()
获取上一个兄弟节点对象

返回：
返回上一个兄弟节点对象

getSonID

public int getSonID()
获取第一个子节点ID

返回：
返回第一个子节点ID

getSonNode

public Node getSonNode()
获取第一个子节点对象

返回：
返回第一个子节点对象

getTreeName

public java.lang.String getTreeName()
获取节点的树名称

返回：
返回节点的树名称

setID

public void setID(int id)
设置节点ID

参数：
id - 节点ID号

setLevel

public void setLevel(int iLevel)
设置节点层次

参数：
iLevel - 节点层次

setNextID

public void setNextID(int iNextID)
设置下一个兄弟节点ID

参数：
iNextID - 下一个兄弟节点ID

setNextNode

public void setNextNode(Node nextNode)
设置下一个兄弟节点对象

参数：
nextNode - 下一个兄弟节点对象

setParentID

public void setParentID(int iParentID)
设置父节点ID

参数：
iParentID - 父节点ID

setParentNode

public void setParentNode(Node parentNode)
设置父节点对象

参数：
parentNode - 父节点对象

setPreID

public void setPreID(int iPreID)
设置上一个兄弟节点ID

参数：
iPreID - 上一个兄弟节点ID

setPreNode

public void setPreNode(Node preNode)
设置上一个兄弟节点对象

参数：
preNode - 上一个兄弟节点对象

setSonID

public void setSonID(int iSonID)
设置第一个子节点ID

参数：
iSonID - 第一个子节点ID

setSonNode

public void setSonNode(Node sonNode)
设置第一个子节点对象

参数：
sonNode - 第一个子节点对象

setTreeName

public void setTreeName(java.lang.String strTreeName)
设置节点的树名称

参数：
strTreeName - 树名称
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 详细信息： 字段 | 构造函数 | 方法


Tree

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法

com.trs.was.tree
类 Tree

java.lang.Object
    继承者  com.trs.was.tree.Tree
直接已知子类：
ChannelTree
public class Tree
extends java.lang.Object

树对象基类,可继承为频道或导航树,提供树结构的基本操作.

构造函数摘要
Tree()
构造方法
方法摘要
boolean | containNode(int id) 判断该树是否包含某节点。
Node[] | deleteAllSonNodes(int iNodeID) 删除指定节点的所有子节点。
Node[] | deleteNode(boolean bDelAll, int iNodeID) 删除树指定的节点。
void | getAllParents(int iNodeID, java.util.Vector v) 获取所有父节点
void | getAllParentsID(int iNodeID, java.util.Vector v) 获取所有父节点id
void | getAllSons(int iNodeID, java.util.Vector v, boolean bGetAll, int iSQLFlag) 获取指定节点的所有子节点对象。
void | getAllSonsID(int iNodeID, java.util.Vector v, boolean bGetAll) 获取指定节点的所有子节点。
Node | getLastSonNode() 获取最后一个子节点
java.util.Hashtable | getMapNodes() 获取节点集合哈希表
Node | getNode(int id) 获取该树中指定ID号的节点对象。
Node | getNode(java.lang.String strName) 返回指定名称的节点
Node | getRootNode() 获取根节点对象
int | getSonOrder(int iParentID, int iSonID) 获取某子节点是其父节点下的第几个子节点。
java.lang.String | getTreeName() 获取树名称
int | getTreeSize() 获取返回该树的节点数。
boolean | haveChildrens(int iNodeID) 判断节点是否包含子节点。
Node[] | insertNode(int iParentID, int iOrder, Node newnode) 在树指定位置插入节点
void | insertNode(int iParentID, Node newnode, int iOrder) 在树指定位置插入节点
Node[] | moveNodes(int iNodeID, int iNodeIDMoveTo, int iOrder) 移动节点到指定位置。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造函数详细信息

Tree

public Tree()
构造方法

方法详细信息

containNode

public boolean containNode(int id)
                    throws WASException
判断该树是否包含某节点。

参数：
id - 节点ID号
返回：
包含则返回TRUE
抛出：
WASException

deleteAllSonNodes

public Node[] deleteAllSonNodes(int iNodeID)
                         throws WASException
删除指定节点的所有子节点。

参数：
iNodeID - 节点ID号
返回：
返回所有子节点的ID
抛出：
WASException

deleteNode

public Node[] deleteNode(boolean bDelAll,
                         int iNodeID)
                  throws WASException
删除树指定的节点。

参数：
iNodeID - 待删除的节点ID号
bDelAll - 是否删除该节点的所有子节点
返回：
返回所有改动的节点对象
抛出：
WASException

getAllParents

public void getAllParents(int iNodeID,
                          java.util.Vector v)
                   throws WASException
获取所有父节点

参数：
iNodeID - 节点id
v - 用于保存所有父节点的集合
抛出：
WASException

getAllParentsID

public void getAllParentsID(int iNodeID,
                            java.util.Vector v)
                     throws WASException
获取所有父节点id

参数：
iNodeID - 节点id
v - 保存所有父节点id的集合
抛出：
WASException

getAllSons

public void getAllSons(int iNodeID,
                       java.util.Vector v,
                       boolean bGetAll,
                       int iSQLFlag)
                throws WASException
获取指定节点的所有子节点对象。

参数：
iNodeID - 节点ID号
v - 节点容器
bGetAll - 是否获取所有子节点
iSQLFlag - SQL标识
抛出：
WASException

getAllSonsID

public void getAllSonsID(int iNodeID,
                         java.util.Vector v,
                         boolean bGetAll)
                  throws WASException
获取指定节点的所有子节点。

参数：
iNodeID - 节点ID号
v - VECTOR容器
bGetAll - 是否获取所有子节点
抛出：
WASException

getLastSonNode

public Node getLastSonNode()
                    throws WASException
获取最后一个子节点

返回：
最后一个子节点
抛出：
WASException

getMapNodes

public java.util.Hashtable getMapNodes()
获取节点集合哈希表

返回：
返回节点集合哈希表

getNode

public Node getNode(int id)
             throws WASException
获取该树中指定ID号的节点对象。

参数：
id - 节点ID号
返回：
返回节点对象
抛出：
WASException

getNode

public Node getNode(java.lang.String strName)
             throws WASException
返回指定名称的节点

参数：
strName -
返回：
节点对象
抛出：
WASException

getRootNode

public Node getRootNode()
获取根节点对象

返回：
返回根节点对象

getSonOrder

public int getSonOrder(int iParentID,
                       int iSonID)
                throws WASException
获取某子节点是其父节点下的第几个子节点。

参数：
iParentID - 父节点ID号
iSonID - 子节点ID号
返回：
返回子节点在其父节点下的位置
抛出：
WASException

getTreeName

public java.lang.String getTreeName()
获取树名称

返回：
返回树名称

getTreeSize

public int getTreeSize()
                throws WASException
获取返回该树的节点数。

返回：
返回该树的节点数
抛出：
WASException

haveChildrens

public boolean haveChildrens(int iNodeID)
                      throws WASException
判断节点是否包含子节点。

参数：
iNodeID - 节点ID
返回：
包含则返回true，否则返回false
抛出：
WASException

insertNode

public Node[] insertNode(int iParentID,
                         int iOrder,
                         Node newnode)
                  throws WASException
在树指定位置插入节点

参数：
iParentID - 父节点ID
newnode - 新节点对象
iOrder - 插入节点序号
返回：
返回所有改动的节点对象
抛出：
WASException

insertNode

public void insertNode(int iParentID,
                       Node newnode,
                       int iOrder)
                throws WASException
在树指定位置插入节点

参数：
iParentID - 父节点ID
newnode - 新节点对象
iOrder - 插入节点序号
抛出：
WASException

moveNodes

public Node[] moveNodes(int iNodeID,
                        int iNodeIDMoveTo,
                        int iOrder)
                 throws WASException
移动节点到指定位置。

参数：
iNodeID - 待移动的节点ID号
iNodeIDMoveTo - 移动到的目标节点
iOrder - 指定移动位置，-1表示成为最后一个子节点
返回：
返回所有改动的节点对象
抛出：
WASException
概述 软件包 类 使用 树 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造函数 | 方法 | 详细信息： 字段 | 构造函数 | 方法


About Jd2chm...

The project files of this HTML Help
Were generated with Jd2chm version 0.34
Copyright © 2006-2009 Xiaoxiang Li

And the original Jd2chm version 0.30
Copyright © 2000-2003 Andre Burgaud
http://www.burgaud.com


 所有类
AppConfig
ChannelNode
ChannelTree
ConfigData
DataSource
FieldData
LoginConfig
MapChannel
MapDataSource
MapFieldData
MapGroup
MapTree
Node
RequestOperation
SearchData
Tree
WASException
WASGroup
WASResultSet
WASRole
WASTools
WASUser


常量字段值

目录
  • com.trs.*
com.trs.*

com.trs.was.config.com.trs.was.config.WASConstant
public static final int | ACTION_TYPE_ADVANCESEARCH | 2048
public static final int | ACTION_TYPE_DELETE | 512
public static final int | ACTION_TYPE_DETAIL | 8
public static final int | ACTION_TYPE_DOCUMENT | 128
public static final int | ACTION_TYPE_DOWNLOAD | 16
public static final int | ACTION_TYPE_INSERT | 256
public static final int | ACTION_TYPE_LOGIN | 1
public static final int | ACTION_TYPE_LOGOUT | 4096
public static final int | ACTION_TYPE_MAIL | 32
public static final int | ACTION_TYPE_OUTLINE | 4
public static final int | ACTION_TYPE_PRINT | 64
public static final int | ACTION_TYPE_SEARCH | 2
public static final int | ACTION_TYPE_TREE | 8192
public static final int | ACTION_TYPE_UPDATE | 1024
public static final int | BINARY_COLUMN_BIN | 1
public static final int | BINARY_COLUMN_DOC | 2
public static final int | BINARY_COLUMN_NONE | 0
public static final int | CHECK_DETAIL_FIELDNAME | 2
public static final int | CHECK_OUTLINE_FIELDNAME | 1
public static final int | COLUMN_PARENT_DETAIL | 2
public static final int | COLUMN_PARENT_OUTLINE | 1
public static final int | COLUMN_TYPE_COUNT | 4
public static final int | COLUMN_TYPE_NORMAL | 0
public static final int | COLUMN_TYPE_OUTFILE | 1
public static final int | COLUMN_TYPE_RELATION | 2
public static final int | COLUMN_TYPE_SOURCE | 8
public static final int | COLUMNSPECAILTYPE_KEYWORD | 4096
public static final int | COLUMNSPECAILTYPE_STAT | 8192
public static final int | COLUMNSPECIALTYPE_DEFAULTSEARCH | 256
public static final int | COLUMNSPECIALTYPE_DETAIL | 2
public static final int | COLUMNSPECIALTYPE_DOWNLOAD | 4
public static final int | COLUMNSPECIALTYPE_MAIL | 8
public static final int | COLUMNSPECIALTYPE_OUTFILE | 32
public static final int | COLUMNSPECIALTYPE_OUTLINE | 1
public static final int | COLUMNSPECIALTYPE_PRIMARY | 1024
public static final int | COLUMNSPECIALTYPE_PRINT | 16
public static final int | COLUMNSPECIALTYPE_READTIMES | 64
public static final int | COLUMNSPECIALTYPE_RELATION | 128
public static final int | COLUMNSPECIALTYPE_SEARCHFORM | 512
public static final int | COLUMNSPECIALTYPE_SOURCE | 2048
public static final int | COLUMNSPECIALTYPE_TIMELINE | 16384
public static final int | DEBUG_CONFIG | 512
public static final int | DEBUG_DEBUG | -1
public static final int | DEBUG_ENCODING | 2048
public static final int | DEBUG_ERROR | 1
public static final int | DEBUG_FUNCTION | 512
public static final int | DEBUG_KEEPFILE | 256
public static final int | DEBUG_LOG | 128
public static final int | DEBUG_MONITOR | 16
public static final int | DEBUG_NONE | 0
public static final int | DEBUG_SERVLET | 64
public static final int | DEBUG_SQL | 8
public static final int | DEBUG_STACK | 2
public static final int | DEBUG_TAG_EXCEPTION_THROW | 4
public static final int | DEBUG_TAGLIB | 32
public static final int | DEBUG_TREE | 1024
public static final int | DISPLAY_FORMAT_AUTO | 1
public static final int | DISPLAY_FORMAT_HTML | 2
public static final int | DISPLAY_FORMAT_PRE | 0
public static final int | ENCODING_LEVEL_PARAMETER | 1
public static final int | ENCODING_LEVEL_PARAMETER_VALUES | 2
public static final int | ENCODING_LEVEL_URL | 4
public static final char | ENUM_SEPARATOR | 10
public static final int | ERROR_INEXIST_RESOURCE | 1002
public static final int | ERROR_NORMAL | 1001
public static final int | ERROR_UNEXPECT_PARAMETER | 1003
public static final int | ERROR_UNKNOW | 1000
public static final int | GRANTRIGHT_DETAIL | 2
public static final int | GRANTRIGHT_ENTERPRISE | 8
public static final int | GRANTRIGHT_MODIFY | 4
public static final int | GRANTRIGHT_OUTLINE | 1
public static final int | GRANTRIGHT_ROLE | 4
public static final int | GRANTRIGHT_USER | 1
public static final int | GRANTRIGHT_USERGROUP | 2
public static final java.lang.String | LOG_ADMIN_ACCESS | "YYYY-MM-DD hh:mm:ss %user %host %command %detail"
public static final java.lang.String | LOG_DEFAULT | "YYYY-MM-DD hh:mm:ss "
public static final int | LOG_LEVEL_ACCESS | 1
public static final int | LOG_LEVEL_ADMIN | 4
public static final int | LOG_LEVEL_ERROR | 2
public static final int | LOG_LEVEL_NONE | 0
public static final int | LOG_TYPE_ACCESS | 1
public static final int | LOG_TYPE_ADMIN | 3
public static final int | LOG_TYPE_ERROR | 2
public static final int | NODETYPE_CHANNEL | 1
public static final int | NODETYPE_URL | 2
public static final int | OPENED_POINT_NOT_IN_TREE | -1
public static final java.lang.String | SingleTreeName | "admin"
public static final int | SOURCEFILE_LINK | 0
public static final int | SOURCEFILE_NONE | 1
public static final int | SOURCEFILE_SHOW | 2
public static final int | TREE_ADMIN_CHANNELSELECTTREE | 16
public static final int | TREE_ADMIN_CHANNELTREE | 4
public static final int | TREE_ADMIN_NAVIGATETREE | 8
public static final int | TREE_APP_CHANNELTREE | 1
public static final int | TREE_APP_NAVIGATETREE | 2
public static final int | TREE_TYPE_CHANNEL | 1
public static final int | TREE_TYPE_NAVIGATE | 2
public static final char | TRS_DIV | 255
public static final int | TRS50_IDEOSINGLE | 1
public static final int | TRS50_LICENSECODE | 2
public static final int | TRS50_LIFO | 8
public static final int | TRS50_UTF8 | 4
public static final int | TRSRS_BUFFER_SIZE | -1
public static final int | TRSRS_READ_SIZE | 20
public static final int | USER_TYPE_CONNECT | 35
public static final int | USER_TYPE_DBA | 32
public static final int | WAS4DETAILFOUND | 1
public static final int | WAS4DETAILNOTFOUND | 2
public static final int | WAS4OUTLINEFOUND | 1
public static final int | WAS4OUTLINENOTFOUND | 2
public static final int | WAS4TEMPLATE | 1
public static final int | WAS5DETAILFOUND | 3
public static final int | WAS5DETAILNOTFOUND | 4
public static final int | WAS5OUTLINEFOUND | 3
public static final int | WAS5OUTLINENOTFOUND | 4
public static final int | WAS5TEMPLATE | 2
public static final int | WAS5TEMPLATECOMBO | 3
public static final int | WCMRootID | 10000000
public static final int | WCMSiteRootID | 9000000
public static final java.lang.String | XML_NAMESPACE | "my"
public static final java.lang.String | XML_NAMESPACEURL | "www.trs.com.cn/was5/"

概述 软件包 类 使用 树 索引 帮助


API 帮助

上一个 下一个 框架 无框架

此 API 文档的组织方式

此 API（应用程序编程接口）文档包含对应于导航栏中的项目的页面，如下所述。

概述

概述 页面是此 API 文档的首页，提供了所有软件包的列表及其摘要。此页面也可能包含这些软件包的总体描述。

软件包

每个软件包都有一个页面，其中包含它的类和接口的列表及其摘要。此页面可以包含四个类别：

  • 接口（斜体）
  • 类
  • 枚举
  • 异常
  • 错误
  • 注释类型

类/接口

每个类、接口、嵌套类和嵌套接口都有各自的页面。其中每个页面都由三部分（类/接口描述、摘要表，以及详细的成员描述）组成：

  • 类继承图
  • 直接子类
  • 所有已知子接口
  • 所有已知实现类
  • 类/接口声明
  • 类/接口描述

  • 嵌套类摘要
  • 字段摘要
  • 构造函数摘要
  • 方法摘要

  • 字段详细信息
  • 构造函数详细信息
  • 方法详细信息
每个摘要条目都包含该项目的详细描述的第一句。摘要条目按字母顺序排列，而详细描述则按其在源代码中出现的顺序排列。这样保持了程序员所建立的逻辑分组。

注释类型

每个注释类型都有各自的页面，其中包含以下部分：

  • 注释类型声明
  • 注释类型描述
  • 必需元素摘要
  • 可选元素摘要
  • 元素详细信息

枚举

每个枚举都有各自的页面，其中包含以下部分：

  • 枚举声明
  • 枚举描述
  • 枚举常量摘要
  • 枚举常量详细信息

使用

每个已文档化的软件包、类和接口都有各自的“使用”页面。此页面介绍了使用给定类或软件包的任何部分的软件包、类、方法、构造函数和字段。对于给定的类或接口 A，其“使用”页面包含 A 的子类、声明为 A 的字段、返回 A 的方法，以及带有类型为 A 的参数的方法和构造函数。访问此页面的方法是：首先转至软件包、类或接口，然后单击导航栏中的“使用”链接。

树（类分层结构）

对于所有软件包，有一个 类分层结构 页面，以及每个软件包的分层结构。每个分层结构页面都包含类的列表和接口的列表。从 java.lang.Object 开始，按继承结构对类进行排列。接口不从 java.lang.Object 继承。
  • 查看“概述”页面时，单击“树”将显示所有软件包的分层结构。
  • 查看特定软件包、类或接口页面时，单击“树”将仅显示该软件包的分层结构。

索引

索引 包含按字母顺序排列的所有类、接口、构造函数、方法和字段的列表。

上一个/下一个

这些链接使您可以转至下一个或上一个类、接口、软件包或相关页面。

框架/无框架

这些链接用于显示和隐藏 HTML 框架。所有页面均具有有框架和无框架两种显示方式。

序列化表格

每个可序列化或可外部化的类都有其序列化字段和方法的描述。此信息对重新实现者有用，而对使用 API 的开发者则没有什么用处。尽管导航栏中没有链接，但您可以通过下列方式获取此信息：转至任何序列化类，然后单击类描述的“另请参见”部分中的“序列化表格”。

常量字段值

常量字段值页面列出了静态最终字段及其值。

此帮助文件适用于使用标准 doclet 生成的 API 文档。

概述 软件包 类 使用 树 索引 帮助


生成的文档（无标题）

框架警报

请使用框架功能查看此文档。如果看到此消息，则表明您使用的是不支持框架的 Web 客户机。
链接到非框架版本。


概述

所有类

软件包
com.trs.was
com.trs.was.config
com.trs.was.tree


序列化表格

软件包 com.trs.was.config

类 com.trs.was.config.LoginConfig 继承 java.lang.Object 实现 Serializable

serialVersionUID: 2631053345887209757L

序列化方法

readObject

private void readObject(java.io.ObjectInputStream in)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
序列化时，从输入流中读取信息的函数。

抛出：
java.io.IOException
java.lang.ClassNotFoundException

writeObject

private void writeObject(java.io.ObjectOutputStream out)
                  throws java.io.IOException
序列化时，输出到输出流的函数。

抛出：
java.io.IOException
序列化字段

m_wasUser

WASUser m_wasUser

m_channelTreeOpenedPoints

java.util.Vector m_channelTreeOpenedPoints

m_navigateTreeOpenedPoints

java.util.Vector m_navigateTreeOpenedPoints

m_strCurrentChannel

java.lang.String m_strCurrentChannel

m_strCurrentChannelTree

java.lang.String m_strCurrentChannelTree

m_strCurrentNavTree

java.lang.String m_strCurrentNavTree

类 com.trs.was.config.WASException 继承 java.lang.Exception 实现 Serializable

serialVersionUID: -5304401244719758724L

序列化字段

m_iErrorNumber

int m_iErrorNumber

m_strChannelID

java.lang.String m_strChannelID

m_strError

java.lang.String m_strError

m_strErrorFrom

java.lang.String m_strErrorFrom

m_strErrorDetail

java.lang.String m_strErrorDetail

m_strErrorServlet

java.lang.String m_strErrorServlet

m_strErrorURL

java.lang.String m_strErrorURL

m_strAbortURL

java.lang.String m_strAbortURL

m_strRetryURL

java.lang.String m_strRetryURL

类 com.trs.was.config.WASUser 继承 java.lang.Object 实现 Serializable

serialVersionUID: 1L

序列化字段

m_strUserId

java.lang.String m_strUserId

m_strUserName

java.lang.String m_strUserName

m_strPassword

java.lang.String m_strPassword

m_strUserGroup

java.lang.String m_strUserGroup

m_strUserRole

java.lang.String m_strUserRole

m_iUserType

int m_iUserType

m_createDate

java.util.Date m_createDate

m_strComment

java.lang.String m_strComment

enable

boolean enable
软件包 com.trs.was.tree

类 com.trs.was.tree.BuildGroupTree 继承 javax.servlet.http.HttpServlet 实现 Serializable

序列化字段

tree

Tree tree
已过时。

rootid

int rootid
已过时。

level

int level
已过时。

v

java.util.Vector v
已过时。

session

javax.servlet.http.HttpSession session
已过时。

iRequest

javax.servlet.http.HttpServletRequest iRequest
已过时。

searchData

SearchData searchData
已过时。

loginConfig

LoginConfig loginConfig
已过时。

类 com.trs.was.tree.BuildTree 继承 javax.servlet.http.HttpServlet 实现 Serializable

序列化字段

tree

Tree tree
已过时。

rootid

int rootid
已过时。

level

int level
已过时。

v

java.util.Vector v
已过时。

session

javax.servlet.http.HttpSession session
已过时。

iRequest

javax.servlet.http.HttpServletRequest iRequest
已过时。

searchData

SearchData searchData
已过时。

loginConfig

LoginConfig loginConfig
已过时。

index_channel

java.lang.String index_channel
已过时。

recchlid

int recchlid
已过时。

概述 软件包 类 使用 树 索引 帮助


 com.trs.was
类
WASResultSet
WASTools


类 com.trs.was.WASResultSet 的使用

上一个 下一个 框架 无框架

类 com.trs.was.WASResultSet
的使用

使用 WASResultSet 的软件包
com.trs.was

com.trs.was 中 WASResultSet 的使用

返回 WASResultSet 的 com.trs.was 中的方法
static WASResultSet WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)
获取WAS结果集对象

参数类型为 WASResultSet 的 com.trs.was 中的方法
static int | WASTools.classResultForTimeLine(WASResultSet wasRS, java.lang.String column, boolean isRegExp) 分类统计，用于时间轴
static java.lang.String[][] | WASTools.getTimeLine(WASResultSet wasRS, int classnum, java.lang.String commonPart, int showNum, int span, java.lang.String currentDate, int endNode) 获取时间轴

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.WASTools 的使用

上一个 下一个 框架 无框架

类 com.trs.was.WASTools
的使用

没有 com.trs.was.WASTools 的用法

概述 软件包 类 使用 树 索引 帮助


 com.trs.was.config
类
AppConfig
ChannelNode
ChannelTree
ConfigData
DataSource
FieldData
LoginConfig
MapChannel
MapDataSource
MapFieldData
MapGroup
RequestOperation
SearchData
WASGroup
WASRole
WASUser
异常
WASException


类 com.trs.was.config.AppConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.AppConfig
的使用

使用 AppConfig 的软件包
com.trs.was

com.trs.was 中 AppConfig 的使用

参数类型为 AppConfig 的 com.trs.was 中的方法
static WASResultSet WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)
获取WAS结果集对象

参数类型为 AppConfig 的 com.trs.was 中的构造函数
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.CacheItem 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.CacheItem
的使用

使用 com.trs.was.config.CacheItem 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.CacheItem 的使用

返回 com.trs.was.config.CacheItem 的 com.trs.was.config 中的方法
com.trs.was.config.CacheItem | MapCacheItem.getCacheItem(java.lang.String strKey) 已过时。 从集合中获取缓存对象
com.trs.was.config.CacheItem | MapCacheItem.getItemHead() 已过时。 获取集合中的第一个缓存对象
com.trs.was.config.CacheItem | CacheItem.getItemNext() 已过时。 获取下一个缓存对象
com.trs.was.config.CacheItem | CacheItem.getItemPrev() 已过时。 获取上一个缓存对象
com.trs.was.config.CacheItem | MapCacheItem.getItemTail() 已过时。 获取集合中的最后一个缓存对象

参数类型为 com.trs.was.config.CacheItem 的 com.trs.was.config 中的方法
void | MapCacheItem.setCacheItem(com.trs.was.config.CacheItem cacheItem) 已过时。 添加缓存对象到集合中
void | MapCacheItem.setItemHead(com.trs.was.config.CacheItem itemHead) 已过时。 设置集合中的第一个缓存对象
void | CacheItem.setItemNext(com.trs.was.config.CacheItem itemNext) 已过时。 设置下一个缓存对象
void | CacheItem.setItemPrev(com.trs.was.config.CacheItem itemPrev) 已过时。 设置上一个缓存对象
void | MapCacheItem.setItemTail(com.trs.was.config.CacheItem itemTail) 已过时。 设置集合中的最后一个缓存对象

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.ChannelNode 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.ChannelNode
的使用

使用 ChannelNode 的软件包
com.trs.was
com.trs.was.config

com.trs.was 中 ChannelNode 的使用

返回 ChannelNode 的 com.trs.was 中的方法
static ChannelNode WASTools.getChannel(ConfigData wasConfig, java.lang.String strChannelID)
获取频道对象

参数类型为 ChannelNode 的 com.trs.was 中的方法
static java.lang.String WASTools.getOrderBy(ChannelNode channelNode, SearchData searchData)
获取频道排序条件.

com.trs.was.config 中 ChannelNode 的使用

参数类型为 ChannelNode 的 com.trs.was.config 中的方法
 void ChannelNode.inherit(ChannelNode parentNode)
继承父节点的属性

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.ChannelTree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.ChannelTree
的使用

没有 com.trs.was.config.ChannelTree 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.ConfigData 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.ConfigData
的使用

使用 ConfigData 的软件包
com.trs.was
com.trs.was.config

com.trs.was 中 ConfigData 的使用

参数类型为 ConfigData 的 com.trs.was 中的方法
static ChannelNode | WASTools.getChannel(ConfigData wasConfig, java.lang.String strChannelID) 获取频道对象
static java.lang.String | WASTools.getChannelNames(ConfigData wasConfig, java.lang.String strChannelIDs) 获得操作的频道名。
static java.lang.String | WASTools.getChannelSources(ConfigData configData, java.lang.String strChannelID) 获取频道的TRS数据库名称。
static WASResultSet | WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取WAS结果集对象
static LoginConfig | WASTools.loadLoginConfig(javax.servlet.http.HttpSession session, ConfigData wasConfig) 获取登录对象

参数类型为 ConfigData 的 com.trs.was 中的构造函数
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)

com.trs.was.config 中 ConfigData 的使用

参数类型为 ConfigData 的 com.trs.was.config 中的方法
static int | MapGrantRight.getGrants(ConfigData configData, int iChannelID, int iNum, int iPage, java.util.Vector v) 已过时。
boolean | MapGrantRight.hasRight(ConfigData configData, java.lang.String strName, java.lang.String strGroup, java.lang.String strRole, java.lang.String strType, boolean bLogic, java.lang.String strNodeID, int iGrantType) 已过时。 获取指定用户/用户组/角色对某节点是否有权限
boolean | LoginConfig.login(ConfigData configData, com.trs.was.config.MapGrantRight mapGrantRight, java.sql.Connection conn, java.lang.String strUserName, java.lang.String strPassword) 已过时。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.DataSource 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.DataSource
的使用

使用 DataSource 的软件包
com.trs.was.config

com.trs.was.config 中 DataSource 的使用

返回 DataSource 的 com.trs.was.config 中的方法
 DataSource MapDataSource.getDataSource(java.lang.String strDataSourceId)
从数据源对象集合中取出指定strDataSourceId对应的数据源

参数类型为 DataSource 的 com.trs.was.config 中的方法
 void MapDataSource.setDataSource(DataSource dataSource)
向数据源对象集合中写入指定strDataSourceId对应的数据源

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.FieldData 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.FieldData
的使用

使用 FieldData 的软件包
com.trs.was.config

com.trs.was.config 中 FieldData 的使用

返回 FieldData 的 com.trs.was.config 中的方法
FieldData | ChannelNode.deleteField(java.lang.String strFieldName) 从频道的字段集合中删除字段对象
FieldData | MapFieldData.getField(java.lang.String strFieldName) 获取指定名称的字段对象
FieldData | ChannelNode.getField(java.lang.String strFieldName) 从频道的字段集合中获取指定字段对象
FieldData[] | MapFieldData.getFieldArray() 获取所有字段对象
FieldData[] | ChannelNode.getFieldArray() 获取所有字段对象
FieldData | MapFieldData.getFieldByDisplayName(java.lang.String strDisplayName) 根据字段显示名称获取指定字段对象
FieldData[] | MapFieldData.getFieldsByType(int iSpecialType) 根据字段特殊类型获取指定字段对象
FieldData | MapFieldData.removeField(java.lang.String strFieldName) 从频道字段集合中删除指定名称的字段对象

参数类型为 FieldData 的 com.trs.was.config 中的方法
void | MapFieldData.setField(FieldData field) 添加字段对象到频道的字段集合中
void | ChannelNode.setField(FieldData field) 在频道的字段集合中添加字段对象
void | MapFieldData.setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中
void | ChannelNode.setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.GrantRight 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.GrantRight
的使用

没有 com.trs.was.config.GrantRight 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.HttpGBK2UnicodeRequest 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.HttpGBK2UnicodeRequest
的使用

没有 com.trs.was.config.HttpGBK2UnicodeRequest 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.HttpMultiFormPart 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.HttpMultiFormPart
的使用

使用 com.trs.was.config.HttpMultiFormPart 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.HttpMultiFormPart 的使用

返回 com.trs.was.config.HttpMultiFormPart 的 com.trs.was.config 中的方法
com.trs.was.config.HttpMultiFormPart | HttpGBK2UnicodeRequest.getBinParameter(java.lang.String name) 已过时。 在此处插入方法说明。
com.trs.was.config.HttpMultiFormPart[] | HttpGBK2UnicodeRequest.getBinParameterArray(java.lang.String name) 已过时。 在此处插入方法说明。
com.trs.was.config.HttpMultiFormPart | HttpMultiFormPart.getNextParameter() 已过时。 在此处插入方法说明。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.IPFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.IPFilter
的使用

没有 com.trs.was.config.IPFilter 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.LoginConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.LoginConfig
的使用

使用 LoginConfig 的软件包
com.trs.was

com.trs.was 中 LoginConfig 的使用

返回 LoginConfig 的 com.trs.was 中的方法
static LoginConfig WASTools.loadLoginConfig(javax.servlet.http.HttpSession session, ConfigData wasConfig)
获取登录对象

参数类型为 LoginConfig 的 com.trs.was 中的方法
static java.lang.String | WASTools.getChannelID(LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取频道ID
static java.lang.String | WASTools.getURL(javax.servlet.http.HttpServletRequest request, SearchData searchData, LoginConfig loginConfig, java.lang.String strChannelID) 组合请求中的参数返回
static WASResultSet | WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取WAS结果集对象

参数类型为 LoginConfig 的 com.trs.was 中的构造函数
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapCacheItem 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapCacheItem
的使用

没有 com.trs.was.config.MapCacheItem 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapChannel
的使用

使用 MapChannel 的软件包
com.trs.was.config

com.trs.was.config 中 MapChannel 的使用

返回 MapChannel 的 com.trs.was.config 中的方法
 MapChannel ConfigData.getMapChannel()
获得频道树集合

参数类型为 MapChannel 的 com.trs.was.config 中的方法
 void ConfigData.setMapChannel(MapChannel mapChannel)
设置频道树集合

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapDataSource 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapDataSource
的使用

使用 MapDataSource 的软件包
com.trs.was.config

com.trs.was.config 中 MapDataSource 的使用

返回 MapDataSource 的 com.trs.was.config 中的方法
 MapDataSource ConfigData.getMapDataSource()
获得数据源集合

参数类型为 MapDataSource 的 com.trs.was.config 中的方法
 void ConfigData.setMapDataSource(MapDataSource mapDataSource)
设置数据源集合

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapFieldData 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapFieldData
的使用

使用 MapFieldData 的软件包
com.trs.was.config

com.trs.was.config 中 MapFieldData 的使用

返回 MapFieldData 的 com.trs.was.config 中的方法
 MapFieldData ChannelNode.getMapFieldData()
获得数据库字段集合

参数类型为 MapFieldData 的 com.trs.was.config 中的方法
 void ChannelNode.setMapFieldData(MapFieldData mapFieldData)
设置数据库字段集合

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapGrantRight 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapGrantRight
的使用

使用 com.trs.was.config.MapGrantRight 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.MapGrantRight 的使用

返回 com.trs.was.config.MapGrantRight 的 com.trs.was.config 中的方法
 com.trs.was.config.MapGrantRight ConfigData.getMapGrantRight()
已过时。

参数类型为 com.trs.was.config.MapGrantRight 的 com.trs.was.config 中的方法
boolean | LoginConfig.login(ConfigData configData, com.trs.was.config.MapGrantRight mapGrantRight, java.sql.Connection conn, java.lang.String strUserName, java.lang.String strPassword) 已过时。
void | ConfigData.setMapGrantRight(com.trs.was.config.MapGrantRight mapGrantRight) 已过时。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapGroup
的使用

使用 MapGroup 的软件包
com.trs.was.config

com.trs.was.config 中 MapGroup 的使用

返回 MapGroup 的 com.trs.was.config 中的方法
 MapGroup ConfigData.getMapGroup()
获取用户组集合

参数类型为 MapGroup 的 com.trs.was.config 中的方法
 void ConfigData.setMapGroup(MapGroup m_mapGroup)
设置用户组集合

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapNavigate 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapNavigate
的使用

使用 com.trs.was.config.MapNavigate 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.MapNavigate 的使用

返回 com.trs.was.config.MapNavigate 的 com.trs.was.config 中的方法
 com.trs.was.config.MapNavigate ConfigData.getMapNavigate()
已过时。

参数类型为 com.trs.was.config.MapNavigate 的 com.trs.was.config 中的方法
 void ConfigData.setMapNavigate(com.trs.was.config.MapNavigate mapNavigate)
已过时。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.MapWASStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.MapWASStyle
的使用

使用 com.trs.was.config.MapWASStyle 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.MapWASStyle 的使用

返回 com.trs.was.config.MapWASStyle 的 com.trs.was.config 中的方法
 com.trs.was.config.MapWASStyle ConfigData.getMapWASStyle()
已过时。

参数类型为 com.trs.was.config.MapWASStyle 的 com.trs.was.config 中的方法
 void ConfigData.setMapWASStyle(com.trs.was.config.MapWASStyle mapWASStyle)
已过时。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.NavigateNode 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.NavigateNode
的使用

使用 com.trs.was.config.NavigateNode 的软件包
com.trs.was.tree

com.trs.was.tree 中 com.trs.was.config.NavigateNode 的使用

参数类型为 com.trs.was.config.NavigateNode 的 com.trs.was.tree 中的方法
static java.lang.String TreeOperation.formatNavigateItem(com.trs.was.config.NavigateNode node, java.lang.String strFormat, java.lang.String strTarget)
已过时。 输出格式化的导航节点的信息

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.NavigateTree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.NavigateTree
的使用

没有 com.trs.was.config.NavigateTree 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.RequestOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.RequestOperation
的使用

没有 com.trs.was.config.RequestOperation 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.SearchData 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.SearchData
的使用

使用 SearchData 的软件包
com.trs.was

com.trs.was 中 SearchData 的使用

返回 SearchData 的 com.trs.was 中的方法
static SearchData WASTools.getSearchDataFromRequest(javax.servlet.http.HttpServletRequest request)
从请求中获取检索条件对象.

参数类型为 SearchData 的 com.trs.was 中的方法
static java.lang.String | WASTools.getChannelID(LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取频道ID
static java.lang.String | WASTools.getOrderBy(ChannelNode channelNode, SearchData searchData) 获取频道排序条件.
static java.lang.String | WASTools.getURL(javax.servlet.http.HttpServletRequest request, SearchData searchData, LoginConfig loginConfig, java.lang.String strChannelID) 组合请求中的参数返回
static WASResultSet | WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取WAS结果集对象

参数类型为 SearchData 的 com.trs.was 中的构造函数
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASConstant 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASConstant
的使用

没有 com.trs.was.config.WASConstant 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASDebug 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASDebug
的使用

没有 com.trs.was.config.WASDebug 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASEncoding 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASEncoding
的使用

没有 com.trs.was.config.WASEncoding 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASException 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASException
的使用

使用 WASException 的软件包
com.trs.was
com.trs.was.config
com.trs.was.tree

com.trs.was 中 WASException 的使用

抛出 WASException 的 com.trs.was 中的方法
static int | WASTools.classResultForTimeLine(WASResultSet wasRS, java.lang.String column, boolean isRegExp) 分类统计，用于时间轴
static void | WASTools.freeWASResultSet(javax.servlet.ServletRequest request) 释放WAS结果集
static void | WASTools.freeWASResultSet(javax.servlet.ServletRequest request, java.lang.String strChannelID) 释放WAS结果集
int | WASResultSet.getBinaryObjectCount(java.lang.String strColumnName) 获得指定字段二进制对象的个数。
int | WASResultSet.getBinaryObjectRealCount(java.lang.String strColumnName) 获得指定字段二进制对象的个数。
java.io.InputStream | WASResultSet.getBinaryStream(java.lang.String strColumnName, int iMultiIndex) 获得当前记录指定字段名称和多值序号的对象的输入流对象。
byte[] | WASResultSet.getBytes(java.lang.String strColumnName, int iMulti) 获取字段内容的字节数组
static ChannelNode | WASTools.getChannel(ConfigData wasConfig, java.lang.String strChannelID) 获取频道对象
static java.lang.String | WASTools.getChannelID(LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取频道ID
static java.lang.String | WASTools.getChannelNames(ConfigData wasConfig, java.lang.String strChannelIDs) 获得操作的频道名。
static java.lang.String | WASTools.getChannelSources(ConfigData configData, java.lang.String strChannelID) 获取频道的TRS数据库名称。
int | WASResultSet.getColHitNum(java.lang.String strColumn) 获取字段命中点数
int | WASResultSet.getColumnMultiValue(java.lang.String strColumnName) 获取字段的多值个数
int | WASResultSet.getColumnType(java.lang.String strColName) 获得当前记录中指定字段的类型。
java.lang.String | WASResultSet.getContentType(java.lang.String strColumnName, int iMultiIndex) 该方法返回当前记录的二进制字段的指定对象的 ContentType
java.lang.String | WASResultSet.getDate(java.lang.String strColumnName, java.lang.String strFormat) 获取日期字段指定格式的内容
java.lang.String[] | WASResultSet.getDetailFields() 获得检索结果对象对应的频道的细览字段
java.lang.String[] | WASResultSet.getDownloadFields() 获得检索结果对象对应的频道的下载字段
java.lang.String | WASResultSet.getFile(java.lang.String strColumnName, int iMultiIndex) 获得指定二进制字段的文件名。
float | WASResultSet.getFloat(java.lang.String strColumnName) 获取指定NUMBER字段FLOAT类型内容
int | WASResultSet.getInt(java.lang.String strColumnName) 获取指定NUMBER字段INT类型内容
java.lang.String[] | WASResultSet.getMailFields() 获得检索结果对象对应的频道的推荐字段
static java.lang.String | WASTools.getOrderBy(ChannelNode channelNode, SearchData searchData) 获取频道排序条件.
java.lang.String | WASResultSet.getPrimaryKey() 获得当前检索结果集的主键
java.lang.String | WASResultSet.getPrimaryKeyPair() 获得当前检索记录的主键名值对
long | WASResultSet.getRecordCount() 获取命中记录数
double | WASResultSet.getRelevance() 获取当前记录的相关度
static SearchData | WASTools.getSearchDataFromRequest(javax.servlet.http.HttpServletRequest request) 从请求中获取检索条件对象.
java.lang.String | WASResultSet.getString(java.lang.String strColumnName) 获得指定字段的字段值内容
java.lang.String | WASResultSet.getString(java.lang.String strColumnName, java.lang.String strHitColor, int iCutSize) 获取指定字段带命中点反显标记的内容
static java.lang.String[][] | WASTools.getTimeLine(WASResultSet wasRS, int classnum, java.lang.String commonPart, int showNum, int span, java.lang.String currentDate, int endNode) 获取时间轴
com.trs.client.TRSConnection | WASResultSet.getTRSConnection() 获取TRS连接对象.
com.trs.client.TRSConnection | WASResultSet.getTRSReConnection(java.lang.String strLicenseCode) 利用系统许可证获取TRS连接.
static java.lang.String | WASTools.getURL(javax.servlet.http.HttpServletRequest request, SearchData searchData, LoginConfig loginConfig, java.lang.String strChannelID) 组合请求中的参数返回
static WASResultSet | WASTools.getWASResultSet(javax.servlet.http.HttpServletRequest request, AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID) 获取WAS结果集对象
static LoginConfig | WASTools.loadLoginConfig(javax.servlet.http.HttpSession session, ConfigData wasConfig) 获取登录对象
boolean | WASResultSet.moveTo(int iMoveFlag, long lNewNo) 移动到检索结果记录集的指定记录
void | WASResultSet.setCutSize(int iNewCutSize, boolean bClear) 设置取字段时的截断长度。

抛出 WASException 的 com.trs.was 中的构造函数
WASResultSet(AppConfig appConfig, ConfigData wasConfig, LoginConfig loginConfig, SearchData searchData, java.lang.String strChannelID)

com.trs.was.config 中 WASException 的使用

抛出 WASException 的 com.trs.was.config 中的方法
void | MapGrantRight.addRight(java.lang.String strName, java.lang.String strNodeID, java.lang.String strNodeType) 已过时。 添加指定用户/用户组对某节点的权限
boolean | MapDataSource.contains(java.lang.String strDataSourceId) 查找指定strDataSourceId对应的数据源是否存在于数据源对象集合中
boolean | MapDataSource.containsName(java.lang.String strDataSourceName) 查找指定strDataSourceName对应的数据源是否存在于数据源对象集合中
Node[] | NavigateTree.deleteAllSonNodes(int iNodeID) 已过时。 删除指定节点的所有子节点。
FieldData | ChannelNode.deleteField(java.lang.String strFieldName) 从频道的字段集合中删除字段对象
Node[] | NavigateTree.deleteNode(boolean bDelAll, int iNodeID) 已过时。 删除树指定的节点。
static java.lang.String | WASEncoding.encodingString(java.lang.String strSource, java.lang.String strEncoding) 已过时。 对字符串进行指定的编码。
static java.lang.String | WASEncoding.encodingString(java.lang.String strSource, java.lang.String strCharacterEncoding, java.lang.String strEncoding) 已过时。 对字符串进行指定的编码。
java.lang.String | ChannelNode.getAllFieldInfo() 返回所有字段信息字符串.
static java.lang.String | WASEncoding.getAppServerEncoding(javax.servlet.http.HttpServletRequest request) 已过时。 获取应用服务器的编码类型.
static boolean | RequestOperation.getBoolParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的布尔类型参数值
static boolean | RequestOperation.getBoolParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, boolean bDefaultValue) 获取请求中布尔类型的参数值
static boolean[] | RequestOperation.getBoolParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取多个布尔类型参数的值
DataSource | MapDataSource.getDataSource(java.lang.String strDataSourceId) 从数据源对象集合中取出指定strDataSourceId对应的数据源
static java.lang.String | WASEncoding.getDefaultEncodingType() 已过时。 获取缺省编码类型.
java.lang.String | ChannelNode.getDefaultSearchFieldString() 获取频道的默认检索字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getDefaultSearchFieldStringArray() 获取频道的默认检索字段数组
java.lang.String | ChannelNode.getDetailFieldString() 获取频道的细览字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getDetailFieldStringArray() 获取频道的细览字段数组
java.lang.String | ChannelNode.getDownloadFieldString() 获取频道的下载字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getDownloadFieldStringArray() 获取频道的下载字段数组
static int | WASEncoding.getEncodingLevel() 已过时。 获取系统编码级别.
static java.lang.String | WASEncoding.getEncodingType(javax.servlet.http.HttpServletRequest request) 已过时。 获取希望请求参数进行的编码类型。
static java.lang.String | WASEncoding.getEncodingType(java.lang.String strEncodFlag) 已过时。 获得指定的编码类型
FieldData | MapFieldData.getField(java.lang.String strFieldName) 获取指定名称的字段对象
FieldData | ChannelNode.getField(java.lang.String strFieldName) 从频道的字段集合中获取指定字段对象
FieldData[] | MapFieldData.getFieldArray() 获取所有字段对象
FieldData[] | ChannelNode.getFieldArray() 获取所有字段对象
FieldData | MapFieldData.getFieldByDisplayName(java.lang.String strDisplayName) 根据字段显示名称获取指定字段对象
java.util.Enumeration | MapFieldData.getFieldNames() 枚举频道的字段名称
int | MapFieldData.getFieldNum() 获取字段个数
FieldData[] | MapFieldData.getFieldsByType(int iSpecialType) 根据字段特殊类型获取指定字段对象
java.lang.String | FieldData.getFieldSeq() 获取字段所有特殊类型的字段序号
java.lang.String[] | MapFieldData.getFieldStringArrayByType(int iSpecialType) 根据字段特殊类型获取指定字段对象的名称数组
java.lang.String | MapFieldData.getFieldStringByType(int iSpecialType) 根据字段类型获取指定字段对象的名称串
static int | MapGrantRight.getGrants(ConfigData configData, int iChannelID, int iNum, int iPage, java.util.Vector v) 已过时。
java.lang.String | MapDataSource.getIdFromName(java.lang.String strDataSourceName) 查找指定strDataSourceName对应的id
static int | RequestOperation.getIntParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的整数类型参数值
static int | RequestOperation.getIntParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, int iDefaultValue) 获取请求中的整数类型参数值
static int[] | RequestOperation.getIntParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的多个整数类型参数值。
java.util.Enumeration | MapWASStyle.getKeys() 已过时。 返回hashtable的key.
java.util.Enumeration | MapDataSource.getKeys() 返回hashtable的key
java.lang.String | ChannelNode.getKeyWordFieldString() 获取频道的关键词字段字符串
java.lang.String[] | ChannelNode.getKeyWordFieldStringArrary() 获取频道的关键词字段数组
static long | RequestOperation.getLongParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, int lDefaultValue) 获取请求中长整型参数的参数值
java.lang.String | ChannelNode.getMailFieldString() 获取频道的推荐字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getMailFieldStringArray() 获取频道的推荐字段数组
int[] | NavigateTree.getNodeByChannelID(int iChannelID) 已过时。 由频道ID获取相应的导航节点对象
java.lang.String | ChannelNode.getOutfileFieldString() 获取频道的外部文件字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getOutfileFieldStringArray() 获取频道的外部文件字段数组
java.lang.String | ChannelNode.getOutlineFieldString() 获取频道的概览字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getOutlineFieldStringArray() 获取频道的概览字段数组
static java.lang.String | RequestOperation.getParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的参数值。
static java.lang.String | RequestOperation.getParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strEncoding, java.lang.String strParameterName) 获取请求中的参数值。
static java.lang.String[] | RequestOperation.getParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName) 获取请求中的多个参数值。
static java.lang.String[] | RequestOperation.getParameterValues(javax.servlet.http.HttpServletRequest request, java.lang.String strEncoding, java.lang.String strParameterName) 获取请求中的多个参数值。
java.lang.String | ChannelNode.getPrimaryFieldString() 获取频道的主键字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getPrimaryFieldStringArray() 获取频道的主键字段数组
java.lang.String | ChannelNode.getReadTimeFieldString() 获取频道的阅读次数字段字符串
java.lang.String[] | ChannelNode.getReadTimeFieldStringArray() 获取频道的阅读次数字段数组
java.lang.String | ChannelNode.getRelationFieldString() 获取频道的相关阅读字段字符串
java.lang.String[] | ChannelNode.getRelationFieldStringArray() 获取频道的相关阅读字段数组
java.lang.String | ChannelNode.getSearchFormFieldString() 获取频道的检索表单字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getSearchFormFieldStringArray() 获取频道的检索表单字段数组
int | FieldData.getSeq(int iFieldSpecialType) 根据字段特殊类型获取字段序号
java.lang.String | ChannelNode.getSourceFileFieldString() 获取频道的源文件字段字符串，不同字段以逗号分隔
java.lang.String[] | ChannelNode.getSourceFileFieldStringArray() 获取频道的源文件字段数组
java.lang.String | ChannelNode.getStatFieldString() 获取频道的分类统计字段字符串
java.lang.String[] | ChannelNode.getStatFieldStringArrary() 获取频道的分类统计字段数组
java.lang.String | HttpMultiFormPart.getStringValue() 已过时。 在此处插入方法说明。
static java.lang.String | RequestOperation.getStrParameter(javax.servlet.http.HttpServletRequest request, java.lang.String strParameterName, java.lang.String strDefaultValue) 获取请求中字符串型参数值
java.lang.String | SearchData.getStrRecords() 获得记录号
java.lang.String | ChannelNode.getTimeLineFieldString() 获取频道的时间轴字段字符串
java.lang.String[] | ChannelNode.getTimeLineFieldStringArrary() 获取频道的时间轴字段数组
java.util.Hashtable | MapGrantRight.getUserGrant(java.lang.String strUser) 已过时。 获取指定用户/用户组的授权集合
com.trs.was.config.WASStyle | MapWASStyle.getWASStyle(java.lang.String strWASStyleName) 已过时。 从风格对象集合中取出指定风格名对应的风格
boolean | NavigateTree.hasChannel(int iChannelID) 已过时。 返回导航树是否包含指定频道ID的节点
boolean | MapGrantRight.hasRight(ConfigData configData, java.lang.String strName, java.lang.String strGroup, java.lang.String strRole, java.lang.String strType, boolean bLogic, java.lang.String strNodeID, int iGrantType) 已过时。 获取指定用户/用户组/角色对某节点是否有权限
boolean | MapGrantRight.hasRight(java.lang.String strName, java.lang.String strNodeID, int iNodeType, int iGrantType) 已过时。 获取指定用户/用户组对某节点是否有权限
void | ChannelNode.inherit(ChannelNode parentNode) 继承父节点的属性
void | LoginConfig.initOpenedPointTree(Node root, java.lang.String strLayer, int iTreeType) 已过时。
Node[] | NavigateTree.insertNode(int iParentID, int iOrder, Node newnode) 已过时。 在树指定位置插入节点
void | NavigateTree.insertNode(int iParentID, Node newnode, int iOrder) 已过时。 插入导航节点
static boolean | WASEncoding.isEncodingLevel(int iLevel) 已过时。 判断是否为指定编码级别
static boolean | WASEncoding.isSupportEncoding(java.lang.String strEncoding) 已过时。 判断编码类型是否支持.
java.util.Enumeration | MapGrantRight.key() 已过时。 返回权限集合枚举
boolean | LoginConfig.login(ConfigData configData, com.trs.was.config.MapGrantRight mapGrantRight, java.sql.Connection conn, java.lang.String strUserName, java.lang.String strPassword) 已过时。
boolean | LoginConfig.login(java.sql.Connection conn, java.lang.String strUserName) 已过时。
boolean | LoginConfig.login(java.sql.Connection conn, java.lang.String strUserName, java.lang.String strPassword) 登录操作
void | MapFieldData.removeAllFields() 删除频道字段集合中的所有字段对象
void | ChannelNode.removeAllFields() 从频道的字段集合中删除所有字段对象
void | MapDataSource.removeDataSource(java.lang.String strDataSourceId) 从数据源对象集合中删除指定strDataSourceId对应的数据源
FieldData | MapFieldData.removeField(java.lang.String strFieldName) 从频道字段集合中删除指定名称的字段对象
void | MapGrantRight.removeRight(java.lang.String strName, java.lang.String strNodeID, java.lang.String strNodeType) 已过时。 删除指定用户/用户组对某节点的权限
void | MapWASStyle.removeWASStyle(java.lang.String strWASStyleName) 已过时。 从风格对象集合中删除指定风格名对应的风格
void | MapGrantRight.saveRight(java.sql.Connection conn, java.lang.String strName, java.lang.String strNodeID, java.lang.String strNodeType, int iSQLType) 已过时。 保存权限
void | ChannelNode.setAllSources(java.lang.String strSources) 设置数据库/视图名称
void | SearchData.setBack(java.lang.String strBack) 设置回退操作的步数
void | MapDataSource.setDataSource(DataSource dataSource) 向数据源对象集合中写入指定strDataSourceId对应的数据源
void | MapFieldData.setField(FieldData field) 添加字段对象到频道的字段集合中
void | ChannelNode.setField(FieldData field) 在频道的字段集合中添加字段对象
void | MapFieldData.setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中
void | ChannelNode.setFieldsByArray(FieldData[] fieldDataArray) 添加字段对象数组到频道的字段集合中
void | MapFieldData.setFieldsByString(java.lang.String strFieldsString) 从字符串中解析出DataField信息并写入到m_mapFields
void | ChannelNode.setFieldsByString(java.lang.String strFieldsString) 从字符串中解析出DataField信息并写入到m_mapFieldData中
void | FieldData.setFieldSeq(java.lang.String strFieldSeq) 解析字段序号字符串
void | SearchData.setPage(java.lang.String strPage) 设置当前页面号
void | FieldData.setSeq(int iFieldSpecialType, int iSeq) 根据字段特殊类型设置字段序号
void | MapGrantRight.setUserGrant(java.lang.String strUser, java.util.Hashtable hGrant) 已过时。 设置指定用户/用户组的授权集合
void | MapWASStyle.setWASStyle(com.trs.was.config.WASStyle wasStyle) 已过时。 向风格对象集合中写入指定的风格
static java.lang.String | WASEncoding.urlEncoding(java.lang.String strSource, javax.servlet.http.HttpServletRequest request) 已过时。 进行URL编码
static java.lang.String | WASEncoding.urlEncoding(java.lang.String strSource, java.lang.String strEncoding) 已过时。 进行URL编码
static java.lang.String | HttpGBK2UnicodeRequest.URLGBKDecode(java.lang.String strSRC) 已过时。
static java.lang.String | HttpGBK2UnicodeRequest.URLGBKEncode(java.lang.String s) 已过时。 在此处插入方法说明。

抛出 WASException 的 com.trs.was.config 中的构造函数
AppConfig()
默认构造方法，读取wasconfig.properties配置文件，初始化各成员变量
AppConfig(javax.servlet.ServletContext application)
构造方法，读取wasconfig.properties配置文件，初始化各成员变量，保存在ServletContext对象中
ConfigData()
构造方法，初始化各私有变量，对各私有变量赋予初值
HttpGBK2UnicodeRequest(javax.servlet.http.HttpServletRequest request)
已过时。 在此处插入方法说明。
MapChannel(java.util.Hashtable trees)
构造方法
MapGroup(java.util.Hashtable trees)
构造方法
MapNavigate(java.util.Hashtable trees)
已过时。 构造方法

com.trs.was.tree 中 WASException 的使用

抛出 WASException 的 com.trs.was.tree 中的方法
static void | TreeOperation.buildTree(java.lang.String strRootTitle, Node root, java.util.Vector openPoints, javax.servlet.jsp.JspWriter out, java.lang.String strTarget, java.lang.String strItemFormat, boolean bLastTree, int iLevel, java.lang.String strTreeFile, int iTreeKind, java.lang.String strErrorUrl) 已过时。 构造树输出到页面
void | MapTree.buildTree(Tree tree, java.util.Hashtable nodes, Node root) 构造树对象。
boolean | Tree.containNode(int id) 判断该树是否包含某节点。
Node[] | Tree.deleteAllSonNodes(int iNodeID) 删除指定节点的所有子节点。
Node[] | Tree.deleteNode(boolean bDelAll, int iNodeID) 删除树指定的节点。
static java.lang.String | TreeOperation.formatNavigateItem(com.trs.was.config.NavigateNode node, java.lang.String strFormat, java.lang.String strTarget) 已过时。 输出格式化的导航节点的信息
void | Tree.getAllParents(int iNodeID, java.util.Vector v) 获取所有父节点
void | Tree.getAllParentsID(int iNodeID, java.util.Vector v) 获取所有父节点id
void | Tree.getAllSons(int iNodeID, java.util.Vector v, boolean bGetAll, int iSQLFlag) 获取指定节点的所有子节点对象。
void | Tree.getAllSonsID(int iNodeID, java.util.Vector v, boolean bGetAll) 获取指定节点的所有子节点。
Node | Tree.getLastSonNode() 获取最后一个子节点
Node | Tree.getNode(int id) 获取该树中指定ID号的节点对象。
Node | MapTree.getNode(int iNodeID) 获取指定ID号的节点对象。
Node | Tree.getNode(java.lang.String strName) 返回指定名称的节点
int | MapTree.getSize() 获取集合中树的个数。
int | Tree.getSonOrder(int iParentID, int iSonID) 获取某子节点是其父节点下的第几个子节点。
Tree | MapTree.getTree(java.lang.String strTreeName) 在集合中获取指定名称的树对象。
java.util.Enumeration | MapTree.getTreeNames() 获取集合中所有树的名称。
Tree[] | MapTree.getTrees() 从集合中获取所有的树对象。
int | Tree.getTreeSize() 获取返回该树的节点数。
boolean | Tree.haveChildrens(int iNodeID) 判断节点是否包含子节点。
Node[] | Tree.insertNode(int iParentID, int iOrder, Node newnode) 在树指定位置插入节点
void | Tree.insertNode(int iParentID, Node newnode, int iOrder) 在树指定位置插入节点
boolean | Tree.isSon(int parentID, int nodeID, boolean allSon) 已过时。
void | Tree.moveNode(int iNodeID, int iNodeIDMoveTo, int iOrder) 已过时。
Node[] | Tree.moveNodes(int iNodeID, int iNodeIDMoveTo, int iOrder) 移动节点到指定位置。
static void | TreeOperation.outputItem(java.lang.String strRootTitle, Node node, java.util.Vector openPoints, javax.servlet.jsp.JspWriter out, java.lang.String strTarget, java.lang.String strItemFormat, boolean bLastTree, int iLevel, java.lang.String strTreeFile, int iTreeKind, java.lang.String strErrorUrl) 已过时。 输出节点信息。
static java.lang.String | TreeOperation.outputItemHref(Node node, java.lang.String strTreeFile, int iTreeKind) 已过时。 输出节点前图标的链接信息。
static void | TreeOperation.outputItemSelf(java.lang.String strRootTitle, Node node, javax.servlet.jsp.JspWriter out, java.lang.String strItemFormat, int iTreeKind, java.lang.String strTarget, int iLevel, java.lang.String strErrorUrl) 已过时。 输出节点的自身信息。
static void | TreeOperation.outputParentIcon(Node node, javax.servlet.jsp.JspWriter out, boolean bLastTree, int iLevel, int iTreeKind) 已过时。 输出节点前的所有父节点的连接图标。
Tree | MapTree.removeTree(java.lang.String strTreeName) 从集合中移除指定的树
void | MapTree.setTree(Tree tree) 将树对象添加到哈希表中。

抛出 WASException 的 com.trs.was.tree 中的构造函数
MapTree(java.util.Hashtable trees)
构造方法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASGroup
的使用

没有 com.trs.was.config.WASGroup 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASRole 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASRole
的使用

没有 com.trs.was.config.WASRole 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASStyle
的使用

使用 com.trs.was.config.WASStyle 的软件包
com.trs.was.config

com.trs.was.config 中 com.trs.was.config.WASStyle 的使用

返回 com.trs.was.config.WASStyle 的 com.trs.was.config 中的方法
 com.trs.was.config.WASStyle MapWASStyle.getWASStyle(java.lang.String strWASStyleName)
已过时。 从风格对象集合中取出指定风格名对应的风格

参数类型为 com.trs.was.config.WASStyle 的 com.trs.was.config 中的方法
 void MapWASStyle.setWASStyle(com.trs.was.config.WASStyle wasStyle)
已过时。 向风格对象集合中写入指定的风格

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.config.WASUser 的使用

上一个 下一个 框架 无框架

类 com.trs.was.config.WASUser
的使用

使用 WASUser 的软件包
com.trs.was.config

com.trs.was.config 中 WASUser 的使用

返回 WASUser 的 com.trs.was.config 中的方法
 WASUser LoginConfig.getWasUser()
获得当前登录用户

参数类型为 WASUser 的 com.trs.was.config 中的方法
java.util.Vector | MapGrantRight.getGrantChannel(WASUser user, int iMask) 已过时。 返回用户有权限的频道集合
void | LoginConfig.setWasUser(WASUser wasUser) 设置当前登录用户

概述 软件包 类 使用 树 索引 帮助


 com.trs.was.tree
类
MapTree
Node
Tree


类 com.trs.was.tree.BuildGroupTree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.BuildGroupTree
的使用

没有 com.trs.was.tree.BuildGroupTree 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.tree.BuildTree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.BuildTree
的使用

没有 com.trs.was.tree.BuildTree 的用法

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.tree.MapTree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.MapTree
的使用

使用 MapTree 的软件包
com.trs.was.config

com.trs.was.config 中 MapTree 的使用

com.trs.was.config 中 MapTree 的子类
class | MapChannel 频道树对象集合类。
class | MapGroup 用户组树对象集合类。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.tree.Node 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.Node
的使用

使用 Node 的软件包
com.trs.was.config
com.trs.was.tree

com.trs.was.config 中 Node 的使用

com.trs.was.config 中 Node 的子类
class | ChannelNode 频道节点对象，用于存储频道对象信息。
class | WASGroup 用户组信息类,用于存储用户组信息

返回 Node 的 com.trs.was.config 中的方法
Node[] | NavigateTree.deleteAllSonNodes(int iNodeID) 已过时。 删除指定节点的所有子节点。
Node[] | NavigateTree.deleteNode(boolean bDelAll, int iNodeID) 已过时。 删除树指定的节点。
Node[] | NavigateTree.insertNode(int iParentID, int iOrder, Node newnode) 已过时。 在树指定位置插入节点

参数类型为 Node 的 com.trs.was.config 中的方法
void | LoginConfig.initOpenedPointTree(Node root, java.lang.String strLayer, int iTreeType) 已过时。
Node[] | NavigateTree.insertNode(int iParentID, int iOrder, Node newnode) 已过时。 在树指定位置插入节点
void | NavigateTree.insertNode(int iParentID, Node newnode, int iOrder) 已过时。 插入导航节点

com.trs.was.tree 中 Node 的使用

返回 Node 的 com.trs.was.tree 中的方法
Node[] | Tree.deleteAllSonNodes(int iNodeID) 删除指定节点的所有子节点。
Node[] | Tree.deleteNode(boolean bDelAll, int iNodeID) 删除树指定的节点。
Node | Tree.getLastSonNode() 获取最后一个子节点
Node | Node.getNextNode() 获取下一个兄弟节点对象
Node | Tree.getNode(int id) 获取该树中指定ID号的节点对象。
Node | MapTree.getNode(int iNodeID) 获取指定ID号的节点对象。
Node | Tree.getNode(java.lang.String strName) 返回指定名称的节点
Node | Node.getParentNode() 获取父节点对象
Node | Node.getPreNode() 获取上一个兄弟节点对象
Node | Tree.getRootNode() 获取根节点对象
Node | Node.getSonNode() 获取第一个子节点对象
Node[] | Tree.insertNode(int iParentID, int iOrder, Node newnode) 在树指定位置插入节点
Node[] | Tree.moveNodes(int iNodeID, int iNodeIDMoveTo, int iOrder) 移动节点到指定位置。

参数类型为 Node 的 com.trs.was.tree 中的方法
static void | TreeOperation.buildTree(java.lang.String strRootTitle, Node root, java.util.Vector openPoints, javax.servlet.jsp.JspWriter out, java.lang.String strTarget, java.lang.String strItemFormat, boolean bLastTree, int iLevel, java.lang.String strTreeFile, int iTreeKind, java.lang.String strErrorUrl) 已过时。 构造树输出到页面
void | MapTree.buildTree(Tree tree, java.util.Hashtable nodes, Node root) 构造树对象。
Node[] | Tree.insertNode(int iParentID, int iOrder, Node newnode) 在树指定位置插入节点
void | Tree.insertNode(int iParentID, Node newnode, int iOrder) 在树指定位置插入节点
static void | TreeOperation.outputItem(java.lang.String strRootTitle, Node node, java.util.Vector openPoints, javax.servlet.jsp.JspWriter out, java.lang.String strTarget, java.lang.String strItemFormat, boolean bLastTree, int iLevel, java.lang.String strTreeFile, int iTreeKind, java.lang.String strErrorUrl) 已过时。 输出节点信息。
static java.lang.String | TreeOperation.outputItemHref(Node node, java.lang.String strTreeFile, int iTreeKind) 已过时。 输出节点前图标的链接信息。
static void | TreeOperation.outputItemSelf(java.lang.String strRootTitle, Node node, javax.servlet.jsp.JspWriter out, java.lang.String strItemFormat, int iTreeKind, java.lang.String strTarget, int iLevel, java.lang.String strErrorUrl) 已过时。 输出节点的自身信息。
static void | TreeOperation.outputParentIcon(Node node, javax.servlet.jsp.JspWriter out, boolean bLastTree, int iLevel, int iTreeKind) 已过时。 输出节点前的所有父节点的连接图标。
void | Node.setNextNode(Node nextNode) 设置下一个兄弟节点对象
void | Node.setParentNode(Node parentNode) 设置父节点对象
void | Node.setPreNode(Node preNode) 设置上一个兄弟节点对象
void | Node.setSonNode(Node sonNode) 设置第一个子节点对象

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.tree.Tree 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.Tree
的使用

使用 Tree 的软件包
com.trs.was.config
com.trs.was.tree

com.trs.was.config 中 Tree 的使用

com.trs.was.config 中 Tree 的子类
 class ChannelTree
频道树类，扩展了Tree类

com.trs.was.tree 中 Tree 的使用

返回 Tree 的 com.trs.was.tree 中的方法
Tree | MapTree.getTree(java.lang.String strTreeName) 在集合中获取指定名称的树对象。
Tree[] | MapTree.getTrees() 从集合中获取所有的树对象。
Tree | MapTree.removeTree(java.lang.String strTreeName) 从集合中移除指定的树

参数类型为 Tree 的 com.trs.was.tree 中的方法
void | MapTree.buildTree(Tree tree, java.util.Hashtable nodes, Node root) 构造树对象。
void | MapTree.setTree(Tree tree) 将树对象添加到哈希表中。

概述 软件包 类 使用 树 索引 帮助


类 com.trs.was.tree.TreeOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.was.tree.TreeOperation
的使用

没有 com.trs.was.tree.TreeOperation 的用法

概述 软件包 类 使用 树 索引 帮助


A - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

A

addSpecialType(int) - 类 com.trs.was.config.FieldData 中的方法
为该字段对象添加指定特殊类型
AppConfig - com.trs.was.config 中的 类
基本配置信息类，用于读取wasconfig.properties文件。
AppConfig() - 类 com.trs.was.config.AppConfig 的构造函数
默认构造方法，读取wasconfig.properties配置文件，初始化各成员变量
AppConfig(ServletContext) - 类 com.trs.was.config.AppConfig 的构造函数
构造方法，读取wasconfig.properties配置文件，初始化各成员变量，保存在ServletContext对象中
概述 软件包 类 使用 树 索引 帮助
上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W


B - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

B

buildSQL(String, String, String) - 类 com.trs.was.WASTools 中的静态方法
返回组合检索条件。
buildTree(Tree, Hashtable, Node) - 类 com.trs.was.tree.MapTree 中的方法
构造树对象。
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


C - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

C

ChannelNode - com.trs.was.config 中的 类
频道节点对象，用于存储频道对象信息。
ChannelNode() - 类 com.trs.was.config.ChannelNode 的构造函数
默认构造方法，初始化各成员变量
ChannelTree - com.trs.was.config 中的 类
频道树类，扩展了Tree类
ChannelTree() - 类 com.trs.was.config.ChannelTree 的构造函数
默认构造方法，调用父类的构造方法
classResultForTimeLine(WASResultSet, String, boolean) - 类 com.trs.was.WASTools 中的静态方法
分类统计，用于时间轴
clone() - 类 com.trs.was.config.ChannelNode 中的方法
克隆对象
clone() - 类 com.trs.was.config.FieldData 中的方法
克隆对象
clone() - 类 com.trs.was.config.MapFieldData 中的方法
克隆对象
clone() - 类 com.trs.was.tree.Node 中的方法
克隆对象
close() - 类 com.trs.was.WASResultSet 中的方法
关闭WAS结果集.
com.trs.was - 软件包 com.trs.was
com.trs.was.config - 软件包 com.trs.was.config
com.trs.was.tree - 软件包 com.trs.was.tree
ConfigData - com.trs.was.config 中的 类
存储系统所有配置信息类，用于储存频道，导航等对象信息。
ConfigData() - 类 com.trs.was.config.ConfigData 的构造函数
构造方法，初始化各私有变量，对各私有变量赋予初值
containNode(int) - 类 com.trs.was.tree.Tree 中的方法
判断该树是否包含某节点。
contains(String) - 类 com.trs.was.config.MapDataSource 中的方法
查找指定strDataSourceId对应的数据源是否存在于数据源对象集合中
containsName(String) - 类 com.trs.was.config.MapDataSource 中的方法
查找指定strDataSourceName对应的数据源是否存在于数据源对象集合中
ConverXSS(String) - 类 com.trs.was.WASTools 中的静态方法
将HTML中的字符实体如"<", ">", "("等等替换为字符
convOutput(String) - 类 com.trs.was.WASTools 中的静态方法
将字符如"(", ")", "<", ">"等字符替换为HTML字符实体
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


D - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

D

DataSource - com.trs.was.config 中的 类
数据源对象类。
DataSource() - 类 com.trs.was.config.DataSource 的构造函数
deleteAllSonNodes(int) - 类 com.trs.was.tree.Tree 中的方法
删除指定节点的所有子节点。
deleteField(String) - 类 com.trs.was.config.ChannelNode 中的方法
从频道的字段集合中删除字段对象
deleteNode(boolean, int) - 类 com.trs.was.tree.Tree 中的方法
删除树指定的节点。
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


F - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

F

FieldData - com.trs.was.config 中的 类
字段对象。
FieldData() - 类 com.trs.was.config.FieldData 的构造函数
默认构造方法。
freeWASResultSet(ServletRequest) - 类 com.trs.was.WASTools 中的静态方法
释放WAS结果集
freeWASResultSet(ServletRequest, String) - 类 com.trs.was.WASTools 中的静态方法
释放WAS结果集
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


G - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

G

getAbortURL() - 异常 com.trs.was.config.WASException 中的方法
获取出错后选择放弃时去往的页面
getAdvSearchTemplate() - 类 com.trs.was.config.ChannelNode 中的方法
获得高级搜索模板
getAllFieldInfo() - 类 com.trs.was.config.ChannelNode 中的方法
返回所有字段信息字符串.
getAllParents(int, Vector) - 类 com.trs.was.tree.Tree 中的方法
获取所有父节点
getAllParentsID(int, Vector) - 类 com.trs.was.tree.Tree 中的方法
获取所有父节点id
getAllSearchWord() - 类 com.trs.was.config.SearchData 中的方法
获取所有检索条件。
getAllSons(int, Vector, boolean, int) - 类 com.trs.was.tree.Tree 中的方法
获取指定节点的所有子节点对象。
getAllSonsID(int, Vector, boolean) - 类 com.trs.was.tree.Tree 中的方法
获取指定节点的所有子节点。
getAllSources() - 类 com.trs.was.config.ChannelNode 中的方法
返回所有数据库/视图名称.
getAnonyAccount() - 类 com.trs.was.config.ConfigData 中的方法
获得匿名帐号
getAnonyGroup() - 类 com.trs.was.config.ConfigData 中的方法
获取匿名用户所在组织
getAnonyRole() - 类 com.trs.was.config.ConfigData 中的方法
获取匿名用户所在角色
getAntonymDic() - 类 com.trs.was.config.ChannelNode 中的方法
获取用于频道检索的反义词典名称
getAppServerEncoding() - 类 com.trs.was.config.AppConfig 中的方法
获得应用服务器编码
getAReduplicate() - 类 com.trs.was.config.ChannelNode 中的方法
获取去重属性数组
getAutoExtend() - 类 com.trs.was.config.ChannelNode 中的方法
获取保存自动扩展选项的字符串
getBack() - 类 com.trs.was.config.SearchData 中的方法
获取回退操作的步数
getBaseDir() - 类 com.trs.was.config.AppConfig 中的方法
获取应用根目录路径
getBinaryObjectCount(String) - 类 com.trs.was.WASResultSet 中的方法
获得指定字段二进制对象的个数。
getBinaryObjectRealCount(String) - 类 com.trs.was.WASResultSet 中的方法
获得指定字段二进制对象的个数。
getBinaryStream(String, int) - 类 com.trs.was.WASResultSet 中的方法
获得当前记录指定字段名称和多值序号的对象的输入流对象。
getBindFormID() - 类 com.trs.was.config.ChannelNode 中的方法
获取绑定表单ID
getBoolParameter(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的布尔类型参数值
getBoolParameter(HttpServletRequest, String, boolean) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中布尔类型的参数值
getBoolParameterValues(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取多个布尔类型参数的值
getBoolProperties(String) - 类 com.trs.was.config.AppConfig 中的静态方法
获取布尔型配置值
getBytes(String, int) - 类 com.trs.was.WASResultSet 中的方法
获取字段内容的字节数组
getCfgHash() - 类 com.trs.was.config.ConfigData 中的方法
获取系统配置信息集合
getChannel(ConfigData, String) - 类 com.trs.was.WASTools 中的静态方法
获取频道对象
getChannelID() - 类 com.trs.was.config.SearchData 中的方法
获取频道ID号
getChannelID() - 异常 com.trs.was.config.WASException 中的方法
获取出错的频道ID号
getChannelID() - 类 com.trs.was.WASResultSet 中的方法
获取频道ID
getChannelID(LoginConfig, SearchData, String) - 类 com.trs.was.WASTools 中的静态方法
获取频道ID
getChannelName() - 类 com.trs.was.config.ChannelNode 中的方法
获得频道名称
getChannelNames(ConfigData, String) - 类 com.trs.was.WASTools 中的静态方法
获得操作的频道名。
getChannelSources(ConfigData, String) - 类 com.trs.was.WASTools 中的静态方法
获取频道的TRS数据库名称。
getChannelSQL() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道条件
getCheckPermit() - 类 com.trs.was.config.AppConfig 中的方法
是否需要验证用户权限
getCheckType() - 类 com.trs.was.config.ChannelNode 中的方法
获得频道控制类型
getClassColumn() - 类 com.trs.was.config.SearchData 中的方法
获取分类统计字段名称
getClassRoot() - 类 com.trs.was.config.SearchData 中的方法
获取分类树根节点
getClassSQL() - 类 com.trs.was.config.SearchData 中的方法
获取分类统计条件表达式
getColHitNum(String) - 类 com.trs.was.WASResultSet 中的方法
获取字段命中点数
getColumnMultiValue(String) - 类 com.trs.was.WASResultSet 中的方法
获取字段的多值个数
getColumnType() - 类 com.trs.was.config.FieldData 中的方法
获得字段类型
getColumnType(String) - 类 com.trs.was.WASResultSet 中的方法
获得当前记录中指定字段的类型。
getComment() - 类 com.trs.was.config.ChannelNode 中的方法
获得频道的说明信息
getComment() - 类 com.trs.was.config.WASGroup 中的方法
获取用户组说明
getComment() - 类 com.trs.was.config.WASRole 中的方法
获取角色说明信息
getComment() - 类 com.trs.was.config.WASUser 中的方法
获取用户说明
getConnPool() - 类 com.trs.was.config.ConfigData 中的方法
获得数据库连接池对象
getContentType(String, int) - 类 com.trs.was.WASResultSet 中的方法
该方法返回当前记录的二进制字段的指定对象的 ContentType
getCreateDate() - 类 com.trs.was.config.WASGroup 中的方法
获取用户组创建时间
getCreateDate() - 类 com.trs.was.config.WASRole 中的方法
获取角色创建日期
getCreateDate() - 类 com.trs.was.config.WASUser 中的方法
获取用户创建时间
getCreateTime() - 类 com.trs.was.config.ChannelNode 中的方法
获得创建日期
getCurrentChannel() - 类 com.trs.was.config.LoginConfig 中的方法
获得当前频道
getCurrentUserType() - 类 com.trs.was.config.DataSource 中的方法
获取当前用户权限级别
getCustomExpr() - 类 com.trs.was.config.SearchData 中的方法
获取自定义表达式
getDataSource(String) - 类 com.trs.was.config.MapDataSource 中的方法
从数据源对象集合中取出指定strDataSourceId对应的数据源
getDataSourceId() - 类 com.trs.was.config.ChannelNode 中的方法
获得数据源Id
getDataSourceId() - 类 com.trs.was.config.DataSource 中的方法
获得数据源id
getDataSourceName() - 类 com.trs.was.config.DataSource 中的方法
获得数据源名称
getDate(String, String) - 类 com.trs.was.WASResultSet 中的方法
获取日期字段指定格式的内容
getDebugLevel() - 类 com.trs.was.config.AppConfig 中的方法
获得调试级别
getDefaultAdvSearch() - 类 com.trs.was.config.ConfigData 中的方法
获得默认高级搜索模板
getDefaultDetail() - 类 com.trs.was.config.ConfigData 中的方法
设置默认细览模板
getDefaultMail() - 类 com.trs.was.config.ConfigData 中的方法
获得默认邮件发送模板
getDefaultOutline() - 类 com.trs.was.config.ConfigData 中的方法
获得默认概览模板
getDefaultPrint() - 类 com.trs.was.config.ConfigData 中的方法
获得默认打印模板
getDefaultSearchColumn() - 类 com.trs.was.config.SearchData 中的方法
获取缺省检索字段
getDefaultSearchFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的默认检索字段字符串，不同字段以逗号分隔
getDefaultSearchFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的默认检索字段数组
getDemoPath() - 类 com.trs.was.config.AppConfig 中的方法
获取演示数据库路径
getDetailFields() - 类 com.trs.was.WASResultSet 中的方法
获得检索结果对象对应的频道的细览字段
getDetailFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的细览字段字符串，不同字段以逗号分隔
getDetailFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的细览字段数组
getDetailTemplate() - 类 com.trs.was.config.ChannelNode 中的方法
获得细览模板
getDownloadFields() - 类 com.trs.was.WASResultSet 中的方法
获得检索结果对象对应的频道的下载字段
getDownloadFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的下载字段字符串，不同字段以逗号分隔
getDownloadFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的下载字段数组
getDownloadType() - 类 com.trs.was.config.AppConfig 中的方法
获取下载类型
getError() - 异常 com.trs.was.config.WASException 中的方法
获取错误说明
getErrorDetail() - 异常 com.trs.was.config.WASException 中的方法
获取详细的出错信息
getErrorFile() - 类 com.trs.was.config.AppConfig 中的方法
获取错误文件名
getErrorFrom() - 异常 com.trs.was.config.WASException 中的方法
获取出错处
getErrorNumber() - 异常 com.trs.was.config.WASException 中的方法
获取错误号
getErrorServlet() - 异常 com.trs.was.config.WASException 中的方法
获取出错时的Servlet或JSP位置，便于记录日志
getErrorURL() - 异常 com.trs.was.config.WASException 中的方法
获取出错时所在页面，用于未登录等操作回到原来的页面
getEstimatestop() - 类 com.trs.was.config.ChannelNode 中的方法
获取快速检索时，至少返回的记录数
getEstimateStops() - 类 com.trs.was.config.SearchData 中的方法
获取至少返回的记录数（用于快速返回）
getEstimateunit() - 类 com.trs.was.config.ChannelNode 中的方法
获取估算检索时，每个逻辑段包含的记录数
getEstimateUnit() - 类 com.trs.was.config.SearchData 中的方法
获取每个逻辑段包含的记录数（用于快速检索）
getExpTempMap() - 类 com.trs.was.config.ConfigData 中的方法
获取表达式模板集合
getExtendOpt() - 类 com.trs.was.config.ChannelNode 中的方法
获取保存扩展检索选项的字符串
getExtendOpt() - 类 com.trs.was.config.SearchData 中的方法
获取扩展检索选项
getExtension() - 类 com.trs.was.config.SearchData 中的方法
获取扩展检索方式
getExtraCfg() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道其它配置
getExtraString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道其他配置
getField(String) - 类 com.trs.was.config.ChannelNode 中的方法
从频道的字段集合中获取指定字段对象
getField(String) - 类 com.trs.was.config.MapFieldData 中的方法
获取指定名称的字段对象
getFieldArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取所有字段对象
getFieldArray() - 类 com.trs.was.config.MapFieldData 中的方法
获取所有字段对象
getFieldByDisplayName(String) - 类 com.trs.was.config.MapFieldData 中的方法
根据字段显示名称获取指定字段对象
getFieldDisName() - 类 com.trs.was.config.FieldData 中的方法
获得字段显示名
getFieldName() - 类 com.trs.was.config.FieldData 中的方法
获得字段名
getFieldNames() - 类 com.trs.was.config.MapFieldData 中的方法
枚举频道的字段名称
getFieldNum() - 类 com.trs.was.config.MapFieldData 中的方法
获取字段个数
getFieldsByType(int) - 类 com.trs.was.config.MapFieldData 中的方法
根据字段特殊类型获取指定字段对象
getFieldSeq() - 类 com.trs.was.config.FieldData 中的方法
获取字段所有特殊类型的字段序号
getFieldSpecialType() - 类 com.trs.was.config.FieldData 中的方法
获得字段特殊类型
getFieldStringArrayByType(int) - 类 com.trs.was.config.MapFieldData 中的方法
根据字段特殊类型获取指定字段对象的名称数组
getFieldStringByType(int) - 类 com.trs.was.config.MapFieldData 中的方法
根据字段类型获取指定字段对象的名称串
getFieldType() - 类 com.trs.was.config.FieldData 中的方法
获得字段类型
getFile(String, int) - 类 com.trs.was.WASResultSet 中的方法
获得指定二进制字段的文件名。
getFilterMap() - 类 com.trs.was.config.ConfigData 中的方法
获取过滤词集合
getFloat(String) - 类 com.trs.was.WASResultSet 中的方法
获取指定NUMBER字段FLOAT类型内容
getForceReload() - 类 com.trs.was.config.AppConfig 中的方法
获取是否强制定时重新加载配置文件
getFormMap() - 类 com.trs.was.config.ConfigData 中的方法
获取表单集合
getFullVersion() - 类 com.trs.was.config.DataSource 中的方法
获取数据源TRS服务器完整的版本号
getGrantRight() - 类 com.trs.was.config.ChannelNode 中的方法
获取存放WAS4升级的权限数据
getHitNum() - 类 com.trs.was.WASResultSet 中的方法
获取命中点个数
getHitType() - 类 com.trs.was.config.ChannelNode 中的方法
获取命中点类型
getHitType() - 类 com.trs.was.config.SearchData 中的方法
获取命中点类型
getHotWord() - 类 com.trs.was.config.ConfigData 中的方法
获取热搜词集合
getID() - 类 com.trs.was.tree.Node 中的方法
获取节点ID
getIdFromName(String) - 类 com.trs.was.config.MapDataSource 中的方法
查找指定strDataSourceName对应的id
getIndexTemplet() - 类 com.trs.was.config.ChannelNode 中的方法
获取主页模板
getInt(String) - 类 com.trs.was.WASResultSet 中的方法
获取指定NUMBER字段INT类型内容
getIntParameter(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的整数类型参数值
getIntParameter(HttpServletRequest, String, int) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的整数类型参数值
getIntParameterValues(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的多个整数类型参数值。
getIntProperties(String) - 类 com.trs.was.config.AppConfig 中的静态方法
获取整数型配置值
getIpFilterMap() - 类 com.trs.was.config.ConfigData 中的方法
获取IP限制集合
getIRecords() - 类 com.trs.was.config.SearchData 中的方法
获取当前记录号数组
getKeys() - 类 com.trs.was.config.MapDataSource 中的方法
返回hashtable的key
getKeyWord() - 类 com.trs.was.config.SearchData 中的方法
获取关键词，即检索框内的检索词
getKeyWordFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的关键词字段字符串
getKeyWordFieldStringArrary() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的关键词字段数组
getLastChangeTime() - 类 com.trs.was.config.ChannelNode 中的方法
获得最后一次修改日期
getLastSonNode() - 类 com.trs.was.tree.Tree 中的方法
获取最后一个子节点
getLevel() - 类 com.trs.was.tree.Node 中的方法
获取节点层次
getLicenseCode() - 类 com.trs.was.config.SearchData 中的方法
获取系统许可证
getLicenseCode() - 类 com.trs.was.WASResultSet 中的方法
获取连接许可证
getLogLevel() - 类 com.trs.was.config.ConfigData 中的方法
获得系统日志级别
getLongParameter(HttpServletRequest, String, int) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中长整型参数的参数值
getMailAccount() - 类 com.trs.was.config.ConfigData 中的方法
获得邮件服务器帐号
getMailAddress() - 类 com.trs.was.config.ConfigData 中的方法
获得发送邮件地址
getMailFields() - 类 com.trs.was.WASResultSet 中的方法
获得检索结果对象对应的频道的推荐字段
getMailFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的推荐字段字符串，不同字段以逗号分隔
getMailFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的推荐字段数组
getMailPwd() - 类 com.trs.was.config.ConfigData 中的方法
获得邮件服务器密码
getMailTemplate() - 类 com.trs.was.config.ChannelNode 中的方法
获得邮件推荐模板
getMapChannel() - 类 com.trs.was.config.ConfigData 中的方法
获得频道树集合
getMapDataSource() - 类 com.trs.was.config.ConfigData 中的方法
获得数据源集合
getMapFieldData() - 类 com.trs.was.config.ChannelNode 中的方法
获得数据库字段集合
getMapGroup() - 类 com.trs.was.config.ConfigData 中的方法
获取用户组集合
getMapNodes() - 类 com.trs.was.tree.Tree 中的方法
获取节点集合哈希表
getName() - 类 com.trs.was.config.WASGroup 中的方法
获取用户组名称
getNeedReload() - 类 com.trs.was.config.ConfigData 中的方法
获得是否需要重新加载
getNextID() - 类 com.trs.was.tree.Node 中的方法
获取下一个兄弟节点ID
getNextNode() - 类 com.trs.was.tree.Node 中的方法
获取下一个兄弟节点对象
getNode(int) - 类 com.trs.was.tree.MapTree 中的方法
获取指定ID号的节点对象。
getNode(int) - 类 com.trs.was.tree.Tree 中的方法
获取该树中指定ID号的节点对象。
getNode(String) - 类 com.trs.was.tree.Tree 中的方法
返回指定名称的节点
getOrderBy() - 类 com.trs.was.config.ChannelNode 中的方法
获得频道的排序方式
getOrderBy() - 类 com.trs.was.config.SearchData 中的方法
获取排序方式
getOrderBy(ChannelNode, SearchData) - 类 com.trs.was.WASTools 中的静态方法
获取频道排序条件.
getOutfileFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的外部文件字段字符串，不同字段以逗号分隔
getOutfileFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的外部文件字段数组
getOutFilePath() - 类 com.trs.was.config.AppConfig 中的方法
获取外部文件路径
getOutlineFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的概览字段字符串，不同字段以逗号分隔
getOutlineFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的概览字段数组
getOutlinePage() - 类 com.trs.was.config.SearchData 中的方法
获取概览导航显示页码数
getOutlineTemplate() - 类 com.trs.was.config.ChannelNode 中的方法
获得概览模板
getPage() - 类 com.trs.was.config.SearchData 中的方法
获取当前页面号
getParameter(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的参数值。
getParameter(HttpServletRequest, String, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的参数值。
getParameterValues(HttpServletRequest, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的多个参数值。
getParameterValues(HttpServletRequest, String, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中的多个参数值。
getParentID() - 类 com.trs.was.tree.Node 中的方法
获取父节点ID
getParentNode() - 类 com.trs.was.tree.Node 中的方法
获取父节点对象
getPassword() - 类 com.trs.was.config.WASUser 中的方法
获取用户密码
getPerpage() - 类 com.trs.was.config.SearchData 中的方法
获取每页记录数
getPreID() - 类 com.trs.was.tree.Node 中的方法
获取上一个兄弟节点ID
getPreNode() - 类 com.trs.was.tree.Node 中的方法
获取上一个兄弟节点对象
getPreSearchWord() - 类 com.trs.was.config.SearchData 中的方法
获取上一次检索表达式
getPrimaryFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的主键字段字符串，不同字段以逗号分隔
getPrimaryFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的主键字段数组
getPrimaryKey() - 类 com.trs.was.WASResultSet 中的方法
获得当前检索结果集的主键
getPrimaryKeyPair() - 类 com.trs.was.WASResultSet 中的方法
获得当前检索记录的主键名值对
getPrimaryKeyValue() - 类 com.trs.was.config.SearchData 中的方法
获取主键值
getPrintTemplate() - 类 com.trs.was.config.ChannelNode 中的方法
获得打印模板
getProperties(String) - 类 com.trs.was.config.AppConfig 中的静态方法
获取系统配置值
getProperty() - 类 com.trs.was.config.AppConfig 中的方法
获取系统配置属性
getQuickSelectOpt() - 类 com.trs.was.config.ChannelNode 中的方法
获取估算检索设置参数
getReadTimeFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的阅读次数字段字符串
getReadTimeFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的阅读次数字段数组
getRecordCount() - 类 com.trs.was.WASResultSet 中的方法
获取命中记录数
getReduplicateString() - 类 com.trs.was.config.ChannelNode 中的方法
获取保存去重属性的字符串
getRelationFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的相关阅读字段字符串
getRelationFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的相关阅读字段数组
getRelevance() - 类 com.trs.was.WASResultSet 中的方法
获取当前记录的相关度
getReloadTime() - 类 com.trs.was.config.AppConfig 中的方法
获得重新加载时间
getResultNum() - 类 com.trs.was.config.SearchData 中的方法
获取结果记录总数
getRetryURL() - 异常 com.trs.was.config.WASException 中的方法
获取出错后选择重试时去往的页面
getRoleID() - 类 com.trs.was.config.WASRole 中的方法
获取角色ID
getRoleName() - 类 com.trs.was.config.WASRole 中的方法
获取角色名称
getRootNode() - 类 com.trs.was.tree.Tree 中的方法
获取根节点对象
getSearchDataFromRequest(HttpServletRequest) - 类 com.trs.was.WASTools 中的静态方法
从请求中获取检索条件对象.
getSearchFormFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的检索表单字段字符串，不同字段以逗号分隔
getSearchFormFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的检索表单字段数组
getSearchOpt() - 类 com.trs.was.config.ChannelNode 中的方法
获取保存检索选项的字符串
getSearchOption() - 类 com.trs.was.config.SearchData 中的方法
获取检索选项
getSearchTime() - 类 com.trs.was.WASResultSet 中的方法
获取检索耗时
getSearchWord() - 类 com.trs.was.config.SearchData 中的方法
获取检索表达式
getSearchWord() - 类 com.trs.was.WASResultSet 中的方法
获取检索条件表达式
getSecondSearch() - 类 com.trs.was.config.SearchData 中的方法
获取是否二次检索
getSeq(int) - 类 com.trs.was.config.FieldData 中的方法
根据字段特殊类型获取字段序号
getServerVersion() - 类 com.trs.was.config.DataSource 中的方法
获取数据源TRS服务器版本号
getSize() - 类 com.trs.was.tree.MapTree 中的方法
获取集合中树的个数。
getSMTPServer() - 类 com.trs.was.config.ConfigData 中的方法
获得邮件服务器名称
getSonID() - 类 com.trs.was.tree.Node 中的方法
获取第一个子节点ID
getSonNode() - 类 com.trs.was.tree.Node 中的方法
获取第一个子节点对象
getSonOrder(int, int) - 类 com.trs.was.tree.Tree 中的方法
获取某子节点是其父节点下的第几个子节点。
getSortField() - 类 com.trs.was.config.SearchData 中的方法
获取排序方式表达式
getSourceFileFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的源文件字段字符串，不同字段以逗号分隔
getSourceFileFieldStringArray() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的源文件字段数组
getSources() - 类 com.trs.was.config.ChannelNode 中的方法
获得检索的TRS数据库/视图
getSources() - 类 com.trs.was.WASResultSet 中的方法
获取检索对象列表
getSQL() - 类 com.trs.was.config.ChannelNode 中的方法
获得频道的检索表达式
getSRecords() - 类 com.trs.was.config.SearchData 中的方法
获取当前记录号数组
getStatFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的分类统计字段字符串
getStatFieldStringArrary() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的分类统计字段数组
getString(String) - 类 com.trs.was.WASResultSet 中的方法
获得指定字段的字段值内容
getString(String, String, int) - 类 com.trs.was.WASResultSet 中的方法
获取指定字段带命中点反显标记的内容
getStrParameter(HttpServletRequest, String, String) - 类 com.trs.was.config.RequestOperation 中的静态方法
获取请求中字符串型参数值
getStrRecords() - 类 com.trs.was.config.SearchData 中的方法
获得记录号
getStyleName() - 类 com.trs.was.config.ChannelNode 中的方法
获得显示风格名称
getSynonymDic() - 类 com.trs.was.config.ChannelNode 中的方法
获取用于频道检索的同义词典名称
getSysDriver() - 类 com.trs.was.config.AppConfig 中的方法
获得数据库驱动
getSysPasswd() - 类 com.trs.was.config.AppConfig 中的方法
获得数据库登录密码
getSysURL() - 类 com.trs.was.config.AppConfig 中的方法
获取系统URL
getSysUser() - 类 com.trs.was.config.AppConfig 中的方法
获得数据库登录用户
getTempletCombo() - 类 com.trs.was.config.ChannelNode 中的方法
获取模板组合
getTempletFile() - 类 com.trs.was.config.SearchData 中的方法
获取模板文件
getTempletFilePath() - 类 com.trs.was.config.AppConfig 中的方法
获取模板文件保存路径
getTempPath() - 类 com.trs.was.config.AppConfig 中的方法
获取模板保存路径
getThesaurusDic() - 类 com.trs.was.config.ChannelNode 中的方法
获取用于频道检索的主题词典名称
getTimeLine(WASResultSet, int, String, int, int, String, int) - 类 com.trs.was.WASTools 中的静态方法
获取时间轴
getTimeLineExpr() - 类 com.trs.was.config.SearchData 中的方法
获取用于显示时间轴的检索表达式
getTimeLineFieldString() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的时间轴字段字符串
getTimeLineFieldStringArrary() - 类 com.trs.was.config.ChannelNode 中的方法
获取频道的时间轴字段数组
getToken() - 类 com.trs.was.config.SearchData 中的方法
获取预览校验
getTree(String) - 类 com.trs.was.tree.MapTree 中的方法
在集合中获取指定名称的树对象。
getTreeName() - 类 com.trs.was.config.ChannelNode 中的方法
获得所属频道树名称
getTreeName() - 类 com.trs.was.tree.Node 中的方法
获取节点的树名称
getTreeName() - 类 com.trs.was.tree.Tree 中的方法
获取树名称
getTreeNames() - 类 com.trs.was.tree.MapTree 中的方法
获取集合中所有树的名称。
getTrees() - 类 com.trs.was.tree.MapTree 中的方法
从集合中获取所有的树对象。
getTreeSize() - 类 com.trs.was.tree.Tree 中的方法
获取返回该树的节点数。
getTRSConnection() - 类 com.trs.was.WASResultSet 中的方法
获取TRS连接对象.
getTRSFlag() - 类 com.trs.was.config.AppConfig 中的方法
获得TRS标识
getTrsIP() - 类 com.trs.was.config.DataSource 中的方法
获得TRS服务器IP
getTrsPassword() - 类 com.trs.was.config.DataSource 中的方法
获得TRS用户密码
getTrsPort() - 类 com.trs.was.config.DataSource 中的方法
获得TRS服务器端口
getTRSReConnection(String) - 类 com.trs.was.WASResultSet 中的方法
利用系统许可证获取TRS连接.
getTrsRS() - 类 com.trs.was.WASResultSet 中的方法
获取TRSResultSet对象
getTrsUserName() - 类 com.trs.was.config.DataSource 中的方法
获得TRS用户帐号
getURL(HttpServletRequest, SearchData, LoginConfig, String) - 类 com.trs.was.WASTools 中的静态方法
组合请求中的参数返回
getUserGroup() - 类 com.trs.was.config.WASUser 中的方法
获取所属用户组
getUserId() - 类 com.trs.was.config.WASUser 中的方法
获取用户Id
getUserMap() - 类 com.trs.was.config.ConfigData 中的方法
获取用户集合
getUserName() - 类 com.trs.was.config.LoginConfig 中的方法
返回当前用户名，用于兼容was4
getUserName() - 类 com.trs.was.config.WASUser 中的方法
获取用户名称
getUserRole() - 类 com.trs.was.config.WASUser 中的方法
获取用户角色名称
getUserType() - 类 com.trs.was.config.WASUser 中的方法
获取用户类型
getWASResultSet(HttpServletRequest, AppConfig, ConfigData, LoginConfig, SearchData, String) - 类 com.trs.was.WASTools 中的静态方法
获取WAS结果集对象
getWasUser() - 类 com.trs.was.config.LoginConfig 中的方法
获得当前登录用户
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


H - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

H

hasAutoExtend(String) - 类 com.trs.was.config.ChannelNode 中的方法
频道自动扩展选项中是否含有指定的配置项
hasExtendOpt(String) - 类 com.trs.was.config.ChannelNode 中的方法
频道扩展检索选项中是否含有指定的配置项
hasHitType(String) - 类 com.trs.was.config.ChannelNode 中的方法
频道命中点类型中是否含有指定的类型
hasSearchOpt(String) - 类 com.trs.was.config.ChannelNode 中的方法
频道检索选项中是否含有指定的配置项
haveChildrens(int) - 类 com.trs.was.tree.Tree 中的方法
判断节点是否包含子节点。
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


I - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

I

inherit(ChannelNode) - 类 com.trs.was.config.ChannelNode 中的方法
继承父节点的属性
insertNode(int, Node, int) - 类 com.trs.was.tree.Tree 中的方法
在树指定位置插入节点
insertNode(int, int, Node) - 类 com.trs.was.tree.Tree 中的方法
在树指定位置插入节点
isAnonymous() - 类 com.trs.was.config.ConfigData 中的方法
获得是否允许匿名登录
isCluster() - 类 com.trs.was.config.DataSource 中的方法
判断数据源是否是集群
isCrypted() - 类 com.trs.was.config.AppConfig 中的方法
配置文件中系统数据库密码是否加密处理
isEnable() - 类 com.trs.was.config.WASUser 中的方法
用户是否启用
isIgnoreTimeLine() - 类 com.trs.was.config.SearchData 中的方法
是否忽略时间轴表达式
isQuickSelect() - 类 com.trs.was.config.ChannelNode 中的方法
是否进行估算检索
isQuickSelect() - 类 com.trs.was.config.SearchData 中的方法
是否使用快速返回
isRelationSearch() - 类 com.trs.was.config.SearchData 中的方法
获取是否使用相关文章检索
isSpecialType(int) - 类 com.trs.was.config.FieldData 中的方法
判断该字段是否包含指定的特殊类型
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


L - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

L

loadLoginConfig(HttpSession, ConfigData) - 类 com.trs.was.WASTools 中的静态方法
获取登录对象
login(Connection, String, String) - 类 com.trs.was.config.LoginConfig 中的方法
登录操作
LoginConfig - com.trs.was.config 中的 类
用户登录配置信息类。
LoginConfig() - 类 com.trs.was.config.LoginConfig 的构造函数
默认构造方法，初始化各成员变量
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


M - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

M

MapChannel - com.trs.was.config 中的 类
频道树对象集合类。
MapChannel() - 类 com.trs.was.config.MapChannel 的构造函数
默认构造方法，无实现
MapChannel(Hashtable) - 类 com.trs.was.config.MapChannel 的构造函数
构造方法
MapDataSource - com.trs.was.config 中的 类
数据源对象集合类。
MapDataSource() - 类 com.trs.was.config.MapDataSource 的构造函数
默认构造方法，初始化各成员变量。
MapFieldData - com.trs.was.config 中的 类
存储频道相应的数据库字段对象的集合类
MapFieldData() - 类 com.trs.was.config.MapFieldData 的构造函数
默认构造方法，初始化成员变量
MapGroup - com.trs.was.config 中的 类
用户组树对象集合类。
MapGroup() - 类 com.trs.was.config.MapGroup 的构造函数
默认构造方法，无实现
MapGroup(Hashtable) - 类 com.trs.was.config.MapGroup 的构造函数
构造方法
MapTree - com.trs.was.tree 中的 类
树对象集合类，用于存储多棵树对象。
MapTree() - 类 com.trs.was.tree.MapTree 的构造函数
构造方法
MapTree(Hashtable) - 类 com.trs.was.tree.MapTree 的构造函数
构造方法
moveNodes(int, int, int) - 类 com.trs.was.tree.Tree 中的方法
移动节点到指定位置。
moveTo(int, long) - 类 com.trs.was.WASResultSet 中的方法
移动到检索结果记录集的指定记录
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


N - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

N

Node - com.trs.was.tree 中的 类
节点基类对象
Node() - 类 com.trs.was.tree.Node 的构造函数
构造方法
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


R - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

R

removeAllFields() - 类 com.trs.was.config.ChannelNode 中的方法
从频道的字段集合中删除所有字段对象
removeAllFields() - 类 com.trs.was.config.MapFieldData 中的方法
删除频道字段集合中的所有字段对象
removeDataSource(String) - 类 com.trs.was.config.MapDataSource 中的方法
从数据源对象集合中删除指定strDataSourceId对应的数据源
removeField(String) - 类 com.trs.was.config.MapFieldData 中的方法
从频道字段集合中删除指定名称的字段对象
removeSpecialType(int) - 类 com.trs.was.config.FieldData 中的方法
为该字段移除指定的特殊类型
removeTree(String) - 类 com.trs.was.tree.MapTree 中的方法
从集合中移除指定的树
RequestOperation - com.trs.was.config 中的 类
请求参数处理类,用于对HTTP请求参数进行相应的编码处理.
RequestOperation() - 类 com.trs.was.config.RequestOperation 的构造函数
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


S - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

S

SearchData - com.trs.was.config 中的 类
用于储存标准检索请求参数。
SearchData() - 类 com.trs.was.config.SearchData 的构造函数
setAbortURL(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错后选择放弃时去往的页面
setAdvSearchTemplate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置高级搜索模板
setAllSources(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置数据库/视图名称
setAnonyAccount(String) - 类 com.trs.was.config.ConfigData 中的方法
设置匿名帐号
setAnonyGroup(String) - 类 com.trs.was.config.ConfigData 中的方法
设置匿名用户所在组织
setAnonyRole(String) - 类 com.trs.was.config.ConfigData 中的方法
设置匿名用户所在角色
setAntonymDic(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置用于频道检索的反义词典名称
setAutoExtend(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置自动扩展选项
setBack(String) - 类 com.trs.was.config.SearchData 中的方法
设置回退操作的步数
setBindFormID(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置绑定表单ID
setCfgHash(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置系统配置信息集合
setChannelID(String) - 类 com.trs.was.config.SearchData 中的方法
设置频道ID号
setChannelID(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错的频道ID号
setChannelID(String) - 类 com.trs.was.WASResultSet 中的方法
设置频道ID
setChannelName(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道名称
setChannelSQL(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道条件
setCheckType(int) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道控制类型
setClassColumn(String) - 类 com.trs.was.config.SearchData 中的方法
设置分类统计字段名称
setClassRoot(String) - 类 com.trs.was.config.SearchData 中的方法
设置分类书根节点
setClassSQL(String) - 类 com.trs.was.config.SearchData 中的方法
设置分类统计条件表达式
setColumnType(String) - 类 com.trs.was.config.FieldData 中的方法
设置字段类型
setComment(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道的说明信息
setComment(String) - 类 com.trs.was.config.WASGroup 中的方法
设置用户组说明
setComment(String) - 类 com.trs.was.config.WASRole 中的方法
设置角色说明信息
setComment(String) - 类 com.trs.was.config.WASUser 中的方法
设置用户说明
setConnPool(ConnectionPool) - 类 com.trs.was.config.ConfigData 中的方法
设置数据库连接池对象
setCreateDate(Date) - 类 com.trs.was.config.WASGroup 中的方法
设置用户组创建时间
setCreateDate(Date) - 类 com.trs.was.config.WASRole 中的方法
设置角色创建日期
setCreateDate(Date) - 类 com.trs.was.config.WASUser 中的方法
设置用户创建时间
setCreateTime(Date) - 类 com.trs.was.config.ChannelNode 中的方法
设置创建日期
setCurrentUserType(int) - 类 com.trs.was.config.DataSource 中的方法
设置当前用户权限级别
setCustomExpr(String) - 类 com.trs.was.config.SearchData 中的方法
设置自定义表达式
setCutSize(int, boolean) - 类 com.trs.was.WASResultSet 中的方法
设置取字段时的截断长度。
setDataSource(DataSource) - 类 com.trs.was.config.MapDataSource 中的方法
向数据源对象集合中写入指定strDataSourceId对应的数据源
setDataSourceId(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置数据源Id
setDataSourceId(String) - 类 com.trs.was.config.DataSource 中的方法
设置数据源id
setDataSourceName(String) - 类 com.trs.was.config.DataSource 中的方法
设置数据源名称
setDefaultAdvSearch(String) - 类 com.trs.was.config.ConfigData 中的方法
设置默认高级搜索模板
setDefaultDetail(String) - 类 com.trs.was.config.ConfigData 中的方法
设置默认细览模板
setDefaultOutline(String) - 类 com.trs.was.config.ConfigData 中的方法
设置默认概览模板
setDefaultSearchColumn(String) - 类 com.trs.was.config.SearchData 中的方法
设置缺省检索字段
setDetailTemplate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置细览模板
setEnable(boolean) - 类 com.trs.was.config.WASUser 中的方法
设置用户是否启用
setError(String) - 异常 com.trs.was.config.WASException 中的方法
设置错误说明
setErrorDetail(String) - 异常 com.trs.was.config.WASException 中的方法
设置详细的出错信息
setErrorFrom(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错处
setErrorNumber(int) - 异常 com.trs.was.config.WASException 中的方法
设置错误号
setErrorServlet(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错时的Servlet或JSP位置，便于记录日志
setErrorURL(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错时所在页面，用于未登录等操作回到原来的页面
setEstimateStops(long) - 类 com.trs.was.config.SearchData 中的方法
设置至少返回的记录数（用于快速返回）
setEstimateUnit(long) - 类 com.trs.was.config.SearchData 中的方法
设置每个逻辑段包含的记录数（用于快速检索）
setExpTempMap(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置表达式模板集合
setExtendOpt(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置扩展检索选项
setExtendOpt(String) - 类 com.trs.was.config.SearchData 中的方法
设置扩展检索选项
setExtension(String) - 类 com.trs.was.config.SearchData 中的方法
设置扩展检索方式
setExtraCfg(Hashtable) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道其它配置
setExtraString(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道其它配置
setField(FieldData) - 类 com.trs.was.config.ChannelNode 中的方法
在频道的字段集合中添加字段对象
setField(FieldData) - 类 com.trs.was.config.MapFieldData 中的方法
添加字段对象到频道的字段集合中
setFieldDisName(String) - 类 com.trs.was.config.FieldData 中的方法
设置字段显示名
setFieldName(String) - 类 com.trs.was.config.FieldData 中的方法
设置字段名
setFieldsByArray(FieldData[]) - 类 com.trs.was.config.ChannelNode 中的方法
添加字段对象数组到频道的字段集合中
setFieldsByArray(FieldData[]) - 类 com.trs.was.config.MapFieldData 中的方法
添加字段对象数组到频道的字段集合中
setFieldsByString(String) - 类 com.trs.was.config.ChannelNode 中的方法
从字符串中解析出DataField信息并写入到m_mapFieldData中
setFieldsByString(String) - 类 com.trs.was.config.MapFieldData 中的方法
从字符串中解析出DataField信息并写入到m_mapFields
setFieldSeq(String) - 类 com.trs.was.config.FieldData 中的方法
解析字段序号字符串
setFieldSpecialType(int) - 类 com.trs.was.config.FieldData 中的方法
设置字段特殊类型
setFieldType(int) - 类 com.trs.was.config.FieldData 中的方法
设置字段类型
setFilterMap(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置过滤词集合
setFormMap(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置表单集合
setFullVersion(String) - 类 com.trs.was.config.DataSource 中的方法
设置数据源TRS服务器完整的版本号
setGrantRight(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置存放WAS4升级的权限数据
setHitNum(long) - 类 com.trs.was.WASResultSet 中的方法
设置命中点个数
setHitType(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置命中点类型
setHitType(String) - 类 com.trs.was.config.SearchData 中的方法
设置命中点类型
setHotWord(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置热搜词集合
setID(int) - 类 com.trs.was.tree.Node 中的方法
设置节点ID
setIgnoreTimeLine(boolean) - 类 com.trs.was.config.SearchData 中的方法
设置是否忽略时间轴表达式
setIndexTemplet(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置主页模板
setIpFilterMap(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置IP限制集合
setIRecords(int[]) - 类 com.trs.was.config.SearchData 中的方法
设置当前记录号数组
setIsCluster(boolean) - 类 com.trs.was.config.DataSource 中的方法
设置数据源是否是集群
setKeyWord(String) - 类 com.trs.was.config.SearchData 中的方法
设置关键词，即检索框内的检索词
setLastChangeTime(Date) - 类 com.trs.was.config.ChannelNode 中的方法
设置最后一次修改日期
setLevel(int) - 类 com.trs.was.tree.Node 中的方法
设置节点层次
setLicenseCode(String) - 类 com.trs.was.config.SearchData 中的方法
设置系统许可证
setLicenseCode(String) - 类 com.trs.was.WASResultSet 中的方法
设置连接许可证
setLogLevel(int) - 类 com.trs.was.config.ConfigData 中的方法
设置系统日志级别
setMailAccount(String) - 类 com.trs.was.config.ConfigData 中的方法
设置邮件服务器帐号
setMailAddress(String) - 类 com.trs.was.config.ConfigData 中的方法
设置发送邮件地址
setMailPwd(String) - 类 com.trs.was.config.ConfigData 中的方法
设置邮件服务器密码
setMailTemplate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置邮件推荐模板
setMapChannel(MapChannel) - 类 com.trs.was.config.ConfigData 中的方法
设置频道树集合
setMapDataSource(MapDataSource) - 类 com.trs.was.config.ConfigData 中的方法
设置数据源集合
setMapFieldData(MapFieldData) - 类 com.trs.was.config.ChannelNode 中的方法
设置数据库字段集合
setMapGroup(MapGroup) - 类 com.trs.was.config.ConfigData 中的方法
设置用户组集合
setName(String) - 类 com.trs.was.config.WASGroup 中的方法
设置用户组名称
setNeedReload(boolean) - 类 com.trs.was.config.ConfigData 中的方法
设置是否需要重新加载
setNextID(int) - 类 com.trs.was.tree.Node 中的方法
设置下一个兄弟节点ID
setNextNode(Node) - 类 com.trs.was.tree.Node 中的方法
设置下一个兄弟节点对象
setOrderBy(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道的排序方式
setOrderBy(String) - 类 com.trs.was.config.SearchData 中的方法
设置排序方式
setOutlinePage(int) - 类 com.trs.was.config.SearchData 中的方法
设置概览导航显示页码数
setOutlineTemplate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置概览模板
setPage(String) - 类 com.trs.was.config.SearchData 中的方法
设置当前页面号
setParentID(int) - 类 com.trs.was.tree.Node 中的方法
设置父节点ID
setParentNode(Node) - 类 com.trs.was.tree.Node 中的方法
设置父节点对象
setPassword(String) - 类 com.trs.was.config.WASUser 中的方法
设置用户密码
setPerpage(int) - 类 com.trs.was.config.SearchData 中的方法
设置每页记录数
setPreID(int) - 类 com.trs.was.tree.Node 中的方法
设置上一个兄弟节点ID
setPreNode(Node) - 类 com.trs.was.tree.Node 中的方法
设置上一个兄弟节点对象
setPreSearchWord(String) - 类 com.trs.was.config.SearchData 中的方法
设置上一次检索表达式
setPrimaryKeyValue(String) - 类 com.trs.was.config.SearchData 中的方法
设置主键值
setPrintTemplate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置打印模板
setQuickSelect(boolean) - 类 com.trs.was.config.SearchData 中的方法
设置是否使用快速返回
setReduplicate(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置去重属性
setRelationSearch(boolean) - 类 com.trs.was.config.SearchData 中的方法
设置是否使用相关文章检索
setResultNum(long) - 类 com.trs.was.config.SearchData 中的方法
设置结果记录总数
setRetryURL(String) - 异常 com.trs.was.config.WASException 中的方法
设置出错后选择重试时去往的页面
setRoleID(int) - 类 com.trs.was.config.WASRole 中的方法
设置角色ID
setRoleName(String) - 类 com.trs.was.config.WASRole 中的方法
设置角色名称
setSearchOpt(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置检索选项
setSearchOption(String) - 类 com.trs.was.config.SearchData 中的方法
设置检索选项
setSearchTime(double) - 类 com.trs.was.WASResultSet 中的方法
设置检索耗时
setSearchWord(String) - 类 com.trs.was.config.SearchData 中的方法
设置检索表达式
setSearchWord(String) - 类 com.trs.was.WASResultSet 中的方法
设置检索条件表达式
setSecondSearch(String) - 类 com.trs.was.config.SearchData 中的方法
设置是否二次检索
setSeq(int, int) - 类 com.trs.was.config.FieldData 中的方法
根据字段特殊类型设置字段序号
setSMTPServer(String) - 类 com.trs.was.config.ConfigData 中的方法
设置邮件服务器名称
setSonID(int) - 类 com.trs.was.tree.Node 中的方法
设置第一个子节点ID
setSonNode(Node) - 类 com.trs.was.tree.Node 中的方法
设置第一个子节点对象
setSortField(String) - 类 com.trs.was.config.SearchData 中的方法
设置排序方式表达式
setSources(String[]) - 类 com.trs.was.config.ChannelNode 中的方法
设置检索的TRS数据库/视图
setSources(String) - 类 com.trs.was.WASResultSet 中的方法
设置检索对象列表
setSQL(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置频道的检索表达式
setSRecords(String[]) - 类 com.trs.was.config.SearchData 中的方法
设置当前记录号数组
setStyleName(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置显示风格名称
setSynonymDic(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置用于频道检索的同义词典名称
setTempletCombo(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置模板组合
setTempletFile(String) - 类 com.trs.was.config.SearchData 中的方法
设置模板文件
setThesaurusDic(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置用于频道检索的主题词典名称
setTimeLineExpr(String) - 类 com.trs.was.config.SearchData 中的方法
设置用于显示时间轴的检索表达式
setToken(String) - 类 com.trs.was.config.SearchData 中的方法
设置预览校验
setTree(Tree) - 类 com.trs.was.tree.MapTree 中的方法
将树对象添加到哈希表中。
setTreeName(String) - 类 com.trs.was.config.ChannelNode 中的方法
设置所属频道树名称
setTreeName(String) - 类 com.trs.was.tree.Node 中的方法
设置节点的树名称
setTrsIP(String) - 类 com.trs.was.config.DataSource 中的方法
设置TRS服务器IP
setTrsPassword(String) - 类 com.trs.was.config.DataSource 中的方法
设置TRS用户密码
setTrsPort(String) - 类 com.trs.was.config.DataSource 中的方法
设置TRS服务器端口
setTrsUserName(String) - 类 com.trs.was.config.DataSource 中的方法
设置TRS用户帐号
setUserGroup(String) - 类 com.trs.was.config.WASUser 中的方法
设置所属用户组
setUserId(String) - 类 com.trs.was.config.WASUser 中的方法
设置用户Id
setUserMap(Hashtable) - 类 com.trs.was.config.ConfigData 中的方法
设置用户集合
setUserName(String) - 类 com.trs.was.config.WASUser 中的方法
设置用户名称
setUserRole(String) - 类 com.trs.was.config.WASUser 中的方法
设置用户角色名称
setUserType(int) - 类 com.trs.was.config.WASUser 中的方法
设置用户类型
setWasUser(WASUser) - 类 com.trs.was.config.LoginConfig 中的方法
设置当前登录用户
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


T - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

T

Tree - com.trs.was.tree 中的 类
树对象基类,可继承为频道或导航树,提供树结构的基本操作.
Tree() - 类 com.trs.was.tree.Tree 的构造函数
构造方法
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


V - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

V

valueBound(HttpSessionBindingEvent) - 类 com.trs.was.config.LoginConfig 中的方法
对象插入到SESSION时触发的操作
valueUnbound(HttpSessionBindingEvent) - 类 com.trs.was.config.LoginConfig 中的方法
对象从SESSION中删除时触发的操作
概述 软件包 类 使用 树 索引 帮助
A B C D F G H I L M N R S T V W


W - 索引

上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W

W

WASException - com.trs.was.config 中的 异常
系统异常类,用于处理异常信息
WASException() - 异常 com.trs.was.config.WASException 的构造函数
WASException(String) - 异常 com.trs.was.config.WASException 的构造函数
WASException(String, Exception) - 异常 com.trs.was.config.WASException 的构造函数
WASGroup - com.trs.was.config 中的 类
用户组信息类,用于存储用户组信息
WASGroup() - 类 com.trs.was.config.WASGroup 的构造函数
WASResultSet - com.trs.was 中的 类
WAS结果集对象
WASResultSet(AppConfig, ConfigData, LoginConfig, SearchData, String) - 类 com.trs.was.WASResultSet 的构造函数
WASRole - com.trs.was.config 中的 类
用户角色类
WASRole() - 类 com.trs.was.config.WASRole 的构造函数
WASTools - com.trs.was 中的 类
WAS工具类。
WASTools() - 类 com.trs.was.WASTools 的构造函数
WASUser - com.trs.was.config 中的 类
用户信息类,用于存储用户信息
WASUser() - 类 com.trs.was.config.WASUser 的构造函数
概述 软件包 类 使用 树 索引 帮助
上一个字母 下一个字母 框架 无框架
A B C D F G H I L M N R S T V W