团队介绍：

LR team 全称：Lenovo ROM team ，隶属于联想手机乐粉家，由熟悉制作安卓Rom的开发人员组成的非盈利性Rom团队，致力于为联想手机提供极致Rom体验，并长期服务联想手机乐粉家社区，为乐粉提供基于官方Rom或其他厂商的第三方Rom版本体验。

【LR.Team】刷机系列教程

教程作者：

wzsx150

团队名称：

LR.Team

教程时间：

2016年8月29日

简 介：

针对很多机友不懂刷机常识和刷机方法，LR团队特别制作了该系列教程，教程不可能面面俱到，只能以个别机型为例作为讲解，但大部分机型的刷机方法和思路基本是一致的，就算不能完全照搬，也可以借鉴。希望该系列教程可以给予广大机友一定的帮助。教程做的还比较简陋，望理解。请多关注和支持LR团队！

>>后续持续更新其它相关教程<<


刷机常识简单问答

根据自己刷机的经历，本人简单制作一个问答形式的刷机常识分享，方便各位机油进行刷机操作。可能都是文字显得比较枯涩，但绝对有用。具体手机还要看具体操作和情况，不能一概而论，但是可以视情况参考。

（1） 手机开机模式有哪几种？具体是怎么操作的？（各个手机不同，请参考自己手机的操作）

【正常开机】：关机状态下，长按电源键，震动松开按键。
【强制重启】：任何状态下，长按电源键，震动屏幕再次亮起松开按键。

【工程模式卡刷】：关机状态下，按住电源键+音量减键，出现Lenovo或zuk界面就松开电源键。

此界面是黑色屏幕几行白字，其中有一个是sd update。联想系手机一般都有这个模式。
【rec（恢复）模式】：关机状态下或任何状态下，按住电源键+音量加键+音量减键，直至进入松开按键。
【bootloader（fastboot线刷）模式】：关机状态下，按住音量加键+音量减键，同时usb线连接电脑，直至进入松开按键。此模式，手机界面为Lenovo的logo不动的界面。
【高通QPST（9008端口）线刷模式】：关机状态下，若是5.1的系统：按住音量加键，同时usb线连接电脑。若是6.0系统：按住音量加键，在usb线连接电脑的同时，按一下电源键。此模式手机是黑屏状态。
【高通QPST（9006端口）模式】：当手机无法正常进入系统时，手机自动进入9006端口模式，特征就是电脑上弹出好多需要格式化的分区，设备管理器显示9006端口。此时手机黑屏亮蓝灯。

（2）adb是什么？怎么使用adb命令进入手机的各种模式？怎么在fastboot模式下进入手机的各种模式？
adb是电脑端可以对安卓手机进行连接和指令操作。
使用时必须需要：

1.电脑端有adb程序。

2.手机端开启开发者模式中的调试模式。

3.电脑上正确安装手机驱动程序。

4.手机授权电脑的调试。
adb可以通过一些指令操作手机，一般可以用来传输文件，或者重启手机进入各种模式。例如：（部分指令可能无效）

adb reboot 重启手机进入系统
adb reboot edl 重启手机进入9008线刷模式（可以进行高通线刷）
adb reboot recovery 重启手机进入recovery模式
adb reboot testmode 重启至工程模式（可以进行官方QSB卡刷）
adb reboot bootloader 重启手机进入fastboot模式

当手机处在fastboot模式时，可以通过fastboot命令进入其他模式，方便刷机：（部分指令可能无效或需要解锁）

fastboot reboot 重启手机进入系统
fastboot oem reboot-edl 重启至9008线刷模式（可以进行高通线刷）
fastboot oem reboot-testmode 重启至工程模式（可以进行官方卡刷）
fastboot reboot-bootloader 重启进入fastboot模式
fastboot oem reboot-recovery 重启进入recovery模式

（3）手机关机的几种方法和思路？
手机卡死或者手机刷机失败，无法进入系统，也无法关机，因为我们刷机进入各种模式都需要在在关机状态为基础才可以继续操作的。
这种情况下，我们可以等手机电池没电自动关机，也可以使用一下几种思路。（手机黑屏不代表手机就是关机（英文：power off）了）

1. 正常系统状态，长按电源>关机按钮。

2.手动长按电源键，当手机黑屏时，松开电源键；如果手机一直反复闪屏，那就多按一会，直到黑屏松开按键时，屏幕依旧黑屏，就可以了。

3.先进入recovery模式，选择关机选项。

4.手动拆机断掉电池（一般不推荐这样做）。

（4）什么是解锁？解锁后能干什么？有什么影响？如何上锁？（以联想解锁为例）
Bootloader从字面上来看就是启动加载的意思。用过电脑的都知道，windows开机时会首先加载bios，然后是系统内核，最后启动完毕。那么bootloader就相当于手机的bios，它在手机启动的时候根据基带初始化硬件，然后引导系统内核，直到系统启动。

因为厂商为了能保证手机系统不被刷入第三方的系统，防止用户随意刷入ROM，进而把bootloader锁死。锁死后，用户只能刷本厂商的ROM，不能刷入第三方rec和ROM。

手机解锁就会解锁手机的bootloader。解锁后可以刷入第三方的rec和rom。
解锁后可能会给手机带来一些风险，例如刷机带来变砖等问题，还会失去保修等权益。
注意，很多手机没有真解锁，或者没有提供解锁，所以还要根据自己手机去看。

解锁的方法和教程论坛上有，主要两种：
1.fastboot模式下输入命令：
fastboot oem unlock-go
注意：该命令解锁会将手机内数据全清空。
2.使用高通QPST线刷解锁的bootloader，参看论坛工具和教程。该方法的好处是不会清空手机内数据。但需要对应版本的bootloader
重新上锁的两种方法：
1. 解锁以后如果您希望重新锁定Bootloader，可以重启手机到fastboot模式，并输入如下命令
fastboot oem lock
此时手机状态会重新上锁。注意：该命令解锁会将手机内数据全清空。
2.使用高通QPST线刷上锁的bootloader，参看论坛工具和教程。该方法的好处是不会清空手机内数据。但需要对应版本的bootloader

（5）怎么降级？有哪些方法？
目前来说，降级的方法主要有这三种：

1. 工程模式卡刷低版本QSB卡刷包
这种刷机方式一般不会清除用户数据。因为不清除数据，所以可能会因为保留的数据和低版本系统产生不兼容，从而出现一些莫名其妙的问题和bug，比如卡开机画面。建议降级前，恢复出厂设置或者双清。
2.高通QPST刷低版本的线刷包
这种刷机方式会清空用户所有数据，将手机恢复到出厂状态，这种方式不受升降级的限制。线刷风险大，不会操作或者操作错误可能会变砖，请知晓！
3.第三方rec卡刷官方系统的zip完整系统卡刷包（zip官方包或者官改包）
这种刷入方式比较灵活，一般不会清除手机内的数据（尤其是手机内置存储）。我们可以选择在刷入降级包之前进行双清（三清）来消除可能会有保留的高版本数据带来的不兼容性。

（6）手机ROM是什么？刷ROM是什么含义？
手机ROM实际上就是手机内的系统的镜像文件，刷写ROM就是通过将这些镜像文件写入手机内存，使手机运行我们想要的系统。

（7）手机OTA升级是什么意思？
OTA升级，就是空中升级，也就是在手机系统里，直接通过联网，下载相应升级包，然后自动刷入升级包。

（8）手机里有多少分区？都有什么用处？
安卓手机有很多分区，十几个二十几个，甚至三十几个。手机内部有几十个分区，除了几个底层分区外，大家能感觉到的也就是system分区和userdata分区。这两个分区，system分区是存放系统文件和程序的分区；userdata分区是存放用户文件和用户APP的分区。
还有其他分区比如recovery分区，用于系统恢复升级刷系统；boot分区用于启动系统；aboot分区用于引导手机启动；modem分区是存放基带文件的分区等等。

（9）手机root是什么？怎么样才能root？
安卓手机root实际上就是取得手机操作系统的用户最高权限，一般root需要取得权限、安装su文件、安装权限管理APP。这样用户使用时，需要root权限的软件会向用户申请root权限，你可以选择是否给予软件root权限。
root的方法因手机而异，有的手机系统自带root权限，有的需要破解工具root，有的通过刷入root刷机包就可以root等等。
现在一般是刷入supersu的卡刷包进行root手机。

（10）手机root后能做什么？
手机root后能做的事情有很多，最直接的就是用户可以查看系统目录下的各种文件，同时可以对其进行删改，例如可以删除系统内置的app，可以卸载内置软件；修改键值表，达到修改按键功能的效果；替换系统文件达到改变系统样式界面的效果，如替换系统字体；开启或者关闭安卓系统的一些功能。还可以安装高权限软件进行一些特殊操作，例如安全软件进行联网控制，进行广告屏蔽；安装可以刷写手机的APP，直接在手机系统下刷写手机的boot和recovery等。当然能做的事很多，就看大家能怎么去利用。

（11）bootloader是什么？有什么用？
bootloader是手机的引导文件，或者引导模式，也可以说是fastboot模式，个人说法不是很准确和严谨。手机开机时，bootloader引导系统进入开机的流程，进而手机开机进入系统。bootloader可以进入fastboot模式。
如果bootloader分区出现损坏，会导致手机成黑砖。只有通过线刷才能救砖，否则就要售后换主板。

（12）boot分区是什么？有什么用？
boot分区是安卓手机的内核和系统启动文件存放的分区。boot分区是系统启动时加载进内存的，比如内核的一些文件数据、驱动程序之类的，包括系统的初始化等等。是bootloader引导到boot，然后boot在到系统文件，然后手机才能进入系统。刷机时，对应的镜像文件一般为boot.img。

（13）system分区是什么？有什么用？
system分区是安卓手机存放系统文件的分区，包括系统底层文件和系统app，包括进入系统动画、系统组件、系统设置文件等等，可以理解为Windows系统的C盘，但是有所不同的是，一般如果没有root权限，用户是不能随意修改删除system分区内文件的。也不建议随意修改删除system分区内的文件以免造成系统崩溃，开不了机。我们平时所说的安卓系统主要就在这个分区，同时我们说的刷机刷不同的系统，主要就是指刷写这个分区的文件。

（14）userdata分区是什么？有什么用？
userdata分区是安卓手机存放用户数据的分区，包括用户安装的app以及用户的配置信息，还有用户的内置存储也在这个分区。

（15）卡刷是什么意思？有哪几种？
卡刷顾名思义，就是将内存卡中的ROM文件刷入手机，或者将手机内置储存中的ROM文件刷入手机。因为早期的安卓手机没有内置储存，一般必须要插入sd卡用来扩展存储。刷机包，一般放在内存卡里，于是乎就沿袭下来，一直叫卡刷，但是实际上现在很多手机都有内置储存，所以不一定是sd卡。
对于联想系手机而言主要有卡刷主要两种：一是【rec模式】下刷入zip格式的刷机包，二是【工程模式】下刷入qsb格式的刷机包。

（16）卡刷包是什么？包括什么？
卡刷包就是存放ROM数据的刷机包，可以通过卡刷的方式，将ROM刷入手机。卡刷包一般包括手机系统里的基本文件，有boot.img、system分区的文件、还有其他分区文件、手机底层文件以及刷机脚本等。完整卡刷包一般有完整system分区系统文件；如果是升级包，一般不包含完整的系统文件，只是系统的一部分。

（17）rec是什么？如何rec卡刷？
rec是recovery的简称，安卓手机一般都有recovery分区，当手机出现问题是，可以使用rec模式进行对系统的升级备份修改以及其他高级操作等。
rec卡刷的步骤：
1.将卡刷包放入手机存储里（如果是三方rec，也可以进入rec后再拷入手机存储也行）。
2.手机进入rec模式（开机键+音量加键+音量减键），可以看到rec的选项。
3.选择刷写ROM，选择手机刷机包，然后点刷入，等刷写完毕。
4.重启进入系统即可。一般在刷入系统之前都要进行双清。

（18）rec卡刷什么是“双清”“三清”？为什么要清除？
双清（wipe翻译过来就是擦除清除）就是在rec模式下，清空userdata分区（不包括内置内存卡里的内容）并恢复出厂设置，清空cache分区。
三清就是在双清的基础上，清空Dalvik虚拟机缓存。
因为不同系统之间产生的用户配置文件、系统环境文件、系统所需文件、软件缓存、系统缓存等等是不同的，是不兼容的。如果不进行清除，则有可能造成系统卡开机画面进不了系统，或者系统报错，软件报错闪退等问题。
所以在刷写不同系统的ROM时或者进行系统版本降级时，一般必须进行双清（三清）操作。

（19）工程模式是什么？如何qsb卡刷？
对于运行官方系统的联想系手机，在关机状态下，按住电源键+音量下键，手机会进入工程模式。在工程模式下，可以对手机进行一些操作，比如刷机、备份还原、恢复出厂设置、手机功能检测等等。
工程模式下可以将qsb格式卡刷包刷入手机的步骤：
1.在手机内部存储根目录新建sdfuse文件夹，把下载的卡刷包解压得到的qsb格式卡刷包复制到该文件夹。
2.关机，按住电源键+音量下键，进入工程模式。
3.选择sd update选项。
4.选择刚才的qsb文件，点击start。
5.刷机成功后，点restart重启进入系统。

（20）线刷是什么意思？有哪几种？
线刷的意思是连着usb数据线刷写手机ROM，一般ROM是存放在电脑端，通过电脑端的刷机程序或者指令，将ROM通过数据线，刷写入手机里。
对于联想系手机而言有两种：【fastboot模式刷入】和【高通QPST工具线刷】。

（21）线刷包是什么？包括什么？
线刷包就是存有ROM系统文件镜像的用于线刷的文件，一般是压缩或者镜像文件。线刷包一般包括手机系统里的基本文件，有boot.img、system分区的文件、还有其他分区文件、手机底层文件以及刷机脚本等。fastboot模式线刷和高通QPST工具线刷用的文件基本一致的，可以通用，除了system和userdata两个分区的镜像文件略用不同，一个是完整的一个img文件，一个是拆分成好多个img文件。

（22）fastboot模式是什么？如何fastboot线刷？
fastboot模式是安卓手机一种刷写系统的特殊模式。手机关机状态下，按住音量加键和减键，同时usb连接电脑，此时手机会进入fastboot模式，在电脑端利用fastboot工具包，利用bat格式的刷机脚本，打开bat文件就开始刷机了。
刷机的语句格式是 fastboot flash （分区名） （对应镜像文件）
一行写一条，例如：
fastboot flash modem NON-HLOS.bin
fastboot flash recovery recovery.img
以此类推。

重启手机语句是fastboot reboot
提示：fastboot模式必须是已解锁的状态下才能刷入镜像文件，如果有锁是没法刷入的。若没有真解锁，也是不行的。

（23）如何QPST工具线刷？
使用高通芯片的手机，一般都可以使用高通QPST工具进行一些操作，包括刷机、备份和还原等。
QPST线刷的工具和方法教程请在论坛查找。理论上只要手机bootloader没有损坏，都可以通过高通线刷救砖。
出现900E端口时，不要慌张，如果bootloader还可以进入fastboot模式或者rec模式，或者工程卡刷模式，那么手机就是有救的。
若出现9006或者9008端口，则使用9006或者9008的刷机方法刷写手机，即可。
对于完全地黑砖就是bootloader损坏，什么模式都进不去，手机关机也不能进入9006或9008，手机一直处在900E状态，那么基本就要送售后换主板了

（24）一键刷入rec工具是什么？怎么样刷入rec？
就是利用adb和fastboot两种手段，通过一定的指令操作手机，最终将rec刷入手机里。基本原理是：
1.手机开启调试模式，装好驱动。
2.连上adb，（有的手机需要root才能开启fastboot）重启到fastboot。
3.在fastboot模式下永久刷入rec，或者临时刷入rec。

（25）什么是内置存储和外置存储卡？有什么区别？
外置存储卡就是通常说的sd卡，通过将卡插入卡槽，可以拓展手机的存储量。
内置存储就是手机内部的焊接在手机主板上的储存芯片。
区别：外置sd卡可以拔插，可以换，可以拓展，而且一般手机恢复出厂设置时，不会清除sd卡内的数据。
内置存储不能换，不能扩展，而且如果刷机操作不当或者彻底恢复出厂设置时，是有可能清空内部数据的。内置存储是属于userdata分区下的数据。在rec刷机时，格式化userdata会导致内部存储数据也被清除

（26）RSD刷机是什么？有什么用？
RSD刷机工具是moto官方的线刷工具，他提供了专为moto手机刷机的一种独特方式，其主要原理还是利用手机的fastboot模式，进行刷写系统。
利用RSD可以进行简单的刷机，可以刷写底包，可以救砖和解决开不了机的情况。


lenovo手机解锁教程

理论上联想官方并没有放出来解锁的途径，但是通过广大民间人士的努力，很多机型基本都能解锁。本教程不提供具体工具和软件，只是提供思路。工具可以去论坛查找，或者使用刷机精灵等第三方软件的adb和fastboot工具箱也行。

请注意：联想机型很多是没有解锁功能的，或者说不是真解锁，有些刷机命令依旧无法使用。

针对联想，一般有两种方法：

（1）刷入解锁的bootloader文件

（2）通过fastboot命令解锁

方法一：刷入解锁bootloader文件

1.到社区论坛，搜索自己手机型号的解锁教程，下载他提供的解锁bootloader文件。

2.下载安装高通QPST软件（包含Qfile）

3.参照高通线刷及救砖教程刷入解锁的bootloader文件。

方法二：fastboot命令解锁

部分联想手机支持使用fastboot命令解锁。

1. 首先手机进入fastboot模式：可以在开机状态下，开启usb调试模式，使用adb命令，adb reboot bootloader 。手机会自动重启到fastboot模式；或者使用手动进入，关机，按住音量上下键，usb链接电脑，也可以进入fastboot模式。一般的此模式是定格在开机logo界面。

2. 其次，使用fastboot命令fastboot oem unlock-go 。手机解锁。若不支持该命令，则手机不支持fastboot命令解锁。解锁会清空手机内数据，请注意数据备份。

3. 在fastboot模式查看手机是否解锁命令是fastboot oem device-info 。然后看反馈的信息中有一行unlocked：XXX。如果XXX为true则为解锁状态，为false则为上锁状态。


moto手机解锁教程

首先得说明，解锁bootloader后，你就失去了保修资格。因此最好是已经过保的机器来玩，另外你得明白你解锁的目的是什么，是要玩第三方rom，root，还是想要加载原生谷歌服务框架套件？（加了也没用，在中国用不了，除非你一天到晚挂着VPN）
 解决了这些疑问后，你决定还是要开始root了，首先你得检查一下你的bootloader解锁了没有。怎样确定bootloader解锁了，只要你开机没有下图画面，就说明你的bootloader是未解锁的。解锁是通往刷机、root的关键步骤。

 既然号称史上最详细的教程，就是面向全小白用户。首先什么叫bootloader。
 小知识点：Bootloader从字面上来看就是启动加载的意思。用过电脑的都知道，windows开机时会首先加载bios，然后是系统内核，最后启动完毕。那么bootloader就相当于手机的bios，它在手机启动的时候根据基带初始化硬件，然后引导系统内核，直到系统启动。
假如没有解锁bootloader，我们就开始解锁教程，已经解锁的自动跳过这一步。
bootloader（简称BL）解锁详细教程
1.下载好moto的官方驱动

http://pan.baidu.com/s/1dkGay
2.打开开发者选项
打开手机，找到系统设置—关于手机（最底下）—版本号（最底下），点开”版本号“，等你回到系统设置主页面时候会发现多了一个开发者选项。

3.允许OEM解锁
点进开发者选项—OEM解锁（允许解锁引导加载程序）果断点亮这个选项。这样你才能解锁BL。
4.进入fastboot模式
手机关机，按住音量键下，然后按住电源键2~3秒，松开电源键，音量键下不松，此时机子进入开机选项，这个时候就是fastboot模式了。
5.下载电脑解锁工具（moto在电脑上的adb工具）

http://pan.baidu.com/s/1hqm1OYo
6.获取设备ID
将fastboot状态手机连接上电脑，打开解锁工具文件夹里的”命令提示符“输入以下命令（你可以复制黏贴）

fastboot oem get_unlock_data

命令输入后，你会得到一串字串符，你需要把图中红线圈中的字串符复制到一个文本文档中，并衔接起来，
例如：

7.获取解锁码
进入解锁码网站，>>>>申请个摩托账号 假如你已经有了账号，就略这步；
等你在申请邮箱中激活了你的账号，进可以进入获取解锁码的页面，>>>>点击进入；
别管前面说啥，直接跳到第六步，这里可以检查你的设别是否已经激活过了。假如未激活过，会在底下生成一个按钮，点了按钮，你的邮箱中就会获得解锁码。

8.在终端里敲入以下命令，完成解锁

adb reboot bootloader

fastboot oem unlock XXXXXXXXXX

00001.

XXXXXXXXX是你的解锁码

至此，BL解锁完成。


zuk手机解锁教程

以zuk z1手机为例，进行详细讲解，其他手机型号的具体步骤可能略有差异。

 官方在公布了解锁方案后，第一时间申请了解锁服务，但是折腾了一下始终没得到要领，也想部分机友说的那样会一直显示等待设备，左思右想才发现可能是官方给与的命令并不适用于我们这小小白机友，因为我们没有配置对应文件夹路径到系统环境变量里面，那么到底怎么办呢？
 如果有机友看过CM国际版的刷机教程的其实就知道该怎么处理了，那下面我还是详细说一下具体的解锁步骤吧。
解锁教程
1.手机下载ADB工具包，下载地址：http://bbs.zuk.cn/z1/t42598/，然后将其解压至你的某个盘里（以D盘为例）
2.在开发者平台申请解锁，就会收到官方自动发放的解锁必须img文件，下载，放在桌面备用

3.手机打开开发者模式并开启USB调试，并且将手机连接至电脑

4.同时按着电脑的win+R键，在弹出的对话框内输入cmd命令，回车

5.在弹出的对话框内依次输入以下命令，手机进入fastboot模式

D：

cd adb

adb reboot bootloader

6.此时会显示手机还是锁着（locked）的状态

7.继续输入命令fastboot -i 0x2b4c flash unlock unlock_bootloader.img（如果你的unlock文件是放在桌面上，可直接在输入fastboot -i 0x2b4c flash unlock后打个空格，然后直接拖动这个文件到对应命令后即可），点击回车，进行解锁。（z2系列机型，还要加一条命令fastboot oem unlock-go，然后按照手机上的提示开始解锁就可以了）

8.解锁状态手机会重启，然后你会看到一个进度条进度条结束后即表示解锁完成，手机重启，因为此操作会删除你所有的用户数据和非系统的app，所以开机会慢一点

9.开机后再次开启USB调试模式，然后输入命令adb reboot bootloader，就会发现手机已经解锁了。（z2系列手机解锁后，每次开机会多一屏提示，5秒后才自动进入系统）

注意事项：

• 一旦解锁，您的手机将不再适用于ZUK保修政策，不再享受免费维修和退换货服务。
• 解锁过程中您手机里的全部应用程序，数据和设置都将被删除或重置，请您提前做好系统备份。
• 解锁后您将无法使用系统更新（OTA）功能，无法升级到最新的ZUI系统。
• 安装第三方ROM可能导致您的手机无法正常工作，甚至损害硬件，如手机过热导致芯片损毁。
• 解锁过程是不可逆的，您的手机一旦被解锁就无法恢复到锁定的状态。


官方系统（OTA）升级教程

本教程适用于联想手机和zuk手机，其他手机根据自己手机的来操作。

下面是以ZUK Z1为例进行的详细讲解，其他手机通用，个别细节略有不同。

OTA
Over－The－Air Technology，即空中下载技术。是通过移动通信（GSM或CDMA）的空中接口对SIM卡数据及应用进行远程管理的技术。空中接口可以采用WAP、GPRS、CDMA1X及短消息技术。OTA技术的应用，使得移动通信不仅可以提供语音和数据服务，而且还能提供新业务下载。
升级方法
1.打开系统升级APP或者从系统设置中的系统升级入口进入升级界面

2.进入系统升级界面后如有更新文件，则会进行提示，如没有，这会提醒你现在已经是最新系统

3.如有系统更新，则会提示你更新包的大小，点击正下方的立即下载，即可下载更新包，下载过程会提示你剩余时间

4.下载完毕后，点击重启更新即可进入升级界面完成系统升级（重启前记得备份重要资料以免资料丢失）


官方Recovery模式刷官方的zip卡刷包教程

以ZUK Z1为例进行的详细讲解，其他手机通用，个别细节略有不同。

此类刷机包是通过recovery刷入的，刷机包的命名方式一般为 “Z1_CN_OPEN_USER_L_ZUI_FullOTA.zip”,手机自带系统升级下载后安装的就是这种刷机包。此类升级分为差分（小升级）和完整包（大升级），差分包不会清除数据，完整包会清除各种数据，因此升级前最好保存一下重要资料。
刷入方式：
1.下载OTA卡刷包（一般为ZIP格式），将压缩包命名为update.zip，拷进手机内存

2.拷入手机内存后可以通过系统升级界面右上角的扩展栏进入recovery模式或者关机后同时按着整个音量键加电源键进入recovery界面

3.进入recovery模式后会提醒你选择语言模式，建议选取中文模式（英文也没啥压力），点击中文后选择“安装升级包”后点击确定即可进入升级界面，会有进度条提示

4.进度条走完后会提示系统升级成功，重启后进入新系统


官方工程模式下刷QSB格式刷机包教程

本教程适用于联想手机和zuk手机，有工程模式的手机才能使用工程模式卡刷。

以ZUK Z1为例进行的详细讲解，其他手机通用，个别细节略有不同。

这种刷机包是通过DROIDBOOT刷机的，简单方便，成功率高。提供刷机包是qsb格式，需要从官方给的压缩包（压缩包命名一般为：Z1_CN_OPEN_USER_****.zip）中解压。

刷机前请备份数据，以免数据丢失！

适用范围：

1.手机不可正常开机，但可进入工程模式（需使用OTG功能挂在外接U盘）

2.OTA无法正常升级时

刷机方法：

1.将官方提供压缩包进行解压缩，得到qsb格式刷机包

2.SD卡根目录下新建sdfuse文件夹（如有则清空里面内容），并将qsb格式刷机包拷进改文件夹内，手机关机

3.同时按住“音量-”键和电源键直至出现纯净的ZUK图标为止，即可进入工程模式

4.选择第三项项SD Update ，按电源键或屏幕上的Enter键确认。（音量键控制上下选择，电源键代表确认）

5.进入SD Update界面后即可看到之前拷进去的刷机包

6.点击START即可进行刷机

7.最后出现Update successful!!!表示刷机成功，点击REBOOT重启即可。


刷入第三方recovery的教程

下面是以ZUK Z1为例进行的详细讲解，其他手机通用，个别细节略有不同。
所需工具可能有所不同，但是原理是相同的，请自行到论坛查找自己手机适合的工具和软件。

刷入第三方rec的方法主要有三种：

一、Fastboot模式下刷rec（最常用方法）

二、高通QPST线刷rec

三、Recovery模式下刷入twrp的zip包和img镜像

一、Fastboot模式下刷rec（最常用方法）教程

手机在fastboot模式下链接电脑，电脑上驱动装好，在fastboot工具的目录运行命令行。fastboot模式下刷入rec的方法和命令主要是概括为两条命令：

fastboot flash recovery recovery.img

请注意：带下划线的这个部分替换成recovery.img文件的目录，如果在同一个目录就不用改。这个命令是把rec永久刷入手机。如果手机没有“真解锁”，这个命令是不能执行成功的。

fastboot boot recovery.img

请注意：带下划线的这个部分替换成recovery.img文件的目录，如果在同一个目录就不用改。这个命令是把rec临时刷入手机。如果手机没有“真解锁”，这个命令是不能执行成功的。

下面是本人制作的zuk z1一键刷入工具的教程，利用的就是这两个命令的原理。

1. 下载twrp的fastboot线刷包，解压

2.确保手机bootloader未锁，并且开启usb调试模式，授权调试

3.双击运行一键刷入recovery工具.bat文件，会出现命令行对话框，按任意键继续

4.确认现在手机的状态，开机状态就输入1，然后回车；如果你现在手机已经处于fastboot模式，那就输入2回车。

5.按照提示做好准备工作，（手机连点7下关于手机-版本号，就会打开开发者模式，再进开发者模式，打开USB调试）。将手机USB连接电脑，若手机出现授权，就选总是信任授权。

6.手机会重启进入fastboot模式，然后自动刷入rec，刷写完毕，手机会再次重启。

7.手机重启后会进入第三方rec模式。现在可以进行刷写第三方rom刷机包。

（注：手机如果没有解锁，手机会进不去rec，也可能最后可以进入rec，此时为临时rec。在临时rec界面可以刷入twrp等第三方rec卡刷包，以此刷入永久的rec，也可以在临时rec直接刷写第三方rom）

二、高通QPST线刷rec

1. 下载安装高通QPST线刷工具软件和驱动
2.下载twrp3.0.2的高通QPST线刷包，并解压。（此包只是zuk z1的，不适用于其他手机，其他手机没有的，可以自行制作）
3.打开QFIL软件，选择Browse按钮，找到线刷包解压后的路径，双击 prog_emmc_firehose_8974.mbn 文件

4.选择 Load XML 按钮，出现对话框双击 rawprogram-flash_rec.xml 文件，在跳出一个对话框，双击 patch0.xml 文件。到此步，Download 按钮都是灰色的，无法点击。

5.手机处于关机状态，按住音量上键，手机连接电脑，此时软件界面会显示，Qualcomm hs-usb qdloader 9008端口，同时Download 按钮显亮并且可以点击，赶紧点击 Download 按钮，QPST软件开始刷入rec。（注意刷机过程中，一定不要拔掉USB数据线）
6.至手机重启，软件界面如下，表示刷入完毕，可以拔掉USB线。现在手机中的rec就是twrp了，可以进入rec刷入第三方包。（注意在手机重启前，按住音量上下键，让手机重启直接进入第三方rec模式。否则，如果手机正常重启进入系统，官方系统会覆盖rec为官方的rec）

三、Recovery模式下刷入twrp的zip包和img镜像

（一）Recovery模式下卡刷twrp的zip包教程

1.下载zip格式卡刷包，存入手机内置内存

2.进入rec模式

方法（1）：关机状态下，同时按下音量上+音量下+电源键，直至进入rec模式；

方法（2）：也可以在开机状态下，开启usb调试模式，在命令行里输入adb reboot recovery，手机会自动重启进入rec模式。

2. 在rec模式界面选择 安装 按钮

3. 选择zip卡刷包

4. 滑动滑块刷入卡刷包

5. 刷入完毕，点主页键，回到主页，在选重启至rec模式。手机会自动重启然后进入rec模式

（二）Recovery模式下卡刷twrp的img镜像文件教程

1.下载img格式镜像文件，存入手机内置内存

2.进入rec模式

方法（1）：关机状态下，同时按下音量上+音量下+电源键，直至进入rec模式；

方法（2）：也可以在开机状态下，开启usb调试模式，在命令行里输入adb reboot recovery，手机会自动重启进入rec模式。

2. 在rec模式界面选择 安装 按钮

6. 点击 刷入img镜像 按钮，选择对应路径的img镜像文件

7. 选择刷入的目标分区，滑动滑块刷入镜像文件（一定不要选错分区！！！！）

8. 刷入完毕，点主页键，回到主页，在选重启至rec模式。手机会自动重启然后进入rec模式


第三方rec卡刷rom教程

以ZUK Z1手机的TWRP刷机为例进行详细讲解，其他手机通用，个别细节略有不同。

zip卡刷包就是我们最常用的一种刷机方式，zip的卡刷包有很广大的用途，可以给手机刷入系统，也可以刷写底层文件，各种分区文件，以及刷写supersu文件去root手机，还可以刷入ota或者update升级包，升级当前系统。

操作步骤：
 （1） 在社区和论坛下载为该型号手机制作的第三方zip刷机包，将刷机包存放到手机内。
 （2） 进入recovery模式。进入rec的方法一般是两种：

a.关机状态下，同时按下音量上+音量下+电源键，直至进入rec模式；

b.也可以在开机状态下，开启usb调试模式，使用adb命令，在命令行里输入adb reboot recovery，手机会自动重启进入rec模式。

（3） 刷机前一般进行双清（恢复出厂设置），这个看个人需求。若进行双清，则手机data内的数据会清空，请注意数据备份。在rec主界面选择清除，然后在清除界面滑动滑块，即执行双清。然后返回主界面。

（4） 安装刷机包，在主界面选择安装按钮。

（5） 到你存放zip刷机包的目录，然后点击该zip包。

（6） 进入安装确认界面，该页面显示了当前的刷机包的目录和文件名。滑动滑块就可以开始安装此刷机包了。

1-1-2
* zip刷机包签名校验：就是刷写zip包的时候，要验证签名，如果签名不通过就不能刷zip刷机包，一般作为第三方的rec，这个选项我们都不用，都是取消的。
* 完成后重启：顾名思义，刷完刷机包直接重启手机进入系统。
* 添加更多刷机包：可以选择一起刷入更多的刷机包，最多可以选择10个。
* 清除卡刷包队列：就是取消之前选择的卡刷包，返回到目录重新去选择zip卡刷包。
* 卡刷完毕后，会显示完成界面，返回按钮就是返回卡刷界面，重启就是重启手机进入系统。在这里要注意，如果手机系统没有root，重启前，会提示你是否要安装supersu，你可以选择root手机，也可以选择跳过（不root手机）。

（7） 刷机结束以后，可以选择返回继续操作，也可以选择重启，直接重启手机。


TWRP使用教程

 本教程只是针对twrp3.0.2（第三方rec）所做的教程，部分功能为略有不同，编译作者不同，添加功能也略有不同，请知晓！！
 下面是以ZUK Z1为例进行TWRP使用的详细讲解，其他手机通用，个别细节略有不同。教程图多，步骤详细，请仔细阅读。
twrp主界面：进入rec模式，过了twrp logo界面后默认进入此界面，这是整个twrp的主界面。twrp任务栏左侧默认显示cpu温度，中间显示当前时间，右侧显示手机电池剩余电量。

日志界面：通过在所有页面点击菜单按钮，就会在正常界面和日志界面之间切换。这个界面会把很多操作显示出来，方便用户掌握刷机情况。

选择存储位置：twrp有一个默认存储位置，这个位置决定着优先从这个位置选择刷机包，备份到这个位置，从这个位置还原，配置文件存到这个位置，截屏放到这个位置等等。通常情况下，rec默认存储位置为内置存储也就是内置sdcard。当手机插入了外置优盘等OTG存储设备时，可以选择将默认存储位置为usb-otg（外置U盘等存储设备）。如果没有otg设备，那么usb-otg是不能被选取的。

 rec模式下截屏：在twrp系统里，默认音量下+电源键为截屏键，这样，可以把rec状态下屏幕显示的信息保留下来。截屏存在的位置为默认存储位置，若没有挂载存储，那么就存放在/tmp目录下。在日志界面会显示保存地址和文件名。

可选不修改system分区：第一次进入twrp系统时，会跳出是否允许修改system分区的提示。如果保持只读，那么就无法刷入刷机包、无法修改系统分区文件等操作。保持system只读，只是为了在官方升级是能够保持正常升级，不至于因为自己私自修改系统文件，导致无法官方OTA升级。只有滑动滑块允许修改系统分区，才能正常的使用twrp的各种功能。

* 选择语言：可以选择进入系统后显示的文字的语言类型。
按键介绍：
按下实体home键或点击虚拟home按钮，或点击页面左上方上下箭头twrp logo按钮：主要是返回到主界面。
轻触右侧键或点击三角图标按钮：主要是返回上一层页面或者取消操作。
轻触左侧键或点菜单按钮：在普通界面和日志界面来回切换。
电源键：亮屏时，是锁屏锁定界面；熄屏时，是点亮屏幕。
音量键：单独使用没有作用。音量下键+电源键，可以截屏。
一．安装
 安装选项主要作用就是安装刷机包，主要包括，zip卡刷包和img镜像文件。默认处于选取zip卡刷界面，通过刷入img镜像按钮可以来回切换。

 （一）zip卡刷包就是我们最常用的一种刷机方式，zip的卡刷包有很广大的用途，可以给手机刷入系统，也可以刷写底层文件，各种分区文件，以及刷写supersu文件去root手机，还可以刷入ota或者update升级包，升级当前系统。
 安装zip的步骤：
 （1） 选取到你存放zip刷机包的目录，然后点击该zip包。

（2）进入安装界面，该页面显示了当前的刷机包的目录和文件名。滑动滑块就可以开始安装此刷机包了。

* zip刷机包签名校验：就是刷写zip包的时候，要验证签名，如果签名不通过就不能刷zip刷机包，一般作为第三方的rec，这个选项我们都不用，都是取消的。
* 完成后重启：顾名思义，刷完刷机包直接重启手机进入系统。
* 添加更多刷机包：可以选择一起刷入更多的刷机包，最多可以选择10个。
* 清除卡刷包队列：就是取消之前选择的卡刷包，返回到目录重新去选择zip卡刷包。
* 卡刷完毕后，会显示完成界面，返回按钮就是返回卡刷界面，重启就是重启手机进入系统。在这里要注意，如果手机系统没有root，重启前，会提示你是否要安装supersu，你可以选择root手机，也可以选择跳过（不root手机）。

 （二）img镜像文件主要就是手机各个分区的镜像，主要包含img、mbn和bin三种格式的文件。一般地，data、system、cache、splash等分区的镜像是img格式，tz、rpm、sdi、sbl1等分区都是mbn格式，modem分区是bin格式。
 安装镜像文件的步骤：
（1）在安装界面，点选 刷入image镜像 按钮，进入存放镜像文件的目录，点选需要刷入的镜像文件。

（2）进入选择目标分区界面，在这个界面选择你刚才选择的镜像文件对应的分区，然后滑动滑块开始刷入镜像文件。（这里需要非常注意的是，在选定分区时，一定要镜像文件和分区对应，否则可能导致手机成砖，若不知道对应关系，请不要乱刷。一定要选对分区。另，data分区的在恢复的时候是会清除内置储存的，请谨慎操作。）

二．清除
 清除选项主要作用就是清除手机数据、恢复出厂设置（双清、三清）、格式化手机分区和转换分区文件系统。所谓双清，就是清除data分区和cache分区，三清就是在双清基础上清除dalvik缓存。
 （一）点击清除选项默认进入是在双清界面。这里双清是不会清除内置内存的，所以内置内存卡数据都还在，滑动滑块直接开始手机双清。如下图：

* 高级清除选项按钮：可以进入高级清除界面。
* 格式化data分区：进入格式化data分区界面。
 （二）高级清除就是可以格式化一些分区和目录。在此界面，你可以勾选相应想要擦除或者格式化的分区。然后滑动滑块开始清除操作。

（三）格式化data分区界面，界面提醒格式化data会同时清除手机内置储存数据，先按yes，然后开始格式化data。（请谨慎操作，如没有必要，一定不要格式化data）

三．备份
 备份选项主要作用就是将手机各个分区的数据备份成文件形式保存起来，这些数据可以用于还原恢复。这里可以相当于Windows下的ghost软件，道理相同。
 进入备份的默认界面，可以选取需要备份的分区，然后滑动滑块开始备份。

* 备份名称，如果你不手动命名，他会自动生成一个以日期为编号的文件夹备份名，点击备份名称位置，可以进入重命名备份名称界面。
* 选择存储位置：就是备份在内置存储还是otg设备上。
* 刷新分区大小：就刷新所有分区使用的内存空间大小。

 点击上层 选项 按钮可以设置备份选项。

* 启动压缩：备份的时候是否压缩数据，如果启用压缩，可以减少备份文件的大小，但是会延长备份时间。一般不需要开启。
* 备份时跳过生成md5：意思很明了，就是备份的时候不生成md5，这样就会有一个后果就是，你恢复的时候就没有md5可以验证了，一般备份还原功能没问题的话就不用勾选这。
* 禁用剩余空间检测：每个分区都有自己剩余空间大小，选取这个会禁止检测剩余大小。为了确保数据不会溢出，一般也不勾选这个。

 点击上层 加密 按钮，可以设置进行加密备份。输入两次密码即可。点击 备份 按钮，滑动滑块即可开始备份。一般不用设置密码。

 下图是备份过程截屏：

下图是备份完成时截屏：

四．还原（恢复）
 还原选项主要作用就是将之前备份的数据还原到手机各个分区，只有之前备份过的数据才能还原。
 1.进入还原界面，会列出当前存储位置所有的备份数据。可以点选对应备份文件。

2.在跳出的还原详细情况界面，会显示这份备份所有已经备份的分区，你可以选择还原那些分区。

* 点击备份名称位置：会进入到重命名备份名称界面
* 启用md5校验备份文件：此选项会对去md5文件，校验备份，如果检验不通过，会提示失败。主要是确保备份的文件没有被修改或者损坏等。
* 删除备份文件：会进入删除备份文件界面。

 3.在删除备份界面，会显示删除的备份的名称，滑动滑块就可以开始删除此备份文件。

4.下图是删除备份完毕的截屏：

五．挂载
 挂载选项的主要作用就是将手机各个有文件系统的分区挂载出来，这样就可以操作相应分区和文件数据。挂载可以简单的理解为显示文件夹，取消挂载可以理解隐藏文件夹，当然挂载有很多强大的功能，这样说是不恰当的。
 进入挂载界面后，可以选择要挂载的分区。需要说明的是：data分区就包含内置存储和sdcard目录。usb-otg分区只要当出入otg设备时才能被选中，否者点选无效，无法挂载。外置优盘等设备挂载在/usb-otg目录下。

* 挂载system分区为只读：就是不修改system分区数据，保持只读状态。
* 选择储存位置：就是选择默认的储存位置，前面已经讲过，不赘述。
* 启用/停用mtp：启用mtp时，手机连接电脑，手机会将内置存储显示到电脑里，方便存取数据。同时，电脑端可以通过adb命令操控修改手机。停用mtp时，以上两项都会不行。

六．设置
 设置选项的主要作用就是设置rec状态的一些参数，主要包括常规、时区、屏幕、震动和语言。
 1.常规设置

* zip刷机包签名验证：就是刷写zip包的时候，要验证签名，如果签名不通过就不能刷zip刷机包，一般作为第三方的rec，这个选项我们都不用，都是取消的。
* 使用rm -rf命令代替格式化：意思就是用删除命令代替格式化分区，这个可以根据需要看是不是选择。
* 备份时跳过生成md5：意思很明了，就是备份的时候不生成md5，这样就会有一个后果就是，你恢复的时候就没有md5可以验证了，一般备份还原功能没问题的话就不用勾选这。
* 使用24小时制：就是中间时间显示为24制的时间。
* 反转底部按钮：就是返回键在右，不勾选时，返回键在左。
* 为测试主题进行模拟操作：就是如果勾选这个选项，所有操作就都是模拟操作，就不会真正去操作，是为了测试主题用的。此状态下，状态栏会变成红色。另外勾选这个还会出来一个模拟失败操作，就是模拟操作的结果是失败。
* 恢复默认设置，顾名思义，就是清除当前设置，恢复默认的配置。

 2.时区设置

* 就是选择时区用的，这个会决定当前系统时间。
* 时间偏差默认0就行了
* 夏令时，就是在标准时间的基础上加一个小时。
* 选择好设置，要点一下设置时区按钮才能生效。

 3.屏幕设置

* 启用屏幕超时：如果不启用，屏幕是一直亮屏的。启用之后有超时时间可以设置。
* 屏幕超时时间：就是在多少秒（最大值300）以后屏幕熄屏，并且锁屏。如果设置为0则是永不超时，意味着屏幕一直亮屏。
* 屏幕亮度：就是调节手机屏幕显示的亮度，是百分比形式。

 4.震动设置

* 按钮震动强度：就是屏幕上所有的按钮被按下时，手机震动一下，震动的强度就是设定的值。0为不震动，最大值300.
* 键盘震动强度：就是在有键盘显示时，按键盘时，手机震动的强度。0为不震动，最大值300.
* 操作震动强度：就是在进行滑动滑块和进行各种操作或者操作完成时，震动一下的强度。0为不震动，最大值300.

 5.语言设置

* 选择语言：列表列出一些gui显示的文本的语言，可以选择，原版有多个语言，且没有中文，作者删除了无用的其他外国语言，只留下简体中文和英语两种。
* 选择相应的语言后，需要点设置语言才能生效。
* 若进入twrp发现所有该显示字的地方都是空的，只剩下图形和按钮，那多半是这里语言设置出现问题。

七．高级
 高级选项的主要作用就是进行一些高级操作，如导出日志，修复context，sd卡分区，文件管理，终端命令，重载主题，adb线刷，root系统。

1.导出日志：将rec的日志导出到当前的的储存目录，一般是/sdcard目录，文件名为recovery.log。导出日志后，方便开发人员查找问题和bug。

2.修复context：安卓有一个SELinux安全机制，当出现问题是，可以使用这个选项进行修复。一般不需要使用这个功能，因为这个功能也不是很安全。

3.sd卡分区：对实体插入的sd卡进行分区操作。

4.文件管理：对现有的文件系统进行管理，主要就是对文件和文件夹进行复制，移动，删除，重命名，设置权限等操作。提供六种排序方式，名称升降序，时间升降序，大小升降序，可以根据需要点选相应按钮，以方便我们浏览和查找文件。

在文件管理器界面，点选具体文件就是选中文件，而点击右下角 对勾按钮 就是选中当前文件夹。选中后会跳出如下界面供操作。每个操作完成后，在日志界面都会有提示。

复制文件（夹）：点选按钮后，进入目标目录后，点 对勾按钮 会出现确认复制界面。滑动滑块进行复制操作。

移动文件（夹）：点选按钮后，进入目标目录后，点 对勾按钮 会出现确认移动界面。滑动滑块进行移动操作。

设置权限755：点选按钮后，会出现确认设置界面。滑动滑块进行设置权限操作。755的权限是一般系统目录下的系统可执行文件的权限。

设置权限：点选按钮后，会出现自定义权限界面。可以修改四位权限数字，点选右下角对勾按钮设置相应的权限。界面对四位数字权限进行了说明，方便理解和使用。

删除文件（夹）：点选按钮后，出现确认删除界面。滑动滑块删除选中的文件操作。

重命名文件（夹）：点选按钮后，进入重命名界面，修改新名称之后，点 对勾按钮 开始重命名操作。

5.终端命令：使用本地shell进行命令行操作和调试操作，如文件管理操作，分区挂载卸载，查看手机一些参数。。。总之会命令行是一件很强大的事。

6.重载主题：重载当前主题，因为多线程操作可能会导致不同步等一些问题，所以如果主题出现问题是，或许重载一下就可以了。

 7.adb线刷：使用adb sideload 命令通过adb线刷zip刷机包。使用方法就是：打开adb sideload线刷模式，将手机连接电脑，在电脑命令行输入adb sideload 卡刷包文件名.zip。然后会自动将电脑端的zip卡刷包复制到手机内，并开始安装此zip卡刷包。

8.root系统：通过安装SuperSU，使手机系统可以取得root权限。

八．重启
 重启选项的主要作用就是进行手机重启到什么状态的操作。主要有重启进入系统，关闭手机，重启进入rec模式，重启进入fastboot模式。twrp在重启选项中启用了root验证，即：他会在你每次点击重启时，验证手机是否已经root，如果没有，则会跳出root界面供你选择。

1.重启系统：重启之后进入系统，一般刷机完成后会进行此操作，不用手动按电源键了。adb命令是adb reboot。
 2.关闭手机：一般在刷机完毕后，可以选择关闭手机。另外，对于高通平台手机的高通线刷，因为要在关机的基础上才能操作，所以这个选项又有另一层意义：当手机进不了系统时，物理按键很难关机，但是如果此时还可以进入rec，那就可以利用rec的关机选项到达关机的效果，然后就可以进行高通线刷之类的操作。
 3.重启到rec模式：一般如果重刷了rec分区，那么就需要再次进入rec模式，使的刚刷入的rec生效。另外，一些问题可以通过重启rec解决。adb命令是adb reboot recovery
 4.重启到fastboot模式：使手机重启到fastboot模式，在fastboot模式下，可以刷写线刷文件，刷入boot分区，rec分区等等。adb命令是adb reboot bootloader
 5.重启到EDL模式：使手机重启到EDL模式即高通9008端口模式，一般高通平台的手机都有edl模式，在EDL模式下，可以进行高通QPST线刷rom或者救砖。adb命令是adb reboot edl
 6.重启到工程模式：使手机重启到工程模式，一般联想原厂的系统才有在工程模式，在工程模式下，可以刷写QSB卡刷包，可以进行恢复出厂设置，备份还原等操作。adb命令是adb reboot testmode


高通QPST线刷及救砖教程

本教程以联想大拍shot手机为例进行讲解，理论上支持所有高通平台手机。（新平台msm8996以上手机请看另一篇教程）
 线刷会将手机内所有数据都将清空，一定提前备份数据！请知晓！！
 刷机有风险，操作需谨慎，一定严格按照教程内容操作。
高通QPST软件下载地址：

434版带环境软件，链接: http://pan.baidu.com/s/1jIo9zAe 密码: kx5a

437版单安装包，链接: http://pan.baidu.com/s/1dE91TIh 密码:fwei
联想USB驱动下载地址：

链接: http://pan.baidu.com/s/1i46DS0X 密码: fmi5
高通HS-USB端口驱动下载地址：（9008端口驱动不识别的时候再下载安装本驱动）

链接:http://pan.baidu.com/s/1bpv9nFx 密码:5f58
adb和fastboot工具下载地址：

链接: http://pan.baidu.com/s/1dF0oAFR 密码: jjry

（其他手机工具和软件，请自行到手机社区或者论坛查找下载，本教程不负责提供）
运行环境和系统要求：
Win7 以上系统，32位和64位皆可（本帖演示win7 x64系统）
内存至少2GB以上，
安装联想USB驱动，
安装高通HS-USB驱动，
安装.net 4.0以上版本，
安装VC++运行环境
等等

不关心高通线刷的基本原理和知识的机油请跳过下面的这段文字：
 这里说的高通QPST线刷其实就是利用高通芯片自带的9008端口，将手机系统内的所有分区的镜像文件，直接刷写入手机。
 这个刷机方式比REC卡刷和fastboot线刷，更底层、高效、强大。这种方式，不需要进入手机的任何分区，就可以直接刷写手机固件。
 REC卡刷必须要手机能进入recovery模式，并且要是第三方rec才能随意刷zip卡刷包。
 Fastboot线刷要求手机能够进入fastboot模式，而且没有锁定bootloader，否则也无法刷入各种刷机包和分区镜像文件。
 而高通线刷可以刷写包括fastboot所在的bootloader分区、boot启动分区、recovery恢复分区在内的所有分区。甚至可以改写手机分区表。就算手机开不了机了，一样可以刷入，只要9008端口能连接就可以刷。这就是高通线刷既可以刷入系统又可以救砖的原理。
下面以高通QPST-2.7.437版本为基础进行讲解，新版的QFIL和老版本的在界面上可能略有不同，功能都一样，操作步骤基本一致，所以新版老版都一样，都可以刷机和救砖。
高通QPST线刷教程：
（软件安装过程中，如果出现询问驱动不安全，是否安装时，一定要点始终安装，每次碰到都点始终安装）
一、安装驱动软件
 手机只有保证能够被线刷软件识别才能进行线刷，这是大家都知道的。
1.安装联想USB驱动软件
 下载LenovoUsbDriver_autorun_1.0.16.exe文件，按照提示一步一步安装驱动，不详细讲解，很简单的。若之前安装过驱动，则可以跳过此步。
1-1
2.如果不识别9008端口，请下载安装高通驱动。默认安装，遇到安装驱动的，勾选始终信任安装！！
1-2
二、安装高通QPST工具软件和环境软件
1.下载高通QPST工具包，解压。点击setup进行安装。
2-1
2.出现安装VC++界面，点install开始安装VC++。
2-2
3.在出现的界面点击下一步。
2-3
2-4
4.开始安装，最后安装完成，点击完成。
2-5
2-6
5.如果以前安装过QPST，会出现下图，选repair QPST2.7。点击next（下一步），安装完毕后，关闭窗口即可。如果没有安装过QPST请看第6步。
2-7-1
6.如果以前没安装过QPST会跳出如下界面，点击next（下一步）。
2-7-0
7.在下面界面选择I Agree（我同意），点击next（下一步）。
2-7-0-1
8.在下面界面不用更改，默认就行，（如果要更改路径可以浏览，也可以在路径框内直接修改），点击next（下一步）。
2-7-0-2

9.在下面界面，点击next（下一步）。
2-7-0-3

10.软件开始安装。
2-7-0-4
11.安装完毕，点击close（关闭），退出界面。
2-7-0-5

三、下载高通QPST线刷包
 在社区下载高通QPST线刷包，解压到电脑硬盘。
 注意解压的文件路径（包括每一层的文件夹名）最好不要含有中文字符，一定不能有空格！！否则会导致刷机不成功！
3-1

四、配置刷机软件
1.打开开始菜单，所有程序》》QPST目录》》QFIL，运行线刷程序。
4-1
2.初始界面如下图，选择configuration，（老版本的不用操作的）
4-2
在弹出的小窗口中配置如下，若不勾选reset，则刷机完毕时，手机不会自动重启，需要手动重启。
4-2-1
3.在界面①选择Flat Bliuld，②选择Browse按钮，找到线刷包解压后的路径，然后③双击 prog_emmc_firehose_8936.mbn 文件（请找对应自己手机型号的那个文件）。
4-3
4-4

4.④选择 Load XML 按钮，出现对话框⑤双击 rawprogram-XXX.xml 文件，在跳出一个对话框，⑥双击 patch0.xml 文件。
4-5
4-6
4-7

到此步，主界面还没有端口号出现，Download 按钮也是灰色的，无法点击。
4-8

五、手机进入9008端口模式和开始刷机（按各自手机的方法操作）
1.手机进入高通9008端口的技巧是这样的，请严格按照说明操作，三种方法任选其一，如果手机黑砖，那就只能选择方法一：

（1）手动进入9008：拔出usb连接，手机完全关机，然后一直按住音量上键不松手（之后的操作，5.1系统和6.0系统略有不同）
 5.1系统：然后插入usb；
 6.0系统：然后插入usb的同时，按一下电源键，需要一定技巧；
（此时如果电脑上以前没有安装usb和高通9008驱动，那么现在电脑会开始安装驱动）
看软件界面如果出现9008端口，则说明安装驱动成功，手机已成功进入9008端口状态（此时手机是黑屏状态）；
设备管理器中也可以看到9008端口。
5-1
5-1-1
（2）adb命令进入：开机状态下，开启开发者模式（设置-关于手机-设备信息-点七次版本号开启），打开USB调试模式，将手机连接电脑，确保电脑上正确安装了驱动。
 下载解压adb和fastboot工具，按住shift键右击文件夹界面，选“在此处打开命令窗口”，
 在出现的命令行中，输入adb reboot edl（注意是EDL的小写），如果手机提醒授权，就点始终授权，
 手机就会自动重启到9008端口模式，此时软件界面如下图，手机为黑屏状态。
 （如果没有重启，说明是驱动没有安装好之类的问题）
5-2-1
5-2-2
5-1
（3）手机如果刷入了wzsx150编译的twrp，则可以在rec模式下，选择重启至EDL模式。
5-3

2.软件已经配置好的状态下，当手机一进入9008状态（软件界面显示9008端口）时，立刻马上点击download开始刷机。
5-4
5-5
3.当进度条走完，出现flash succeed，Finish Download表明手机刷写完毕。手机自动开机，可以拔出usb线。如果手机没有自动开机，那么就长按电源键手动重启手机。
5-6

若出现刷机失败，请检查：刷机包是否正确，文件是否正确，路径是否满足要求，9008驱动是否正确安装和运行（大部分错误都是这个原因导致的），软件配置是否正确。

若出现了9008端口，但是软件无法开始刷写而是报错的情况，请尝试：1.重启电脑，重启手机 ，2.换usb接口，usb数据线，3.管理员身份运行Qfile，4.操作快点，手机一进入9008就立刻操作，5.更换电脑多试几次。


高通QPST线刷及救砖教程（新机型）

本教程以zuk z2 pro手机为例进行讲解，理论上支持所有高通平台（msm8996以上的新平台）手机，刷机包中包含contexts.xml文件才能使用该方法。（旧平台的请参看另一个教程）

线刷会将手机内所有数据都将清空，一定提前备份数据！请知晓！！刷机有风险，操作需谨慎，一定严格按照教程内容操作。

注意本教程与ZUK Z2刷机教程有区别，请机油看清楚教程操作！

高通QPST软件下载地址：

434版带环境软件，链接: pan.baidu.com/s/1jIo9zAe 密码: kx5a（地址已更新）
437版单安装包，链接:pan.baidu.com/s/1dE91TIh 密码:fwei

ZUK USB驱动下载地址：

链接: pan.baidu.com/s/1i5HHxGT 密码: mgfh

高通HS-USB端口驱动下载地址：

链接:http://pan.baidu.com/s/1bpv9nFx 密码:5f58

ZUK的adb和fastboot工具下载地址：

链接: pan.baidu.com/s/1dF0oAFR 密码: jjry

其他手机工具和软件，请自行到手机社区或者论坛查找下载，本教程不负责提供

运行环境和系统要求：

Win7 以上系统，32位和64位皆可（本帖演示win7 x64系统）

内存至少2GB以上，

安装ZUK_USB驱动，

安装高通HS-USB驱动，

安装.net 4.0以上版本，

安装VC++运行环境

等等

不关心高通线刷的基本原理和知识的机油请跳过下面的这段文字：

这里说的高通QPST线刷其实就是利用高通芯片自带的9008端口，将手机系统内的所有分区的镜像文件，直接刷写入手机。

这个刷机方式比REC卡刷和fastboot线刷，更底层、高效、强大。这种方式，不需要进入手机的任何分区，就可以直接刷写手机固件。

REC卡刷必须要手机能进入recovery模式，并且要是第三方rec才能随意刷zip卡刷包。

Fastboot线刷要求手机能够进入fastboot模式，而且没有锁定bootloader，否则也无法刷入各种刷机包和分区镜像文件。

而高通线刷可以刷写包括fastboot所在的bootloader分区、boot启动分区、recovery恢复分区在内的所有分区。甚至可以改写手机分区表。就算手机开不了机了，一样可以刷入，只要9008端口能连接就可以刷。这就是高通线刷既可以刷入系统又可以救砖的原理。

高通QPST线刷教程：

（软件安装过程中，如果出现询问驱动不安全，是否安装时，一定要点始终安装，每次碰到都点始终安装）

一、安装驱动软件

手机只有保证能够被线刷软件识别才能进行线刷，这是大家都知道的。

1.安装ZUK USB驱动软件

下载ZUK_UsbDriver_1.0.5.zip文件，解压，安装驱动，不详细讲解，很简单的。

1-1

2.安装高通驱动，默认安装，遇到安装驱动的，勾选始终信任安装！！

1-2

二、安装高通QPST工具软件和环境软件

1.下载高通QPST工具包，解压。点击setup进行安装。

2-1

2.出现安装VC++界面，点install开始安装VC++。

2-2

3.在出现的界面点击下一步。

2-3

2-4

4.开始安装，最后安装完成，点击完成。

2-5

2-6

5.如果以前安装过QPST，会出现下图，选repair QPST2.7。点击next（下一步），安装完毕后，关闭窗口即可。如果没有安装过QPST请看第6步。

2-7-1

6.如果以前没安装过QPST会跳出如下界面，点击next（下一步）。

2-7-0

7.在下面界面选择I Aree（我同意），点击next（下一步）。

2-7-0-1

8.在下面界面不用更改，默认就行，（如果要更改路径可以浏览也可以在路径框内直接修改），点击next（下一步）。

2-7-0-2

9.在下面界面，点击next（下一步）。

2-7-0-3

10.软件开始安装。

2-7-0-4

11.安装完毕，点击close（关闭），退出界面。

2-7-0-5

三、下载高通QPST线刷包

在社区下载高通QPST线刷包，解压到电脑硬盘，注意解压的文件路径最好不要含有中文字符和空格。

3-1

四、配置刷机软件

1.打开开始菜单，所有程序》》QPST目录》》QFIL，运行线刷程序。

4-1
2.在主界面选择Meta Build，然后点击Configuration选项卡，打开配置窗口。

4-2
3.在配置窗口，选择UFS和No Validation选项，选定Reset（此为可选可不选，选择后，刷机完会重启手机，不选择刷机完手机不会重启，一般选上），按OK确定。
4-3

4.回主界面，点击Load Context按钮，找到线刷包解压后的路径，然后双击 contexts.xml 文件。

4-3

4-4

5.软件会自动读取和识别一些信息。到此步，主界面还没有端口号出现，Context Download 按钮也是灰色的，无法点击。

4-5

五、手机进入9008端口模式和开始刷机

1.手机进入高通9008端口的技巧是这样的，请严格按照说明操作，两种方法任选其一，如果手机黑砖，那就只能选择方法一：

（1）拔出usb连接，手机完全关机，然后一直按住音量上键不松手（点击Context Download按钮后再松开），此时，再按住电源键，0.5秒后（几乎是同时）将手机usb连接电脑。（此时如果电脑上以前没有安装usb和高通9008驱动，那么现在电脑会开始安装驱动），看软件界面如果出现9008端口，则说明安装驱动成功，手机也成功进入9008端口状态（此时手机是黑屏状态），设备管理器中也可以看到这个端口。

5-1

5-1-1

（2）开机状态下，开启开发者模式（设置-关于-点七次版本号开启），打开USB调试模式，将手机连接电脑，电脑会安装驱动，成功以后。

下载解压ZUK的adb和fastboot工具，按住shift键右击文件夹界面，选“在此处打开命令窗口”，在出现的命令行，输入adb reboot edl（注意是EDL的小写）（如果手机提醒授权，就点始终授权），手机就会自动重启到9008端口，软件界面如下图，手机是黑屏状态。（如果没有重启，说明是驱动没有安装好之类的问题）

5-2-1

5-2-2

5-2-3

2.软件已经配置好的状态下，当手机一进入9008状态（软件界面显示9008端口）时，立刻马上点击Context Download开始刷机，否则时间太长可能会提示错误，无法正常的进入刷机状态。

5-4

3.当进度条走完，出现Flash Succeed，Finish Download表明手机刷写完毕。可以拔出usb线。此时如果手机没有自动重启，那么就长按电源键手动重启手机。

5-5
5-6
若出现刷机失败，请检查：刷机包是否正确，文件是否正确，路径是否满足要求，9008驱动是否正确安装和运行（大部分错误都是这个原因导致的），软件配置是否正确。

如出现错误，那么要注意把configure设置里，选择UFS和0-No validation。出错也可能是由于操作太慢导致的，记住，一进入9008模式，立刻点Context Download。

针对出现了9008端口，但是软件无法开始刷写而是报错的情况，请尝试：1.重启电脑，重启手机 ，2.换usb接口，3.管理员身份运行Qfile，4.操作快点，手机一进入9008就立刻操作，5.尝试不同的姿势多试几次。


MiFlash线刷及救砖教程

 本教程以联想大拍shot手机为例进行讲解，理论上支持所有高通平台手机。
 MiFlash是小米开发的一款功能强大的刷机工具，他支持fastboot模式刷机，9008模式刷机和9006模式刷机，可以说他有部分的功能是和高通QPST线刷软件相同的，所以本教程和QPST线刷救砖教程基本是一致的。
 线刷会将手机内所有数据都将清空，一定提前备份数据！请知晓！！
 刷机有风险，操作需谨慎，一定严格按照教程内容操作。
MiFlash刷机软件下载地址：

链接: http://pan.baidu.com/s/1qYQsDp6 密码: wea5
联想USB驱动下载地址：

链接: http://pan.baidu.com/s/1i46DS0X 密码: fmi5
高通HS-USB端口驱动下载地址：（9008端口驱动不识别的时候再下载安装本驱动）

链接:http://pan.baidu.com/s/1bpv9nFx 密码:5f58
adb和fastboot工具下载地址：

链接: http://pan.baidu.com/s/1dF0oAFR 密码: jjry
（其他手机工具和软件，请自行到手机社区或者论坛查找下载，本教程不负责提供）
使用MiFlash线刷救砖教程：
（软件安装过程中，如果出现询问驱动不安全，是否安装时，一定要点始终安装，每次碰到都点始终安装）
一、安装驱动软件
 手机只有保证能够被线刷软件识别才能进行线刷，这是大家都知道的。
1.安装联想USB驱动软件
 下载LenovoUsbDriver_autorun_1.0.16.exe文件，按照提示一步一步安装驱动，不详细讲解，很简单的。若之前安装过驱动，则可以跳过此步。
1-1
2.如果不识别9008端口，请下载安装高通驱动。默认安装，遇到安装驱动的，勾选始终信任安装！！
1-2
二、安装MiFlash线刷工具
1.下载MiFlash线刷工具，解压。点击 miflash-MiPhone20151028.exe 进行安装。
2-1
2.出现安装界面，可以选择安装目录，点击下一步。
2-2
3.软件安装中
2-3
4.安装过程中出现 驱动安装提示时，一律选择始终安装。
2-4
5.安装完毕
2-5
三、下载官方线刷包
 在社区下载QPST线刷包，解压到电脑硬盘。
 注意解压的文件路径（包括每一层的文件夹名）最好不要含有中文字符，一定不能有空格！！否则会导致刷机不成功！
3-1
四、配置刷机软件
1.打开开始菜单，所有程序》》MiFlash，运行线刷程序。
4-1
2.初始界面如下图
4-2
3.在软件界面①选择浏览，②选择线刷包所在的目录，③确定
4-3
4-4
4.①点击倒三角的按钮，选择高级设置，②在Flash烧写器后面点浏览按钮
4-5
4-6
5.③双击 prog_emmc_firehose_8936.mbn 文件
4-7
6.④在Raw XML文件后面点浏览按钮，在弹出的窗口⑤双击 rawprogram-XXX.xml 文件
4-8
4-9
7.⑥Patch XML文件后面点浏览按钮，在弹出的窗口⑦双击 patch0.xml 文件
4-10
4-11
8.当确认图中三个框内的文件已经选择完毕后，⑧点击确定，保存设置。
4-12
9.到此配置完毕，回到主界面。

五、手机进入9008端口模式和开始刷机（请按各自手机方法进入）
1.手机进入高通9008端口的技巧是这样的，请严格按照说明操作，三种方法任选其一，如果手机黑砖，那就只能选择方法一：
（1）手动进入9008：拔出usb连接，手机完全关机，然后一直按住音量上键不松手（之后的操作，5.1系统和6.0系统略有不同）
 5.1系统：然后插入usb；
 6.0系统：然后插入usb的同时，按一下电源键，需要一定技巧；
（此时如果电脑上以前没有安装usb和高通9008驱动，那么现在电脑会开始安装驱动）
设备管理器中可以看到9008端口。则说明安装驱动成功，手机已成功进入9008端口状态（此时手机是黑屏状态）；
5-1
此时，在软件界面点击刷新，然后会出现端口，类似于COM+一个数字，和设备管理器9008对应的COM一样，此时表明软件已经识别端口。
5-1-1
（2）adb命令进入：开机状态下，开启开发者模式（设置-关于手机-设备信息-点七次版本号开启），打开USB调试模式，将手机连接电脑，确保电脑上正确安装了驱动。
 下载解压adb和fastboot工具，按住shift键右击文件夹界面，选“在此处打开命令窗口”，
 在出现的命令行中，输入adb reboot edl（注意是EDL的小写），如果手机提醒授权，就点始终授权，
 手机就会自动重启到9008端口模式。
 （如果没有重启，说明是驱动没有安装好之类的问题）
5-2-1
5-2-2
（3）手机如果刷入了wzsx150编译的twrp，则可以在rec模式下，选择重启至EDL模式。
5-3
2.软件已经配置好的状态下，点击软件界面的刷新，会出现一行COM的显示，此时①点击下方的 完全清除所有数据，②点击刷机按钮，开始刷机
5-4
手机开始刷写内容，时间在走，设备忙，内容在提示。若点刷机后，出现错误，则再点刷新，再点刷机重试，若依旧错误，请检查，9008驱动，可能需要卸载重装，检查刷机文件，检查配置等等。
5-5
3.当出现 操作成功完成 表明手机刷写完毕。此时手机依旧黑屏，需要长按电源键手动重启手机即可。到此刷机完毕。
5-6

 若出现刷机失败，请检查：刷机包是否正确，文件是否正确，路径是否满足要求，9008驱动是否正确安装和运行（大部分错误都是这个原因导致的），软件配置是否正确。
 若出现了9008端口，但是软件无法开始刷写而是报错的情况，请尝试：1.重启电脑，重启手机 ，2.换usb接口，usb数据线，3.管理员身份运行，4.操作快点，手机一进入9008就立刻操作，5.更换电脑多试几次。


MTK平台手机刷机教程

本教程适用于MTK平台手机，所需工具和软件请自行到网上论坛上搜索查找。

1.驱动安装。下载驱动文件，解压，然后选择驱动自动安装：

完成上一步，可直接到下一步软件包选择。以下为刷机时读取不到端口时手动安装教程：计算机右键，打开设备管理器，手机关机状态插入数据线。

2.以32位系统为例，双击打开端口，手动安装驱动

3.检查设备是否正确安装。

个别电脑由于驱动签名问题需要关闭驱动签名，百度即可。（64位系统安装下面那个）驱动安装时需等待，选择始终安装程序，若安装失败，检查是不是驱动签名问题，可关闭驱动签名。

4.打开工具，开始升级，可选择语言为中文

5.点击右侧配置文件，选择升级软件包(包需解压)注意看文件名，必要时可以选择两次

6.在下拉选项中选择“固件升级”或“下载”，其他选项不要选

7.点击下载按钮，手机，关机状态，插上数据线，（必要时可以按音量键，个别手机不用电池也可）

8.出现红色滚动条时说明连接成功

9.当出现黄色滚动条开始走，并且达到100时即升级完成，升级过程中耐心等待，中途不要断电。

10.拔数据线，重新插拔下电池，开机。首次开机需要更新系统，耐心等待3到5分钟，中途不要动手机，以防断电。

11.手机开机，测试没问题时，关机重启，再正常使用。

升级常见错误分析

1、刷机过了红条，到了紫色条卡住。（错误代码4008）

这种情况出现的话，大家可以把电池拿下来，然后重新安装上，进入REC后选择关机。然后重新刷。

2、驱动安装好了，一点刷机就弹出错误提示。

这种情况一般是USB口的供电问题，使用PC后面的USB插口，或者拔掉几个用电量大的设备。

3、正常操/作情况下，和步骤2出现的问题提示不一样的。（典型的3013问题，出现率最高的）

这个问题就是大家经常问的，出现这个问题基本上都是因为大家升级到了4.1.2然后想刷回4.0.4的情况，大家使用4.1.2刷机时候用的SP_Flash_Tool重新刷4.0.4即可，或者用甲鱼官方4.1.2的SP_Flash_Tool。

MTK 手机线刷错误信息汇总和解决办法

【1022 错误】：刷机软件版本和手机不匹配、或者 USB 接口不好用

【解决办法】先换个 USB 端口刷，：不行的话建议去下载个最新刷机软件试试去！

【1040 错误】：S_UNSUPPORTED_OPERATION 刷机引导文件 Scatter.txt 不匹配

【解决办法】：下载适合你的机器的线刷 ROM，很明显这个山寨机会遇到！比如机器是双核 6577，但是下载的刷机 ROM 是单核 6575 的所以会报错

【2005 错误】：S_BROM_CMD_STARTCMD_FAIL

【解决办法】：实际是没有加载好刷机包的文件导致的，重新打开刷机软件，继续线刷即可！

【3002 错误】：没有勾选下图的地方，刷机完毕，会提示【>TOOL DL image Fail！=>uboot is blocking by dl info】

【解决办法】记得按下图的选项勾选，重新线刷一次即可！这样就不会开机卡屏了。

【3144 错误】 S_DA_EMMC_FLASH_NOT_FOUND：

【解决办法】：刷机引导文件 Scatter.txt 不匹配，请换一个对的线刷包！主要常见于 EMMC 分区机型和 MTD 分区机器的引导 TXT 不能混用！

【4004 错误】：驱动问题

【解决办法】：先试试安装 MTP 驱动，不行就卸载驱动后再重新安装驱动识别或者重装电脑

【4032 错误】：操作手法问题

【解决办法】：在红色进度条完成之后，请立刻按下音量下键（减少音量的那个键），即可触发后续的刷机用的黄色进度条。刷机过程最好有装电池一起刷。具体可以参考联想 S920 板块置顶的教程贴，里面有更加详细的操作！

【4050 错误】：S_FT_NEED_DOWNLOAD_ALL_FAIL；单刷 recovery 常见的错误。因为目标 ROM文件和手机的系统差距大无法单刷。

【解决办法】：把 recovery.img 文件，替换进原厂线刷包里面，按下面的截图勾选，然后线刷，这样

就进度条就会走了。如果还不行就完整的线刷一次

【5066 错误】 S_DL_PC_BL_INVALID_GFH_FILE_INFOR：

【解决办法】：导入刷机引导文件 txt 错误，检查是否导入的是刷机用的 txt 文件！重新操作一次！

【8038 错误】：SP FLASH TOOL ERROR，具体原因不知

【解决办法】：1、遇到这个的提示，那么，你必须只能点击刷机软件的“fireware-upgrade”或者“固件-升级”’按钮进行刷机！完整的线刷一次。2、也可能是刷机软件的版本不适合手机

【8100 错误】：can not find usb port！这是刷机驱动没有完全识别/安装好的提示，请从新安装驱动或者换端口换电脑系统为 XP 等等

【解决办法】：请重新安装驱动并关机来识别出来，建议换电脑，换台式机等等

【8200 错误】：原因是手机系统和刷机包的系统不同一个芯片平台

【解决办法】：方法一：重新找 ROM，你的 ROM 是不对的！比如机器是 6575，刷机包是 6577 所以就会报这样的错。

方法二：更新最新版的刷机软件


MOTO手机RSD工具刷机教程

本教程适用于MOTO手机，各个型号可能略有不同，所需工具和软件请自行到网上论坛上搜索查找。

1、下载刷机包、刷机工具，驱动。
2、安装RSD刷机工具
 2.1、先安装驱动
 2.2、安装RSDLite6.2.4刷机工具
 2.3、解压底包
3、刷机
 3.1、手机关机状态，按住音量减 + 电源键 三秒后松开。进入bootloader模式、接上数据线。
 3.2、打开刷机工具RSDLite, 到刚才解压的目录选择刷机脚本、完成后自动重启。


root手机教程

教程作者：Sunny

【前言】

现在国内手机厂商搭载的手机系统一般的都是经过自家优化定制的本地化安卓系统，在功能、权限管理、用户交互等方面都做了本地化处理（比如优秀的VIBEUI），让我们使用起来也就更加的顺手了。但是对于ROOT这件事，一般玩机的小伙伴都会去做。因为安卓现在虽然今非昔比，ROOT、刷机的需求已经缩小很多，但对于高级玩家来说，ROOT却可以让自己以最高权限管理手机、可以让自己体验到很多需要ROOT才能玩的大型游戏、可以更高级的搞机。

但是也正因为安卓的不断升级，在安全防御级别上也越来越高，导致我们ROOT手机越来越难。作为优秀搞机族的我们来说，怎么可能忍。

今天就让Sunny给大家带来【Sun玩机教程】，带你Root带你飞。
【Sun玩机教程开始】

准备待Root的手机，教程通用，理论安卓版本越低的手机越容易被Root。
 目前主流的Root方法主要有两种：一键Root和卡刷Root包方式，今天我们主要围绕这两种方式进行讲解。
（一）【一键Root方式】：这种Root方式比较简单快捷，但缺点是并不能很好支持所有手机。
 目前市场上有很多一键Root软件，Root方案基本大同小异，个人推荐“KingRoot、360 Root”这两款软件（下方附下载地址）。因为这两款软件综合来言，Root能力较强，更新较快，可以更好的支持新的安卓版本，同时支持手机端操作。
① 下载以上Root软件，然后安装打开。

② 将手机开发者选项中的USB调试打开并且连接电脑，点击一键Root软件上的“一键Root”开始进行一键Root。
③ Root过程会需要一些时间，请耐心等待。

④ 如果手机Root成功，那么恭喜您Root成功。如果Root失败，请看看我们的第二种【卡刷Root包方式】吧，这种Root只有手机有第三方recovery，98%的手机都能深度Root成功。

（二）【卡刷Root包方式】：手机刷入第三方recovery，一般对应机型都有详细刷入recovery的教程。
① 下载SuperSu卡刷包，下方附SuperSU-v2.76-CHS.zip专业版以及官方下载地址，将附件复制到手机存储根目录。
② 手机重启到recovery模式，点击[安装]。

③ 选择SuperSu卡刷包。

④ 确认刷入。

⑤ 刷完成入并点击[重启手机]。

⑥ 看到桌面的SuperSu耀眼的图标没？看到就代表你已经成功将手机Root啦！

（三）【第三方rec自带root方式】：手机刷入第三方recovery，一般对应机型都有详细刷入recovery的教程。

利用twrp自带的root方式进行root，一般在刷机完成后，重启系统前，twrp会自动检测系统是否root。若没有root，会提醒是否安装supersu，即是否root。滑动滑块，则就是进行root手机操作。（此方法不一定适用于6.0以上系统，还要看twrp编译者是否加入6.0系统的root。）

★【KingRoot】下载地址（exe为电脑版，apk为手机版）：

http://pan.baidu.com/s/1c1HDnry
★【360 Root】下载地址（exe为电脑版，apk为手机版）：

http://pan.baidu.com/s/1ge3tXsB
★【SuperSU-v2.76-CHS.zip专业版】卡刷包下载地址：

http://pan.baidu.com/s/1geZib55
★【SuperSU】官方下载下载地址：

download.chainfire.eu/964/SuperSU